Vous êtes sur la page 1sur 11

Travail Demandé 

:
1) Créer les tables suivantes :
a- ARTICLES

Nom du champ Type de champ Taille Format Clé

Ref Texte 10 Primaire

Design Texte 50

Qstock Numérique Entier (2 octets) 999

Prix_U Numérique Réel (4 octets) 99 999,99

TVA Numérique Réel (4 octets) 99,99

Entier (4 octets) 999 999 999


Secondaire
Num_Inv Numérique (avec doublant)

b- Famille-Art :

Nom du champ Type de champ Taille Format Clé

Code_Fam Numérique Entier (4 octets) 999 999 999 Primaire

Nom_Fam Texte 50

2) Faire la saisie de 10 enregistrements au moins


3) Exécuter le Bouton RAD pour générer l’application Modèle
4) Construire les fenêtres suivantes :
A- Menu
B- Table Articles (donner l’opération (code source) de chaque Bouton)

C- Fiche Articles (Ecran de Saisie)

5) Compléter la Base de Données par les tables décrites dans la page 1


Code des Boutons : FENETRE : Table Articles
a) Nouveau (Ajout) :
b) Modif = Faux
// Création d'un nouvel enregistrement
HRAZ(ARTICLES)
// Ouverture de la fiche du fichier articles en mode création
Ouvre(Fiche_Article)
// Rafraichissement de la table
TableAffiche(Table_ART,taCourantPremier)

c) Modifier:

1èreMéthode
SI TableSelect(Table_ART)>0 ALORS
Ouvre(Fiche_Article)
SINON
Info("Selectionner un Article S.V.P")
RETOUR
FIN
d) TableAffiche(Table_ART,taCourantBandeau)
e)
f)
g) 2èmeMéthode
SI TableSelect(Table_ART)=-1 ALORS
Info("Selectionner un Article S.V.P")
RETOUR
SiNon
Modif = Vrai
ID_A = Table_ART.Ref // ID_A (Identifiant Article) est une variable mémoire
Ouvre(Fiche_Article)
Fin
TableAffiche(Table_ART,taCourantBandeau)

c) Supprimer:
// Une ligne est-elle sélectionnée ?
SI TableSelect(Table_ART) = -1 ALORS
Info("Selectionner un Article S.V.P")
RETOUR
Fin

Si OuiNon("Êtes-vous sûr de vouloir supprimer l'enregistrement ?")= vrai ALORS


// Suppression de l'enregistrement articles à partir de la table
HSupprime(ARTICLES)
FIN
// Positionnement sur l'enregistrement courant
TableAffiche(Table_ART, taCourantPremier)

d) Imprimer:
iAperçu(iapZoom100)
e) iImprimeEtat(Etat_Produits)
FENETRE : FICHE Articles


Description du Combo (liste déroulante):

Code du Combo :
Code Initialisation de la fiche:

1ère Méthode
FichierVersEcran(Fiche_Article,ARTICLES)
MaFenêtre..ValeurRenvoyée = Faux

2ème Méthode
SI Modif = Faux ALORS
titre = "Nouveau Article"
SINON
titre = "Modification d'un Article"
HLitRecherchePremier(ARTICLES,Ref,Id_A)
SI HTrouve(ARTICLES) ALORS
FichierVersEcran()
FIN
// Sauvegarde de la valeur de champ de saisie dans un autre champ de saisie pour voir si la donnée existe ou non
Sai_Ref1 = Sai_Ref
FIN
MaFenêtre..ValeurRenvoyée = Faux

a) Bouton Valider (Enregistrer) :

1ère Méthode
EcranVersFichier(Fiche_Article,ARTICLES)
SI ARTICLES..NouvelEnregistrement=Vrai ALORS
HAjoute(ARTICLES)
SINON
HModifie(ARTICLES)
FIN
MaFenêtre..ValeurRenvoyée=Vrai
Ferme()

2ème Méthode
// Contrôle de Saisie
SI Sai_Ref="" ALORS
Erreur("Saisir la Référence de l'Article SVP")
RepriseSaisie(Sai_Ref)
FIN

…………………..etc
SI Combo_Famille<=0 ALORS
Info("la Famille manque")
RETOUR
FIN
SI Modif=Faux ALORS // On l'ajoute
EcranVersFichier()
HAjoute(ARTICLES)
SINON // On le modifie...
HLitRecherchePremier(ARTICLES,Ref,Id_A)
SI HTrouve(ARTICLES) ALORS
EcranVersFichier()
HModifie(ARTICLES)
FIN
FIN
MaFenêtre..ValeurRenvoyée=Vrai
Ferme()

b) Bouton Annuler :
c) MaFenêtre..ValeurRenvoyée=Faux
Ferme()

d) Sortie du Champ_Saisie : Sai_Ref


SI Modif=Faux ALORS
SI Sai_Ref = "" ALORS RETOUR
SI Sai_Ref <> "" ALORS
HLitRecherchePremier(ARTICLES,Ref,Sai_Ref)
SI HTrouve(ARTICLES) ALORS
Info("Cet Article existe déjà")
BTN_valide..Etat=Grisé
RepriseSaisie(Sai_Ref)
SINON
BTN_valide..Etat=Actif
FIN
FIN
SINON
SI Sai_Ref<>Sai_Ref1 ALORS
HLitRecherchePremier(ARTICLES,Ref,Sai_Ref)
SI HTrouve(ARTICLES) ALORS
Info("Cet Article existe déjà")
BTN_valide..Etat=Grisé
RepriseSaisie(Sai_Ref)
SINON
BTN_valide..Etat=Actif
FIN
FIN
FIN
REQUETE:REQ_ART (Cette requête permet d’obtenir les données de la table physique dans la table logique Table_Art)
FENETRE : TABLE Articles

❶ Table logique « Table_Art » Affiche la liste des Articles


Code de la fenêtre TABLE Articles

6) Ajouter à la base de données les tables suivantes :


7) Ajouter l’association de type père-père (1-N, 1-N) entre la table ACHAT et la table ARTICLE comme suit :
8) Construire les fenêtres suivantes :
A) Fenêtre ACHAT :

B) Fenêtre Fiche_Achat:

Vous aimerez peut-être aussi