Vous êtes sur la page 1sur 32

Pr.

Benaceur OUTTAJ

1
Chapitre 3

2
• Insérer la bonne formule dans la cellule B2 sachant que ta TVA est de 20%
• Copier la formule dans les autres cellules C2 et D2
• S’assurer de la bonne copie (exactitude de la formule)
3
Section 1

4
 Au lieu d’utiliser des formules complexes et/ou
de les appliquer à un grand nombre de données,
on remplace ces formules par des fonctions pré-
installées (par analogie avec les fonctions
mathématiques)
 Exemple :
 f(x;y;z;t)=x²+2yt-z on construit une fonction f qu’on
applique aux paramètres x;y;z et t
 N.B : le nombre de paramètres d’une fonction
Excel peut être variable (selon l’usage ou non
des paramètres optionnels)

5
Opérateurs

Références de cellules Plage de données


Fonctions
Opérandes
6
Il s’agit d’insérer une fonction dans une formule

Ou

7
Deux étapes à respecter :
1. Choix de la fonction (à chercher dans la liste des
fonctions disponibles)
2. Choix des paramètres en tenant compte des
paramètres obligatoires et des paramètres
optionnels et en respectant la syntaxe

N.B : la syntaxe d’écriture d’une fonction Excel est


l’ensemble des règles d’écriture de la fonction et
l’ordre de placement des paramètres.
8
 Tableau de notes de 4 matières d’une classe de 10
élèves
1. Calculer la moyenne de la classe pour chaque matière
2. La plus petite note de la classe dans chaque matière
3. La note la plus grande de la classe dans chaque
matière
4. L’écart type entre les notes de chaque matière
5. La plus grande note dans toutes les matières
 Pondérer chaque matière par un coefficient et refaire
le travail

9
Nom Note1 Note2 Note3 Note4
AAA 4 7 13 12
Insérer les fonctions BBB 7 8 14 11
convenables CCC 9 12 11 10
DDD 9 8 10 9
EEE 9 5 7 6
FFF 9 10 11 10
GGG 11 9 9 10
HHH 15 14 16 13
JJJ 12 11 14 12
KKK 10 9 8 9
Moy
Min
Max
E-Type 10
 SI (test; action1; action2)
 Test : expression logique dont le test peut
prendre la valeur vrai ou faux
 action1 : traitement ou valeur à retourner si le
test est vrai
 action2 : traitement ou valeur à retourner si le
test est faux

11
 Matricielles
 Déterminant d’une matrice DETERMAT
 Produit de deux matrices PRODUITMAT
 Inverse d’une matrice INVERSEMAT
N.B : pour les résultats de type matrice, la
validation des formules doit être faite
avec la touche Ctrl+Maj+Entrée

12
 Si la note < 10 afficher Echec
 Sinon (c’est-à-dire la note >=10) afficher Réussite
 =SI(B2>=10;"Reussite";"Echec")
 Remarque : la négation de note<10 est note>=10
Cas imbriqué : il s’agit de détailler le cas où la note
est >=10 pour distinguer 2 sous-cas :
 Si note >=12 afficher Mention
 Sinon afficher Passable
=SI(B2<10;"AJ";SI(B2>=12;"MENTION";"PASSABLE"))
13
Cas avancé : (plusieurs imbrications)
Afficher la mention associée à chaque note (en copiant la formule)
Données de test
Note mention
Guide des évaluations
4
Note Mention
7
Entre [0 et 5 [ Non validé
9
Entre [5 et 10 [ Rattrapage 9
Entre [10 et 12 [ Passable 9
Entre [12 et 14[ Assez-bien 9
Entre [14 et 16[ Bien 11
Entre [16 et 18[ Très Bien 15
Entre [18 et 20] Excellent 16
19 14
Section 2

15
• Saisissez la formule =B3+B3*0,2 dans C3 et copier cette formule dans
les autres cellules C4 et C5.
•Que constater ?
16
• Refaire le travail avec C3 =B3+B3*B8 et copier la dans les autres
cellules C4 et C5.
•Analysez ce qui change lors de la copie
• Corriger le problème en fixant B8 comme référence absolue
• Fixez uniquement la référence de la ligne ou bien de la colonne
17
• Renverser le tableau et saisir la formule dans B2=B1*(1+B4) et copier la
dans les autres cellules C2 et D2.
•Analysez ce qui change lors de la copie
• Que faut il fixer dans B4, la référence de la ligne ou bien de la colonne?

18
-une référence absolue ne change pas quand on la copie dans
une formule
-on fixe la référence absolue en insérant le symbole $ devant
l'indice de la colonne et de la ligne
- on peut, selon les cas, fixer uniquement l'indice de la colonne
ou celui de la ligne :
Application : Changer la disposition des données
(verticalement vers horizontalement)

19
 Afin de tenir à jour un compte bancaire, on se
propose d'utiliser un tableur.
 Les différentes opérations sont mises dans
un tableau
 A raison d'une opération par ligne, avec leur
date et leur montant.
 En B17 , plaçons le libellé "solde débiteur" si
C17>D17
 ou "solde créditeur", dans le cas contraire

 Procédez ensuite à une mise en page


 Syntaxe :
 =RECHERCHEV(cellule_lue ; tableau ; numéro_de_colonne;param4)
 recherche dans le tableau la valeur de la cellule_lue et renvoie la
valeur trouvée dans le cellule qui a le même numéro_de_colonne.
 Param4 prend 2 valeurs :
 Vrai si on cherche approximativement cellule_lue
 Ou bien faux si on cherche exactement cellule_lue
 Tester la fonction recherchev sur ce tableau
=RECHERCHEV(38;A2:C10;3)
référence designation PU
2 banane 11,80 MAD
3 pomme de terre 3,95 MAD
4 tomate 4,90 MAD

entrez le code 4
le nomdu produit est : tomate
 Feuille de calcul produits
référence designation PU
2 banane 11,80 MAD
3 pomme de terre 3,95 MAD Recherchev
4 tomate 4,90 MAD
 Feuille de calcul facture
reference designation PU quantite prix total
2 5
3 10
4 20

Total 0,00 MAD

Saisir uniquement la référence et la quantité pour déterminer les autres


cellules Désignation, Prix unitaire et Montant
 le 4ème argument de la fonction recherchev
 RECHERCHEV(valeur_cherchée;tableau;no_col, [valeur_proche])
 Si l’argument valeur_proche est VRAI ou omis, une donnée exacte
ou proche est renvoyée. Si aucune valeur exacte n’est trouvée, la
valeur immédiatement inférieure à valeur_cherchée est renvoyée.
 Si l’argument valeur_proche est FAUX, RECHERCHEV recherche
exclusivement une correspondance exacte.
 Syntaxe :
 =RECHERCHEH(cellule_lue ; tableau ; numéro_de_ligne;param4)
 recherche dans le tableau la valeur de la cellule_lue et renvoie la
valeur trouvée dans le cellule qui a le même numéro_de_ligne.
 Param4 prend 2 valeurs :
 Vrai si on cherche approximativement cellule_lue
 Ou bien faux si on cherche exactement cellule_lue
 Reprendre l’exemple précédent et transposer
les données (permuter les lignes en colonnes)

28
 Dans deux feuilles de calcul séparées, utilisez
la fonction recherchev pour calculer le
montant de la facture à partir du références
des produits (fichier recherchev.xls).
 sélectionner les références $A$1:$F$4 dans le
tableau et définir un nom PRODUITS pour ces
références (menu Formules)
 J1=Terme à rechercher
 J2=Description trouvée (ligne 2 du tableau)
 J3=Quantité trouvée (ligne 3 du tableau)
 J4=Prix trouvé (ligne 4 du tableau)

 J2=RECHERCHEH($J$1;PRODUITS;2;FAUX)
 Faire de même pour J3 et J4

 FAUX indique que l’on cherche exactement


cette expression
 Tester
=SIERREUR(RECHERCHEH($J$1;PRODUITS;
2;FAUX);"Inconnu")
En saisissant des codes erronés

Vous aimerez peut-être aussi