Vous êtes sur la page 1sur 4

ALGORITHMIQUE - EXERCICES CORRIGES

Exercice n1 Donner un logigramme correspondant lalgorithme suivant : Algorithme fonction calculPriRectangle (longueur : rel, largeur : rel) : rel dbut lire(longueur,largeur) primtre<-2*(longueur+largeur) retourne primtre fin Exercice n2 2 1 2 1) Calculer le produit des matrices suivant : 0 7 3 2) Ecrire un algorithme qui ralise ce produit. 5 3

Exercice n3 Dfinir une procdure maximum qui prend une liste de 10 lments en argument et retourne le plus grand de la liste. Exemple : maximum(1 4 2 0 36 0,5 12 17 6 23) = 36 Exercice n4 n est un entier naturel et i une variable initialise la valeur 0. Quel est leffet de linstruction suivante : tant que ( i 2 n ) faire i i + 1 fin tant que ?
Donner la valeur de la variable i aprs lexcution de cette instruction. Excuter la main cette instruction pour n = 7 et n = 9 .
Exercice n5 Ecrire un algorithme ou un organigramme permettant de rsoudre une quation du second degr dans .

Page 1/4

jgcuaz@hotmail.com

ALGORITHMIQUE - EXERCICES CORRIGES CORRECTION


Exercice 1 Un logigramme correspondant lalgorithme peut-tre :

Commentaires : Dans la syntaxe du logigramme : L'ellipse reprsente un vnement qui intervient automatiquement dans le procd Le rectangle reprsente une action Exercice 2 1) On calcule : 2 1 2 5 2 2 + 1 3 2 5 + 1 3 2 2 + 3 10 + 3 = = 3 0 2 + 7 3 0 5 + 7 3 21 7 3 0 7 3 2) Un algorithme qui ralise ce produit peut-tre : Algorithme Variable : matrice=tableau(4) fonction calculproduitmatrice(a : matrice , b : matrice) : matrice dbut Variable : i entier Pour i variant de 1 4 lire a(i) Pour i variant de 1 4 lire b(i) calculproduitmatrice(1)<-a(1)*b(1)+a(2)*b(3) calculproduitmatrice(2)<-a(1)*b(2)+a(2)*b(4) calculproduitmatrice(3)<-a(3)*b(1)+a(4)*b(3) calculproduitmatrice(4)<-a(3)*b(2)+a(4)*b(4) Pour i variant de 1 4 retourne calculproduitmatrice(i) fin Exercice 3 Variable : liste=tableau(10) procedure maximum(a : liste) : rel dbut Variable : i entier , M : rel Pour i variant de 1 10 lire a(i) M<-a(1) Pour i variant de 2 10 si a(i)>M alors M<-a(i) retourne M fin
Page 2/4 jgcuaz@hotmail.com

Exercice n4 Linstruction tant que ( i 2 n ) faire i i + 1 fin tant que aura pour effet de retourner le plus petit entier
suprieur ou gal la racine carre de n. En langage mathmatique, la valeur de la variable i aprs lexcution de cette instruction est :

i=E

( n ) +1

o E dsigne la fonction partie entire.

Pour n=7 : i=0 puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 1


puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 3 puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 2

Puisque ( i 2 n ) est faux, on sarrte l, et on retourne i = 3 Pour n=9 : i=0 puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 1 puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 2 puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 3 puisque ( i 2 n ) on calcule i i + 1 , cest--dire i = 4 Puisque ( i 2 n ) est faux, on sarrte l, et on retourne i = 4 Exercice n5 Algorithme : Rentrer les coefficients a,b et c de lquation ax 2 + bx + c = 0 Si a 0 alors Debut Si d b 2 4ac Si d<0 alors debut si afficher lquation nadmet pas de solution relle fin si Si d = 0 alors debut si u b / 2 a afficher la solution est afficher u fin si Si d > 0 alors debut si

u b d / 2 a

( ) v ( b + d ) / 2 a

afficher les solutions sont afficher u afficher v fin si Fin Si Sinon afficher ce nest pas une quation du second degr Organigramme : Remarque : Ceci nest quun exemple, variable selon la syntaxe et les normes typographiques..
Page 3/4 jgcuaz@hotmail.com

Page 4/4

jgcuaz@hotmail.com