Vous êtes sur la page 1sur 8

Corrigé de L’examen d’algorithmique du second semestre (Vague 1):

Exercice 1 :

Écrire un algorithme permettant de calculer et d’afficher la valeur de S en prenant 50 termes de


la suite, sachant que X = -5 :

1 2 3
𝑆=1− + 2 − 3 +⋯
𝑋 + 1 2𝑋 + 2 3𝑋 + 3

Réponse :

Début
Réel X, S
Entier 𝑖
𝑋 ← −5

Pour 𝑖 variant de 1 à 49 avec un pas égal à 1 faire


𝑆 ← 𝑆 + 𝑖 ∗ (−1) ∗∗ 𝑖 ⁄(𝑖 ∗ 𝑋 ∗∗ 𝑖 + 𝑖)

FinPour
Écrire S
Fin
Exercice 2 :

Soit le vecteur réel T, contenant 100 valeurs de température. Écrire l’algorithme et


l’organigramme permettant de calculer la moyenne MOY et le produit P des températures
supérieures strictement à 45°C et de compter leur nombre Isup45, ainsi que celui des
températures égales à 45°C, I45.

Afficher les résultats.

Réponse :

Algo

Début
Réel, T(100), MOY, P, SOM
Entier i, Isup45, I45
Lire (T(i), i=1, 100)
SOM ← 0
P←1
Isup45 ← 0
I45 ← 0
Pour i variant de 1 à 100 avec un pas égal à 1 faire
Si (T(i) > 45) alors
SOM ← SOM + T(i)
P ← P * T(i)
Isup45 ← Isup45 + 1
Sinon
Si (T(i) = 45) alors
I45 ← I45 + 1
FinSi
FinSi
FinPour
𝑀𝑂𝑌 ← 𝑀𝑂𝑌⁄𝐼𝑠𝑢𝑝45

Écrire MOY, Ispu45, I45, P


Fin
Organigramme :
Début
Lire (T(i), i=1, 100)
SOM ← 0
P←1
Isup45 ← 0
I45 ← 0
i←1
T(i) > 45
T(i) = 45 SOM ← SOM + T(i)
I45 ← I45 + 1 P ← P * T(i)
Isup45 ← Isup45 + 1
i←i+1
i ≤ 100
𝑀𝑂𝑌 ← 𝑀𝑂𝑌⁄𝐼𝑠𝑢𝑝45

Écrire MOY, Ispu45, I45, P


Fin
Exercice 3 :

Soient deux matrices réelles A(N,M) et B(N,M). Écrire l’algorithme et l’organigramme


permettant de calculer et d’afficher la somme et le produit des carrés des éléments de ces deux
matrices.

Réponse :

Début

Réel A(100,100), B(100,100), SOM(100,100), P(100,100)

Entier i, j, N, M

Lire N, M

Lire ((A(i,j), j=1, M), i=1, N)

Lire ((B(i,j), j=1, M), i=1, N)

Pour i variant de 1 à N avec un pas égal à un faire

Pour j variant de 1 à M avec un pas égal à un faire

SOM(i,j) ← A(i,j)**2 + B(i,j)**2

P(i,j) ← A(i,j)**2 * B(i,j)**2

FinPour

FinPour

Écrire ((A(i,j), j=1, M), i=1, N)

Écrire ((B(i,j), j=1, M), i=1, N)

Fin
Organigramme:

Début

Lire N, M

Lire ((A(i,j), j=1, M), i=1, N)

Lire ((B(i,j), j=1, M), i=1, N)

i←1

j←1

SOM(i,j) ← A(i,j)**2 + B(i,j)**2

P(i,j) ← A(i,j)**2 * B(i,j)**2

j←𝑗+1
j≤ 𝑀
i←i+1
i≤𝑁
Écrire ((A(i,j), j=1, M), i=1, N)

Écrire ((B(i,j), j=1, M), i=1, N)

Fin
Corrigé de L’examen d’algorithmique du second semestre (vague 2) :
Exercice 1 :

Écrire un algorithme permettant de calculer et d’afficher la valeur de R en prenant 80 termes de


la suite, sachant que Y = -8 :

1 2 3
𝑅 = 1− + − +⋯
𝑌 + 1 2𝑌 2 + 1 3+1
2 3𝑌 3

Réponse :

Algo :

Début
Réel Y, R
Entier 𝑖
𝑌 ← −8

Pour 𝑖 variant de 1 à 79 avec un pas égal à 1 faire


𝑅 ← 𝑅 + 𝑖 ∗ (−1) ∗∗ 𝑖 ⁄(𝑖 ∗ 𝑌 ∗∗ 𝑖 + (1⁄𝑖 ))

FinPour
Écrire R
Fin
Exercice 2 :

Soit le vecteur réel P, contenant 150 valeurs de pression. Écrire l’algorithme et l’organigramme
permettant de calculer la moyenne MOY et le produit Prod des pressions inférieures strictement
à 20 bars et de compter leur nombre Iinf20, ainsi que celui des pressions égales à 20, I20.

Afficher les résultats.

Réponse :

Début
Réel, P(100), MOY, Prod, SOM
Entier i, Iinf20, I20
Lire (P(i), i=1, 150)
SOM ← 0
P𝑟𝑜𝑑 ← 1
Iinf20 ← 0
I20 ← 0
Pour i variant de 1 à 150 avec un pas égal à 1 faire
Si (P(i) < 20) alors
SOM ← SOM + P(i)
Prod ← Prod * P(i)
Iinf20 ← Iinf20 + 1
Sinon
Si (P(i) = 20) alors
I20 ← I20 + 1
FinSi
FinSi
FinPour
𝑀𝑂𝑌 ← 𝑀𝑂𝑌⁄𝐼𝑖𝑛𝑓20

Écrire MOY, Iinf20, I20, Prod


Fin
Organigramme :
Début
Lire (P(i), i=1, 150)
SOM ← 0
Prod ← 1
Iinf20 ← 0
I20 ← 0
i←1
P(i) < 20
P(i) = 20 SOM ← SOM + P(i)
I20 ← I20 + 1 Prod ← Prod * P(i)
Iinf20 ← Iinf20 + 1
i←i+1
i ≤ 100
𝑀𝑂𝑌 ← 𝑀𝑂𝑌⁄𝐼𝑖𝑛𝑓20

Écrire MOY, Iinf20, I20, Prod


Fin
Exercice 3 :

Soient deux matrices réelles C(N,M) et D(N,M). Écrire l’algorithme et l’organigramme


permettant de calculer et d’afficher la somme et le produit des inverses des éléments de ces deux
matrices (On suppose qu’elles ne contiennent pas d’éléments nuls).

Réponse :

Début

Réel C(100,100), D(100,100), SOM(100,100), P(100,100)

Entier i, j, N, M

Lire N, M

Lire ((A(i,j), j=1, M), i=1, N)

Lire ((B(i,j), j=1, M), i=1, N)

Pour i variant de 1 à N avec un pas égal à un faire

Pour j variant de 1 à M avec un pas égal à un faire

SOM(i,j) ← 1/C(i,j) + 1/D(i,j)

P(i,j) ← 1/C(i,j) * 1/D(i,j)

FinPour

FinPour

Écrire ((SOM(i,j), j=1, M), i=1, N)

Écrire ((P(i,j), j=1, M), i=1, N)

Fin
Organigramme:

Début

Lire N, M

Lire ((C(i,j), j=1, M), i=1, N)

Lire ((D(i,j), j=1, M), i=1, N)

i←1

j←1

SOM(i,j) ← 1/C(i,j) + 1/D(i,j)

P(i,j) ← 1/C(i,j) * 1/D(i,j)

j←𝑗+1
j≤ 𝑀
i←i+1
i≤𝑁
Écrire ((SOM(i,j), j=1, M), i=1, N)

Écrire ((P(i,j), j=1, M), i=1, N)

Fin

Vous aimerez peut-être aussi