Vous êtes sur la page 1sur 49

VG COMMANDS

lsvg Display all VGs lsvg -o Display all active VGs lsvg rootvg Display info about rootvg lsvg -l rootvg Display info about all LVs in rootvg lsvg -o | lsvg -il Display info about all LVs in all VGs lsvg -p rootvg Display info about all PVs in rootvg mkvg -y'datavg' hdisk1 Create VG with name datavg on hdisk1 with partition size 128MB reducevg -df datavg hdisk1 Remove VG datavg mkvg -s 8 hdisk1 Create VG with name vgxx on hdisk1 with partition size 8MB mkvg -s 8 -y sivg hdisk1 Create VG with name sivg on hdisk1 with partition size 8MB mkvg -s 4 -t 2 -y sivg hdisk1 Create sivg on hdisk1 with PP size 4 and no of partions 2 * 1016 chvg -a y newvg To cuase VG newvg automatically activated at startup chvg -a n newvg To deactivate the automatic activation at startup chvg -t 2 newvg To change maximum no. of PP to 2032 on vg newvg chvg -Q n newvg To disable quorum on VG newvg reorgvg newvg Reorganises PP allocation of VG newvg extendvg newvg hdisk3 hdisk4 Add PV hdisk3 and hdisk4 to VG newvg extendvg '-f' 'rootvg' 'hdisk1' Add PV hdisk1 by force to rootvg exportvg newvg Exports the VG newvg importvg -V 44 -y newvg hdisk2 Import the hdisk2 with name newvg, and assign major number 44 redcucevg newvg hdisk3 Remove PV hdisk3 from VG newvg varyoffvg newvg To deactviate VG newvg varyonvg newvg To activate VG newvg syncvg -v sivg To sync the mirrored LV in the VG sivg mirrorvg -S -m sivg hdisk2 To mirror LVs of sivg with hdisk2 (-m for exact mirror, -S forbackground mirror) unmirrorvg sivg hdisk2 To remove the mirrored PV from the set. To remove or replace physical volumes in a volume group for maintenance purposes, use SMIT or the chpv command. # reducevg <VGname> <PVname> # rmdev -dl hdisk<n> Replace the disk... # cfgmgr -v # lspv # chdev -l hdisk<n> -a pv=yes # extendvg <VGname> <hdisk<n> Mirroring rootvg If you do not mirror the root volume group, you have a single point of failure. Always mirror rootvg! I have seen too many unnecessary system rebuilds because rootvg was not mirrored. Mirroring rootvg is a straightforward process and consists of the following steps, in which we are going to mirror rootvg to a new disk called hdisk1: 1. Add hdisk1 to the rootvg for mirroring: # extendvg rootvg hdisk1

2. Use this command if all the rootvg logical volumes were created properly: # mirrorvg rootvg 3. Or (if a problem was encountered) manually mirror rootvg and do not mirror the dump device (lv00 in example): # lsvg # lsvg -l rootvg # lsvg rootvg 4. Mirror each logical volume: # for N in $(lsvg -l rootvg | grep syncd | awk '{print $1}' | grep -v lv00) > do > echo $N > mklvcopy $N 2 > done 5. Sync the volume group: # syncvg -v rootvg # lsvg -l rootvg 6. Configure the boot devices: # ipl_varyon -i PVNAME BOOT DEVICE PVID VOLUME GROUP ID hdisk0 NO 00001047375ac230 000010472822f021 hdisk1 YES 000010472822e532 000010472822f021 # bosboot -a -d /dev/hdisk0 bosboot: Boot image is 6955 512 byte blocks. # ipl_varyon -i PVNAME BOOT DEVICE PVID VOLUME GROUP ID hdisk0 YES 00001047375ac230 000010472822f021 hdisk1 YES 000010472822e532 000010472822f021 # chvg -a'y' -Q'n' -x'n' rootvg # bootlist -m normal -o hdisk1 # bootlist -m normal hdisk0 hdisk1 # bootlist -m normal -o hdisk0 hdisk1 # lsvg rootvg | grep -i QUORUM OPEN LVs: 14 QUORUM: 1 The mirrorvg command does all of the mklvcopy commands under the covers for you. Since disk quorum was disabled, we must reboot the system for the changes to take effect. # shutdown -r now

FS COMMANDS
lsfs lsfs -q Lists all filesystems in the /etc/filesystems entry List all filesystems with detailed info

lsfs -a To list all filesystems (default) lsfs -l Specify the output in list format lsfs -c Specify the output in column format lsfs -v jfs Lists all jfs filesystems chfs -a size=24576 /si Change size of FS /si to 24576 x 512 bytes blocks (12 MB) chfs -a size=+24576 /si Add 24576 x 512 byte blocks to FS /si chfs -a size='+1024M' /usr Add 1GB space to FS /usr chfs -m /si /bi Change the mount point from /si to /bi chfs -A /si To auto mount the filesystem si chfs -d account /si Remove account attribute of /si. ( from /etc/filesystems file) chfs -a splitcopy=/backup -a copy=2 /oracle This will mount the 2nd copy of mirrored filesystem oracle to /backup in read-only mode crfs -v jfs -g testvg -a size=64465 -m /siju Creates FS /siju of type jfs in VG testvg of blocksize 64465 crfs -v jfs -g datavg -a size=10M -m /oracle Creates FS /orzcle of type jfs in VG datavg of 10MB crfs -v jfs -d /dev/lv00 -m /siju Create FS /siju of type jfs on device /dev/lv00 rmfs /siju Deletes FS /siju and associated LV rmfs -r /siju Deletes FS /siju its mount point and associated LV defragfs /sifs To defragment the file system /sifs defragfs -q /sifs Display the current defrag status of the file system fsck -y n /dev/lv00 To fsck the filesystem associated to /dev/lv00 assuming response "yes" fsck -p /dev/lv00 To restore superblock from backup superblock

PV COMMANDS
lspv hdisk0 Display status and characteristics of the PV lspv -p hdisk0 Display PP usage of hdisk0 lspv -l hdisk0 To list all logical volumes on PV hdisk0 chpv -v r hdisk1 Close the PV (Used while removing PV without varyon) chpv -v a hdisk1 Open the PV chpv -c hdisk0 Clear the master boot record on PV hdisk0 migratepv hdisk1 hdisk2 To move PPs from PV hdisk1 to hdisk2 migratepv -l silv hdisk1 hdisk2 To migrate LV silv from PV hdisk1 to hdisk2

LV COMMANDS
lslv -l lv00 Display info about LV by PV lslv -p hdisk1 Display LV allocation map for hdisk1 chlv -t copy lv00 To change the lv00 to copy type chlv n silv lv00 To rename lv00 to silv chlv -p r lv00 To change the lv00 to readonly mode rmlv silv To remove silv rmlv -f silv To remove silv without user intervention mklv -s n -c 3 silv hdisk1 To make LV silv with three copies on hdisk1 extendlv silv 5 To extend the LV silv with 5 LPs mklvcopy -s n lvsi 2 hdisk1 To mirror LV lvsi on same PV with 2 copies mklvcopy lvsi 3 hdisk1 hdisk2 To mirror LV lvsi on PV hdisk1 and hdisk2 with 3 copies rmlvcopy lvsi 2 hdisk1 Will remove one copy of LV lsvi from hdisk1

mklv -t jfslog -y log00 newvg 2 To create a jfslog with name log00 on VG newvg with 2LPs logform /dev/log00 To format jfslog volume log00

BLV COMMANDS
bootlist -m normal -o To see the boot sequence in normal mode bootlist -m service -o To see the boot sequence in service mode bootlist -m normal cd0 hdisk0 To change boot sequence to cd0,hdisk0 in normal mode bootlist -m service cd0 rmt0 hdisk0 To change boot sequence to cd0,rmt0,hdisk0 in service mode bosboot -ad /dev/hdisk1 To create boot image on PV hdisk1 mkboot -cd /dev/hdisk1 To clear the boot image bootinfo -b Specifies the bootable disk bootinfo - t Specifies the type of boot 1 Disk boot 3 CD-ROM boot 4 Tape boot 5 Network boot bootinfo -e Check the machine can boot from tape bootinfo -T To see the machine hardware type bootinfo -s hdisk0 To see the size of hdisk0 bootinfo -r To see the size of memory in KB bootinfo k To see the key position (1 Secure, 2 Service, 3 Normal) bootinfo m To see the machine model code bootinfo o hdisk0 To list the location code of hdisk0 bootinfo z To see the machine is MP capable (0 Not Capable, 1 Capable) bootinfo p To find out if the machine can run 64-bit kernel (Returns the string "32", if executed on a machine that is only capable of running the 32-bit kernel. The command returns "chrp", if the machine is capable of running the 64-bit kernel or the 32-bit kernel) bootinfo K or prtconf k To find out the currently enabled kernel mode (Returns "32" if the 32-bit kernel is enabled, and "64" if the 64-bit kernel is enabled.) bootinfo -y command will identify the type of system hardware you have, either 32-bit or 64-bit. If the command returns a 32, you cannot use the 64-bit kernel. # prtconf -k Kernel Type: 32-bit To find out if 64 bit extensions are loaded: $ lslpp -l bos.64bit If 32-bit: lslpp: 0504-132 Fileset bos.64bit not installed. On AIX 4.3.3 , If 64-bit: Fileset Level State Description ---------------------------------------------------------------------------Path: /usr/lib/objrepos bos.64bit 4.3.3.78 COMMITTED Base Operating System 64 bit Runtime

On AIX 5.1 , If 64-bit: Fileset Level State Description ---------------------------------------------------------------------------Path: /usr/lib/objrepos bos.64bit 5.1.0.35 COMMITTED Base Operating System 64 bit Runtime To find out if OS is 32b-it or 64-bit : $ locale64 If 32-bit: exec(): 0509-036 Cannot load program locale64 because of the following errors: 0509-032 Cannot run a 64-bit program on a 32-bit machine. If 64-bit: LANG=en_US LC_COLLATE="en_US" LC_CTYPE="en_US" LC_MONETARY="en_US" LC_NUMERIC="en_US" LC_TIME="en_US" LC_MESSAGES="en_US" LC_ALL= To find out if kernel is 32-bit or 64-bit: $ ls -l /unix If 32-bit: lrwxrwxrwx 1 root lrwxrwxrwx 1 root If 64-bit: rwxrwxrwx 1 root system 21 Mar 25 2002 /unix@ -> /usr/lib/boot/unix_mp* system 21 Jul 10 16:48 /unix -> /usr/lib/boot/unix_up system 21 Jun 04 2002 /unix@ -> /usr/lib/boot/unix_64*

For AIX 5.2 64-bit: To find out if hardware if 32-bit or 64-bit : $ getconf HARDWARE_BITMODE 64 ( If hardware is 64 bit) To find out if kernel is 32-bit or 64-bit: Command: getconf KERNEL_BITMODE 64 (If Kernel is booted in 64 bit mode) To find out if Oracle is 32-bit or 64-bit use: $ ORACLE_HOME/bin> file oracle If 32-bit : oracle: If 64-bit : executable (RISC System/6000) or object module not stripped

oracle:

64-bit AIX executable or object module not stripped

How to Change Kernel Mode of IBM AIX 5L (5.1) for more information.

There are three kernels available in the /usr/lib/boot directory: unix_up 32-bit kernel for uniprocessor systems unix_mp 32-bit kernel for multiprocessor systems unix_64 64-bit kernel for 64-bit processor systems
The following example provides the commands to run to enable the 64-bit kernel after system installation:
# ln -sf /usr/lib/boot/unix_64 /unix # ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix # bosboot -ad /dev/ipldevice # shutdown -r

After the system has rebooted, it will be running the 64-bit kernel. To reactivate the 32-bit kernel, follow the same procedure, substituting unix_up or unix_mp for unix_64, depending on your system type.

PAGE SPACE COMMANDS


lsps -a lsps hd6 chps -s'10' hd6 chps -d'10' hd6 To list out all paging spaces To display the details of the paging space hd6 To increase the size of paging space hd6 by 10 LPs To decrease size of paging space hd6 by 10 LPs This (-d10) will perform the following steps shrinkps: Temporary paging space paging00 created. shrinkps: Dump device moved to temporary paging space. shrinkps: New boot image created with temporary paging space. shrinkps: Paging space hd6 removed. shrinkps: Paging space hd6 recreated with new size. shrinkps: New boot image created with resized paging space. shrinkps: Resized and original paging space characteristics differ, check the lslv command output. To turn on the paging space paging00 To turn off the paging space paging00 To increase the size of the paging space in 4 LP blocks To create a paging space on VG sivg of 4 LP size (-s4) and activate it immediately (-n) and activate it at every restarts To remove the paging space paging00 To invoke all entries in /etc/swapspaces file To make available swap space paging00 To deactivate paging space paging00 Shell script that chps -d executes to shrink paging space Takes a snapshot of virtual memory usage. Part of the perfagent.tools fileset IBMs top/monitor clone Reports virtual memory statistics System Activity Report Status of inodes Removes any currently unused modules in kernel or library memory Displays the current status of processes

chps -a y paging00 chps -a n paging00 chps -s4 paging00 mkps -a -n -s4 sivg rmps paging00 swapon -a swapon /dev/paging00 swapoff /dev/paging00 shrinkps svmon topas vmstat sar istat slibclean ps

Adding a swap space (512MB as hd6) Replacing existing paging00 with hd6 # mklv -y'hd6' -t'paging' rootvg 16 hdisk0 (16PP x 32 as PP size = 512MB) hd6 # lsps -a Page Space Physical Volume Volume Group Size %Used Active Auto Type paging00 hdisk0 rootvg 512MB 1 yes yes lv hd6 hdisk0 rootvg 512MB 0 no no lv # chps -a y hd6 # Makes an entry in /etc/swapspaces (Means auto - yes)

# swapon -a # Activates swap spaces as per /etc/swapspaces 0517-075 swapon: Paging device /dev/paging00 is already active. swapon: Paging device /dev/hd6 activated. # swapoff /dev/paging00 # Removes an entry in /etc/swapspaces (Means auto - no)

# chps -a n paging00 # Dctivates swap spaces as per /etc/swapspaces # lsps -a Page Space Physical Volume Volume Group Size %Used Active Auto Type paging00 hdisk0 rootvg 512MB 0 no no lv hd6 hdisk0 rootvg 512MB 1 yes yes lv # sysdumpdev -P -p /dev/hd6 primary /dev/hd6 secondary /dev/sysdumpnull copy directory /var/adm/ras forced copy flag TRUE always allow dump FALSE dump compression ON # rmps paging00 # lsps -a Page Space Physical Volume Volume Group Size %Used Active Auto Type hd6 hdisk0 rootvg 512MB 1 yes yes lv #

SYSTEM DUMP COMMANDS


sysdumpdev -l To list the current dump destination sysdumpdev -L List the details of the previous dump sysdumpstart -p Starts dump in the primary dump device sysdumpstart -s Starts dump in the secondary dump device sysdumpdev -p /dev/lv00 To make lv00 as primary dump device sysdumpdev -P -p /dev/lv00 To make lv00 as primary dump device permanently sysdumpdev -s /dev/rmt0 To make rmt0 as secondary dump device sysdumpdev -z To determine a new system dump occurred

Device related commands


cfgmgr To configure devices and installs device software in system cfgmgr -l vscsi0 To configure the components connected to the vscsi0 interface lscfg To display config, diagnostics and vital product definition info lscfg -l mem0 Display info about device mem0 lscfg -l ent* Display info about all Ethernet cards lscfg -v Display vpd lscfg -v -l hdisk0 Display vpd of hdisk0 lscfg -vp |grep -e "Memory DIMM" -e "Size" DIMMs Details mkdev -l rmt0 To change device rmt0 from defined state to available state lsdev -P To lists all supported devices lsdev -P -c disk To list all supported disks lsdev -P -r class To display supported class lsdev -P -r subclass To display all sub class lsdev -C To lists all configured devices lsdev -Cc if To display existing network interfaces lsdev -C -l mem0 To display the properties of mem0 chdev -l sys0 -a maxproc=100 To change default maxproc value to 100 chdev -l rmt0 -a blocksize=512 To change the block size to 512 chdev -l rmt0 -a ret=no To avoid tape retension rmdev -l rmt0 To remove the device rmt0 rmdev -d -l rmt0 To remove the device totally from database rmdev -l rmt0 -S To change the state of the device stopped lsparent -C -k rs232 To display possible parent devices which accept rs232 devices lsparent -C -l hdisk0 To display parent devices which accept child device hdisk0 lsattr -Dl rmt0 To see the default values of the device rmt0 lsattr -El rmt0 To see the current values of the device rmt0 lsattr -El tty0 -a login -R To see all possible values of the login attribute of tty0 lsconn -p scsi0 To list all possible connection scsi0 can accept lvlstmajor To list the available major numbers mknod /dev/null c 2 2 Create null device with major (2) and minor (2) nos. (c - char device)

Console emulation commands


lscons To list the current console lscons -b To list the console at next boot chcons /dev/tty3 To change the console to tty3 chcons -a login=enable /dev/tty3 Redirect console to tty3 and provide login prompt swcons /dev/tty3 To change system console to tty3 temporarily alog -L -t console To see the current attributes of log type console alog -t console -o To see the console messages alog -t boot -o To see the boot time messages

Installation specific commands


lslpp -l To see the details of installed file sets

lslpp -ha bos.net.* To list the installation history of all file set in bos.net packages lslpp -f bos.rte To list the files in the bos.rte package lslpp -w /etc/hosts To list the file set which contain /etc/hosts file lslpp -p bos.net.nfs.server To list the pre requisites for bos.net.nfs.server file set installp -L -d /dev/rmt0.1 To list the installable products on the device rmt0 installp -aX -d /dev/rmt0.1 bos.net To install all filesets within bos.net and expands file system if it requires installp -u bos.net To remove bos.net installp -r To reject the applied software installp -c -f <product> To commit the <product> installp -C To cleanup an incomplete installation lppchk v To check package inconsistency. (No output for consistency) lppchk -c <product> To check the <product> instfix -k IX9999 -d /dev/rmt0.1 To install the file set associated with fix IX9999 from rmt0 instfix -ik IX9999 To verify fix IX9999 installed smit install Base install panel smit install_latest Selective install panel smit install_all Install ALL products bffcreate -qv -d <media> -f <disk-path> Copy maint to disk installp -qa -d <media-path> -X all APPLY updates installp -rB -X all REJECT updates installp -c -g -X all COMMIT updates Installp -u <fileset> DEINSTALL a fileset installp -C <fileset> CLEAN UP failed install

Network related commands


host 193.9.200.1 Resolves ip to host name (from /etc/hosts file) host ibm Resolve ibm to ip address (from /etc/hosts file) hostname ibm To change the host name to ibm entstat en0 To the status of ethernet device en0 entstat -d en0 To list the detailed status of device en0 no -a To list all net configurable attributes and their values no -d thewall To change thewall parameter to its default value no -o ipforwarding=1 To make the machine as router in tcpip networks traceroute ibm To trace the route to ibm ping ibm To tcp ping to the machine ibm ifconfig -a To show the status of all network interfaces ifconfig en0 To show the status of en0 ifconfig en0 up Turns on network card en0 ifconfig en0 down Turns off network card en0 ifconfig en0 detach Removes en0 card from the network interface list ifconfig en0 inet 194.35.52.1 netmask 255.255.255.0 up Configure en0 starts immediately ifconfig en0 alias 195.60.60.1 Create alias ip address for en0 route add 0 192.100.13.7 To make 192.100.13.7 as default gateway for entire network route add 192.100.12.0 192.100.13.7 To make 13.7 as gateway for 12.0 network route -f To clear the gateway table

chdev -l inet0 -a hostname=si To change the host name to si permanently netstat -a To show the state of all sockets netstat -c To show the network buffers cache netstat -D To show the net drops of packets netstat -i To display interface statistics netstat -r To show the routing table netstat -rn To show routing table (ip will be given instead of host names) netstat -s To show the statistics of the protocols netstat -s -p < tcp/udp/ipv6> To show the statistics of respective protocols

Space usage commands


du -k du -l du -s df -i df -k To list number of bytes in 1k blocks To list number of bytes in 512 bytes blocks To list only the total disk usage in the current directory To display no of free and used inodes To display diskspace in 1024 bytes format

Backup commands
mksysb -i -X /dev/rmt0 Creates image.data and system backup (-X expands /tmp if required) mksysb -m /dev/rmt0 Creates image.data file with map file and system backup mksysb -e /dev/rmt0 Creates system data but excludes the files listed in /etc/exclude.rootvg mkszfile Creates /image.data file mkcd -d /dev/cd1 Creates system boot backup to the CD-R device /dev/cd1 mkcd -d /dev/cd1 -v vg00 Creates backup of vg vg00 to CD-R device /dev/cd1 mkcd -d /dev/cd1 -G Creates generic boot backup savevg -i -f /dev/rmt0 vg00 Creates vg00.data image file and backup vg vg00 savevg -ef /dev/rmt0 vg00 Creates vg00 backup but excludes files listed in the /etc/exclude.vg00 find / -print | backup -ivf /dev/rmt0 Backup entire system to rmt0 backup -0vf /dev/rmt0 /home Backup /home directory to rmt0 with backup level 0 restore -Tvf /dev/rmt0 List the archive in rmt0 restore -xvf /dev/rmt0 /home Restore /home from archive in device rmt0 find ./home -print |cpio -ocvumB > /dev/rmt0 Archives /home directory cpio -icvdumB < /dev/rmt0 Restores cpio archive from rmt0 cpio -ivt < /dev/rmt0 List the contents of cpio archive from rmt0 cpio -icvd < /dev/rmt0 /homeRestores /home directory from rmt0 tar -cvf /dev/rmt0 /home Archives /home to rmt0 device tar -tvf /dev/rmt0 List the archives in rmt0 tar -xvf /dev/rmt0 /home Extract /home from rmt0 dd if=si of=si1 conv=ebcdic Convert and copy ascii file si to ebcdic si1 dd if=/dev/rmt0 ibs=512 obs=1024 of=/dev/rmt1 To copy blocks from rmt0 with 512 blocks to rmt1 with 1024 blocks tctl -f /dev/rmt0 rewind To rewind the tape tctl -f /dev/rmt0 offline To eject the tape tctl -f /dev/rmt0 status To show the status of tape

chdev -l rmt0 -a block_size=512

To change the block size of the tape to 512

When using variable block size, the dd command can be employed with an excessive block size to buffer input to tar, cpio, backup, and restore. # dd if=/dev/rmt0.1 ibs=64k obs=512 | restore -xvf# dd if=/dev/rmt0.1 ibs=64k obs=5120 | tar -xvBf# dd if=/dev/rmt0.1 ibs=64k obs=5120 | cpio -ivB # dd if=/dev/rmt0.1 ibs=64k obs=5120 | pax rf You can change the default block size defined to AIX for a tape device using the chdev command or through SMIT, as shown in the following listing. Remember that this does not alter the physical block size used by the device! # chdev -1 rmt0 -a "block_size=0" Variable block size # chdev -1 rmt0 -a "block_size=512" Fixed 512-byte block size # chdev -1 rmt0 -a "block_size=1024" Fixed 1024-byte block size Tape Device Name Implicit Options Filename Rewind on Close Retention on Open /dev/rmt* Yes No /dev/rmt*.1 No No /dev/rmt*.2 Yes Yes /dev/rmt*.3 No Yes /dev/rmt*.4 Yes No /dev/rmt*.5 No No /dev/rmt*.6 Yes Yes /dev/rmt*.7 No Yes # tctl -f/dev/rmt0 rewind # tctl -f /dev/rmt0 offline # mt -f /dev/rmt0 rewind # mt -f /dev/rmt0 offline Density High High High High Low Low Low Low

Rewind the rmt0 tape drive Rewind and eject the rmt0 tape drive Rewind the rmt0 tape drive Rewind and eject the rmt0 tape drive

Shutdown Commands # shutdown -m +5 Shut system down to single user in 5 minutes # shutdown -r Shut down and reboot # shutdown now Shut down immediately without rebooting # shutdown -r Reboot now # shutdown -Fr Reboot now without any user warning # shutdown -r now Reboot now and warn the users # shutdown -k Avoid shutting down the system ODM: Customized object classes represent the devices actually present on the system. /etc/objrepos/Pdxxx ODM predefined Attributes, Connections, and Devices: PdAt PdCn PdDv /etc/objrepos/Cuxxx ODM customized Attributes, Dependencies, Device Drivers and Vital Product Data: CuAt CuDep CuDv CuDvDr CuVPD Config_Rules CuOD (New to 5L!) /usr/share/lib/objrepos Components of the SoftWare Vital Product Data (SWVPD) : lpp history inventory product

Device object classes are linked hierarchically into subclasses. # odmshow <ObjectClassName> Sampling of AIX Object Classes Class Object Contents of the Object Class PdDv Predefined devices supported by AIX PdAt Predefined device attributes PdCn Predefined device subclass connections CuDv Customized devices attached to the system CuDvDr Customized device drivers CuAt Customized device attributes CuDep Custom device dependencies CuVPD Customized vital product data Config_Rules Configuration rule sets

Print commands
qchk -q qchk -P lp0 qchk -# 123 qchk -A qcan -x 123 qcan -X -P lp0 qpri -#570 -a 25 qhld # 569 qhld -r -#569 qmov -m lpa -#11 enable psq disable psq cancel -#111 lpstat lpstat -p lp0 lpstat -u root lpq -P lp0 last last | grep shutdown uptime (w -u ) # switch.prt -s AIX # switch.prt -s SystemV To display the default q To display the status of the printer lp0 To display the status of job number 123 To display the status of all queues To cancel the print job 123 To cancel all jobs submitted to lp0 To change the priority of the job to 25 To hold the job 569 To remove holding from 569 To move the job 11 to queue lpa To enable queue psq To disable queue psq To cancel job 111 To display the status all queues To display the status of print queue lp0 To display the jobs submitted by user root To display the status of queue lp0 To list all the records in the /var/adm/wtmp file To show the shutdown sessions To show how long the system has been up Switch to the AIX printer subsystem Switch to the System V printer subsystem

Once the printer driver is installed, you can proceed to add the System V printer to the system. There are three steps to enable the printer. The lpadmin command is used to add the printer: # mkdev c printer t hp4V s parallel p ppa0 w p # lpadmin -p hp4V -v /dev/lp0 -D "Hewlett-Packard LaserJet 4/4M" After the System V printer has been added to the system, you need to use the accept command to allow the printer to accept print requests: # accept hp4V

The last step is to enable the new print queue using the enable command: # enable hp4V To define the print queue on the remote client, use the following command syntax: # lpadmin -p <client_printer_name> -s <remote_pr_server>!<remote_pr_queue> The System V filesets that are installed by default include the following: bos.msg.en_US.svprint bos.svprint.fonts bos.svprint.hpnp bos.svprint.ps bos.svprint.rte bos.terminfo.svprint.data

Licensing commands
oslevel oslevel r instfix -i | grep ML lslicense chlicense -u30 chlicense -f on To list the operating system level To get the ML info To get the ML info To see the number of license To change the fixed user license to 30 To enable floating user license

User commands
id To list all system identifications for current user id -gn To list the default group for current user id -Gn To list all system groups for current user lsuser root To list the attribute of user root lsuser ALL To list the attributes of all users lsuser -a HOME ALL To list the home directory of all users lsuser -a ALL To list all usernames lsuser -a auth1 auth2 ALL To list the authentication method for all users lsuser -a expires ALL To list expiry date lsuser -a account_locked ALL To check account lock status of all users chuser -a login=true san To enable the user san chuser -a rlogin=true san Enable san to login remotely mkuser si Creates user si with default values in /usr/lib/security/mkuser.defalault mkuser su=false si Create user si without su facility rmuser si To remove user si rmuser -p si To remove user si and his all attributes who List users with tty nos and ip numbers who /var/adm/wtmp Lists history of login logout system startup and shutdowns who -r To list the run level who am i /who -m To list the current user mkgroup dcm To create the group dcm chgroup users=u1,u2,u3 dcm To add users u1 u2 and u3 to dcm group rmgroup dcm To delete the group dcm

chauthent

To change the authentication methods

To enable a non-root administrator to use pwdadm, simply add their ID to the "security" group

Subsystem Commands
lssrc -a lssrc -h node1 -a lssrc -s kadmind lssrc -g tcpip mkssys rmssys -s kerberos chssys -s kerb -s kad startsrc -s kadmin startsrc -g tcpip stopsrc -s kadmin stopsrc -g tcpip refresh -s nfsd refresh -g tcpip refresh s lpd To list the status of all subsystems To list the status of all subsystems on foreign host node1 To list the status of the subsystem kadmind To get the status of the subsystem group tcpip To add a subsystem To remove the subsystem kerberos To rename the subsystem kerb to kad To start the subsystem kadmin To start the subsystem group tcpip To stop the subsystem kadmin To stop the subsystem group tcpip To refresh nfsd subsystem To refresh tcpip subsystem group

Scheduling commands
crontab -l crontab -e crontab -l > /si crontab -r crontab -v /var/adm/cron/cron.allow /var/adm/cron/cron.deny at -l at -r root.dfjdhjdh.21 /var/adm/cron/at.allow /var/adm/cron/at.deny batch atq joe To list the crontab entries To edit the crontab entries To copies the entries of crontab to /si file To remove all crontab entries To list the submission time File containing users who allowed cron service File containing users denied cron service To list the jobs scheduled via at command To remove the scheduled job root.dfjdhjdh.21 File containing users who allowed at service File containing users denied at service To run the command when the system load permits To list all the jobs submitted by user joe

ODM Commands
odmget sm_menu_opt odmget -q "id=licenses" sm_menu_opt To get the objects from class sm_menu_opt To list objects that matches query id=licenses from object sm_menu_opt odmdelete -o sm_menu_opt -q "id=licenses" To delete the entries from class sm_menu_opt which agrees the query id=licenses odmshow sm_menu_opt To show the object class definition odmdrop -o sm_menu_opt To drop sm_menu_opt object class

odmchange -o sm_menu_opt -q "id=licenses" file1 To change the attributes from file1

Report & Errors Commands


errpt To display complete summary of report errpt -a To list complete detailed report errpt -d H To list all hardware related errors errpt -d S To list all software related errors errpt -a -j 34564423 To list detailed error report of error id 34564423 chitab tty002:23:respawn:/usr/sbin/getty /dev/tty To enter the entry tty002:23:respawn:/usr/sbin/getty /dev/tty in inittab lssrc -g portmap To start tcpip

Daemons of NIS
Server ypserv yppasswd ypupdated Slave Server ypserv Client ypbind

NIS maps created by default (if file available on master server) MAP FILE NICK NAME passwd.byname /etc/passwd passwd passwd.byaddr group.byname /etc/group Group group.byaddr hosts.byname /etc/hosts Hosts hosts.byaddr ethers.byname /etc/ethers Ethers ethers.byaddr networks.byname /etc/networks Networks networks.byaddr rpc.bynumber /etc/rpc services.byname /etc/services protocols.byname /etc/protocols protocols protocols.bynumber netgroup.byhost /etc/netgroup netgroup.byuser bootparams /etc/bootparams mail.aliases /etc/aliases aliases mail.byaddr publickey.byname /etc/publickey netid.byname /etc/passwd /etc/group /etc/hosts /etc/netid

netmasks.byaddr chypdom I mca chypdom B mca chypdom N mca domainname mca mkmaster

/etc/netmasks

Modifies nis domain name entry in /etc/rc.nfs Changes nis domain and modifies /etc/rc.nfs file Changes nis domain name to mca Changes nis domain name to mca until next reboot To make the machine NIS master (Options -O Overwrites existing maps -o prevents overwriting existing maps -E Exit on errors -e No exit on errors -P Starts yppasswdd daemon -p Dont start yppasswdd daemon -U Starts ypupdated daemon -u Dont start ypupdated daemon -C Starts ypbind daemon -c Dont start ypbind daemon -B Executes ypinit command and modifies rc.nfs mkclient B S mca Makes the machine as a client of mca server and starts ypbind daemon ypcat passwd To cat the password map file passwd.byname ypcat x To display map nickname translation table ypcat d pci passwd To display the passwd file in the domain pci yppasswd To change the password of nis user lsmaster Display characteristics for the configuration of NIS master mrgpwd >/var/yp/passwd To merge /etc/passwd and /etc/security/passwd file to /var/yp/passwd ypxfr -h mca passwd.byname To transfer password map file from host mca

Procedure for NIS


Master Server
Change the nis domain name in the master server chypdom B mca or smit chypdom Verify tcpip is running by executing lssrc s inetd Verify portmap is running by executing lssrc s portmap (For security reason it is better to locate all nis files to /var/yp directory and change the DIR=/etc entry to DIR=/var/yp in the /var/yp/MakeFile. For merging the existing passwords execute mrgpwd > /var/yp/passwd) Execute mkmaster O E P U C B -O Overwrites existing maps for this domain -E Exist on errors when creating master server -P Starts yppasswdd daemon -U Starts ypupdated daemon -C Starts ypbind daemon -B Executes ypinit command, uncomment entries in rc.nfs and starts daemons Check the yp daemons with lssrc g yp

Slave Server

Change the nis domain name chypdom B mca Edit hosts file, keep entries for loopback, this machine and of server Execute mkslave O B C mca

Client machine
Change the nis domain name chypdom B mca Edit hosts file, and keep entries for loopback , this machine and of server Execute mkclient B mca Check for ypbind with lssrc s ypbind LPAR indyoradst# uname -L 1 06-C891G indyoradst# prtconf -L LPAR Info: 1 06-C891G indyoradst# HMC: List partitions authenticated by RMC
/opt/csm/bin/lsnodes -a Status partition01 1 partition02 0 partition03 1

Where 1 means LPAR is activated and authenticated for DLPAR; 0 means otherwise. If the LPAR is activated and still shows Active<0>, you could have either network or hostname setup problems. If you have just rebooted the HMC, wait for a few minutes. If nothing changes after that, check your hostname/network setup in Setting up HMC/partitions hostname and network.

HMC: List partitions recognized by DLPAR


lspartition -dlpar <#0> Partition:<001, partition01.company.com, 9.3.206.300> Active:<1>, OS:<AIX, 5.2>, DCaps:<0xf>, CmdCaps:<0x1, 0x0> <#1> Partition:<002, partition02.company.com, 9.3.206.300> Active:<0>, OS:<AIX, 5.2>, DCaps:<0xf>, CmdCaps:<0x1, 0x0> <#2> Partition:<003, partition03.company.com, 9.3.206.300> Active:<0>, OS:<, 5.1F>, DCaps:<;0x0>, CmdCaps:<0x0, 0x0>

If all active AIX 5.2 partitions are listed as Active<1>, ..., DCaps:<0xf> your system has been set up properly for DLPAR, and you can skip the checklist now. (In this example, LPAR 002 is being shut down, and LPAR 003 is not activated because it is at AIX 5.1.) If you're missing some active partitions or some partitions are reported as Active<0>, your system probably still has a network/hostname set up problem. See Setting up the HMC/partitions hostname and network. (If your LPAR is Active<1> but the GUI is still not DLPAR capable, do a rebuild to get around this problem. See the Appendixes in this article for more information.) If you still can't get partitions recognized by DLPAR after verifying the checklist, contact IBM service personnel.

HACMP Commands
logs /tmp/hacmp.out Detailed event script output logged in 7 day rolling history /var/adm/cluster.log High level view of cluster events (No clean up on this file) /usr/sbin/cluster/history/cluster.mmdd Day by day view of cluster events. (one file / day of month) /tmp/cm.log Clstrmgr messages /tmp/cspoc.log Output from C-SPOC commands (similar to smit.log) /tmp/emuhacmp.out Output from event emulation rdist -b -f /etc/disfile1 To distribute the files in disfile1 to all nodes in disfile1 in binary mode Sample entry for disfile1 HOSTS = ( root@node1 root@node3 ) FILES = ( /etc/passwd /etc/security/passwd) ${FILES} -> ${HOSTS} clstart -m -s -b -i -l clstop -f -N clstop -g -N clstop -gr -N cldare -t cldare -t -f cldare -r cldare -r -f clverify cllscf cllsclstr cllsnode cllsnode -i node1 cllsdisk -g shrg cllsnw cllsnw -n ether1 cllsif cllsif -n node1_service cllsvg cllsvg -g sh1 cllslv cllslv -g sh1 cllsdisk -g sh1 cllsfs cllsfs -g sh1 cllsnim To start cluster daemons (m-clstrmgr, s-clsmuxpd, b-broadcast message, -i-clinfo, -l cllockd) To force shutdown cluster immediately without releasing resources To do graceful shutdown immediately with no takeover To do graceful shutdown immediately with takeover To sync the cluster toplogy To do the mock sync of topology To sync the cluster resources To do the mock sync of resources cluster verification utility To list clustur topology information To list the name and security level of the cluster To list the info about the cluster nodes To list info about node1 To list the PVID of the shared hard disk for resource group shrg To list all cluster networks To list the details of network ether1 To list the details by network adapter To list the details of network adapter node1_service To list the shared vgs which can be accessed by all nodes To list the shared vgs in resource group sh1 To list the shared lvs To list the shared lvs in the resource group sh1 To list the PVID of disks in the resource group sh1 To list the shared file systems To list the shared file systems in the resource group sh1 Show info about all network modules

cllsnim -n ether cllsparam -n node1 cllsserv

Show info about ether network module To list the runtime parameters for the node node1 To list all the application servers

claddclstr -i 3 -n dcm To add a cluster definition with name dcm and id 3 claddnode To add an adapter claddnim To add network interface module claddgrp -g sh1 -r cascading -n n1 n2 To create resource group sh1 with nodes n1,n2 in cascade claddserv -s ser1 -b /usr/start -e /usr/stop Creates an application server ser1 with startscript as /usr/start and stop script as /usr/stop clchclstr -i 2 -n dcmds To change cluster definitions name to dcmds and id to 2 clchclstr -s enhanced To change the clustur security to enhanced clchnode To change the adapter parameters clchgrp To change the resource group name or node relationship clchparam To change the run time parameters (like verbose logging) clchserv To change the name of app. server or change the start/end scripts clrmclstr clrmgrp -g sh1 clrmnim ether clrmnode -n node1 clrmnode -a node1_svc clrmres -g sh1 clrmserv app1 clrmserv ALL clgetactivenodes -n node1 cluster clgetaddr node1 clgetgrp -g sh1 clgetgrp -g sh1 -f nodes clgetif To remove the cluster definition To delete the resource group sh1 and related resources To remove the network interface module ether To remove the node node1 To remove the adapter named node1_svc To remove all resources from resource group sh1 To remove the application server app1 To remove all applicaion servers To list the nodes with active cluster manager processes from

manager on node node1 returns a pingable address from node node1 To list the info about resource group sh1 To list the participating nodes in the resource group sh1 To list interface name/interface device name/netmask associated with a specified ip label / ip address of a specific node clgetip sh1 To get the ip label associated to the resource group clgetnet 193.9.200.2 255.255.255.0 To list the network for ip 193.9.200.2, netmask 255.255.255.0 clgetvg -l nodelv To list the VG of LV nodelv cllistlogs To list the logs

clnodename -a node5 To add node5 to the cluster clnodename -o node5 -n node3 To change the cluster node name node5 to node3 clshowres clfindres xclconfig Lists resources defined for all resource group To find the resource group within a cluster X utility for cluster configuration

xhacmpm xclstat

X utility for hacmp management X utility for cluster status

SP Commands
Daemons
hats hags haem hr pman Topology services hatsd Group services hagsd Event management haemd Host responds hrd Problem management pmand,pmanrmd ( /usr/sbin/rsct/bin/hatsctrl script) (/usr/sbin/rsct/bin/hagsctrl script) (/usr/sbin/rsct/bin/haemctrl script) (/usr/sbin/rsct/bin/hrctrl script) (/usr/sbin/rsct/bin/pmanctrl script)

fault_service_Worm_RTG_SP (WORM) css_restart_node) kadmind

Switch daemon on nodes (/usr/lpp/ssp/rc.switch called by

kerberos kpropd hardmon install_cw

The authentication database daemon for password changing and administration tools Listens port 751. It checks acl files admin.acl.(get,mod,add) in /var/kerberos/database /.k file for master key and /var/kerberos/databse/pricipal.pag, pricipal.dir for authentication database. Daemon that provides authentication services & ticket granting ticket for clients. Daemon to receive update for a secondary database server Daemon that monitors and controls the state of SP hardware It checks acl file /spdata/sys1/spmon/hmacls To complete PSSP installation on cws (Installs PSSP programs for SMIT panels Starts and configures SDR Sets node number 0 for cws in ODM Creates hmacls file with rood.admin entry in Starts and configure PSSP daemons Configures default partition) To setup workstation as SP authentication server (Creates /etc/krb.conf, /etc/krb.realms files Creates authentication database using kdb_edit command Create master key file /.k using kstash command Adds kadmin and kerberos to inittab file and starts them Define initial auth. admin (eg:- root.admin) using kdb_edit command Creates Kerberos ACLS (admin_acl.get,mod,add files) Execute kinit for root.admin and creates local service principals (hardmon.cws, rcmd.cws) Creates /.klogin file and add admin principal to it Creates /etc/krb-srvtab file using ext_srvtab command) To setup CWS as BIS To check the PSSP versions in all nodes To verify system monitor configured properly

setup_authent

setup_server splst_versions -G -t spmon_ctest

spmon_itest SYSMAN_test CSS_test SDR_test -l si SDRListClasses SDRArchive si name

To verify system monitor installed properly & operational To verify the system management component To verify communication subsystem To verify SDR and logs the errors in file si To list the class name in the SDR To backup SDR in the directory /spdata/sys1/sdr/archives with

backup.<year><Julian day>.<hour><minute>.si sprestore_config backup.<year><Julian day>.<hour><minute>.si To restore SDR and partion sensitive subsystems SDRGetObjects Syspar To get the system partition info SDRGetObjects syspar_map To get the system partition map (with node info) SDRGetObjects Adapter node_number netaddr To get the node number and net address in the Adapter class SDRDeleteObjects Adapter netaddr==193.9.200.227 To delete class Adapter with netaddr value 193.9.200.227 SDRChangeAttrValues Node node_number==9 bootp_response==install To change the boot response as install on node with node number 9 SDRWhoHasLock <class_name> Returns the transaction ID of a lock on a specified class SDRClearLock <class_name> To unlock an SDR class syspar_ctrl -G -A syspar_ctrl -G -D syspar_ctrl -R syspar_ctrl -E syspar_ctrl -s syspar_ctrl -k syspar_ctrl -r ngcreate -s 1:1 si ngcreate -n 1 2 3 si ngcreate -N ng1,ng2 si ngcreate -w n1,n2 si ngcreate -ae n1,n2 si nglist nglist -G ngfind si ngnew si1 si2 si3 ngnew -G si1 si2 si3 ngresolve -G -n si ngresolve -w si name ngresolve -d si ngdelete si si1 ngdelete -u si To add and restart all system partition sub systems To stop and delete all system partition sub systems To restore all system partition sub systems in current partition To list all system partition sub systems To start all system partition sub systems in current partition To stop all system partition sub systems in current partition To refresh all system partition sub systems in current partition To create node group si with 1st node in 1st frame To create node group si with 1st 2nd and 3rd nodes To create node group si with node groups ng1 and ng2 To create node group si with host name n1 and n2 To create node group si with all nodes in the current partition excluding hosts n1 and n2 To list node groups in current partition To list node groups globally To find all node groups which contain node group si To create 3 node groups with names si1 si2 and si3 To create 3 node groups globally with names si1 si2 and si3 To resolve the nodes in the node group si as node numbers with global option To resolve the nodes in the node group si as fully qualified host To resolve the nodes in the node group si as fully qualified ip address To remove node groups si and si1 To remove node group si but leave entries in other node groups

ngclean -Ga ngaddto si 1 2 ngaddto si 1 2 ng1 ngdelfrom si 1 2 ngdelfrom si 1 2 ng1 spled -G spled or spmon -L

which is having the entries in it To clean up all node groups To add nodes 1 and 2 to the existing node group si To add nodes 1,2 and node group ng1 to node group si To remove nodes 1 and 2 from node group si To remove nodes 1, 2 and node group ng1 from node group si To display leds of nodes in a multi partition system To display leds of nodes in the current partion

spmon -p off frame2/node3 To power off node3 in frame 2 spmon -p on frame2/node3 To power on node 3 in frame 2 spmon -G -p on frame2/node3 To power on node3/frame 2 if it is outside current partition spmon -k service /frame2/node3 To change the key settings to service spmon -p off frame1 To power off frame1 spmon -K frame1/node1 To see the key settings of frame1/node1 spmon -reset frame1/node1 To reset spmon -open frame1/node1 To open a tty on frame1/node1==(s1term -w 1 1) spmon -d To run the diag in the current partition spmon -G -d To run the diag globally hmmon -V 1:1 hmmon -Q -s 1:1 hmmon -q -s 1:1 hmreinit Displays a descriptive list of symbolic variable names Displays the state of node1 in frame 1 and exists Displays and monitors continuously To stop and restart hardmon

hmcmds -G off all To power off all hardware hmcmds -G off 1:3 To power off slot 3 in frame 1 hmcmds -G on 1:3 To power on slot 3 in frame 1 hmcmds -v -G boot_supervisor 1:1 To reset the power of node_supervisor card on slot 1 frame 1 (Use full to close the opened ttys on nodes) hmcmds secure l 1-3:2 To change the key in secure mode for slot 2 in frame 1 2 and 3 hmcmds -v synch_reset Perform sync reset. To clear the switch errors hmcmds -v power_on_reset Perform sync reset and do self test of switch chips cstartup -G all cstartup -N 1 2 4-8 cstartup -g si cstartup -GZ all already cstartup -k all cstartup -E all cshutdown -F node1 cshutdown -h node1 cshutdown -g si cshutdown -G -N 1 3 4-7 To startup all nodes globally To startup nodes 1,2 and 4 to 8 To startup node group si To startup all nodes. With Z it will restart the nodes which are running (otherwise command will exit) To verify the startup with sequence file (StartSeq) To startup all nodes ignoring the sequence file To shutdown node1 immediately To halt the node node1 To shutdown the nodes in the node group si To shutdown nodes 1 3 and 4 to 7 regardless partition

cshutdown -X -N 1 2 3 hostlist -av hostlist -avd hostlist -dw node1 hostlist -N si hostlist -s 1-4:4 nodecond -n 1 1 nodecond 1 1 splstdata -h splstdata -i splstdata -v splstdata -t splstdata -b splstdata -n splstdata -s splstdata -d splstdata -p splstdata -e Efence Efence 193.9.1.2 193.9.1.5 Efence node1 node3 Efence -autojoin node1

To shutdown nodes 1 2 and 3 ignoring sequence file To list sp host name which is active To list the hosts in ipaddress which are active Returns the ip of the node node1 List the host names in the node group si List the hostname of the node in 4th slot in frames 1-4 To get the ehternet address of the node 1 in frame 1 To network boot the node 1 in frame 1 To list the hardware info (equivalent to lscfg ) To list the network adapter data (equivalent to netstat -in) To list VG info on nodes To list extension node config To list boot install info To list node information To list node switch information To list file system info (equivalent to df) To list SP partition info To list the sp environment variables like ntp_config, amd_config To display all nodes fenced To fence nodes with ips 193.9.1.2 and 3 To fence nodes node1 and node3 To fence out but will unfence it after reboot To unfence nodes with ips 193.9.1.2 and 3 To unfence nodes node1 and node3

Eunfence 193.9.1.2 193.9.1.5 Eunfence node1 node3 Estart Estart -autounfence -0 Eunpartition delnimclient -l 1 2 3 mknimclient -l 1 2 3 delnimmast -l 1 17 33 mknimmast -l 1 17 33 lshacws ntpdate 90.1.2.1 spbootlist -l 1 2 nodecond 1 4 nodecond -n 1 4 sphrdwrad 1 3 2

To start sp switch To start sp switch and turn off autounfence feature (1 for autounfence enabled) To prepare a system partition for repartitioning To delete nim client definition for nodes 1 2 and 3 from NIM master To make node 1 2 and 3 as NIM clients To unconfigure nodes 1 17 and 33 as NIM masters and remove filesets To make nodes 1 17 and 33 as NIM masters To list the status of the CWS Sets date and time by enquiring ntp server 90.1.2.1 To set the bootlist on nodes 1 and 2 To network boot the node 4 in frame 1 To fetch the ethernet address of node 4 in frame 1 To fetch mac address for node 3 and 4 in frame 1

setup_authent kdb_destroy create_krb_files srvtab file ext_srvtab -n node1 ext_srvtab -n SPbgAdm SPbgAdm spsetauth -d k4 std chauthpar k4 std kpasswd lsauthent k4init siju k4init -v siju k4init -i siju k4init -r siju k4init -l siju rcmdtgt node k4list k4list -srvtab chkp -l 6 siju chkp -e 2001-5-23 siju lskp -p lskp -s lskp -c lskp siju abc rmkp siju rmkp -n siju rmkp -v siju kdb_edit kdb_edit -n kdb_util dump /si.bak kdb_util load /si.bak kdb_util new_master_key kadmin

To setup a cws to use kerberos authentication To destroy the kerberos database Searches for nodes in install/Customise mode and create krbfor those nodes. (Creates in tftpboot directory of CWS.) To extract service key files from the database for instance node1 To extract service key files from the database for instance (Creates in the present directory with name <instance>-new-srvtab) To set the authentication methods as k4 and standard To change the authentication methods as k4 and std To change the kerberos principals password To list the authentication table To get the kerberos ticket for principal siju To get the same as above but give verbose output To get the same but the machine will ask for the instance To get the same for a different realm (U can specify realm) To get the same for the life time in minutes which u specify To obtain a maximum life time ticket for rcmd services on local To list the ticket cache and principals name To list the contents of the server key file To change the life time of the principal siju to 30 minutes (6 x 5) To change the expiry date of principal siju to 2001 may 23 To list the predefined kerberos principals To list the kerberos service principals To list the kerberos client principals To list the principals of siju and abc To remove the principal siju To remove the principal siju without prompting for confirmation To remove the principal with verbose output To change the attributes of the kerberos principals To avoid asking master key and get it from .k file To backup the kerberos database to si.bak file To restore the kerberos database from file si.bak. To change the master key To add,delete,see,change password,change admin passwd of

kerberose kadmin ank kadmin cpw kadmin cap kadmin get kadmin dest kstash kdb_init

To add a new kerberos principal To change the password of a principal To change admin password To get the details of a principal To destroy admin ticket To save the master key in the .k file To initialize the kerberos system

ksrvutil list To list the principals and version number in the server key file ksrvutil -f /etc/srvtab.bak list To list the principals in the file /etc/srvtab.bak ksrvutil change To change the key version in the default srvtab file ksrvutil delete To delete the keys in the /etc/krb-srvtab file ksrvutil -f /etc/srvtab.bak delete To delete the keys in the /etc/srvtab.bak file spacs_cntrl block user1 To block user1 on the node spacs_cntrl unblock user1 To unblock user1 spacs_cntrl deny user1 To deny user1 spacs_cntrl allow user1 To allow user1 spacs_cntrl -f /tmp/si deny To deny the list of the users in the file /tmp/si cw_allowed List of users to be allowed to login to CWS cw_restrict_login Script which will deny user to login to cws and allow them to change the passwd (files are /usr/lpp/ssp/config/admin directory and entry for second file will be in /etc/profile file) spmkuser id=1234 pgrp=system groups=system,bin home=node1:/home/siju siju To create SP user siju with id 1234, primary groups system, secondary groups system,bin and home directory home/siju of node1 sprmuser -ipr siju To remove the SP user siju (I for interactive, p for removing info from passwd file and r for removing the home directory) splsuser -c siju splsuser -f siju To list the attributes of sp user siju in column format To list the attributes of sp user siju in stanza format

spchuser groups=dev,system sh=/bin/ksh siju To change the shell to ksh and secondary groups to dev, system of SP user siju supper -v supper update supper status supper when supper where supper log supper rlog To go to the supper prompt in verbose mode To update all file collections To see the status of the file collections To list when last updation occured To show current servers for updation To show summary of last or current updation To show the details of last of current updation

supper file user.admin supper install siju supper remove siju supper update user.admin supper diskinfo

To list the files in the file collection user.admin To install the file collection siju To remove file collection siju To update file collection user.admin To show the diskspace and current VG

Procedure to Build a file collection with name siju for files in /home/siju 1) go to /var/sysman/sup 2) create dir siju 3) change ownership and group of siju to bin 4) copy contents of /var/sysman/sup/user.admin to siju 5) edit list file for including and omitting files in /home/siju directory It should contains entry like the following symlinkall upgrade ./home/siju omit ./home/siju/abc omitany ./home/siju/s* 6) Add a symbolic link to siju file in lists directory to list in siju directory ie ln -s /var/sysman/sup/siju/list /var/sysman/sup/lists/siju 7) Update /var/sysman/file.collections file with following entry primary siju - / - / EDO power no 8) Update sup.admin file collection to reflect the changes made to file.collections dsh -av supper update sup.admin 9) Install file collection siju in the nodes dsh -av supper install siju sysctld /etc/sysctl.conf Sysctl server daemon Sysctl configuration file

setauth -cmd svcconnect NONE To allow non kerberos users to execute sysctl commands (Entry in sysctl.conf file) setauth -cmd pdf {ACL /etc/si.acl} To change the acl file for pdf command to /etc/si.acl (Entry in sysctl.conf file) /etc/sysctl.acl Default acl file for sysctl

sysctl -h node1 Opens a sysctl command interface for node node1 sysctl -h node1 aclcheck siju To check entry for siju in the default acl file (sysctl.acl) sysctl -h node1 -f /etc/si.acl siju To check entry for siju in the acl file /etc/si.acl sysctl -h node1 info commands To list the authorized commands for the current principal sysctl -h node1 acladd -p siju To add the principal siju to the default ACL file sysctl -h node1 -f /etc/si.acl acladd -p siju To add the principal siju to /etc/si.acl ACL file sysctl -h node1 acldelete -p siju To delete the principal siju to the default ACL file sysctl -h node1 -f /etc/si.acl acldelete -p siju To delete the principal siju to /etc/si.acl ACL file

sysctl -h node1 acllist To list the entries in the default acl file sysctl -h node1 -f /etc/si.acl acllist To list the entries in /etc/si.acl file sysctl -h node1 aclcreate -p root.admin -p siju -f /etc/si.acl To create acl file /etc/si.acl with the entries root.admin and siju sysctl -h node1 checkauth -cmd pdf To check authorization for command pdf for the current user sysctl -h node1 confadd include /etc/si.acl To include the acl file si.acl in the sysctl.conf file sysctl -h node1 confdelete include /etc/si.acl To remove the acl file si.acl from sysctl.conf file sysctl -h node1 svcrestart To restart the sysctld daemon on node node1 Steps to create a Syctl application Task :- User siju (kerberos principal siju.adm) should get the permission to start a subsystem by executing the command substart. Permission should not be given to other users. 1) Create the client application substart in /usr/bin directory of cws with following contents if [ $# -gt 2 ] then echo "Arguments exceed the limit" exit 1 fi /usr/lpp/ssp/bin/hostlist -n $1 | /usr/bin/sysctl -c - substart_proc $2 In the above script if condition will check for the number of arguments and execute procedure corresponding host Change the mode to executable chmod 755 /usr/bin/substart Create server application substart.tcl with a procedure substart_proc with following contents create proc substart_proc {SubSystem} AUTH { global SCUSER if [ aclcheck -f /etc/substart.acl $SCUSER ] { exec /etc/substart.srv $SubSystem return }} if condition in the above example checks for kerberos user in the acl file /etc/substart.acl If the condition is true it execute the command /etc/substart.srv with arguments passed by substart command Create the script substart.srv with following contents startsrc -s $2 This script execute the command startsrc with the argument passed by the substart command Change the mode to executable chmod 755 /etc/substart.srv Create acl file substart.acl with the entry for user siju #acl# _PRINCIPAL siju.adm@CWS Add the application to the sysctl by adding following line to sysctl.conf file include /etc/substart.tcl Distribute the files to all nodes pcp -av /usr/bin/substart pcp -av /etc/substart.tcl

on 2) 3)

4) 5) 6) 7) 8)

9) 10) 11)

pcp -av /etc/substart.srv pcp -av /etc/substart.acl pcp -av /etc/sysctl.conf Restart the sysctld daemon to get the new information on cws and on all nodes Get the kerberos ticket for user siju and execute following command substart 3 lpd This should start the lpd daemon on node 3 Try the above command with any other kerberos ticket. Result should be negative

NIM Commands
smit nimconfig Configure and start NIM master smit nim_mknet Create NIM network objects smit nim_mkroute Define NIM network routes smit nim_mkmac Create client network object smit nim_mkres Create lpp_source smit nim_alloc Create bos.inst resources lsnim List NIM-defined objects bootinfo -q Check IPL ROM emulation bosboot -r Create IPL ROM media smit nim_alloc Create bos_inst resource on client smit nim_perms Set master push permission smit nim_mac_op Select client and resource smit nim_mkgrp Create a NIM client group smit bos_inst Push install stand-alone client smit nim_install Pull install from client smit dksl_init Initialize diskless client smit nim_mac_opp lppchk Verify installation smit nim_backup_db Back up NIM configuration smit nim_restore_db Restore NIM configuration smit nim_client_op Remotely operate a NIM client smit nim_unconfig Unconfigure NIM master nimconfig -a pif_name=en0 -a netname=net1 To initialise the NIM master with network name net1 nimconfig -r To rebuild /etc/niminfo file which contains the variables for NIM nim -o define -t lpp_source -a source=/dev/cd0 -a server=master -a location=/export/lpp_source/lpp_source1 lpp_source1 To define lpp_source1 image in /export/lpp_source/lpp_source directory from source cd0 nim -o define -t mksysb -a server=master -a location=/resources/mksysb.image mksysb1 To define mksysb resource mksysb1, from source /resources/mksysb.image on master nim -o remove inst_resource To remove the resource inst_resource nim -o check lpp_source1 To check the status of lpp_source lpp_source1 nim -o allocate -a spot=spot1 -a lpp_source=lpp_source1 node1 To allocate the resources spot1 and lpp_source1 to the the client node1

nim -o bos_inst node1 To initialise NIM for the BOS installation on node1 with the allocated resources nim -o dkls_init dcmds To initialize the machine dcmds as diskless operation nim -o dtls_init dcmds To initialize the machine dcmds for dataless operation nim -o cust dcmds To initialize the machine dcmds for customize operation nim -o diag dcmds To initialize the machine dcmds for diag operation nim -o maint dcmds To initialize the machine dcmds for maintenance operation nim -o define -t standalone -a platform=rspc -a if1="net1 dcmds xxxxx" -a cable_type1=bnc dcmds To define the machine dcmds as standalone with platform as rspc and network as net1 with cable type bnc and mac address xxxxx nim -o unconfig master To unconfigure nim master master nim -o allocate -a spot=spot1 dcmds To allocate the resource spot1 from machine dcmds nim -o deallocate -a spot=spot1 dcmds To de allocate the resource spot1 from machine dcmds nim -o remove dcmds To remove machine dcmds after removing all resources associated to it nim -o reboot dcmds To reboot ther client dcmds nim -o define -t lpp_source -a location=/software/lpp1 -a server=master -a source=/dev/cd0 lpp1 To define lppsource lpp1 on master at /software/lpp1 directory from source device /dev/cd0 lsnim To list the nim resources lsnim -l dcmds To list the detailed info about the object dcmds lsnim -O dcmds To list the operation dcmds object can support lsnim -c resources dcmds To list the resources allocated to the machine dcmds nimclient The client version of nim command (User can obtain same results of nim in server )

Network Install Manager (NIM) 1. First, create a /tftpboot filesystem before running smitty nim_config_env. To create the /tftpboot filesystem and install the NIM software, use the following command sequence: # mklv -y 'lvtftp' rootvg 1 # crfs -v jfs -d lvtftp -m /tftpboot -A yes # mount /tftpboot # chfs -a size=120000 /tftpboot # df -k /tftpboot # installp -qaX -d <device> bos.sysmgt..nim.master bos.sysmgt.nim.spot # smitty nim_config_env 2. Create a /tftpboot filesystem and install the NIM filesets using the preceding command sequence.
3. Configure the NIM Master from CD-ROM using smitty nim_config_env. 4. Define the client machine(s) using smitty nim_mac. 5. Create a mksysb image and define a mksysb resource using smitty nim_res. 6. Install a stand-alone client from the mksysb image using smitty nim_bosinst. 7. Boot the client.

NFS Daemons There are a number of daemons that need to run on both the client and the server. Client biod Improves NFS performance by filling and emptying the buffer cache. By default 6 biod daemons are started however this can be changed to improve performance. These are started in the /etc/rc.nfs file. rpc.statd Allows the remote procedure calls rpc.lockd Handles File locking Server

portmap

nfsd

rpc.mountd rpc.statd rpc.lockd

Provides a standard way of looking up the port for a certain application. The application registers with portmap, then portmap listens on the appropriate port. When a client communicates on the NFS port, portmap replies with the real port number of NFS. Portmap is included in the /etc/rc.tcpip file and must be started before inetd and the RPC servers so that it can accept the registrations. A server daemon that handles the client requests for file system operations. Each daemon accepts one request at a time, however once it has passed the request on to the kernel it is free to accept a new request. Bu default 8 nfsd daemons are started, however if the server is a busy nfs server then a value 50 to 100 might be more appropriate. These are started from /etc/rc.nfs and are under the control of SRC. Accepts a mount request from the client and allows the export if authorised. Allows Remote procedure calls Implements file locking

NIS Servers and Clients Configuration # smit mkmaster HOSTS that will be slave servers [slave1,slave2] Can existing MAPS for the domain be overwritten? yes EXIT on errors, when creating master server? yes START the yppasswdd daemon? no START the ypupdated daemon? no START the ypbind daemon? yes START the master server now, both at system restart, or both? # smit mkslave HOSTNAME of the master server [Master] Can existing MAPS for the domain be overwritten? yes START the slave server now, both at system restart, or both? Quit if errors are encountered? Yes # smit mkclient START the NIS client now, at system restart, or both? NIS server - required if there are no NIS servers on this subnet both []

To stop, start, or check status of the NIS client ypbind daemon, run the following commands: # lssrc s ypbind # stopsrc s ypbind # startsrc s ypbind NIS Packages - bos.net.nis Starting NIS Services Like NFS, NIS is managed as a subsystem under AIX. NIS daemons are started using the SRC startsrc and stopsrc commands. The /etc/rc.nfs script contains code to start up NIS services before bringing up NFS.

# startsrc -g nis # stopsrc -g nis The NIS daemons are as follows: ypserv NIS server daemon ypbind NIS server binding manager yppasswdd NIS passwd update daemon ypupdated NIS map update invoked by inetd keyserv Public key server daemon portmap RPC program to port manager NIS PLUS NIS Packages - bos.net.nisplus To create NIS+ master servers and clients, invoke the SMIT FastPath smit nisp_config. AIX also provides setup scripts to set up NIS+: nisserver, nispopulate, and nisclient.
The following table contains a list of common NIS+ commands to manage different NIS+ components.

Command niscat nisls nisrmdir nisrm rpc.nisd nisinit nis_cachemgr nisshowcache nisping nislog nisgrpadm nisdefaults nisaddent

Description Displays object properties of an NIS+ table Displays the contents of an NIS+ table Removes an NIS+ object from a namespace Removes NIS+ directories and subdirectories from a namespace The NIS+ daemon; provides NIS+ services Initializes a workstation to be an NIS+ client Starts the NIS+ cache manager daemon Displays the contents of the shared cache file Pings the replicas and prompts for updating Displays the contents of the transaction log Creates, deletes, and performs miscellaneous administration operations on NIS+ groups Displays the seven default values currently active in the namespace Creates NIS+ tables from corresponding /etc files or NIS maps

Starting NIS+ Services Like NIS, NIS+ is managed as a subsystem under AIX. NIS+ daemons are started using the SRC startsrc and stopsrc commands. The /etc/rc.nfs script contains steps to start up NIS+ services. # startsrc -g nisplus # stopsrc -g nisplus NIS+ daemons are as follows: rpc.nisd NIS+ server daemon rpc.nispasswd NIS+ passwd update daemon nis_cachemgr NIS+ cache manager daemon Sendmail Files The sendmail MTA uses the following files for configuration and data: /etc/mail/sendmail.cf Sendmail configuration file /etc/mail/aliases Mail aliases /etc/mail/aliases.db Compiled alias file

/etc/mail/sendmail.pid /etc/sendmail.pid /etc/mail/statistics

PID of sendmail daemon Link to sendmail.pid file Mail statistics

The sendmail program accesses configuration file information from a compiled version of the /etc/sendmail.cf table. To compile a new version of the database, use sendmail with the -bz flag. # /usr/lib/sendmail bz --- Compile a new sendmail.cf database sendmail accesses alias information from a dbm version of the /etc/aliases table. To compile a new version of the /etc/aliases table, use /usr/lib/sendmail -bi. # /usr/lib/sendmail bi ---- Create new alias database The sendmail program is invoked as a subsystem from the /etc/rc.tcpip script. The AIX sendmail automatically compiles the /etc/mail/aliases and /etc/mail/sendmail.cf files when it is started. If you are running a non-IBM-supplied sendmail, you may need to force a compile of these files as part of the start-up. If you update any of the configuration information while sendmail is running, refresh the sendmail subsystem by issuing an SRC refresh command or by sending the daemon a SIGHUP. # refresh -s sendmail # kill -1 'head 1 /etc/sendmail.pid' The basic startup flags for sendmail should invoke sendmail as a daemon and specify the time in minutes between mail queue scans for postponed messages. These flags are -bd and -q<time>. # /usr/lib/sendmail -bd -q30m # Start and scan mail queue every 30 minutes To stop the sendmail daemon, use the SRC stopsrc command or send a SIGABORT to the daemon. # stopsrc -s sendmail # kill -6 'head 1 /etc/sendmail.pid' To restart the stopped server, use the SRC startsrc command. (Note that starting sendmail with startsrc requires an additional parameter.) # startsrc -s sendmail -a'-bd -q30m' To check the status of the sendmail daemon, use the SRC lssrc command. # lssrc -s sendmail To display the set of supported signals, use the -l argument of the kill command: # /bin/kill -l

Datavg recovery # varyonvg datavg 0516-082 varyonvg: Unable to access a special device file. Execute redefinevg and synclvodm to build correct environment. snitsoradbs06# lsvg rootvg datavg snitsoradbs06# lsvg datavg 0516-010 : Volume group must be varied on; use varyonvg command. # lsdev -Cc disk hdisk0 Available 08-08-00-3,0 16 Bit LVD SCSI Disk Drive hdisk1 Available 08-08-00-4,0 16 Bit LVD SCSI Disk Drive hdisk2 Available 08-08-ff-0,0 SCSI RAID 5 Disk Array # lspv hdisk0 hdisk1 hdisk2 00cdb75d801c9e88 00cdb75dc9733fb1 00cdb75d0ae46707 rootvg rootvg datavg active active

# redefinevg -d hdisk2 datavg # synclvodm datavg 0516-010 : Volume group must be varied on; use varyonvg command. 0516-544 synclvodm: Unable to access volume group datavg. # varyonvg datavg # mount -a mount: 0506-324 Cannot mount /dev/hd1 on /home: The requested resource is busy. mount: 0506-324 Cannot mount /proc on /proc: The requested resource is busy. mount: 0506-324 Cannot mount /dev/hd10opt on /opt: The requested resource is busy. mount: 0506-324 Cannot mount /dev/lv09 on /unix_stage: The requested resource is busy. mount: 0506-324 Cannot mount /dev/lv00 on /oracle: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv01 on /oracle/data1: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv02 on /oracle/data2: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv03 on /oracle/data3: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv04 on /oracle/data4: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv05 on /bkup_arch_logs: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv06 on /transfer_edi: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv08 on /apps: A file or directory in the path name does not exist. mount: 0506-324 Cannot mount /dev/lv07 on /non_edi_data: A file or directory in the path name does not exist. # mount /oracle mount: 0506-324 Cannot mount /dev/lv00 on /oracle: A file or directory in the path name does not

exist. # fsck /dev/lv00 fsck: 0506-035 /dev/lv00 is not a known file system. # ls /dev/lv00 ls: 0653-341 The file /dev/lv00 does not exist. # varyoffvg datavg # exportvg datavg # importvg -y datavg hdisk2 datavg # lsvg rootvg datavg # lsvg -l datavg datavg: LV NAME TYPE loglv00 jfslog lv00 jfs lv01 jfs lv02 jfs lv03 jfs lv04 jfs lv05 jfs lv06 jfs lv07 jfs lv08 jfs

LPs PPs 1 1 57 57 92 92 103 103 110 110 149 149 4 4 1 1 1 1 6 6

PVs LV STATE 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd 1 closed/syncd

MOUNT POINT N/A /oracle /oracle/data1 /oracle/data2 /oracle/data3 /oracle/data4 /bkup_arch_logs /transfer_edi /non_edi_data /apps

AIX FS Recovery Maintenance Type the number of your choice and press Enter. >>> 1 Access a Root Volume Group 2 Copy a System Dump to Removable Media 3 Access Advanced Maintenance Functions 4 Install from a System Backup 88 Help ? 99 Previous Menu >>> Choice [1]: 1 Warning: If you choose to access a root volume group, you will not be able to return to the Base Operating System Installation menus without rebooting. Type the number of your choice and press Enter. 0 Continue 88 Help ? >>> 99 Previous Menu >>> Choice [99]: 0 Access a Root Volume Group Type the number for a volume group to display the logical volume information and press Enter. 1) Volume Group 00cdb75d00004c0000000103fba9f700 contains these disks: hdisk1 70006 08-08-00-4,0 hdisk0 70006 08-08-00-3,0 2) Volume Group 00cdb75d00004c00000001040ae47c8c contains these disks: hdisk2 134560 08-08-ff-0,0 Choice: 1 Volume Group Information -----------------------------------------------------------------------------Volume Group ID 00cdb75d00004c0000000103fba9f700 includes the following logical volumes: hd5 hd3 hd6 hd1 hd8 hd10opt hd4 hd2 hd9var fwdump lg_dumplv paging00

paging01 paging02 lv09 lv10 -----------------------------------------------------------------------------Type the number of your choice and press Enter. 1) Access this Volume Group and start a shell 2) Access this Volume Group and start a shell before mounting filesystems 99) Previous Menu Choice [99]: 2 Importing Volume Group... rootvg Checking the / filesystem. log redo processing for /dev/rhd4 syncpt record at 5137028 end of log 5137028 syncpt record at 5137028 syncpt address 5137028 number of log records = 1 number of do blocks = 0 number of nodo blocks = 0 /dev/rhd4 (/): ** Unmounted cleanly - Check suppressed Checking the /usr filesystem. /dev/rhd2 (/usr): ** Unmounted cleanly - Check suppressed Exit from this shell to continue the process of accessing the root volume group. # fsck /dev/hd1 ** Checking /dev/rhd1 (/home) ** Phase 0 - Check Log log redo processing for /dev/rhd1 ** Phase 1 - Check Blocks and Sizes ** Phase 2 - Check Pathnames ** Phase 3 - Check Connectivity ** Phase 4 - Check Reference Counts ** Phase 5 - Check Inode Map ** Phase 6 - Check Block Map 2801 files 986057 blocks 8451127 free # fsck /dev/hd2 ** Checking /dev/rhd2 (/usr) ** Phase 0 - Check Log log redo processing for /dev/rhd2 ** Phase 1 - Check Blocks and Sizes ** Phase 2 - Check Pathnames ** Phase 3 - Check Connectivity

** Phase 4 - Check Reference Counts ** Phase 5 - Check Inode Map ** Phase 6 - Check Block Map 32400 files 10371960 blocks 2473096 free # fsck /dev/hd3 ** Checking /dev/rhd3 (/tmp) ** Phase 0 - Check Log log redo processing for /dev/rhd3 ** Phase 1 - Check Blocks and Sizes ** Phase 2 - Check Pathnames ** Phase 3 - Check Connectivity ** Phase 4 - Check Reference Counts ** Phase 5 - Check Inode Map ** Phase 6 - Check Block Map 1142 files 292240 blocks 1018480 free # fsck /dev/hd4 ** Checking /dev/rhd4 (/) ** Phase 0 - Check Log log redo processing for /dev/rhd4 ** Phase 1 - Check Blocks and Sizes ** Phase 2 - Check Pathnames ** Phase 3 - Check Connectivity ** Phase 4 - Check Reference Counts ** Phase 5 - Check Inode Map ** Phase 6 - Check Block Map 1998 files 194240 blocks 67904 free # fsck /dev/hd9var ** Checking /dev/rhd9var (/var) ** Phase 0 - Check Log log redo processing for /dev/rhd9var ** Phase 1 - Check Blocks and Sizes ** Phase 2 - Check Pathnames ** Phase 3 - Check Connectivity ** Phase 4 - Check Reference Counts ** Phase 5 - Check Inode Map ** Phase 6 - Check Block Map 7096 files 2011784 blocks 2968952 free # fsck /dev/hd10opt ** Checking /dev/rhd10opt (/opt) ** Phase 0 - Check Log log redo processing for /dev/rhd10opt ** Phase 1 - Check Blocks and Sizes ** Phase 2 - Check Pathnames ** Phase 3 - Check Connectivity

** Phase 4 - Check Reference Counts ** Phase 5 - Check Inode Map ** Phase 6 - Check Block Map 581 files 56271 blocks 205873 free # logform /dev/hd8 logform: destroy /dev/hd8 (y)?y # bootlist -m normal -o cd0 rmt0 hdisk0 # df -k Filesystem 1024-blocks Free %Used Iused %Iused Mounted on /dev/ram0 131072 107680 18% 363 1% / /dev/cd0 611836 0 100% 305918 100% /SPOT # bootlist -m normal hdisk0 # bootlist -m service hdisk0 # /usr/sbin/shutdown -rF now # exit Saving special files and device configuration information. Checking and mounting the /tmp filesystem. /dev/rhd3 (/tmp): ** Unmounted cleanly - Check suppressed Checking and mounting the /var filesystem. /dev/rhd9var (/var): ** Unmounted cleanly - Check suppressed Filesystems mounted for maintenance work. # bootlist -m normal -o hdisk0

AIX System Recovery # bootlist -m normal cd0 hdisk0 # bootlist -om normal cd0 hdisk0 # shutdown -Fr Rebooting . . . RIO Configuration +------------- Remote I/O Attachment Summary --------------+ 1 = SMS Menu 8 = Open Firmware Prompt memory keyboard network 5 = Default Boot List 6 = Stored Boot List scsi speaker

STARTING SOFTWARE PLEASE WAIT... Elapsed time since release of system processors: 1 mins 59 secs ------------------------------------------------------------------------------Welcome to AIX. boot image timestamp: 22:26 04/09 The current time and date: 13:52:27 07/23/2004 number of processors: 2 size of memory: 4096Mb boot device: /pci@400000000111/pci@2,2/scsi@1/sd@5:\ppc\chrp\bootfile.exe closing stdin and stdout... ------------------------------------------------------------------------------AIX Version 5.2 Starting NODE#000 physical CPU#001 as logical CPU#001... done. ******* Please define the System Console. ******* Type a 1 and press Enter to use this terminal as the system console. HARDWARE SYSTEM MICROCODE Licensed Internal Code - Property of IBM (C) Copyright IBM Corp. 1990, 1994. All rights reserved. US Government Users Restricted Rights Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp. >>> 1 Type 1 and press Enter to have English during install.

88 Help ? >>> Choice [1]: 1 Welcome to Base Operating System Installation and Maintenance Type the number of your choice and press Enter. Choice is indicated by >>>. >>> 1 Start Install Now with Default Settings 2 Change/Show Installation Settings and Install 3 Start Maintenance Mode for System Recovery 88 Help ? 99 Previous Menu >>> Choice [1]: 3 Maintenance Type the number of your choice and press Enter. >>> 1 Access a Root Volume Group 2 Copy a System Dump to Removable Media 3 Access Advanced Maintenance Functions 4 Install from a System Backup 88 Help ? 99 Previous Menu >>> Choice [1]: 1 Warning: If you choose to access a root volume group, you will not be able to return to the Base Operating System Installation menus without rebooting. Type the number of your choice and press Enter. 0 Continue 88 Help ? >>> 99 Previous Menu >>> Choice [99]: 0 Access a Root Volume Group

Type the number for a volume group to display the logical volume information and press Enter. 1) Volume Group 0059d6ca00004c00000000fb91a3829f contains these disks: hdisk5 34757 1D-08-L hdisk4 34757 1D-08-L hdisk3 34757 1n-08-L hdisk2 34757 1n-08-L 2) Volume Group 0059d6ca00004c00000000fb874a4e3a contains these disks: hdisk1 34715 1S-08-00-9,0 hdisk0 34715 1S-08-00-8,0 Choice: 2 Volume Group Information -----------------------------------------------------------------------------Volume Group ID 0059d6ca00004c00000000fb874a4e3a includes the following logical volumes: hd5 hd6 paging00 hd8 hd4 hd2 hd9var hd3 hd1 hd10opt lg_dumplv fslv00 pinutil -----------------------------------------------------------------------------Type the number of your choice and press Enter. 1) Access this Volume Group and start a shell 2) Access this Volume Group and start a shell before mounting filesystems 99) Previous Menu Choice [99]: 2 Importing Volume Group... rootvg Checking the / filesystem. **************** j2_logredo:end of log 0x44ce2c j2_logredo:syncpt record at 0x1433c j2_logredo:syncpt address 0x1433c j2_logredo:log record count = 34955 j2_logredo:after record count = 19003 j2_logredo:do block count = 455 j2_logredo:nodo block count = 118 /dev/hd4: Superblock is marked dirty (FIXED) Checking the /usr filesystem. **************** Exit from this shell to continue the process of accessing the root volume group.

# logform /dev/hd8 logform: destroy /dev/rhd8 (y)?y # fsck -p /dev/hd1 **************** # fsck -p /dev/hd2 **************** # fsck -p /dev/hd3 **************** # fsck -p /dev/hd4 **************** # fsck -p /dev/hd9var **************** # fsck -p /dev/pinutil **************** # exit Saving special files and device configuration information. Checking and mounting the /tmp filesystem. **************** Checking and mounting the /var filesystem. **************** Filesystems mounted for maintenance work. # df -k Filesystem 1024-blocks Free %Used Iused %Iused Mounted on /dev/ram0 65536 53368 19% 1844 14% / /dev/hd4 65536 53368 19% 1844 14% / /dev/hd2 3014656 1577468 48% 33097 9% /usr /dev/hd3 393216 295708 25% 455 1% /tmp /dev/hd9var 131072 71004 46% 2339 13% /var # lsvg rootvg dbvg # varyonvg dbvg 0516-082 varyonvg: Unable to access a special device file. Execute redefinevg and synclvodm to build correct environment. # lspv hdisk0 hdisk1 hdisk2 0059d6ca0d8bf584 0059d6ca7793e65c 0059d6ca7814ecf6 rootvg rootvg dbvg active active

hdisk3 hdisk4 hdisk5

0059d6ca7814ef34 0059d6ca7814f184 0059d6ca7814f38f

dbvg dbvg dbvg

# redefinevg -d hdisk2 dbvg # synclvodm Usage: synclvodm [-v] [-P] VGname [LVname...] # synclvodm dbvg 0516-010 : Volume group must be varied on; use varyonvg command. 0516-544 synclvodm: Unable to access volume group dbvg. # varyonvg dbvg # synclvodm dbvg # lsvg -l dbvg dbvg: LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT u01 jfs2 200 200 1 closed/syncd /u01 u02 jfs2 200 200 1 closed/syncd /u02 u03 jfs2 200 200 1 closed/syncd /u03 u04 jfs2 200 200 1 closed/syncd /u04 loglv00 jfs2log 1 1 1 closed/syncd N/A # fsck /u01 **************** The current volume is: /dev/u01 **Phase 1 - Check Blocks, Files/Directories, and Directory Entries **Phase 2 - Count links **Phase 3 - Duplicate Block Rescan and Directory Connectedness **Phase 4 - Report Problems **Phase 5 - Check Connectivity **Phase 7 - Verify File/Directory Allocation Maps **Phase 8 - Verify Disk Allocation Maps 13107200 kilobytes total disk space. 1308 kilobytes in 1808 directories. 6083969 kilobytes in 2978 user files. 7018816 kilobytes are available for use. File system is clean. # fsck /u02 **************** The current volume is: /dev/u02 **Phase 1 - Check Blocks, Files/Directories, and Directory Entries **Phase 2 - Count links **Phase 3 - Duplicate Block Rescan and Directory Connectedness **Phase 4 - Report Problems **Phase 5 - Check Connectivity **Phase 7 - Verify File/Directory Allocation Maps **Phase 8 - Verify Disk Allocation Maps

13107200 kilobytes total disk space. 6 kilobytes in 12 directories. 656696 kilobytes in 16 user files. 12448076 kilobytes are available for use. File system is clean. # fsck /u03 **************** The current volume is: /dev/u03 **Phase 1 - Check Blocks, Files/Directories, and Directory Entries **Phase 2 - Count links **Phase 3 - Duplicate Block Rescan and Directory Connectedness **Phase 4 - Report Problems **Phase 5 - Check Connectivity **Phase 7 - Verify File/Directory Allocation Maps **Phase 8 - Verify Disk Allocation Maps 13107200 kilobytes total disk space. 6 kilobytes in 12 directories. 2266944 kilobytes in 16 user files. 10837828 kilobytes are available for use. File system is clean. # fsck /u04 **************** The current volume is: /dev/u04 **Phase 1 - Check Blocks, Files/Directories, and Directory Entries **Phase 2 - Count links **Phase 3 - Duplicate Block Rescan and Directory Connectedness **Phase 4 - Report Problems **Phase 5 - Check Connectivity **Phase 7 - Verify File/Directory Allocation Maps **Phase 8 - Verify Disk Allocation Maps 13107200 kilobytes total disk space. 1383 kilobytes in 983 directories. 13102635 kilobytes in 7927 user files. 0 kilobytes are available for use. File system is clean. # logform /dev/loglv00 logform: destroy /dev/rloglv00 (y)?y # sync # sync # sync # bootlist -m normal -o cd0 hdisk0 # bootlist -m normal hdisk0 # reboot Rebooting . . .

TSM Commands select node_name,filespace_name,stgpool_name,volume_name from volumeusage q vol status=pending Volume Name Storage Device Estimated Pct Volume Pool Name Class Name Capacity Util Status (MB) ---------------- ------------ ---------- ----- -------000001 DR_BKPPOOL 3584CLASS 0.0 0.0 Pending 000092 DR_BKPPOOL 3584CLASS 0.0 0.0 Pending backup image /dev/pcondata27ops tsm> arch /exportdump/cweom/expPREEOM01DEC2005.dmp.Z -archmc=archive0030 Manual Checkin: tsm> move drmedia <volume name> wherestate=vaultret tostate=onsiter tsm> move drmedia <volume name> wherestate=vaultret tostate=onsiter tsm> CHECKIN libvol 3584lib search=bulk checklabel=barcode status=scr tsm> q req tsm> reply <Request No.> Manual Checkout: tsm> checkout libvolume <library_name> <tape no> CHECKLABEL=YES FORCE=NO REMOVE=YES Automatic Checkout: tsm> run drcheckout New LTO Labeling and Checking in: LABEL libvol 3584lib labelsource=barcode search=bulk checkin=scr Space Reclamation: To start space reclamation: tsm> update stgpool <POOL_NAME> reclaim=80 To end (ie., after) Space reclamation: tsm> update stgpool <POOL_NAME> reclaim=100 Auditing: tsm> audit library 3584lib

Dismounting the tape: tsm> dismount vol <TAPE_NO>

DRCHECKOUT move drmedia * wherestate=mountable tostate=vault cmd="Send volume &vol to offsite" cmdfilename=/tmp/drcheckout.txt remove=bulk wait=yes DRCHECKIN move drmedia * wherestate=vaultretrieve tostate=onsiteretrieve cmd="&vol" cmdfilename=/tmp/drcheckin.txt wait=yes checkin libvol 3584lib search=bulk vollist=FILE:/tmp/drcheckin.txt checklabel=barcode status=scr DRBACKUP disable sessions select * from sessions where upper(session_type)='NODE' if (rc_ok) goto reschedule expire inventory wait=yes move data /tsmdb/bkp_diskpool.dsm stgpool=3584_bkppool wait=yes move data /tsmdb/arc_diskpool.dsm stgpool=3584_arcpool wait=yes backup stgpool 3584_bkppool dr_bkppool wait=yes backup stgpool 3584_arcpool dr_bkppool wait=yes backup db devclass=3584class type=full wait=yes backup volhist filenames=/tsmdb/backup/volhist.bkp backup devconf filenames=/tsmdb/backup/devconf.bkp audit license update schedule drbackup type=admin starttime=16:00:00 enable sessions exit reschedule: update schedule drbackup type=admin starttime=now+00:05 exit Server side Query: q script q script DRBACKUP f=d q stgpool query actlog (query the activity log) query admin (display administrator information) query association (query client node associations with a schedule) query auditoccupancy (query client node storage utilization) query backupset (query a backup set) query backupsetcontents (query contents of a backup set) query cloptset (query a client option set) query content (query the contents of a storage pool volume) query copygroup (query copy groups) query datamover (display data mover definitions) query db (display information on the database) query dbbackuptrigger (query the database backup trigger)

query dbvolume (display information on one or more database volumes) query devclass (display information on one or more device classes) query domain (query a policy domain) query drive (query information about a drive) query drmedia (query disaster recovery media) query drmstatus (query disaster recovery manager system parameters) query enabled (query enabled events) query event (query scheduled and completed events) query eventrules (query rules for server or client events) query eventserver (query the event server) query filespace (query one or more file spaces) query library (query a library) query libvolume (query a library volume) query license (display license information) query log (display information on the recovery log) query logvolume (display information on one or more log volumes) query machine (query machine information) query media (query sequential access storage pool media) query mgmtclass (query a management class) query mount (display information on mounted sequential access volumes) query node (query nodes) query occupancy (query client file spaces in storage pools) query option (query server options) query path (display a path definition) query policyset (query a policy set) query process (query one or more server processes) query profile (query a profile) query recoverymedia (query recovery media) query request (query one or more pending mount requests) query restore (query restartable restore sessions) query rpfcontent (query recovery plan file contents stored on a target server) query rpfile (query recovery plan file information stored on a target server) query schedule (query schedules) query script (query tivoli storage manager scripts) query server (query a server) query servergroup (query a server group) query session (query client sessions) query sqlsession (display sql session value) query spacetrigger (query the database or recovery log space triggers) query status (query system parameters) query stgpool (query storage pools) query subscriber (display subscriber information) query subscription (display subscription information) query system (query the system configuration and capacity) query volhistory (display sequential volume history information) query volume (query storage pool volumes) Ex:-

q actlog -begintime=00:00 begindate=today-1 or=cl node=<hostname> q vol status=<STATUS> q vol stgpool 3584_arcpool status=<STATUS> -> displays the filling tapes in arcpool library with filled in size STATUS can be online, offline, filling, full, empty. q volhist type=dbbackup -> To check drbackup completion status

Type DSMC to get into TSM backup client, and tsm> Use the below command for taking backup for the following EG: tsm>arch /nscw1arch_local/cwops_1_12345.arc EG: tsm>arch /nscw1arch_local/cwops_1_12345.arc archmc=archve0030 EG: tsm>arch /nscw1arch_local/cwops_1_12345.arc archmc=archve0090 EG: tsm>arch /nscw1arch_local/cwops_1_12345.arc archmc=archve0365 EG: tsm>arch /nscw1arch_local/cwops_1_12345.arc archmc=archve2225 Backup is completed, if not please escalate appropriate Check the backed up data by using tsm>q arch /nscw1arch_local/cwops_1_12345.arc and it will display the data file with retention time and date. Exit the TSM client by using quit. ============================================================= Login to the server from where you want to restore the data. Use Putty on your system type the IP address of the server At user prompt type user name and password Type DSMC to get into TSM client, it will prompt tsm> Use the below command to check the data availability EG: tsm>q arch /nscw1arch_local/cwops_1_12345.arc Use the below command for restore the data for following tsm>ret /nscw1arch_local/cwops_1_12345.arc tsm>ret /nscw1arch_local/cwops_1_12345.arc /tmp/ Login to the server where you target to restore the data and type #dsmc ret /nscw1arch_local/cwops_1_12345.arc /tmp/ -virtualnode= the system name which you have performed the backup TSM Server Management: Defining Database and Recovery Log Sizes: Size in default: DB Volume (db.dsm) 17 MB LOG Volume (log.dsm) 9 MB Format and define a 500MB DB and 25MB Recoery LOG vol. And extend them by define dbvolume db2.dsm formatsize=500 define logvolume log2.dsm formatsize=25

extend db 500 extend log 25 Increasing Disk Storage Pools: By default, BACKUPPOOL backup.dsm (8 MB) ARCHIVEPOOL archive.dsm (8 MB) SPACEMGPOOL spcmgmt.dsm (8 MB) To create a 100MB volume named sbkp01.dsm in BACKUPPOOL, Define volume backuppool sbkp01.dsm formatsize=100 Adding Administrators: Creating a user named mark with password Missouri and adding him to system class Register admin mark Missouri Grant authority mark classes=system Adding Backup-Archive clients: Registering a node Mercedes where u have already installed TSM client with password montana Register node Mercedes Montana userid=none

Vous aimerez peut-être aussi