Vous êtes sur la page 1sur 17

Problème récurrent avec nVidia (Optimus - Bumblebee)

Contenu | Rechercher | Menus

Ubuntu-fr

Communauté francophone d'utilisateurs d'Ubuntu

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Recherche rapide
Recherche rapide
Forum
Forum
ok
ok
Identifiant Mot de passe connexion
Identifiant
Mot de passe
connexion

/ inscription

AccueilIdentifiant Mot de passe connexion / inscription Documentation Forum Navigation Liste des membres Règles

DocumentationMot de passe connexion / inscription Accueil Forum Navigation Liste des membres Règles Inscription

Forumpasse connexion / inscription Accueil Documentation Navigation Liste des membres Règles Inscription

Navigationconnexion / inscription Accueil Documentation Forum Liste des membres Règles Inscription Identification Liens

Liste des membres/ inscription Accueil Documentation Forum Navigation Règles Inscription Identification Liens de recherche

RèglesAccueil Documentation Forum Navigation Liste des membres Inscription Identification Liens de recherche Messages

InscriptionDocumentation Forum Navigation Liste des membres Règles Identification Liens de recherche Messages récents

IdentificationForum Navigation Liste des membres Règles Inscription Liens de recherche Messages récents Discussions sans

Liens de rechercheListe des membres Règles Inscription Identification Messages récents Discussions sans réponse Planet Annonce

Messages récentsRègles Inscription Identification Liens de recherche Discussions sans réponse Planet Annonce Si vous rencontrez

Discussions sans réponseIdentification Liens de recherche Messages récents Planet Annonce Si vous rencontrez des soucis à rester

Planetde recherche Messages récents Discussions sans réponse Annonce Si vous rencontrez des soucis à rester connecté

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum, déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

automatiquement lors de mes prochaines visites". Pack liberté : venez nous aider à redonner une bonne

Pack liberté : venez nous aider à redonner une bonne odeur de frais à l'internet et à sauver des chatons!

Accueilodeur de frais à l'internet et à sauver des chatons! » Forum Affichage et cartes graphiques

de frais à l'internet et à sauver des chatons! Accueil » Forum Affichage et cartes graphiques

» Forum

Affichage et cartes graphiquesl'internet et à sauver des chatons! Accueil » Forum Problème récurrent avec nVidia (Optimus - Bumblebee)

Problème récurrent avec nVidia (Optimus - Bumblebee)chatons! Accueil » Forum Affichage et cartes graphiques » » Pages : 1 2 3 …

»

»

Pages : 1 2 3 51 Suiv.

#1 Le 08/07/2011, à 13:01

ArchangeGabriel

Problème récurrent avec nVidia (Optimus - Bumblebee)

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

24/01/12: La version 3.0 est disponible depuis le 19 janvier. Beaucoup de changements, modifications de ce post à venir.

Bonjour à tous !

Je suis un des développeurs de Bumblebee, et je viens vous apporter un support francophone.

Si vous possédez un ordinateur doté de la technologie Optimus de nVidia et que vous utilisez Ubuntu, je vous invite à tester Bumblebee.

Qu'est-ce qu'Optimus ?

En fait, Intel intègre depuis janvier 2010 une carte graphique (dite intégrée, et de qualité assez moyenne quoiqu'en pleine progression au fil des générations de processeurs) dans la majorité de ses processeurs pour ordinateur portable.

Si ces cartes graphiques se veulent suffisantes pour une majorité de choses, certaines applications 3D (jeux notamment) nécessitent plus de puissance, c'est pourquoi nVidia et AMD développent des cartes graphiques pour ordinateurs portables, dites cartes dédiées, celles-ci fournissant plus de puissance en échange d'une consommation accrue.

Problème, lorsque nVidia veut rajouter une carte graphique dans ces ordinateurs, l'ordinateur se retrouve avec 2 cartes graphiques complètement différentes, ce qui implique beaucoup plus de consommation qu'avant. nVidia a donc développé Optimus pour permettre d'avoir une carte graphique dédiée sans trop consommer : la carte graphique intégrée s'occupe de l'affichage et des calculs simples, la carte graphique dédiée n'étant alors allumée qu'à la demande pour les calculs lourds.

Le problème est que si nVidia a développé des pilotes (drivers) pour gérer Optimus sous Windows, ils ont complètement laissé tomber Linux (la faute échouant partiellement au serveur d'affichage de Linux, qui se fait un peu vieux (presque 30 ans pour les premières bases), et qui a de plus en plus de mal avec les nouvelles technologies. Wayland sera probablement la solution, mais en attendant, on ne peut rester les bras croisés).

Donc par défaut, sous Linux, les deux cartes graphiques sont allumées en permanence et consomment, alors que seule l'intégrée est utilisée. Et cela est dommageable pour l'autonomie, la carte graphique pouvant représenter jusqu'à 50% de la consommation de l'ordinateur. Il est de plus impossible d'utiliser la carte graphique dédiée, l'installation des pilotes propriétaires (développés par nVidia) résultant au mieux par aucun changement, au pire par une impossibilité pour le système de démarrer correctement. Il ne faut donc surtout pas procéder à leur installation manuelle.

Via Bumblebee, nous voulons réaliser une sorte d'implémentation de la méthode des drivers de Windows : la possibilité d'éteindre la carte graphique dédiée lorsqu'on ne s'en sert pas, et de l'allumer juste pour les calculs "lourds".

Je suis ici pour vous apporter une aide en français et ajouter le support pour le plus de modèle possible. Notamment, je vous demande si vous le voulez bien de poster ici la version d'Ubuntu que vous utilisez ainsi que la marque et le modèle de votre portable.

Guide pour l'installation

Tout d'abord, Bumblebee ne fonctionne actuellement que pour les ordinateurs dotés de la technologie Optimus. Si votre ordinateur est doté de deux cartes graphiques mais n'utilise pas la technologie Optimus (ordinateur plus ancien, comme les Asus UL30Vt, UL50Vt, UL80Vt pour lesquels vous pouvez essayer vga_switcheroo, ou ordinateur très récent utilisant l'une des technologies similaires développées par AMD), Bumblebee ne fonctionnera pas pour vous. Nous

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

envisageons de nous occuper de ces cas plus tard, mais ils ne sont pas notre priorité.

Un prérequis nécessaire est d'utiliser au minimum Ubuntu 10.04 (les versions supportées sont 10.04, 10.10, 11.04 et 11.10). De manière générale, les différents composants matériels présents dans de tels ordinateur nécessitent de toutes façons l'utilisation d'un kernel (noyau du système) récent, et je vous encourage à migrer vers la version 11.04. Nous testons Oneiric Ocelot (11.10) sous toutes les coutures en ce moment, afin d'être sûr de la compatibilité totale dès la sortie.

Si vous êtes encore là, c'est que tout les prérequis sont vérifiés, on peut donc procéder à l'installation.

Guide d'installation d'une version stable

Si tout va bien, vous pouvez maintenant installer bumblebee.

Pour cela, lancez un terminal, puis entrez les commandes suivantes une par une :

sudo apt-add-repository ppa:bumblebee/stable

Si vous souhaitez des drivers nVidia plus récent que ceux disponibles dans les repos d'Ubuntu (mais stables tout de même, et je vous recommande de le faire), ajoutez ce PPA supplémentaire :

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

(A noter pour les intéressés que vous pouvez utiliser le PPA testing des xorg-edgers, à vos risques et périls naturellement, mais je vous confirme qu'il fonctionne avec bumblebee. Comme pour la version dev de Bumblebee, je vous laisse vous débrouiller pour cela.)

sudo apt-get update sudo apt-get install bumblebee

En cas de doute, n'hésitez pas à venir demander ici !

Dans les 3 cas, il faut ensuite entrer dans un terminal (en remplaçant NOMDUTILISATEUR par votre nom d'utilisateur) :

sudo usermod -a -G bumblebee NOMDUTILISATEUR

Pour vérifier si cela marche, plusieurs choses à faire. Premièrement, après l'installation, commencez par redémarrer l'ordinateur pour vérifier qu'aucun problème n'apparaît.

Puis, dans un terminal, entrez ceci :

glxspheres

Un fenêtre apparaît, avec une animation de sphères colorées. Laisser tourner 30s, puis fermez la fenêtre, et notez le résultat.

Puis comparez avec la même chose sur la carte nVidia :

optirun glxspheres

(Notez que la toute première fois, il vous sera peut-être demandé de vous ajouter au groupe bumblebee et de vous déconnecter/reconnecter)

Puis fermez la fenêtre, et notez le résultat.

Normalement, les résultats devraient être largement supérieurs avec optirun (et encore, les performances avec optirun sont limitées par VirtualGL pour ne pas faire de calculs inutiles, i.e. calculer plus d'images que nécessaires. Dans une prochaine version, il y aura une option

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

benchmark pour optirun afin de désactiver cette limitation pour effectuer

ce n'est pas le cas (si les performances avec la carte Intel sont strictement supérieures à celle de

la carte nVidia), postez ici les résultats obtenus, accompagnés de la marque et du modèle de votre ordinateur/carte graphique.

un benchmark !). Si

Sinon, tout fonctionne, et vous l'aurez compris, il suffit de précéder les commandes qu'on veut lancer sur la carte graphique nVidia par optirun. Cela n'est pas optimal comme fonctionnement, mais nous avons pour projet d'améliorer grandement cela.

N'hésitez pas à poser vos questions !

Changelog

Ce changelog commence à la version 2.3, les versions précédentes n'ayant pas réellement de sens.

Version 2.4.1

- Nouvel outil pour le report de bug (aucun changement pour les utilisateurs en gros, principalement pour nous permettre de mieux vous aider)

- Correction d'un bug dans le script cleanup

Version 2.4.0

- Support préliminaire de la gestion d'énergie (ACPI)

- Support de nouveau et nvidia simultanément (nvidia reste le driver par défaut pour le moment, la paquet nouveau des dépôts étant réellement trop vieux)

- Script cleanup amélioré

Version 2.3.1

- Correction d'un bug lors de l'installation via le PPA sur un Ubuntu 32bit avec un serveur X.org multiarch (utilisateurs de xorg-edgers par exemple).

- Ajout d'une fonction manquante conduisant au non-fonctionnement des portables de "type"

DFP-0.

Version 2.3.0

- Ré-écriture complète de Bumblebee:

- Détection automatique des paramètres ne nécessitant plus bumblebee-configuration.

- La configuration se fait désormais totalement hors-ligne, la vitesse en est grandement accrue.

- La gestion énergétique est temporairement supprimée, elle rendait les système instable. Voir ci-dessous.

- Plus besoin d'être root pour utiliser bumblebee, amélioration sur la sécurité donc, c'est

désormais un daemon qui gère le serveur X

- Détection automatique de l'architecture utilisée par les programmes (32 ou 64 bit), il n'est

plus nécessaire d'utiliser optirun32/64 ou optirun -32.

- Ajout de l'option --help pour l'installation, optirun (client) et bumblebee (daemon)

- Option --unattended pour l'installeur

- Bumblebee peut maintenant être packagé simplement grâce aux options d'installation

- Nouveau désinstalleur beaucoup plus propre, arrête le daemon et supprime les fichiers de bumblebee. Les dépendances sont laissées.

- xorg.conf optimisé

- Script cleanup pour nettoyer toutes traces des anciennes versions

- Nettoyage du code, plus d'erreurs

- Suppresion de l'option VGL_READBACK puisque sa valeur ne nécessite pas d'être changée en théorie. Cela peut toujours être utilisé comme variable d'environnement.

- Suppresion de VGL_LOG puisque désormais inutile. L'option --debug-log pour optirun remplace ce paramètre.

- Les erreurs sont loggés : /var/log/bumblebee.log

- Description précise et récupération si possible des erreurs du serveur X

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

- Possibilité de configurer bumblebee pour tourner sur la carte intel en cas d'échec

- Nouvel outil de report de bugs

- Amélioration de la sécurité du serveur X en utilisant une connexion host.

Questions fréquentes

Comment vérifier que la gestion d'énergie (power-management, à savoir éteindre/allumer la carte nVidia) est bien active ?

Si vous avez activé cette fonctionnalité dans Bumblebee, voici comment vérifier qu'elle fonctionne bien. Commencez par débrancher l'alimentation de votre portable pour le faire tourner sur batterie afin de pouvoir relever la valeur de sa consommation.

Ensuite, après un démarrage sans aucune application tournant, ouvrez un terminal et copiez ceci :

grep rate /proc/acpi/battery/BAT0/state

(A noter que BAT0 peut être à remplacer par BAT1 sur certains modèles (voir même un autre chiffre) Notez le résultat.

Dans un nouveau terminal, lancez :

optirun glxspheres

Laissez tourner un peu et pendant ce temps, dans l'autre terminal, relancez la commande précédente (accessible en appuyant sur la touche Flèche HAUT) :

grep rate /proc/acpi/battery/BAT0/state

Notez le résultat.

Comparez les deux résultat, le premier obtenu devrait être amplement inférieur au second. Si ce n'est pas le cas, postez dans ce topic les valeurs obtenues, le modèle de votre ordinateur et les appels ACPI utilisés (contenu des fichiers /etc/bumblebee/card{on,off}).

Ne peut-on pas utiliser exclusivement la carte nVidia, et éteindre la carte Intel ?

Non, cela n'est pas possible pour une raison simple : c'est matériellement impossible. La carte nVidia et la carte Intel sont matériellement connectées entre elles, et seule la carte Intel est connectée à l'écran. Donc l'affichage passe forcément par la carte Intel, il n'est donc pas possible de la désactiver.

EDIT : Il semblerait que quelques modèles commencent à offrir cette possibilité via le BIOS. Affaire à suivre

Je n'ai rien à faire de l'autonomie. Puis-je faire en sorte que mon système tourne entièrement sur la carte nVidia ?

Pour le moment, cela n'est pas possible, mais nous y travaillons. Faire tourner tout le système sur la carte nVidia s'avère pour le moment assez compliqué, mais nous sommes optimistes.

Ce n'est pas très pratique de devoir lancer toutes ses applications 3D via le terminal. Ne peut-on pas avoir un mode automatique ?

C'est en fait exactement ce que font les drivers nVidia sous Windows : ils comparent les applications lancées avec une liste, et si les applications apparaissent dans la liste, alors elles doivent tourner sur la carte nVidia. Nous travaillons également à une implémentation de ce système.

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Par ailleurs, vous pouvez modifier la commande des raccourcis de vos bureaux/menus/lanceurs et ajouter optirun devant le contenu présent.

Pourrait-on avoir un bouton visuel pour switcher de cartes graphiques à la demande ? C'est à dire, je clique sur le bouton, et à partir de ce moment, toutes les applications sont lancées sur la cartes nVidia, jusqu'à ce que je reclique sur le bouton.

Nous y travaillons aussi, mais comme pour faire tourner l'intégralité du système, cela s'avère assez compliqué.

Je n'arrive pas à accéder au Panneau de Configuration nVidia (nvidia-settings) (ou il me dit que je n'utilise pas la carte nvidia). Que faire ? Tout d'abord, si on vous conseille d'utiliser nvidia-xconfig, ne le faites pas !

En fait, le Panneau de Configuration nVidia ne détecte votre carte que si le fichier xorg.conf utilisé est celui de celle-ci et que de plus le serveur X.org sur lequel le Panneau tourne est géré par cette carte. Ces conditions font qu'il n'est pas possible d'utiliser le Panneau de Configuration nVidia tel quel pour le moment, nous réfléchissons aux différentes options qui s'offrent à nous pour contourner ce problème.

En attendant, vous pouvez tout de même y accéder, en utilisant la commande suivante :

optirun nvidia-settings -c :8

(Utilisateurs avancés, si vous avez changé la valeur de VGL_DISPLAY, il faut la changer ici aussi)

Je n'arrive pas à utiliser mon port DVI et/ou HDMI. Est-ce lié à Optimus ?

Très certainement. A moins qu'il ne s'agisse d'un problème simple dont les solutions existent déjà, votre port HDMI est probablement relié à la carte nVidia. Nous avons beaucoup de travaux à faire de ce point de vue là, car pour le moment, il est impossible d'utiliser un tel port HDMI sous Linux. Cependant, nous avons trouvé quelques premières pistes, et l'acquisition récente (le 17/10/2011) d'un écran avec un port HDMI devrait me permettre d'avancer sur ce point.

Les performances avec la carte nVidia ne me semblent pas énormes. Est-ce normal ?

Si vous parlez des performances de glxspheres, tant qu'elle sont supérieures à celle de la carte Intel et au moins à environ 60 FPS, on ne peut pas dire qu'il y a un problème.

Normalement, les résultats devraient être largement supérieurs avec optirun, mails les performances sont limitées par VirtualGL pour ne pas faire de calculs inutiles, i.e. calculer plus d'images que nécessaires. Dans une prochaine version, il y aura une option benchmark pour

optirun afin de désactiver cette limitation pour effectuer

un benchmark.

Si en revanche ce n'est pas le cas (si les performances avec la carte Intel sont strictement supérieures à celle de la carte nVidia), postez ici les résultats obtenus, accompagnés de la marque et du modèle de votre ordinateur/carte graphique.

De même, pour toute application graphiques, plaignez-vous uniquement si les performances de la carte nVidia sont inférieurs à celles de la Intel, ou paraissent vraiment trop faibles pour votre modèle.

Puis-je vous aider ?

Volontiers ! Que vous ayez des connaissances approfondies ou même basiques, votre aide est la bienvenue. Il est cependant recommandé de pratiquer l'anglais assez facilement, tout se faisant dans la langue de Shakespeare. Si vous êtes intéressés, faites un tour sur GitHub, lisez ce qui s'y trouve et proposez vos idées. Le chan IRC #bumblebee-dev sur Freenode est là pour parler entre

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

développeurs également, n'hésitez pas à aller y faire un tour si vous voulez aider.

Pour ceux qui se demanderaient où est passée la procédure de soumission des tables ACPI qui se trouvait ici, elle a été purement et simplement supprimée, car la 3.0 la rendra inutile (tout du moins sous cette forme), et que la sortie de cette version étant proche, nous n'avons plus le temps d'analyser des tables pour les utilisateurs de la version 2.4.

La documentation Ubuntu-fr ne semble vraiment pas à jour. Pourquoi ? C'est un domaine qui évolue très vite, et je suis actuellement en train de la réécrire complètement. La nouvelle version devrait-être en ligne prochainement, probablement avec la version 3.0 de Bumblebee.

Divers

J'ajouterais d'ici peu de nouvelles QRs ici (à propos de vga_switcheroo, de l'utilisation de nouveau avec Bumblebee, et de pleins d'autres choses liées à ce thème).

Si vous avez la moindre question, n'hésitez par à la poser dans la suite de ce topic. Si vous vous la posez, d'autres sont probablement dans la même situation. Donc pour obtenir le meilleur pour tous, exprimez-vous ! Si vous êtes nombreux à vous poser une question, c'est aussi probablement qu'il y a un problème ou qu'elle devrait être ajoutée ici.

Remerciements à Martin Juhl pour avoir initié ce projet !

Dernière modification par ArchangeGabriel (Le 24/01/2012, à 23:15)

Hors ligne

#2 Le 11/07/2011, à 13:43

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Up, post mis à jour ! Peut-être pourrait-on épingler ce topic, je pense qu'il doit concerner un nombre important de personnes, et cela va aller en empirant.

Hors ligne

#3 Le 11/07/2011, à 13:47

gwlegion

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

faudrais metre en titre: solution au probleme nvidia sur ordinateur recent trouver !

ca aiderais a le

deplus plusieures question me viennent a l'esprit apres avoir testé la bete.

y'a il moyen de forcer l'utilisation d'un GPU de facon definitive ? j'entends pas la de selectionner en debut de session ou alors de parametrer dans un fichier texte l'utilisation unique du GPU nvidia. Apres tout, le GPU intel ne m'interesse pas !

Perso, je pense que je vais changer completement de technique: je vais reinstaller mon PC en

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

windows (je sais c'est mal, mais si le materiel est mieux geré ce que faut pas deconner quand meme!

) et installer une VM ubuntu

par

Dernière modification par gwlegion (Le 11/07/2011, à 14:06)

Hors ligne

#4 Le 11/07/2011, à 15:02

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

gwlegion a écrit :

faudrais metre en titre: solution au probleme nvidia sur ordinateur recent a le trouver !

ca aiderais

deplus plusieures question me viennent a l'esprit apres avoir testé la bete.

y'a il moyen de forcer l'utilisation d'un GPU de facon definitive ? j'entends pas la de selectionner en debut de session ou alors de parametrer dans un fichier texte l'utilisation unique du GPU nvidia. Apres tout, le GPU intel ne m'interesse pas !

Perso, je pense que je vais changer completement de technique: je vais reinstaller mon

) et installer une

VM ubuntu

PC en windows (je sais c'est mal, mais si le materiel est mieux geré

par ce que faut pas deconner quand meme!

Je mettais à jour le premier post avec les réponses à une partie de ces questions pendant que tu as modifié ton message

Pour information, je ne suis pas de ceux qui te diront Windows c'est mal, car c'est le système que j'utilise principalement et ce par choix. Enfin si, je dirait que Windows c'était mal, mais ça évolue plutôt bien, Windows 7 est très convaincant.

Enfin, j'ai réussi il y a quelques mois à faire dire à des puristes du libres qui n'étaient pas capable de m'aider pour Optimus et pour cause, il était alors difficile d'envisager la moindre solution, ne serait-ce que pour éteindre le carte graphique, "Installe Windows".

Hors ligne

#5 Le 11/07/2011, à 15:06

gwlegion

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

j'ai oublié un point super hyper mega important lors de mon dernier post :

Un enorme merci pour ce travail qui doit s'averer collosal.

Hors ligne

#6 Le 11/07/2011, à 15:18

Problème récurrent avec nVidia (Optimus - Bumblebee)

CapitainePipo

récurrent avec nVidia (Optimus - Bumblebee) CapitainePipo http://forum.ubuntu-fr.org/viewtopic.php?id=565321 Re :

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Salut !

Cool.Il faudra que je réinstalle Ubuntu 11.04 avant de tester ça car je l'ai bien bousillé mon linux avec les drivers Nvidia. ^^ Alors pour ma part j'ai un ASUS N53S Series, carte Nvidia Geforce GT550M (cuda 2GB). Et j'ai installé ubuntu 11.04 en dual boot.

La carte Nvidia utilisera bien le driver propriétaire Nvidia ?

@ gwlegion > y a pas forcément besoin d'une carte nvidia pour faire tourner libre office ou autre logiciel basic. Sinon on peut surement mettre "optirun64" dans un raccourci qui se lance automatiquement dans le terminal. Enfin j'espère. ^^

Dernière modification par CapitainePipo (Le 11/07/2011, à 15:19)

Mon portfolio

SAV Blender

Hors ligne

#7 Le 11/07/2011, à 15:20

slasher-fun

Blender Hors ligne #7 Le 11/07/2011, à 15:20 slasher-fun Re : Problème récurrent avec nVidia (Optimus

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

ArchangeGabriel a écrit :

Up, post mis à jour ! Peut-être pourrait-on épingler ce topic, je pense qu'il doit concerner un nombre important de personnes, et cela va aller en empirant.

Non mais si tu demandes pas visiblement aussi

en empirant. Non mais si tu demandes pas visiblement aussi Allez hop. Hors ligne #8 Le

Allez hop.

Hors ligne

#8 Le 11/07/2011, à 15:24

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

CapitainePipo a écrit :

Salut !

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Cool.Il faudra que je réinstalle Ubuntu 11.04 avant de tester ça car je l'ai bien bousillé mon linux avec les drivers Nvidia. ^^ Alors pour ma part j'ai un ASUS N53S Series, carte Nvidia Geforce GT550M (cuda 2GB). Et j'ai installé ubuntu 11.04 en dual boot.

La carte Nvidia utilisera bien le driver propriétaire Nvidia ?

@ gwlegion > y a pas forcément besoin d'une carte nvidia pour faire tourner libre office ou autre logiciel basic. Sinon on peut surement mettre "optirun64" dans un raccourci qui se lance automatiquement dans le terminal. Enfin j'espère. ^^

Alors pour ce qui est du N53S, que ce soit un N53Sn ou un N53Sv, nous avons même déjà les fonctions d'extinction/allumage de la carte graphique.

La carte nVidia utilisera bien le driver propriétaire nVidia comme je l'explique dans mon premier post.

Enfin, il suffit effectivement dans n'importe quel raccourci de cliquer sur Propriétés, et dans le champ correspondant à la commande lancée de rajouter optirun (ou optirun32/64 selon le cas) pour que le lancement passe par optirun. Et même pas besoin de terminal dans ce cas.

Hors ligne

#9 Le 11/07/2011, à 17:59

spikiq

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Bonjour, je fais la manipulation pour installer bumblebee (euh sympa le nom d'ailleurs

donc j'ai vu qu'il y avait déjà des configurations comme mon pc (N61JV) mais c'est pas précisé si

ce sont ceux avec core i3 ou i5 etc

fanêtre qui me dit "system is working", c'est censé durer longtemps ça? Parce que là ça fait déjà bien 5 minutes, donc j'voulais savoir si c'était normal quoi. Par ailleurs, tout à l'heure j'ai redémarré mon PC (pensant que l'installe était fini, fenêtre toujours là) et au redémarrage, lea commande "sudo apt-get install" ne fonctionnait plus ! j'ai du faire une manip qui m'était décrite pour configurer apkg (j'ai pas compris, mais ensuite j'ai pu relancer l'installe de bumblebee, celle qui est en route actuellement). En tout cas, merci pour votre travail ! Car mon pc ne fonctionne bien que sur Linux ! (SSD OCZ Vertex II 60Go, 8Go DDR3 Crucial, core i3-370M 2.4Ghz, GT325M 1Go) Mille mercis, et bonne continuation !

bref),

enfin bon j'ai lancé celui là quand même, et ensuite, il y a la

Dernière modification par spikiq (Le 11/07/2011, à 18:00)

Hors ligne

#10 Le 11/07/2011, à 18:04

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Non ce n'est pas normal et cela explique le problème rencontré au démarrage, apt était encore en train d'installer un package donc il ne pouvait rien faire d'autre.

Problème récurrent avec nVidia (Optimus - Bumblebee)

Je vais voir ce que je peux faire sur ce point.

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Pour la configuration précise du N61Jv, cela n'a aucune importance, tous utilisant la même carte graphique nVidia.

Dernière modification par ArchangeGabriel (Le 11/07/2011, à 18:05)

Hors ligne

#11 Le 11/07/2011, à 18:34

spikiq

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Ok merci, réponse rapide et infos pertinentes, j’apprécie ton implication des gens qui sont à fond dans leur projet !

ton implication des gens qui sont à fond dans leur projet ! Ca fait plaisir de

Ca fait plaisir de voir

EDIT: après avoir laissé tourner un moment (le temps d'un repas) j'ai fini par appuyer simplement sur "entrer", les commandes se sont bien terminées, et j'ai pu finir la procédure d'installation proprement ! C'est cool ! Merci Par contre, petite question, bumblebee fait-il en sorte à ce que la CG ne soit pas utilisée tant qu'elle n'est pas conviée par "optirun64"? Car je la sent toujours tourner, et ma batterie descend toujours aussi vite ^^ (enfin, à vue d'oeil, je verrais après une charge complète)

à vue d'oeil, je verrais après une charge complète) Dernière modification par spikiq (Le 11/07/2011, à

Dernière modification par spikiq (Le 11/07/2011, à 19:27)

Hors ligne

#12 Le 11/07/2011, à 22:29

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Pour information, c'est la première fois que je teste la version du PPA (ce n'était pas mon boulot) et j'utilise d'habitude mon fork git pour cela. Effectivement, l'interface d'installation n'est pas des plus accueillantes, et je comprends le problème que tu as eu.

Pour ce qui est de ta question, normalement oui Bumblebee fait cela. Cependant, il faut pour cela que les scripts bumblebee-enablecard et bumblebee-disablecard soient bien remplis.

Ils sont situés dans /usr/local/bin/, et les tiens devraient être identiques à ceux-ci :

https://github.com/MrMEEE/bumblebee/blo … 61Jv.N73Sv https://github.com/MrMEEE/bumblebee/blo … 61Jv.N73Sv

Hors ligne

#13 Le 11/07/2011, à 22:50

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Problème récurrent avec nVidia (Optimus - Bumblebee)

slasher-fun a écrit :

ArchangeGabriel a écrit :

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Up, post mis à jour ! Peut-être pourrait-on épingler ce topic, je pense qu'il doit concerner un nombre important de personnes, et cela va aller en empirant.

Non mais si tu demandes pas visiblement aussi

Je n'avais même pas vu ce post

Merci d'avoir épinglé !

Hors ligne

pas vu ce post Merci d'avoir épinglé ! Hors ligne Allez hop. #14 Le 12/07/2011, à

Allez hop.

#14 Le 12/07/2011, à 15:24

CapitainePipo

ligne Allez hop. #14 Le 12/07/2011, à 15:24 CapitainePipo Re : Problème récurrent avec nVidia (Optimus

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Merci pour la réponse. J'ai réinstaller Ubuntu 11.04 hier soir pour partir sur une base saine. Je rencontre une erreur lorsque que souhaite lancer glxgears avec optirun64 :

terminal a écrit :

luke@luke-N53SN:~$ optirun64 glxgears [sudo] password for luke:

* Starting Bumblebee X server bumblebee

/bumblebee: 117: /usr/local/bin/bumblebee-enablecard: not found

[ OK ]

* Stopping Bumblebee X server bumblebee

/bumblebee: 117: /usr/local/bin/bumblebee-disablecard: not found

luke@luke-N53SN:~$

[ OK ]

/etc/init.d

/etc/init.d

not found luke@luke-N53SN:~$ [ OK ] /etc/init.d /etc/init.d Lors de l'installation j'avais le choix entre

Lors de l'installation j'avais le choix entre plusieurs configuration, j'ai fait le choix de faire une configuration personnel plus tard (dernier choix de la liste). Le problème pourrait t'il venir de là ?

Merci d'avance.

Mon portfolio

SAV Blender

Hors ligne

#15 Le 12/07/2011, à 15:28

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Oui, le problème vient de là. Si Bumblebee n'est pas configuré, il ne risque pas de marcher

Pour le configurer, fais :

sudo bumblebee-configuration

Hors ligne

#16 Le 12/07/2011, à 15:43

CapitainePipo

Hors ligne #16 Le 12/07/2011, à 15:43 CapitainePipo Re : Problème récurrent avec nVidia (Optimus -

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Merci beaucoup c'est parfait !!!! Trop puissant Bumblebee.

Voici mes résultats :

14135 mW

glxgears = 60.230 FPS

Voici mes résultats : 14135 mW glxgears = 60.230 FPS optirun64 glxgears = 324 or 296

optirun64 glxgears = 324 or 296 FPS

14091 mW

C'est incroyable ! Joli travail !

or 296 FPS 14091 mW C'est incroyable ! Joli travail ! Mon portfolio SAV Blender Hors

Mon portfolio

SAV Blender

Hors ligne

#17 Le 12/07/2011, à 15:47

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Ok, il reste juste un petit détail, ta carte graphique n'étant pas éteinte apparemment.

Tu peux redonner la consommation de la batterie lorsqu'optirun ne tourne pas ?

Et je vais avoir besoin de toi pour quelques infos supplémentaires si tout marche.

Hors ligne

#18 Le 12/07/2011, à 16:09

CapitainePipo

infos supplémentaires si tout marche. Hors ligne #18 Le 12/07/2011, à 16:09 CapitainePipo 13 sur 17

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Okay ça roule.

récurrent avec nVidia (Optimus - Bumblebee) Okay ça roule. Après redémarrage d'Ubuntu j'ai lancé plusieurs

Après redémarrage d'Ubuntu j'ai lancé plusieurs fois la commande "grep rate /proc/acpi/battery /BAT0/state", voici les résultats :

15169

mW

16973

mW

13915

mW

14652

mW

14388

mW

14993

mW

Après avoir lancé Blender (avec optirun64) est subdivé plusieurs fois le cube présent dans la scène 3D :

20251

mW

18821

mW

J'ai subdivisé encore plus le cube pour demander plus de puissance graphique :

28710 mW

18667 mW (résultat obtenu quelques minutes après le précèdent)

J'ai dupliqué le cube 4 fois pour demandé encore plus de puissance graphique :

30041 mW

18568 mW (résultat obtenu quelques minutes après le précèdent)

Résultat après avoir quitté Blender :

18359

mW

18106

mW

19173

mW

Je peux refaire d'autres tests.

Dernière modification par CapitainePipo (Le 12/07/2011, à 16:10)

Mon portfolio

SAV Blender

Hors ligne

#19 Le 12/07/2011, à 16:11

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Peux-tu me donner le contenu des scripts bumblebee-enablecard et bumblebee-disablecard ? (Upload les quelque part et met un lien ici)

Hors ligne

#20 Le 12/07/2011, à 16:31

CapitainePipo

Problème récurrent avec nVidia (Optimus - Bumblebee)

Problème récurrent avec nVidia (Optimus - Bumblebee) http://forum.ubuntu-fr.org/viewtopic.php?id=565321 Re : Problème

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Yes voila les liens :

bumblebee-disablecard

bumblebee-enablecard

Mon portfolio

SAV Blender

Hors ligne

#21 Le 12/07/2011, à 16:38

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Ok, alors tout devrait être bon.

Pour de futurs améliorations, pourrais-tu faire les choses suivantes :

sudo apt-get install acpidump iasl

mkdir ~/acpiinfo ; cd ~/acpiinfo

sudo acpidump > acpidump.txt

sudo acpixtract acpidump.txt

ls *.dat | while read i; do iasl -d "${i}"; done && name=`sudo dmidecode -s system-product-name`

mkdir "${name}" && cp *.dsl "${name}"/ && tar czf "${name}.tar.gz" "${name}"/ && ls -l "$( pwd )/${name}".tar.gz

Et uploader l'archive créée.

Aussi, peux-tu donner le résultat de :

sudo dmidecode -s system-version

Merci.

Dernière modification par ArchangeGabriel (Le 13/07/2011, à 11:33)

Hors ligne

#22 Le 12/07/2011, à 17:17

spikiq

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Re : Problème récurrent avec nVidia (Optimus - Bumblebee) Bonjour En effet, les scripts sont les

Bonjour En effet, les scripts sont les mêmes ! Et ça marche du tonnerre ! Après une charge complète et

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

une heure d'utilisation, il me restait encore 2h et quelques ! C'est parfait Et pour ce qui est de la configuration de bumblebee, une interface graphique serait sympathique peut-être, mais je ne doute pas que ça ira en s'améliorant Dernière petite question qui me semble importante:

Si bumblebee voit sa version s'améliorer, y'a-t-il une commande à faire pour le mettre à jour? Merci pour votre boulot, c'est énorme !

mettre à jour? Merci pour votre boulot, c'est énorme ! Hors ligne #23 Le 12/07/2011, à
mettre à jour? Merci pour votre boulot, c'est énorme ! Hors ligne #23 Le 12/07/2011, à

Hors ligne

#23 Le 12/07/2011, à 17:19

ArchangeGabriel

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Nous n'avons que des améliorations prévues au programme

n'avons que des améliorations prévues au programme Pour ce qui est des mises à jour de

Pour ce qui est des mises à jour de bumblebee, elles sont proposées de la même manière que les mises à jour de n'importe quel paquet du système.

Hors ligne

#24 Le 12/07/2011, à 17:53

spikiq

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

Alors c'est parfait, je vous souhaite bon courage

Hors ligne

c'est parfait, je vous souhaite bon courage Hors ligne #25 Le 13/07/2011, à 11:31 CapitainePipo Re

#25 Le 13/07/2011, à 11:31

CapitainePipo

Hors ligne #25 Le 13/07/2011, à 11:31 CapitainePipo Re : Problème récurrent avec nVidia (Optimus -

Re : Problème récurrent avec nVidia (Optimus - Bumblebee)

J'ai une erreur dans le terminal lors de la 4ème étape :

terminal a écrit :

luke@luke-N53SN:~/acpiinfo$ ls *.dat | while read i; do iasl -d "${i}"; done && name=`sudo dmidecode -s system-product-name` ls: impossible d'accéder à *.dat: Aucun fichier ou dossier de ce type

Que faire ?

Problème récurrent avec nVidia (Optimus - Bumblebee)

http://forum.ubuntu-fr.org/viewtopic.php?id=565321

SAV Blender

Hors ligne

Pages : 1 2 3 51 Suiv.

AccueilSAV Blender Hors ligne Pages : 1 2 3 … 51 Suiv. » Forum Affichage et

Blender Hors ligne Pages : 1 2 3 … 51 Suiv. Accueil » Forum Affichage et

» Forum

Affichage et cartes graphiquesHors ligne Pages : 1 2 3 … 51 Suiv. Accueil » Forum Problème récurrent avec

Problème récurrent avec nVidia (Optimus - Bumblebee)51 Suiv. Accueil » Forum Affichage et cartes graphiques » » Haut de page ↑ Pied

»

»

Haut de page ↑

Pied de page des forums

Atteindre

Affichage et cartes graphiques Aller
Affichage et cartes graphiques
Aller

Flux RSS de la discussion

Propulsé par FluxBB

Contactcartes graphiques Aller Flux RSS de la discussion Propulsé par FluxBB Ressources Licences 17 sur 17

Ressourceset cartes graphiques Aller Flux RSS de la discussion Propulsé par FluxBB Contact Licences 17 sur

Licencescartes graphiques Aller Flux RSS de la discussion Propulsé par FluxBB Contact Ressources 17 sur 17