Vous êtes sur la page 1sur 93

Module 1 :

Introduction to Classless Routing


CCNA 3 version 3.1
Philippe Dastroy
IEPSA aot 2006
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
2
Introduction
Dfinir VLSM et brivement dcrire les raisons de lemployer.
Diviser un grand rseau en sous-rseaux de diffrentes tailles en
employant VLSM.
Dfinir la route agrgation and summarization et leur rapport
avec VLSM.
Configurer un routeur pour VLSM.
Dcrire les caractristiques principales de RIP v1 et RIP v2 .
Dcrire les grandes diffrences entre RIP v1 et RIP v2 .
Configurer RIP v2
Vrifier et dpanner RIP v2.
Configurer des routes par dfaut en utilisant les commandes ip
route and ip default-network.
Advanced IP Management
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
4
Rappel : classes d'adresses IPv4
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
5
Rappel : classes d'adresses IPv4
Problmes :
Pas de rseau de taille moyenne
Au dbut dinternet, les adresses IP ont t attribues aux
organisations sur demande au lieu de selon leurs besoins.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
6
Rappel : classes d'adresses IPv4
Adresses de classe D
Une adresse de classe D commence avec 1110 binaire dans le premier octet.
Premier octet de 224 239.
Les adresses de classe D peuvent tre utilises pour reprsenter un groupe
dhtes aussi appel groupe multicast.
Adresses de classe E
le premier octet commence avec 1111.
Les adresses de classe E sont rserve un usage exprimental et ne
peuvent pas tre utilise pour dsigner des htes ou des groupes multicast.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
7
Adresses prives (RFC 1918)
Si on adresse ce qui suit, on peu employer des adresses prives la place dadresses
globales uniques:
Un intranet
Un labo
Un rseau domestique
Les adresse globales doivent tres obtenues auprs dun provideur avec certains frais.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
8
La crise d'adressage IP
Manque dadresses
Explosion de la taille des tables de routage Internet
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
9
Rappel : classes d'adresses IPv4
Subnet Mask
Une solution au manque dadresses IP est le
masque de sous-rseau.
Standardis en 1985 (RFC 950), le masque de
sous-rseau divise un rseau de classe A, B
ou C en plus petits rseaux ( sous-rseaux ).
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
10
Exemple de sous-rseau
Soit le rseau de classe B 190.52.0.0 :
Using /24
subnet...
190.52.1.2
190.52.2.2
190.52.3.2
Network Network Subnet Host
Mais les routeurs internes savent
que toutes ces adresses sont
dans des rseaux diffrents,
appels des sous-rseaux.
Les routeurs Internet continuent de voir ce
rseau comme 190.52.0.0
Class B Network Network Host Host
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
11
Exemple de sous-rseau
En utilisant le 3 ime octet, 190.52.0.0 est divis en :
190.52.1.0 190.52.2.0 190.52.3.0 190.52.4.0
190.52.5.0 190.52.6.0 190.52.7.0 190.52.8.0
190.52.9.0 190.52.10.0 190.52.11.0 190.52.12.0
190.52.13.0 190.52.14.0 190.52.15.0 190.52.16.0
190.52.17.0 190.52.18.0 190.52.19.0 etc ...
Network Network Subnet Host
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
12
Exemple de sous-rseau
Adresse rseau 190.52.0.0 avec un masque de sous-
rseau /16
Network Network Subnet Host
190 52 0 Host
190 52 1 Host
190 52 2 Host
190 52 3 Host
190 52 Etc. Host
190 52 254 Host
190 52 255 Host
255
Subnets
2
S
- 1
Subnets
Utilisation de sous-rseaux: mask 255.255.255.0 or /24
On ne peut pas
utiliser le dernier
sous-rseau car c'est
l'adresse de
broadcast.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
13
Exemple de sous-rseau
Le problme du sous-rseau 0 (sous-rseau avec tous des
0): ladresse du sous-rseau, 190.52.0.0/24 est la mme
que le rseau principal, 190.52.0.0/16.
Network Network Subnet Host
190 52 0 Host
190 52 1 Host
190 52 254 Host
190 52 Etc. Host
190 52 255 Host
255
Subnets
2
S
- 1
Subnets
Le problme du dernier sous-rseau (sous-rseau avec tous
des 1): ladresse de broadcast pour le sous-rseau,
190.52.255.255 est la mme que pour le rseau principal,
190.52.255.255.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
14
Sous-rseaux tout 0 et tout 1
Utilisation des sous-rseaux tout 1 et tout 0 :
Il ny a pas de commande pour activer ou dsactiver lutilisation du sous-rseau
tout 1, il est activ par dfaut.
Pour le sous-rseau tout 0, pour les version dIOS avant la 12.0, il faut activer
lusage du sous-rseau 0 avec la commande :
Router(config)#ip subnet-zero
A partir de lIOS 12.0 il est activ doffice.
La RFC 1878 indique, La pratique dexclure les sous-rseaux tout 1 et tout 0 est
obsolte! Les softwares modernes sont capables dutiliser tous les sous-rseaux
disponibles." De nos jours, lutilisation du sous-rseau 0 et du sous-rseau tout 1 est
en gnral accept et la plupart des fabriquants supportent leur usage. Cependant, sur
certain rseaux, principalement ceux qui emploient des softwares anciens, leur
utilisation peut amener de srieux problmes.
A lire : Subnet 0 and the all 1 subnet
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
15
Solution court terme : extensions d'IPv4
CIDR (Classless Inter-Domain Routing) RFCs
1517, 1518, 1519, 1520
VLSM (Variable Length Subnet Mask) RFC
1009
Adressage priv - RFC 1918
NAT/PAT (Network Address Translation / Port
Address Translation)
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
16
Solution long terme : IPv6
IPv6, ou IPng (IP the Next Generation) utilise un
adressage 128-bit, ce qui donne
340,282,366,920,938,463,463,374,607,431,768,211,4
56
adresses possibles.
IPv6 a mis du temps pour arriver.
IPv4 revitalis par les nouvelles possibilits (sous-
rseaux, adresses prives, VLSM) fait que IPv6
ntait pas ncessaire de suite.
IPv6 demande de nouveaux softwares; le personnel
IT doit se mettre niveau
IPv6 coexistera surement pendant de nombreuses
annes avec IPv4.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
17
CIDR (Classless Inter-Domain Routing)
En 1992, les membres de lIETF ont rencontr de srieux problmes
cause de la croissance exponantielle dInternet et de ce fait de la
croissance des tables de routages.
LIETF tait aussi inquiet cause de lpuisement ventuel de
lespace dadresses sur 32 bits dIPv4.
Des projections ont t faites et cela indiqu un tat critique au
niveau de 1994 ou 1995.
La rponse de lIETF tait le concept de Supernetting (agrgation) ou
CIDR, cider.
Pour les routeurs compatibles CIDR, les classes dadresses ne
signifient rien.
La partie rseau de ladresse est dtermine par le masque de sous-
rseau ou le prfixe (/8, /19, etc.)
Les premiers bits de la partie rseau ne sont pas utiliss pour dterminer
les parties rseau et hte de ladresse.
CIDR aide rduire la taille des tables de routage dinternet grace au
supernetting et la rallocation dadresses IPv4.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
18
CIDR (Classless Inter-Domain Routing)
Dploy en 1994, CIDR a fortement amlior ladaptabilit
et lefficacit dIPv4 car il:
limine les traditionnelles classes A, B, C permettant ainsi une
meilleure allocation des adresses IPv4.
Supporte laggrgation de routes (summarization), aussi appele
supernetting, o des milliers de routes peuvent tre reprsentes
par une seule dans la table de routage.
Laggrgation aide aussi viter le route flapping sur les routeurs
internet utilisant BGP. Des Flapping routes peuvent poser de
srieux problmes sur les routeurs principaux dInternet.
CIDR permet aux routeurs dagrger, ou de rsumer, les
informations de routage et de ce fait de rduire la taille de
leur tables de routage.
Juste une combinaison adresse/masque peut reprsenter les
routes vers une multitude de rseaux.
Utilis par les routeurs IGP dans un AS et par les routeurs EGP
entre les AS.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
19
Sans CIDR, un
routeur doit
maintenir des
entres de table
de routage
individuelles
pour ces
rseaux de
classe B.
Avec CIDR, un
routeur peut
summariser
ces routes en
utilisant une
seule adresse
avec un prfixe
/13:
172.24.0.0 /13
1. Compter le nombre de bits gauche correspondants, /13 (255.248.0.0)
2. Ajouter tous des 0 aprs le dernier bit correspondant:
172.24.0.0 = 10101100 00011000 00000000 00000000
Etapes:
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
20
CIDR (Classless Inter-Domain Routing)
En utilisant un prfixe pour rsumer les routes, les administrateurs
peuvent limiter la taille des tables de routage, ce qui signifie:
un routage plus efficace.
Un nombre rduit de cycles CPU lors dun nouveau calcul dune
table de routage, ou lors de la consultation pour trouver un chemin.
moins de mmoire ncessaire pour les routeurs.
Le fait de rsumer des routes est aussi appel :
Agrgation de routes
Supernetting
Supernetting est essentiellement linverse du dcoupage en sous-
rseau.
CIDR enlve une autorit centrale (InterNIC) la responsabilit
dattribuer les adresse.
En effet, les ISP se voient attribuer des blocs dadresses quils
dcoupent comme ils le veulent pour les attribuer leurs clients,
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
21
Exemple d'aggrgation :
La socit XYZ a besoin de 400 adresses dhtes.
Son ISP lui donne deux rseaux contigus de classe C:
207.21.54.0/24
207.21.55.0/24
La socit XYZ peut utiliser un prfixe de 207.21.54.0 /23 pour
rsumer ses deux rseaux contigus. (contenants 510 adresses htes)
207.21.54.0 /23
207.21.54.0/24
207.21.55.0/24
23 bits in common
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
22
Avec lISP agissant comme lautorit dattribution pour un bloc
dadresses CIDR, le rseau du client de lISP, la socit XYZ, peut
tre annonc sur internet comme un seul supernet.
Supernetting Exemple
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
23
Un autre exemple dagrgation de routes.
CIDR et le Provider
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
24
200.199.48.32/27 11001000 11000111 00110000 0 0100000
200.199.48.64/27 11001000 11000111 00110000 0 1000000
200.199.48.96/27 11001000 11000111 00110000 0 1100000
200.199.48.0/25 11001000 11000111 00110000 0 0000000
(aussi longtemps quil ny a pas de route ailleurs dans le mme range ..)
200.199.56.0/24 11001000 11000111 0011100 0 00000000
200.199.57.0/24 11001000 11000111 0011100 1 00000000
200.199.56.0/23 11001000 11000111 0011100 0 00000000
CIDR et le provider
200.199.56.0/23
200.199.48.0/25
Agrgation chez le
client vers son
provider.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
25
CIDR et le provider
200.199.48.0/25
200.199.56.0/23
200.199.48.0/25 11001000 11000111 0011 0000 00000000
200.199.49.0/24 11001000 11000111 0011 0001 00000000
200.199.56.0/23 11001000 11000111 0011 1000 00000000
200.199.48.0/20 11001000 11000111 0011 0000 00000000
20 bits en commun
Agrgation supplmentaire
vers le provider suivant.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
26
Les protocoles de routage dynamiques doivent
envoyer ladresse rseau et le masque (prfixe)
dans leurs mises jour de routage.
En dautres mots, CIDR demande lemploi de
protocoles de routage dynamiques classless .
On peut aussi agrger des routes statiques.
Restrictions de CIDR
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
27
172.16.2.0/24
Merida reoit une mise jour de route aggrge /16 de Quito et une mise
jour de route /24 plus spcifique de Cartago.
Merida incluera les deux routes dans sa table de routage.
Merida transmettra tous les paquets correspondant au moins aux 24 premiers
bits de 172.16.5.0 Cartago (172.16.5.0/24) = longest-bit match.
Merida transmettra tout les paquets correspondant au moins aux 16 premiers
bits de 172.16.0.0/16 Quito.
Routes agrges et routes spcifiques : Longest-bit Match
172.16.10.0/24
172.16.1.0/24
172.16.5.0/24
172.16.0.0/16 172.16.5.0/24
Summarized Update Specific Route Update
Merida
Quito Cartago
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
28
Exemple
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
29
Exemple
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
30
VLSM (Variable Length Subnet Mask)
La limitation demployer un seul masque de sous-
rseau pour un rseau donn fait quune socit
est bloque avec un nombre fixe de sous-rseaux
de taille fixe.
1987, la RFC 1009 spcifie comment un sous-
rseau peut employer plus dun masque de sous-
rseau.
VLSM = Subnetting a Subnet
Si vous savez calculer les sous-rseaux, vous savez
faire du VLSM!
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
31
VLSM - Exemple simple
Diviser un rseau /8 en employant un masque de /16 nous
donne 256 sous-rseaux avec 65,536 htes par sous-rseau.
Prenons le sous-rseau 10.2.0.0/16 et divisons le de nouveau.
10.0.0.0/8
10.0.0.0/16
10 Host Host Host
10 Subnet Host Host
1st octet 2nd octet 3rd octet 4th octet
10.0.0.0/16 10 0 Host Host
10.1.0.0/16 10 1 Host Host
10.2.0.0/16 10 2 Host Host
10.n.0.0/16 10 Host Host
10.255.0.0/16 10 255 Host Host
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
32
VLSM - Exemple simple
Note: 10.2.0.0/16 est maintenant un rsum de
tous les sous-rseaux 10.2.0.0/24 .
10.2.0.0/16 10 2 Host Host
Network Subnet Host Host
10.2.0.0/24 10 2 Subnet Host
10.2.0.0/24 10 2 0 Host
10.2.1.0/24 10 2 1 Host
10.2.n.0/24 10 2 Host
10.2.255.0/24 10 2 255 Host
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
33
Exemple simple de VLSM
10.0.0.0/8 divis en employant /16
Sous-rseau 1er hte Dernier hte Broadcast
10.0.0.0/16 10.0.0.1 10.0.255.254 10.0.255.255
10.1.0.0/16 10.1.0.1 10.1.255.254 10.1.255.255
10.2.0.0/16 divis en employant /24
Sous-rseau 1er hte Dernier hte Broadcast
10.2.0.0/24 10.2.0.1 10.2.0.254 10.2.0.255
10.2.1.0/24 10.2.1.1 10.2.1.254 10.2.1.255
10.2.2.0/24 10.2.2.1 10.2.2.254 10.2.2.255
Etc.
10.2.255.0/24 10.2.255.1 10.2.255.254 10.2.255.255
10.3.0.0/16 10.3.0.1 10.3.255.254 10.0.255.255
Etc.
10.255.0.0/16 10.255.0.1 10.255.255.254 10.255.255.255
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
34
Exemple simple de VLSM
Votre rseau a donc maintenant 255 /16 sous-rseaux avec 65,534 htes
chacun ET 256 /24 sous-rseaux avec 254 htes chacun.
Tout ce quil faut faire pour que cela marche cest employer un protocole
de routage classless qui enverra le masque de sous-rseau avec
ladresse rseau dans les mises jour de routage.
Protocoles de routage Classless : RIPv2, EIGRP, OSPF, IS-IS, BGPv4
Sous-rseaux
10.0.0.0/16
10.1.0.0/16
10.2.0.0/16
10.2.0.0/24
10.2.1.0/24
10.2.2.0/24
Etc.
10.2.255.0/24
10.3.0.0/16
Etc.
10.255.0.0/16
10.1.0.0/16
Un exemple de VLSM, mais un mauvais design
rseau.
10.3.0.0/16
10.4.0.0/16 10.5.0.0/16
10.6.0.0/16
10.7.0.0/16
10.2.0.0/24
10.2.3.0/24
10.2.4.0/24
10.2.5.0/24
10.2.8.0/24
10.8.0.0/16
10.2.6.0/24
10.2.1.0/24
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
35
Exemple VLSM
Le rseau 207.21.24.0/24 est divis en huit sous-rseau /27
(255.255.255.224)
Ce rseau a donc sept sous-rseaux /27 avec 30 htes chacun
ET huit sous-rseau/30 avec 2 htes chacuns.
Les sous-rseaux /30 sont trs utiles pour les liens srie.
Le sous-rseau 207.21.24.192/27, est divis en huit
sous-rseaux /30 (255.255.255.252)
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
36
207.21.24.192/27 207.21.24. 11000000
/30 Hosts Bcast 2 Hosts
0 207.21.24.192/30 207.21.24. 110 00000 01 10 11 .193 & .194
1 207.21.24.196/30 207.21.24. 110 00100 01 10 11 .197 & .198
2 207.21.24.200/30 207.21.24. 110 01000 01 10 11 .201 & .202
3 207.21.24.204/30 207.21.24. 110 01100 01 10 11 .205 & .206
4 207.21.24.208/30 207.21.24. 110 10000 01 10 11 .209 & .210
5 207.21.24.212/30 207.21.24. 110 10100 01 10 11 .213 & .214
6 207.21.24.216/30 207.21.24. 110 11000 01 10 11 .217 & .218
7 207.21.24.220/30 207.21.24. 110 11100 01 10 11 .221 & .222
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
37
207.21.24.192/30
207.21.24.196/30
207.21.24.200/30
207.21.24.204/30
207.21.24.208/30 207.21.24.212/30
207.21.24.32/27
207.21.24.64/27
207.21.24.96/27
207.21.24.128/27
207.21.24.160/27 207.21.24.224/27
207.21.24.0/27
207.21.24.216/30
Ce rseau a sept sous-rseaux /27 avec 30 htes chacun ET
sept sous-rseaux /30 avec 2 htes chacun (il en reste 1).
Les sous-rseaux /30 avec 2 htes par sous-rseau ne
gaspillent pas dadresses sur des liens srie.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
38
VLSM et table de routage
Table de routage sans VLSM
RouterX#show ip route
207.21.24.0/27 is subnetted, 4 subnets
C 207.21.24.192 is directly connected, Serial0
C 207.21.24.196 is directly connected, Serial1
C 207.21.24.200 is directly connected, Serial2
C 207.21.24.204 is directly connected, FastEthernet0
Table de routage avec VLSM
RouterX#show ip route
207.21.24.0/24 is variably subnetted, 4 subnets, 2 masks
C 207.21.24.192 /30 is directly connected, Serial0
C 207.21.24.196 /30 is directly connected, Serial1
C 207.21.24.200 /30 is directly connected, Serial2
C 207.21.24.96 /27 is directly connected, FastEthernet0
La route Parent montre le masque classfull.
Chaque route enfant affiche son masque de sous-rseau.
Affiche 1 masque de sous-rseau pour toutes les routes enfant .
Le masque classfull est employ pour la route parent.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
39
Notes finales sur VLSM
Tant que possible, il est prfrable de grouper les routes
contiges pour quelles puissent tre agrges par les
Upstream Routers
Si toutes les routes contiges ne sont pas ensembles, les
tables de routage utilisent the longest-bit match qui
autorise le routeur choisir la route la plus spcifique par
rapport une route agrge.
Vous pouvez avoir diffrentes tailles de sous-rseaux
avec VLSM.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
40
Route flapping
Un route flapping arrive quand linterface dun routeur alterne rapidement entre
ltat up et ltat down.
Le route flapping peut paralyser un routeur cause dune quantit excessive
dupdates et de calculs supplmentaires.
Cependant, lagrgation protge les autres routeurs du problme de flapping
sur RTC.
La perte dun rseau nannule pas la route vers le supernet 200.199.56.0/21.
Pendant que RTC est occup avec sa route qui flappe, RTZ, et tous les
routeurs suivant, ne sont pas conscients des problmes en downstream.
Lagrgation isole les autres routeurs du problme de route flapping.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
41
Sous-rseaux non contigus
Mlanger des adresses prives avec des adresses
publiques peut entraner des sous-rseaux non contigus
Des sous-rseaux non contigus, sont des sous-rseaux
dun mme rseau qui sont spars par un rseau ou un
sous-rseau tout fait diffrent.
Question: si un protocole de routage classfull comme RIPv1 ou IGRP
est employ, quoi les updates ressembleront entre le routeur du site
A et le routeur du site B ?
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
42
Sous-rseaux non-contigus
Les protocoles de routage classfull tels que RIPv1 et IGRP, ne supportent pas
des sous-rseaux non contigus, car le masque de sous-rseau nest pas
inclus dans les mises jour de routage.
RIPv1 et IGRP ramnent automatiquement la classful.
Le Site A et le Site B envoient tous les deux ladresse classfull
207.21.24.0/24.
Un protocole de routage classless (RIPv2, EIGRP, OSPF) sera ncessaire
pour:
Ne pas agrger au rseau classfull
Inclure le masque de sous-rseau dans les mises jour de routage.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
43
Sous-rseaux non-contigus
RIPv2 et EIGRP agrge automatiquement la classfull ( fonction auto-
summary).
Quand on emploie RIPv2 et EIGRP, pour arrter lauto-summary,
taper sur les deux routeurs:
Router(config-router)#no auto-summary
Le site B reoit maintenant 207.21.24.0/27
Le Site A reoit maintenant 207.21.24.32/27
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
44
Network Address Translation (NAT)
NAT: Network Address Translatation
NAT, comme dfinis par la RFC 1631, est le processus de
remplacer une adresse ipar une autre dans len-tte du
paquet IP.
En pratique, NAT est employ pour autoriser des htes
ayant une adresse prive daccder internet.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
45
Network Address Translation (NAT)
Les translations NAT peuvent tre statiques ou dynamiques.
La fonction la plus puissante de NAT est sa possibilit demployer port address
translation (PAT), qui permet de multiples adresses internes de sortir sur la mme
adresse globale.
On appelle cela parfois many-to-one NAT .
Avec PAT, ou ladresse overloading , en thorie, des centaines dadresse prives
peuvent aller sur internet avec une seule adresse globale.
Le routeur NAT garde une trace des diffrentes conversation en employant les nde
ports TCP et UDP.
2.2.2.2 TCP Source Port 1923
2.2.2.2 TCP Source Port 1924
TCP Source Port 1026
TCP Source Port 1026
Classless Routing Protocols
RIPv2
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
47
Classless routing protocols
La principale caractristique qui dfinit un
protocole de routage classless est sa capacit de
transporter le masque de sous-rseau dans ses
annonces de routes . Jeff Doyle, Routing TCP/IP
Un des bnfices davoir un masque associ
avec chaque route est le fait que les sous-rseaux
tout 0 et tout 1 sont maintenant utilisables.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
48
Classless Routing Protocols
Bnfices:
Sous-rseaux tout 0 et tout 1 utilisables
Cependant certains fabriquants, entre autres Cisco, le permet
aussi avec un protocole de routage classful.
VLSM
On peut avoir des sous-rseaux discontinus
Meilleure utilisation des adresses IP
CIDR
plus de contrle sur le rsum des routes
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
49
RIP version 1
0 1 2 3 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| command (1) | version (1) | must be zero (2) |
+---------------+---------------+-------------------------------+
| address family identifier (2) | must be zero (2) |
+-------------------------------+-------------------------------+
| IP address (4) |
+---------------------------------------------------------------+
| must be zero (4) |
+---------------------------------------------------------------+
| must be zero (4) |
+---------------------------------------------------------------+
| metric (4) |
+---------------------------------------------------------------+
Protocole de routage Classful, envoie sur le port UDP n520
Ninclus pas le masque de sous-rseau dans ses mises jour de
routage.
Rsum automatique sur le rseau principal par le routeur de
bordure.
Les mises jour sont envoyes en broadcasts sauf si la commande
neighbor a t employe, dans ce cas, elles sont envoyes en unicast.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
50
Rappels RIPv1
Internet est un ensemble de systmes autonomes (SA). En rgle gnrale, chaque SA est
administr par une entit unique. Chaque SA a sa propre technologie de routage, qui peut
tre diffrente de celle des autres systmes autonomes. Le protocole de routage utilis au
sein dun SA est appel IGP (Interior Gateway Protocol). Un protocole distinct, appel
EGP (Exterior Gateway Protocol), est utilis pour transfrer des informations de routage
entre diffrents systmes autonomes. Le protocole RIP a t conu pour fonctionner
comme un IGP dans un SA de taille moyenne. Il nest pas cens tre utilis dans des
environnements plus complexes.
RIP v1 est considr comme un protocole IGP par classes (classful).
RIP v1 est un protocole vecteur de distance qui diffuse intgralement sa table de routage
chaque routeur voisin, intervalles prdfinis. Lintervalle par dfaut est de 30 secondes.
RIP utilise le nombre de sauts comme mtrique, avec une limite de 15 sauts maximum.
Si le routeur reoit un paquet pour un membre dun rseau principal directement connect,
le routeur applique le masque de sous-rseau configur sur linterface connecte ce
rseau. Si ce nest pas pour un rseau principal connect, cest le masque par dfaut de la
classe qui est employ.
Pour les adresses de classe A, le masque de classe par dfaut est 255.0.0.0.
Pour les adresses de classe B, le masque de classe par dfaut est 255.255.0.0.
Pour les adresses de classe C, le masque de classe par dfaut est 255.255.255.0.
RIP v1 est un protocole de routage trs populaire car il est compatible avec tous les
routeurs IP. Son succs repose essentiellement sur sa simplicit et sa compatibilit
universelle. RIP v1 est capable de grer lquilibrage de charge ( load balancing ) sur
maximum six chemins de cot gal, avec une valeur de quatre chemins par dfaut.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
51
Rappel : configuration de RIPv1
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
52
Classful route lookups :
Quand un paquet entre dans un routeur tournant sous RIP et quune
consultation de la table de routage a lieu, les diffrents choix dans la
table sont limins un par un jusqu ce quil ne reste plus quun
chemin possible.
En premier, la partie rseau de ladresse de destination est lue et
compare la table de routage pour trouver une correspondance.
Cest cette premire tape de lecture de ladresse du rseau principal
de classe A,B ou C qui dfinit une consultation classful de la table de
routage.
Sil ny a pas de correspondance pour le rseau principal, le paquet
est jet et un message ICMP Destination Unreachable est envoy
la source du paquet.
Sil y a une correspondance pour la partie rseau, la liste des sous-
rseaux pour ce rseau est examine.
Sil y a une correspondance, le paquet est rout.
Sil ny a pas de correspondance pour un sous-rseau, le paquet est
jet et un message ICMP Destination Unreachable est envoy la
source du paquet.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
53
Classless route lookups :
Par dfaut, les routeurs Cisco font du classful
route lookup. On peut modifier cela avec la
commande globale ip classless.
Quand un routeur fait de la consultation de route
classless (classless route lookup), il ne fait pas
attention la classe du rseau de destination. A la
place, il fait une comparaison bit par bit et il
cherche la meilleure correspondance avec ses
routes. Ce comportement sera utile lors de
lemploi de route par dfaut (voir plus loin).
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
54
Routage classful / classful route lookup
Il faut bien se mettre en tte que le routage
classful nest pas la mme chose que le classful
route lookup.
Routage = faon de concevoir la table de routage
Lookup = faon de la consulter
On peut faire du lookup classless sur une table
classful et aussi du lookup classful sur une table
classless.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
55
Classful routing et sous-rseaux directement connects
La table de routage dun routeur contient les rseaux :
10.0.0.0 255.255.0.0 is subnetted, 9 subnets :
C 10.5.0.0
. -
172.25.0.0 255.255.255.0 is subnetted, 3 subnets
R 172.25.153.0
R 172.25.131.0
C 172.25.15.0
Si un paquet arrive avec ladresse de destination 192.168.35.3, il ny a
pas de correspondance avec la table de routage et le paquet est jet.
Si un paquet arrive avec ladresse de destination 172.25.33.89, il y a
correspondance pour le rseau de classe B 172.25.0.0 . De ce fait, les
sous-rseau sont consults et comme il ny a pas de correspondance
pour le sous-rseau 172.25.33.0, le paquet est jet.
Si un paquet arrive avec ladresse de destination 172.25.153.220, il y
aura une correspondance avec le sous-rseau 172.25.153.0 et le
paquet sera transfr ladresse next-hop correspondante.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
56
Classful routing et sous-rseaux directement connects
Comme il na pas de masque avec ladresse des sous-
rseaux dans la table de routage, le routeur ne peut pas
savoir o dans ladresse 172.25.131.23 les bits de sous-
rseau terminent et mme sil y a un sous-rseau.
La seule solution pour le routeur est destimer que le
masque configur sur ses interfaces attaches au rseau
172.25.0.0 est employ partout dans le rseau global.
Si le rseau nest pas directement connect, il ny a que le
masque par dfaut qui est employ.
Donc, comme le protocole classful emploie le masque
local, il faut absolument que le masque de sous-rseau
soit le mme partout.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
57
Classful routing et rsum sur le routeur de bordure
Comment un processus RIP interprte-til les sous-rseaux
dun rseau principal qui nest pas directement reli une
de ses interfaces?
Comme on la dit plus haut, il ne sait pas linterprter !
Cependant la solution est simple : si le routeur nest pas
directement attach au rseau, il a seulement besoin dun
route pointant vers un routeur directement attach ce
rseau. Celui-ci sera capable de dterminer les sous-
rseau par le principe vu plus haut.
Sur cette base, un routeur de frontire nenverra quune
route rsume vers lautre rseau
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
58
RIP version 2
0 1 2 3 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| command (1) | version (1) | must be zero (2) |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Address Family Identifier (2) | Route Tag (2) |
+-------------------------------+-------------------------------+
| IP Address (4) |
+---------------------------------------------------------------+
| Subnet Mask (4) |
+---------------------------------------------------------------+
| Next Hop (4) |
+---------------------------------------------------------------+
| Metric (4) |
+---------------------------------------------------------------+
Protocole de routage Classless, envoie sur le port UDP n520
Inclus le masque de sous-rseau dans les mises jour de routage.
Le rsum automatique sur le routeur de bordure peut tre annul.
Les mises jour sont envoyes en multicast sauf si la commande neighbor a
t employe, dans ce cas, elles sont emvoyes en unicast.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
59
Caractristiques de RIPv2
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
60
Caractristiques de RIPv2
RIP v2 est une version amliore de RIP v1. Les deux protocoles partagent un
certain nombre de caractristiques:
Il sagit dun protocole vecteur de distance utilisant le nombre de sauts comme
mtrique.
Il utilise des compteurs de retenue pour empcher les boucles de routage (valeur
par dfaut: 180 secondes).
Il utilise la rgle split horizon pour empcher les boucles de routage.
Il utilise 16 sauts comme mtrique de mesure infinie.
RIP v2 prsente une fonctionnalit de routage CIDR lui permettant denvoyer
des informations sur les masques de sous-rseau avec la mise jour des
routes. Par consquent, RIP v2 prend en charge le routage CIDR qui permet
diffrents sous-rseaux du mme rseau dutiliser des masques de sous-
rseau distincts, comme dans VLSM.
RIP v2 permet lauthentification dans ses mises jour. Il est possible dutiliser
une combinaison de cls sur une interface comme vrification
dauthentification. RIP v2 permet de choisir le type dauthentification utiliser
dans les paquets RIP v2. Il peut sagir de texte en clair ou dun cryptage bas
sur lalgorithme dauthentification MD5. Le type dauthentification par dfaut
est le texte en clair. Lalgorithme MD5 peut tre utilis pour authentifier la
source dune mise jour de routage. MD5 est gnralement utilis pour le
cryptage des mots de passe enable secret et n'a pas d'algorithme de
rversibilit connu.
Pour une meilleure efficacit, RIP v2 utilise ladresse de classe D 224.0.0.9
pour envoyer les mises jour de routage en multicast.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
61
Comparaison des version 1 et 2 de Rip
Le protocole RIP utilise des algorithmes vecteur de distance pour
dterminer la direction et la distance jusqu une liaison quelconque
de linterrseau. Sil existe plusieurs chemins vers une destination, le
protocole RIP slectionne celui qui comporte le moins de sauts.
Toutefois, comme le nombre de sauts est la seule mtrique de routage
utilise par le protocole RIP, il nest pas garanti que le chemin
slectionn soit le plus rapide.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
62
Comparaison des version 1 et 2 de Rip
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
63
Comparaison des version 1 et 2 de Rip
RIP v1 permet aux routeurs de mettre jour leurs tables de routage des
intervalles programmables. Lintervalle par dfaut est de 30 secondes. Lenvoi
continu de mises jour de routage par RIP v1 signifie que le trafic rseau
augmente rapidement. Pour viter quun paquet ne tourne en boucle
indfiniment, le protocole RIP limite le nombre de sauts 15 maximum. Si le
rseau de destination se trouve une distance de plus de 15 routeurs, on
considre que ce rseau est inaccessible et le paquet est abandonn. Se
pose alors la question de lvolutivit pour le routage au sein dimportants
rseaux htrognes. RIP v1 utilise la rgle split horizon pour empcher les
boucles de routage. Cela signifie que RIP v1 annonce les routes en sortie
dune interface uniquement lorsquelles nont pas t apprises via des mises
jour en entre de cette interface. Le protocole utilise des compteurs de
retenue pour empcher les boucles de routage. Les hold down timers
permettent dignorer les nouvelles informations provenant dun sous-rseau en
affichant une moins bonne mtrique au cours du dlai de retenue.
La figure de la page prcdente rsume le comportement de RIP v1 lorsque
ce dernier est utilis par un routeur.
RIP v2 est une version amliore de RIP v1. Ils ont beaucoup de fonctions
communes. RIP v2 est galement un protocole vecteur de distance qui
utilise le nombre de sauts, les compteurs de retenue et la rgle split horizon.
La figure de la page suivante compare RIP v1 et RIP v2.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
64
Comparaison des version 1 et 2 de Rip
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
65
Configuration de Rip version 2 :
RIP v2 est un protocole de routage dynamique configur en spcifiant le protocole de routage RIP
Version 2, puis en attribuant des numros de rseau IP sans prciser de valeurs de sous-rseau.
Cette section dcrit les commandes de base permettant de configurer RIP v2 sur un routeur Cisco.
Pour activer un protocole de routage dynamique, il suffit d'accomplir les tches suivantes:
Slectionner un protocole de routage tel que RIP v2.
Attribuer des numros de rseau IP sans prciser de valeurs de sous-rseau.
Attribuer des adresses de rseau ou de sous-rseau et le masque de sous-rseau appropri aux interfaces.
RIP v2 utilise des messages de diffusion multicast pour communiquer avec les autres routeurs. La mtrique de
routage aide les routeurs trouver le meilleur chemin menant chaque rseau ou sous-rseau.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
66
Configuration de Rip version 2 :
La commande router lance le processus de routage. La commande network entrane la
mise en uvre des fonctions suivantes:
Diffusion multicast des mises jour de routage en sortie dune interface.
Traitement des mises jour de routage en entre de cette mme interface.
Annonce du sous-rseau directement connect cette interface.
La commande network est ncessaire, car elle permet au processus de routage de dterminer
les interfaces qui participeront l'envoi et la rception des mises jour du routage. Cette
commande lance le protocole de routage sur toutes les interfaces que comporte le routeur sur le
rseau spcifi. Elle permet aussi au routeur dannoncer ce rseau.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
67
Exemple de configuration de RIPv2 :
La combinaison des commandes router rip et version 2 dsigne RIPv2 comme
protocole de routage, alors que la commande network identifie un rseau attach qui
participe au routage.
Dans cet exemple, la configuration du routeur A inclut les commandes suivantes:
router rip Active RIP comme le protocole de routage
version 2 Dsigne la version 2 comme la version de RIP qui doit tre utilise
network 172.16.0.0 Spcifie un rseau directement connect.
network 10.0.0.0 Spcifie un rseau directement connect.
Les interfaces du routeur A, connectes aux rseaux 172.16.0.0 et 10.0.0.0 (ou leurs sous-
rseaux), envoient et reoivent les mises jour du protocole RIP v2. Ces mises jour
permettent au routeur d'apprendre la topologie du rseau. Les configurations RIP des routeurs B
et C sont similaires mais leurs numros de rseau sont diffrents.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
68
Autre exemple
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
69
Exemple plus concret
Scnario:
Sous-rseaux discontinus
VLSM
CIDR
Supernet vers 207.0.0.0/8
e0
ISP
SantaCruz2 SantaCruz1
192.168.4.20/30
172.30.1.0/24
Internet
s0
s0 s0
s1
172.30.100.0/24
e0
192.168.4.24/30
.21
.22
.25
.26
10.0.0.0/8
e0 .1
.1 .1
Lo0
Lo0
172.30.110.0/24
172.30.2.0/24
.1
.1
.1
static route to
207.0.0.0/8
207.0.0.0/16
207.1.0.0/16
207.2.0.0/16
207.3.0.0/16
etc.
`
172.30.200.16/28
172.30.200.32/28
Lo1
Lo2
Avec auto-summary
activ par dfaut sur
les routeurs, le
routeur ISP fera du
load balancing pour
tous les paquets
destins
172.30.0.0/16
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
70
SantaCruz1
router rip
network 172.30.0.0
network 192.168.4.0
version 2
no auto-summary
SantaCruz2
router rip
network 172.30.0.0
network 192.168.4.0
version 2
no auto-summary
ISP
router rip
redistribute static
network 10.0.0.0
network 192.168.4.0
version 2
no auto-summary
ip route 207.0.0.0 255.0.0.0 null0
e0
ISP
SantaCruz2 SantaCruz1
192.168.4.20/30
172.30.1.0/24
Internet
s0
s0 s0
s1
172.30.100.0/24
e0
192.168.4.24/30
.21
.22
.25
.26
10.0.0.0/8
e0 .1
.1 .1
Lo0
Lo0
172.30.110.0/24
172.30.2.0/24
.1
.1
.1
static route to
207.0.0.0/8
207.0.0.0/16
207.1.0.0/16
207.2.0.0/16
207.3.0.0/16
etc.
`
172.30.200.16/28
172.30.200.32/28
Lo1
Lo2
RIPv2 Example
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
71
e0
ISP
SantaCruz2 SantaCruz1
192.168.4.20/30
172.30.1.0/24
Internet
s0
s0 s0
s1
172.30.100.0/24
e0
192.168.4.24/30
.21
.22
.25
.26
10.0.0.0/8
e0 .1
.1 .1
Lo0
Lo0
172.30.110.0/24
172.30.2.0/24
.1
.1
.1
static route to
207.0.0.0/8
207.0.0.0/16
207.1.0.0/16
207.2.0.0/16
207.3.0.0/16
etc.
`
172.30.200.16/28
172.30.200.32/28
Lo1
Lo2
SantaCruz2#show ip route
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
R 172.30.2.0/24 [120/2] via 192.168.4.21, 00:00:21, Serial0
R 172.30.1.0/24 [120/2] via 192.168.4.21, 00:00:21, Serial0
C 172.30.100.0/24 is directly connected, Ethernet0
C 172.30.110.0/24 is directly connected, Loopback0
192.168.4.0/30 is subnetted, 2 subnets
R 192.168.4.24 [120/1] via 192.168.4.21, 00:00:21, Serial0
C 192.168.4.20 is directly connected, Serial0
R 10.0.0.0/8 [120/1] via 192.168.4.21, 00:00:21, Serial0
R 207.0.0.0/8 [120/1] via 192.168.4.21, 00:00:21, Serial0
Examen de la table de routage
Supernet, les protocoles de routage
classless routent des supernets
(CIDR)
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
72
RIPv2: envoi et rception des updates
ISP#debug ip rip
RIP protocol debugging is on
ISP#01:23:34: RIP: received v2 update from 192.168.4.22 on Serial1
01:23:34: 172.30.100.0/24 -> 0.0.0.0 in 1 hops
01:23:34: 172.30.110.0/24 -> 0.0.0.0 in 1 hops
ISP#
01:23:38: RIP: received v2 update from 192.168.4.26 on Serial0
01:23:38: 172.30.2.0/24 -> 0.0.0.0 in 1 hops
01:23:38: 172.30.1.0/24 -> 0.0.0.0 in 1 hops
ISP#
01:24:31: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (10.0.0.1)
01:24:31: 172.30.2.0/24 -> 0.0.0.0, metric 2, tag 0
01:24:31: 172.30.1.0/24 -> 0.0.0.0, metric 2, tag 0
01:24:31: 172.30.100.0/24 -> 0.0.0.0, metric 2, tag 0
01:24:31: 172.30.110.0/24 -> 0.0.0.0, metric 2, tag 0
01:24:31: 192.168.4.24/30 -> 0.0.0.0, metric 1, tag 0
01:24:31: 192.168.4.20/30 -> 0.0.0.0, metric 1, tag 0
<text omitted>
ISP(config)# line console 0
ISP(config-line)# logging synchronous
Envoi en
multicast
Le masque est inclus
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
73
Ajouter une route par dfaut RIPv2
e0
ISP
SantaCruz2 SantaCruz1
192.168.4.20/30
172.30.1.0/24
Internet
s0
s0 s0
s1
172.30.100.0/24
e0
192.168.4.24/30
.21
.22
.25
.26
10.0.0.0/8
e0 .1
.1 .1
Lo0
Lo0
172.30.110.0/24
172.30.2.0/24
.1
.1
.1
static route to
207.0.0.0/8
207.0.0.0/16
207.1.0.0/16
207.2.0.0/16
207.3.0.0/16
etc.
`
172.30.200.16/28
172.30.200.32/28
Lo1
Lo2
ISP
router rip
redistribute static
network 10.0.0.0
network 192.168.4.0
version 2
no auto-summary
default-information originate
ip route 207.0.0.0 255.0.0.0 null0
ip route 0.0.0.0 0.0.0.0
ethernet0
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
74
Autres commandes RIPv2 (EXTRA)
Router(config-router)# neighbor ip-address
Dfinis un routeur voisin avec lequel changer les updates en
unicast. (RIPv1 ou RIPv2)
Router(config-if)# ip rip send|receive version 1 |
2 | 1 2
Configuration dune interface pour envoyer/recevoir des paquets
RIPv 1 et/ou RIPv2
Router(config-if)# ip summary-address rip
ip_address ip_network_mask
Spcifie les adresses et masque des routes rsumer (rsum
manuel)
Autres commandes et exemples dans :
www.dastroy.be/Materiel Cisco CCNA 3/Configuring RIP.pdf
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
75
Vrification de RIPv2 :
Les commandes show ip protocols et show ip route affichent des informations sur les protocoles de routage et sur
la table de routage.
La commande show ip protocols affiche les valeurs des protocoles de routage et les informations relatives aux
compteurs de routage associes ce routeur. Le routeur de l'exemple est configur avec RIP et envoie des mises
jour de la table de routage toutes les 30 secondes. Il est possible de configurer cet intervalle. Si un routeur RIP ne
reoit pas de mise jour dun autre routeur pendant au moins 180 secondes, le premier routeur dclare non valides
les routes desservies par le routeur qui nenvoie pas de mise jour. Dans la figure, le compteur de retenue est de 180
secondes. Par consquent, la mise jour dune route qui, aprs avoir t indisponible redevient disponible, pourrait
rester gele pendant 180 secondes.
Si aucune mise jour na eu lieu aprs un dlai de 240 secondes, le routeur supprime les entres correspondantes
dans la table de routage. Le routeur insre des routes pour les rseaux rpertoris sous la ligne Routing for Networks.
Le routeur reoit des routes des routeurs RIP voisins, rpertoris sous la ligne Routing Information Sources. La
distance par dfaut de 120 correspond la distance administrative dune route RIP.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
76
Limitations de RIPv2 et de RIPv1
Convergence lente et besoin demployer le
mcanisme holddown timers (compteur de
retenue) pour rduire les risques de boucles de
routage
Voyez les notes de CCNA pour plus de dtail.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
77
Limitations de RIPv2 et de RIPv1
RIP v2 continue dpendre du compte linfinis pour
pouvoir rsoudre certaines erreurs dans le rseau.
Dpent du holddown timers.
Les updates provoques par un vnement sont aussi
utiles.
Voyez les notes de CCNA pour plus de dtail.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
78
Limitations de RIPv2 et de RIPv1
La plus grande limitation que RIPv2 hrit de RIPv1 est
que son interprtation de linfini reste 16.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
79
Compatibilit avec RIPv1
NewYork
interface fastethernet0/0
ip address 192.168.50.129
255.255.255.192
ip rip send version 1
ip rip receive version 1
interface fastethernet0/1
ip address 172.25.150.193
255.255.255.240
ip rip send version 1 2
interface fastethernet0/2
ip address 172.25.150.225
225.255.255.240
router rip
version 2
network 172.25.0.0
network 192.168.50.0
Linterface FastEthernet 0/0 est
configure pour envoyer et
recevoir des updates RIPv1.
FastEthernet 0/1 est
configure pour envoyer des
updates de version 1 et 2.
FastEthernet0/2 na pas de
configuration spciale et de ce
fait elle envoie et reoit des
updates version 2 par dfaut.
RIPv2
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
80
Affichage de la table de routage :
La commande show ip interface brief peut aussi tre utilise pour obtenir un rsum des
informations relatives une interface et son tat.
La commande show ip route affiche le contenu de la table de routage IP. Cette table contient des
entres pour tous les rseaux et les sous-rseaux connus, ainsi quun code indiquant comment ces
informations ont t apprises.
Examinez ces informations pour savoir si la table de routage contient des informations de routage.
Sil manque des entres, aucune information de routage ne sera change. Utilisez les commandes
show running-config ou show ip protocols disponibles en mode privilgi sur le routeur pour
chercher un ventuel protocole de routage mal configur.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
81
Dpannage de RIPv2 :
Utilisez cette commande pour afficher les mises jour de
routage RIP lors de leur envoi et de leur rception. Les
commandes no debug all ou undebug all permettent de
dsactiver toutes les oprations de dbogage.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
82
Dpannage de RIPv2 :
Dans lexemple utilis, le routeur dpann a reu des mises jour dun routeur
situ ladresse source 10.1.1.2. Le routeur situ ladresse source 10.1.1.2
a envoy des informations concernant deux destinations dans la mise jour
de la table de routage. Le routeur en train dtre dbogu envoie aussi des
mises jour, dans les deux cas ladresse multicast 224.0.0.9, comme
adresse de destination. Le nombre entre parenthses reprsente ladresse
source encapsule dans len-tte IP.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
83
Dpannage de RIPv2 :
La commande debug ip rip peut galement
gnrer les messages suivants:
RIP: broadcasting general request on Ethernet0
RIP: broadcasting general request on Ethernet1
Ces messages apparaissent au dmarrage ou
lorsquun vnement survient tel quune transition
dinterface ou la rinitialisation de la table de
routage par un utilisateur.
Si vous obtenez le message suivant, il est
probable que lmetteur a envoy un paquet mal
form:
RIP: bad version 128 from 160.89.80.43
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
84
Dpannage de RIPv2 :
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
85
Routes statiques :
Par dfaut, les routeurs apprennent les chemins vers les destinations donnes l'aide
des trois mthodes suivantes:
Route statique Ladministrateur systme dfinit manuellement une route statique en tant que
prochain saut vers une destination. Lutilisation des routes statiques contribue renforcer la
scurit et rduire le trafic lorsquaucune autre route nest connue.
Route par dfaut L'administrateur systme dfinit aussi manuellement une route par dfaut
en tant que chemin suivre lorsqu'il n'existe aucune route connue menant la destination. Les
routes par dfaut rduisent le nombre dentres des tables de routage. Lorsqu'il n'existe pas de
rseau de destination dans une table de routage, le paquet est envoy au rseau par dfaut.
Route dynamique Le routeur apprend les routes menant aux destinations par la rception de
mises jour priodiques provenant des autres routeurs.
Dans la figure , la route statique est configure l'aide de la commande suivante:
Router(config)#ip route 192.168.20.0 255.255.255.0 192.168.19.2
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
86
Commande IP DEFAULT-NETWORK :
La commande ip default-network permet de dfinir une route par dfaut sur
les rseaux utilisant des protocoles de routage dynamique.
Router(config)#ip default-network 192.168.20.0
En rgle gnrale, une fois que la table de routage qui gre tous les rseaux
devant tre configurs a t dfinie, il est utile de sassurer que les autres
paquets sont dirigs vers un emplacement spcifique. Il sagit de la route par
dfaut du routeur. Prenons lexemple dun routeur connect Internet. Tous
les paquets qui ne sont pas dfinis dans la table de routage seront envoys
vers linterface dsigne du routeur par dfaut.
La commande ip default-network pointe vers un rseau qui est soit
directement connect, soit spcifi par une route statique, soit appris par
routage dynamique.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
87
Routes par dfaut :
Des routes par dfaut peuvent tre configures sur chaque
routeur qui en a besoin, ou alors sur un seul routeur qui
annoncera les routes ses voisins.
ip route 0.0.0.0 0.0.0.0 next hop
Tout routeur utilisant une route par dfaut doit absolument
faire de la consultation de table classless (classless
lookup). Activation par la commande ip classless
(comportement classful par dfaut pour les routeurs
Cisco). En effet, si le rseau principal est dans la table,
mais que le sous-rseau ny est pas, en consultation
classful, le paquet sera jet, mme sil y a une route par
dfaut.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
88
Gateway of last resort
Dans la table de routage, Gateway of last
resort indique le next hop routeur mentionn par
la route par dfaut.
Si le routeur est directement connect au rseau
mentionn dans la route par dfaut, il ny a pas de
Gateway of last resort mentionn car cest le
router lui-mme qui en joue le rle.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
89
Authentication (extra)
Un problme de scurit avec tous les protocoles de routage vient du risque quun
routeur accepte des mises jour de routage invalides
On indique lutilisation de de lauthentification en mettant le champ address family
identifier tout 1 (0xffff).
Le type dauthentification pour le mot passe en texte clair est 2 : 0x0002.
Le type dauthentification avec MD5 est 3 : 0x0003
Les 16 octets restant transportent un mot de passe alpha numrique allant jusqu 16
caractres.
Le mot de passe est justifi gauche, les caractres ventuellement vides sont
remplacs par des 0.
Lauthentification est
faite en modifiant ce
qui devrait
normalement tre la
1 ire route du
message RIP
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
90
Authentication (extra)
RFC 1723 dcrit seulement lauthentification en texte clair.
LIOS Cisco donne la possibilit demployer
lauthentification avec MD5 la place du texte clair.
Cisco utilise lemplacement de la premire et de la
dernire route pour lauthentification MD5.
MD5 calcule une valeur hache de 128-bit partir dun
message alatoire et du password configur.
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
91
Authentification
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
92
Authentification MD5 (extra)
1 2
3 4
5
6
Philippe Dastroy - IEPSA aot 2006 - Module 1 - CIDR - VLSM - RIPv2
93
Configurer l'authentification (extra)
Router(config)#key chain Romeo
Router(config-keychain)#key 1
Router(config-keychain-key)#key-string Juliet
Le password doit tre la mme sur les deux routeurs (Juliet), mais le
nom de la cl (Romeo) peut tre diffrent.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip rip authentication key-chain Romeo
Router(config-if)#ip rip authentication mode md5
Si la commande ip rip authentication mode md5 nest pas ajoute,
linterface utilisera par dfaut le texte clair pour lauthentification. Bien que le
texte clair pour lauthentification soit ncessaire pour certaines
implmentations de RIPv2, pour des raisons de scurit, il vaut mieux utiliser
lauthentification avec MD5 quand cela est possible.