Vous êtes sur la page 1sur 6

Epreuve complmentaire: routage

Ingnierie de rseau d'entreprise

Configuration OSPF
Ci joint un extrait de la configuration d'un routeur Cisco :
RTA#
interface EthernetO
ip address 192.213.11.1 255.255.255.0
interface Ethernet1
ip address 192.213.12.2 255.255.255.0
interface Ethernet2
ip address 128.213.1.1 255.255.255.0
router ospf 100
network 192.213.0.0 0.0.255.255 area 0.0.0.0
network 128.213.1.1 0.0.0.0 area 23

Faire un schma reprsentant le routeur, ses interfaces et les zones auxquelles les interfaces
appartiennent.

Area 0.0.0.0

Il

Configuration RIP

Soit le rseau ci-dessous, exploit en RIP VI :


192.168.1.2

Quelle est la table de routage de RA? On utilisera le format simplifi suivant:

Destination

Masque

Next Hop

Interface

Cot

192.168.1.0

255.255.255.240

192.168.1.1

Jl

192.168.2.0

255.255.255.240

192.168.2.1

12

192.168.3.0

255.255.255.0

192.168.2.4

12

192.168.3.0 est un rseau de classe C et RA n'a pas d'interface dans ce rseau: en RIP v1 on
applique donc le masque naturel. Le masque est donc faux mais le routage est nanmoins correct
Que se passe-t-il si les adresses IP sont changes en 172.168.xXX.xXX? Commentez en dgageant
l'intrt du phnomne mis en vidence et les ventuels problmes soulevs

RA dispose maintenant d'une interface dans le rseau concern, puisque l'adresse est de classe B
et que le rseau est unique: 172.168.0.0. Les masques seront donc justes.
On se donne maintenant le rseau suivant, toujours sous RIPVI :
192.168.1.2

192.168.1.1

RA

J1

192.168.2.1

192.168.2.2

J2

192.168.1.3

J1

HA

192.168.2.4

RB
J2 192.168.2.20

J1

R3
192.168.2.2
192.168.1.3
masque:

255.255.255.240
192.168.2.3

HA et He apparaissent comme tant dans le mme sous rseau car


RB n'a pas d'interface dans es
rseaux 192.168.1.0 Le routage est donc faux. La rgle gnral est qu'il ne doit pas
y avoir de
discontinuit de rseau lorsque l'on utilise un protocole de routage ne tansmettant pas les masques comme
RIP V1

III Rsolution de problme


Le rseau de la figure ci-dessous a t configur par des routes statiques.

172.20.150.13/20
172.20.87.5/20
172.20.165.1/20
172.20.67.15120

/
/

-,

/ RTB

RTe

172.20.130.255120
172.20.20.1/20
172.20.30.255/20

172.20.96.15/20

-,

172.20.16.50/20

192.168.1.17 RC

192.168.1.22

192.168.2.17

192.168.2.18

J2
192.168.1.23
HC

masque:

255.255.255.240

La station HA se plaint de ne pouvoir communiquer avec la station He. Pourquoi? La


table de routage de b aprs convergence est:
Destination
Masque
Next Hop
Interface
Cot

192.168.2.0

255.255.255.240

192.168.2.4

Jl

192.168.2.16

255.255.255.240

192.168.2.20

12

192.168.1.0

255.255.255.0

192.168.2.1

Jl

192.168.1.0

255.255.255.0

192.168.2.17

12

En dduire une rgle gnrale concernant les configurations RIP. Concerne-t-elle d'autres protocoles
de routage?
J.P. Arnaud-

epreuve routage ire 2004 corrig. doc

172.20.230.1120

/
172.20.192.15/20

172.20.223.210/20

Les configurations du routage statique sur chacun des trois routeurs sont donnes ci-dessous.

J.P. Arnaud-

epreuve routage ire 2004 corrig. doc

RT
i p rutiliser
o ue 172.
20.96.192.168.100.0.
0 255. 255.24Faites
0.0 17
2.20.2
0.1 (sous-rseau,
Le plan d'adressage doit
le rseau
une
proposition
r
o
u
t
masques) pour chacun des
i p sous-rseaux
concern,
reporter
sur0.0
la figure.
Quel protocole
de routage
172. 20.82.
0 le
255.
255.24
17 2.20.2
0.1
e
vous proposez-vous d'adopter
(justifier
rapidement)?
r
o
u
t
ip
172. 20.64. 0 255. 255.24 0.0 17 2.20.2 0.1
e
r
o
u
t
Network Address
Subnet 40.0
1 Host 17 2.20. 30.255
,ip
~72. 20.160 .0 2 55 .255.2
192
168
100
192.168.100.0
x ix x x ix
TIR
o 1 x x40.0
i p reo u t 168
172. 20.144 .0
2 55 .255.2
17 2.20.
30.255
192
100
192.168.100.128
1 1 x x x ix x x ix
1
1
1
1
1
1
1
1
1
1
1
1
1
i p r1eo u t 72.20.126.0
255.255.240.0
72.20.30.255
Network Address
192
192
192
1
1

Network Address
192
192
1

F lT e

ip
ip
ip
ip
ip
ip
RT

SubnetlSub-Subnet

1 Host
1002 5 5 .2 515 . 02 40
0 .x 0 172.20.16.50
x x x
x 192.168.100.128
1

r o e 168172.20'.192.0
168
100
1 1 0 x x x x
5 5 . . 2 0 .x 192.168.100.192
17 2 . 2 0 .2 2 4 .100
0 25 5 1. ,2
r o u t 168
16.50
1 1 x 72
2
4
0
,
.
0 x x x x 192.168.100.224
1 2 . 2 ,0 , .
1 255 . 255.
1
7
rout
172.20'.16.50
1
1 21 8 .0
24 ' 0 . 0
. 2 40 1.Sub0 172.20.30.255
r o u t 72 . 2 .160.0 2 5 5 .2 5 5Subnet
2
5
5
.2
5
5
.1 72 .20, . 30 255
SubnetlHost
r o u t T 72.20. 144 .0
2
4
168
100
10 '1 .1 00 x x x
x 192.168.100.224
1 7 2 . 2 ,0 . 1 28
2 5 5 .2 515 . 12 40
' . 017 2 . 2 0 .3 0 . 2 5 5
r o u t 168
100
1 1 x x x
x 192.168.100.240
.0
1

Network Address
192
192
192

0
ip r o u t e168
172.20.96.0

i p r o u t e 72.20.82.0
i p r o u t e 172.20.64.0
168.100.0/25
192.
1

192.
100 Hcsts (1-126)

68.
100.224128 10 Hosts
(22 . 239)

IV Plan d'adressage
On se donne le rseau ci-dessous:

100 H05tS

J.P. Arnaud-

IO I-l05 1 :S

epreuve routage ire 2004 corrig. doc

FDDI

255.255.240.0
Subnet ISub- 1 72.20. '6.50
Subnetl Host 1 72.20 . '6.50
255.255.255.0
100

1 1 0

0 x

x 192.168.100.240
x
x 192.168.100.248
100
1
1 1 1 1172.20.
1 x 20. x1192.168.100.252
255.255.240.0
100

255.255.24,0.0'
1
1 1

1 1

172.20.16.50
0

255.255.240.0

172.20. 20 . 1

255.255.240.0

172 . 20. 20 . 1

Les utilisateurs se plaignent de problmes de connectivit : quel est votre diagnostic? Il


faut corriger les entres suivantes:
A, 2me corriger en ip route 172.20.80.0255.255.255.240.0172.20.20.1
B
corriger en ip route 172.20.208.0255.255.255.240.0172.20.16.50 C 2me
corriger en ip route 172.20.208.0255.255.255.240.0172.20.16.50 et 5me corriger en
ip route 172.20.80.0255.255.255.240.0172.20.20.1

r-,

Enet

i p r o u e 172.20'.192.0
ip r o u t e 1 72.20' . 208 .
0
168
1 72 . 20 .224 .
ip r o u t e168

Enet

J.P. Arnaud- epreuve routage

re 2004 corr g.doc

c0~~-J7

192.168.100.240/30 2
Hasts (241-242)

V Gnralits
2. Bien que fond sur un algorithme "distance vector" BOP est utilis sur de grands rseaux
sans que cela conduise des problmes du type "comptage l'infini". Pourquoi?
3. En vous aidant ventuellement du simulateur fourni sur le serveur web donner au moins
un exemple de schma de rseau ayant un nombre minimal de routeurs et pour lequel le
clivage d'horizon ne suffit pas rsoudre les problmes de comptage l'infini.

Nota : Cette preuve ne constitue pas un partiel. Chaque exercice en sera not
indpendamment, et pourra compter pour un rattrapage de 0.4 point au cas o votre note
moyenne aux preuves d'valuation de la valeur (projet dimensionnement, expos,
examen) serait comprise entre 10 et 12 (rappel: une moyenne de 12/20 est exige pour les
valeurs C). Les moyennes suprieures 12 ne seront pas rajustes. Les moyennes
infrieures 10 ne seront pas rattrapes.
J.P. Arnaud-

epreuve routage ire 2004 corrig. doc

Vous aimerez peut-être aussi