Vous êtes sur la page 1sur 18

BGP Routing

Lab coniguration and practices


RedCLARA
Eriko Porto eporto@rnp.br
Hans Reyes hans@internet2.unam.mx
BGP coniguration - management
Topology for the lab management network
all trainees have access to all routers
GigEth 0/1
of all routers
Catalyst
3750
LAN ports
of all workstations
192.168.0.0
network
BGP coniguration - management
Steps for configuring the management network
connect all equipment to the switch
configure the switch ports with the correct access mode and
to the default VLAN 0
define IP addresses for the interfaces
configure management workstations interfaces
access console ports of the routers
configure the routers Gigabit Ethernet 0 interfaces for the
management network
verify connectivity
BGP coniguration
Topology for the lab BGP network
two groups of trainees
same topology for the two labs
GigEth 0/2 GigEth 0/2 GigEth 0/3 GigEth 0/3 GigEth 0/2 GigEth 0/2
BGP coniguration
BGP topology
Backbone ISP
ASN 100
ASN 200
ISP1 ISP2
UN200 UN300
172.16.2.0/30 172.16.1.0/30 172.16.3.0/30
Loopback ISP1 172.16.100.101/32
Loopback ISP2 172.16.100.102/32
Loopback UN200 172.17.20.1/32
Loopback UN300 172.18.30.1/32
ASN 300
eBGP iBGP eBGP
BGP coniguration
Basic steps for configuring BGP routing
planning the network define IP addresses ranges to the
networks (areas)
connect the gigabit interfaces of the routers following the
defined topology
configure the gigabit and loopback interfaces of the routers
create an IGP routing process between the ISP routers
verify layer 3 connectivity internal to the ISP
create IGP routing processes in the clients routers
Coniguration 1emplate
ISP1 interfaces and IGP
configuration using IS-IS
!
hostname isp1
!
interface loopback 0
ip addr 172.16.100.101 255.255.255.255
ip router isis
interface giga 0/1
ip addr 192.168.10.y 255.255.255.0
interface giga 0/2
ip addr 172.16.2.1 255.255.255.252
ip router isis
interface giga 0/3
ip addr 172.16.1.1 255.255.255.252
ip router isis
!
router isis
net 49.0001.1720.1610.0101.00
metric-style wide
is-type level-2-only
passive-interface Giga 0/0
!
Coniguration 1emplate
ISP2 interfaces and IGP
configuration using IS-IS
!
hostname isp2
!
interface loopback 0
ip addr 172.16.100.102 255.255.255.255
ip router isis
interface giga 0/1
ip addr 192.168.10.y 255.255.255.0
interface giga 0/2
ip addr 172.16.3.1 255.255.255.252
ip router isis
interface giga 0/3
ip addr 172.16.1.2 255.255.255.252
ip router isis
!
router isis
net 49.0001.1720.1610.0102.00
metric-style wide
is-type level-2-only
passive-interface Giga 0/0
!
Coniguration 1emplate
UN200 interfaces
configuration
create several sub-
interfaces for training
prefix distribution
!
hostname un200
!
interface loopback 0
ip addr 172.17.20.1 255.255.255.255
interface giga 0/1
no ip addr
interface giga 0/1.1
ip addr 192.168.10.y 255.255.255.0
interface giga 0/1.2
ip addr 172.17.2.1 255.255.255.0
interface giga 0/1.3
ip addr 172.17.3.1 255.255.255.0
interface giga 0/1.4
ip addr 172.17.4.1 255.255.255.0
interface giga 0/2
ip addr 172.16.2.2 255.255.255.252
!
Coniguration 1emplate
UN200 IGP
configuration
using OSPF as the IGP
routing protocol
!
hostname un200
!
router ospf 200
network 172.17.2.1 0.0.0.255 area 0
network 172.17.3.1 0.0.0.255 area 0
network 172.17.4.1 0.0.0.255 area 0
!
!
Coniguration 1emplate
UN300 interfaces
configuration
create several sub-
interfaces for training
prefix distribution
!
hostname un300
!
interface loopback 0
ip addr 172.18.30.1 255.255.255.255
interface giga 0/1
no ip addr
interface giga 0/1.1
ip addr 192.168.10.y 255.255.255.0
interface giga 0/1.2
ip addr 172.18.2.1 255.255.255.0
interface giga 0/1.3
ip addr 172.18.3.1 255.255.255.0
interface giga 0/1.4
ip addr 172.18.4.1 255.255.255.0
interface giga 0/2
ip addr 172.16.3.2 255.255.255.252
!
Coniguration 1emplate
UN300 IGP
configuration
using OSPF as the IGP
routing protocol
!
hostname un300
!
router ospf 300
network 172.18.2.1 0.0.0.255 area 0
network 172.18.3.1 0.0.0.255 area 0
network 172.18.4.1 0.0.0.255 area 0
!
!
BGP coniguration
Further steps to configure BGP
configure internal BGP (iBGP) on the ISP routers (ASN 100)
configure the external BGP (eBGP) peering between ISP
routers and the UN routers
verify the connectivity between autonomous systems
BGP Coniguration 1emplate
ISP1 BGP configuration
!
router bgp 100
bgp log-neighbor-changes
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 100
neighbor INTERNAL update-source Loopback0
neighbor UN200 peer-group
neighbor UN200 remote-as 200
neighbor UN200 update-source Gig 0/2
neighbor 172.16.100.102 peer-group INTERNAL
neighbor 172.16.2.2 peer-group UN200
!
address-family ipv4
neighbor INTERNAL activate
neighbor INTERNAL soft-reconfig inbound
neighbor UN200 activate
neighbor UN200 soft-reconfig inbound
no auto-summary
no synchronization
bgp dampening
network 172.16.1.0 mask 255.255.255.252
network 172.16.100.101 mask 255.255.255.255
exit-address-family
!
BGP Coniguration 1emplate
ISP2 BGP configuration
!
router bgp 100
bgp log-neighbor-changes
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 100
neighbor INTERNAL update-source Loopback0
neighbor UN300 peer-group
neighbor UN300 remote-as 300
neighbor UN300 update-source Gig 0/2
neighbor 172.16.100.101 peer-group INTERNAL
neighbor 172.16.3.2 peer-group UN300
!
address-family ipv4
neighbor INTERNAL activate
neighbor INTERNAL soft-reconfig inbound
neighbor UN300 activate
neighbor UN300 soft-reconfig inbound
no auto-summary
no synchronization
bgp dampening
network 172.16.1.0 mask 255.255.255.252
network 172.16.100.102 mask 255.255.255.255
exit-address-family
!
BGP Coniguration 1emplate
UN200 BGP
configuration
!
router bgp 200
bgp log-neighbor-changes
neighbor ISP100 peer-group
neighbor ISP100 remote-as 100
neighbor ISP100 update-source Gig 0/2
neighbor 172.16.2.1 peer-group ISP100
!
address-family ipv4
neighbor ISP100 activate
neighbor ISP100 soft-reconf inbound
no auto-summary
no synchronization
bgp dampening
network 172.17.20.1 mask 255.255.255.255
network 172.16.2.0 mask 255.255.255.252
exit-address-family
!
BGP Coniguration 1emplate
UN300 BGP
configuration
!
router bgp 300
bgp log-neighbor-changes
neighbor ISP100 peer-group
neighbor ISP100 remote-as 100
neighbor ISP100 update-source Gig 0/2
neighbor 172.16.3.1 peer-group ISP100
!
address-family ipv4
neighbor ISP100 activate
neighbor ISP100 soft-reconf inbound
no auto-summary
no synchronization
bgp dampening
network 172.18.30.1 mask 255.255.255.255
network 172.16.3.0 mask 255.255.255.252
exit-address-family
!
BGP coniguration
Additional training
training with show and debug commands
training management of configuration files (running-config,
startup-config and tftp server)
configuring BGP authentication MD5 passwords
training configuration of BGP filtering tools
training fine tuning of BGP parameters

Vous aimerez peut-être aussi