Vous êtes sur la page 1sur 30

Algoritmos

Facultad de ingeniera

Que es la algoritmia?
Es un conjunto de pasos, instrucciones o acciones que se deben seguir y realizar ordenadamente para llegar a un fin determinado. Ej: Solucin de un problema, obtencin de una respuesta, realizacin de una tarea, mejorar un proceso, etc.

Algoritmos cualitativos. Son aquellos pasos o instrucciones descritos por medio de palabras que sirven para llegar a la obtencin de una respuesta o solucin de un problema. Ej.: La utilizacin del directorio telefnico, una recta de cocina (preparar sancocho), montaje de una llanta, etc.

Algoritmos cuantitativos. Son todos aquellos pasos o instrucciones que involucran clculos numricos para llegar aun resultado satisfactorio Ej: Una ecuacin diferencial, hallar una raz, etc. Facultad de ingeniera

Ejemplo de un algoritmo
Algoritmo para comprar los boletos de entrada al cine 1. Inicio. 2. Llegar al lugar de proyeccin de la pelcula. 3. Revisar la cartelera. 4. Seleccionar la pelcula. 5. Hacer la cola de pago. 6. Esperar el turno. 7. Solicitar la pelcula. 8. Si la hay (ir al paso 10), sino (ir al paso 9). 9. Escoger otra pelcula (ir al paso 8), o retirarse (ir al paso 12). 10. Entregar el dinero. 11. Esperar por los boletos y la diferencia de pago. 12. Fin.

Facultad de ingeniera

Partes de un algoritmo
Todo algoritmo debe obedecer a la estructura bsica de un sistema, es decir: entrada, proceso y salida. ENTRADA: Corresponde al insumo, a los datos necesarios que requiere el proceso para ofrecer los resultados esperados. PROCESO: Pasos necesarios para obtener la solucin del problema o la situacin planteada. SALIDA: Resultados arrojados por el proceso como solucin.

Facultad de ingeniera

Partes de un algoritmo
.

Datos

Datos procesados

SALIADA

PROCESO

ENTRADA

Facultad de ingeniera

Partes de un algoritmo
Ejemplo de un algoritmo de la sumatoria de los dos nmeros Inicio Leer A Leer B Suma= A + B Escribir Suma Fin Tenemos que: ENTRADA : Valores de las variables A y B. PROCESO: Asignar a la variable Suma, el valor de A mas el valor de B. SALIDA: Impresin del valor de la variable Suma, que contiene la sumatori a de los valores de A y B. Facultad de ingeniera

Caractersticas de un algoritmo
Principios de Algoritmia Caractersticas de los Algoritmos Consecuente: Indica el orden de realizacin de cada paso dentro del proceso. Definicin: Indica la exactitud y consistencia de los pasos descritos en el proceso, si el algoritmo se prueba dos veces, en estas dos pruebas, se debe obtener el mismo resultado. Finitud: Indica el nmero razonable de pasos, los cuales deben conllevar a la finalizacin del proceso y producir un resultado en un tiempo finito

Facultad de ingeniera

Elementos que componen un algoritmo


Dado que un algoritmo es un conjunto de instrucciones que permiten resolver un problema, los elementos que se utilizan en la construccin de algoritmos son los siguientes: Comandos: Son palabras que denotan una accin que son interpretadas y ejecutarlas el computador. Cada comando conserva una sintaxis determinada, es decir la forma de utilizarlo. Los lenguajes computacionales tienen en su repertorio comandos di rigidos al procesamiento de archivos y datos, entre ellos: Inicio, Le er, Imprimir. Datos: Numricos (Reales, Enteros) Lgicos (Binarios) Carcter (Char, String) Facultad de ingeniera

Elementos que componen un algoritmo


Variables y contantes: Son espacios de memoria que contienen valores especifico de dato que pueden mantenerse (Constantes) o que puedan variar (Variables). de un tipo

Constante: Es un dato que permanece con un valor por siempre Ej: PI, e, etc. Variable: Es un dato cuyo valor puede variar a lo largo del desarrollo del algoritmo Ej: Velocidad, aceleracin, contador, etc.

Facultad de ingeniera

Elementos que componen un algoritmo


Operadores: Son todos los smbolos y palabras que permiten crear operaciones de diversos tipo tales como: Aritmticas: +(Suma) , -(Resta), /(Divisin),*(Multiplicacin), % Residuo. Relacionales: >(Mayor que),< (Menor que),<>(Diferente), >=(Mayor o igual),<=(Menor o igual). Lgicos: AND-&& NOT-! (Negacin), (Conjuncin), OR-|| (Disyuncin),

Facultad de ingeniera

Cmo se representan los algoritmos?

Para representar los algoritmos se utilizan los: Diagramas de Flujo Pseudo Cdigo o Pseudo Lenguaje.

Facultad de ingeniera

Estructuras bsicas de los algoritmos


En los algoritmos se emplean estructuras bsicas o de control ya prediseadas para el tratamiento de informacin, las cuales realizan acciones a las cuales deba someterse la informacin.
Estas estructuras son: Secuenciales: cuando se requiere que una instruccin siga despus de otra. Seleccin o decisin: Para tomar decisiones lgicas, la ejecucin de la instrucciones depender de que se cumplan o no, una o varias condiciones. Repeticin o Iteracin: se utiliza cuando un proceso de be repetirse un nmero determinado o no de veces, una vez . Facultad de ingeniera

Cmo se representan los algoritmos?

Smbolos diagramas de flujo. Inicio/Fin Entrada/ Salida de datos Flujo de datos Bifurcacin (Decisin) Si No Proceso alterno

Proceso

Facultad de ingeniera

Ejemplo de un diagrama de flujo


Terminador Inicio Leer (numero) contador 0 acumulador 0 Decisin SI contador < numero SI NO NO Se recibe el nmero de estudiantes Entrada de Datos

Proceso

contador contador + 1

contador > 0

Leer (edad)

promedio acumulador/contador

promedio 0

acumulador acumulador + edad

Salida de Datos

Escribir (promedio) Fin

Facultad de ingeniera

Ejemplo de un Pseudo cdigo


INICIO leer(numero) contador 0 acumulador 0 MIENTRAS contador < numero HACER contador contador +1 leer(edad) acumulador acumulador + edad FIN MIENTRAS SI contador >0 ENTONCES promedio acumulador/contador SINO promedio 0 FIN SI FIN escribir(promedio)

Facultad de ingeniera

Enunciado de asignacin

Es una accin o proceso por el cual se le asigna un valor (constante o variable) o el resultado de una operacin (expresin) a una variable. Los enunciados de asignacin se utilizan generalmente para cambiarle de valor a una variable o definirla.

Definir una variable consiste en asignarle o darle por primera vez un valor; y puede hacerse de dos maneras: Por medio de una lectura de datos, o Utilizando un enunciado de asignacin. Ejemplo: leer(edad) edad 25

Facultad de ingeniera

Reglas de construccin de enunciados de asignacin

Toda variable que aparezca al lado derecho de un enunciado de asignacin debe estar definida.

Ejemplo 1: edad 25 contador 0 contador contador + edad Las variables edad y contador se definieron correctamente Ejemplo 2: contador 0 contador contador + edad La variable edad nunca fue definida.

Facultad de ingeniera

Reglas de construccin de enunciados de asignacin

En un enunciado de asignacin la variable de la izquierda es la nica que cambia de valor cuando con anterioridad tiene un valor asignado.
Ejemplo : edad 25 contador 0 contador contador + edad

Facultad de ingeniera

Reglas de construccin de enunciados de asignacin


Las variables que aparecen en la parte derecha de un enunciado de asignacin conservan su valor despus de ejecutarse la asignacin. Ejemplo : salario 1000 bono 120 salario_neto salario + bono

Facultad de ingeniera

Reglas de construccin de enunciados de decisin

Los enunciados de decisin se utilizan para tomar una accin o conocer el estado de alguna situacin especial, que generalmente toman un valor Verdadero o Falso.

Facultad de ingeniera

Reglas de construccin de enunciados de decisin


SI
<comparacin>

NO

Pseudo Cdigo

SI <comparacin> ENTONCES VERDADERO Enunciado(s) SINO FALSO Enunciado(s) FIN SI

Facultad de ingeniera

Enunciado de decisin
Diagrama de Flujo SI contador >0 NO

promedio acumulador/contador

promedio 0

Pseudo Cdigo SI contador >0 ENTONCES promedio acumulador/contador SINO promedio 0 FIN SI Facultad de ingeniera

Reglas de construccin de enunciados de repeticin

Son los enunciados que permiten repetir varias o muchas veces un conjunto de enunciados segn se necesite de acuerdo a una condicin. Se les conoce tambin como ciclos.

Facultad de ingeniera

Enunciado de repeticin
Diagrama de Flujo SI
<comparaci n>

NO

Pseudo Cdigo

MIENTRAS <comparacin> HACER VERDADERO Enunciado(s) a repetir FIN MIENTRAS FALSO Enunciado(s)

Enunciado de repeticin
Diagrama de Flujo SI contador contador +1 Leer(edad) acumulador acumulador + edad

contador < numero

NO

promedio acumulador/contador Escribir (promedio) Fin

Pseudo Cdigo

MIENTRAS contador < numero HACER contador contador +1 leer(edad) acumulador acumulador + edad FIN MIENTRAS promedio acumulador/contador escribir(promedio)

Facultad de ingeniera

Reglas de construccin de enunciados de lectura


El enunciado de lectura se utiliza para introducir datos que se van a utilizar en la solucin de un algoritmo. Ejemplo: Leer(edad)

Facultad de ingeniera

Reglas de construccin de enunciados de escritura


El enunciado de escritura se utiliza para informar los resultados que se esperaban obtener al ejecutarse el algoritmo. Ejemplo: Escribir(promedio)

Facultad de ingeniera

Pasos para elaborar un algoritmo


1. Leer el enunciado del problema cuantas veces sea necesario, hasta entenderlo completamente, si tiene duda sobre el significado de alguna pregunta o condicin aclararla, ojala se aprenda de memoria el enunciado. Determinar claramente con que datos de entrada se cuenta para la solucin del problema. Aclarar y determinar la informacin o resultados que se soliciten. 1. Informacin Intermedia. 2. Informacin Final. Definir que clculos y/o comparaciones se necesitan para llegar al resultado final. 1. Clculos y comparaciones intermedias. 2. Clculos y comparaciones finales. Tener en cuenta toda clase de condiciones y restricciones para la solucin del problema.

2. 3.

4.

5.

Todos los pasos tienen la misma importancia, la falta de analisis de alguno de ellos causara problemas en el transcurso del desarrollo del algoritmo.

Facultad de ingeniera

Ejemplo de algoritmo
INICIO leer(numero) contador 0 acumulador 0 cont_mujeres 0 cont_hombres 0 acum_mujeres 0 acum_hombres 0 MIENTRAS contador < numero HACER contador contador +1 leer(edad) leer(sexo) ENTONCES SI sexo = mujer cont_mujeres cont_mujeres +1 acum_mujeres acum_mujeres + edad SINO cont_hombres cont_hombres +1 acum_hombres acum_hombres + edad FIN SI

acumulador + edad FIN MIENTRAS

acumulador

Facultad de ingeniera

Ejemplo de algoritmo
SI contador >0 ENTONCES promedio acumulador/contador SINO promedio 0 FIN SI SI cont_mujeres >0 ENTONCES prom_mujeres acum_mujeres/cont_mujeres SINO prom_mujeres 0 FIN SI SI cont_hombres >0 ENTONCES prom_hombres acum_hombre/cont_hombres SINO prom_hombres 0 FIN SI escribir(promedio) escribir(prom_mujeres) escribir(prom_hombres) FIN

Facultad de ingeniera