Vous êtes sur la page 1sur 24

ALGORITMO E ESTRUCTURA DE DADOS I Prof: Joo da Costa

Conferncia # 5 e 6
Sumario: Exercicios Prtico

1-Desenvolver um programa que efetue a leitura de dois valores numricos. Faa a operao de adio entre os dois valores e apresente o resultado obtido.

Note que sempre estaremos diante de um problema, e que este dever ser resolvido primeiro por ns, para que depois seja resolvido por um computador. Primeiramente, voc deve entender bem o problema, para depois buscar a sua soluo dentro de um computador, ou seja, voc dever ensinar a mquina a resolver seu problema, atravs de um programa. Desta forma, o segredo de uma boa lgica est na compreenso adequada do problema a ser solucionado. Vejamos nosso problema citado acima:

Algoritmo: 1. Ler um valor para a varivel A; 2. Ler outro valor para a varivel B; 3. Efetuar a soma das variveis A e B, colocando o resultado na varivel X; 4. Apresentar o valor da varivel X aps a operao de soma dos dois valores fornecidos.

algoritmo "Soma de dois numeros" var A, B, C :inteiro inicio escreva (" Entra o primeiro Numero A:") leia ( A) escreva ( " Entra o segundo numero B:") leia ( B)

X <- A + B escreva (" soma dos dois numeros " , X) fimalgoritmo

Elaboreum programa que mostre o teu nome completo

Algoritmo 1.Concatenar os nomes 2.Mostrar os nomes ou 1. Tribuir os nome as variaveis 2. Concatenar as Variaveis 3.Mostrar o Nome

algoritmo "Nome Completo" var Nome_Completo: Literal inicio Nome_Completo<- "Maria" + " -Joo" + " Lemos" escreva ( Nome_Completo ) fimalgoritmo

algoritmo NomeCompletoComVariavel" var Nome1,Nome2,Nome3,Nome_Completo: literal inicio Nome1<- " Maria" Nome2<- "-Joo" Nome3<- "-Lemos" Nome_Completo <- Nome1 + Nome2 + Nome3 escreva( Nome_Completo ) fimalgoritmo

A empresa Cesar & Filho possui varios trabalhadores. O seu proprietrio deseja fazer um aumento baseado nas seguintes condies: Se o funcionrio ofere um salario superior a 20000 Kz aumenta-se 5000,caso contrrio aumenta-se 10000. Mostrar o slario real do funcionrio.

1. Ler o slario do trabalhador

2-Ler dois valores inteiros e independentemente da ordem em que foram inseridos, estes devero ser exibidos em ordem crescente, ou seja, se forem fornecidos 5 e 3 respectivamente, devero ser apresentados 3 e 5. O programa em questo dever efetuar a troca dos valores entre as duas variveis

Algoritmo 1. Ler dois valores inteiros (estabelecer variveis A e B); 2. Verificar se o valor de A maior que o valor de B: a. se for verdadeiro, efetuar a troca de valores entre as variveis; b. se for falso, pedir para executar o que est estabelecido no passo 3; 3. Apresentar os valores das duas variveis.

algoritmo OrdenarFinal var X, A, B : inteiro inicio escreva ("Informe uma valor para a variavel A: ") leia(A) escreva ("Informe uma valor para a variavel B: ") leia(B) escreva

se (A > B) entao {Trocade valores} X <- A A <- B B <- X fimse escreva ("Os valores ordenados so: ") escreva(A, " ", B)

fimalgoritmo

3-Ler dois valores numricos e efetuar a adio. Caso o valor somado seja maior ou igual a 10, este dever ser apresentado somando-se a ele mais 5. Caso o valor somado no seja maior ou igual a 10, esta dever ser apresentado subtraindo-se 7.

Algoritmo 1. Ler dois valores (variveis A e B); 2. Efetuar a soma dos valores A e B, atribuindo o resultado da soma a uma varivel X; 3. Verificar se X maior ou igual a 10: a. se for verdadeiro, mostrar X+5; b. se for falso, mostrar X-7.

algoritmo "Soma condional" var A,B,C: inteiro

C<- A+B escreva(" O RESULTADO EQUIVALE A") se C > 10 entao escreva(c+5) senao escreva(C-7) fimse fimalgoritmo

inicio escreva (" Informe o valor de A") Leia (A) Escreva ("Informe o valor de B") Leia (B)

4-Ler dois valores inteiros. Realize a adio destes nmeros, armazenando o resultado em uma terceira varivel. Apresente o valor encontrado. Repita esta operao 5 vezes. 5-Ler dois valores inteiros. Realize a adio destes nmeros, armazenando o resultado em uma terceira varivel. Apresente o valor encontrado. Repita esta operao 5 vezes.