Vous êtes sur la page 1sur 29

2.1.

- Estructuras de Control
CICLO
Ciclo Mientras
MIENTRAS
Permite ejecutar repetidamente un conjunto de
instrucciones, mientras que una condicin sea
verdadera.
La condicin siempre se evala antes de
ejecutar el bloque de instrucciones.

Estructuras de Control
Iterativas (Mientras)
En Visual Basic

Diagrama de
Flujo

condicin

while (condicin)

no

sentencia
End While

s
Sentencia

TRADUCCION MIENTRAS
PSEUDOCODIGO
mientras <condicin> hacer
<bloque instrucciones>
fin_mientras

EJEMPLO 1
Disee un programa que halle la suma de n
trminos de la siguiente serie:
1+ 6/5 + 11/9 + 16/13 +

Pseudocdigo
Variables
X, Y, C, N: entero
suma : Real
Leer N
Suma = 0: c = 0 : x = 1: y = 1
Mientras C < N hacer
Suma = suma + X / Y
x=x+5
y=y+4
c=c+1
Fin_mientras
Escribir (La suma es:, suma)
FIN

Public Class Form1

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e


As System.EventArgs) Handles Button1.Click

Dim C, X, Y As Integer

Dim suma As Double

X=1

Y=1

N = Textbox1.text

While C < N

suma = suma + X / Y

ListBox1.Items.Add(X & / & Y)

X=X+5

Y=Y+4

C=C+1

End While

TextBox2.Text = suma

End Sub

End Class

EJEMPLO 2
Leer un nmero entero N y calcular el resultado de la siguiente
serie: 1 - 1/2 + 1/3 - 1/4+.... +/- 1/N.

Solucin
Dim Serie as Double
Dim I, N as Integer
Dim Band as Boolean
Serie = 0
I = 1
N = Textbox1.text
Band =
True
While I < = N
If Band = True Then
Serie = Serie + ( 1 / I )
Band = False
Else
Serie = Serie - ( 1 / I )
Band = True
End if
I =I+1
End While
Textbox2.text = Serie
End Sub

2.2.- Estructuras de Control


CICLO HAGA- MIENTRAS
Iterativas(Haga
Mientras)

En este ciclo la condicin se evala despus de ejecutar el


bloque de instrucciones, por lo tanto, el bloque se ejecuta por
lo menos una vez y se repite en caso que la evaluacin de la
condicin sea verdadero.

Veo el arco iris


mientras llueve y hace sol

Estructuras de Control
Iterativas (Haga Mientras)
En Visual Basic
Diagrama de
Flujo

Do
sentencia

Sentencia

condicin
No

Si

Loop while/Until(condicin)

Do While/ Until (Condicion)


Sentencia
Loop

12

TRADUCCIN HAGA-MIENTRAS
PSEUDOCODIGO
Haga
<bloque instrucciones>
Mientras / Hasta <condicin>

EJEMPLO 3

PSEUDOCODIGO
Variables

X, Y, N : entero
Suma : Real

Suma = 0: x = 1: y = 2
Haga
Suma=suma + (X / Y)
x=x+2
y=y+3
c=c+1
Hasta C > 99
Escribir (suma + 1)
FIN

Public Class Form1

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e


As System.EventArgs) Handles Button1.Click

Dim C, X, Y As Integer

Dim suma As Double

X=1

Y=2

Do

suma = suma + X / Y

ListBox1.Items.Add(X & / & Y)

X=X+2

Y=Y+3

C=C+1

Loop Until C = 99

suma = suma + 1

TextBox1.Text = suma

End Sub

End Class

2.3.- Estructuras de Control


CICLO
PARA
Ciclo Para
DIAGRAMA DE
FLUJO

Visual basic

For (<variable> = <lim_inf> To


<lim_sup>)
[Step Incremento]

<bloque instrucciones>
Next

TRADUCCION PARA
PSEUDOCODIGO
Para (i = <lim_inf> hasta <lim_sup>) [Incremento]
hacer
<bloque instrucciones>
fin_para

EJEMPLO 4

Realizar la suma de los nmeros


del 1 hasta el N e imprimirla en
pantalla
Suma = 1 + 2 + 3 + 4 ++N

(Diagrama de Flujo)

Solucin

Solucion
Programa
(pseudocdigo)
suma, n, i: entero
suma = 0
leer n
para i = 1 hasta n hacer
suma = suma + i
fin_para
escribir suma

Memoria
suma i
n
???
S
X4
xxx
xxx
xxx
3
6310
321

FORMULARIO

Utilizando For
Private Sub Button1_Click(ByVal sender As System.Object,
ByVal e As System.EventArgs) Handles Button1.Click

Dim N, I, SUMA As Integer


N = TextBox1.Text
For I = 1 to N
SUMA = SUMA + I
ListBox1.Items.Add(I)
Next
TextBox2.Text = SUMA
End Sub

UtilizandoWHILE
While
Utilizando
Private Sub Button1_Click(ByVal sender As System.Object,
ByVal e As System.EventArgs) Handles Button1.Click

Dim N, I, SUMA As Integer


I=1
N = TextBox1.Text
While I <= N
SUMA = SUMA + I
ListBox1.Items.Add(I)
I=I+1
End While
TextBox2.Text = SUMA
End Sub

Utilizando Do Loop
Private Sub Button1_Click(ByVal sender As System.Object,
ByVal e As System.EventArgs) Handles Button1.Click

Dim N, I, SUMA As Integer


I=1
N = TextBox1.Text
Do
SUMA = SUMA + I
ListBox1.Items.Add(I)
I=I+1
Loop Until I > N
TextBox2.Text = SUMA
End Sub

EJERCICIOS PROPUESTOS
1. Hacer un diagrama de flujo que determine la cantidad
de dgitos que tiene un nmero entero y adems
mostrar la suma de los dgitos pares e impares.
Considerar cero como digito par.
2. Hacer un diagrama de flujo, que muestre por pantalla
todos los nmeros de 4 cifras que cumplan con la
condicin de que la suma de las cifras pares es igual
a la suma de las cifras impares. Muestre tambin la
cantidad de nmeros encontrados.

3. Realizar un programa en Visual Basic, que


permita determinar la suma de las cifras de un
numero de 3 dgitos. El programa deber
indicar el mensaje numero fuera de rango
cuando en numero no tenga 3 dgitos