Vous êtes sur la page 1sur 35

Le Routage dynamique

Le protocole RIP
Le protocole IGRP
Le protocole OSPF

Introduction

Le routage statique est inadapt si :


Le nombre de rseaux connecter est important ( plus de 10 routeurs
configurer )
La topologie du rseau change souvent
Plusieurs routeurs existent et la reconfiguration doit tre automatique en cas
de panne (Permet de rorienter le trafic en cas de panne sur une liaison d'un
rseau ).

Le chemin emprunt par un paquet IP dans le routage statique nest


pas forcment le plus court chemin .

Routage dynamique
Routage dynamique : protocole de communication inter-routeurs
qui va permettre de construire automatiquement les tables de
routages.
Protocole de communication inter-routeurs : chaque routeur
communique avec ses voisins directement accessibles pour changer
les informations.
Le principe du routage ne change pas, cest la faon de mettre jour
( construire ) la table de routage qui change, puisquelle nest plus
manuelle mais dynamique.

Le routage dynamique
Le routeur assimile ( apprennent ) dynamiquement de nouvelles informations de routage
(grce des protocoles spcifiques) vers d'autres rseaux.
Lorsqu'un algorithme de routage met jour une table de routage, son principal objectif
est de dterminer la meilleure information inclure dans la table afin de trouver le
meilleur chemin.
A chaque lien du rseau est associ une valeur appele METRIQUE
Tant que la mtrique est petite meilleur est le chemin.
La mtrique est utilis pour choisir le meilleur chemin .
A

4
12
B

1
D

6
2

LA Mtrique
La mtrique d'un lien peut tre soit en fonction d'une seule caractristique ou en fonction de
plusieurs caractristiques.
Quelques mtriques utilises :
Bande passante ( Dbit ) : par exemple, une liaison Ethernet sera 10 ou 100 Mbits/s.
Le Dlai : temps requis pour acheminer un paquet sur le lien .
La Charge : la quantit d'activit sur une ressource rseau telle qu'un routeur ou une liaison.
La Fiabilit : Taux d'erreurs de chaque liaison du rseau.
Le Nombre de sauts : nombre de routeurs par lesquels un paquet doit passer avant d'arriver
destination.
Le Cot : valeur arbitraire, habituellement base sur la bande passante, la dpense dargent ou
d'autres mesures, attribue par un administrateur de rseau.
Toute combinaison de ces valeurs.

Le temps de convergence

chaque fois que la topologie du rseau change ( le changement peut tre


cause dun ajout dun rseau ou une panne ) les informations dtenues par des
routeurs doit aussi changer.
Aprs un changement de la topologie, les routeurs doivent recalculer les routes, ce
qui perturbe le routage.
Ces informations doivent reflter une vision globale cohrente de la nouvelle
topologie.
Cette vision se nomme convergence.
Il y a convergence lorsque tous les routeurs ont une vue uniforme de la topologie
rseau les routeurs sont synchroniss.
Le processus et le temps de convergence des routeurs varient selon les protocoles
de routage plus le temps de convergence est petit plus lalgorithme de
routage est performant

Classification des algorithmes de routage


dynamique
Les algorithmes de routage peuvent tre :
vecteur de distance : ces algorithmes se basent sur le nombre de sauts
( distance ) ou la longueur du chemin qui sera emprunt par le paquet pour
trouver le meilleur chemin les routeurs ont une vision local du la topologie
du rseau .
tat de liens : ces algorithmes se basent sur ltat des liens ( active ou non )
pou crer la topologie exacte de tout le rseau avoir une vision globale
avant de calculer le plus court chemin
Hybride : Cette mthode combine les aspects des algorithmes d'tat de liens
et de vecteur de distance.

RIP : Routing Information Protocol.


Le protocole RIP est un protocole vecteur de distance.
Il diffuse priodiquement le contenu de sa table de routage ses voisin immdiats
( les routeurs directement connects ).
Chaque entre de la table est compose de la destination, de la distance et du
routeur de prochain saut .
La distance est la mesure du cot associ la route le RIP utilise le nombre de
saut comme mtrique .
Le franchissement d'un routeur compte pour un pas ( un saut ).
RIP affecte la valeur 0 pour un rseau connect, de 1 pour un rseau atteint pas le
biais d'un routeur et ainsi de suite.

Mtrique utilis par le RIP


La distance de A E : est gale zro si on utilise le lien R1
La distance de A E : est gale 2 si on utilise les liens R 2 ,R5 et R4
passer par les routeur D et C
R1

A
R3

R4

B
R2

R6
R5

Principe RIP
Initialisation
Au dmarrage le routeur dtecte toutes les interfaces actives, et ainsi
cre la table de routage des routes directes.
Il envoie une requte sur chacune des interfaces afin dobtenir les
tables de routages compltes des autres routeurs voisins.
Le routeur reoit les listes de rseaux accessibles par les routeurs
adjacents, avec une distance associe chaque destination.
Lorsquune nouvelle destination est reue, le routeur lajoute sa
table de routage, indiquant comme adresse de destination, ladresse
source lorigine du message RIP .

Exemple
Au dmarrage : le routeur dtecte deux liens qui lui sont directement connect
Destination

Distance

Prochain pas

144.19.0.0

Direct

130.21.0.0

Direct

Aprs la rception des table de routage de ces voisins il va mettre jour sa propre table de routage
Destination

Distance

Prochain pas

144.19.0.0

Direct

130.21.0.0

Direct

200.1.1.0

144.19.1.100

200.2.5.0

144.19.1.101

199.23.3.0

130.21.5.30

131.200.0.0

130.21.5.32

Principe RIP
Ajout dune route
Aprs la phase dinitialisation, le routeur va diffuser rgulirement
sur chacune de ses interfaces, par dfaut toutes les 30 secondes, sa
table de routage.
Le routeur a sont tour il reoit des informations dautres routeurs .
Si une destination existant dans la table de routage est reue par le
routeur alors il compare les distances et garde dans sa table de
routage lentre ayant la plus petite distance .
En suite il diffuse alors cette information sur les autres interfaces.

Exemple : ajout dune route


Routeur 144.19.1.102

Destination

Distance

Prochain pas

144.19.0.0

Direct

Destination

Distance

130.21.0.0

Direct

144.19.0.0

200.1.1.0

200.2.5.0

199.23.3.0

131.200.0.0

Destination

Distance

Prochain pas

144.19.0.0

Direct

130.21.0.0

Direct

200.1.1.0

144.19.1.100

200.2.5.0

144.19.1.101

199.23.3.0

130.21.5.30

131.200.0.0

130.21.5.32

Comparaison

Mise jour

Destination

Distance

Prochain pas

144.19.0.0

Direct

130.21.0.0

Direct

200.1.1.0

144.19.1.102

200.2.5.0

144.19.1.102

199.23.3.0

130.21.5.30

131.200.0.0

130.21.5.32

Principe RIP
Suppression dune route
La distance maximal est de 16 (count to infinity) et correspond un
rseau inaccessible.
Aprs 3 minutes (invalid timer), une route sur laquelle on na plus
dinformation devient inaccessible (cot de 16).
Elle sera dtruite de la table de routage 1 minute plus tard (route
flush timer), de faon diffuser linformation aux autres routeurs.

Problmes lis RIP


Les protocoles vecteur de distance ne communiquent leur informations que
priodiquement Il se peut donc qu'il y ait des retards dans la propagation des
mises jour sur l'ensemble des routeurs du rseau
Lorsque les routes changent rapidement cest possible davoir de mauvais
calcul de route Le routage ne sera alors pas optimis ou des datagrammes seront
perdus.
. Si le nombre de rseaux crot, la taille des informations de mise jour devient
importante et plus de routeurs changent leurs informations consommation de la
bande passante Il apparat donc que ce type de protocole n'est pas bien adapt
aux rseaux de grande taille.
Limitation du mtrique 16.
RIP ignore la notion dadressage de sous-rseau ( la version RIP2 , le prend en
charge )

Rsolution du problme de convergence lente.


Split horizon : Le routeur enregistre l'interface sur laquelle il reoit les
nouvelles routes, il n'enverra pas les mises jour de routage sur ces interfaces.
Flash update : Le routeur n'attend pas l'expiration de son intervalle de diffusion
pour diffuser l'information.

IGRP : Interior Gateway Routing Protocol

I G R P (vecteur de distance)
IGRP : Interior Gateway Routing Protocol est un protocole vecteur de distance mis
au point par CISCO
Informations de routage diffuses toutes les 90 secondes.
la mtrique utilis est une combinaison de :
Bande passante
Dlai
Charge du lien
Fiabilit (taux de succs)
Unit de transfert d'information maximale (MTU)

Exemple

Schma : il existe 2 chemins possibles entre les


deux postes.

19.2 Kbits/s

Le chemin le plus court mais le plus lent sera choisi


par RIP.
Le chemin le plus long mais le plus rapide sera
choisi par IGRP.

1.5 Mbits/s

1.5 Mbits/s

1.5 Mbits/s

Routage avec tat de lien


OSPF : Open Shortest Path First

Routage avec tat de lien


Les protocoles vecteur de distance ne sont pas bien adapts aux rseaux de
grande taille.
Les protocoles de routage tat de lien maintient une Base de Donnes
reprsentant la topologie complte du rseau .
Cette BDD permet d'tablir une carte reprsente sous forme d'un arbre dans lequel
les routeurs sont les nuds et les rseaux sont les arcs. La racine de l'arbre est le
routeur lui-mme.
A partir de cet arbre, calcule le chemin le plus court vers les destinations du rseau
en partant de lui-mme il peut ainsi construire sa table de routage.
Le calcul est effectu indpendamment sur chaque routeur la convergence est
donc rapide.

OSPF : Open Shortest Path First


Les routeurs OSPF changent des informations concernant l'tat de
leurs liaisons ( LSA ) .
L'tat dun lien peut tre : up (en activit) ou down (hors service).
Connatre l'tat d'une liaison permet un routeur de savoir s'il existe
un chemin de communication direct entre deux routeurs.
Chaque lien comporte une mtrique ( un poids ) pas forcment le
nombre de sauts .

OSPF
Dcouverte du rseau
Au dmarrage , un routeur dtecte les rseaux qui lui sont directement
connects , et il initialise a base de donnes topologique.
par la suite , il sollicite touts les routeurs pour avoir des informations il
demande leurs base de donnes topologique .
On se basant sur ces informations il va mettre jour a bases de donnes pour se
synchroniser donc lensemble de routeur vont avoir la mme base de donnes
d'informations.

Exemple de dcouverte du rseau pour le routeur A.

4 (R1)

12 ( R3)

B
1 ( R2)

3 (R4)

12

12

6 (R6)
2 ( R5)

Calcul du plus court chemin


L'algorithme de routage Shortest Path First (SPF) sert de base aux oprations d'OSPF
il se base sur lalgorithme de Djikstra pour le calcul du plus cours chemin.

le principe consiste construire un arbre dont la racine est le routeur qui excute
lalgorithme .

tapes 1 : Initialement , on place le routeur la racine , en suite on place les routeurs


qui lui sont directement accessible en indiquant les mtriques correspondantes.

tape2 : Par la suite , on prend la branche qui possde le plus petit poids et on place le
routeur associ comme routeur racine , et on refait ltape 1.

tape 3 : Si on trouve une autre branche ayant un poids infrieur alors on abondons la
branche courante et on refait ltape 1 partir de la nouvelle branche, jusqu traiter
toute les chemin

Larbre calcul des plus courts chemins permet de construire la table de routage.

Exemple : calcul de
A

larbre partir de A

4 (R1)
12 ( R3)

3 (R4)

1 ( R2)

6 (R6)
2 ( R5)

A
12
B

4
D

A
12

4
D

12

6
E

3
E

2
C

4
D

3
C

6
B

C
4

2
A

4
D

2
C
6
B

Gnration de la nouvelle base de donnes

4 (R1)

A
12 (R3)
B
1 (R2)
D

1
D

3 (R4)

6 (R6)
2 (R5)

C
6
B

Destinati
on

Passer
par

Cot

direct

Gnration de la nouvelle table de routage


Destinatio
n

Passer par

Cot

direct

Destination

Passer par

Cot

R1

direct

R2

direct

R3

direct

R3

R6

R4

R5

R6

R2

R5

R1

R4

Destination

Passer par

Cot

R1, R2, R3

direct

R3, R6

R4, R5, R6

R2, R5

R1, R4

Gnration de la nouvelle base de donnes


Destination

Passer par

Cot

R1

direct

R2

direct

R3

direct

R3

R6

R4

R5

R6

R2

R5

R1

R4

Sil y a une redondance


choisir la route
ayant le plus petit cot

Destination

Passer par

Cot

R1

direct

R2

direct

R3

direct

R4

R6

R5

Exercice
Donner la table de routage du routeur A
4 (R1)

A
2 (R3)
B
1 (R2)
D

3 (R4)
1 (R6)

3 (R5)

OSPF (suite)
Inconvnients du routage tat de liaison
Traitement et Mmoire
Les routeurs doivent utiliser plus de mmoire et excuter plus de traitements que pour les protocoles
vecteur de distance.
Les routeurs mettent jour leurs donnes par rapport tous les autres routeurs Leur mmoire doit donc
tre en mesure de contenir toute cette information.

Bande passante
La largeur de bande consacre l'inondation initiale ( dcouverte du rseau ) de donnes peut tre trs
importante. Tous les routeurs transmettent des donnes de mise jour tous les autres routeurs. Ce
processus rduit temporairement la quantit de bande passante disponible pour les utilisateurs.
Ensuite, les protocoles ncessitent peu de bande passante pour transmettre des mise jour qui ne refltent
que des changements topologiques.

Amlioration de lOSPF
Pour amliorer les performance du protocole OSPF , le rseau est dcoup en
plusieurs zone ( area )
Chaque area contient un ensemble de routeurs ( < 50 )
Les routeur lintrieurs dune zone sont dits routeurs internes et il utilise utilise
le protocole OSPF .
Il existe des routeur qui permet de relier les diffrentes zone.
ces routeur appartienne une zone appele BACKBONE ( area 0 ), qui consiste
en un ensemble de routeurs qui permet de relier les diffrentes area.
Les routeur dune zone qui communique avec la zone 0 sont dit routeur de
brodeur ( ABR : Area Border Routers).)

Les routeur R1, R2, R3 et R4 appartient larea 1


Les routeur R7, R8, R9 et R10 appartient larea 2
Les routeur R13, R12, R11 et R4 appartient larea 3
Les routeurs R4, R5, R6, R10, R11, et R12 constituent le backbone ( area 0 )

OSPF avec un dcoupage en zone

Une base de donnes topologiques est une vue globale des rseaux en relation avec des
routeurs.

La base de donnes topologiques contient la collection de LSAs reue de tous les routeurs
dans la mme zone.

Dans une zone , les bases de donnes topologiques de tous les routeurs sont identiques.

La topologie d'une zone est invisible en dehors de la zone . En conservant des topologies
des zone spares OSPF gnre moins de trafic de routage.

La division en zone cre deux types de routages le routage intra-zone et le routage interzone.

Les routeur du Backbone ( zone 0 ) utilise lOSPF est responsable de l'acheminement de


l'information de routage entre les zone. Elle se compose de tous les routeurs de frontire
de secteur (Area Border Routers).

Exemple de configuration de lOSPF avec des routeur CISCO


Router A - Internal Router
interface ethernet 1
ip address 131.108.1.1 255.255.255.0
router ospf 1
network 131.108.0.0 0.0.255.255 area 1
Router B - Internal Router
interface ethernet 2
ip address 131.108.1.2 255.255.255.0
router ospf 202
network 131.108.0.0 0.0.255.255 area 1
Router C - Area Border Router
interface ethernet 3
ip address 131.108.1.3 255.255.255.0
interface serial 0
ip address 131.108.2.3 255.255.255.0
router ospf 999
network 131.108.1.0 0.0.0.255 area 1
network 131.108.2.0 0.0.0.255 area 0