Vous êtes sur la page 1sur 36

PAKET ROUTING DAN

FORWADING
Editor:
Sigit Wasista
PENS-ITS
2008-2011

APA ITU ROUTER?

A router is a computer, just like any other computer


including a PC. The very first router, used for the
Advanced Research Projects Agency Network
(ARPANET), was the Interface Message Processor
(IMP). The IMP was a Honeywell 316 minicomputer;
this computer brought the ARPANET to life on August
30, 1969.

ROUTER ADALAH KOMPUTER

Power
Supply

ARSITEKTUR RUTER

Flash
SIMM
RAM
DIMM
CPU

KETERANGAN RAM

RAM stores the instructions and data needed to be executed by


the CPU. RAM is used to store these components:
Operating System: The Cisco IOS (Internetwork Operating
System) is copied into RAM during bootup.
Running Configuration File: This is the configuration file that
stores the configuration commands that the router IOS is
currently using. With few exceptions, all commands configured on
the router are stored in the running configuration file, known as
running-config.
IP Routing Table: This file stores information about directly
connected and remote networks. It is used to determine the best
path to forward the packet.
ARP Cache: This cache contains the IPv4 address to MAC
address mappings, similar to the ARP cache on a PC. The ARP
cache is used on routers that have LAN interfaces such as
Ethernet interfaces.
Packet Buffer: Packets are temporarily stored in a buffer when
received on an interface or before they exit an interface.

BLOK DIAGRAM ROUTER

RUTER PADA PUSAT JARINGAN

A router connects multiple networks. This means that it has


multiple interfaces that each belong to a different IP network.
When a router receives an IP packet on one interface, it determines
which interface to use to forward the packet onto its destination.
The interface that the router uses to forward the packet may be the
network of the final destination of the packet (the network with the
destination IP address of this packet), or it may be a network
connected to another router that is used to reach the destination
network.

ROUTER MENENTUKAN
JALUR TERBAIK
The

router uses its routing table to


determine the best path to forward the
packet. When the router receives a packet,
it examines its destination IP address and
searches for the best match with a
network address in the router's routing
table. The routing table also includes the
interface to be used to forward the packet.
Once a match is found, the router
encapsulates the IP packet into the data
link frame of the outgoing or exit
interface, and the packet is then
forwarded toward its destination.

ROUTER MENENTUKAN
JALUR TERBAIK

INTERNETWORK OPERATING
SYSTEM (IOS)

The operating system software used in Cisco routers is


known as Cisco Internetwork Operating System (IOS).
Like any operating system on any computer, Cisco IOS
manages the hardware and software resources of the
router, including memory allocation, processes, security,
and file systems. Cisco IOS is a multitasking operating
system that is integrated with routing, switching,
internetworking, and telecommunications functions.

ROLE OF THE ROUTER

The router is a special-purpose computer that plays a


key role in the operation of any data network. Routers
are primarily responsible for interconnecting networks
by:
Determining the best path to send packets
Forwarding packets toward their destination

PENGENALAN TOPOLOGI

The topology consists of three routers, labeled R1, R2, and


R3. Routers R1 and R2 are connected through one WAN
link, and routers R2 and R3 are connected through another
WAN link. Each router is connected to a different Ethernet
LAN, represented by a switch and a PC.

TABEL ALAMAT

HUBUNGAN DAN
KONEKTOR

KONEKTOR SERIAL

For WAN connections, Cisco routers support the EIA/TIA-232,


EIA/TIA-449, V.35, X.21, and EIA/TIA-530 standards for serial
connections, as shown. Memorizing these connection types is not
important. Just know that a router has a DB-60 port that can
support five different cabling standards. Because five different
cable types are supported with this port, the port is sometimes
called a five-in-one serial port. The other end of the serial cable is
fitted with a connector that is appropriate to one of the five possible
standards.

KABEL SERIAL DTE

Newer routers support the


smart serial interface that
allows for more data to be
forwarded across fewer
cable pins. The serial end
of the smart serial cable is
a 26-pin connector. It is
much smaller than the
DB-60 connector used to
connect to a five-in-one
serial port. These
transition cables support
the same five serial
standards and are
available in either DTE or
DCE configurations.

KONEKSI ETHERNET

A different connector is used


in an Ethernet-based LAN
environment. An RJ-45
connector for the unshielded
twisted-pair (UTP) cable is
the most common connector
used to connect LAN
interfaces. At each end of an
RJ-45 cable, you should be
able to see eight colored
strips, or pins. An Ethernet
cable uses pins 1, 2, 3, and 6
for transmitting and receiving
data.
Crossover cables are used for:

Switch-to-switch
PC-to-PC
Switch-to-hub
Hub-to-hub
Router-to-router
Router-to-server

Straight-through cables are


used for:
Switch-to-router
Switch-to-PC
Hub-to-PC
Hub-to-server

PRAKTIKUM 1
PENGENALAN ROUTER
Menggunakan Packet Tracer 5
atau setaranya

KONFIGURASI DASAR ROUTER

When configuring a router,


certain basic tasks are
performed including:

Naming the router


Setting passwords
Configuring interfaces
Configuring a banner
Saving changes on a
router
Verifying basic
configuration and router
operations

Router>
The enable command is
used to enter the privileged
EXEC mode. This mode
allows the user to make
configuration changes on the
router. The router prompt will
change from a ">" to a "#" in
this mode.

Router>enable
Router#

KONFIGURASI BANNER

From the global configuration mode, configure


the message-of-the-day (motd) banner. A
delimiting character, such as a "#" is used at the
beginning and at the end of the message. The
delimiter allows you to configure a multiline
banner, as shown here.

R1(config)#banner motd #
Enter TEXT message. End with the character '#'.
******************************************
WARNING!! Unauthorized Access Prohibited!!
******************************************
#

KONFIGURASI INTERFACE
Konfigurasi alamat IP dan subnet mask:
ROUTER
R1(config)#interface Serial0/0

R1(config-if)#ip address 192.168.2.1 255.255.255.0


In lab environments, enter a simple description that will help in
troubleshooting situations; for example:
R1(config-if)#description Link to R2
After configuring the IP address and description, the interface
must be activated with the no shutdown command.
R1(config-if)#no shutdown
When cabling a point-to-point serial link in our lab environment,
one end of the cable is marked DTE and the other end is marked
DCE. The router that has the DCE end of the cable connected to
its serial interface will need the additional clock rate command
configured on that serial interface.
R1(config-if)#clock rate 64000

KONFIGURASI LENGKAP
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#description R1 LAN
R1(config-if)#no shutdown

VERIFIKASI KONFIGURASI DASAR

VERIFIKASI KONFIGURASI DASAR

VERIFIKASI KONFIGURASI DASAR

VERIFIKASI KONFIGURASI DASAR

VERIFIKASI KONFIGURASI DASAR

PRAKTIKUM 2
VERIFIKASI ROUTER
Menggunakan Packet Tracer 5
Atau setaranya

MELIHAT KONFIGURASI
INTERFACE

Perhatikan Router R1
Ada dua mode konfigurasi yaitu Global dan Privilege,
mode global untuk semua user yang sekedar melihatlihat, sedangkan mode privledge untuk yang berhak.
R1>enable <enter> (untuk masuk pada mode privelege)
R1#

TABEL ALAMAT

KONFIGURASI INTERFACE
ETHERNET

R1#conf term
R1(config)#interface fa 0/0
R1(config-if)#ip address 192.16.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#^Z

KONFIGURASI INTERFACE SERIAL


R1#conf term
R1(config)#interface serial0/0/0
R1(config-if)#ip address 192.16.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#^Z

DINAMIK ROUTING: ROUTING


INFORMATION PROTOCOL (RIP)

RIP adalah sebuah protokol routing dinamis yang digunakan


dalam jaringan LAN (Local Area Network) dan WAN (Wide
Area Network). Oleh karena itu protokol ini diklasifikasikan
sebagaiInterior Gateway Protocol(IGP). Protokol ini
menggunakan algoritmaDistance-Vector Routing.
Pertama kali didefinisikan dalamRFC 1058(1988). Protokol
ini telah dikembangkan beberapa kali, sehingga terciptalah
RIP Versi 2 (RFC 2453).
Kedua versi ini masih digunakan sampai sekarang, meskipun
begitu secara teknis mereka telah dianggap usang oleh teknikteknik yang lebih maju, sepertiOpen Shortest Path
First(OSPF) dan protokolOSIIS-IS. RIP juga telah
diadaptasi untuk digunakan dalam jaringan IPv6, yang
dikenal sebagai standarRIPng(RIPNext Generation/ RIP
generasi berikutnya), yang diterbitkan dalamRFC
2080(1997).

KONFIGURASI ROUTING PROTOKOL


R1 SECARA DINAMIK (RIP)
R1#conf term
R1(config)#router rip
R1(config)#network 192.16.2.0
R1(config)#network 192.16.3.0
R1(config)#^Z
R1#

KONFIGURASI ROUTING PROTOKOL


R2 SECARA DINAMIK (RIP)
R2#conf term
R2(config)#router rip
R2(config)#network 192.16.2.0
R2(config)#network 192.16.1.0
R2(config)#^Z
R2#

KONFIGURASI ROUTER
MENGGUNAKNA STATIK ROUTING
R1#conf term
R1(config)#ip route 192.16.1.0 255.255.255.0
192.16.2.2
R1(config)#ip route 192.16.3.0 255.255.255.0
192.16.2.1
R1(config)#^Z
R1#