Vous êtes sur la page 1sur 40

Introduction BGP

Border Gateway Protocol


Un protocole de routage utilis pour changer des
informations de routage entre les diffrents
rseaux
Exterior gateway protocol

Dcrit dans RFC4271


RFC4276 donne un rapport d'excution sur BGP
RFC4277 dcrit les expriences oprationnelles en
utilisant BGP

Le systme autonome est la pierre angulaire de


BGP
Il est utilis pour identifier de faon unique les rseaux
ayant une politique de routage commune
2

BGP
Path Vector Protocol
Mises jour incrmentales
Beaucoup d'options pour l'application
des stratgies
Classless Inter Domain Routing
(CIDR)
Largement utilis pour le backbone
Internet
Systmes autonomes
3

Path Vector Protocol


BGP est class comme un protocole
de routage path vector (voir RFC
1322)
Un protocole path vector dfinit un
trajet comme un appariement entre une
destination et les caractristiques de la
voie qui
mne cette
12.6.126.0/24
207.126.96.43
1021 0 destination.
6461 7018 6337 11268 i
AS Path

Path Vector Protocol


AS11268

AS6337
AS7018

AS500
AS6461
AS600
5

Dfinitions
Transit acheminement de trafic sur
un rseau, gnralement moyennant
un payement
Peering changer des informations
de routage et de trafic
Default o envoyer le trafic quand il
n'y a pas de correspondance explicite
dans la table de routage
6

Zone franche par dfaut


(Default Free Zone)
La zone franche par dfaut est
constitue de routeurs Internet qui
ont des informations de routage
explicites sur le reste de l'Internet
et n'ont donc pas besoin d'utiliser
une route par dfaut
NB: n'est pas lie
l'emplacement d'un ISP dans
7
la hirarchie

Exemple de Peering et de
Transit
provider A

IXP-OUEST

Backbone
Provider D

IXP-EST

provider B
provider C

A et B peuvent sapparis,
mais ont besoin
d'arrangements de transit avec
D pour obtenir/envoyer des
paquets de/vers C

Systme autonome (AS)


AS 100

Collection de rseaux avec la mme politique


de routage
Protocole de routage unique
Habituellement en proprit, confiance et
contrle administratif unique
Identifi par un entier 32 bits unique9 (ASN)

Numro de systme autonome


(ASN)
Deux gammes
0-65535
(original 16-bit range)
65536-4294967295 (32-bit range RFC4893)

Usage:

0 and 65535
(rserv)
1-64495
(Internet public)
64496-64511
(documentation RFC5398)
64512-65534
(usage priv uniquement)
23456
(represent 32-bit range in 16-bit
world)
65536-65551
(documentation RFC5398)
65552-4294967295 (Internet public)

Reprsentation de gamme 32 bits spcifie dans


RFC5396
Dfinit asplain (format traditionnel) comme
notation
10

Numro de systme autonome


(ASN)
Les ASN sont distribus par les Registres Internet
Rgionaux
Ils sont galement disponibles auprs de fournisseurs de
services Internet en amont qui sont membres de l'un des
RIR

Les allocations ASN actuelles de 16-bit jusqu'


61439 ont t faites pour les RIR
Environ 41200 sont visibles sur Internet

Chaque RIR a galement reu un bloc d'ASN 32bit


Sur les 2800 affectations, autour de 2400 sont visibles
sur Internet

Voir www.iana.org/assignments/as-numbers
11

Configurer BGP dans Cisco


IOS
Cette commande active BGP dans Cisco IOS:
routeur bgp 100

Pour les ASN> 65535, le numro d'AS peut tre


entr en notation "plain" ou "dot ":
router bgp 131076
ou

router bgp 2.4

IOS affiche les ASN en notation "plain" par dfaut


La notation "Dot" est facultative:
router bgp 2.4
bgp asnotation dot

12

Notions de base BGP


Peering
A

AS 100

AS 101
D

Fonctionne sur TCP - port


179
Path vector protocol
Mises jour incrmentales
BGP Interne et Externe

AS 102

13

Zone de dmarcation (DMZ)


A

AS 100

Rseau
DMZ

AS 101
D

AS 102
DMZ est le lien ou rseau partag entre les AS
14

Opration gnrale BGP


Apprend de multiples chemins par
l'intermdiaire de haut-parleurs BGP
internes et externes
Choisit le meilleur chemin et l'installe
dans la table de routage (RIB)
Le meilleur chemin est envoy aux
voisins BGP externes
Les stratgies sont appliques en
influant sur le choix du meilleur
chemin
15

Construire le tableau de
Transfert (Forwarding Table)
Processus BGP entrant
reoit les informations de chemin des pairs
les rsultats de la slection de chemin BGP placs dans
la table BGP
Meilleur chemin marqu

Processus BGP sortant


annonce meilleur chemin aux pairs

Meilleur chemin stock dans la table de routage


(RIB)
Les meilleurs chemins dans le RIB sont ajouts au
tableau de transfert (forwarding table - FIB) si:
prfixe et longueur de prfixe sont uniques
distance protocole la plus faible

16

Construire le tableau de
Transfert (Forwarding Table)
entrant

Processus
BGP "entrant

cart
accept

tous

bgp

table
BGP

peer

Table
routage

meilleurs chemins

sortant

table
transfert

Processus
BGP "sortant"

17

eBGP & iBGP


BGP utilis en interne (iBGP) et
externe (eBGP)
iBGP utilis pour transporter
Certains / tous les prfixes Internet
travers le backbone ISP
les prfixes des clients ISP

eBGP utilis pour


Echanger des prfixes avec d'autres AS
Mettre en uvre la politique de routage
18

Modle BGP/IGP utilis dans les


rseaux ISP
Reprsentation du modle
eBGP

eBGP

eBGP

iBGP

iBGP

iBGP

iBGP

IGP

IGP

IGP

IGP

AS1

AS2

AS3

AS4
19

External BGP Peering (eBGP)


A

AS 100

AS 101

Entre haut-parleurs BGP dans


diffrents AS
Doivent tre directement connects
Ne jamais excuter un IGP entre
20

Configurer un BGP externe


Routeur A dans AS100

adresse IP sur
interface Ethernet

interface Ethernet 5/0


adresse ip 102.102.10.2 255.255.255.240
!
ASN locale
routeur bgp 100
rseau 100.100.8.0 masque 255.255.252.0
ASN distant
neighbor 102.102.10.1 remote-as 101
neighbor 102.102.10.1 prefix-list RouterC in
neighbor 102.102.10.1 prefix-list RouterC out
!

Filtres entrants
et sortants

adresse ip de linterface
Ethernet du routeur C
21

Configurer un BGP externe


Routeur C dans AS101

adresse IP sur
interface Ethernet

interface ethernet 1/0/0


adresse ip 102.102.10.1 255.255.255.240
!
ASN locale
routeur bgp 101
network 100.100.64.0 mask 255.255.248.0
ASN distant
neighbor 102.102.10.2 remote-as 100
neighbor 102.102.10.2 prefix-list RouterA in
neighbor 102.102.10.2 prefix-list RouterA out
!

Filtres entrants
et sortants

adresse ip de linterface
Ethernet du routeur A
22

BGP interne (iBGP)


BGP peer dans le mme AS
Pas requis d'tre directement connect
IGP prend soin de la connectivit de haut-parleurs
inter-BGP

Les haut-parleurs iBGP doivent tre


entirement maills:
Ils gnrent des rseaux connects
Ils transmettent des prfixes appris de l'extrieur
de l'ASN
Ils ne transmettent pas des prfixes appris
dautres haut-parleurs iBGP
23

Peering BGP interne (iBGP)


AS 100
A

Topologie indpendante
Chaque haut-parleur iBGP doit sapparier (peer)
avec chacun des autres haut-parleurs iBGP dans
24
l'AS

Peering entre interfaces de Loopback


AS 100
C

Peer with loop-back interface

L'interface de loop-back ne faillit pas - jamais!

Ne laissez pas une session IBGP dpendre de l'tat


d'une interface unique ou de la topologie physique
25

Configurer un BGP interne


Routeur A dans AS100

adresse IP sur
interface loopback

interface loopback 0
adresse ip 105.3.7.1 255.255.255.255
!
ASN locale
routeur bgp 100
network 100.100.1.0
ASN locale
neighbor 105.3.7.2 remote-as 100
neighbor 105.3.7.2 update-source loopback0
neighbor 105.3.7.3 remote-as 100
neighbor 105.3.7.3 update-source loopback0
!
adresse ip de linterface
loopback du routeur B
26

Configurer un BGP interne


Routeur B dans AS100

adresse IP sur
interface loopback

interface loopback 0
adresse ip 105.3.7.2 255.255.255.255
!
ASN locale
routeur bgp 100
network 100.100.1.0
ASN locale
neighbor 105.3.7.1 remote-as 100
neighbor 105.3.7.1 update-source loopback0
neighbor 105.3.7.3 remote-as 100
neighbor 105.3.7.3 update-source loopback0
!
adresse ip de linterface
loopback du routeur A
27

Insrer des prfixes dans


BGP
Deux faons d'insrer des prfixes
dans BGP
redistribuer statique
(redistribute static)
commande rseau (network command)

28

Insrer des prfixes dans


BGP
redistribuer statique

Exemple de configuration:

routeur bgp 100


redistribuer statique (redistribute static)
route ip 102.10.32.0 255.255.254.0 serial0

Une route statique doit exister


avant que la commande
redistribuer fonctionne
Force l'origine tre incomplte
Soins requis!
29

Insrer des prfixes dans


BGP
redistribuer statique

Soins requis avec redistribuer!

redistribuer <routing-protocol>
signifie que tout dans le <routingprotocol> sera transfr dans l'actuel
protocole de routage
Ne s'ajustera pas s'il n'est pas contrl
Prfrable d'viter autant que possible
redistribuer normalement utilis avec
route-maps et sous contrle
administratif serr
30

Insrer des prfixes dans


BGP
commande rseau

Exemple de configuration

routeur bgp 100


network 102.10.32.0 mask 255.255.254.0
route ip 102.10.32.0 255.255.254.0 serial0

Un itinraire correspondant doit


exister dans la table de routage
avant que le rseau soit annonc
Force l'origine tre IGP

31

Configurer une agrgation


Trois faons de configurer
l'agrgation ditinraires
redistribuer statique
(redistribute static)
adresse-agrgats
commande rseau (network command)

32

Configurer une agrgation


Exemple de configuration:
routeur bgp 100
redistribuer statique (redistribute static)
route ip 102.10.0.0 255.255.0.0 null0 250
une route statique vers null0 est appele une route
pull up
Paquets envoys ici uniquement s'il n'y a plus de
correspondance spcifique dans la table de routage
distance de 250 assure que ceci est le dernier
recours statique
soins requis - voir plus haut!

33

Configurer une agrgation


Commande rseau
Exemple de configuration
routeur bgp 100
network 102.10.0.0 mask 255.255.0.0
route ip 102.10.0.0 255.255.0.0 null0 250

Un itinraire correspondant doit


exister dans la table de routage
avant que le rseau soit annonc
Moyen le plus simple et le meilleur
de gnrer un agrgat
34

Configurer une agrgation


commande dadresse
agrgats
Exemple de configuration:
routeur bgp 100
network 102.10.32.0 mask 255.255.252.0
aggregate-address 102.10.0.0 255.255.0.0 [summary-only]

Ncessite un prfixe plus spcifique dans le tableau


BGP avant que lagrgat soit annonc
Mot-cl uniquement de rsum (summary-only
keyword)
Mot-cl facultatif qui garantit que seul le rsum est
annonc si un prfixe plus spcifique existe dans la table de
routage

Rsum
BGP neighbour status
Router6>shipbgpsum
BGProuteridentifier10.0.15.246,localASnumber10
BGPtableversionis16,mainroutingtableversion16
7networkentriesusing819bytesofmemory
14pathentriesusing728bytesofmemory
2/1BGPpath/bestpathattributeentriesusing248bytesofmemory
0BGProutemapcacheentriesusing0bytesofmemory
0BGPfilterlistcacheentriesusing0bytesofmemory
BGPusing1795totalbytesofmemory
BGPactivity7/0prefixes,14/0paths,scaninterval60secs
NeighborVASMsgRcvdMsgSentTblVerInQOutQUp/DownState/PfxRcd
10.0.15.24141098160000:04:472
10.0.15.24241065160000:01:432
10.0.15.24341098160000:04:492
...

Version BGP

Mises jour
envoyes et
reues

Mises jour en attente


36

Rsum
Table BGP
Router6>shipbgp
BGPtableversionis30,localrouterIDis10.0.15.246
Statuscodes:ssuppressed,ddamped,hhistory,*valid,>best,i
internal,
rRIBfailure,SStale
Origincodes:iIGP,eEGP,?incomplete
NetworkNextHopMetricLocPrfWeightPath
*>i10.0.0.0/2610.0.15.24101000i
*>i10.0.0.64/2610.0.15.24201000i
*>i10.0.0.128/2610.0.15.24301000i
*>i10.0.0.192/2610.0.15.24401000i
*>i10.0.1.0/2610.0.15.24501000i
*>10.0.1.64/260.0.0.0032768i
*>i10.0.1.128/2610.0.15.24701000i
*>i10.0.1.192/2610.0.15.24801000i
...
37

Rsum

BGP4 protocole path vector


iBGP contre eBGP
iBGP stable - pairs avec loopbacks
annonant prfixes et agrgats

38

Reconnaissance et
attribution
Cette prsentation contient des informations
initialement dveloppes et maintenues par les
organisations et individu suivants et prvues pour le
projet AXIS de l'Union africaine
Cisco ISP/IXP Workshops
Philip Smith: - pfsinoz@gmail.com

www.apnic.net

Introduction BGP
Fin

40