Vous êtes sur la page 1sur 96

Nokia Academy

IP Backbone Network Planning with


Juniper
Learning Element 3 Core Routing and
Switching Protocols

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Copyright and confidentiality

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Objectives
After completing this learning element, participant should be able to:
- express IGP design considerations.
- describe the operational and functional characteristics of OSPF.
- configure and verify OSPF routing.
- describe the operational and functional characteristics of IS-IS.
- configure and verify IS-IS routing.
- discuss the different IGP protocols and respective impact on detailed
planning.
- define the characteristics of BGP.
- recognize BGP scaling problems.
- configure and verify BGP routing.
- characterize MPLS control plane and MPLS Forwarding plane functionality.
- deploy and verify MPLS into an existing network.

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IP backbone topology
Router roles
Core (P)

ICR other providers link


P-ICR link
P-RR link
P-P link
PE-P/PE link
PE-CE link

Transit routers
IGP + MPLS +
LDP/RSVP

VPN routes exchange


IGP + MPLS +
LDP/RSVP + MP-BGP

Interconnection (ICR)

Internet Gateways
IGP + MPLS +
LDP/RSVP + EBGP +
MP-BGP

Customer edge (CE)

Service

Provider 1

Provider 2

Customer premises
Managed by
customer/ISP

Customer
2

Site 1

Site 4

CE

Customer
1

CE

Customer
2

PE

CE

PE

.
Customer
n

PE

CE

CE

CE

CE

Site 3

Site 2
Customer
1

Customer
2

CE

CE

Customer
1

CE

Customer
2

PE

PE
CE

PE

.
Customer
n

CN10563EN03GLA1

PE

CE

.
CE

CE

Interconnection Router

ICR

P
P

PE

Route Reflector

RR

VPN Routes

CE

Provider Edge Router

PE

RR

Customer
1

Provider Router

ICR

ICR

Ingress/egress user
traffic
IGP + MPLS +
LDP/RSVP + MP-BGP

Route reflectors (RR)

Service

RR

Edge (PE)

Internet

CE

Nokia Solutions and Networks 2015

Customer
n

Customer
n

Core Routing and Switching Protocols


IGP Topics
IGP:
MPLS Enabled Applications
OSPF
L3 VPN

MPLS TE

QOS

FRR

Label Switching
IGP

BGP

Network Topology

CN10563EN03GLA1

IS-IS

Agenda:
1.
2.
3.
4.
5.
6.
7.
8.

Justification
Terminology
Topology
Addressing
Operation
Authentication
Basic Configuration
Tuning Configuration

Nokia Solutions and Networks 2015

Open Shortest Path First (OSPF)


Link State Routing Protocol
Scalable solution due to the use of Areas
Promotes efficient use of bandwidth
Uses a 2 level hierarchical model
Makes route selection based on costs associated to link capacity
The preferred routes for a given Area are calculated accordingly to Dijkstras algorithm
(SPF)
Fast convergence using less control messages
Allows for VLSM, summarization and CIDR
Allows Equal Cost Multi-Path (ECMP)

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Terminology - Link State Protocol


Link-State Routers have a deeper knowledge about the surrounding network, when
compared with the distance-vector protocols like RIP. As a consequence they tend to do
more accurate routing decisions.
The Link-State Routers collect and maintain information about:
- who are their neighbors;
- all Routers inside the same Area;
- The best paths towards a given destination network.

Neighbor table:
- Also known as adjacency database, contains a list of all known neighbors

Topology table:
- Also known as Link-state Data Base (LSDB), contains information about all routers and links in a
given area.
- The LSDB is identical between routers in the same area.

Routing table:
- Also known as Forwarding Database, contains the list of the best paths for each destination
network.

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Terminology - Link State Protocol

Topological
Database

Link-State Packets

Routing
Table

SPF
Algorithm
Shortest-Path-First Tree

After the initial diffusion only small event-triggered link-state updates are transmitted
between the routers.

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Terminology - Shortest Path First Algorithm

The best routes for each destination are discovered by the routers by applying the Dijkstra Algorithm (SPF) to the Link-State Database:

10

All routers inside the same area will have identical LSDB.

The algorithm places each router at the root of a tree and calculates the shortest path to each destination.

Routes are calculated based on the sum of individual costs for a given path in order to reach a destination network.

Only the best routes (lowest cost) are placed in the Forwarding Database.

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Topology
Overview

Routers discover their neighbors by exchanging


Hello packets.
Routers consider their neighbors to be active
after they have checked certain parameters and
options inside the Hello packet.
For WAN Point-to-point links :
All neighbors build adjacencies.
For LAN links:
Routers form adjacencies only with DR and
BDR.
With the remaining routers the state of
adjacency is kept as two-way

Routing updates and topology information are only exchanged between adjacent routers.
After the adjacency is formed:
LS database packets are exchanged to synchronize the LSDBs.
LSAs (Link state advertisements) are distributed in a reliable way throughout
all network using known adjacencies.

11

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Topology - Scalability

Im receiving too
many LSAs!

SPF algorithm is
running very often!

My Routing Table is too big. Im


almost out of memory!

12

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Topology - Areas


Autonomous System

Area 2

Area 3

Area 1

13

Backbone Area 0

Minimizes the number of entries in the Routing Table.


The impact of a network failure or modification is local to that Area.
The flooding of detailed SLAs stops in the Area border.
The network design must be structured in a hierarchical model.
All existing Areas must connect directly to the Backbone Area (exception: virtual link)

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Topology Areas Example


Network Range
192.168.0.0 192.168.255.255

Destination Network
192.168.0.0/24
192.168.1.0/24

192.168.16.0/20
192.168.32.0/24
192.168.33.0/24

192.168.48.0/20

Area 3
192.168.48.0
192.168.49.0
...
192.168.63.0

Router
Area 1
192.168.16.0
192.168.17.0
...
192.168.31.0

Router

Area 0
192.168.0.0
192.168.1.0
...
192.168.15.0

Router

14

CN10563EN03GLA1

Router

Destination Network
192.168.0.0/20
192.168.16.0/20
192.168.32.0/24
192.168.33.0/24

192.168.48.0/20

Nokia Solutions and Networks 2015

Area 2
192.168.32.0
192.168.33.0
...
192.168.47.0

Router

OSPF Topology - Router Types

Area
Border
Router
ABR

Backbone/
Internal Routers

Internal
Routers
Internal
Routers

Autonomous
System Border
Router ASBR

15

CN10563EN03GLA1

Area
Border
Router
ABR

Nokia Solutions and Networks 2015

OSPF Router ID
A router is known by its Router ID inside the OSPF context.
The LSDBs use the Router ID to identify and distinguish router information inside.
By default, the Router ID is the highest IP address configured for an active interface in
the moment the OSPF process is initiated.
If a loopback interface is configured, then the Router ID will assume that value.
Its recommended to have configured a loopback interface to improve the protocols
stability.

16

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPFv2 Packet

17

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Packet Types


Hello Packet (Type 1)
Discover and maintain neighbors, using 224.0.0.5 (all OSPF routers)
Database Description Packet (Type 2)
Abstract of all LSAs in LSDB
Link State Request Packet (Type 3)
Ask the neighbor for its copy of the local LSAs during the database synchronization
process.
Link State Update Packet (Type 4)
Used in the flooding of LSAs and to send LSAs as response to Link State Request.
Link State Acknowledgment Packet (Type 5)
To confirm the LSU packet the router has received.

18

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Hello Packet

Parameters marked with a * must be


identical between neighboring routers, or
else the adjacency will not be established.
19

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Operation - OSPF Adjacencies

State
Down
Attempt

Router

Router ID 1.1.1.1

Router ID 2.2.2.2

Router

State

Down
Hello
Init
I have Router ID 1.1.1.1 and I still dont know anyone!
Router 2.2.2.2
registers 1.1.1.1 as a
neighbor

Hello

2-Way

I have Router ID 2.2.2.2 and I know 1.1.1.1

20

CN10563EN03GLA1

Nokia Solutions and Networks 2015

2-Way

OSPF Operation - Exchanging Routing Information


State

Ex-Start

Exchange
Loading

Router
Router ID 1.1.1.1

Router
Router ID 2.2.2.2

Hello
I have Router ID 1.1.1.1 and I will start the exchange!
Hello
No, I will start because my ID is higher!
DB Description
Here goes a summary of my link-state DB

State

Ex-Start
Exchange

DB Description
Here goes a summary of my link-state DB
Link State Request
I need detailed information for network x.x.x.x

Loading

Link State Update


Here goes the complete entry for network x.x.x.x
Link State Acknowledgement

Full
21

I confirm I have received the information!


CN10563EN03GLA1

Nokia Solutions and Networks 2015

Full

OSPF Operation - Normal Operation

Router

Router ID 1.1.1.1

Router
Router ID 2.2.2.2

Every 10 sec. Hello

Refresh
Every 30 min.

Every 10 sec.
Hello
Link State Update

Link State Update

Refresh
Every 30 min.

Every LSA record has a sequence number associated to it.


A 4-bytes number is used, starting from 0x80000001, and ending with 0x7fffffff.
Each LSA record is sent by OSPF in 30 min. Intervals to guarantee the synchronization of

the DBs. Each time the sequence number is incremented.


When a Router receives 2 records of the SLA, it will check the associated sequence number
to determine which one is more recent.
22

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Operation - Network Changes

23

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Link State Advertisements (LSA) Types

24

LSA Type

Description

Router LSA

Network LSA

Network Summary LSA

ASBR Summary LSA

AS External LSA

For Not-So-Stubby Areas

9, 10, 11

Opaque LSAs (Link scope, Area Scope, AS scope)

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Timer

25

Default
Value

Timer

10 sec

Hello interval

Frequency with which the router sends hello


packets out of an interface

40 sec

Dead interval

How long OSPF waits before declaring that a


neighboring router is unavailable

120 sec

Poll interval

5 sec

Retransmit interval

1 sec

Transmit delay

CN10563EN03GLA1

Description

How often the router sends hello packets out of


the interface before it establishes adjacency with
a neighbor (for non-broadcast interfaces only)

How long the router waits to receive an LSAck


packet before retransmitting the LSA
Estimated time required to transmit a LSA update
on the interface

Nokia Solutions and Networks 2015

OSPF Authentication
Simple Password Authentication
One password key configured per Area
Routers in the same Area must be configured with the same key
Vulnerable to passive attacks
Message Digest Authentication
Cryptographic Authentication based in key and key-id
A message digest is generated by an algorithm, based on the OSPF packet, the key and
key-id
The message is appended to the packet
The key is not transmitted over the wire, like in simple authentication
Allows for uninterrupted transitions between keys

26

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF topology
P

OSPF Area 0

PE

ICR

RR

Provider Router
Provider Edge Router
Route Reflector

P-ICR link

RR

ICR

P-RR link
P-P link

ICR

PE-P/PE link

RR

27

PE

PE

PE

PE

CN10563EN03GLA1

PE

PE

PE

PE

Nokia Solutions and Networks 2015

Interconnection Router

OSPF Commands - Basic Configuration


Configuration of an Interface IP:
[edit]
user@host# set interfaces ge-0/2/0 unit 0 family inet address 10.0.0.1

Creating an OSPF Area (Backbone Area 0.0.0.0):


[edit]
user@host# edit protocols ospf area 0.0.0.0

Assigning interface ge-0/2/0 to OSPF Area 0.0.0.0:


[edit protocols ospf area 0.0.0.0 ]
user@host# set interface ge-0/2/0.0

Committing the information:


[edit protocols ospf area 0.0.0.0 ]
user@host# commit

28

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Commands - Basic Configuration


Enable OSPF on an interface
user@host# set protocols ospf area 0.0.0.0 interface ge-0/0/0.0

Enable OSPF on a loopback interface. Passive mode specifies that the direct
interface addresses on the interface are advertised without running OSPF on the
interface:
user@host# set interfaces lo0 unit 0 family inet address 192.168.1.2/32
user@host# set protocols ospf area 0.0.0.0 interface lo0.0 passive

Specify a router identifier:


user@host# set routing-options router-id 192.168.1.2

Permit OSPF traffic to a security zone. In this example, OSPF is specified as an


allowed inbound protocol (optional):
user@host# set security zones security-zone trust interfaces ge-0/0/0.0 hostinbound-traffic protocols ospf

To specify that direct interface routes are announced, add the interface to the OSPF
area in passive mode.
user@host# set protocols ospf area 0.0.0.0 interface vlan.100 passive

29

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Commands - Tuning Configuration


Control the cost of individual OSPF network segments
[edit]
user@host# set protocols ospf area 0.0.0.0 interface <ab-x/y/z>.0 metric
<value>

Dynamically adjust OSPF interface metrics based on bandwidth:


[edit]
user@host# set protocols ospf reference-bandwidth <value>

Set the external and internal routing preferences


[edit]
user@host# set protocols ospf preference 168 external-preference 169

Confirm your configuration:


user@host> show protocols ospf
user@host> show ospf interface detail

30

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Commands - Authentication


Simple Authentication
Specify the interface:
[edit]
user@host# edit protocols ospf area 0.0.0.0 interface so-0/1/0

Set the authentication type and the password:


[edit protocols ospf area 0.0.0.0 interface so-0/1/0.0]
user@host# set authentication simple-password PssWd4

MD5 Authentication
Specify the interface:
[edit]
user@host# edit protocols ospf area 0.0.0.0 interface so-0/2/0

Configure MD5 authentication and set a key ID and a password:


[edit protocols ospf area 0.0.0.0 interface so-0/2/0.0]
user@host# set authentication md5 5 key PssWd8

31

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS OSPF configuration example


routing-options {
router-id 10.0.0.51;
}
protocols {
ospf {
area 0.0.0.0 {
authentication-type md5;
interface ge-1/1/0.0 {
interface-type p2p;
metric 40;
ldp-synchronization;
authentication {
md5 0 key "ABCD";
}
}
interface lo0.0 {
passive;
}
}
}
}

32

CN10563EN03GLA1

Define router-id to identify routers in the


OSPF domain

Specify areas and its constituent interfaces


Specify interface level OSPF parameters

Set loopback interface as passive

Nokia Solutions and Networks 2015

OSPF Commands - Checking the Configuration for


OSPF
To verify the OSPF configuration, use the following commands:
user@host> show ospf interface
Intf

State

Area

DR ID

BDR ID

Nbrs

at-5/1/0.0

PtToPt

0.0.0.0

0.0.0.0

0.0.0.0

ge 2/3/0.0

DR

0.0.0.0

192.168.4.16

192.168.4.15

lo0.0

DR

0.0.0.0

192.168.4.16

0.0.0.0

so-0/0/0.0

Down

0.0.0.0

0.0.0.0

0.0.0.0

so-6/0/1.0

PtToPt

0.0.0.0

0.0.0.0

0.0.0.0

so-6/0/2.0

Down

0.0.0.0

0.0.0.0

0.0.0.0

so-6/0/3.0

PtToPt

0.0.0.0

0.0.0.0

0.0.0.0

user@host> show ospf neighbor


Address

Interface

State

ID

Pri

Dead

10.222.2.2

ge-0/0/11.0

Full

192.168.36.1

128

36

33

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Core Routing and Switching Protocols


IGP Topics
IGP:
MPLS Enabled Applications

L3 VPN

MPLS TE

QOS

FRR

Label Switching
IGP

BGP

Network Topology

34

CN10563EN03GLA1

OSPF

IS-IS

Agenda:
1.
2.
3.
4.
5.
6.
7.
8.

Justification
Terminology
Topology
Addressing
Metric
Basic Configuration
Tuning Configuration
Authentication

Nokia Solutions and Networks 2015

Intermediate System to Intermediate System protocol


(IS-IS)
Very scalable and stable Cisco recommends up to 600 routers per area.
Will provide future support for routing IPv6 based packets.
A Link State Protocol Fast to converge and supports advanced MPLS features such as
TE and FRR.
Added security as IS-IS is not opened to usual IP attacks due to its ISO functionality.
- Even when IS-IS is used to route only IP, IS-IS is still an ISO CLNP protocol.
Consequently, the packets by which IS-IS communicates with its neighbors are CLNS
PDUs, even in an IP-only environment a IS-IS router must have an ISO address. The
ISO address is a network address called a NET (Network Entity Title).
OSPF is also a valid choice depending on Operators preferences.

35

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Terminology
ES End System (host)
IS Intermediate System (router)
LSDB Link-State DataBase
CLNP ConnectionLess Network Protocol
CLNS ConnectionLess-Mode Network Service
- Common CLNS parameters need to be configured even if IS-IS is used in a pure IP
environment (e.g. NSAP address)
- Even in IP environments, IS-IS still establishes adjacencies with CLNS and uses
CLNS packets to send routing updates

36

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Topology - Router Types

IS-IS identifies Routers as Level 1, Level 2 or Level 1/Level 2:


L1 Routers build a common topology to all systems inside the same area
(like an internal OSPF router).
L2 Routers exchange information about the prefixes of the different areas
(like a Backbone router in OSPF)
L1/L2 Routers work as the frontier between L1 and L2 routers
(like an ABR in OSPF).

37

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Topology - Routing

L1 Router: Compares the Area ID of the

L1/L2 Router : Compares the Area ID of the


destination address to the ID of its own area:
destination address to the ID of its own area :
If it matches, it uses the L1 database to
If it matches, it uses the L1 database to
perform routing per System ID.
perform routing per System ID;
If it doesnt match, it passes it to the closest If it doesnt match, it uses the L2 database to
L1/L2 router.
perform routing per Area ID.
38

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Topology - Areas


Area 1

Area 2

192.168.3.0
01.1111.1111.1111.00

ES

L1
IS

192.168.4.0

02.2222.2222.bbbb.00

L1-2 192.168.16
192.168.2.0
.0
IS
L1-2
01.2222.2222.2222.00
02.2222.2222.aaaa.00
IS
L2
IS

01.3333.3333.3333.00

192
.16
8.

Area 3
33.
0

L2
IS

192.168.17.0
8.32.0
192.16

Formed by Level 2 Routers


They must be contiguous
Areas
Formed by Level 1 Routers

CN10563EN03GLA1

ES
ES
192.168.18.0

L1-2
IS

02.2222.2222.cccc.00

192.168.34.0

Backbone

39

192.168.1.0

L1-2
IS

03.3333.3333.aaaa.00

Nokia Solutions and Networks 2015

IS-IS Topology
Example

40

CN10563EN03GLA1

All routers in the production network can be


Level 2 devices.

Provides simplicity and scalability.

Should network partition be required


separate Level 1 areas may be created.

Nokia Solutions and Networks 2015

IS-IS Addressing - NSAP Address Format


Used by Level 2 Routing

Used by Level 1 Routing

DSP

IDP
AFI

IDI

High Order DSP

System ID

NSEL

6 bytes

1 byte

Variable Length Area Address


NSAP addresses can either public or private,
addresses starting with 49 (AFI=0x49) are considered private.
Simplified Cisco Format consists of three parts:
Area = AFI + 2 byte High Order DSP (Area ID)

System ID = IP address of loopback in MAC format or Routers MAC address


NSAP Selector (NSEL): always = 00
NSAP address with NSEL = 00 is know as NET (Network Entity Title)

41

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Addressing - NET Address Example


NET 49.0001.1921.6801.1003.00
49: Private Organization Owner
0001: Area ID, no more than one area is needed initially in the Backbone
1921.6801.1003 : Loopback address 192.168.11.3
Convert this to system ID by:
Adding zeros where missing - 192.168.011.003
Re-formatting into 3 parts 1921.6801.1003
00: NSEL always 00

42

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Metrics
IS-IS has two metric styles:
Narrow (default)
Wide (up to 32-bit extended metric) required for MPLS TE
Critical: metric style must be the same in all IS-IS routers.
IS-IS Wide Metric is user defined and represented as:
0 to 63 in decimal, for narrow metric style;
0 to 16,777,215 in decimal, for wide metric style with 24 bits.
IS-IS Metric must be specified per link (if omitted default metric is 10).
When equal cost paths exist to the same destination load balance will be performed.
However, since TE is being deployed, a single path will be selected to setup the tunnel
and no load balancing will occur.

43

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Metrics - Proposal


Metric Link Type

Description

40

P to P (same plane)

Link connecting two P routers in the same


plane

15

P to P (different planes)

Link connecting two P routers in different


planes

120

P to PE

Link connecting a PE router to a P router

15

PE to PE

Link connecting two PE routers

500

P to RR

Link connecting a P router to a RR router

IS-IS has a default metric of 10


44

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Timers

45

Value

Timer

Description

3 secs

Hello
interval

Frequency with which the router sends hello packets out


of an interface.

9 secs

Hold down
interval

Length of time a neighbor considers this router to be up


after receiving a hello packet.

10 secs

CSNP
interval

Interval between transmissions of CSNP packets on a


LAN interface.

100 msecs

LSP interval LSP transmission interval time.

65535 secs

LSP lifetime How long an LSP is valid.

200 msecs

SPF interval Time interval between the detection of a topology change


and when the SPF algorithm runs.

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS topology
P

ISIS Level 2 - Area 0


ICR

PE

RR

L2
P-ICR link

RR

ICR
RR

PE

46

P-P link
L2

PE-P/PE link

L2

PE

ICR

P-RR link

L2

L2

L2

CN10563EN03GLA1

P
L2

L2

L2

L2

PE

L2

L2

L2

L2

L2

L2

L2

L2

L2

L2

PE

PE

L2

PE

L2

PE

L2

PE

L2

Nokia Solutions and Networks 2015

L2

L2

Provider Router
Provider Edge Router
Route Reflector
Interconnection Router

IS-IS Commands - Basic configuration


Enable IS-IS on all necessary interfaces
[edit]
user@host# set protocols isis interface <ab-x/y/z>.0
user@host# set protocols isis interface <ab-x/y/z>.0 level 1 disable
user@host# set protocols isis interface lo0.0 passive

Set ISO protocol family on those interfaces


[edit]
user@host# set interface <ab-x/y/z> unit 0 family iso

Loopback interface, create iso protocol family and set the NET address
[edit]
user@host# set interface lo0 unit 0 family iso address
49.0001.1921.6800.1001.00

47

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Commands - Tuning Configuration


Generate IS-IS metric values greater than 63 (on a per IS-IS level basis):
[edit]
user@host# set protocols isis level 2 wide-metrics-only

As default, each IS-IS interface has a metric of 10, to modify this default value the
following command can be used:
[edit]
user@host# set protocols isis interface <ab-x/y/z>.0 level 2 metric <value>

Following command is employed to configure the default reference bandwidth:


[edit]
user@host# set protocols isis reference-bandwidth <value>

Enable IS-IS if your router is in secure context (optional):

[edit]
user@host# set security forwarding-options family iso mode packetbased

48

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Commands - Authentication


Configure MD5 Authentication Key for IS-IS:
[edit]
user@host# set protocols isis level 2 authentication-type md5
user@host# set protocols isis level 2 authentication-key <auth_key>

49

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS IS-IS configuration example


interfaces {
ge-1/1/0 {
unit 0 {
family iso;
}
}
lo0 {
unit 0 {
family iso {
address
49.0001.0100.0000.0011.00;
}
}
}
}
Enable ISO family on all interfaces
running IS-IS and define single ISO
address per router

50

CN10563EN03GLA1

Define global IS-IS


protocol parameters
and features

protocols {
isis {
lsp-lifetime 65535;
level 1 disable;
level 2 {
authentication-key ABCD";
authentication-type md5;
wide-metrics-only;
}
interface ge-1/1/0.0 {
ldp-synchronization;
point-to-point;
level 2 metric 40;
}
interface lo0.0 {
passive;
}
}
}

Specify
interface
level IS-IS
parameters

Set loopback
interface as passive

Nokia Solutions and Networks 2015

JUNOS IS-IS show commands


Verify the configuration:
user@host> show isis ?
Possible completions:
adjacency
Show
authentication
Show
backup
Show
context-identifier
Show
database
Show
hostname
Show
interface
Show
overview
Show
route
Show
spf
Show
statistics
Show

IS-IS adjacency database


IS-IS authentication information
IS-IS backup information
IS-IS context-identifier information
IS-IS link-state database
IS-IS hostname database
IS-IS interface information
overview of IS-IS information
IS-IS routing table
shortest-path-first calculations information
IS-IS performance statistics

user@host> show isis interfaces < brief | detail | extensive >


user@host> show isis authentication
user@host> show route protocol isis

51

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Commands - Checking the configuration for IS-IS


To verify the IS-IS configuration, use the following commands:
user@host> show isis interface brief
IS-IS interface database:
Interface

CirID

Level 1

DR

Level 2 DR

lo0.0

0x1

router1

router.01

ge-0/0/1.0

0x9

Disabled

router.03

ge-1/0/0.0

0x7

Disabled

router.05

user@host> show isis adjacency brief


IS-IS adjacency database:
Interface

System

State

Hold (secs) SNPA

ge-0/0/0.0

1921.6800.5067

Up

13

ge-0/0/1.0

1921.6800.5067

Up

25

ge-0/0/2.0

1921.6800.5067

Up

19

52

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Commands - Checking the detailed configuration


for IS-IS
user@host> show isis interface detail
lo0.0
Index:3, State:0x7, Circuit id: 0x1, Circuit type:3 LSP interval: 100 ms,
Sysid: router1
Level Adjacencies Priority Metric Hello(s) Hold(s)
1
0
64
0
9
27
2
0
64
0
9
27
ge-0/0/1.0
Index:3, State:0x9, Circuit id: 0x9, Circuit type:2 LSP interval: 100 ms,
Sysid: router1
Level Adjacencies Priority Metric Hello(s) Hold(s)
1
0
64
0
9
27
2
0
64
0
9
27
user@host> show isis adjacency extensive
Interface: so-0/0/0.0, Level: 2, State: Up, Expires in 25 secs
Priority: 0, Up/Down transitions: 1, Last transition: 4w6d 19:38:52 ago
Circuit type: 2, Speaks: IP, IPv6
Topologies: Unicast
Restart capable: Yes
IP addresses: 10.1.12.1

53

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Core Routing and Switching Protocols


IGP Comparison
IGP:
MPLS Enabled Applications

L3 VPN

MPLS TE

QOS

FRR

OSPF
IS-IS

Label Switching
IGP

BGP

Network Topology

54

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS vs. OSPF - Area Design


OSPF Areas

Backbone

ABR

Area 0

Area 1

Internal

Stub Area
IS-IS Areas

L1 Router

L1/L2 Router
Area 49.0001

OSPF is based on a central backbone with


all other areas attached to it.
In OSPF the border is inside routers
(ABRs).
Each link belongs to one area.

55

CN10563EN03GLA1

L1/L2 Router
Area 49.0002

In IS-IS the area borders lie on links.


Each IS-IS router belongs to exactly one

area
IS-IS is more flexible when extending the
backbone
Nokia Solutions and Networks 2015

Similarities Between IS-IS and OSPF


Main characteristics and similarities between IS-IS and OSPF
- Link State protocol based on Cost
- Promotes a more efficient use o bandwidth
- Permits CIDR and summarization
- Permits Equal Cost Multi-Path (ECMP)
- Fast Convergence
- Uses Dijkstras algorithm (SPF)
- Supports advanced MPLS features like TE (Traffic Engineering) and
FRR (Fast ReRoute)
- Minimal advantages from on protocol to another specially in smaller networks (less
than 100 routers)

56

CN10563EN03GLA1

Nokia Solutions and Networks 2015

IS-IS Advantages
More easily scalable than OSPF for networks with 500 or more routers
More flexible to technology updates due to the use of TLV field
Added Security
- Even in pure IP environments ISIS still uses CLNS to exchange routing packets, i.e. it
is not subject to threats from the IP world
Traditional choice in Service provider environments

57

CN10563EN03GLA1

Nokia Solutions and Networks 2015

OSPF Advantages
OSPF has a more options for Area type specification
Interface Cost can be indexed to link bandwidth, in IS-IS when Cost is not configured it
always defaults to the same value (10)
More support from vendors for OSPF
Easier to find detailed documentation and case studies for OSPF
Easier to find qualified engineers with OSPF experience

58

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Administrative distance

59

Route Source

Default Administrative Distance Values

Connected

Static

eBGP

20

OSPF

110

IS-IS

115

RIP

120

iBGP

200

Unknown *

255

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Core Routing and Switching Protocols


BGP Topics
BGP
MPLS Enabled Applications
L3 VPN

MPLS TE

QOS

FRR

Label Switching
IGP

1. Justification
2. Implementing BGP
3. Scaling Techniques
Route Reflector
Peer Templates
4. Optimization
5. Configuration

BGP

Network Topology

60

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Border Gateway Protocol (BGP)


BGP is the only protocol that will extend MPLS-VPN routing information between PE
routers.
The routes learnt by the PE router are re-distributed into MP-BGP and carried across the
backbone to the other PE routers.
This allows for a very scalable, secure and stable VPN routing domain, but at the
expense of fast convergence.
BGP propagates reachability information for VPN-IPv4 prefixes among PE routers by
means of the BGP Multiprotocol Extensions (see RFC 2283) which defines support for
address families other than IPv4.
It does this in a way that ensures the routes for a given VPN are learned only by other
members of that VPN, enabling members of the VPN to communicate with each other.

61

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Characteristics
BGP is a path vector routing protocol
Neighborships are manually configured
Initial routing tables are exchanged between peers after neighborships are formed and
afterwards only triggered incremental updates are sent.
TCP (port 179) is used for exchanging messages.
Each route has a number of attributes assigned which are representing the metric of that
route.
Maintains its own routing table with all paths learnt. Only best route is installed in routing
table.
The best route is chosen by evaluating the attributes according to a defined algorithm.

62

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Attributes
Origin: defines how the route was learned by BGP (interior, exterior, incomplete)
AS_Path: sequence of AS that a route has traversed starting.
Next_hop: IP address of the next hop that should be used to reach the destination
Local preference: Used to in iBGP peerings to influence how a destination can be
reached if there are multiple exits form the AS. Lowest value preferred.
Multiple Exit Discriminator (MED): Used to influence incoming traffic when multiple
entry points in an AS exist.
Weight: Has local significance only, not propagated to other routers. Allows enforcing
election of a specific path locally.

63

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Internal BGP (IBGP)


IBGP sessions exist between routers in the same AS and are required to be fully
meshed. Where multiple exit points from an AS are available then IBGP sessions allow
traffic to exit from the optimal exit point (optimal exit point depends on the policy
adopted).
A public AS is a prerequisite for multi-homing to other public ASs and will allow a greater
range of connectivity options. Public AS numbers must be allocated by IANA (RIPE in
Europe) to a specific entity.
IBGP
Peers

EBGP
Peer
EBGP
Peer

64

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Scaling Techniques - Route Reflectors (RR)


Route Reflector is an iBGP peer which replicates BGP updates to its neighbors.
BGP speaking routers peer only with router reflectors instead of all other iBGP peers:
- Number of neighbors is reduced
- No need for full iBGP mesh
- Number of routes propagated is reduced each RR advertises only the best path to
its clients.
Avoids the n*(n-1)/2 iBGP mesh.
For resilience, at least two routers should be deployed as route reflectors, each to be
located in different sites.
The route reflectors will peer with all PE routers and other route reflectors.

65

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Optimization - Convergence Time


BGP convergence depends on sessions between BGP peers. BGP sessions stay Up
as long as the BGP speaking router/process is running
In case a BGP peer shuts down or is faulty appropriate BGP session hellos will normally
track this error after several seconds. Traffic between external networks is lost up to 1
minute and more. This will be enhanced by a parameter called BGP next hop trigger
(NHT)

66

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Optimization - Next-hop Tracking (NHT) with Route


Reflectors
A Route Reflector will not further enhance the BGP convergence time but it will help to
run NHT on all BGP routers.
The Route Reflector will inform all client BGP router about the new best path.

67

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Timers

68

Default Value

Timer

90 secs

Hold time

1/3 Hold time

Keepalive time

CN10563EN03GLA1

Description
How long BGP waits without receiving any
keepalive, update or notification message,
before declaring that a neighboring router is
unavailable.
Interval between keepalive messages.

Nokia Solutions and Networks 2015

BGP Design Considerations

Route Reflectors

Improve scalability in large networks and


avoid full IBGP mesh

BGP Attributes

Determine which attributes will be


employed (local preference, MED,
communities, etc)

Routing policies

Define import/export policies to control


routing updates

Timers

Hold and keepalives timer values to


monitor peer availability

Authentication

Authenticate protocol packets with secure


MD5 key

Damping

Control flapping routes

BGP in the core uses as protocol next-hop loopback addresses,


therefore it is critical to learn them via IGP
Route reflectors are strongly recommended in the core network

69

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP topology

Internet
P

Service

Service

Provider 1

Provider 2

PE

RR

EBGP
RR

ICR

MP/iBGP
ICR

AS <number>

RR
VPN Routes

MP/iBGP

P
MP/iBGP

PE

PE

MP/iBGP
MP/iBGP

PE

70

CN10563EN03GLA1

PE

Nokia Solutions and Networks 2015

Provider Router
Provider Edge Router
Route Reflector
Interconnection Router

BGP Commands - Configuration Example

BGP Example:
Router A is the RR
Routers B and C are clients of the RR (inside the
same cluster)
Routers D and E are non clients (inside the same
AS but outside the cluster)
Configuration Steps:
Configure Router ID and AS
Configure the Interfaces
Configure BGP, including the cluster identifier and
neighbor relationships with all IBGP enableddevices
Configure an IGP
Configure the redistribution policy from IGP to BGP

71

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Commands - Route Reflector Configuration


Configure the router ID and the autonomous system (AS) number
[edit]
user@host# set routing-options autonomous-system <AS_number>
user@host# set routing-options router-id <IP_address_lo0>

Configure neighbor relationships with all IBGP-enabled devices in the AS


[edit]
user@host#
user@host#
user@host#
user@host#
user@host#

set
set
set
set
set

protocols
protocols
protocols
protocols
protocols

bgp
bgp
bgp
bgp
bgp

group
group
group
group
group

int-peers
int-peers
int-peers
int-peers
int-peers

type internal
peer-as <AS_number>
local-address <IP_address_lo0>
neighbor <IP_address_client1>
neighbor <IP_address_client2>

Enable MP-BGP to carry Layer 3 VPN NLRI for the IPv4 address family
[edit]
user@host# set protocols bgp group int-peers family inet-vpn unicast

Configure the cluster identifier, it identifies the Route Reflector


[edit]
user@host# set protocols bgp group int-peers cluster <IP_address_lo0>

72

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Commands - Route Reflector Client Configuration


Configure the router ID and the autonomous system (AS) number
[edit]
user@host# set routing-options autonomous-system <AS_number>
user@host# set routing-options router-id <IP_address_lo0>

Configure neighbor relationship with Route Reflector in AS


[edit]
user@host# set protocols bgp group int-peers type internal
user@host# set protocols bgp group int-peers peer-as <AS_number>
user@host# set protocols bgp group int-peers local-address <IP_address_lo0>
user@host# set protocols bgp group int-peers family inet-vpn unicast
user@host# set protocols bgp group int-peers neighbor <IP_address_RR>

73

CN10563EN03GLA1

Nokia Solutions and Networks 2015

BGP Commands - Route Reflector Client Configuration Redistribution


Configure a policy that redistributes routes into BGP
[edit]
user@host# set policy-options policy-statement send-ospf term 1 from protocol
ospf
user@host# set policy-options policy-statement send-ospf term 1 then accept
user@host# set policy-options policy-statement send-direct term 1 from
protocol direct
user@host# set policy-options policy-statement send-direct term 1 then accept
user@host# set policy-options policy-statement send-static term 1 from
protocol static
user@host# set policy-options policy-statement send-static term 1 then accept

Apply the policy that redistributes routes into BGP


[edit]
user@host# set protocols bgp group int-peers export send-ospf
user@host# set protocols bgp group int-peers export send-direct
user@host# set protocols bgp group int-peers export send-static

74

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS BGP configuration example (PE)


routing-options {
router-id 10.0.0.111;
autonomous-system 65000;

Set local AS number

}
protocols {
bgp {
group int-peers {
type internal;
local-address 10.0.0.111;
family inet-vpn {
unicast;
}
neighbor 10.0.0.1;
}

Loopback 0
Exchange VPN-IPv4 routes
between PE routers via RRs
Specify peer address

}
}

75

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS BGP show commands


user@host > show bgp ?
Possible completions:
bmp

Show BGP Monitoring Protocol statistics

group

Show the BGP group database

neighbor

Show the BGP neighbor database

replication

BGP NSR replication state between master and backup

summary

Show overview of BGP information

user@host> show bgp summary


user@host> show route protocol bgp

76

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Core Routing and Switching Protocols


MPLS Topics
MPLS Enabled Applications

L3 VPN

MPLS TE

QOS

FRR

MPLS
1. Implementing MPLS
2. LDP
Configuration

Label Switching
IGP

BGP

Network Topology

77

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Multiprotocol Label Switching (MPLS) Characteristics


Based on assignment of labels to packets for data forwarding
Label Switch Path (LSP): unidirectional labeled path from one entry point (ingress) to an
exit point (egress) of the MPLS domain
Router performing MPLS operations is called Label Switched Router (LSR). Entry and exit
point routers of an MPLS network are called label edge routers (LERs).
- Ingress router: Beginning of the LSP path, label push is performed to the initial IP packet
- Transit router: Receives a labeled packet, forwards to next hop in the LSP by performing
a label swap operation
- Egress router: End of the LSP, label is popped and packet is forwarded based on IP
address
Improved route lookup time by using labels to forward traffic
BGP free core P routers
Increased scalability
More traffic flow control through the use of traffic engineering
Multiple technologies over same infrastructure

78

CN10563EN03GLA1

Nokia Solutions and Networks 2015

What is MPLS?
MPLS is a high-performance packet forwarding technology that integrates the
performance and traffic management capabilities of data link layer switching with the
scalability, flexibility and performance of network-layer (Layer 3) routing.
The entry and exit points of an MPLS network are called Label Edge Routers (LER),
which, respectively, push an MPLS label onto the incoming packet and pop it off the
outgoing packet.
Routers that perform routing based only on the label are called Label Switch Routers
(LSR).
10.10.10.1

10.10.10.1

LER
Routing lookup
and
label assignment
10.0.0.0/8
L=50

L=

33
=
L

50

LSR

CN10563EN03GLA1

Label removal and


routing lookup
L=33

Label
swapping
L=50 L=33

79

LER

Nokia Solutions and Networks 2015

Benefits of MPLS
Scalable support for Virtual Private Networks (VPNs) - MPLS enables VPN services to
be supported in service provider networks, thereby greatly accelerating Internet growth.
Explicit routing capabilities (also called constraint-based routing or traffic engineering) Explicit routing employs constraint-based routing, in which the path for a traffic flow is
the shortest path that meets the resource requirements (constraints) of the traffic flow.
Support for IP routing on ATM switches (also called IP and ATM integration) - MPLS
enables an ATM switch to perform virtually all of the functions of an IP router.
Primary
STM64 link

Site A

Site C

Secondary
STM16 link

Site B

80

CN10563EN03GLA1

Traffic can be forwarded based on


other parameters (QoS, source)
Load sharing across unequal
paths can be achieved.

Nokia Solutions and Networks 2015

MPLS - LDP Explained

LDP convergence depends on IGP information.


A MPLS/LDP overlay network can only be
established if IGP knows about all routes and
considers all latest routing information.

First LDP gets a trigger from enhanced IGP,


BFD or any interface (triggers from LDP hellos
will come too late after several seconds). Then
LDP convergence will be accomplished by
simply deleting affected paths from label
forwarding information base (LFIB). This
procedure is rather fast provided the
recommended platform are used.

Another task for LDP would be to react on


newly added links or on links which recover
after an outage.

81

CN10563EN03GLA1

Nokia Solutions and Networks 2015

LDP timers
Value
5 secs
15 secs
30 secs

82

Timer
Hello
interval
Targeted
hello
interval
Keepalive
timeout

CN10563EN03GLA1

Description
Frequency with which the router sends hello
packets out of an interface.
Frequency with which the router sends targeted
hello packets out of an interface.
Amount of time that the neighbor LDP node waits
before determining that the session has failed.

Nokia Solutions and Networks 2015

LSP topology of site 1


P

PE

RR

ICR

RR
ICR
LDP-LSP

RR

Site 1
LDP-LSP
PE

PE
Site 4

LDP-LSP
LDP-LSP

PE
Site 2

83

CN10563EN03GLA1

PE
Site 3

Nokia Solutions and Networks 2015

Provider Router
Provider Edge Router
Route Reflector
Interconnection Router

MPLS Commands - Basic MPLS Configuration


Enable MPLS on the Router
[edit]
user@host# set protocols mpls interface all

Disable the management interface for MPLS


[edit]
user@host# set protocols mpls interface fxp0.0 disable

Enable MPLS on Router Interfaces


[edit]
user@host# set interfaces so-0/0/2 unit 0 family mpls

84

CN10563EN03GLA1

Nokia Solutions and Networks 2015

MPLS Commands - Basic LDP Configuration

In order to enable LDP in a JUNOS router, under the protocols section, the interfaces
where LDP is enabled must be defined. In addition to this, MPLS must be enabled on
those interfaces as per the previous section.

Similarly to the MPLS configuration, LDP will only be enabled on core interfaces. It is
also advisable to enable LDP in the loopback interface itself to facilitate the
establishment of targeted LDP sessions that are required for some of the Layer 2 MPLS
technologies. Finally, for completeness, the transport address used to support the LDP
session will be configured to match the router-id of the router.

set protocols ldp interface <ab-x/y/z>.0


set protocols ldp interface lo0.0
set protocols ldp transport-address router-id

85

JUNOS places all prefixes for which it has received an LDP label in the inet.3 routing
table, which is used by BGP for next hop resolution.

CN10563EN03GLA1

Nokia Solutions and Networks 2015

MPLS Commands - Basic RSVP Configuration


Enable RSVP on the Router
[edit]
user@host# set protocols rsvp interface all

Disable the management interface for RSVP


[edit]
user@host# set protocols rsvp interface fxp0.0 disable

Establish an LSP in your Network


Configure the LSP on the ingress and egress routers
[edit]
user@host# set protocols mpls label-switched-path R1-to-R6 to 10.0.0.6

86

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS MPLS configuration example


interfaces {
ge-1/1/0 {
unit 0 {
family mpls;
}
}
}
protocols {
mpls {
interface ge-1/1/0.0;
}
ldp {
transport-address router-id;
keepalive-timeout 30;
interface ge-1/1/0.0;
interface lo0.0;
session 10.0.0.21 {
authentication-key ABCD";
}
}
rsvp {
interface ge-1/1/0.0 {
authentication-key ABCD";
link-protection;
}
}
}

87

CN10563EN03GLA1

Enable MPLS family on core interfaces

Define interfaces running MPLS at the


protocols level

Define interfaces where LDP


will be enabled and set global
LDP parameters

Define interfaces where RSVP will be enabled

Nokia Solutions and Networks 2015

MPLS Commands - Verify Configuration


verify that the LSP is up, from the ingress router:
user@host> show mpls lsp extensive

verify MPLS interfaces:


user@host> show mpls interface

verify the RSVP protpcol:


user@host> show rsvp version

verify RSVP interfaces


user@host> show rsvp interface

verify the MPLS labels using the ping command:


user@host> ping mpls rsvp <lsp-name> detail

88

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS routing table


IGP Routes:
loopback addresses +
connected subnets

Labels for specific prefixes learnt via LDP/RSVP


LDP: Loopback addresses
RSVP: Manually configured LSPs

inet.0

inet.3

mpls.0

Master routing
table

LDP/RSVP
routing table

MPLS routing
table

All routes learnt via the IGP


are installed in inet.0

Prefixes for which a label has


been learnt via LDP/RSVP are
installed in inet.3

Used for MPLS label swapping


and forwarding

BGP checks first inet.3 routing table for


next-hop resolution, before looking in
inet.0

Only traffic whose BGP next-hop is in the inet.3 routing table will be MPLS
forwarded => This includes all VPN user data

89

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Core Routing and Switching Protocols - MPLS Topics


MPLS Enabled Applications

L3 VPN

MPLS TE

QOS

FRR

Label Switching
IGP

BGP

MPLS
1. Implementing MPLS
2. LDP
Configuration
3. MPLS Traffic Engineering
Justification
Design Constrains
Primary and Secondary

or Backup Paths
FRR
Configuration

Network Topology

90

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Traffic Engineering (TE)


MPLS Traffic Engineering (TE) known as the ability of steering traffic through the network
Standard IP routing based purely on least cost path forwarding; TE allows forwarding
traffic more efficiently given certain conditions and constraints
Very popular when high resiliency and traffic control are required
Characteristics
Implemented as an extension of the RSVP protocol
Traffic forwarded using MPLS labels
CSPF algorithm computed to calculate the most optimal path
Special constraints added for best path calculation (bandwidth, hops, explicit paths)
Extensions added to the IGP to carry the additional information required to build TE
database
Benefits
Granular traffic flow control
Traffic protection capabilities (FFR, node and link protection)
Sub 50ms failure restoration

91

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Constrained Shortest Path First (CSPF) Algorithm


Constraints
Link
attributes
(BW, etc)

Explicit
Route
(ERO)

Max hop
number

Preemption
priorities

Admin
Groups
Constraints are
statically defined on the
LSP configuration

Constrained
Shortest Path First
(CSPF) Algorithm

IGP

Best path

If after running the CSPF


algorithm more than one path still
available, a tie breaking rule is
applied (random, least fill or most
fill) to select best path

TE CSPF shortest path computation is still based on the IGP, but links that do not
comply with the defined constraints are pruned from the SPF calculations

92

CN10563EN03GLA1

Nokia Solutions and Networks 2015

Traffic Protection Primary and Secondary Paths


One of the main benefits of RSVP TE is that allows for LSP paths to be protected and
reduce the downtime after a network failure
Without traffic protection => first the failure needs to be notified and then a new LSP
needs to be signaled before the traffic can be restored (traffic will be dropped during this
process)
Primary and secondary paths enable to define statically main and alternate paths for an
LSP
Secondary
Primary path
Employed in the first place
to establish the LSP
Secondary path
Primary
LSP fails over to its secondary path
PE1
when its primary path fails
Can be pre-signaled using standby keyword for a reduced failover time

93

CN10563EN03GLA1

Nokia Solutions and Networks 2015

PE2

Traffic Protection FRR, Link and Node Protection


Fast Reroute (FRR)
Protects an entire LSP path
1:1 (each detour path protects a single LSP)

Traffic protection mechanisms


provide a way to immediately
start forwarding traffic over a
backup path while
simultaneously alerting the
ingress LSR the presence of
downstream link or node
failures

Backup

PE1

Active

PE2

Node Protection
Protects a particular node
1:N (protects multiple LSPs passing through that node)

Link Protection
Protects a particular link
1:N (protects multiple LSPs passing through that link)

Backup

Backup
Protected
node

Protected
link
PE1

94

Active

CN10563EN03GLA1

PE2

PE1

Active

Nokia Solutions and Networks 2015

PE2

Traffic Engineering

Enabling CSPF

In a JUNOS router when a LSP is manually created inside the MPLS protocols
configuration level, it has by default CSPF algorithm enabled. The only requirement for
CSPF to be able to select a valid path is to have the traffic engineering extensions of
the IGP enabled in order to build the TE database.

In <Customer> network all RSVP-TE LSPs created will use as default CSPF algorithm
for path calculation.

LSP bandwidth reservation

set protocols mpls label-switched-path <LSP_name> bandwidth <value>

RSVP available link bandwidth

set protocols rsvp interface <ab-x/y/z>.0 subscription <percentage>


set protocols rsvp interface <ab-x/y/z>.0 bandwidth <value>

95

CN10563EN03GLA1

Nokia Solutions and Networks 2015

JUNOS MPLS TE configuration example


protocols {
mpls {
Create static LSP and
label-switched-path LSP_PE01_TO_PE03 {
set the destination
to 10.0.0.131;
bandwidth 200m;
hop-limit 255;
Define TE parameters
priority 7 0;
least-fill;
link-protection;
Specify traffic protection mechanism
primary PRIM_PE01_TO_PE03;
secondary SEC_PE01_TO_PE03 {
standby;
Define primary and secondary paths
}
}
path PRIM_PE01_TO_PE03 {
10.0.16.17 strict;
10.0.8.18 strict;
10.0.8.22 strict;
}
path SEC_PE01_TO_PE03 {
10.0.16.17 strict;
Specify ERO explicit hops for primary
10.0.8.37 strict;
and secondary paths
10.0.8.29 strict;
10.0.8.25 strict;
}
}

96

CN10563EN03GLA1

Nokia Solutions and Networks 2015