Vous êtes sur la page 1sur 19

RAPPORT DES TRAVAUX

PRATIQUES
SUR CISCO PACKET TRACER

4me ANNEE GENIE TELECOMMUNICATIONS

Prsent par:
FOTZO SIMO NELSON

Encadreur Ing. TCHIO Flaubert


Supervision Pr EMMANUEL Tonye
Novembre 2011
Rapport TP VII par FOTZO SIMO NELSON
RAPPORT VII

CONFIGURATION DU ROUTAGE
DYNAMIQUE

Rapport TP VII par FOTZO SIMO NELSON


CONFIGURATION DU ROUTAGE DYNAMIQUE

Contrairement au routage statique, le routage


dynamique sadapte lvolution du rseau (tient
compte de la vie ou mort des routeurs) et sa
configuration varie peu en fonction du routeur. Ce
type de routage:
Est optimal car il permet la slection des meilleures
routes.
limine les boucles de routage ou routes circulaires.
Est efficace car consomme peu de bande passante.
Est stable car la configuration est rapide.

Rapport TP VII par FOTZO SIMO NELSON


CONFIGURATION DU ROUTAGE DYNAMIQUE
Les protocoles de routage dynamique
Les protocoles intrieurs (IGP Interior
Gateway Protocol) qui changent des
informations de routage lintrieur dun rseau
autonome. Quelques exemples sont:
Les protocoles
Ces protocoles transmettent lavecteur
totalit des de distance
informations tels tous
de routage que RIP
les routeurs participants et tablissent des tables de voisins directs.
(Routing Information protocol) et IGRP (Interior
Gateway Routing Protocol).
Les protocoles
Avec ces protocoles, tat
aucun routeur nades liens
une vision telsduque
complte OSPF
rseau.
(Open Shortest Path First) et IS IS (Integrated
Ces protocoles ne diffusent que leurs meilleures routes sur leurs interfaces.
Intermediate System to Intermediate System).
Rapport TP VII par FOTZO SIMO NELSON
CONFIGURATION DU ROUTAGE DYNAMIQUE
Les protocoles de routage dynamique
Les protocoles extrieurs (EGP Exterior
Gateway Protocol) changent des informations
de routage entre systmes autonomes.
Quelques exemples sont: BGP (Border Gateway
Protocol) et IDRP (Inter-Domain Routing
Protocol).

Rapport TP VII par FOTZO SIMO NELSON


CONFIGURATION DU ROUTAGE DYNAMIQUE
Les protocoles de routage dynamique

En rsum:

Routage dynamique Caractristiques


Caractristiques
Caractristiques
vecteur de distance
Routage dynamique Exploite les atouts
Configuration
Cofiguration difficile
facile
tat des liens des deux prcdents
Convergence
Convergence rapide
lente
Routage dynamique Proprit
Exemple deIGRP
OSPF
Exemple RIP cisco
,IS-IS
Hybride EIGRP
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage vecteur de distance (RIP)

Rapport TP VII par FOTZO SIMO NELSON


EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage vecteur de distance (RIP)
TABLE DADRESSAGE
Equipement Interface Adresse IP Masque Passerelle
Routeur R 1 Fa0/0 172.16.1.17 255.255.255.240 ---
Se2/0 192.168.10.1 255.255.255.252 ---
Se3/0 192.168.10.5 255.255.255.252 ---
Routeur R 2 Fa0/0 10.10.10.1 255.255.255.0 ---
Se2/0 192.168.10.2 255.255.255.252 ---
Se3/0 192.168.10.9 255.255.255.252 ---
Routeur R 3 Fa0/0 172.16.1.33 255.255.255.248 ---
Se2/0 192.168.10.6 255.255.255.252 ---
Se3/0 192.168.10.10 255.255.255.252 ---
PC 1 Ethernet 175.16.1.20 255.255.255.240 172.16.1.16
PC 2 Ethernet 10.10.10.10 255.255.255.0 10.10.10.1
PC 3 Ethernet 172.16.1.35 255.255.255.248 172.16.1.33
Rapport TP VII par FOTZO SIMO NELSON
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage vecteur de distance (RIP)

Configuration
Configurationdu
deRIP
base
surduleRouteur
RouteurRR11
Router(config)#int Se3/0
Router(config)#router
Se2/0
rip Configuration de base du Routeur R1
Router(config)#int fa0/0
Router(config-if)#ip
Router(config-router)#version
address 192.168.10.5
192.168.10.1
2 255.255.255.252
On choisit RIPv2
Router(config-if)#ip address
Router(config-if)#clock
Router(config-router)#network 172.16.1.17
rate 64000 255.255.255.240
192.168.10.4 On annonce les trois rseaux
Router(config-if)#no shutdown
Router(config-if)#bandwidth 64192.168.10.0
Router(config-router)#network
Router(config-if)#no shutdown 172.16.1.16
Router(config-router)#network
Rapport TP VII par FOTZO SIMO NELSON
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage vecteur de distance (RIP)

Configuration
Configurationdu
deRIP surduleRouteur
base RouteurRR22
Router(config)#router rip Configuration de base du Routeur R 2
Router(config)#int Se3/0
Se2/0
Router(config)#int fa0/0
Router(config-router)#version
Router(config-if)#ip 2
address 192.168.10.9
192.168.10.2 On choisit RIPv2
255.255.255.252
Router(config-if)#ip address
Router(config-router)#network
Router(config-if)#clock
Router(config-if)#bandwidth 10.10.10.1 255.255.255.0On annonce les trois rseaux
192.168.10.8
rate 64000
64
Router(config-if)#no shutdown
Router(config-router)#network
Router(config-if)#bandwidth
Router(config-if)#clock 64192.168.10.4
rate 64000
Router(config-router)#network
Router(config-if)#no shutdown 10.10.10.0
Rapport TP VII par FOTZO SIMO NELSON
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage vecteur de distance (RIP)
TEST

Configuration deRIP
Configurationdu base
surduleRouteur
RouteurRR33
Router(config)#int rip Configuration de base du Routeur R 3
Se3/0
Router(config)#router
Se2/0
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.10.10
Router(config-router)#version192.168.10.6
2 255.255.255.252
255.255.255.252
On choisit RIPv2
Router(config-if)#ip address 64
Router(config-if)#bandwidth
Router(config-router)#network 172.16.1.33 255.255.255.248
172.16.1.32 On annonce les trois rseaux
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-router)#network 192.168.10.8
Router(config-if)#no shutdown 192.168.10.4
Router(config-router)#network
Rapport TP VII par FOTZO SIMO NELSON
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage vecteur de distance (RIP)
TEST

Sur le PC 2
1 (10.10.10.10),
(172.16.1.20), on tape ping 172.16.1.35
10.10.10.10
Rsultat (Connexion russie)

Rapport TP VII par FOTZO SIMO NELSON


EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
II Configuration du routage tat des liens (OSPF)

Rapport TP VII par FOTZO SIMO NELSON


EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
II Configuration du routage tat des liens (OSPF)
TABLE DADRESSAGE
Equipement Interface Adresse IP Masque Passerelle
Routeur R 1 Fa0/0 172.16.1.17 255.255.255.240 ---
Se2/0 192.168.10.1 255.255.255.252 ---
Se3/0 192.168.10.5 255.255.255.252 ---
Routeur R 2 Fa0/0 10.10.10.1 255.255.255.0 ---
Se2/0 192.168.10.2 255.255.255.252 ---
Se3/0 192.168.10.9 255.255.255.252 ---
Routeur R 3 Fa0/0 172.16.1.33 255.255.255.248 ---
Se2/0 192.168.10.6 255.255.255.252 ---
Se3/0 192.168.10.10 255.255.255.252 ---
PC 1 Ethernet 175.16.1.20 255.255.255.240 172.16.1.16
PC 2 Ethernet 10.10.10.10 255.255.255.0 10.10.10.1
PC 3 Ethernet 172.16.1.35 255.255.255.248 172.16.1.33
Rapport TP VII par FOTZO SIMO NELSON
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage tat des liens (OSPF)

Configuration de base du Routeur R 1


Configuration
Configurationde debasebaseduduRouteur
RouteurRR11
Router(config)#hostname "R 1
RR1(config)#int
1(config)#intSe3/0
Se2/0 Configuration de base du Routeur R 1
R 1(config)#no ip domain-lookup
RR 1(config-if)#ip
1(config-if)#ip address
address192.168.10.5
192.168.10.1255.255.255.252
255.255.255.252
RR1(config)#username
1(config)#int fa0/0 4gtel password 4gtel2013
RR 1(config-if)#clock
1(config-if)#clock rate
rate64000
64000
RR1(config)#banner
1(config-if)#ip address
motd c172.16.1.17 255.255.255.240
***** BIENVENUE SUR LE ROUTEUR R 1 ***** c
RR 1(config-if)#bandwidth
1(config-if)#bandwidth 256
64 64kbps
256kbps
RR1(config)#line
1(config-if)#no shutdown
vty 04 Configuration La configuration
de laccs parest pareille pour R 2 et R 3.
telnet
RR 1(config-if)#no
1(config-if)#no shutdown
shutdown La configurationLa configuration
estlepareille
est
pour
pareille
Rles
2 et
pour
R 3.RSeules
2 et des
R
RSeules les adresses
1(config-line)#login etlocal
le bandwidth changent. Voir schma pour bandwidth
3.les
Seules
adresses
les adresses
et le bandwidth
et le bandwidth
changent. changent.
Voir le schma
Voir le pour
schma
les bandwidth
pour les bandwidth
des
Rinterfaces.
1(config-line)#transport input telnet
des
interfaces.
interfaces. Rapport TP VII par FOTZO SIMO NELSON
R 1(config-line)#password 4gtel2013 On fait de mme sur R 2 et R 3
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage tat des liens (OSPF)

Configuration
Configuration dOSPF
dOSPF sur sur le
le Routeur
Routeur R R1 2
3
R 1(config)#router
R 3(config)#router ospf
2(config)#router ospf 11 On annonce les trois rseaux
On annonce les trois rseaux
R
R 1(config-router)#network
2(config-router)#network 172.16.1.16
3(config-router)#network 0.0.0.15
10.10.10.0 0.0.0.255
172.16.1.32 0.0.0.7 areaarea
area000 On On choisit
choisit00
Onchoisit comme
0comme area_id
commearea_id
area_id
R
R 1(config-router)#
2(config-router)# network
3(config-router)#network 192.168.10.0
network192.168.10.4
192.168.10.00.0.0.30.0.0.3
0.0.0.3areaarea
area00 On
0 On utilise
On utilise le
utilisele mme
lemme area_id
mmearea_id
area_id
pour annoncer tous les rseaux
pour annoncer tous les rseaux
R
R 1(config-router)#
2(config-router)# network
3(config-router)# network 192.168.10.4
192.168.10.8 0.0.0.3
0.0.0.3 area
area 00
R 1(config-router)#
R 3(config-router)# end
2(config-router)# end NB: Le masque 0.0.0.3 reprsente 4 adresses 0.0.0.0
0.0.0.3 Rapport TP VII par FOTZO SIMO NELSON
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage tat des liens (OSPF)

Configuration dOSPF sur les routeurs


On peut modifier les adresses loopback comme le montre cet exemple:
R1(config)#router ospf 1Configuration dOSPF sur le Routeur R 3 1
2
(Attribution dadresses
R1(config-router)#router-id 10.4.4.4 loopback pour identifier les routeurs)
R 3(config)#interface
1(config)#interface
2(config)#interface loopback
On peut 0 la configuration OSPF comme suit:
supprimer
R 1(config-if)#ip
3(config-if)#ip
2(config-if)#ip address 10.3.3.3
R1(config-router)#end 10.1.1.1
10.2.2.2 255.255.255.255
R1# clear ip ospf process
Reset ALL OSPF processes? [no]:yes
Rapport TP VII par FOTZO SIMO NELSON
R1#
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage tat des liens (OSPF)

Configuration dOSPF sur les routeurs


Configuration du protocole Hello (utilis par les routeurs pour changer des donnes
Configuration
de leurs tables de routaages) dOSPF sur(lintervalle
et du dead-interval les routeursde temps au bout duquel
Voici quelques
un routeur commandes
est considr Configuration
comme pour
mortvisualiser
dunchange
sil cot:ltat
Exemple
de laavec
plus configuration OSPF:
les routeurs voisins):
R1(config)#
R 3(config)#interface
show ip ospf
Se2/0
neighbor Exemple
R1(config)#
R 3(config-if)#ip
showospf
ip route
R1(config)#interface cost 1562
Se2/0
R1(config)#
R 3(config-if)#interface
show
R1(config-if)#ip ip protocols
ospf Se3/0
hello-interval 5 Echange de donnes Hello une fois toutes les 5 s
R1(config)#
R 3(config-if)#ip
show
R1(config-if)#ip ospf
ip ospf
ospf cost 1562
dead-interval 20 Dead-interval = 20 s
R1(config)# show ip ospf interface
R1(config-if)# Chaque
Rapport TP VII par FOTZO interface
SIMO NELSONa sa configuration
EXEMPLE DE CONFIGURATION DU ROUTAGE DYNAMIQUE
I Configuration du routage tat des liens (OSPF)
TEST

Sur le PC 2
1 (10.10.10.10),
(172.16.1.20), on tape ping 172.16.1.35
10.10.10.10
Rsultat (Connexion russie)
FIN

Rapport TP VII par FOTZO SIMO NELSON