Vous êtes sur la page 1sur 45

Université Hassan II- Mohammedia

Faculté des Sciences, Juridiques, Économiques et Sociales

Microsoft Excel
Semestre 4
Notions de base
1. Définition

Un tableur est un logiciel permettant de manipuler des


données numériques et d'effectuer automatiquement
des calculs sur des nombres stockés dans un tableau. Il
est ainsi possible d'automatiser des calculs complexes
mettant en jeu un grand nombre de paramètres en
créant des tableaux appelés feuilles de calcul.

2
2. Présentation du tableur Microsoft Excel

C’est le tableur de la suite bureautique Microsoft


Office. Pour le lancer, cliquer sur l'icône appropriée du
menu Démarrer (sous Windows) ou bien cliquer sur un
fichier Excel (dont l'extension est .xls(x)).

Un document Excel est appelé classeur, il contient une


ou plusieurs feuilles de calcul, présentes sous formes
d'onglets en bas de page.

3
3. Présentation de l'écran Excel

Barre de titre
Barre de titre Barre de formules

Ruban d’Excel
Référence de la
cellule active

Feuille du classeur

4
Une des principales nouveautés sous Excel 2007, est le remplacement des
menus et des barres d'outils par un ruban constitué d'onglets qui regroupent
les fonctionnalités de l'application.

5
Création d’un classeur
Application
1. Ouvrir un classeur Excel

2. Dans la feuille 1, positionnez-vous en cellule A1, et


tapez "Nom"

3. Validez en pressant Entrée

4. Saisissez le tableau comme ci-après:

6
7
Enregistrer un classeur
Pour enregistrer un classeur Excel :

1. Dans le menu Fichier, cliquez sur Enregistrer sous.

2. Dans la boite de dialogue, sélectionnez le lecteur et


le dossier dans lesquels vous souhaitez enregistrer le
classeur.

3. Cliquez sur Enregistrer.

Application
 Enregistrez le classeur sous le nom "Fonctionnaires"

8
Enregistrer les modifications d’un classeur

Lorsque des changements sont apportés au fichier, il est


indispensable de l’enregistrer pour conserver ces
modifications.

Application

Mettre les données de la première ligne du tableau au


centre, en gras, police (Comic sans MS), Taille 12 et le
motif en bleu

Enregistrez le classeur sous un autre nom "Gestion"

9
Insertion et suppression de colonne et
de ligne
1. Sélectionner la ligne qui se trouve en dessous de
celle à insérer (ou la colonne qui se trouve après
celle à insérer)

2. Dans le menu Insertion, cliquez sur Cellules ou Lignes


ou Colonnes.

10
Pour Supprimer des cellules, des lignes ou des colonnes
vides dans une feuille de calculs:
1. Sélectionner cellules ou la ligne ou la colonne à
supprimer
2. Dans le menu Édition, cliquez sur Supprimer.

Application
Insérer un titre pour le tableau intitulé " GESTION
DES FONCTIONNAIRES" mettez-le au centre, en
Italique et souligner.

11
Somme automatique

La somme automatique est la fonction de calcul la plus


simple à utiliser.

Le bouton du groupe Edition, onglet Accueil (ou la


combinaison Alt + =) permet par défaut, de sommer le
contenu de toutes les cellules situées au-dessus (ou à
gauche) de celle où ce bouton a été activé.

12
Copier une formule
Cliquez sur le coin inférieur droit de la cellule contenant la
formule (Somme, Moyenne,….) Jusqu’à l’obtention d’un  et
faites glisser sur la ou les cellules désirées dans les colonnes
suivantes ou plus rapidement par un double clic sur 
Application
Dans le tableau du classeur «Fonctionnaires »
1. Effectuez le calcul du total de la colonne D
2. Copiez ensuite la formule pour les autres colonnes.
3. Enregistrer les modifications.

13
Copier coller et collage spécial
1. Recopier une cellule

2. Remplacer le contenu d’une cellule

14
Mise en forme d’un tableau

1. Bordure et couleur

1. Sélectionner votre tableau


2. Choisir la commande Format, Cellules
3. Dans l’onglet Bordure de la boite de dialogue, choisir
le type de bordure demandé et cliquer sur ok.

15
Vous pouvez aussi appliquer un modèle de bordure à
partir de l’option Mise en forme automatique :

1. Sélectionner votre tableau

2. Choisir la commande Format, Mise en forme


automatique

3. Dans la boite de dialogue, choisir le modèle et


cliquer sur ok.

16
2. Largeur de colonne

La largeur initiale d’une colonne est de 10.71


caractères, pour la modifier :

1. Sélectionner votre colonne

2. Choisir la commande Format dans le groupe


«Cellules», Largeur de Colonne

3. Dans la boite de dialogue, saisir la larguer souhaitée


et cliquer sur ok.

17
3. Hauteur d’une ligne
La hauteur initiale d’une ligne est fixée par défaut à
12.75 points, pour la modifier :
1. Sélectionner votre ligne
2. Choisir la commande Format dans le groupe
«Cellules», puis Hauteur de Ligne,
3. Dans la boite de dialogue, saisir la hauteur
demandée et cliquer sur ok.

Application
•Changer la hauteur des lignes à 16 et la largeur des colonnes à 18.
•Changer manuellement la largeur de la colonne poste
18
4. Fusionner des cellules

1. Sélectionner les cellules à fusionner

2. Choisir la commande Format de Cellule

3. Dans l’onglet Alignement de la boite de dialogue,

activer Fusionner les cellules et cliquer sur ok.

4. Ou utiliser tout simplement le bouton du

groupe Alignement
19
5. Renvoi à la ligne automatiquement

1. Sélectionner la cellule au niveau de laquelle vous

voulez créer un renvoi à la ligne

2. Choisir la commande Format de Cellule

3. Dans l’onglet Alignement de la boite de dialogue,

activer Renvoyer à la ligne automatiquement et

cliquer sur ok.

4. Ou utiliser le bouton du groupe Alignement


20
Application
1. Reproduire le tableau ci-dessous sur la feuille 2 du classeur en

respectant les références des cellules et en appliquant le même

type de couleurs. Renommer la feuille : Analyse des bénéfices.

21
2. Fusionner les cellules C3, D3 et E3.

3. Faire un renvoi à la ligne dans la ligne 5

4. Fixer la largeur de la colonne A à 9 caractères et

celle de la colonne F à 18.

22
Opérations et fonctions
1. Opérations

1. Sélectionner la cellule dans laquelle doit

apparaître le résultat du calcul.

2. Saisir la formule de calcul en commençant par le

signe égal (=) et valider par la touche entrer.

23
2. Fonctions statistiques

Fonction Formule Définition

Calcule la moyenne arithmétique


MOYENNE =MOYENNE(B5 :B13) d’une plage de cellules.

Calcule la plus petite valeur


MIN d’une plage de cellules, soit la valeur
=MIN(B5 :B13)
minimale.

Calcule la plus grande valeur d’une


MAX plage de cellules, soit la valeur
=MAX(B5 :B13) maximale.

Comptabilise les cellules contenant des


valeurs numériques ; ignore les cellules
NB =NB(B5:B15) contenant du texte.

= SI(Condition; opération à Renvoie une valeur si le résultat d’une


SI condition spécifiée est vraie, et une
effectuer si VRAI; Opération à autre valeur si le résultat est faux.
effectuer si FAUX)

24
Pour appliquer l’une de ces fonctions :

1. Sélectionner la cellule dans laquelle doit apparaître le résultat.


2. Saisir la formule de la fonction en commençant par le signe égal
(=), sélectionner la plage des données et valider par la touche
entrer.
Vous pouvez aussi appliquer ces fonctions comme suit :

1. Sélectionner la cellule dans laquelle doit apparaître le résultat.

2. Choisir la commande Insertion, Fonctions

3. Dans la boite de dialogue qui s’affiche, choisir le type de


fonction statistique et cliquer sur le bouton ok.

4. Dans la nouvelle fenêtre qui s’ouvre qui vous indique comment


utiliser la fonction en question, cliquer sur le bouton ok.

25
Fonction SI: Syntaxe
 =si(condition;alors;sinon)

Si condition est fausse


Si condition est vraie
 Exemple :
Application
Dans le tableau de la feuille analyse du bénéfice

1. Afficher le résultat de l’opération suivante dans la cellule


E10: (E6+25)/SOMME(B6:C6)

2. En D6, calculez la marge réalisé pour les pelles sachant que:


marge réalisée = Prix de vente – prix de revient

3. Reproduire la formules pour les autres articles

4. En F6, calculez le bénéfice réalisé pour les pelles tel que:


Bénéfice réalisé = marge réalisée * quantité vendue

5. Reproduire la formule pour les autres articles

6. En C11, calculez la Marge moyenne réalisée

7. En C12, calculez le Meilleur bénéfice réalisé 27


8. En G6, vérifier si l’objectif est atteint ou non pour les pelles en
utilisant la fonction SI suivante :

 Si le bénéfice réalisé est supérieur à 6000, l’objectif est


atteint « oui »

 Si le bénéfice réalisé est inférieur à 6000, l’objectif est non


atteint « non »

9. Reproduire la formule pour les autres articles

28
Fonction si imbriquée
 La fonction SI() n'autorise que 2 réponses possibles. Lorsqu’on a
un problème à résoudre avec 3 réponses possibles, il faudra
procéder par élimination en utilisant, successivement, 2 fonctions
SI(). Les 2 fonctions seront imbriquées.

=SI(test_logique1;valeur_si_vrai ; SI(test_logique2 ; valeur_si_vrai2 ;


valeur_si_faux2))

 La 2ème fonction SI(), qui est représentée en bleue, s'exécutera


si (et seulement si) la réponse au test_logique1, qui est
représenté en rouge, est "FAUX".
29
Références relatives, références
absolus & références combinées
 Une référence de cellule, telle que A1, qui permet à Excel d’identifier une
cellule par rapport à une autre cellule contenant la formule, est dite
relative.

 Exemple : A15, B32, D4:F10.

 Une référence absolu est une référence qui reste inchangée lors d’une
copie ou d’un déplacement de données : la référence concerne toujours la
même cellule.

 Exemple : $A$15, $B$12, $D$4:$F$10

 On utilise une référence combinée si on souhaite que la référence à la


colonne ou la référence à la ligne ne soit pas modifiée.

 Exemple : $A15, B$362, D$4:F$10.


Exercice 1

Saisie des formules (directement ou par recopie)

Calcul du Prix HT
Dans la cellule D6, saisissez =B6*C6. Validez.
Sélectionnez D6. Par cliqué-glissé, copiez la formule jusqu'en D9 (ou
plus rapidement double-cliquez sur la poignée de D6). 31
Calcul du Prix TTC

Pour préserver la valeur du taux de TVA, il faudra donc que la ligne de


B3 soit saisie en référence absolue.
En E6, saisissez =D6*(1+B$3). (On pourrait aussi écrire $B$3, puisqu'on
ne se sert pas ici de la qualité relative de la colonne de référence).
Par cliqué-glissé, copiez cette formule jusqu'en E9 (ou plus rapidement
double-cliquez sur la poignée de E9).

Calcul du Total TTC

Dans la cellule E10, saisissez =E6+E7+E8+E9, ou plus rapidement


=somme(E6:E9).

32
Exercice 2
 Créer un nouveau classeur Excel
 A partir de la cellule A1, saisir les titres de colonnes ainsi que les
données des colonnes Articles, Désignation, Quantité et PU.
 Sauvegarder le classeur sous le nom Commande.
 Dans la cellule E2, entrer la formule : =C2*D2.
 Copier cette formule dans la plage E3:E10.
 Insérer 2 lignes vides au début de la feuille.

 Dans la cellule A1, saisir le titre suivant : Commande des articles pour la
société X-R.

 Nommer la feuille Atelier1.


 Copier la feuille Atelier1 et nommer la feuille copiée Atelier2.
 Faire toutes les modifications afin d’obtenir la mise en forme présentée
ci-dessous. Noter bien le format des nombres monétaire (65,00 Dh).
 Utiliser le format personnalisé. Sélectionner la zone concernée puis
exécuter la commande: format de cellule-nombre- personnalisée et
dans "type" Ecrire: 0,00" Dh"
 Modifier la feuille Atelier2 afin d’obtenir le résultat présenté ci-
dessous.
 Le prix total = (la quantité * le prix unitaire) - (la quantité * le prix
unitaire * la remise)

 TVA = 19%
Exercice 3
Soit le tableau ci-dessous qui englobe les notes de trois
matières d’un groupe d’étudiants. Chaque matière est
pondérée par un coefficient. On cherche à remplir les
cellules non vides.

37
1. Dans la colonne E, calculer le total des lignes correspondantes
2. Dans la colonne F, calculer la moyenne de chaque étudiant.
3. Dans la colonne G, trouver en fonction de sa moyenne le
classement de chaque étudiant par rapport à son groupe. Utiliser
la fonction rang.
4. Dans la colonne H, afficher la mention de chaque étudiant tel que
si: moyenne < 10, afficher faible,
moyenne < 12, afficher passable,
moyenne < 14, afficher assez bien,
moyenne < 16, afficher bien,
sinon, afficher très bien.
5. Dans la ligne 10, calculer la moyenne de classe.
38
La fonction RANG:
=Rang (nombre; référence; ordre)

Cette fonction revoie le rang d’un nombre dans une liste


d’arguments: sa taille est relative aux autres valeurs de la liste.
Nombre: est le nombre dont on veut connaitre le classement
Référence: une matrice ou une référence à une liste de nombre.
Ordre: l’ordre décroissant =0 ou omis, l’ordre croissant = toute
valeur non nulle.

39
La fonction NB.SI :

=NB.SI(plage;critère)

La fonction NB.SI permet de compter seulement une partie des


données d'un tableau, si elles correspondent à un critère défini. Par
exemple compter combien de fois figure un même pays dans une
liste.

 Plage = Sélection des données à retenir dans le calcul critère


 Critère = Un nombre ou une valeur définissant les données à
compter

Application: Quel est le nombre des étudiants ayant la moyenne >=10


Combien d’étudiants ayant la mention « Bien » 40
La fonction SOMME.SI:

= SOMME.SI(plage;critère;somme_plage)

La fonction SOMME.SI permet de faire des additions seulement sur


une partie des données d'un tableau, si elles correspondent à un
critère défini.

 Plage = Sélection des données à retenir dans le calcul


 Critère = Un nombre ou une valeur définissant les données
à additionner
 Somme_plage = La plage des données qui sera retenue pour le
calcul

41
Exercice 4: Calculer le nombre de ventes et le total
des CA pour chaque commercial :

=NB.SI($A$4:$A$27;D5)

=Somme.Si(MonTableau;D5;$B$4:
$B$27)

MonTableau est le nom de la plage


A4:A27
42
Exercice 5

=max(H11:H23)

43
Corrigé

=SI(ET(H11>=10;B11>8;D11>8;F11>8);"Admis";"Non admis")

=SI(OU(H12<10;B12<=8;D12<=8;F12<=8);"Non
admis";"Admis")

=NB.SI(H11:H23;">=10")

=SI(ET(I11="Admis";H11>=16);"T.Bien";SI(ET(I11="Admis";
H11>=14);"Bien";SI(ET(I11="Admis";H11>=12);"A.Bien";SI(E
T(I11="Admis";H11>=10);"Passable";" "))))

44
Tri des données

Pour trier les données selon un ordre précis


(chronologique, numérique ou alphabétique) :

 Sélectionner les données ( ou placer juste le pointeur


sur n'importe quelle cellule de la liste de données)

 Choisir la commande Données, Trier

 Dans la boîte de dialogue qui s’affiche, définir les


critères de tri (lignes et ordre : croissant ou
décroissant) et cliquer sur le bouton ok.
45