Vous êtes sur la page 1sur 26

SEMANA 07

1
Arreglos
Un arreglo (array) es una colección de datos del mismo tipo, que se almacenan en
posiciones consecutivas de memoria y reciben un nombre común.

Para referirse a un determinado elemento de un arreglo se deberá utilizar un índice,


que especifique su posición relativa en el arreglo.

Un arreglo es una colección finita, homogénea y ordenada de elementos.


•Finita: Todo arreglo tiene un límite; es decir, debe determinarse cuál será el
número máximo de elementos que podrán formar parte del arreglo.
•Homogénea: Todos los elementos del arreglo deben ser del mismo tipo.
•Ordenada: Se puede determinar cuál es el primer elemento, el segundo, el
tercero,.... y el n-ésimo elmento.

2
Arreglos

3
Arreglos

Los arreglos se clasifican de acuerdo con el número de dimensiones que


tienen. Así se tienen los:

Unidimensionales (vectores)
Bidimensionales (tablas o matrices)
Multidimensionales (tres o más dimensiones)

4
Arreglos
Array Unidimensionales Array Bidimensionales

Elemento 0 Elemento 0,0 Elemento 0,1 …………. Elemento 0,n

Elemento 1 Elemento 1,0 Elemento 1,1 …………. Elemento 1,n

Elemento 2,0 Elemento 2,1 …………. Elemento 2,n


Elemento 2
………….
. . . .
………….
. . . .
Elemento n Elemento m,0 Elemento m,1 …………. Elemento m,n

5
Arreglos Unidimensionales
Están formados por un conjunto de elementos de un mismo tipo de datos que se
almacenan bajo un mismo nombre, y se diferencian por la posición que tiene cada
elemento dentro del arreglo de datos.

Para declarar un arreglo tiene que indicar su tipo, un nombre único y la cantidad de
elementos que va a contener.

Por ejemplo, las siguientes instrucción declaran un arreglo Calificaciones de 100


elementos:
Dim Calificaciones(99) As Double

6
ARREGLOS UNIDIMENSIONALES
Calificaciones

0 Calificaciones( 0 )
1 Calificaciones( 1 )
2 18.50 Calificaciones( 2 )
.
.
.
.
.
99 Calificaciones( 99 )

Dim Calificaciones(99) As Double

7
Arreglos Unidimensionales

Para acceder a valores específicos del arreglo, use un valor de índice que apunte
al elemento deseado.

 Por ejemplo, para acceder al tercer elemento del arreglo calificaciones debe
utilizar el valor de índice 2.
calificaciones( 2 )

8
Declaracion de arreglos
Declararemos un array de igual forma que hacemos con una variable normal, con
la excepción de que junto al nombre de la variable, situaremos unos paréntesis.
Esto indica que dicha variable contiene un array.
Ejemplo: Declarar un array llamado colores de 4 elementos

n +1

9
Mitchell Ferrand Marcone – Universidad Valparaíso
Ejemplos:

Sea arre un arreglo de 70 elementos enteros con índices enteros. Su


representación nos queda:

Dim Arre( 69 ) As Integer

Arre 0 1 2 3 ……………………………….. 69

Arre( 0) Arre( 69 )

10
Lectura de un Arreglo

El proceso de lectura de un arreglo consiste en leer y asignar un valor a cada uno
de sus elementos.
 Normalmente se realizan con estructuras repetitivas, aunque pueden usarse
estructuras selectivas.
Usamos los índices para recorrer los elementos del arreglo:

Para i = 0 hasta 69 hacer


leer Arre( i )
fin_para

11
Escritura de un Arreglo

Es similar al caso de lectura, sólo que en vez de leer el componente del


arreglo, lo escribimos.

leer N
Para i = 0 hasta N hacer
escribir Arre( i )
fin_para

12
V

13
Asignacion
No es posible asignar directamente un valor a todo el arreglo; sino que se debe
asignar el valor deseado en cada componente.
 Con una estructura repetitiva se puede asignar un valor a todos los elementos
del vector.

•Por ejemplo:
arre(1) = 120 (asignación de un valor constante único a una casilla del vector)

•Se puede asignar un valor constante a todos los elementos del vector:
Para i = 0 hasta 4 hacer
arre( i ) = 3
fin_desde

14
Inicializar

Para inicializar con cero todos los elementos del arreglo:

Para i = 0 hasta 69 hacer


arre( i ) = 0
fin_desde
Arre
0 0 0 0…. …. …. 0

Arre( 0) Arre( 69 )

15
Ejercicio 1

• Encontrar el mayor y menor valor de un


arreglo de 20 números diferentes, y
determinar sus respectivos índices.

16
Ejercicio 2

Dado dos vectores A y B de 15 elementos


cada uno, obtener un vector C donde la
posición i se almacene la suma de A( i ) + B( i )
y mostrar el mayor de los C( i ).

17
18
ALGORITMO
VARIABLE
ENTERO A(14)
ENTERO B(14)
ENTERO C(14)
ENTERO indice
ENTERO suma
ENTERO mayor
ENTERO mayor_indice
FIN_VARIABLE

INICIO
PARA indice = 0 HASTA 14
ESCRIBIR (“Introduce un numero para el vector A y B”)
LEER A(indice)
LEER B(indice)
FIN_PARA

19
PARA indice = 0 HASTA 14
Suma = A(indice) + B(indice)
C(indice) = suma
FIN_PARA
Mayor = C(0)
PARA indice = 0 HASTA 14
SI C(indice) > mayor ENTONCES
Mayor = C(indice)
FIN_SI
FIN_PARA
ESCRIBIR (mayor)
FIN_INICIO
FIN_ALGORITMO

20
Ejercicio 3

• Diseñar un programa en VB tal que al


ingresar 19 presiones obtenidas en un
experimento de laboratorio, nos muestre
lo siguiente:
• La presión mayor y menor
• cuantas presiones son mayores y
menores e iguales a 3.

21
Public Class Form1
Public WMAY, I, C1, C2 As Integer
Public WMEN As Integer = 99999

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As


System.EventArgs) Handles Button1.Click
Dim PRES( 18 ) As Double
PRES( I ) = TextBox1.Text
ListBox1.Items.Add(PRES( I ))
If PRES( I ) > WMAY Then
WMAY = PRES( I )
End if

If PRES( I ) < WMEN Then


WMEN = PRES( I )
End If

If PRES( I ) > 3 Then


C1 = C1 + 1
Else
C2 = C2 + 1
End If
I=I+1
End Sub
23
Private Sub Button2_Click(ByVal sender As
System.Object, ByVal e As System.EventArgs) Handles
Button2.Click
TextBox2.Text = WMAY
TextBox3.Text = WMEN
TextBox4.Text = C1
TextBox5.Text = C2
C1 = 0
C2 = 0
End Sub
End Class

24
FIN
Ejercicios Propuestos
1) Muestre en pantalla la Suma total y el Promedio de un arreglo A ( i ), el
arreglo contiene 20 elementos.
2) Conforme un arreglo de 10 elementos asignando los valores desde el teclado
y que solo los acepte si son números pares
3) Hacer un programa que tenga un arreglo de 20 elementos ingresados por el
usuario y nos diga cual es el mayor y cual el menor.
4) Hacer un programa que tenga un arreglo de 20 elementos dados por el
usuario, después de ingresar los 20 elementos pedirle al usuario un número y
que nos diga cuantas veces se repite dentro del arreglo.

26