Vous êtes sur la page 1sur 31

Le protocole EIGRP*

*Enhandced Interior Gateway Routing Protocol


Sommaire

1) Introduction
2) Caractéristiques
3) Les métriques
4) Le protocole Hello
5) La table des voisins
6) La table topologique
7) L’algorithme DUAL
8) Configuration
9) Dépannage
1) Introduction

 EIGRP = Enhanced Interior gateway Protocol

 Protocole propriétaire Cisco

 Version améliorée de IGRP


2) Caractéristiques

 Protocole de routage classless

 Supporte le VLSM

 Utilise l’algorithme DUAL

 Métriques
 bande passante
 délai
Caractéristiques

 Principe de successeur

 Compatible avec IGRP

 Protocole de routage hybride

 Multicast = 224.0.0.10
3) Métrique

 Critères utilisés pour calculer la métrique :

 Bande passante (par défaut)


 Délai (par défaut)
 Charge
 Fiabilité

 Valeur de la métrique

 Nombre de 32 bits
 Métrique IGRP * 256
Métrique

 Formule

 Métrique = (K1 × Bandwidth + K2 × Bandwidth ÷ (256 –


Load) + K3 × Delay) + K5 ÷ (Reliability + K4) x 256

 Formule simplifiée en utilisant les valeurs par défaut

 Métrique = Bandwidth + Delay


 Métrique = (107 ÷ BP + Σ délais) × 256
4) Le protocole Hello

 Découverte dynamique des routeurs voisins

 Détection de la perte de connectivité

 Utilise RTP pour la bonne réception des messages


 RTP = Reliable Transport Protocol

 Remplit la table de voisinage


Le protocole Hello

 Les paquets Hello

L
ab_
A e
tLa
b_Cso
ntm
esv
ois
ins

O
L H
ELL
E
HL O
L
ab_
B

L
ab_
A L
ab_
C

L
ab_
B e
stm
onv
ois
in L
ab_
B e
stm
onv
ois
in
5) La Neighbor table

 Base de données contenant l’ensemble des routeurs


voisins

 Caractéristiques d’un voisin :

 Routeur directement connecté

 Transmission de paquets Hello

 Utilisation du protocole de routage EIGRP, avec un numéro


d’AS identique et des paramètres de métrique identiques
6) La table topologique

 Contient tous les réseaux accessibles par les


routeurs voisins

 Mise à jour grâce à l’algorithme DUAL

 Paquets Update et Reply maintiennent la table


topologique

 La table topologique est recalculée lorsque :


 Un nouveau réseau est disponible
 Un réseau devient inaccessible
Terminologie

 Advertised Distance (AD)


 Métrique annoncée par un voisin pour un réseau donné.

 Feasible Distance (FD) :


 Plus petite métrique pour atteindre un réseau donné.

 Successor
 Voisin utilisé comme prochain saut pour une destination
donnée.
Terminologie

 Feasible Successor (FS)


 Voisin vérifiant la FC. Il est potentiellement éligible en tant
que successeur.

 Feasible Condition (FC)


 Condition vérifiée quand un voisin informe une AD plus
petite que la FD du routeur local pour une même
destination.
Election d’un Feasible Successor

Réseau X
AD = 8 Métrique : 8

A
6
Réseau X
Métrique : 5

4 B
Réseau X Successor
Next Hop : B
Métrique : 9

5
FD=9 C Réseau X
Réseau X
Métrique : 14
AD = 14

A ou C = Feasible Successor ?
ó FC = AD < FD

FD = 5 + 4 = 9

AD(A) = 8 → A = Feasible Successor


AD(C) = 14 → C ≠ Feasible Successor
7) L’algorithme DUAL

 DUAL = Diffusing Update ALgorithm

 Maintient la table topologique à jour

 Gestion d’envoi des paquets


 Update, Query, Reply et ACK

 Sélectionne les Feasible Successors et Successors

 Remplit la table de routage


L’algorithme DUAL

DUAL : Sélection successeurs

Table de Table de Table de


voisinage topologie routage
Établit / maintient des Contient toutes les Contient les
relations avec les informations de la Successeurs pour
voisins, pour connaître topologie : chaque réseau de
leur état. - FS, S, autres destination.
routeurs
- État des routes :
actives /passives

Echanges de Hello DUAL : Décisions de routage


paquets Update,
Query, Reply
8) Configuration d’EIGRP

 router eigrp {n° AS}

 Mode configuration globale


 Permet d’initialiser le protocole de routage EIGRP

Router(config)# router eigrp 100


8) Configuration d’EIGRP

 network {préfixe} [masque générique]

 Indique les réseaux directement connectés


 Mode configuration du routeur

Router(config)# router eigrp 100


Router(config-router)# network 172.16.0.0
Configuration optionnelle

 bandwidth {BP}

 Spécifie la bande passante


 Mode de configuration d’interface
 Le paramètre BP est exprimé en Kbps.

Router(config)# interface serial 0/0


Router(config-if)# bandwidth 128
Configuration optionnelle

 passive-interface {type} {numéro}

 Mode de configuration du routeur


 Empêche l’interface d’envoyer des MAJ
 Désactive localement le protocole Hello

Router(config-router)#passive-interface serial 0/0


Agrégation des routes

 [no] auto-summary

 Désactivation/activation de l’agrégation automatique des


routes (actif par défaut)
 Mode de configuration du routeur

Router(config-router)# no auto-summary
Agrégation des routes

 ip summary-address eigrp {n° AS} {réseau}


{masque} [DA]

 Configuration manuelle d’un agrégat de routes à une


frontière Classless
 Mode de configuration d’interface

Router(config)# interface serial 0/0


Router(config-if)# ip summary-address eigrp 100 10.1.128.0 255.255.128.0
Gestion des routes

 maximum-paths {nombre}

 Mode de configuration du routeur


 Nombre max de liens avec le même métrique pouvant être
utilisés pour la répartition de charge
 Max = 6 ou 16 (IOS >= 12.3(2)T)
 Défaut = 4

Router(config-router)#maximum-paths 2
Gestion des routes

 variance {valeur}

 Mode de configuration du routeur


 Coefficient pour répartition de charge entre liens ayant des
métriques différentes
 Répartition de charge = Weighted Round Robin

Router(config-router)#variance 2
Gestion des routes

 metric weights {TOS} {K1} {K2} {K3} {K4}


{K5}

 Mode de configuration du routeur


 Coefficients pour le calcul des métriques
 TOS = 0
 Défaut
 K1 = K3 = 1
 K2 = K4 = K5 = 0

Router(config-router)#timers basic 30 180 180 240


Exemple

172.16.0.0 /26 172.16.0.128 /26

F0 200.0.0.4 /30 200.0.0.0 /30


S1 S0
RouterA S0 RouterB S1 RouterC
F1

172.16.0.64 /26 172.16.0.192 /26

RouterA(config)# router eigrp 100


RouterA(config-router)# network 172.16.0.0 0.0.0.63
RouterA(config-router)# network 172.16.0.64 0.0.0.63
RouterA(config-router)# network 200.0.0.4 0.0.0.3
RouterA(config-router)# no auto-summary
9) Dépannage d’EIGRP

 debug eigrp packet


Affiche les paquets EIGRP émis et reçus, sachant que le type
de message peut être précisé.

 debug eigrp neighbors


Affiche les paquets Hello émis et reçus par le routeur ainsi que
les voisins découverts.
Dépannage d’EIGRP

 debug ip eigrp route


Affiche les changements dynamiques apportés à la table de
routage.

 debug ip eigrp summary


Affiche un résumé des informations concernant EIGRP telles
que les voisins, le filtrage et la redistribution.

 debug eigrp events


Affiche les types de paquets émis et reçus et les statistiques
sur les décisions de routage.
Questions types CCNA
Questions types CCNA
Questions types CCNA

Vous aimerez peut-être aussi