Vous êtes sur la page 1sur 40

Module 2

Chapter 1. Packet Forwarding


Ce chapitre couvre les sujets suivants:

Internetworking: cette section explique comment se fait la


commutation des données à la couche 2 et à la couche 3 du modèle OSI.

Architectures de transfert: cette section examine les mécanismes


utilisés par les routeurs et les commutateurs pour transférer le trafic
réseau.
A. Internetworking
Les différents types de communication

• Half duplex
• Full duplex

Lipouki TINDAME
Network & Systems Administrator
Les différents types de communication
Domaine de collision
• Un domaine de collision représente une situation dans laquelle
deux machines au moins ne peuvent pas communiquer
simultanément.

Important:
• le hub constitue un domaine de collision
• Chaque port du switch constitue un domaine de collision
• Chaque port du routeur constitue un domaine de collision
Domaine de diffusion
• Un domaine de diffusion présente une situation dans
laquelle un ordinateur appartenant à un LAN peut envoyer un
message identique à tous les autres ordinateurs du LAN.
• Ce message est appelé message broadcast/de diffusion.

• Important:
• Le hub constitue un domaine de diffusion
• Le switch constitue un domaine de diffusion
• Chaque port du routeur constitue un domaine de difffusion
Domaine de collision Domaine de diffusion
• Le hub • Le hub
• Chaque port du switch • Le switch
• Chaque port du routeur • Chaque port du routeur
Fonctionnement du CSMA/CD
• Il s’agit du protocole permettant d’éviter les collisions dans un domaine de
collision.
• Fonctionnement:
Lorsqu’une machine veut émettre elle inspecte d’abord le média pour s’assurer qu’il
n’y a pas de données qui circulent. Ensuite au cours de l’envoie des données il
continue d’inspecter le réseau pour s’assurer qu’une machine ne s’apprête à émettre
aussi ; et si tel est le cas, il leur envoie un message pour leur signaler que le média
est occupé et les machines attendront un moment.
• En cas de collision :
- Un message est envoyé à toutes les machines
- Toutes les machines arrêtent d’émettre pendant un moment
- Après le délai toutes les machines ont la même priorité d’émettre
III- The OSI Reference Model

Lipouki TINDAME
Network & Systems Administrator
Modèle OSI
Open System Interconnection

Lipouki TINDAME
Network & Systems Administrator
ENCAPSULATION ET DECAPSULATION

Lipouki TINDAME
Network & Systems Administrator
Les équipements à chaque couche du modèle OSI

Les couches du Modèle OSI Les équipements


Couche Application • Ordinateur
• Ordinateur
Couche Réseau • Routeur
• Switch de niveau 3
• Ordinateur
• Routeur
Couche Data Link • Bridge
• Switch de niveau 2
• Ordinateur
• Routeur
Couche Physique • Bridge
• Switch de niveau 2
• Hub, câble
Modèle TCP/IP

Lipouki TINDAME
Network & Systems Administrator
Principaux Protocoles
Application: Telnet (Port 23), SSH (Port 22), FTP (Port 20, 21), IMAP4 (Port
143), POP3 (Port 110), SMTP (Port 25), HTTP (Port 80), HTTPS (Port 443), DNS
(Port 53)….

Transport : TCP, UDP

Internet : IP, ICMP, ARP, RARP

Access réseau : Ethernet

Lipouki TINDAME
Network & Systems Administrator
Virtuals LAN
Les VLAN sont des réseaux virtuels créés sur des switches pour
permettre une segmentation logique des réseaux, une gestion
efficace des flux de trafics et pour des raisons de sécurité.

Fonctionnement:
• Les machines d’un même département peuvent être regroupées
logiquement au sein d’un même vlan mais en étant physique
connectées à différents switches.

• Les machines d'un VLAN ne peuvent pas communiquer avec des


machines d'un autre VLAN en l’absence d’un équipement de
couche 3 (routeur ou switch de niveau 3) .
• Le VLAN 0 est réservé au trafic 802.1P et ne peut pas être
modifié ou supprimé.
• Le VLAN 1 est le VLAN par défaut et ne peut pas être
modifié ou supprimé.
• Les VLAN 2 à 1001 sont dans la plage de VLAN normale et
peuvent être ajoutés, supprimé ou modifié si nécessaire.
• Les VLANS 1002 à 1005 sont réservés et ne peuvent pas
être supprimés.
• Les VLAN 1006 à 4094 sont dans la plage étendue des
VLAN et peuvent être ajoutés, supprimés ou modifiés si
nécessaire.
Configurations

S1(config)#vlan id id Є[2 ; 1002]


S1(config-vlan)#name nom

#show vlan : pour le troubeshooting


• brief: affiche uniquement le résumé des mappages de port aux VLAN
• summary: affiche un nombre de VLANS, de VLAN participant au VTP et de
VLAN qui se trouvent dans la plage étendue de VLAN.
• id vlan-id: l’affichage concerne uniquement le VLAN spécifié.
• name vlanname: l’affichage concerne uniquement le VLAN spécifié
Access port
• Un port configuré en mode Access est attribué à un seul vlan.
• Il achemine seulement le trafic du VLAN spécifié.

Configurations

S3(config)#int fa0/3
S3(config-if)#switchport mode access
S3(config-if)#switchport access vlan id

Pour le troubleshooting
• #show run
• #show vlan
• #show vlan brief
• #sh int fa0/3 switchport
Trunk ports

• Un port configuré en mode Trunk peut transporter le


trafic de plusieurs vlans contrairement au port en mode
access.
• Les ports trunk sont généralement utilisés pour
interconnecter deux switch comportant plusieurs vlan,
pour relier un switch à un routeur ou un pare-feu pour
assurer le routage intervlan.
Configurations
Le protocole qui permet l’encapsulation sur une liaison trunk est :
802.1Q.

• Sur un switch de niveau 2


S1(config)#int range f0/15-18
S1(config-if-range)#switchport mode trunk

• Sur un switch de niveau 3


S1(config)#int range f0/15-18
S1(config-if-range)#switchport trunk encapsulation dot1q
S1(config-if-range)#switchport mode trunk

Pour le troubleshooting:
#sh int trunk: pour afficher les interfaces trunk
Native VLAN
• Le vlan natif est considéré comme étant le vlan de gestion du switch.
• C’est sur ce vlan que certains protocoles de base comme le CDP et
DTP sont échangés
• Les trames circulant dans ce vlan ne sont pas taguées.
• Si on interconnecte deux switchs par une liaison trunk, le vlan natif
sur chacun des switchs doit être identique.

Configuration:
S1(config)#int f0/3
S1(config-if)#switchport trunk native vlan id
Pour autoriser/refuser des VLANs sur une liaison trunk
Autoriser
• Pour autoriser le VLAN 4 sur une liaison trunk.
S1(config-if)#int f0/3
S1(config-if)#switchport trunk allowed vlan 4

• Pour autoriser les VLANs 4 à 8 sur une liaison trunk.


S1(config-if)#int f0/3
S1(config-if)#switchport trunk allowed vlan 4-8

• Pour ajouter un VLAN 8 aux vlans autorisés sur une liaison trunk.
S1(config-if)#int f0/3
S1(config-if)#switchport trunk allowed vlan add 8

• Pour autoriser tous les VLANs


S1(config-if)#int f0/3
S1(config-if)#switchport trunk allowed vlan all
Refuser

• Pour refuser les VLANs 4 à 8 sur une liaison trunk.


S1(config)#int f0/3
S1(config-if)#switchport trunk allowed vlan remove 4-8

• Pour refuser un VLAN 4 sur une liaison trunk.


S1(config)#int f0/3
S1(config-if)#switchport trunk allowed vlan remove 4

• Pour refuser un seul VLAN sur une liaison trunk et autoriser le


reste des VLAN.
S1(config)#int f0/3
S1(config-if)#switchport trunk allowed vlan except 4
Inter-vlan routing

Etape 1 : configuration du switch


2960(config)#int f0/1
2960(config-if)#switchport mode trunk
2960(config-if)#int f0/2
2960(config-if)#switchport access vlan 2
2960(config-if)#int f0/3
2960(config-if)#switchport access vlan 3
Etape 2 : configuration du routeur

ISR(config) # int f0/0


ISR(config-if)#no shutdown
ISR(config-if)#int f0/0.2
ISR(config-subif)#encapsulation dot1q 2
ISR(config-subif)#ip address 172.16.10.1 255.255.255.128
ISR(config-subif)#int f0/0.3
ISR(config-subif)#encapsulation dot1q 3
ISR(config-subif)#ip address 172.16.10.254
255.255.255.128
Switched Virtual Interfaces
• Avec les switchs, il est possible d'attribuer une adresse IP à un
interface virtuelle (SVI), également appelée interface VLAN.
• Si le switch est de niveau 3, les SVI peuvent être utilisés pour
router des paquets entre des VLAN sans avoir besoin d'un routeur
externe.
Configuration:
S1(config)#int vlan 10
S1(config-if)#ip address 192.168.10.1 255.255.255.0
S1(config-if)#no shut
Routage inter-vlan avec un switch
de niveau 3
S1(config)#ip routing //**pour activer le routage**//
S1(config)#int vlan 10
S1(config-if)#ip address 192.168.10.1 255.255.255.0
S1(config-if)#no shut
S1(config-if)#int vlan 20
S1(config-if)#ip address 192.168.20.1 255.255.255.0
S1(config-if)#no shut
Routed Switch Ports
Il est possible d’attribuer une adresse ip à l’interface d’un
switch de niveau 3 avec la commande no switchport.
S1(config-if)#int f0/3
S1(config-if)#no switchport
S1(config-if)#ip address 192.168.10.1 255.255.255.0
Packet forwading
Au sein d’un réseau local

• ARP table
• MAC address table
D’un réseau local à un autre

• Routing table
B. Architectures de transfert
Cette partie aborde les différentes manières pour un routeur
de gérer le routage des packets IP.

On distingue:
• le process switching
• le fast switching
• le CEF (Cisco Express Forwarding)
Process switching:
• C’est le plus ancien des processus de commutation des routeurs.

• Chaque paquet reçu par le routeur même pour une destination


identique subissent chacun le processus d’examination de la table de
routage et du protocole ARP

• C’est un processus lent

• Le CPU est toujours impliqué dans les décisions de transfert

• L’équilibrage des charge s’applique aux paquets

• Il par défaut actif sur les IOS des routeurs Cisco


Fast
• switching:
Il fait usage d’une table cache de route qui contient toute les information utilisées pour
gérer le premier packet tels que: l’aresse IP de destination, les adresses MAC à ajoutées
en entête
• Le CPU est moins impliqué cette fois-ci
• Seulement le premier paquet reçu par le routeur est gérer en process switching, le reste
des packet est gérer via la table cache de route en y ajoutant seulement les informations
nécessaires.
• Le CPU est moins impliqué cette fois-ci
• C’est un processus plus rapide que le Process switching
• L’équilibrage des charge s’applique par destination (tous les packets suivent le chemin
emprunté par le premier packet)
• On l’active avec la commande: ()#ip route-cache
• L’inconvénient avec ce type de commutation est que le cache est
construit à la demande et que le premier packet est toujours gérer
par process Switching. Aux cas ou le routeur des trafics importants
vers des destination qui ne sont pas encore dans le cache le
processeur sera toujours consommé ce qui va affecter les
performances de commutation.
CEF:
• C’est le plus récent et le plus préféré car incorpore pratiquement le deux
processus de commutation précédent.

• Il fait usage d’une FIB (Forwading Information Base) qui est une version
simplifiée de la table de routage contenant des infos précises tels que: l’adresse
du IP du prochain pour chaque réseau de destination

• Il fait aussi usage d’une Table d’adjacence qui contient le infos de couche 2 pour
chaque destination contenu dans la FIB excluant le besoin du ARP à chaque fois.

• C’est le processus plus rapide

• L’équilibrage des charge s’applique par destination et par packet (tous les packets
suivent le chemin emprunté par le premier packet)

• On l’active avec la commande: ()#ip cef


TCAM (Ternary Content Adressable Memory:

• Il s’agit d’une mémoire similaire à la mémoire CAM sauf


qu’elle contient bien plus d’information que la table MAC tels
que des ACLs…