Vous êtes sur la page 1sur 34

Ministère de l’enseignement supérieur et de la recherche scientifique

Institut Supérieur des Etudes Technologiques de Radés

Etude et Mise en Place d’un réseau d’une haute


disponibilité LAN et WAN

Réalisé par : Mlle Ben Targem Leila


Mr Mahfoudh Mohamed Bilel

Encadré par : Mr Elmahroug Sofiene


Mr Abdelmalek Anis

2010/2011
Plan

Présentation de la société

Présentation

Etude du besoin

Partie LAN

Partie WAN

Conclusion

3
Présentation de la société

 C’est l’Union Bancaire pour le Commerce et


l’industrie .

 Son Siège se situe à Tunis et ses deux cent


agences sont réparties sur toute la république.

 Elle bénéficie d’un accès direct au réseau mondial


du group BNP PARIBAS

4
Présentation

 Le Projet consiste à mettre en œuvre une solution de


communication unifiée pour l’UBCI en respectant les
contraintes suivantes:

Garantir la qualité de service

Assurer une haute disponibilité de service

Mise en place de protocole garantissant le basculement


vers des liaisons redondants.

5
Etude du besoin

Visioconférence
VLAN
Accès rapide à Internet VPN
Transfert des données MPLS
Transfert du voix (VoIP )
QOS

UBCI

6
Partie LAN
Solution LAN Proposée A

B
Configuration des VLANs

C
Configuration du service DHCP

D
Configuration de VTP

E
Améliorer le protocole STP

F
Configuration des IP phones

7
Architecture LAN existante

8
Solution LAN Proposée

étage1 étage 2 étage 3 étage 4

9
Réalisation « LAN »

-- Vlan
Vlan Data
Data
-- Vlan
Vlan voix
voix
Crée
Créeles
lesVLANs
VLANs -- Vlan
Vlan admin
admin

Activation
Activationde
deprotocole
protocoleRSTP
RSTP Sw1# spanning-tree mode rapid-pvst

Configuration etage1#vlan
SwI#vlan database
database
Configurationde
deprotocole
protocole SwI(vlan)#vtp server
etage1(vlan)#vtp client
VTP
VTP SwI(vlan)#vtp domain
etage1(vlan)#vtp domain
UBCI.com.tn
UBCI.com.tn

10
Réalisation  « LAN »

Siege
Siege (config)
(config) ## ip
ip dhcp
dhcp pool
pool Admin
data
Voice
data
Voice
Admin
Siege
Siege (dhcp-config)
(dhcp-config) ## network
network 11.142.2.1
10.142.2.1
22.142.2.1
10.142.2.1
22.142.2.1
11.142.2.1
255.255.254.0
255.255.254.0
Configuration
Configurationde
deprotocole
protocole Siege
Siege (dhcp-config)
(dhcp-config) #default-router
#default-router
DHCP
DHCP 10.142.2.1
22.142.2.1
11.142.2.1
10.142.2.1
22.142.2.1
11.142.2.1
Siege
Siege (dhcp-config)
(dhcp-config) #exit
#exit
Siege
Siege (config)#
(config)# ip
ip dhcp
dhcp excluded-address
excluded-address
10.142.2.1
22.142.2.1
11.142.2.1
10.142.2.1 11.142.2.2
22.142.2.1
11.142.2.1 10.142.2.2
22.142.2.2
10.142.2.2
22.142.2.2
11.142.2.2

Siege
Siege (config-
(config)
(config) telephony)
(config- #telephony)
# telephony-service
## ephone-dn
ephone-dn 11
telephony-service
Siege
Siege (config-
(config- telephony)#
telephony)
telephony) ##125
telephony)# max-dn
max-dn 55
125
Siege
Siege (config-
(config- telephony)
telephony) ## max
max –ephones
–ephones 55
Configuration
Configurationdes
desIP
IPphones
phones Siege
Siege (config-
(config- telephony)
telephony) ## ip
ip source
source address
address
22.142.2.1
22.142.2.1 port
port 2000
2000
Siege
Siege (config-
(config- telephony)
telephony) ## auto
auto assign
assign 44 to
to 66
Siege
Siege (config-
(config- telephony)
telephony) ## auto
auto assign
assign 11 to
to 55

11
Partie WAN

A
Solution WAN proposée

B
Configuration des liaisons MPLS

C
Configuration des liaisons VPN

D
L ’implémentation du protocol HSRP

12
Architecture WAN existante

13
Problématique

Convergence de différent Augmentation du


flux tels que voix, data Et nombre d’utilisateurs

1
Augmentation de la taille des tables de routages

2
Augmentation des temps de traitement et de traversée

14
Problématique

Besoin de trouver une méthode plus


efficace pour la transmission de
paquets en garantissant la qualité de
service

MPLS
15
Solution WAN proposée

Siége_VPN
Siége_MPLS
HSRP

16
Maquette MPLS

10.10.10.0/3 10.10.10.4/30
0

10.142.249.0 10.142.249.24/3
/30 0

10.142.2.0/2
3 10.142.20.0/23

17
Implémentation de MPLS
1
Activation du routage IP classique

o Assignation des adresse IP par interface


o Assignation des adresse IP des loopback des routeur CE et PE
o Activation du routage IGP (OSPF)
2
Activation MPLS

o Activation de la commutation CEF


o Activation de la distribution des labels sur les interfaces participants
o Configuration de l’ IGP (OSPF)
3
Activation MPLS/VPN

o Configuration de VRF
o Assignation de VRF à une interfaces
o Configuration de MP-BGP entre les PE
oConfiguration de OSPF par VRF
o Redistribution de MP-BGP en OSPF et OSPF en MP-BGP
18
Implémentation de MPLS
 Extrait de configuration :
Activation de la
ip cef commutation CEF
mpls label protocol ldp
mpls ip Activation de la
distribution de
label
ip vrf site
rd 1:1
route-target export 1:1 Configuration d’un
route-target import 1:1 VRF
exit
Assignation des
interface Loopback 0 adresse loopback
ip address 4.4.4.4 255.255.255.255
Activation de la
interface s1/0 distribution des labels
ip address 10.10.10.5 255.255.255.252 sur touts les interface
P et PE
mpls ip
19
Implémentation de MPLS
 Extrait de configuration :

int s1/1 Assignation de VRF


ip vrf forwarding site a une interface
ip address 10.142.249.26 255.255.255.252

router ospf 10 vrf site Configuration de


redistribute bgp 1 subnets OSPF par VRF
network 10.142.249.26 0.0.0.0 area 0 Redistribuer BGP
exit en OSPF

router ospf 1 Configuration de


routage IGP
network 4.4.4.4 0.0.0.0 area 0 (OSPF)
network 10.10.10.5 0.0.0.0 area 0

20
Implémentation de la QOS

QOS Diffserv

DSCP

EF : Trafic AF: Best effort


voix
Haute priorité
BP: 80Kbits/s

21
Implémentation de la QOS
 Extrait de configuration :
Définir une classe
Megrine(config)# class-map match –all pour notre stratégie
voix de QOS
Megrine(config-cmap)# match ip rtp
16383 16000 Assuré le transfert
Megrine(config-cmap)# exit de la voix (EF)
Megrine(config)# policy map out policy
L’algorithme traite
Megrine(config-pmap)# class voix en priorité la voix et
Megrine(config-pmap-c)# set dscp ef lui garantie au
Megrine(config-pmap-c)# priority 80 moins 80kbits/s de
Megrine(config-pmap-c)#exit la bande passante
Megrine(config-pmap)#class class-default Assuré le transfert
Megrine(config-pmap-c)# set ip dscp des données (best
default effort )
Megrine(config-pmap-c)#exit
Megrine(config-pmap)#exit
Megrine(config)#interface s1/0
Megrine(config-if)#service-policy output
out policy 22
Configuration des liaisons VPN

1
Mettre en place les Tunnels entre les deux sites
( définition des interfaces virtuelles).

2
Crypter les Tunnels.

3
Mettre en place le routage intersites

23
Définition de l’interface virtuelle

•interface Tunnel1
•ip address 172.16.254.2
255.255.255.252
•tunnel source Serial1/1
•tunnel destination
10.142.245.1

24
Cryptage du tunnel
•crypto isakmp policy 2
• authentication pre-share
• lifetime 3600
•crypto isakmp key UBCI address
10.142.245.2
•crypto ipsec transform-set
transfdes esp-des
•crypto map cryptvpn 2 ipsec-
isakmp
• set peer 10.142.245.2
• set security-association lifetime
kilobytes 102400
• set security-association lifetime
seconds 900
• set transform-set transfdes
• match address cryptolist 25
Routage intersites

•router ospf 20
• log-adjacency-changes
• network 10.142.2.0
0.0.1.255 area 0
• network 10.142.245.24
0.0.0.3 area 0
• network 172.16.254.0
0.0.0.3 area 0

26
Les accès Listes
ip access-list extended cryptolist
permit gre host 10.142.245.1 host 10.142.245.2
ip access-list extended natlist
deny ip 10.142.2.0 0.0.1.255 10.142.20.0 0.0.1.255
permit ip 10.142.2.0 0.0.1.255 any
ip access-list extended netin
permit tcp any host 10.142.245.1 established
permit udp any eq domain host 10.142.245.1
permit tcp any eq www host 10.142.245.1
permit tcp any eq 443 host 10.142.245.1
permit udp host 10.142.245.2 eq isakmp host 10.142.245.1 eq isakmp
permit esp host 10.142.245.2 host 10.142.245.1
ip access-list extended netout
permit udp host 10.142.245.1 any eq domain
permit tcp host 10.142.245.1 any eq www
permit tcp host 10.142.245.1 any eq 443
permit tcp any eq 443 host 10.142.245.1
permit udp host 10.142.245.1 eq isakmp host 10.142.245.2 eq isakmp
permit esp host 10.142.245.1 host 10.142.245.2
27
Implémentation du protocole HSRP

Siège
Siège VPN
MPLS
••standby
standby 11 ip
ip 10.142.2.3
10.142.2.3
••standby
standby 11 priority
priority 100
110
••standby
standby 11 preempt
preempt

28
Implémentation du protocole HSRP
Scénario 1

29
Implémentation du protocole HSRP
Scénario 2

30
Implémentation du protocole HSRP
Scénario 3

31
Implémentation du protocole HSRP
implémentation du paramètre « track »

•interface FastEthernet 2/0


•standby 1 track FastEthernet 2/1
•standby 1 track serial 1/0 3
•standby 1 1 track serial 1/1 3

32
Conclusion
A travers ce projet nous avons mis en place une solution
d’interconnexion LAN qui supporte la téléphonie IP et
tolérante aux pannes.

Nous a avons Implémenté une nouvelle architecture WAN


hautement disponible en garantissant la qualité de service
et tolérante aux pannes en prévoyant un basculement
automatique entre équipements en cas de problème.

Un tel réseau dans son ampleur a besoin d’un outil de


supervision ce qui lui fait défaut, pour ce la il faut penser à
mettre en place un outil qui assure la sécurité d’accès au
réseau LAN par exemples des firewalls.

33
34