Vous êtes sur la page 1sur 24

RAPPEL DES NOTIONS

DE BASE DE EXCEL
Qu’est ce que Excel?
• Excel est un logiciel de la suite bureautique Office de
Microsoft et permet la création de tableaux, de calculs
automatisés, de plannings, de graphiques et de bases de
données. On appelle ce genre de logiciel un "tableur".
• Cellule : zone d’une feuille de calcul (intersection d’une ligne et
d’une colonne) où les données sont entrées sous forme de texte,
chiffre ou formule

• Formule : opération mathématique pour calculer ou analyser les


chiffres du modèle

• Feuille de calcul : feuille contenant des cellules, un graphique, les


résultats du gestionnaire de scénarios …

• Classeur : fichier ou document dans lequel se trouvent plusieurs


feuilles de calcul

• Graphique : image qui représente une ou plusieurs séries de


chiffres
• un assistant graphique ;
• un générateur de base de données (permettant de créer des
filtres) ;
Les fonctions de calcul
• SOMME
• =SOMME(A1,A2,A3) ou =Somme(A1:A5)
• MOYENNE
• =MOYENNE(A1:A4)
• Soustraction, multiplication et Division( - , * , / )
• =A1+A2
• =A1*A2
• =A1/A2
Quelques fonctions Statiques et mathématiques
• MIN,MAX,RANG
• =MAX(A1:A100) , =MIN(A1:A10) , =RANG(D6;D6:D14) ou
=RANG(D6;D$6:D$14) étirer la formule vers le bas
• Arrondi
• =Arrondi(A1,2) (2chiffres après la virgule)
• NB,NBVAL
• NB calcule le nombre de cellule contenant des nombres et des dates
• NBVAL calcule le nombre de cellule NON VIDES contenant
texte,nombre,date……
• SOUS.TOTAL
• SI

• =SI(A1>=19;20;A1) 
• OU , ET:
• =SI(OU(B2=4;C2=4);"Inscrit";"-") ;
• =SI(ET(B2="A";C2="C");"Oui";"Non")

• NB.SI
=NB.SI(plage; critères)

• Exemple:
• =NB.SI(A2:A5; “pommes”)

• SOMME.SI

=SOMME.SI(plage_critére ;critère;[plage_somme])
• Exemple:
• =SOMME.SI(D2:D10;“>2000”;F2:F10)

• plage_critére : la référence de la plage de cellules contenant les valeurs parmi lesquelles on va chercher
le critère souhaité.
• Critères : c’est votre condition à réaliser.
• plage_somme : c’est la plage qui contient les valeurs dont on veut calculer la somme. Si la plage de
critères est elle-même la plage_somme, vous pouvez omettre cette dernière.
fonctions Statiques et mathématiques-
suite
• MOYENNE.SI
• =MOYENNE.SI(plage_critére; critères; [plage_moyenne])

• plage_critére : vous devez définir pour cet argument la référence de la plage de cellules
contenant les valeurs parmi lesquelles on va chercher le critère souhaité.
• Critères : c’est votre condition à réaliser.
• plage_moyenne : c’est la plage qui contient les valeurs dont on veut calculer la moyenne. Si la
plage de critères est elle-même la plage_moyenne, vous pouvez omettre cette dernière.

• Exemple:
• Pour ignorer les cellules qui contiennent 0 dans le calcul de la moyenne:
• =MOYENNE.SI(A1:A5;"<>0" )
• Moyenne avec une condition:
• Calcule de la moyenne des ventes réalisé par mohammed:
• =MOYENNE.SI(A9:A14;"mohammed";B9:B14)
• =MOYENNE.SI(A9:A14;A9;B9:B14) remplacer mohammed par la reference de sa cellule
• Moyenne si date 
• Moyenne avant une date:
•  =MOYENNE.SI(A2:A8;"<30/10/2018";C2:C8)
• Moyenne avant aujourd’hui:
• =MOYENNE.SI(A2:A8;"<"&AUJOURDHUI();C2:C8)
• =MOYENNE.SI(A2:A8;"<"&A23;C2:C8) remplacer aujourd’hui() par la reference de sa cellule
Références absolu, relatif et mixte
 une cellule est désignée par son numéro de colonne et de ligne, appellée
aussi la référence ;
A1 est la référence de la cellule A1  !
Pour utiliser efficacement les formules de calcul, il est important de bien
comprendre comment sont référencées les cellules.
Il existe 4 types de références :
Référence relative (ex : A1)
La référence de la cellule est relative. Si l’on fait un copier/coller d’une formule
contenant cette référence ( Par exemple A1 ) alors la référence de la formule
s’ajustera en fonction du nouvel emplacement.
Référence absolue (ex : $A$1)
Si l’on fait un copier/coller d’une formule contenant une référence
absolue ( Par exemple $A$1 ) alors la référence de la formule ne changera
pas. Le symbole dollars « $ » permet de transformer une référence
relative en référence absolue
Il est très important de comprendre cette notion car très souvent dans une
feuille de calcul, vous avez des données importantes qui doivent être utilisées
dans vos formules : date du jour, date de facturation, taux de change,
cours de devises, paramètres dans une formule.......
Reference absolu -Suite
• Une référence absolue c'est une référence qui ne va pas
être modifiée lors d'une phase de recopie. On parle
aussi d'une référence fixée.
• Une cellule est fixée quand vous mettez des $ de part et
d'autre de la référence :
• =$F$2

Pour facilement positionner les symboles $ autour de la référence d'une


cellule il vous suffit d'appuyer sur la touche F4 de votre clavier.
Reference mixte-Suite
• Ligne absolue (ex : A$1)

• Colonne absolue (ex : $A1)

• Référence mixte : Une référence mixte, c'est une référence qui est bloquée
soit sur une colonne, soit sur une ligne mais pas sur les 2 références de la
cellule.
Les Filtres automatiques
les feuilles de calcul Microsoft Office Excel constituent
l’outil incontournable pour compiler des informations sur les
clients, les produits, les revenus des ventes et d’autres
données……
 Mais quand le volume des données consignées dans une
même feuille remplit une multitude de colonnes ou de
rangées, il peut être très difficile de les trier de façon
efficace.
Les filtres automatiques-suite
• Heureusement, Excel offre une fonction de filtre, facile à
utiliser, pour afficher uniquement ce que vous désirez voir et
masquer tout le reste. Le filtrage ne modifie d’aucune façon
vos données. Dès que vous retirez le filtre, toutes vos
données réapparaissent exactement comme avant.
• – On peut filtrer une liste: n’afficher que les lignes qui
satisferont un certain critère
– On peut extraire des lignes pour les recopier à un autre
endroit
– Pour exprimer les conditions, nous avons :
• Les filtres automatiques
• Les filtres élaborés
• Tous les deux accessibles par le menu Données
Les filtres automatiques-suite
• Filtre automatique ou des opérateurs de comparaison tels que « supérieur à » et
« 10 premiers » dans Excel permet d’afficher les données voulues et masquer le
reste. Une fois que vous avez filtré des données dans une plage de cellules ou le
tableau, vous pouvez appliquer à nouveau un filtre pour obtenir des résultats
actualisés, ou effacer un filtre pour afficher de nouveau toutes les données.

Les données filtrées n’affichent que les lignes qui répondent aux critères
spécifiés et masquent celles que vous ne voulez pas afficher. Une fois les
données filtrées, vous pouvez les copier, les modifier, les mettre en forme, les
représenter sous forme de graphique et les imprimer sans les réorganiser ni les
déplacer.

• Vous pouvez également filtrer les données dans plusieurs colonnes. Les filtres
sont additifs, à savoir que chaque filtre supplémentaire est basé sur le filtre actif,
ce qui réduit encore davantage le sous-ensemble de données.
Les filtres automatiques-suite
• Filtrer une plage de données
Sélectionnez les données à filtrer. Pour des résultats
optimaux, les colonnes doivent comporter des en-têtes.

• Cliquez sur la flèche   dans l’en-tête de colonne, puis


cliquez sur Filtres textuels ou Filtres de nombre.
Les filtres automatiques-suite
• Cliquez sur l’un des opérateurs de comparaison. Par
exemple, pour afficher les nombres avec une limite
inférieure et une limite supérieure, sélectionnez Entre.
Les filtres automatiques-suite
• Dans la zone Filtre automatique personnalisé, tapez ou
sélectionnez les critères de filtrage de vos données. Par
exemple, pour afficher tous les nombres compris entre 1 000 et
7 000, dans la zone est supérieur ou égal à, tapez 1000 et
dans l’est inférieure ou égale à la zone, tapez 7000.

• Cliquez sur OK pour appliquer le filtre.


Les filtres automatiques-suite
• Excel filtre les données de toutes les cellules
sélectionnées dans une plage, tant que cette sélection ne
contient aucune cellule ou colonne vierge.
• Si le filtre rencontre une colonne ou une cellule vierge,
celui-ci sera interrompu.
• Si les données de la plage que vous voulez filtrer sont
séparées par une colonne ou une cellule vierge, enlevez-
la avant de lancer le filtre automatique.
Filtres avancés ou élaborés
• Outil puissant qui permet de filtrer des données avec plus
de possibilités que le filtre simple dont on atteint très vite
ses limites.
• En plus de filtrer les données sur place, il permet
l'exportation de celles-ci vers une autre feuille ou un autre
classeur. Son exploitation en VBA offre de belles
perspectives de développement.
Filtres avancés ou élaborés - suite
• Table de données : la première ligne d'une table de données
Excel doit contenir les noms des champs, appelés aussi
étiquettes ;
• les lignes, de la deuxième à la dernière, contiennent toutes les
données (par exemple les renseignements concernant les
clients) : ces lignes sont appelées "enregistrements".
• Chaque colonne contient, pour chaque enregistrement, les
données correspondant à l'étiquette de la colonne.
• Enregistrement : ligne contenant tous les éléments
spécifiques d'un objet déterminé et unique (par exemple les
données d'un client, d'un article…).
• Étiquette : chaque cellule de la première ligne de la table de
données, nommant le contenu de la colonne (par exemple :
"Nom", "Prénom", Numéro", etc.).
Filtres avancés ou élaborés - suite
• Pour utiliser un filtre élaboré, il faut au moins une table de
données et une zone de critères.
• La table de données doit avoir en première ligne les
étiquettes de colonne.
• La zone de critères doit avoir en première ligne des
étiquettes de colonnes et au moins une ligne avec un ou
plusieurs critères sauf pour filtrer les doublons
Filtres avancés ou élaborés - suite
Exemple de filtre élaborés:
On a la tables suivante:
Filtres avancés ou élaborés - suite
Comment activer le filtre élaboré?
• Excel 2007 et suivants : Onglet [Données], groupe Trier
et filtrer, commande Avancé.
• Ensuite la boîte de dialogue apparaît :
• la zone Plages remplie si le curseur se trouve dans une
des cellules de la table des données.
Filtres avancés ou élaborés - suite
• filtrer les lignes (les enregistrements) où la
colonne Lieu est égale à "Bruxelles".
• Dans la cellule B2 qui se trouve juste en dessous de
l'étiquette Lieu, nous introduisons la valeur "Bruxelles".
• Dans le groupe Trier et filtrer de l'onglet [Données],
cliquons sur la commande Avancé. La boîte de
dialogue Filtre avancé apparaît.
Filtres avancés ou élaborés - suite
• Analysons chaque option de cette boîte.
• Filtrer la liste sur place : filtre directement dans la zone de cellules d'Excel
où sont placées les données de départ et qui sont déclarées par
l'option Plages(dans notre exemple A5:G12).
• Copier vers un autre emplacement : permet de créer la liste filtrée vers un
autre emplacement défini par l'option Copier dans.
• Plages : la zone à filtrer.
• Zone de critères : désigne la plage de cellules où nous avons inséré nos
critères de filtrage (dans notre exemple A2:G2).
• Copier dans : désigne la cellule ou la plage de cellules à partir de laquelle la
copie des lignes filtrées se fera. Cette option n'est accessible que si
l'option Copier vers un autre emplacement est cochée.
• Extraction sans doublon : permet de ne pas afficher les données en double
soit avec le filtre sur place, soit en copiant vers un autre emplacement.
• Nous optons donc pour le filtre sur place en prenant comme plage A5:G12 et
comme zone de critères A1:G2. Confirmons par OK et voyons le résultat.

Vous aimerez peut-être aussi