Vous êtes sur la page 1sur 56

UNIVERSIT DE TECHNOLOGIE

COMPIGNE

Cours SR04 du 09/12/2013


UTC Cours MPLS

MPLS
(MultiProtocol Label Switching)

Christophe Fillot
DSI
2 / 56

Rappels sur le routage IP


Intrt de MPLS

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
3 / 56

Routage des paquets IP

Le routeur reoit un paquet IP sur une de ses interfaces,

Il extrait ladresse IP de destination prsente dans le paquet,

Il consulte sa table de routage et dtermine linterface de sortie et


ladresse IP du routeur suivant (next-hop ou prochain saut),

Il construit une nouvelle entte de niveau 2 (avec des protocoles comme


ARP par exemple) en fonction des informations obtenues.

Il envoie le paquet sur linterface de sortie.

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
4 / 56

Routage IP saut par saut: chaque saut doit connaitre


lensemble des routes!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
5 / 56

Internet: des interconnexions complexes de rseaux

Peering : change de trafic utilisateur entre 2 AS

09/12/2013 Transit: fourniture dune connectivit Internet complte


Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
6 / 56

Problmatique

Une recherche dans la table de routage IP est dite longest match :


pour une adresse IP donne on doit trouver le prfixe le plus spcifique
(ex: 192.168.1.0/24 est plus spcifique que 192.168.0.0/18)

Complexe pour les routeurs ayant toutes les routes Internet (plus de
430000 en 2012, actuellement: ~480000).

MPLS visait lorigine acclrer la commutation des paquets, en


utilisant un numro/label plutt que ladresse IP de destination (ou une
combinaison de plusieurs critres). Un label est ajout en entre de
rseau, et supprim la sortie, ce qui rend lopration transparente au
final. Sur le chemin, il y a remplacement (swap) de label.

Ainsi, les routeurs intermdiaires nont plus prendre de dcision


complexe chaque paquet, juste analyser un label (lookup dans une
table).

09/12/2013
Il faut toutefois mettre en place un systme de distribution des labels
Christophe FILLOT
pour crer des chemins (LSP Label Switched Path).
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
7 / 56

Principes de base de MPLS

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
8 / 56

Encapsulation

Les labels sont insrs entre lentte de niveau 2 (Ethernet, ) et


lentte de niveau 3 (IPv4, IPv6, )

On peut dire quil sagit du niveau 2.5

Il est possible davoir plusieurs labels conscutifs (stacking)

Un label a une taille de 4 octets (32-bits) et contient les informations


suivantes:
Label : entier sur 20 bits
TTL (Time-To-Live) : 8 bits
CoS/EXP : 3 bits (utilis pour la qualit de service)
BoS (Bottom of Stack): 1 bit (dernier label de la pile si = 1)

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
9 / 56

Commutation de label

On peut rsumer les oprations de commutation:

Push Label : insre un nouveau label (en tte) => routeur dentre (ingress)
Pop Label : supprime le 1er label => routeur de sortie (egress)
Swap : remplacement de label => routeurs intermdiaires

Les routeurs utilisent le 1er label de la pile pour la commutation.

Un peu de terminologie:
Label Switched Path (LSP): chemin MPLS
Label Switch Router (LSR): routeur supportant MPLS
Ingress LSR: routeur dentre (insertion de label)
Egress LSR: routeur de sortie (pop de label)
Forwarding Equivalent Class (FEC): groupe de paquets qui sont commuts de la
mme manire, suivant les mmes critres (ex le plus courant: adresse IP
destination), avec le mme chemin.

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
10 / 56

Distribution de Labels

Protocole : LDP (Label Distribution Protocol) RFC 5036

Les routeurs voisins tablissent une adjacence (Hello en UDP multicast,


puis connexion TCP)

2 modes:
Downstream on Demand : un routeur demande explicitement un label pour une
FEC ;
Unsollicited Downstream : le routeur annonce ses voisins un label pour chaque
prfixe/FEC quil connait.

Les routeurs construisent une LIB (Label Information Base), en


consolidant les informations reues de leurs voisins LDP.

On a typiquement plusieurs labels pour un mme prfixe IP =>


comment choisir ?

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
11 / 56

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
12 / 56

Construction de la LFIB

Les routeurs utilisent toujours un IGP pour calculer le meilleur chemin :


ils construisent une RIB (Routing Information Base), partir des
diffrents protocoles configurs (routes connectes, statiques, OSPF,
etc)

Avec laide de la RIB, on peut dterminer le meilleur label utiliser pour


un prfixe donn (le nexthop figure dans la LIB).

On garde les meilleurs labels pour gnrer la LFIB (Label Forwarding


Information Base)

Le routeur utilise la LFIB pour la commutation des paquets MPLS. La LFIB


contient typiquement ces informations:
Label dentre
Label de sortie (ou indication de poplabel si dernier saut)
Interface de sortie
Prfixe IP

Pour les routeurs hardware, la LFIB est programme dans le matriel


09/12/2013
(TCAM, )
Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
13 / 56

Construction de la LFIB : rsum

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
14 / 56

Exemple de LFIB

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
15 / 56

Pen-Ultimate Hop Popping (PHP)

Plutt quannoncer un vrai label, le dernier routeur du LSP peut


annoncer un label appel Implicit-Null (label rserv 3).

Lavant-dernier routeur, lorsquil reoit ce binding, sait quil doit raliser


une opration pop au lieu dune opration swap. Le label Implicit-
Null napparat en fait jamais sur le lien.

=> Cela vite que le dernier routeur ait analyser un label puis faire
un lookup IP dans sa FIB (il ne fait plus que le lookup IP).

Par dfaut sur Cisco IOS

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
16 / 56

Qualit de service (QoS)

Un label MPLS contient un champ de 3 bits appel CoS (ou EXP) qui sert
au marquage de la QoS.

Similaire lIP Precedence du champ DSCP dun paquet IP.

Les routeurs MPLS se basent sur ce champ CoS pour appliquer les rgles
de QoS (les routeurs IP utilisent le champ DSCP).

Par dfaut, les routeurs ingress recopient le champ IP DSCP dans le


champ CoS MPLS.

Possibilit sur le routeur Egress dannoncer un label Explicit-Null pour


garder linformation de CoS MPLS jusquau bout. Explicit-Null est un label
rserv (0 pour IPv4, 2 pour IPv6) qui apparat sur le lien.

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
17 / 56

Cur de rseau BGP-free

On reprend notre exemple initial, o tous les routeurs sont peers BGP et
connaissent lensemble des routes.

On active MPLS sur lensemble des routeurs, et on ne garde BGP


quentre routeurs de bordure (il faut donc juste un IGP (pour les routes
du coeur) et LDP sur les routeurs intermdiaires).

Les routeurs dentre encapsulent les paquets avec un label MPLS. Ce


label correspond au routeur de bordure de sortie (next-hop BGP pour le
prfixe correspondant ladresse IP de destination).

Cest le chemin optimal, puisque le label a t choisi en fonction de ce


qui a t calcul par lIGP.

Les routeurs intermdiaires acheminent le trafic en se basant sur le


label, et nexaminent plus lentte IP. Ils peuvent donc acheminer des
paquets pour lesquels ladresse IP de destination leur est totalement
inconnue.
09/12/2013

Christophe FILLOT En sortie, le routeur reoit un paquet IP (PHP) et le route normalement.


DSI

www.utc.fr/dsi
cf@utc.fr MPLS
18 / 56

Routage IP/MPLS : seuls les routeurs de bordure connaissent


toutes les routes

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
19 / 56

VPN niveau 3 avec MPLS/VPN

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
20 / 56

VPN niveau 3 (L3VPN)

De nombreuses entreprises disposent de sites externes (agences) qui


doivent se raccorder un site central (le sige)

On utilise gnralement des adresses IP prives (RFC 1918), non


routables sur Internet, pour ladressage interne (10.0.0.0/8,
172.16.0.0/12, 192.168.0.0/16).

Elles peuvent faire appel des oprateurs capables de leur fournir un


service de VPN niveau 3 (loprateur soccupe du routage entre les sites
de lentreprise)

Problme: diffrents clients sont susceptibles dutiliser des plans


dadressage privs qui se recouvrent.

MPLS/VPN permet de rsoudre ce problme, en isolant compltement le


trafic des clients.

Attention, MPLS/VPN ne fournit aucun chiffrement, il sagit disoler du


09/12/2013 trafic. Pour scuriser le trafic, il faut utiliser un protocole comme IPSec.
Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
21 / 56

Exemple doprateur raccordant 3 clients diffrents

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
22 / 56

Virtual Routing and Forwarding (VRF)

Un routeur IP classique ne dispose gnralement que dune seule


table de routage, utilise pour tout le trafic IP.

Pour MPLS/VPN, il est ncessaire disoler le trafic entre les diffrents


clients, qui peuvent en plus avoir des plans dadressages recouvrants
(adressage priv)

=> Les routeurs MPLS/VPN supportent plusieurs tables de routage


dissocies appeles VRF. Chaque VRF dispose de ses propres RIB et
FIB.

Pour placer le trafic dans une VRF donne, il existe plusieurs mthodes:
Assignation en dur dune interface ou dune sous-interface dans la VRF
Mthode dynamique, en fonction de diffrents critres (typiquement adresses IP
des paquets entrants).

Il est possible dutiliser les VRF sans utiliser MPLS/VPN, il sagit de VRF
Lite.
09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
23 / 56

Exemples de configuration Cisco IOS

! Definition de la VRF
ip vrf BLUE
rd 100:1
route-target import 100:1
route-target export 100:1
!
interface Ethernet1/0
ip vrf forwarding BLUE
ip address 10.0.0.1 255.255.255.0
!
ip route vrf BLUE 10.1.0.0 255.255.255.0 10.0.0.2
!
router ospf 200 vrf BLUE
network 10.0.0.0 0.0.0.255 area 0
!
router bgp 65000
address-family ipv4 vrf BLUE
neighbor 10.0.0.3 remote-as 65001
neighbor 10.0.0.3 activate
!
!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
24 / 56

Mapping de sous-interfaces dans des VRF diffrentes

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
25 / 56

Mapping de sous-interfaces dans des VRF diffrentes: Cisco IOS

interface Ethernet1/0.1
encapsulation dot1Q 100 ! Description VLAN 100: Personnels
ip vrf forwarding pers
ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0.2
encapsulation dot1Q 200 ! Description VLAN 200: Etudiants
ip vrf forwarding etu
ip address 10.1.0.1 255.255.255.0
!
interface Ethernet1/0.3
encapsulation dot1Q 300 ! Description VLAN 300: Invits
ip vrf forwarding guests
ip address 10.2.0.1 255.255.255.0
!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
26 / 56

Terminologie

3 types de routeurs : P, PE, CE

Router P (Provider) : appartient au cur de rseau de loprateur, il


na aucune notion de VRF ou de VPN (pas de connexion de clients)

Router PE (Provider Edge): appartient loprateur, ces routeurs


raccordent les clients et utilisent des VRF pour isoler leur trafic.

Routeur CE (Customer Edge): appartient au client, et na aucune


notion de MPLS ou de VRF.

Les routeurs P ne sont pas obligatoires, il est tout fait possible de


monter un backbone avec uniquement des routeurs PE.

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
27 / 56

MP-BGP

Les routeurs PE peerent entre eux en MP-BGP (Multi-Protocol BGP),


en utilisant laddress-family VPNv4 [AFI 1 (IPv4), SAFI 128 (VPN)]

Les routes changes contiennent notamment un prfixe dit VPN-


IPv4 (Prfixe IPv4 + Route Distinguisher) et un Label MPLS, local au PE
qui fait lannonce.

Le RD (Route Distinguisher) permet de distinguer les routes de clients


diffrents. Le RD a une taille de 8 octets (il est configur manuellement
par loprateur).

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
28 / 56

Exemple dupdate MP-BGP

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
29 / 56

Acheminement du trafic

Dans notre exemple, on voit que PE1 reoit le label 28 du routeur PE2
pour la route VPN-IPv4 100:1:192.168.1.0/24

Problme: comment utiliser ce label qui est local PE2 ? Si on envoie un


paquet avec le label 28 P1, celui-ci ne connat pas ce label (ou il est
utilis pour tout autre chose) => il faut pouvoir aiguiller le trafic vers
PE2 !

Dans lupdate MP-BGP, on connait le next-hop (PE2), et on a appris par


LDP un label pour cette adresse.

PE1 va construire un paquet avec 2 labels MPLS:


Le 1er label correspond au label pour atteindre PE2. Il est appris via LDP
Le 2nd label correspond au label VPN utilis par PE2. Il est appris par MP-BGP

Les routeurs intermdiaires ne soccupent que du 1 er label: lorsque le


paquet arrive PE2, le 1er label a t retir (PHP), seul reste le 2 nd label,
qui va permettre PE2 daiguiller le paquet vers la bonne interface de
09/12/2013 sortie.
Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
30 / 56

Exemple dacheminement

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
31 / 56

Route-Targets (RT)

Les RT sont des communauts tendues BGP

Un routeur PE annonce les routes dune VRF avec les RT spcifis en


export.

Les autres routeurs PE importent ces routes dans les VRF qui sont
configures pour importer ces valeurs de RT.

Ne surtout pas confondre avec le RD qui sert distinguer les routes!

Exemple: le routeur 1 exporte les routes de la VRF FOO avec le RT


100:1. Le routeur 2 importe les routes marques avec le RT 100:1
dans la VRF BAR.
! !
hostname Router1 hostname Router2
! !
ip vrf FOO ip vrf BAR
rd 400:150 rd 300:200
route-target export 100:1 route-target import 100:1
! !
09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
32 / 56

Route-Targets: Topologie Any To Any

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
33 / 56

Route-Targets: Topologie Hub & Spoke

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
34 / 56

Configuration Cisco IOS


!
hostname PE2
!
ip vrf BLUE
rd 100:1
route-target both 100:1 ! Both= Import + Export
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Ethernet0/1
description Client 1
ip vrf forwarding BLUE
ip address 192.168.1.1 255.255.255.0
!
router bgp 65000
neighbor 10.1.1.1 remote-as 65000
neighbor 10.1.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
!
address-family ipv4 vrf BLUE
redistribute connected
09/12/2013 !
Christophe FILLOT !
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
35 / 56

6PE
(IPv6 Provider Edge)

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
36 / 56

Principes de 6PE

Raccordement de clients IPv6, travers un cur MPLS (RFC 4798)

Pas de normalisation de LDP pour IPv6 => Utilisation de MP-BGP [AFI 2


(IPv6), SAFI 4 (label)]

Avec 6PE, le cur na pas besoin dtre IPv6-aware

Avantages :
Ne ncessite pas un upgrade du cur, on conserve lexistant
Seuls les routeurs PE doivent tre mis jour et supporter 6PE, cela peut se faire
de manire incrmentale

Mme principe que pour VPNv4 => 2 labels sont utiliss, le 1 er pour
atteindre le PE de sortie, le 2nd correspondant au prfixe IPv6 sur le PE.

Le Next-Hop BGP est annonc sous forme dadresse IPv6 IPv4-


09/12/2013 Mapped. Les PE extraient ladresse IPv4 et recherchent le label
Christophe FILLOT annonc par LDP pour cette adresse.
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
37 / 56

Exemple dacheminement

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
38 / 56

Configuration Cisco IOS

!
hostname PE2
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Ethernet0/1
description Client IPv6
ipv6 address 2001:660::1/48
!
router bgp 65000
neighbor 10.1.1.1 remote-as 65000
neighbor 10.1.1.1 update-source Loopback0
!
address-family ipv6
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-label
redistribute connected
!
!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
39 / 56

6VPE
(IPv6 VPN Provider Edge)

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
40 / 56

Principes de 6VPE (RFC 4659)

6PE permet de raccorder des sites en IPv6, mais sans notion disolation
de trafic (trafic global).

6VPE reprend les mmes concepts que pour VPNv4 (VRF, RD/RT)

Les avantages sont les mmes que pour 6PE (pas de mise jour du
cur qui reste en IPv4/MPLS, pas de configuration supplmentaire sur le
cur, ).

Le Next-Hop BGP est annonc sous forme dadresse IPv6 IPv4-


Mapped. Les PE extraient ladresse IPv4 et recherchent le label
annonc par LDP pour cette adresse.

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
41 / 56

AToM
AnyThing Over MPLS

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
42 / 56

AnyThing Over MPLS

AToM permet de transporter des paquets de niveau 2 (ATM, Frame-Relay,


Ethernet, HDLC, PPP) travers un cur de rseau MPLS: mulation
dune liaison niveau 2 point--point (Pseudo-wire PW).

Session LDP directe tablie entre les 2 routeurs dextrmits: affectation


dun label pour le circuit.

Aucune configuration ncessaire sur les routeurs intermdiaires


(routeurs P)

2 labels utiliss sur le chemin:


1er label (appris par LDP) pour atteindre le routeur dextrmit
2nd label (appris par la session LDP entre routeurs PE) pour dterminer le circuit

Cross-connect

Intrt : permet de raccorder 2 sites avec une technologie niveau 2 sans


avoir besoin de crer une liaison spcialise.
09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
43 / 56

MPLS-TE
Traffic Engineering

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
44 / 56

Principes de MPLS-TE

LIGP slectionne le meilleur chemin suivant diffrents critres (bande


passante,)

Sur les rseaux fortement maills, des liens sont susceptibles dtre
sous-utiliss voire pas utiliss du tout

Le Traffic Engineering permet de crer des chemins alternatifs pour re-


router du trafic.

On cre par configuration des LSP qui vont passer par les liens sous-
utiliss

2 mthodes:
Chemin explicite: on liste les next-hops sur le routeur de dpart
Par affinit: utilisation de valeurs avec masques binaires ( dfinir par les
gestionnaires du rseau)

Protocoles mis en jeu:


09/12/2013 Extensions IGP (OSPF et IS-IS) pour le calcul du chemin ;
Christophe FILLOT RSVP-TE (Extension de RSVP Resource Reservation Protocol)
DSI
Signalisation/mise en place du LSP
www.utc.fr/dsi
cf@utc.fr MPLS
45 / 56

Pour aller plus loin

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
46 / 56

Autres possibilits

VPLS (Virtual Private LAN Service) : Emulation dun LAN par-dessus MPLS

MPLS CsC (Carrier Supporting Carrier) : Permet de construire son propre


rseau MPLS par-dessus un rseau MPLS dun autre oprateur

Inter-AS MPLS/VPN

etc

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
47 / 56

Questions ?

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
48 / 56

Dmonstration / Maquette

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
49 / 56

Topologie / Adressage IP

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
50 / 56

Partie 0: Configuration backbone

Initialement, on a prpar la configuration suivante:


Routeurs P et PE configurs avec:
Loopbacks, Interconnexions IP (/30)
OSPF (une seule aire, laire 0)
Les routeurs clients, avec:
Linterconnexion IP avec le routeur PE correspondant
Une route par dfaut vers le PE
Une loopback pour simuler le LAN

Au dpart, les routeurs clients (CE) nont bien sr pas de connectivit


entre eux.

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
51 / 56

Partie 0: Exemple avec P1

!
hostname P2
!
ip cef
!
interface Loopback0
ip address 10.254.0.1 255.255.255.255
!
interface Ethernet0/0
description Vers PE1
ip address 10.0.0.1 255.255.255.252
!
interface Ethernet0/1
description Vers PE2
ip address 10.0.0.5 255.255.255.252
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 0
!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
52 / 56

Partie 1: Etapes pour lactivation de MPLS

Vrifier la connectivit (ping, traceroute) dans le backbone avant


dactiver MPLS

Activer MPLS (+ LDP) sur les interfaces du backbone (pas sur les
interfaces ct clients!) avec la commande mpls ip.

Vrifier que les adjacences LDP sont bien tablies avec show mpls
ldp neighbor.

Tester (ping, traceroute) la connectivit. Le traceroute donne les


indications de label.

Note: sur un rseau de production, attention aux problmatiques de MTU


!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
53 / 56

Partie 2: Etapes pour lactivation de MPLS/VPN

Configurer le peering BGP entre PE1 et PE2.

Configurer les VRF BLUE et RED sur PE1 et PE2, avec les
informations suivantes:
PE1 / BLUE : RD 100:1, RT 65000:100
PE1 / RED : RD 200:1, RT 65000:200
PE2 / BLUE : RD 100:2, RT 65000:100
PE2 / RED : RD 200:2, RT 65000:100

Configurer les interfaces clientes pour les placer dans les VRF
(commande ip vrf forwarding <VRF>). Mettre en place les routes
statiques pour les subnets en 172.x.x.x (commande ip route vrf
<VRF> <subnet> <mask> <nexthop>)

Redistribuer les routes connectes et statiques dans BGP (redistribute


connected et redistribute static dans BGP, sous laddress-family ipv4
vrf <VRF>)

Vrifier la bonne rception des routes BGP avec show ip route vrf
09/12/2013
<VRF>
Christophe FILLOT
DSI

www.utc.fr/dsi Tester (ping, traceroute) la connectivit entre routeurs PE puis entre


cf@utc.fr MPLS
routeurs clients. Le traceroute donne les indications de label.
54 / 56

Partie 2: Exemple avec PE1 (1/2)


ip vrf BLUE
rd 100:1
route-target export 65000:100
route-target import 65000:100
!
ip vrf RED
rd 200:1
route-target export 65000:200
route-target import 65000:200
!
interface Ethernet0/2
description Vers RED1
ip vrf forwarding BLUE
ip address 192.168.1.1 255.255.255.252
!
interface Ethernet0/3
description Vers BLUE1
ip vrf forwarding RED
ip address 192.168.2.1 255.255.255.252
!
ip route vrf BLUE 172.16.0.0 255.255.0.0 192.168.1.2
ip route vrf RED 172.20.0.0 255.255.0.0 192.168.2.2
!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
55 / 56

Partie 2: Exemple avec PE1 (2/2)


router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.254.1.2 remote-as 65000
neighbor 10.254.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.254.1.2 activate
neighbor 10.254.1.2 send-community extended
exit-address-family
!
address-family ipv4 vrf BLUE
no synchronization
redistribute connected
redistribute static
exit-address-family
!
address-family ipv4 vrf RED
no synchronization
redistribute connected
redistribute static
exit-address-family
!

09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS
56 / 56

Commandes Cisco IOS utiles

show ip vrf : liste les VRF avec les interfaces associes

ping vrf <VRF> <adresse_ip> : ralise un ping dans la VRF indique

traceroute vrf <VRF> <adresse IP> : Traceroute

show ip route vrf <VRF> : affiche les routes de la VRF

show mpls ldp neighbor : affiche les voisins LDP

show mpls ldp bindings : affiche la LIB (Label Information Base)

show mpls forwarding-table : affiche la LFIB (Label Forwarding


Information Base)

show ip cef vrf <VRF> <subnet> <masque> : affiche les informations


de forwarding (y compris les labels MPLS utiliss)
09/12/2013

Christophe FILLOT
DSI

www.utc.fr/dsi
cf@utc.fr MPLS