Vous êtes sur la page 1sur 10

Commandes Switching Commandes de Configuration

Commande

Exemple

 

Fonction

 

Concepts et Configuration de Base de la Commutation

 

Configuration de la Connectivité IP

 
 

Passer

du

mode

d’exécution

S1#config t

privilégié

au

mode

de

configuration globale

 

S1(config)#interface vlan

S1(config)#interface vlan

Passer en mode de configuration d’interface pour l’interface du VLAN 99

id_vlan

99

S1(config-if)#ip address

adresse_ip masque

Comm1(config-if)#ip

Configurer

l’interface

   

address 172.17.99.11

255.255.255.0

l’adresse

IP

de

S1(config-if)#no shutdown

Active l’interface

 

S1(config)#interface

S1(config)#interface

Entrer dans l’interface pour affecter le réseau local virtuel

id_interface

fa0/18

S1(config-if)#switchport mode access

Définir le mode d’appartenance du port à un réseau local virtuel

S1(config-if)#switchport

S1(config-if)#switchport

Affecter le port local virtuel

à

un réseau

access vlan id_vlan

access vlan 99

S1(config)#ip default-

S1(config)#ip default- gateway 172.17.99.1

Configurer la passerelle par défaut sur le commutateur

gateway ip_address

S1#copy running-config startup-config

Enregistrer la configuration en cours dans la configuration de démarrage du commutateur

Configuration de la Mémoire Tampon d’Historique des Commandes

 

S1#terminal history

Active l’historique du terminal. Vous pouvez exécuter cette commande en mode utilisateur ou en mode d’exécution privilégié

S1#terminal history size

 

Configure la taille de l’historique du terminal. L’historique du terminal peut conserver entre 0 et 256 lignes de commande

taille

S1#terminal history size 50

S1#terminal no history size

Rétablit la taille de l’historique du terminal d’après sa valeur par défaut, soit 10 lignes de commande

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

S1#terminal no history

Désactive l’historique du terminal

Configuration du Mode Bidirectionnel et de la Vitesse

 

S1(config)#Interface fa0/1 S1(config-if)#duplex auto

Configurer le mode birectionnel d’interface pour activer la configuration bidirectionnelle automatique

 

Configurer

la

vitesse

S1(config-if)#speed auto

 

bidirectionnelle

d’interface

et

activer

la

configuration

de

 

vitesse automatique

Configuration d’une Interface Web

 
   

Configurer l’interface du serveur HTTP pour le type d’authentification enable. Les autres options disponibles sont les suivantes :

S1(config)#ip http authentication enable | local

enable : utilisation du mot de passe actif, soit la méthode par défaut pour l’authentification utilisateur du serveur HTTP. local : utilisation de la base de données utilisateur telle que définie sur le routeur Cisco ou le serveur d’accès. tacacs : utilisation du serveur TACACS.

| tacacs

S1(config)#ip http authentication enable

S1(config)#ip http server

S1(config)#ip http server

Activer le Serveur HTTP

 

Sauvegarde et Restauration des Configurations des Commutateurs

 

S1#copy system:running-config flash:startup-config Nom du fichier de destination [startup-config] ?

Version officielle de la commande de copie de Cisco IOS. Confirmez le nom du fichier de destination. Appuyez sur la touche Entrée pour valider ou sur les touches Crtl+C pour annuler

 

Version non officielle de

la

S1#copy running-config startup-config Nom du fichier de destination [startup-config] ?

commande de copie. Il est supposé alors que la configuration en cours est exécutée sur le système et que le fichier de configuration de démarrage sera stocké dans la mémoire vive non volatile flash. Appuyez sur la

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

 

touche Entrée pour valider ou sur les touches Crtl+C pour annuler

S1#copy startup-config flash:config.bak1 Nom du fichier de destination [config.bak1] ?

Sauvegardez la configuration de démarrage dans un fichier stocké dans la mémoire vive non volatile flash. Confirmez le nom du fichier de destination. Appuyez sur la touche Entrée pour valider ou sur les touches Crtl+C pour annuler

S1#copy flash:config.bak1 startup-config Nom du fichier de destination [startup-config] ?

Copiez le fichier config.bak1 stocké dans la mémoire flash dans la configuration de démarrage qui doit être stockée dans la mémoire flash. Appuyez sur la touche Entrée pour valider et sur les touches Crtl+C pour annuler

 

Demandez à Cisco

IOS

de

redémarrer le commutateur. Si vous avez modifié le fichier de

Comm1#reload

configuration en cours, le système vous demande de l’enregistrer. Confirmez par un

System configuration has been modified. Save? [yes/no]: n Proceed with reload? [confirm]?

'y' (oui)

ou

un

'n'

(non). Pour

confirmer le rechargement, appuyez sur la touche Entrée pour valider ou sur les touches Crtl+C pour annuler

S1#copy system:running- config

tftpserver_tftp_name

S1#copy system:running- config

tftp://172.17.2.155/Tokyo

-confg

Sauvegarde

des

fichiers

de

configuration

TFTP

sur

un

Serveur

S1#erase nvram

 

Suppression

des

fichiers

de

configuration

 

Configuration de l’Accès à la Console

 

S1(config)#line con 0

Passer du mode de configuration globale au mode de configuration de ligne pour la console 0

S1(config-line)#password

S1(config-line)#password

Définir cisco en tant que mot de passe pour la ligne de console 0 sur le commutateur

mot_de_passe

cisco

S1(config-line)#login

Définir la

ligne de console

pour

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

 

exiger la saisie du mot de passe avant l’octroi de l’accès

Configuration de l’Accès au Terminal Virtuel

 

S1(config)#line vty 0 4

Passer du mode de configuration globale au mode de configuration de ligne pour la console 0

S1(config-line)#password

S1(config-line)#password

Définir cisco en tant que mot de passe pour la ligne de console 0 sur le commutateur

mot_de_passe

cisco

S1(config-line)#login

Définir la ligne de console pour exiger la saisie du mot de passe avant l’octroi de l’accès

Configuration du mot de passe en mode d’Exécution

 

S1(config)#enable password

S1(config)#enable password class

Configurer la commande enable password pour le passage en mode d’exécution privilégié

mot_de_passe

S1(config)#enable secret

S1(config)#enable secret class

Configurer le mot de passe enable secret pour le passage en mode d’exécution privilégié

mot_de_passe

S1#service password-encryption

Crypter les mots de passe

 

Flash_init

 

Load_helper

Activation de la Récupération des mots de passe

boot

Configuration d’une Bannière de Connexion et la Bannière du Message du Jour

 

S1(config)#banner login

S1(config)#banner login "Authorized Access Only"

Configurer

une

bannière

de

"message"

connexion

S1(config)#banner motd "message"

S1(config)#banner motd "La maintenance du périphérique aura lieu vendredi."

Configurer une bannière du message du jour

Configuration de Telnet et SSH

 

S1(config)#line vty 0 15 S1(config-line)#transport input telnet

Configuration de Telnet

 

S1(config)#ip domain-name mydomain.com S1(config)# crypto key generate rsa S1(config)#ip ssh version 2 S1(config)#line vty 0 15 S1(config-line)# transport input SSH

Configuration de SSH

 

Configuration de la Sécurité des Ports sur un Commutateur Cisco Catalyst

 

S1(config)#interface fastEthernet 0/18 S1(config-if)#switchport mode access

Définissez le mode d’interface en accès. Vous ne pouvez pas

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

S1(config-if)#switchport port-security

configurer une interface en tant que port sécurisé selon le mode dynamique par défaut approprié et activez la sécurité des ports sur l’interface

Scripts de Configuration de la Sécurité des Ports

 

S1(config)#interface fa0/18 S1(config-if)#switchport mode access

Définissez le mode d’interface en accès

S1(config-if)#switchport port-security

Activez la sécurité des ports sur l’interface

S1(config-if)#switchport port-security maximum 50

Définissez le nombre maximal d’adresses sécurisées à 50

S1(config-if)#switchport port-security mac-address sticky

Activez l’apprentissage rémanent

S1(config-if)#switchport port-security violation shutdown

configuration du port pour qu’il se désactive automatiquement en cas de violation de la sécurité

Désactivation des Ports inutilisés

 

S1(config)#interface fa0/18

Désactiver le port inutilisé

S1(config)#shutdown

 

Réseaux Locaux Virtuels

Configuration de VLAN Natif et Agrégation 802.1q

 

S1(config)#interface F0/1 S1(config-if)#switchport mode trunk

Définir l’interface F0/1 comme agrégation IEEE 802.1Q

S1(config-if)#switchport

S1(config-if)#switchport

Configurer le VLAN 99 en tant que VLAN natif

trunk native id_vlan

trunk native vlan 99

Ajout d’un Réseau Local Virtuel

 

S1(config)#vlan id_vlan

S1(config)#vlan 20

Créer un VLAN. « id_vlan » est le numéro de VLAN à créer. Passe en mode de configuration de VLAN pour l’ID de VLAN du VLAN

S1(config-vlan)#name

S1(config-vlan)#name

(Facultatif) Spécifier un nom de VLAN unique pour identifier le VLAN. Si aucun nom n’est entré, le numéro de VLAN, complété par des zéros, est ajouté au mot « VLAN », comme par exemple

VLAN0020

nom_vlan

student

Affectation d’un Port de Commutateur

 

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

S1# config t S1(config)#interface fa0/18 S1(config-if)#switchport mode access

Définir le mode d’appartenance du port à un réseau local virtuel

S1(config-if)#switchport

S1(config-if)#switchport

Affecter le port local virtuel

à

un réseau

access vlan id_vlan

access vlan 20

 

Gestion des appartenances des Ports

 

S1# config t

S1# config t

Supprimer l’affectation de VLAN sur cette interface de port de commutateur et revenir à l’appartenance par défaut au VLAN 1

S1(config)#interface

S1(config)#interface

fa0/18

fa0/18

S1(config-if)#no switchport access vlan id_vlan

S1(config-if)#no switchport access 20

Configuration d’une Agrégation 802.1Q

 

S1(config)#interface

S1(config)#interface

   

id_interface

S1(config-if)#switchport

fa0/18

S1(config-if)#switchport

Forcer

la

liaison

à

reliant

devenir

les

une

mode trunk

mode trunk

commutateurs liaison agrégée

 

S1(config-if)#switchport

S1(config-if)#switchport

Spécifier un autre VLAN en tant que VLAN natif pour le trafic non étiqueté pour les agrégations IEEE 802.1Q

trunk native vlan id_vlan

trunk native vlan 99

Gestion de la configuration d’une Agrégation

 
 

réinitialiser

tous

les

VLAN

S1(config-if)#no switchport trunk allowed vlan

configurés

sur

l’interface

d’agrégation.

 

S1(config-if)#no switchport trunk native vlan

réinitialiser le VLAN natif et le réaffecter au VLAN 1.

 

réinitialiser l’interface du port

S1(config-if)#switchport mode access

d’agrégation en port de d’accès statique.

mode

S1(conf-if)#switchport

S1(conf-if)#switchport

trunk allowed vlan 10,20,99

Autoriser le trafic d'un VLAN à accèder à l’Agrégation

access trunk allowed vlan add id_vlan

 

Protocole VTP

Configurer le Serveur VTP

S1(config)#vtp mode server

Activer mode Serveur VTP

 

S1(config)# vtp

S1(config)# vtp domain

Configure le nom de Domaine

 

domain nom_domaine

cisco1

S1(config)# vtp

S1(config)# vtp password cisco

Configure un mot de passé

 

password mot_de_passe

S1(config)#vtp version

S1(config)#vtp version 1

Configurer la version du VTP

 

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

numéro

numéro
numéro

Configurer les Clients VTP

S1(config)#vtp mode client

Activer mode Client VTP

Connectez-vous au Serveur VTP

 

S1(config)#vlan 20 S1(config)# switchport access vlan 20

Configure les ports d’accès

 
 

Protocole STP

Configuration du Coût de Port

 

S1(config)#interface

   

id_interface

S1(config-if)#spanning-

tree cost valeur

S1(config)#int fa0/8

S1(config-if)#spanning-tree

cost 25

configurer

d’une interface

le

coût

des

ports

S1(config-if)#no spanning-tree cost

rétablir la valeur par défaut du coût du port

Configuration du BID (Bridge Identifier)

 

S1(config)#spanning-tree

S1(config)#spanning-tree

 

vlan id_vlan root primary

vlan 1 root primary

S1(config)#spanning-tree

S1(config)#spanning-tree

 

vlan id_vlan root secondary

vlan 1 root secondary

S1(config)#spanning-tree

S1(config)#spanning-tree

configuration de la valeur de priorité du pont

vlan id_vlan priority valeur

vlan 1 priority 24576

Configuration de la Priorité des Ports

 

S1(config)#interface

   

id_interface

S1(config-if)#spanning-

tree port-priority valeur

S1(config)#int fa0/1

S1(config-if)#spanning-tree

port-priority 112

configurer la valeur de priorité d’un port

Minuteurs BPDU

S1(config)#spanning-tree

S1(config)#spanning-tree

configurer le diamètre du réseau dans une configuration STP (5 = un diamètre de 5 switchs)

vlan id_vlan root primary diameter valeur

vlan 1 root primary diameter 5

Technologies PortFast de Cisco

 

S1(config)#int fa0/11 S1(config-if)#spanning-tree portfast

configurer PortFast sur un port de Switch

S1(config)#int fa0/11 S1(config-if)#no spanning-tree portfast

Désactiver

la

technologie

PortFast

Configuration du Protocole PVST+

 

S1(config)#spanning-tree

S1(config)#spanning-tree

configurer un Switch de sorte qu’il devienne le pont racine d’un

vlan id_vlan root primary

vlan 20 root primary

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

   

VLAN spécifié

S3(config)#spanning-tree

S3(config)#spanning-tree

configurer un Switch comme pont racine secondaire

vlan id_vlan root secondary

vlan 20 root secondary

S1(config)#spanning-tree

S1(config)#spanning-tree

Definer la Priorité du Switch à la valeur la plus faible possible

vlan id_vlan priority valeur

vlan 20 priority 4096

Configuration du Protocole Rapid PVST+

 
 

Configurer le

mode

d’arbre

S1(config)#spanning-tree mode rapid-pvst

recouvrant du protocole rapid

PVST+

S1(config)#int fa0/11 S1(config-if)#spanning-tree link-type point-to-point

Spécifier que le type de liaison pour ce port est point à point.

S1#clear spanning-tree detected-protocols

Désactiver tous les protocoles STP détectés

 

Routage Inter-VLAN

Configuration de sous-interface

 

R1(config)#interface id-

 

créer la sous-interface de routeur en entrant la commande interface f0/0.10 en mode de configuration globale. La syntaxe pour la sous-interface est toujours l’interface physique, dans ce cas f0/0, suivie d’un point et d’un numéro de sous- interface. Le numéro de sous- interface est configurable, mais est généralement choisi pour refléter le numéro de VLAN (dans cet exemple VLAN 10)

interafece-

physique_point_num-sous-

R1(config)#int f0/0.10

interface

R1(config-

R1(config-

une sous-interface doit être configurée pour fonctionner sur un VLAN spécifique

subif)#encapsulation dot1q

subif)#encapsulation dot1q

id_vlan

10

R1(config-subif)#ip address

adresse_ip masque

R1(config-subif)#ip address

affecte la sous-interface à l’adresse IP appropriée pour ce VLAN

172.17.10.1

255.255.255.0

R1(config)#int f0/0 R1(config-if)#no shutdown

Activer l’interface

 

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

Commandes de Vérification

Commandes

 

Fonction

 

Concepts et Configuration de Base de la Commutation

 

S1#show interfaces | S1#show interface

Affiche l’état et la configuration d’une ou de l’ensemble des interfaces disponibles sur le commutateur

fa0/1

S1#show startup-config

Affiche le contenu de la configuration de démarrage

S1#show running-config

Affiche la configuration actuelle

 

S1#show flash

Affiche des informations sur le système de fichiers flash

S1#show version

Affiche

l’état du

logiciel et du matériel

système

S1#show history

Affiche

l’historique

des

commandes

de

session

S1#show ip interface | http | arp

Affiche des informations IP. L’option d’interface dévoile l’état et la configuration de l’interface IP. L’option http affiche les données HTTP relatives au gestionnaire de périphériques exécuté sur le commutateur. L’option arp affiche la table ARP IP

S1#show mac-address-table

Affiche la la table de transmission MAC

 

S1#show port-security interface fa0/18

Verification de la Sécurité des Ports

 

S1#show port-security address

Verification des Adresses MAC sécurisées

 

Réseaux locaux Virtuels

 

S1#show interface fa0/1 switchport

Verification du VLAN Natif

 

S1#show vlan brief

Afficher une ligne pour chaque VLAN comportant le nom du VLAN, son état et ses ports

 

S1#show vlan id id_vlan

Afficher des informations sur un VLAN unique identifié par un numéro d’ID de VLAN. La valeur id_vlan peut être comprise entre 1 et 4094

S1#show vlan name name_vlan

Afficher des informations sur un VLAN unique identifié par un nom de VLAN. Le nom de VLAN est une chaîne ASCII de 1 à 32 caractères de long

S1#show vlan summary

Afficher un résumé sur les VLAN

 

S1#show vlan id_vlan switchport

Identification du VLAN. La plage est

 

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB

 

comprise entre 1 et 4094

S1#show interfaces trunk

 

Protocole VTP

S1#show vtp status

Affiche l’état VTP

S1#show vtp counters

vérifier que les annonces ont eu lieu

Protocole STP

S1#show spanning-tree

vérifier le coût des chemins et des ports vers le pont racine

Fait par le Stagiaire Souhaib EL BEJAOUI du TRI 2A GB