Vous êtes sur la page 1sur 16

Travaux pratiques 2.5.

1 : Configuration de base d’un commutateur

Schéma de topologie

Table d’adressage
Masque de Passerelle par
Périphérique Interface Adresse IP
sous-réseau défaut

PC1 Carte réseau 172.17.99.21 255.255.255.0 172.17.99.1

PC2 Carte réseau 172.17.99.32 255.255.255.0 172.17.99.1

S1 VLAN99 172.17.99.11 255.255.255.0 172.17.99.1

Objectifs pédagogiques
À l’issue de ces travaux pratiques, vous serez en mesure d’effectuer les tâches suivantes :
• Câbler un réseau conformément au schéma de topologie
• Supprimer une configuration existante sur un commutateur
• Examiner et vérifier la configuration par défaut
• Créer la configuration de base d’un commutateur, avec un nom et une adresse IP
• Configurer des mots de passe pour sécuriser l’accès à l’interface de ligne de commande
• Configurer les propriétés de vitesse de port et de mode bidirectionnel du commutateur pour une
interface
• Configurer la sécurité de base des ports du commutateur
• Gérer la table d’adresses MAC
• Affecter les adresses MAC statiques
• Ajouter et déplacer des hôtes sur un commutateur

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 1 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Scénario
Au cours de ces travaux pratiques, vous allez examiner et configurer un commutateur de réseau local
autonome. Bien qu’un commutateur exécute des fonctions de base dans son état initial par défaut, un
administrateur réseau doit modifier un certain nombre de paramètres pour s’assurer qu’un réseau local
est sécurisé et optimisé. Ces travaux pratiques vous présentent les notions fondamentales de la
configuration des commutateurs.

Tâche 1 : câblage, suppression et rechargement du commutateur

Étape 1 : câblage d’un réseau


Installez un réseau similaire à celui de la topologie. Créez une connexion console au commutateur. Si
nécessaire, reportez-vous aux Travaux pratiques 1.3.1 pour savoir comment créer une connexion
console.
Vous pouvez utiliser n’importe quel commutateur durant les travaux pratiques, pourvu qu’il soit équipé
des interfaces indiquées dans la topologie. Le résultat présenté dans ces travaux pratiques provient d’un
commutateur 2960. Si vous utilisez d’autres commutateurs, vous obtiendrez peut-être des résultats et
des descriptions d’interface différents.
Remarque : PC2 n’est pas initialement connecté au commutateur. Il est uniquement utilisé pour la
tâche 5.

Étape 2 : suppression de la configuration sur le commutateur


Supprimez la configuration sur le commutateur à l’aide de la procédure de l’annexe 1.

Tâche 2 : vérification de la configuration par défaut du commutateur

Étape 1 : accès au mode privilégié


Vous pouvez accéder à toutes les commandes du commutateur en mode privilégié. Toutefois, comme un
grand nombre des commandes du mode privilégié permettent de configurer des paramètres d’exploitation,
l’accès privilégié doit être protégé par mot de passe pour empêcher toute utilisation non autorisée. Vous
définirez des mots de passe dans la tâche 3.
Parmi les commandes du mode d’exécution privilégié, on retrouve celles du mode utilisateur, ainsi que la
commande configure qui donne accès aux autres modes de commande. Accédez au mode d’exécution
privilégié en entrant la commande enable.
Switch>enable
Switch#

Notez que l’invite a changé dans la configuration pour représenter le mode d’exécution privilégié.

Étape 2 : examen de la configuration actuelle du commutateur


Examinez le fichier de configuration en cours d’exécution.
Switch#show running-config

Combien d’interfaces FastEthernet le commutateur possède-t-il ? _______________________


Combien d’interfaces Gigabit Ethernet le commutateur possède-t-il ? ____________________
Quelle est la plage de valeurs affichée pour les lignes vty ? ____________________________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 2 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Examinez le contenu actuel de la mémoire vive non volatile :

Switch#show startup-config
startup-config is not present
Pourquoi le commutateur donne-t-il cette réponse ?
____________________________________________________________________________________
Examinez les caractéristiques de l’interface virtuelle VLAN1 :

Switch#show interface vlan1

Une adresse IP est-elle définie sur le commutateur ? _________________________________________


Quelle est l’adresse MAC de cette interface de commutateur virtuelle ? ___________________________
Cette interface fonctionne-t-elle ? _________________________________________________________
Affichez maintenant les propriétés IP de l’interface :

Switch#show ip interface vlan1

Quel résultat voyez-vous ? ______________________________________________________________

Étape 3 : affichage des informations Cisco IOS


Examinez les informations de version suivantes que rapporte le commutateur.
Switch#show version
Quelle version de Cisco IOS le commutateur exécute-t-il ? ____________________________________
Quel est le nom de fichier de l’image système ? _____________________________________________
Quelle est l’adresse MAC de base de ce commutateur ? ______________________________________

Étape 4 : examen des interfaces FastEthernet


Examinez les propriétés par défaut de l’interface FastEthernet utilisée par PC1.

Switch#show interface fastethernet 0/18

L’interface est-elle activée ou désactivée ? _________________________________________________


Quel événement pourrait activer une interface ? _____________________________________________
Quelle est l’adresse MAC de l’interface ? __________________________________________________
Quels sont les paramètres de vitesse et de mode bidirectionnel de l’interface ? ____________________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 3 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 5 : examen des informations du VLAN (réseau local virtuel)


Examinez les paramètres VLAN par défaut du commutateur.

Switch#show vlan

Quel est le nom du VLAN 1 ? ________________________________


Quels ports se trouvent dans ce VLAN ? ______________
Le VLAN 1 est-il actif ? _________________________________________________
Quel est le type de VLAN par défaut ? ______________________________

Étape 6 : examen de la mémoire flash


Lancez l’une des commandes suivantes pour examiner le contenu du répertoire flash.
Switch#dir flash:
ou
Switch#show flash

Quels sont les fichiers ou répertoires trouvés ?


____________________________________________________________________________________

Les fichiers comportent une extension de fichier, telle que .bin, à la fin du nom de fichier. Les répertoires
n’ont pas d’extension de fichier. Pour examiner les fichiers d’un répertoire, lancez la commande suivante
à l’aide du nom de fichier affiché dans le résultat de la commande précédente :

Switch#dir flash:c2960-lanbase-mz.122-25.SEE3

Le résultat doit être similaire à celui-ci :


Directory of flash:/c2960-lanbase-mz.122-25.SEE3/
6 drwx 4480 Mar 1 1993 00:04:42 +00:00 html
618 -rwx 4671175 Mar 1 1993 00:06:06 +00:00 c2960-lanbase-mz.122-25.SEE3.bin
619 -rwx 457 Mar 1 1993 00:06:06 +00:00 info
32514048 bytes total (24804864 bytes free)

Quel est le nom du fichier d’image IOS Cisco ? ______________________________________________

Étape 7 : examen du fichier de configuration initiale


Pour afficher le contenu du fichier de configuration initiale, lancez la commande show startup-config en
mode d’exécution privilégié.
Switch#show startup-config
startup-config is not present

Pourquoi ce message apparaît-il ? ______________________________________________________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 4 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Apportez une modification à la configuration du commutateur, puis enregistrez-la. Tapez les commandes
suivantes :

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#exit
S1#
Pour enregistrer le contenu du fichier de configuration en cours dans la mémoire vive non volatile,
exécutez la commande copy running-config startup-config.

Switch#copy running-config startup-config


Destination filename [startup-config]? (Entrée)
Building configuration...
[OK]

Remarque : il est plus facile d’entrer cette commande à l’aide de l’abréviation copy run start.
Affichez maintenant le contenu de la mémoire vive non volatile à l’aide de la commande show startup-
config.

S1#show startup-config
Using 1170 out of 65536 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S1
!
<résultat omis>

La configuration en cours a été enregistrée sur la mémoire vive non volatile (NVRAM).

Tâche 3 : création d’une configuration de base de commutateur

Étape 1 : attribution d’un nom au commutateur


Dans la dernière étape de la tâche précédente, vous avez configuré le nom d’hôte. Voici une liste des
commandes utilisées.
S1#configure terminal
S1(config)#hostname S1
S1(config)#exit

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 5 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 2 : définition des mots de passe d’accès


Passez en mode de configuration de ligne pour la console. Attribuez au mot de passe de connexion la
valeur cisco. Configurez également les lignes vty 0 à 15 en utilisant le mot de passe cisco.

S1#configure terminal
Enter the configuration commands, one for each line. When you are finished,
return to global configuration mode by entering the exit command or pressing
Ctrl-Z.

S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit

Pourquoi la commande login est-elle requise ? ______________________________________________

Étape 3 : définition des mots de passe du mode de commande


Définissez class comme mot de passe secret actif. Ce mot de passe protège l’accès au mode d’exécution
privilégié.
S1(config)#enable secret class

Étape 4 : configuration de l’adresse de la couche 3 du commutateur


Avant de pouvoir gérer S1 à distance depuis PC1, vous devez affecter une adresse IP au commutateur.
La configuration par défaut sur le commutateur est de contrôler la gestion du commutateur par le biais du
réseau local virtuel VLAN 1. Cependant, une méthode recommandée pour la configuration de base du
commutateur est de confier la gestion à un réseau local virtuel autre que le VLAN 1. Les implications et la
raison de cette opération sont exposées dans le chapitre suivant.
Pour des raisons de gestion, vous utiliserez le VLAN 99. Cette sélection est arbitraire et ne vous oblige
en aucun cas à toujours utiliser le VLAN 99.
Vous commencerez par créer le nouveau VLAN 99 sur le commutateur. Ensuite, vous
définirez 172.17.99.11 comme adresse IP du commutateur avec le masque de sous-
réseau 255.255.255.0 sur l’interface virtuelle interne VLAN 99.
S1(config)#vlan 99
S1(config-vlan)#exit
S1(config)#interface vlan99
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to down

S1(config-if)#ip address 172.17.99.11 255.255.255.0


S1(config-if)#no shutdown
S1(config-if)#exit
S1(config)#

Notez que l’interface VLAN 99 est désactivée même si vous avez entré la commande no shutdown.
L’interface est actuellement désactivée car aucun port de commutation n’est affecté au VLAN 99.

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 6 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Affectez tous les ports utilisateur au VLAN 99.


S1(config)#interface range fa0/1 - 24
S1(config-if-range)#switchport access vlan 99
S1(config-if-range)#exit
S1(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up
L’exploration complète des VLAN n’est pas au programme de ces travaux pratiques. Ce point est étudié
de façon détaillée dans le chapitre suivant. Toutefois, pour établir une connectivité entre l’hôte et le
commutateur, les ports utilisés par l’hôte doivent se trouver dans le même VLAN que le commutateur.
Dans le résultat ci-dessus, notez que l’interface du VLAN 1 est désactivée car aucun des ports n’est
affecté au VLAN 1. Au bout de quelques secondes, le VLAN 99 est activé, car au moins un port est
désormais affecté au VLAN 99.

Étape 5 : définition de la passerelle par défaut du commutateur


S1 étant un commutateur de couche 2, il prend des décisions de transfert en fonction de l’en-tête de la
couche 2. Si plusieurs réseaux sont connectés à un commutateur, vous devez préciser la façon dont le
commutateur transfère les trames de l’interréseau, car le chemin doit être déterminé sur la couche 3. Il
faut pour cela spécifier une adresse de passerelle par défaut qui pointe vers un routeur ou commutateur
de couche 3. Bien que cet exercice n’inclue pas de passerelle IP externe, considérez que vous
connecterez le réseau local à un routeur pour un accès externe. En supposant que l’interface du réseau
local soit 172.17.99.1 sur le routeur, définissez la passerelle par défaut pour le commutateur.
S1(config)#ip default-gateway 172.17.99.1
S1(config)#exit

Étape 6 : vérification des paramètres des réseaux locaux de gestion


Vérifiez les paramètres d’interface sur le réseau local virtuel VLAN 99.
S1#show interface vlan 99
Vlan99 is up, line protocol is up
Hardware is EtherSVI, address is 001b.5302.4ec1 (bia 001b.5302.4ec1)
Internet address is 172.17.99.11/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:06, output 00:03:23, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4 packets input, 1368 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
1 packets output, 64 bytes, 0 underruns
0 output errors, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Quelle est la bande passante définie sur cette interface ? ______________________
Quelles sont les spécifications du réseau local virtuel ? Le VLAN99 est __________ Le protocole de
ligne est __________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 7 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Quelle est la stratégie de file d’attente en vigueur ? ____________________

Étape 7 : configuration de l’adresse IP et de la passerelle par défaut pour PC1


Définissez l’adresse IP de PC1 sur 172.17.99.21, avec 255.255.255.0 pour masque de sous-réseau.
Configurez une passerelle par défaut de 172.17.99.11. (Si nécessaire, reportez-vous aux Travaux
pratiques 1.3.1 pour configurer la carte réseau.)

Étape 8 : vérification de la connectivité


Pour vérifier que l’hôte et le commutateur sont correctement configurés, envoyez une requête ping à
l’adresse IP du commutateur (172.17.99.11) depuis PC1.
La requête ping a-t-elle abouti ? ________________________
Si la réponse est Non, dépannez la configuration de l’hôte et du commutateur. Notez que plusieurs
tentatives peuvent être nécessaires pour que les requêtes ping aboutissent.

Étape 9 : configuration des paramètres de vitesse de port et de mode bidirectionnel pour une
interface FastEthernet
Configurez les paramètres de vitesse et du mode bidirectionnel sur FastEthernet 0/18. Utilisez la
commande end pour retourner au mode d’exécution privilégié une fois que vous avez terminé.

S1#configure terminal
S1(config)#interface fastethernet 0/18
S1(config-if)#speed 100
S1(config-if)#duplex full
S1(config-if)#end
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/18, changed
state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to down
%LINK-3-UPDOWN: Interface FastEthernet0/18, changed state to down
%LINK-3-UPDOWN: Interface FastEthernet0/18, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/18, changed
state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up
Le protocole de ligne pour les interfaces FastEthernet 0/18 et VLAN 99 sera temporairement désactivé.
La détection automatique est définie par défaut sur l’interface Ethernet du commutateur. Ainsi, les
paramètres optimaux sont négociés automatiquement. Vous ne devez configurer manuellement le mode
bidirectionnel et la vitesse que si un port doit fonctionner à une vitesse et un mode bidirectionnel définis.
Une configuration manuelle des ports risque de se solder pas des non-concordances du mode
bidirectionnel, qui à leur tour réduisent sensiblement les performances.
Vérifiez les nouveaux paramètres de vitesse et de mode bidirectionnel sur l’interface FastEthernet.

S1#show interface fastethernet 0/18


FastEthernet0/18 is up, line protocol is up (connected)
Hardware is FastEthernet, address is 001b.5302.4e92 (bia 001b.5302.4e92)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is 10/100BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:01, output hang never
Last clearing of "show interface" counters never

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 8 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0


Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
265 packets input, 52078 bytes, 0 no buffer
Received 265 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 32 multicast, 0 pause input
0 input packets with dribble condition detected
4109 packets output, 342112 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

Étape 10 : enregistrement de la configuration


Vous avez terminé la configuration de base du commutateur. Sauvegardez le fichier de configuration en
cours sur la mémoire vive non volatile (NVRAM) pour vous assurer que les modifications ne soient pas
perdues en cas de redémarrage du système ou d’une coupure de courant.

S1#copy running-config startup-config


Destination filename [startup-config]?[Entrée] Building configuration...
[OK]
S1#

Étape 11 : examen du fichier de configuration initiale


Pour voir la configuration qui est stockée en mémoire vive non volatile, exécutez la commande show
startup-config en mode d’exécution privilégié.

S1#show startup-config

Toutes les modifications qui ont été entrées sont-elles enregistrées dans le fichier ? ______________

Tâche 4 : gestion de la table d’adresses MAC

Étape 1 : enregistrement des adresses MAC des hôtes


Déterminez et enregistrez les adresses (physiques) de couche 2 des cartes réseau PC à l’aide des
commandes suivantes :

Démarrer > Exécuter > cmd > ipconfig /all


PC1 : ___________________________________________________________________
PC2 : ___________________________________________________________________

Étape 2 : détermination des adresses MAC que le commutateur a acquises


Affichez les adresses MAC à l’aide de la commande show mac-address-table en mode d’exécution
privilégié.

S1#show mac-address-table

Combien y a-t-il d’adresses dynamiques ? _______________________________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 9 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Combien y a-t-il d’adresses MAC au total ? ______________________________


L’adresse MAC dynamique correspond-elle à l’adresse MAC de PC1 ? _____________________

Étape 3 : énumération des options show mac-address-table

S1#show mac-address-table ?

Combien d’options sont disponibles pour la commande show mac-address-table ? ____________


Affichez uniquement les adresses MAC de la table qui ont été acquises de façon dynamique.

S1#show mac-address-table address dynamic

Combien y a-t-il d’adresses dynamiques ? _________________


Affichez l’entrée d’adresse MAC pour PC1.

S1#show mac-address-table address <adresse MAC pour PC1 ici>

Étape 4 : effacement de la table d’adresses MAC


Pour supprimer les adresses MAC existantes, utilisez la commande clear mac-address-table du mode
d’exécution privilégié.

S1#clear mac-address-table dynamic

Étape 5 : vérification des résultats


Assurez-vous que la table d’adresses MAC a été effacée.

S1#show mac-address-table

Combien y a-t-il d’adresses MAC statiques ? ___________________________________


Combien y a-t-il d’adresses dynamiques ? _____________________________________

Étape 6 : nouvel examen de la table MAC


Il est fort probable qu’une application exécutée sur votre PC1 a déjà envoyé une trame de la carte réseau
(NIC) à S1. Consultez une nouvelle fois la table d’adresses MAC en mode d’exécution privilégié pour voir
si S1 a de nouveau acquis l’adresse MAC pour PC1.

S1#show mac-address-table

Combien y a-t-il d’adresses dynamiques ? ________________________________


Pourquoi est-ce différent du dernier affichage ? _____________________________________________
___________________________________________________________________________________
Si, pour l’instant, S1 n’a pas de nouveau acquis l’adresse MAC pour PC1, envoyez une requête ping à
l’adresse IP du VLAN 99 du commutateur depuis PC1 et répétez l’étape 6.

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 10 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 7 : configuration d’une adresse MAC statique


Pour spécifier à quels ports un hôte peut se connecter, créez un mappage statique de l’adresse MAC
hôte à un port.
Configurez une adresse MAC statique sur l’interface FastEthernet 0/18 en utilisant l’adresse enregistrée
pour PC1 à l’étape 1 de cette tâche. L’adresse MAC 00e0.2917.1884 est utilisée à titre d’exemple
uniquement. Vous devez utiliser l’adresse MAC de votre PC1, qui est différente de celle utilisée ici en
exemple.

S1(config)#mac-address-table static 00e0.2917.1884 vlan 99 interface


fastethernet 0/18

Étape 8 : vérification des résultats


Vérifiez les entrées de la table d’adresses MAC.

S1#show mac-address-table

Combien y a-t-il d’adresses MAC au total ? _______________________________________


Combien y a-t-il d’adresses statiques ? __________________________________________

Étape 9 : suppression de l’entrée MAC statique


Pour effectuer la tâche suivante, il est nécessaire de supprimer l’entrée de la table d’adresses MAC
statiques. Passez en mode de configuration et supprimez la commande en insérant no au début de la
chaîne de commandes.
Remarque : l’adresse MAC 00e0.2917.1884 est utilisée uniquement dans l’exemple. Utilisez l’adresse
MAC pour votre PC1.
S1(config)#no mac-address-table static 00e0.2917.1884 vlan 99 interface
fastethernet 0/18

Étape 10 : vérification des résultats


Vérifiez que l’adresse MAC statique a été supprimée.

S1#show mac-address-table

Combien y a-t-il d’adresses MAC statiques au total ? _______________________________

Tâche 5 : configuration de la sécurité des ports

Étape 1 : configuration d’un deuxième hôte


Vous avez besoin d’un deuxième hôte pour cette tâche. Définissez 172.17.99.32 comme adresse IP de
PC2, avec le masque de sous-réseau 255.255.255.0 et la passerelle par défaut 172.17.99.1. Ne
connectez pas encore ce PC au commutateur.

Étape 2 : vérification de la connectivité


Vérifiez que PC1 et le commutateur sont encore configurés correctement en envoyant une requête ping à
l’adresse IP de VLAN 99 du commutateur depuis l’hôte.
La requête ping a-t-elle abouti ? _____________________________________
Si la réponse est Non, rectifiez la configuration de l’hôte et du commutateur.

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 11 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 3 : copie des adresses MAC de l’hôte


Notez les adresses MAC de l’étape 1 de la tâche 4.
PC1____________________________________________________________________
PC2____________________________________________________________________

Étape 4 : détermination des adresses MAC que le commutateur a acquises


Affichez les adresses MAC apprises à l’aide de la commande show mac-address-table en mode
d’exécution privilégié.

S1#show mac-address-table

Combien y a-t-il d’adresses dynamiques ? __________________________________________


L’entrée d’adresse MAC correspond-elle à l’adresse MAC de PC1 ? ______________________

Étape 5 : énumération des options de sécurité des ports


Explorez les options permettant de définir la sécurité des ports sur l’interface FastEthernet 0/18.
S1# configure terminal
S1(config)#interface fastethernet 0/18
S1(config-if)#switchport port-security ?
aging Port-security aging commands
mac-address Secure mac address
maximum Max secure addresses
violation Security violation mode
<cr>

S1(config-if)#switchport port-security

Étape 6 : configuration de la sécurité d’un port d’accès


Configurez le port du commutateur FastEthernet 0/18 de sorte qu’il accepte deux périphériques
uniquement, acquière les adresses MAC de ces périphériques de façon dynamique et bloque le trafic
issu d’hôtes non valides en cas de violation.
S1(config-if)#switchport mode access
S1(config-if)#switchport port-security
S1(config-if)#switchport port-security maximum 2
S1(config-if)#switchport port-security mac-address sticky
S1(config-if)#switchport port-security violation protect
S1(config-if)#end

Étape 7 : vérification des résultats


Affichez les paramètres de sécurité des ports.

S1#show port-security

Combien d’adresses sécurisées sont autorisées sur FastEthernet 0/18 ?__________________


Quelle est la mesure de sécurité appliquée à ce port ? ________________________________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 12 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 8 : examen du fichier de configuration en cours

S1#show running-config

Y a-t-il dans la liste de la configuration en cours des instructions qui reflètent directement la mise en
œuvre de la sécurité ?____________________________________________________ _____

Étape 9 : modification des paramètres de sécurité d’un port


Sur l’interface FastEthernet 0/18, faites passer le nombre d’adresses MAC maximum pour la sécurité des
ports à 1 et paramétrez la désactivation en cas de violation.

S1(config-if)#switchport port-security maximum 1


S1(config-if)#switchport port-security violation shutdown

Étape 10 : vérification des résultats


Affichez les paramètres de sécurité des ports.

S1#show port-security

Les paramètres de sécurité du port ont-il changé pour refléter les modifications de l’étape 9 ? ________
Lancez une requête ping sur les adresses VLAN 99 du commutateur depuis PC1 pour vérifier la
connectivité et actualiser la table d’adresses MAC. Désormais, l’adresse MAC pour PC1 doit respecter la
configuration en cours.
S1#show run
Building configuration...

<résultat omis>
!
interface FastEthernet0/18
switchport access vlan 99
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 00e0.2917.1884
speed 100
duplex full
!
<résultat omis>

Étape 11 : introduction d’un hôte non autorisé


Déconnectez PC1 et connectez PC2 au port FastEthernet 0/18. Envoyez une requête ping à l’adresse du
VLAN 99 172.17.99.11 depuis le nouvel hôte. Attendez que le voyant de liaison orange devienne vert.
Une fois vert, il est presque immédiatement désactivé.
Consignez toute observation utile : _____________________________________________________
_________________________________________________________________________________

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 13 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 12 : affichage des informations sur la configuration des ports


Pour afficher les informations de configuration pour le seul port FastEthernet 0/18, entrez la commande
suivante en mode d’exécution privilégié :

S1#show interface fastethernet 0/18

Quel est l’état de cette interface ?


FastEthernet 0/18 est ______________ Le protocole de ligne est _______________

Étape 13 : réactivation du port


Si une violation de sécurité a lieu et que le port est désactivé, vous pouvez utiliser la commande no
shutdown pour le réactiver. Toutefois, tant que l’hôte non autorisé est relié à FastEthernet 0/18, tout
trafic issu de l’hôte désactive le port. Reconnectez PC1 à FastEthernet 0/18, et entrez les commandes
suivantes sur le commutateur :

S1# configure terminal


S1(config)#interface fastethernet 0/18
S1(config-if)#no shutdown
S1(config-if)#exit

Remarque : certaines versions du logiciel IOS peuvent nécessiter une commande shutdown manuelle
avant la saisie de la commande no shutdown.

Étape 14 : nettoyage
Sauf indication contraire, effacez la configuration sur les commutateurs, mettez l’ordinateur hôte et les
commutateurs hors tension, puis retirez et stockez les câbles.

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 14 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Annexe 1

Effacement et rechargement du commutateur


Dans la plupart des travaux pratiques d’Exploration 3, il est nécessaire de commencer avec un
commutateur non configuré. L’utilisation d’un commutateur déjà configuré peut produire des résultats
imprévisibles. Ces instructions indiquent comment préparer le commutateur avant de commencer les
travaux pratiques. Elles concernent le commutateur 2960 ; toutefois, la procédure est identique pour les
commutateurs 2900 et 2950.

Étape 1 : accès au mode d’exécution privilégié en tapant la commande enable


Si le système vous demande un mot de passe, entrez class. Si cela ne fonctionne pas, demandez de
l’aide au formateur.
Switch>enable

Étape 2 : suppression du fichier d’informations de la base de données VLAN


Switch#delete flash:vlan.dat
Delete filename [vlan.dat]?[Entrée]
Delete flash:vlan.dat? [confirm] [Entrée]
S’il n’y a pas de fichier VLAN, le message suivant s’affiche :

%Error deleting flash:vlan.dat (No such file or directory)

Étape 3 : suppression du fichier de configuration initiale du commutateur de la mémoire vive non


volatile (NVRAM)
Switch#erase startup-config
Vous obtenez le message suivant :
Erasing the nvram filesystem will remove all files! Continue? [confirm]
Press Enter to confirm.
La réponse suivante doit s’afficher :
Erase of nvram: complete

Étape 4 : vérification de la suppression des informations du VLAN


Vérifiez que la configuration VLAN a été supprimée à l’étape 2 à l’aide de la commande show vlan.
Si les informations relatives au VLAN ont été supprimées à l’étape 2, passez à l’étape 5 et redémarrez le
commutateur à l’aide de la commande reload.
Si les informations de la configuration VLAN précédente (autres que celles du VLAN 1 de gestion par
défaut) sont toujours présentes, vous devez mettre le commutateur hors tension puis sous tension
(redémarrage matériel) plutôt que d’entrer la commande reload. Pour le redémarrage matériel du
commutateur, ôtez le cordon d’alimentation de l’arrière du commutateur ou débranchez-le, puis
rebranchez-le.

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 15 sur 16
CCNA Exploration
Commutation de réseau local et réseau local sans fil :
Concepts et configuration de base d’un commutateur Travaux pratiques 2.5.1 : Configuration de base d’un commutateur

Étape 5 : redémarrage du logiciel


Remarque : cette étape n’est pas nécessaire si le commutateur a été redémarré à l’aide du démarrage
matériel.
À l’invite du mode d’exécution privilégié, entrez la commande reload.
Switch(config)#reload
Vous obtenez le message suivant :
System configuration has been modified. Save? [yes/no]:
Tapez n, puis appuyez sur Entrée.
Vous obtenez le message suivant :
Proceed with reload? [confirm] [Entrée]
La première ligne de la réponse est la suivante :
Reload requested by console.
Après le rechargement du commutateur, la ligne suivante s’affiche :
Would you like to enter the initial configuration dialog? [yes/no]:
Tapez n, puis appuyez sur Entrée.
Vous obtenez le message suivant :
Press RETURN to get started! [Entrée]

All contents are Copyright © 1992-2009 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 16 sur 16