Vous êtes sur la page 1sur 1

U NIVERSIT É DE G HARDA ÏA M ÉTHODES NUM ÉRIQUES

FACULT É DES S CIENCES ET T ECHNOLOGIE 2eme G ÉNIE E LEC .


D ÉPARTEMENT DES S CIENCES ET T ECHNIQUES 2014-2015

TP – 07 Intégration Numérique

But du TP S ← S + h f ( a + ih)
Implémentation d’un code Matlab pour fin pour
évaluer une intégrale par la méthode des trapèzes afficher S
et Simpson 1/3.

1. Préambule 3. Méthode de Simpson 1/3


Soit à calculer l’intégrale suivante : On reprend le problème précédent avec la
méthode de Simpson 1/3 qui donne l’approxima-
2 e x sin x tion de l’intégrale suivant la formule :
Z
I= dx
−1 x2 + 1

h
e x sin x I' ( y0 + y n )
a. Dessiner le graphe de la fonction f ( x ) = 3
x 2 +1
sur l’intervalle [−3, 4].
+ 4 ( y 1 + y 3 + y 5 + · · · + y n −1 )
b. Calculer la valeur de I avec la fonction trapz de 
Matlab. + 2 ( y 2 + y 4 + y 6 + · · · + y n −2 )

2. Méthode des Trapèzes


Cette formule peut être implémenter suivant l’algo-
Par la méthode des trapèzes, l’intervalle entre rithme suivant :
les bornes d’intégration est subdivisé en un cer-
tain nombre n de sous-intervalles de longueur h.
L’intégrale est alors donnée approximativement Lire a , b , n
par : h ← (b − a)/n
S ← f ( a) + f (b)
n −1 pour i = 1 → n − 1 faire
h
I'
2
( y0 + y n ) + ∑ hyi si i impair alors
S ← S + 4 f ( a + ih)
i =1
sinon
Pour implementer cette méthode sous Matlab, S ← S + 2 f ( a + ih)
on va suivre les étapes suivantes : fin si
a. Ecrire une fonction qui renvoie la valeur de la fin pour
fonction f ( x ). h
afficher S ← S
b. Dans le script principal, entrer les limites 3
d’intégration a et b ensuite le nombre d’inter-
a. Modifier l’algorithme des trapèzes pour pou-
valles à utiliser n.
voir suivre la convergence en gardant les va-
c. Définir une variable S qui doit recevoir la valeur leurs calculées de l’intégrale pour chaque va-
de l’intégrale. leur de h et en divisant la valeur de h à chaque
d. Le reste du script doit suivre l’algorithme sui- itération par deux.
vant : b. Faire un graphe de la valeur de l’intégrale en
fonction des itérations.
Lire a , b , n
c. Reproduire les mêmes modifications sur l’algo-
h ← (b − a)/n
rithme de la méthode de Simpson 1/3.
h
S ← ( f ( a) + f (b)) d. Comparer la convergence des deux méthodes.
2
pour i = 1 → n − 1 faire Conclure.

Page 1/1 H. Bouderba