Vous êtes sur la page 1sur 1

AGRAL - ELI - GG - MTX

Informatique Gnrale e e

Informatique Gnrale - EXO EN PLUS 1 - Algorithmes e e


2005 - 2006

1
1.1

Algo ` crire ae
exercice 1.1

Ecrire un algorithme qui calcule la moyenne de 5 nombres.

1.2

exercice 1.2

Ecrire un algorithme qui dtermine si la somme de nombres est positive ou ngative. e e

1.3

exercice 1.3

Ecrire un algorithme prend un numro de mois et dtermine la saison correspondant. e e

1.4

exercice 1.4

Ecrire un algorithme prend la moyenne du bac obtenu par un lycen et retourne si il est reu ou non ou si il doit e c passer le rattrapage.

Algo myst`re e
Algo MYSTERE Donnes entre e e Donnes sortie e Si c > a a <c <a <FinSi Si c > b c b FinSi Si b > a b a FinSi FIN

Que fait cet algorithme ? : a,b,c : nombre entier : alors a+c a-c a-c

b alors <- b+c <- b-c <- b-c

a alors <- a+b <- a-b <- a-b

IST - UPMC