Vous êtes sur la page 1sur 10

Campus des Rseaux Informatiques et Tlcommunications

(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Configuration de base des routeurs CISCO

Prsentation
Il existe plusieurs mthodes pour effectuer la configuration basic dun routeur CISCO. Deux mthodes
sont prsentes ci-dessous :

- Lutilisation du mode setup


- La configuration manuelle CLI

Mais il est galement possible de configurer un routeur laide dun fichier contenu sur un serveur
TFTP o laide de loutil ConfigMaker (outil Cisco gratuit), par linterface WEB.

La configuration des routeurs est toujours stocke sur (NVRAM) dans un fichier appel startup-config
qui est utilis au dmarrage du routeur. Il est alors charg en RAM o il devient le fichier running-
config.

Chaque commande saisie en mode console modifie directement la configuration stocke en RAM. En
cas derreur, il est encore possible de revenir en arrire pour restaurer une configuration valide (en
utilisant la commande (copy startup-config running-config), toutes les modifications sont alors
perdues. A linverse, il est galement possible de sauvegarder les modifications (commande running-
config startup-config ou write memory).

Les fichiers de configuration sont exportables et importables sur le mme routeur ou sur un autre
routeur grce au protocole TFTP. Les fichiers exports sont modifiables laide dun diteur de texte.

Connexion PC-Routeur
La connexion PC-Routeur se fait avec le cble console bleu entre le port console du routeur et un port
srie du PC.

Pour accdes la configuration dun routeur via un cble console, on peut utiliser certains logiciels
gratuit disponible sur internet comme : Tera Term or Putty

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Configuration manuelle du routeur en ligne de commande CLI


Configuration du nom du routeur

Commandes Explications
Router> Mode EXEC utilisateur
Router>enable Passer au mode EXEC privilgi
Router#conf t (configure terminal) Passer au monde configuration globale
Router(config)# hostname groupe Donner le nom groupe pour notre routeur
Router(config)# banner motd # /Message/# Configurer une bannire daccueil

Configuration des mots de passe

Commandes Explications
Router(config)# enable secret @dm1n Dfinir le mot de passe enable secret pour le
mode privilgi @dm1n

Router(config)# line console 0


Router(config-line)#password @dm2n Configurer un mot de passe pour la console
Router(config-line)#login @dm2n
Router(config-line)#exit

Router(config)# line vty 0 15


Router(config-line)#password @dm3n Configurer un mot de passe telnet
Router(config-line)#login @dm3n
Router(config-line)#exit

Router(config)# service password-encryption Crypter les mots de passe

Configuration des mots de passe

Commandes Explications
Router(config)#interface fast0/0 Accs linterface fastEthernet 0/0 (exemple)
Router(config-if)#ip address ip_address mask Donner @IP et le Mask de linterface fa0/0
Router(config-if)#no shutdown Activation de linterface
Router(config-if)#exit Sortir mode configuration de linterface

Router(config)#interface Serial0/0/0 Accs linterface Serial 0/0/0 (exemple)


Router(config-if)#ip address ip_address mask Donner @IP et le Mask de linterface S0/0/0
Router(config-if)#no shutdown Activation de linterface
Router(config-if)#clockrate 64000 Dfinir lhorloge par exemple
Router(config-if)#exit Sortir mode configuration de linterface

Remarque : Suivant la rfrence, le routeur peut avoir des interfaces diffrentes.

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Configuration des protocoles de routage


Configuration routage statique

Commandes Explications
Router(config)# ip route 0.0.0.0 0.0.0.0 0.0.0.0 Configuration dune route par dfaut
Router(config)# ip route X.X.X.X Y.Y.Y.Y Cette commande reprsente comment configurer
ethernet 1/0 une route statique
X.X.X.X : le rseau atteindre
Y.Y.Y.Y : Masque sous-rseau
Ethernet1/0 : interface pour joindre le rseau
On peut aussi utiliser l'adresse IP du prochain
routeur.

Configuration routage dynamique

Commandes Explications
Router(config)#router rip Activer le RIP
Router(config-router)# version {1,2} Dfinir la version
Router(config)#network X.X.X.X Dclaration des rseaux connects aux
interfaces du routeur
Router(config-router)# default-information propagation de la route par dfaut
originate

Configuration OSPF

Commandes Explications
Router(config)# router ospf ID Activer OSPF avec un numro ID
Router(config-router)# network @ de rseau Dfinir le rseau voisin avec le masque
masque gnrique area 0 gnrique Area 0 fait rfrence la zone
OSPF
Router(config-router)# default-information propagation de la route par dfaut
originate

Configuration EIGRP

Commandes Explications
Router(config)# router eigrp ID Activer EIGRP avec un numro ID
Router(config-router)# network @ de rseau Dfinir le rseau voisin avec le masque
masque gnrique gnrique

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Configuration DHCP

Commandes Explications
Router(config)# service dhcp Dmarrer le service DHCP
Router(config)#ip dhcp pool nom_pool Commencer la configuration DHCP et
donner un nom pour le pool DHCP
Router(dhcp-config)# network adrIP masque Dfinir @ Rseau et le maque
Router(dhcp-config)#default-router Y.Y.Y.Y Dfinir la route par dfaut
Router(dhcp-config)# ip dhcp excluded-address Dfinir la plage non alloue

Les commandes de sauvegarde

Commandes Explications
Router# copy running-config startup-config Sauvegarde la configuration courante en
NVRAM
Router# copy run tftp://adrIPserveur:/_fichier Sauvegarde sur un serveur TFTP
Router# copy star tftp Sauvegarde NVRAM vers un serveur TFTP
Router# copy tftp startup-config ou copy tftp Charge un fichier de configuration d'un
star serveur TFTP en NVRAM
Router# copy tftp running-config ou Charge un fichier de configuration d'un
copy tftp run serveur TFTP dans la configuration
courante
Router# erase startup-config ou erase star Efface la configuration de la NVRAM

Les Commandes SHOW

Commandes Explications
Router# show running-config Afficher la configuration en cours
Router# show startup-config Afficher la configuration enregistre dans
NVRAM
Router# show interfaces Afficher les interfaces avec leurs
Router# show history informations en brief :
Afficher toutes les commandes tapes
Router# show ip route Afficher la table de routage
Router# show ip dhcp binding Afficher la configuration DHCP
Router# show ip rip database Afficher les informations de protocole de
routage RIP
Router# show ip ospf database Afficher les informations de protocole de
routage OSPF
Router# show ip eigrp database Afficher les informations de protocole de
routage EIGRP
Router# show ? Afficher des autres informations sur les
commandes SHOW

Pour afficher les informations sur nimporte quelle commande :


Routeur# commande ?

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Configuration de base des commutateurs


CISCO

Ce fichier prsente les principales commandes et configurations possible sur un commutateur


Cisco. Il vous faudra videmment adapter les commandes votre configuration.

Les Commandes de base


Switch>enable
// Passez du mode dexcution utilisateur au mode dexcution privilgi.

Password:password
// Si vous avez dfini un mot de passe en mode dexcution privilgi, le systme vous
demande de le saisir.

Switch#disable
// Passez du mode dexcution privilgi au mode dexcution utilisateur.

Switch#configure terminal
// Passez du mode dexcution privilgi au mode de configuration globale.

Switch(config)#banner login Personnel autoris uniquement


// Configurer une bannire de connexion.

Switch(config)#banner motd Personnel autoris uniquement


// Configurer une bannire de connexion.

Switch(config)#interface id_interface
// Passez du mode de configuration globale au mode de configuration dinterface pour
linterface Fast Ethernet 0/1.

Switch(config-if)#exit
// Passez du mode de configuration dinterface en mode de configuration globale.

Historique des commandes


Switch#show history
// Pour afficher les commandes dexcution qui ont t rcemment entres.
Switch#terminal history
// Configure la taille de lhistorique du terminal.Lhistorique du terminal peut conserver
entre 0 et 256 lignes de commande.

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Switch#terminal history size 50


// Configure la taille de lhistorique du terminal.Lhistorique du terminal peut conserver
entre 0 et 256 lignes de commande.

Switch#terminal no history size


// Rtablit la taille de lhistorique du terminal daprs sa valeur par dfaut, soit 10
lignes de commande

Switch#terminal no history
// Dsactive lhistorique du terminal.

Configuration de la connectivit IP dun switch


Switch(config)#interface vlan X
// Passer en mode de configuration dinterface pour linterface du VLAN X.

Switch(config-if)#ip address @ IP et masque SR


// Configurer ladresse IP de linterface et le masque SR.

Switch(config-if)#no shutdown
// Activer linterface.

Switch(config-if)#end
// Repasser en mode dexcution privilgi.

Configuration du mode bidirectionnel


Switch(config)#Interface id_inteface
// Passer en mode de configuration dinterface.

Switch(config-if)#duplex auto
// Configurer le mode bidirectionnel dinterface pour activer la configuration
bidirectionnelle automatique.

Switch(config-if)#speed auto
// Configurer la vitesse bidirectionnelle dinterface et activer la configuration de
vitesse automatique.

Switch(config-if)#end
// Revenir au mode dexcution privilgi.

Configuration dune interface web

Switch(config)#ip http authentication enable


// Configurer linterface du serveur HTTP pour le type dauthentification enable.

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Switch(config)#ip http server


// Activer le serveur HTTP.

Switch(config)#end
// Revenir au mode dexcution privilgi.

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

CONFIGURATION DE LA SECURITE
La configuration des mots de passe (Console, VTY, )
Switch#configure terminal
// Passer du mode dexcution privilgi au mode de configuration globale.

Switch(config)#line con 0
// Passer du mode de configuration globale au mode de configuration de ligne pour la console
0.

Switch(config-line)#password cisco
// Dfinir cisco en tant que mot de passe pour la ligne de console 0 sur le
commutateur.

Switch(config-line)#login
// Dfinir la ligne de console pour exiger la saisie du mot de passe avant loctroi de
laccs.

Switch(config-line)#end
// Quitter le mode de configuration de ligne et revenir en mode dexcution privilgi.

Switch(config)#line vty 0 4 ( les mmes commandes pour configurer VTY)

Switch(config)#enable secret mot_de_passe


// Configurer le mot de passe enable secret pour le passage en mode dexcution
privilgi.

Switch(config)#service password-encryption
// Chiffrer les mots de passe

Switch(config)#end
// Quitter le mode de configuration de ligne et revenir en mode dexcution privilgi.

Configuration de la scurit des ports


Switch(config)#interface fastEthernet 0/1
// Prcisez le type et le numro de linterface physique configurer (par exemple,
fastEthernet F0/1)

Switch(config-if)#switchport mode access


//Dfinissez le mode dinterface en accs. Vous ne pouvez pas configurer une
interface en tant que port scuris selon le mode dynamique par dfaut appropri.

Switch(config-if)#switchport port-security
// Activez la scurit des ports sur linterface.

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

CONFIGURATION DES VLANS


Crer des VLANs
Switch#configure terminal
// Passer en mode de configuration globale sur le commutateur Switch.

Switch(config)#vlan id_vlan
// Crer un VLAN. id_vlan est le numro de VLAN crer. Passe en mode de
configuration de VLAN pour lID de VLAN du VLAN.

Switch(config-vlan)#name nom_vlan
// Spcifier un nom de VLAN unique pour identifier le VLAN.

Affectation dun port de commutateur

Switch#configure terminal
// Passer en mode de configuration globale sur le commutateur Switch.

Switch(config)#interface id_interface
// Passer en mode de configuration dinterface.

Switch(config-if)#switchport mode trunk / switchport mode access


// Dfinir le mode daccs

Switch(config-if)#switchport trunk native vlan X / switchport access vlan X


// Affectation sera selon le mode choisi avant ( trunk, access).

Configuration dune agrgation 802.1Q

Switch#configure terminal
// Passer en mode de configuration globale.

Switch(config)#interface id_interface
// Passer en mode de configuration dinterface pour configurer linterface.

Switch(config-if)#switchport mode trunk


// Forcer la liaison reliant les commutateurs devenir une liaison agrge.

Switch(config-if)#switchport trunk native vlan id_vlan


// Spcifier un autre VLAN en tant que VLAN natif pour le trafic non tiquet pour les
agrgations IEEE 802.1Q.

Switch(config-if)#end
// Repasser en mode dexcution privilgi.
// Pour vrifier la configuration dune agrgation : show interfaces id_interface switchport.

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)


Campus des Rseaux Informatiques et Tlcommunications
(https://www.facebook.com/groups/RESEAUX2INFORMATIQUES2TELECOM/)

Activer le mode VTP

Switch(config)# vtp domain nom_domain


// Activer le mode VTP
Switch(config)# vtp mode server
// Dfinir le mode VTP comme serveur
Switch(config)# vtp mode client
// Dfinir le mode VTP comme client

Le protocole STP
Switch(config)# spanning-tree vlan 1 root primary
//Fixer un Switch comme un pont racine

Switch(config)# spanning-tree vlan 1 root secondary


// Fixer un Switch comme un pont secondaire

Switch(config)#interface FastEthernet 0/1


Switch(config-if)#spanning-tree vlan 1 cost X
// Configurer le cost STP dune interface

Switch(config)# interface fastEthernet id_interface


Switch(config-if)# spanning-tree vlan 1 port-priority X
Switch(config-if)# exit
//Changer la priorit dun port

Auteur : El Hassan EL AMRI (Campus des Rseaux Informatiques et Tlcommunications)