Vous êtes sur la page 1sur 4

10/10/2021

Exercices

🠶 Exercice 1 : Écrire l’algorithme qui calcule le carré d’un entier saisi au clavier.

🠶 Exercice 2 : Écrire l’algorithme qui saisie un prix unitaire, une quantité et qui calcule le prix total.
🠶 Exercice 3 : Écrire l’algorithme qui lit deux nombres et les imprime dans l’ordre croissant de leurs valeurs.
🠶 Exercice 4 : Soient trois nombres x, y et z. Écrire un algorithme qui détermine et
imprime le plus grand des trois.

UM 5-ESTS-GUE-LPGC 25

Exercice 1 :
Algorithme : Carré
Variables :
x : réel ;
Début
Ecrire (“Saisir la valeur de x : ”) ;
Lire (x) ;
x ← x*x ;
Ecrire (“Le carré de”, x/x “est : ”, x) ;
Fin
Exercice 2 :
Algorithme : Prix total
Variables :
p, q, t : réels ;
Début
Ecrire (“Saisir le prix unitaire et la quantité : ”) ;
Lire (p, q) ;
t ← p*q ;
Ecrire (“Le prix total est : ”, t) ;
Fin
Exercice 3 :
Algorithme : Ordre croissant
Variables :
a, b : réels ;
Début

1
10/10/2021
Ecrire (“Saisir les valeurs de a et b : ”) ;
Lire (a, b) ;
Si (a > b)
Alors Ecrire (“Ordre croissant de a et b est : ”, a, “>”, b) ;
Sinon Ecrire (“Ordre croissant de a et b est : ”, b, “>”, a) ;
FSI

Fin
Exercice 4 :
Algorithme : Maximum
Variables :
x, y, z, m : réels ;
Début
Ecrire (“Saisir les valeurs de x, y et z : ”) ;
Lire (x, y, z) ;
Si (x > y)
Alors m ← x ;
Sinon si (y > z)
Alors m ← y ;
Sinon m ← z ;
FSI
FSI
Ecrire (“Le maximum des valeurs de x, y et z est : ”, m) ;
Fin

Exercices

🠶 A partir d’un nombre lu en données, on détermine un montant net par application d’une remise de :
🠶 1.5 % si le montant est compris entre 2000 et 5000 MAD

🠶 2.5 % si le montant est compris entre 5001 et 10000 MAD

🠶 3 % si le montant excède 10000 MAD


🠶 Écrire l’algorithme qui lit en entrée le montant et fournit en sortie la remise net.

UM 5-ESTS-GUE-LPGC 26

Exercice 5 :

2
10/10/2021
Algorithme : montant
Variable mnt : Réel
Début
Ecrire (“Saisir le montant : ”) ;
Lire (mnt) ;
Si(mnt>10000) Alors
mnt  mnt
Sinon
Si
Sinon
FinSi
FinSi
Fin

3
Exercices
🠶 Donner la trace de l’algorithme suivant : VariablesI, J : entier ;
Début
I1;
Ecrire("Itération ", I); Répéter
J1;
Tant que (J<4) Faire Début de tant que
Ecrire("Itération ", J); J  J+1 ;
Ecrire(I, J) ; Fin tant que
I  I+1 ;
Jusqu’à (I=5)
Fin

UM 5-ESTS-GUE-LPGC 27

27

Vous aimerez peut-être aussi