Vous êtes sur la page 1sur 4

Exercices sur les matrices :

Exercice 1:
Écrire un algorithme permettant de calculer la matrice A, avec A= a.B, B une matrice (N,M) et a un
réel.

Algo :

Début
Réel A(100,100) , B(100,100), a
Entier N, M, i, j

Lire N, M
Lire ((B(i,j), j=1, M), i=1, N)
Pour i variant de 1 à N avec un pas égal à 1 faire
Pour j variant de 1 à M avec un pas égal à 1 faire
A(i,j) ← a*B(i,j)
Fin pour
Fin pour
Écrire ((A(i,j), j=1, M), i=1, N)
Fin

Exercice 2:
Écrire un algorithme permettant de calculer la transposée d'une matrice carrée.

Algo :

Début
Réel A(100,100) , At(100,100)
Entier N, M, i, j

Lire N, M
Lire ((A(i,j), j=1, M), i=1, N)
Pour i variant de 1 à N avec un pas égal à 1 faire
Pour j variant de 1 à M avec un pas égal à 1 faire
At(j,i) ← A(i,j)
Fin pour
Fin pour
Écrire ((At(i,j), j=1, M), i=1, N)
Fin

Exercice 3:
Écrire un algorithme permettant de calculer la trace d'une matrice.

Algo :

Début
Réel A(100,100) , S
Entier N, M, i, j

Lire N, M
Lire ((A(i,j), j=1, M), i=1, N)
S←0
Pour i variant de 1 à N avec un pas égal à 1 faire
Pour j variant de 1 à M avec un pas égal à 1 faire
Si (i=j) alors
S ← S+ A(i,j)
Fin si
Fin pour
Fin pour
Écrire « La trace est égal à : », S
Fin

Exercice 4:
Écrire un algorithme permettant de remplir une matrice identité.

Algo :

Début
Réel A(100,100)
Entier N, M, i, j

Lire N, M

Pour i variant de 1 à N avec un pas égal à 1 faire


Pour j variant de 1 à M avec un pas égal à 1 faire
Si (i=j) alors
A(i,j) ← 1
Sinon
A(i,j) ← 0
Fin si
Fin pour
Fin pour
Écrire ((A(i,j), j=1, M), i=1, N)
Fin

Exercice 5:
Écrire un algorithme permettant de trouver le plus grand/le plus petit élément d'une matrice.

Algo :

Début
Réel A(100,100), MIN, MAX
Entier N, M, i, j

Lire N, M
MIN ← A(1,1)
MAX ← A(1,1)
Pour i variant de 1 à N avec un pas égal à 1 faire
Pour j variant de 1 à M avec un pas égal à 1 faire
Si (MIN> A(i,j) ) alors
MIN ← A(i,j)
Sinon Si (MAX < A(i,j) ) alors
MAX← A(i,j)
Fin si
Fin pour
Fin pour
Écrire « Le plus petit élément de la matrice est », MIN
Écrire « Le plus grand élément de la matrice est », MAX
Fin

Exercice 6:
Écrire un algorithme permettant de calculer le produit de deux matrices.

Algo :

Début
Réel A(100,100) , B(100,100), C(100,100), S
Entier N, M, P, i, j, k

Lire N, M, P
Lire ((A(i,j), j=1, P), i=1, N)
Lire ((B(i,j), j=1, M), i=1, P)
Pour i variant de 1 à N avec un pas égal à 1 faire
Pour j variant de 1 à M avec un pas égal à 1 faire
S←0
Pour k variant de 1 à P avec un pas égal à 1 faire
S ← S+ A(i,k) * B(k,j)
Fin pour
C(i,j) ← S
Fin pour
Fin pour
Écrire ((C(i,j), j=1, M), i=1, N)
Fin

Exercice 7:
Écrire un algorithme permettant de calculer le nombre d'occurrences d'un élément donné dans une
matrice.

Algo :

Début
Réel A(100,100)
Entier N, M, i, j, nb, x

Lire N, M, x
Lire ((A(i,j), j=1, M), i=1, N)
nb ← 0
Pour i variant de 1 à N avec un pas égal à 1 faire
Pour j variant de 1 à M avec un pas égal à 1 faire
Si (A(i,j) = x) alors
nb ← nb+1
Fin si

Fin pour

Fin pour
Écrire « Le nombre d'occurrences de x est : », nb