Vous êtes sur la page 1sur 7

bech tajouti port lel routeur , tod5ollou w tsakkrou w ta5tar wic-1t w tzid les ports

bech tsajjel l config


(conf)#write memory do wr

bech tchouf l fichier de config ​:


show running-config

mode # : mode privilégié


mode (conf) : mode configuration

bech tod5el :
enable // bech tod5el lel mode #
conf t // bech ‘tod5el lel mode (conf)

bech ta3mel mdp lel console :


(conf)#line console 0
(conf)#password val_pwd

(conf)#login

bech ta3mel mdp lel mode user


(conf)#enable password val_pwd
walla
(conf)#enable secret val_pwd

/bech t7ott banniere todh'herlek doub ma t7el l console


(conf)#banner motd $bonjour accés interdit$

bech tcrypti les mdp


(conf)#service password-encryption

bech tsammi e routeur :


(conf)# hostname nom

cable console (bel azra9 l feta7) bech tgeri bih e routeur


men jihet el routeur t7ot console , w fel pc rs32

la meme nature des ports des 2 composants (e niveau mel 1 lel 7): cable mestwi
natures differents : cable met9atta3
dima tnejem t7ot cable automatique , ken entre 2 routeurs lezem t7ot cable serial
cable serial :
- DCE (contole) : master : impose le rythme d'horloge // elli fih l monguela
- DTE (transmission) : slave : suit le rythme d'horloge

bech tconfiguri une interface fastethernet (fel routeur)


(conf)# interface nom_interface (el moujoud 3al interface)
# ip address @ip masque
# no shutdown
# exit

exp :
interface fa0/1
ip addresse 192.168.10.193 255.255.255.240
exit

exp : (les abréviations ye5dmou)


# int f0/0
# ip add 192.168.1.1 255.255.255.0 (l'@ip t7ot l'@ li 3tahelek +1)
# no shut

bech ta3mel el serial , ta3mel les memes etapes fel les deux routeurs w tzid (mel master elli fih l
monguela):
clock rate 64000

bech tchouf l config mte3ek mrigla walla lé


R# show ip interface brief

bech tchouf e routage mte3ek


r# show ip route

ping fi nafs e reseau possible , sinon lezmek tconfiguri :


R(conf)# ip route @destination_distant @mask_dest @ip_interface
R0(conf)# ip route 192.168.3.0 255.255.255.0 se0/1/0
R1(conf)# ip route 192.168.1.0 255.255.255.0 se0/1/0

sinon #ip route 0.0.0.0 0.0.0.0 (nom_interface/@ip_svnt)

el rip bech yab3eth des màj l les adresses li t7ot'hom , bech y3abbiw leurs tables de routage w
ya3ref les pcs lo5rin
bech nconfiguri l protocole rip
n7el el conf t
# router rip
# version 2
# network adresse_super_reseau

sinon , ta3mel show ip route


router rip
version 2
network adresse1
network adresse2
etc ...

bech t'thabbet , a3mel show ip route


par exp tjik hakka :
R 192.168.10.0/25 [120/2] via 192.168.10.254, 00:00:05, Serial0/0/1
r ma3neha jebtou bel rip , [120/2] , 120 heya l mesure , w 2 houwa nombre de sauts

bech t5alli e rip ma yab3atch màj l nes lkol , donc tbloki l ba3then lel les interfaces elli fi nafs e
routeur
ta3mel
router rip
passive-interface esm l'interface
exp :
router rip
passive-interface fa0/0

bech t5alli ayy pc ynejjem yaccedi lel internet , ta3malha mel route racine (elli connecté lel fai) =
bech ta3mel route statique
# ip route 0.0.0.0 0.0.0.0 fa1/1
0.0.0.0 heya reseau mte3 ness lkol , w 0.0.0.0 el masque mte3ha , fa1/1 heyya l'interface mte3
el fai

sinon ,
ip route 30.0.0.0 255.255.255.0 20.0.0.1
ta3malha fel routeur , elli bech ta3mallou route statique ; hné , bech yo5rej mel
20.0.0.1(l'interface
elli t'hezzek lel rizo hedheka) lel reseau 30.0.0.0 w maskou 255.255.255.0

bech les routeurs lo5rin ya3rfou el fai , ta3mel (f nafs el pc)


# router rip
# default-information originate
OSPF point à point
enable
conf t
router ospf 1 (ay nombre) // tnejem testa3mel nafs e num f les routeurs lkol
network 192.168.10.192 0.0.0.31 area 0

bech te7seb el cout , ta3mel


(Bande passente ref) / (bp ligne)
bp ref = 10^8
bech ta3ref el bp ligne , ta3mel
show interface nom_interface
exp :
show interface se0/0/0
el fa dima = 10^8

ki yebda 3andek wa7da tnejem temchi men 2 chemins possible , w t7eb ta5tar un seul
donc yé tzid fel cout mte3 elli ma t7ebhech walla tna99es fel cout mte3 li t7ebha
donc tbaddel fel bande passante mte3 e lien
donc soit tbaddel fel bande passante , tzid fiha bech l coup yon9es
int nom_interface
bandwidth valeur_en_kbps

walla tbaddel fel cout directement


ip ospf cost valeur

OSPF accés multiple


e selection mte3 e dr tkoun selon l priorité , akther we7ed 3andou priorité
ken tal9a akther men 1 3andou akther priorité , tet3adda lel critére 2 = identifiant unique
elli 3andou theni akber priorité , houwa el bdr
ki yti7 el dr , el bdr ywalli dr , w awel we7ed ba3d el bdr (others) ywalli houwa el bdr
w ki yarja3 el dr louleni , yarja3 fel others

bech tchouf e dr (delegué) wel bdr (2éme délégué) ta3mel


show ip ospf neighbor
bech ta3ref el id mte3 el router , ta3mel
show ip protocols

bech tbaddel l priorité mte3 les routeurs


R4(config)#interface fastEthernet 0/0
R4(config-if)#ip ospf priority 200

clear ip ospf process

EIGRP

enable
conf t
router eigrp 1
network @reseaux
ou :
network @reseaux masque_generique
exp :
router eigrp 1
network 192.168.248 0.0.0.3
no auto-summary // desactivé el auto samery

bech tchouf e table de voisinage :


show ip eigrp neighbor

fel show ip protocols


maximum path : houwa e nombre de chemin maximale

bech tchouf e table de topologie :


show ip eigrp topology
w menha ta3ref les successeurs w les successeurs potentiels
successeur houwa a9reb chemin lel routeur avec fd heya el distance de faisabilité
successeur potentiel , houwa l successeur de secour . ma yji ken ki tebda el fd mte3ou as8er
mel fd mte3
e successer .
P ma3neha passif , ma3neha lawwej w kammel . ken A donc actif : mazzel ylawej
el metrique tete7seb b :
( k1 * bande passante + k3 * délai ) * 256
avec k1 w k3 2 coefficients (=1)

bech ta3mel route statique


ip route 0.0.0.0 0.0.0.0 fa1/1
w bech tredestribiha lel les routeurs lo5rin ta3mel:
router eigrp 1
redistribute static

w wa9t'ha tal9a un champ E fel show ip route fel les routeurs lo5rin

bech t7ot un router troddou successeur


temchi lel routeur d'origine w ta3mel

int nom_interface_routeur_successeur
bandwith 100000
delay 10

exp : routeur b t7eb t7ottlou routeur a successeur (elli l'interface mte3ou s0/0/1)

int s0/0/1
bandwith 100000
delay 10

LOOPBACK
bech tajouti des adresse loopbacks , ta3mel

int loopback 0 (w ba3d 1 et 2 etc ...)


int nom

ip address adresse mask

NAT/PAT
nat : bech translati @ privée en @publique
bech ta3malha :
# ip nat inside source static @privée @publique(ay 7aja n7eb 3liha apart .0 felle5er)
exp : 10.0.0.2 bech nroddouha 50.0.0.1
ip nat inside source static 10.0.0.2 50.0.0.1
w ba3d tdeclari el interface interne wel interface externe
exp :
int fa0/0
ip nat inside

int se0/0
ip nat outside

BGP
bech torbet bin plusieurs systems autonomes , fi wost les systemes autonomes . famma ASBR
welli houwa
autonomous system border routers , connectés fi b3adh'hom b ibgp . w bin les s.a , bel ebgp

configuration ibgp (entre asbr € au meme s.a)


r2(conf) # router bgp numero_system_autonome
# neighbor @asbr_voisin as num_sys_autonome
w fel voisin le5er , nafs l 7keya

exp :
router bgp 200
neighbor 192.168.1.197 remote-as 200

configuration egbp (entre asbr €differents s.a)


#router bgp 200
#neigbhor 10.1.0.1 remote as 100