Vous êtes sur la page 1sur 127

Implementation de Routage IP

CCNP ROUTE
Module 2 : Configuration de l’OSPF

Adil SMAHI

Adil SMAHI
Comprendre les
Terminologies de l’OSPF

Adil SMAHI
Open Shortest Path First (OSPF)

• OSPF est un protocole de routage à Etat de lien IP standardisé


et décrit dans la RFC 2328

o Proposé par l'IETF en 1988 et officialisé en 1991

o Il a été développé pour répondre à la limite de 15 sauts de RIP

o Il existe en 2 versions , OSPFv2 pour IPv4 et OSPFv3 pour IPv6

Adil SMAHI
Les caractéristiques de l’OSPF

• Les caractéristiques de l’OSPF  sont :

• Convergence rapide
• Support du VLSM
• Utilisation efficace de la bande passante 
• les modifications de routage déclenchent des mises à jour de routage 
• Prend en charge des réseaux de grande taille
• Regroupement des membres en régions (Area)

Adil SMAHI
Les caractéristiques de l’OSPF

• Avec les protocoles de routage à état de liens, chaque routeur a une


image complète de la topologie du réseau, et peut de manière
indépendante , prendre une décision sur une destination précise du
réseau.

• Pour ce faire, chaque routeur conserve un enregistrement de :


• Ses routeurs voisin immédiat.
• Tous les autres routeurs dans le réseau, ou dans sa zone du réseau et leurs réseaux
attachés.
• Le meilleur chemins vers chaque destination.

Adil SMAHI
Les caractéristiques de l’OSPF

• Prenons un aperçu sur l'état des liens et ce que cela signifie exactement

• Link : C'est l'interface du routeur.


• State : Description de l'interface et la façon dont il est connectée aux routeurs voisins
Adil SMAHI
Les caractéristiques de l’OSPF

• Protocoles de routage à état de liens fonctionnent en envoyant les annonces d'état


de liens (LSA) à tous les autres routeurs à état de liens

Tous les routeurs doivent avoir ces


annonces d'état de liaison afin qu'ils
puissent construire leur base de données
LinkState ou LSDB.

En principe, toutes les annonces d'état de


liaison (LSA) sont des pièces du puzzle qui
construisent le (LSDB).
Cette LSDB est notre image complète du
réseau, en langage réseau nous appelons
cette image topologie.
Adil SMAHI
Les caractéristiques de l’OSPF

• L'OSPF fonctionne avec le concept des zones (Areas) et par défaut, il y toujours une zone unique,
normalement, c'est la zone 0, également appelée zone de réseau fédérateur (Backbone).

Adil SMAHI
Les caractéristiques de l’OSPF

• Vous pouvez avoir plusieurs zones cependant que dans l'image ci-dessus nous avons la


zone 1, 2 et 3. Tous ces domaines doivent se connecter à la zone Backbone.
• Si vous voulez aller de la zone 1 à la zone 2, vous devez passer par la zone Backbone. Il est
impossible
Adil SMAHI
de passer de la zone 1 à la zone 2 directement
Les caractéristiques de l’OSPF

• Routeur interne un routeur dont toutes les interfaces se trouvent dans la même
Area

• Area Border Router (ABR) un routeur qui dispose d'interfaces dans des Area
Différentes

• Autonomous System Boundary Router (ASBR) un routeur qui injecte dans OSPF


des routes qui proviennent d'autres protocoles de routage ou des routes statiques.

• Routeur backbone un routeur dont au moins une interface appartient à l'aire 0. Tous
les ABR sont des routeurs backbone.

Adil SMAHI
Les caractéristiques de l’OSPF

• Les routeurs de la zone dorsale (zone 0) sont appelés routeurs de backbone.


• Les routeurs entre deux zones (comme celui entre la zone 0 et zone 1) sont appelés ABR.
• Les routeurs qui exécutent OSPF et sont connectés à un autre réseau qui exécute un
autre protocole de routage sont appelés ASBR.
Adil SMAHI
Les caractéristiques de l’OSPF

• Une fois que vous configurez OSPF sur un routeur, il va commencer à envoyer des
paquets HELLO.
• Si vous recevez également des paquets HELLO de l'autre routeur, vous deviendrez
voisins

Adil SMAHI
Les caractéristiques de l’OSPF
 OSPF utilise une métrique appelée coût qui repose sur la bande passante d’une
interface
Cost = Reference Bandwidth / Interface Bandwidth
 La bande passante de référence est une valeur par défaut sur les routeurs Cisco égale
à 100Mbit.
Exemples :
 Si vous avez une interface de 100 Mbits quel est le coût ?
• 100 Mbit / 100 Mbit = COST 1
 Si vous avez une interface de 100 Mbits quel est le coût ?
• 100 Mbit / 10 Mbit = COST 10
 Si vous avez une interface de 1 Mbits quel est le coût ?
• 100 Mbit / 1 Mbit = COST 100
Adil SMAHI
Les caractéristiques de l’OSPF

• Chaque LSA possède une horloge de vieillissement.

• Par défaut chaque LSA OSPF n'est valable que pour 30 minutes.

• Si la LSA expire alors le routeur qui a créé la LSA va la renvoyer et


augmente le numéro de séquence

Adil SMAHI
Exercice

Adil SMAHI
Les type de routeurs OSPF

Quel est le rôle de chaque routeur?


R1
R2
R3
R4
R5
Adil SMAHI
Les type de routeurs OSPF

R1 ABR et routeur de backbone


R2 ASBR et routeur de backbone
R3 Routeur Interne et routeur de backbone
R4 Routeur Interne
R5 Routeur EIGRP (routeur externe)

Adil SMAHI
Configuration de base de
l’OSPF

Adil SMAHI
Configuration de l’OSPF

Activer le routage OSPF


• Définir le numéro du système Autonome
Router(config)#

router ospf process-id


• Le processus-id est un numéro utilisé en interne qui identifie le processus de routage
OSPF
 L'identifiant de processus ne doit pas nécessairement correspondre aux ID de
processus des autres routeurs
 Il peut être n'importe quel entier positif dans la plage de 1 à 65535.

Adil SMAHI
Configuration de l’OSPF

Identifier les réseaux OSPF


• Définir les réseaux que OSPF va annoncer aux voisins
Router(config-router)#

network ip-address [wildcard-mask] area area-id


• Le paramètre network peut être un réseau, un sous-réseau, ou l'adresse d'une
interface directement connectée
• Le [wildcard-mask] est un masque inversé utilisé pour déterminer comment
interpréter l'adresse
• Le paramètre area-id spécifie la zone OSPF à être associé à l’adresse.

Adil SMAHI
Configuration de l’OSPF

Identifier les réseaux OSPF


• Une méthode optionnelle pour activer l’OSPF sur une interface

Router(config-if)#

ip ospf process-id area area-id

• Le paramètre area-id spécifie la zone OSPF à être associé à l’adresse.

Adil SMAHI
Configuration de l’OSPF

Définir la bande passante de l’interface :


• Définir les réseaux EIGRP pour les annoncer aux voisins EIGRP

Router( config-if ) #

bandwidth kilobits
• Le paramètre kilobits indique la bande passante prévue en Kbits/s.
 Par exemple, pour définir la bande passante de 512 000 bits/s, utilisez la commande
bandwidth 512
• La bande passante configurée est utilisée par les protocoles de routage dans le calcul de
métriques
• La commande ne modifie pas réellement la vitesse de l'interface.

Adil SMAHI
Configuration de l’OSPF

Loopback0
5.5.5.5/32
Configuration OSPF 1 sur le routeur R1

10.1.1.0/24

Configuration OSPF 1 sur le routeur R5

Loopback0
1.1.1.1/32

Adil SMAHI
Relation de voisinage de l’OSPF

Loopback0
5.5.5.5/32
Relation de voisinage avec le routeur R1

10.1.1.0/24

Relation de voisinage avec le routeur R5

Loopback0
1.1.1.1/32

Adil SMAHI
La vérification de la base de donné LSDB

Loopback0
La base de donné LSDB du routeur R5
5.5.5.5/32

10.1.1.0/24

Loopback0
1.1.1.1/32

Adil SMAHI
Les interfaces OSPF

Sow ip ospf interface : pour afficher des information OSPF pour toutes les interface OSPF
Sow ip ospf interface Ethernet 0: pour afficher des information OOSPF pour une interface
spécifique

Adil SMAHI
ID du Routeur OSPF

 Chaque routeur  OSPF est connu par un ID.


• LSDBs utiliser l'ID du routeur OSPF pour différencier un routeur de l'autre.

 Par défaut, l'ID de routeur est l’adresse IP la plus élevée


d’une interface active au moment du démarrage du processus OSPF.
• Toutefois, pour des raisons de stabilité, il est recommandé que la commande 
router-id ou une interface de bouclage soit configuré.

Adil SMAHI
ID du Routeur OSPF

OUI
Non configuration
Utiliser cet ID
Explicite de l’ID
du Router
du Router
?

interface OUI
Utiliser l'adresse IP de
Loopback
bouclage la plus élevée
Configuré ?

Non
Utiliser la plus élevée
adresse IP active

Adil SMAHI
Définir un ID du routeur

Affecter un ID spécifique à un routeur


Router( config-router ) #

router-id ip-address
 Toute valeur arbitraire de 32 bits dans un format d'adresse IP (décimal pointé) peut
être utilisée.
 Si cette commande est utilisée sur un processus OSPF qui est déjà actif, le nouvel ID
de routeur prend effet :
 Après le prochain redémarrage du routeur .
 Après un redémarrage manuel du processus OSPF avec la commande clear ip ospf
processus du mode privilégiés .

Adil SMAHI
Quel est le RID du routeur R5?

Adil SMAHI
Assigner la priorité du routeur

 Assigner une priorité spécifique à un routeur :


Router(config-if)#

ip ospf priority number


 L’interface d’un routeur peut avoir une confiance entre 0 et 255
• 0 = DROTHER - Le routeur ne peut pas être un DR
• 1 = Favorable - La valeur par défaut pour tous les routeurs
• 255 = Very favorable - Le routeur sera toujours un DR
 La configuration de la priorité doit être faite avant le processus d’élection

 Pour afficher la priorité d’une interface utiliser la commande


show
Adil SMAHI ip ospf interface
Sélection du DR/BDR

• Tous les voisins avec une priorité > 0 sont listés

• le routeur avec la priorité d’interface OSPF la plus élevée est élu DR


o Si les priorités d’interface OSPF sont égaux, c’est le routeur dont l’ID est le plus élevé qui
est choisi.

• S'il n'y a aucun DR, la BDR est promu comme DR

• Le voisin avec la priorité la plus élevé est élu comme BDR

• L’ élection de DR / BDR est non préemptif. Cela signifie que si vous modifiez la priorité ou
L’ID de routeur vous devez réinitialiser OSPF afin de sélectionner un nouveau DR / BDR .
Adil SMAHI
Sélection du DR/BDR

• On va contrôler le choix du routeur DR à l’aide de la commande ip ospf priority

Adil SMAHI
Sélection du DR/BDR

• show ip ospf neighbor sur le routeur DR

• show ip ospf neighbor sur un routeur DROther

Adil SMAHI
Effacement de la table de routage OSPF

 Pour effacer toutes les lignes de la table de routage IP, utilisez :
• Routeur # clear ip route *

 Pour effacer une route spécifique de la table de routage, utilisez :
• Routeur # clear ip route A.B.C.D

Adil SMAHI
Vérification de l’OSPF

Commande Description

Affiche L’ID de processus OSPF, ID de routeur, les routeur du


show ip protocols réseaux qui sont annoncés et la distance administrative

show ip ospf neighbors Affiche les voisins OSPF.

show ip route Affiche la table de routage.

show ip ospf interface Affiche le hello interval et le dead interval

Affiche L’ID de processus OSPF, l’ID de routeur, information sur


show ip ospf la zone OSPF et la dernière fois ou l'algorithme SPF a été exécuté

Adil SMAHI
TP: OSPF dans un réseau
Point to Point

Adil SMAHI
OSPF dans un réseau Point to Point (Mono Area)

Adil SMAHI
OSPF dans un réseau Point to Point (Area Multiple)

Adil SMAHI
Les types de réseaux
OSPF

Adil SMAHI
Les types de réseaux OSPF

OSPF définit 3 types de réseaux :


Network Type Description Exemple

Broadcast • Un réseau de diffusion multi- accès Tous les réseaux Ethernet


• DR / BDR requis.

Point-to-point • Aucun DR / BDR requis. Lien série utilisant PPP / HDLC

• Un réseau qui relie plus de deux routeurs, mais qui n'a pas de
capacité de diffusion.
• DR / BDR peut ou peut ne pas être nécessaire.
• Il y a cinq mode d’operation OSPF disponible pour les réseaux NBMA
• Modes conforme RFC :
Frame Relay
Non broadcast multi • non-broadcast
ATM
Access (NBMA) • point-to-multipoint
X.25
• Modes propriétaire CISCO:
• broadcast
• point-to-multipoint non-broadcast
• point-to-point
• Le choix du mode dépend de la topologie du réseau NBMA.
Adil SMAHI
Les types de réseaux OSPF : Broadcast

Parmi les défis des réseaux de diffusion


est le nombre de contiguïtés qui
seraient nécessaires :

• Une contiguïté pour chaque paire de


routeurs
• Cela augmenterait le trafic du réseau
et ajoute une surcharge sur chaque
routeur pour gérer chaque contiguïté
individuelle.

Adil SMAHI
Les types de réseaux OSPF : Broadcast

Un autre défi est l'augmentation de LSA


du réseau.

• Chaque LSA envoyés requiert également


un accusé de réception.
• Conséquence : bande passante
consommée

Adil SMAHI
Solution: Le Routeur Désigné

Le Routeur désigné (DR) et le routeur


désigné de sauvegarde (BDR) vont
résoudre le problème parce qu’ ils :

 Réduisent le trafic de mises à jour de


routage
 Gèrent la synchronisation des états de
lien

Adil SMAHI
Le Routeur Désigné

 Le DR est chargé de transmettre les


LSA vers les autres routeurs, pour cela
il utilise l’adresse de multidiffusion
224.0.0.5 (tous les routeurs OSPF).

 Au final, un seul routeur assure la


diffusion de l’ensemble des LSA dans
le réseau à accès multiple.

Adil SMAHI
Les caractéristiques de l’OSPF

• Un routeur désigné de secours (BDR) est


également choisi en cas de défaillance du
routeur désigné. Tous les autres routeurs
deviennent des DROthers (ce qui signifie
qu’ils ne sont ni DR, ni BDR).

Adil SMAHI
TP: OSPF dans un réseau
de Broadcast

Adil SMAHI
OSPF dans un réseau de Broadcast (Mono Area)

Adil SMAHI
OSPF dans un réseau de Broadcast (Area Multiple)

Adil SMAHI
L’Eléction du DR dans une topologie NBMA

 Par défaut, OSPF ne peut pas construire automatiquement des contiguïtés avec
des routeurs voisins via les interfaces NBMA.

 OSPF considère que l’environnement NBMA fonctionne de manière similaire à


d'autres médias à accès multiple comme Ethernet.

• Cependant, les réseaux NBMA sont généralement hub-and-spoke en utilisant


des topologies PVC ou circuits virtuels commutés (SVC).

• Dans ces cas, la topologie physique ne fournit pas la capacité multi-accès sur
laquelle repose le protocole OSPF.

Adil SMAHI
L’Election du DR dans une topologie NBMA

 L'élection du DR devient un problème dans les topologies NBMA


parce que le DR et BDR besoin une connectivité complète de
couche 2 avec tous les routeurs du réseau NBMA.

 Le DR et BDR ont également besoin d'avoir une liste de tous les


autres routeurs afin qu'ils puissent établir des contiguïtés.

Adil SMAHI
Les topologies de l’OSPF

• Selon le type de la topologie , plusieurs configurations OSPF sont


disponibles pour un réseau Frame-Relay :

Maillage globale Maillage partiel Hub & spoke

Adil SMAHI
Les configurations de l’OSPF

 Les modes de topologie NBMA sont configurés en utilisant la


commande de configuration d'interface : ip ospf network .

 Certains modes nécessitent qu'un voisin soit configuré manuellement


en utilisant la commande de configuration du routeur neighbor.

Adil SMAHI
Définir un type de réseau OSPF sur une interface

Router(config-if)#

ip ospf network [{non-broadcast | point-to-multipoint [non-


broadcast] | broadcast | point-to-point}]

 Le choix du mode dépend de la topologie NBMA.


 Le mode par défaut de L’OSPF sur un réseau Frame Relay:
• L'interface est en mode non-broadcast.
• Le sous-interface Point-à-point est en mode point-to-point.
• Le sous-interface multipoint est le mode non-broadcast.

Adil SMAHI
Identifier un routeur voisin

 Définir statiquement les relations adjacentes dans les réseaux NBMA.
Router(config-router)#
neighbor ip-address [priority number] [poll-interval number] [cost
number] [database-filter all]

Adil SMAHI
Mode Non-Broadcast (Maillage Global)
 Les caractéristiques du paramètre non-
broadcast comprennent :
• Généralement on utilise une topologie à maillage
global , donc le DR et le BDR sont dynamiquement élus
• Un seul sous-réseau IP
• Les voisins OSPF doivent être configurés manuellement

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network non-broadcast
R1(config-if)# exit
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# neighbor 192.168.1.2
R1(config-router)# neighbor 192.168.1.3
Adil SMAHI
Mode Non-Broadcast (Maillage Partiel)
 Les caractéristiques du paramètre non-
broadcast comprennent :
• Si une topologie à maillage partiel est utilisée, alors le
DR et le BDR sont élus manuellement à l'aide de la
commande priority sur le routeur hub
• Un seul sous-réseau IP
• Les voisins OSPF doivent être configurés manuellement

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network non-broadcast
R1(config-if)# exit
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# neighbor 192.168.1.2 priority 0
R1(config-router)#
Adil SMAHI
neighbor 192.168.1.3 priority 0
Mode Point-to-multipoint
 Les caractéristiques du mode point-to-
multipoint comprennent :
• Utilisé avec une topologie à maillage partiel ou hub-and-spoke
• Un seul sous-réseau IP
• DR et BDR ne sont pas requis.
• Utilise les paquets HELLO multicast pour découvrir
dynamiquement les voisins

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network point-to-multipoint
R1(config-if)# exit
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#
Adil SMAHI
Mode Point-to-multipoint non-broadcast
 Les caractéristiques du mode point-to-
multipoint non-broadcast sont :
• DR et BDR ne sont pas requis.
• Les voisins OSPF doivent être configurés
manuellement
• Utilisé dans des cas particuliers où les voisins ne
peuvent pas être découvert automatiquement.

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network point-to-multipoint non-broadcast
R1(config-if)# exit
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# neighbor 192.168.1.2 cost 10
R1(config-router)#
Adil SMAHI neighbor 192.168.1.3 cost 20
Mode BROADCAST
 Les caractéristiques du mode broadcast
Cisco sont :
• LE DR et le BDR sont élus et nécessitent une
connectivité complète avec tous les autres
routeurs
• Peut être configuré pour une topologie à
maillage global ou une élection statique du DR
basée sur la priorité de l'interface
• Un seul sous-réseau IP
• Utilise les paquets HELLO multicast pour
découvrir dynamiquement les voisins
R1(config)# interface S0/0/0
R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network broadcast
R1(config-if)# exit
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
Adil SMAHI
R1(config-router)#
Mode POINT-TO-POINT

 Les caractéristiques du mode point-to-


point Cisco sont :
• Utilisé avec une topologie à maillage partiel ou
hub-and-spoke (étoile)
• DR et BDR ne sont pas requis.
• Un seul sous-réseau IP

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network broadcast
R1(config-if)# exit
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#
Adil SMAHI
Les sous interfaces

 L'OSPF peut également être exécuté sur des sous-interfaces.


• Une sous-interface est une interface physique peut être divisée en plusieurs
interfaces logiques.
• Chaque sous-interface nécessite un sous-réseau IP.

 Les sous-interfaces peuvent être définis soit comme point à point ou point à
multipoint.
 Une sous-interface point-à-point a des propriétés similaires à l’interface
physique point-à-point .

Note: La commande ip ospf network n’est pas requis

Adil SMAHI
Définir une sous-interface :

 Définir une sous interface

Router(config) #

interface serial number.subinterface-number {multipoint


.
| point-to-point}

Adil SMAHI
Utilisation d’une sous interface POINT-TO-POINT

 Les caractéristiques sont :


• Les mêmes propriétés qu'une interface
physique point-to-point
• DR et BDR ne sont pas requis.
• Un seul sous-réseau IP par interface
• Utilisé lorsque seulement deux routeurs doivent
former une contiguïté sur une paire d'interfaces

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# interface S0/0/0.1 point-to-point
R1(config-subif)# ip address 10.1.1.1 255.255.255.0
R1(config-subif)# interface S0/0/0.2 point-to-point
R1(config-subif)# ip address 10.2.2.1 255.255.255.0
R1(config-subif)# router ospf 1
R1(config-router)# network 10.1.1.0 0.0.0.255 area 0
R1(config-router)#
Adil SMAHI network 10.2.2.0 0.0.0.255 area 0
Utilisation d’une sous interface MULTIPOINT

 L'exemple a une sous-interface point à


point et une autre multipoint
 La sous-interface multipoint prend en charge
deux autres routeurs
 Les sous interfaces Frame Relay Multipoint
sont par défaut en mode non-broadcast, ce
qui nécessite une configuration statique des
voisins et une élection du DR et BDR

R1(config)# interface S0/0/0


R1(config-if)# encapsulation frame-relay
R1(config-if)# interface S0/0/0.1 point-to-point
R1(config-subif)# ip address 10.1.1.1 255.255.255.0
R1(config-subif)# interface S0/0/0.2 multipoint
R1(config-subif)# ip address 10.2.2.1 255.255.255.0
R1(config-subif)# router ospf 1
R1(config-router)# network 10.0.0.0 0.255.255.255 area 0
R1(config-router)# neighbor 10.2.2.3 priority 0
Adil SMAHI
R1(config-router)# neighbor 10.2.2.4 priority 0
TP: Configuration OSPF
sur Frame Relay

Adil SMAHI
Configuration OSPF sur Frame Relay Point to Point

Adil SMAHI
Configuration OSPF sur Frame Relay Point to Multipoint

Adil SMAHI
Les paquets OSPF et la
découverte de voisinage

Adil SMAHI
Les paquets OSPF

• Hello: Découverte de voisins, construction et


maintenance des contiguïtés de voisinage.

• DBD: Ce paquet est utilisé pour vérifier si la LSDB


entre 2 routeurs est la même. Le DBD est un
résumé de la LSDB

• LSR: Demande des enregistrements spécifiques


d'état de liens d’un voisin OSPF.

• LSU: envoie les enregistrements d'état de liens


qui ont été demandés. Ce paquet est comme une
enveloppe qui contient plusieurs LSA

• LSAck: Le protocole OSPF est un protocole fiable,


Adil SMAHI
un accusé de réception
Les états des routeurs OSPF

OSPF doit passer par 7 états pour avoir une relation de voisinage :
Down: aucun voisin détecté jusqu’à ce moment.
Attempt: utilisé pour une configuration manuelle
Init: Packet Hello reçu.
Two-way: Propre ID de routeur trouvé dans paquet hello reçu.
Exstart: rôles de maître et esclave déterminés.
Exchange: paquets de description de base de données (DBD) envoyé.
Loading: échange des paquets LSRs (Link state request) et LSUs (Link state update).
Full: Routeurs OSPF ont maintenant une contiguïté.

Adil SMAHI
Les types de paquets LSA

Adil SMAHI
Les types de paquets LSA

OSPF utilise plusieurs types de LSA :

• LSA Type 1: Router LSA


• LSA Type 2: Network LSA
• LSA Type 3: Summary LSA
• LSA Type 4: Summary ASBR LSA
• LSA Type 5: Autonomous system external LSA
• LSA Type 6: Multicast OSPF LSA
• LSA Type 7: Not-so-stubby area LSA
• LSA Type 8: External attribute LSA for BGP

Adil SMAHI
LSA Type 1: Router LSA

 Généré par tous les routeurs dans une zone pour décrire leurs liens directement
connectés (itinéraires Intra-zone).

• Inondations dans la zone et ne peuvent pas traverser un ABR.


• LSA comprend la liste des liens directement attachés et est identifié par l'ID de
routeur qui a généré le paquet LSA
• Entrée de table de routage O

Adil SMAHI
LSA Type 2: Network LSA

 Les LSA de type 2 ou (Network LSA) sont créés


pour les réseaux multi-accès.
 Les LSA de type 2 sont générés par le DR
 Les LSA de type 2 contiennent :
• Une liste de tout les routeurs qui sont
connectés au réseau multi-accès
• Le DR (Routeur désigné)
• Le préfixe et le masque de sous réseau
• L’ID d’état de lien est le DR
• L’entrée de la table de routage est : O

Adil SMAHI
LSA Type 3: Summary LSA

 Annoncé par l’ABR de la zone d'origine


• Régénéré par L’ABR suivant pour inonder tout le système autonome
• Par défaut, les routes ne sont pas résumées et le LSA type 3 est annoncé pour chaque sous-réseau.
• L’ ID d’état de lien est le réseau ou sous-réseau annoncés dans le summary LSA
• L’entrée de table de routage O IA  

Adil SMAHI
LSA Type 4: Summary ASBR LSA

 Généré par l’ABR de la zone d'origine pour annoncer un ASBR à toutes


les autres zones dans le système autonome.
•  Ils sont régénérés par tous les ABR suivants pour inonder tout le système
autonome
• L’ID d'état de lien est l'ID de routeur de l'ASBR
•  Entrée de Table de Routage O IA
Adil SMAHI
LSA Type 5: External LSA

 Utilisé par le routeur ASBR pour annoncer les réseaux des autres
systèmes autonomes. 
• Les LSA Type 5 sont annoncés par l'ASBR d'origine
• L' ID d’état de lien est le numéro de réseau externe
• Entrée de table de routage O E1 ou E2
Adil SMAHI
LSA Type 7: NSSA LSA

 Produit par un ASBR à l'intérieur d’une zone (NSSA) pour décrire les
routes redistribuées dans le NSSA.
• LSA type 7 est traduit en LSA type 5 lorsqu'il sort de la NSSA
• Entrée de la table de routage O N1 ou O N2
• comme le LSA 5, N2 est un coût statique tandis que N1 est un coût cumulatif qui
inclut le coût jusqu'à l'ASBR
Adil SMAHI
Les types de paquets LSA

• Dans cette image on a une


topologie avec 3 zones OSPF
et plusieurs routeurs ABR et
ASBR
• On montre chaque type de
LSA seulement une seule fois

Adil SMAHI
Les entré dans la table de routage

LSA Type Entré dans la table de routage


LSA1 Router LSA O
LSA2 Network LSA O
LSA3 Summary LSA O IA
LSA4 Summary ASBR LSA O IA
LSA5 External LSA O E1 ou E2
LSA7 NSSA LSA O N1 ou O N2

Adil SMAHI
Redistribution des routes dans
l’OSPF

Adil SMAHI
Exemple

Adil SMAHI
Exemple

Adil SMAHI
Exemple

La redistribution des routes OSPF dans le protocole RIP


R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#redistribute ospf 1 metric 1

La redistribution des routes RIP dans le protocole OSPF


R1(config)#router ospf 1
R1(config-router)#redistribute rip subnets

Adil SMAHI
Exemple

Adil SMAHI
Les types de zone OSPF

Adil SMAHI
Zones OSPF Stub et Totally Stub

 Une zone se qualifie comme stub ou totalement stub si elle présente


les caractéristiques suivantes :

• la zone n'est pas la zone d’épine dorsale (zone 0)


• Il y a un seul point de sortie de cette zone.
• Il n'y a aucun ASBR à l'intérieur de la zone.
•  La zone n'est pas utilisée comme une zone de transit pour les liens virtuels.

Adil SMAHI
Les caractéristiques des zones Stub et Totally Stub

• Tous les routeurs OSPF à l'intérieur de la zone de stub, y compris


ABRs, sont configurés comme des routeurs de stub à l'aide de la
commande area area-id stub

• Par défaut, l'ABR d'une zone Stub ou Totally Stub annonce une
route par défaut avec un coût de 1 Pour modifier le coût de la
route par défaut, utilisez la commande area area-id
default-cost cost

Adil SMAHI
Configuration d’une zone Stub

• Identifier une zone comme zone stub.

Router(config-router)#

area area-id stub

• Le paramètre area-id est l'identificateur de la zone stub et peut être


soit une valeur décimale, soit une valeur au format décimal pointé,
comme une adresse IP.

Adil SMAHI
Changer le cout par défaut

 Définir le coût de la route par défaut injecté dans la zone stub.

Router(config-router)#

area area-id default-cost cost

 Le paramètre de coût est par défaut pour le résumé du route


  Les valeurs acceptables sont comprises entre 0 et 16777215.
 La valeur par défaut est 1.
 Si cette commande n‘est pas configurée, l'ABR annoncera 0.0.0.0 avec
une métrique de coût par défaut de 1, plus les coûts internes

Adil SMAHI
Configuration d’une zone Stub

R3(config)# interface FastEthernet0/0


R3(config-if)# ip address 192.168.14.1 255.255.255.0
R3(config-if)# interface Serial 0/0/0
R3(config-if)# ip address 192.168.15.1 255.255.255.252
R3(config-if)# router ospf 100
R3(config-router)# network 192.168.14.0.0 0.0.0.255 area 0
R3(config-router)# network 192.168.15.0.0 0.0.0.255 area 2
R3(config-router)# area 2 stub

R4(config-if)# interface Serial 0/0/0


R4(config-if)# ip address 192.168.15.2 255.255.255.252
R4(config-if)# router ospf 100
R4(config-router)# network 192.168.15.0.0 0.0.0.255 area 2
Adil SMAHI R4(config-router)# area 2 stub
Vérification du routage Stub

• Table de routage avec une redistribution des routes externe

• Table de routage avec une redistribution des routes externe dans


une stub zone

Adil SMAHI
Zone Totally Stub

 Solution propriétaire Cisco


 La zone n'accepte pas les routes des
AS externes ou les routes interzones
  Plus précisément, il n'accepte pas les LSA
types 3, 4 et 5.
 Il ne reconnaît que les routes intra-zone et
la route par défaut 0.0.0.0.
 Une route par défaut (0.0.0.0) se propage
dans toute la zone.

Adil SMAHI
Configuration d’une zone Totally Stub

 Identifier un ABR comme un réseau totally stub.

Router(config-router)#

area area-id stub no-summary

 La commande n’est configurée que sur le ABR.


• Tous les autres routeurs de la zone totalement stub sont configurés comme
routeurs stub. 
 Le paramètre area-id est l'identificateur de la zone stub
 Le paramètre no-summary arrête l’inondations des resumés LSA et des
LSA externes dans la zone totalement stub

Adil SMAHI
Configuration d’une zone Totally Stub

R3(config)# interface FastEthernet0/0


R3(config-if)# ip address 192.168.14.1 255.255.255.0
R3(config-if)# interface Serial 0/0/0
R3(config-if)# ip address 192.168.15.1 255.255.255.252
R3(config-if)# router ospf 100
R3(config-router)# network 192.168.14.0.0 0.0.0.255 area 0
R3(config-router)# network 192.168.15.0.0 0.0.0.255 area 2
R3(config-router)# area 2 stub no-summary

R4(config-if)# interface Serial 0/0/0


R4(config-if)# ip address 192.168.15.2 255.255.255.252
R4(config-if)# router ospf 100
R4(config-router)# network 192.168.15.0.0 0.0.0.255 area 2
Adil SMAHI R4(config-router)# area 2 stub
Vérification du routage totaly Stub

• Table de routage du routeur R4, dans une zone de stub

• Table de routage du routeur R4, dans une zone totaly stub

Adil SMAHI
La zone Not-So-Stubby (NSSA)

 Semblable à une zone Stub, sauf qu'il est


principalement utilisée pour la connexion
au FAI, ou lorsque la redistribution est
nécessaire.
• Plus précisément, il n'accepte pas les types 4 et 5
LSA.
• Permet l'importation des routes externes de LSA
type 7 et les convertit en LSA type 5 sur l'ABR
• Mieux que la création de zone de stub et aussi
utile pour les spokes.

Adil SMAHI
Configuration d’une zone Not-So-Stubby (NSSA)

 Définir une zone NSSA .

Router(config-router)#

area area-id nssa [no-redistribution] [default-information-originate]


[metric metric-value] [metric-type type-value] [no-summary]

Adil SMAHI
Configuration de la zone Not-So-Stubby (NSSA)

R3(config)# router ospf 10


R3(config-router)# redistribute rip subnets
R3(config-router)# default metric 150
R3(config-router)# network 172.17.0.0 0.0.255.255 area 1
R3(config-router)# area 1 nssa

R2(config)# router ospf 10


R2(config-router)# summary-address 172.16.0.0 255.255.0.0
R2(config-router)# network 172.17.20.0 0.0.0.255 area 1
R2(config-router)# network 172.17.0.0 0.0.255.255 area 0
R2(config-router)# area 1 nssa default-information-originate
Adil SMAHI
La zone Totally Stubby NSSA
 Solution propriétaire Cisco.
 Zone n'accepte pas les routes des AS
externe ou les routes inter-zones.
• Plus précisément, il n'accepte pas les LSA
types 3, 4 et 5.
• Il ne reconnaît que les routes intra-zone et
la route par défaut 0.0.0.0.
• Une route par défaut (0.0.0.0) se propage
dans toute la zone.
 L’ ABR du totally stubby NSSA doit être
configuré avec le mot clé no-summary
pour éviter l'inondation des résumés de
routes dans d'autres zone dans la zone
NSSA.
Adil SMAHI
Configuration de La zone Totally Stubby NSSA

R1(config)# router ospf 10


R1(config-router)# redistribute rip subnets
R1(config-router)# default metric 150
R1(config-router)# network 172.17.0.0 0.0.255.255 area 1
R1(config-router)# area 1 nssa

R2(config)# router ospf 10


R2(config-router)# summary-address 172.16.0.0 255.255.0.0
R2(config-router)# network 172.17.20.0 0.0.0.255 area 1
R2(config-router)# network 172.17.0.0 0.0.255.255 area 0
R2(config-router)# area 1 nssa no-summary
Adil SMAHI
Liens Virtuels

Adil SMAHI
Liens Virtuels

  Tous les zones doivent être connectées à la zone 0 qui est la zone de
Backbone.
 Que se passe-t-il lorsqu'une zone n'est pas reliée à la zone 0
Adil SMAHI
Liens Virtuels

 Est-ce que la topologie OSPF illustré va marcher? Pourquoi?

Adil SMAHI
Liens Virtuels

 Normalement cela ne va pas travailler puisque la zone 2 n’est pas


connectée directement à la zone 0
 Nous pouvons résoudre ce problème en utilisant un lien virtuel.

Adil SMAHI
Liens Virtuels

 Les liens virtuels sont utilisés pour relier une zone discontinue à la
zone 0. (Qui n’est pas connecter a la zone de backbone)
 Un lien logique est construit entre le routeur R1 et le routeur R2.

Adil SMAHI
Liens Virtuels

 Les LSA vieillissent généralement au bout de 30 minutes.


 Cependant, Les LSA apprissent sur les liaisons virtuelles ont l’options (DNA)
DoNotAge.
 Nécessaire pour éviter les inondations excessives sur les liens virtuels.
 Pour identifier une zone comme un lien virtuel, utilisez la commande
de configuration du routeur area-id virtual-link
Adil SMAHI
Configuration du Lien Virtuel
 Définir un lien virtuel

R1(config)# router ospf 100


R1(config-router)# area 1 virtual-link 2.2.2.2
R1(config-router)#

R2(config)# router ospf 100


R2(config-router)# area 1 virtual-link 1.1.1.1
R2(config-router)#

Adil SMAHI
Exemple de configuration du Lien Virtuel

 le routeur au dessus est dans la zone 0. Malheureusement, ce routeur tombe en


panne , et le résultat est que zone 0 est maintenant divisée en deux morceaux.
C'est ce que nous appelons une zone non contigu
 Nous pouvons utiliser un lien virtuel à travers la zone 1 pour résoudre ce
problème
Adil SMAHI
Exemple de configuration du Lien Virtuel

ID 1.1.1.1 ID 2.2.2.2

10.0.0.0 172.16.0.0 10.0.0.0

R1(config)# router ospf 100


R1(config-router)# network 172.16.0.0 0.0.255.255 area 1
R1(config-router)# network 10.0.0.0 0.0.255.255 area 0
R1(config-router)# area 1 virtual-link 2.2.2.2

R2(config)# router ospf 100


R2(config-router)# network 172.16.0.0 0.0.255.255 area 1
R2(config-router)# network 10.0.0.0 0.0.255.255 area 0
R2(config-router)# area 1 virtual-link 1.1.1.1
Adil SMAHI
Vérification des Lien Virtuel

R1# show ip ospf virtual-links


Virtual Link OSPF_VL0 to router 10.2.2.2 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface Serial0/0/1, Cost of using 781
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:07
Adjacency State FULL (Hello suppressed)
Index 1/2, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Adil SMAHI Last retransmission scan time is 0 msec, maximum is 0 msec
Configuration des
fonctionnalités avancées de
l’OSPF

Adil SMAHI
Les types de paquets LSA

 Empêche la sortie des mises à jour OSPF sur une interface spécifiée

Router(config-router)#
passive-interface type number [default]

 Définir une interface particulière ou toutes les interfaces de routeur


passives.
 Pour OSPF, la commande :
• l'interface spécifiée apparaît comme un réseau stub du domaine OSPF .
• Les informations de routage OSPF ne sont ni envoyées ni reçues via cette
interface.
• Empêche l’établissement de relations de voisinage
Adil SMAHI
Exemple de L’ Interface Passive

R1(config)# router ospf 1


R1(config-router)# passive-interface fa0/0

R2(config)# router ospf 10


R2(config-router)# passive-interface fa0/0

Alternate configuration:
R1(config)# router ospf 1
R1(config-router)# passive-interface default
R1(config-router)# no passive-interface S0/0/0
R2(config)# router ospf 10
R2(config-router)# passive-interface default
R2(config-router)# no passive-interface S0/0/0
Adil SMAHI R2(config-router)# no passive-interface S0/0/1
L’AUTHENTIFICATION

Adil SMAHI
L’AUTHENTIFICATION

 Le but est d'authentifier les informations de routage.


 Il s'agit d'une configuration spécifique de l'interface.
 Les Routeurs n'acceptent que les informations de routage des autres
routeurs qui ont été configurés avec les mêmes informations
d'authentification.

Adil SMAHI
Les types d’authentification OSPF

 Le routeur génère et vérifie chaque paquet et authentifie la source de


chaque paquet de mise à jour qu’il reçoit
 Nécessite une "clé" prédéfini (mot de passe)
 Remarque: Tous les voisins participants doivent avoir la même clé configuré
 OSPF prend en charge 2 types d'authentification:
 L'authentification par mot de passe simple (texte brut)
 moins sécurisé
 authentification MD5
 Plus sécurisé et recommandé

Adil SMAHI
Configuration d’une authentification simple
 Définir un mot de passe à utiliser pour l'authentification par mot de
passe simple.
Router(config-if)#

ip ospf authentication-key password

 Le paramètre password peut avoir jusqu'à 8 octets de longueur.


 Cette commande est utilisée en conjonction avec la commande
ip ospf authentication

Adil SMAHI
Configurez le Key-ID MD5 et le Key
 Définir un mot de passe à utiliser pour l'authentification par mot de
passe simple.
Router(config-if)#

ip ospf message-digest-key key-id md5 key

 Le paramètre key-id est un identificateur dans la plage de 1 à 255.


 Le paramètre key peut avoir jusqu'à 16 octets de longueur.
 Tous les routeurs voisins sur le même réseau doivent avoir le même
key-id et la même valeur de key.
 Cette commande est utilisée en conjonction avec la commande ip
ospf authentication message-digest
Adil SMAHI
Configurer le mode d'authentification OSPF
 Définir le type d’authentification
Router(config-if)#

ip ospf authentication [message-digest | null]

 Avant d'utiliser cette commande, configurer un mot de passe.


 La commande sans spécifier aucun paramètre signifie que l'authentification
par mot de passe simple sera utilisée.
 Le paramètre message-digest spécifie que l'authentification MD5 sera
utilisée.
 Le paramètre null spécifie qu'aucune authentification n'est utilisée
 Cela peut être utile pour la substitution de mot de passe simple ou authentification
MD5.
Adil SMAHI
Configuration de l'authentification par mot de passe simple

R1(config)# interface fa0/0


R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# ip ospf authentication
R1(config-if)# ip ospf authentication-key PLAINPAS

R2(config)# interface fa0/0


R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# ip ospf authentication
R2(config-if)# ip ospf authentication-key PLAINPAS

Adil SMAHI
Configuration de l’authentification MD5

R1(config)# interface fa0/0


R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# ip ospf authentication message-digest
R1(config-if)# ip ospf message-digest-key 1 md5 CISCO

R2(config)# interface fa0/0


R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# ip ospf authentication message-digest
R2(config-if)# ip ospf message-digest-key 1 md5 CISCO

Adil SMAHI
ANNEX

Adil SMAHI
Masque générique

• Rappelez-vous qu'un masque générique est l'inverse d'un masque de sous-


réseau
• Une méthode simple pour calculer l'inverse du masque de sous-réseau, est
de soustraire le masque de sous-réseau de 255.255.255.255
• Par exemple, l'inverse du masque de sous-réseau 255.255.255.252 est
0.0.0.3

255.255.255.255
– 255.255.255.252
0. 0. 0. 3

Adil SMAHI
Les type de routeurs OSPF

DR Routeur désigné
BDR Routeur désigné de backup
DROTHERS Un routeur qui ni DR ou BDR
RI Routeur Interne avec toutes ces interfaces dans la même zone (autre que area 0)
ABR Routeur qui a au moins une interface dans la zone de backbone (Area0) et
connecte d’autre zone avec la zone 0
BR Routeur Backbone qui a au moins une interface dans la zone de backbone
(Area0), tous les ABRs sont des routeurs de backbone, mais pas le contraire
ASBR Routeur OSPF et un autre Protocol de routage autre que OSPF (RIP, EIGRP…)

Adil SMAHI
Adil SMAHI