Vous êtes sur la page 1sur 32

La modélisation d’une ville

- La fonction de modélisation
de Google Earth
- Outils utiles
- Ressources utiles
- Terminologie
- Prise de photos
- Construction d’un modèle
- Ajout de textures aux photos
- Liste de vérification de géo-modélisation
- Téléchargement de votre modèle
- Le meilleur de la Banque d’images 3D
- Astuces SketchUp
- Astuces Photoshop

Guide de création de votre environnement Google Earth


La fonction de modélisation de
Google Earth
Google Earth est un environnement en ligne, et les
utilisateurs qui savent tirer profit de cette caractéristique
créeront des modèles de qualité. Un modèle bien
construit sera téléchargé rapidement et permettra à
Google Earth de travailler au mieux de sa performance.

Tous les modèles géo-référencés soumis sont examinés


en interne avant d’être inclus dans les infos pratiques
« Le meilleur de la Banque d’images 3D » de Google
Earth. Référez-vous à ce guide pour mettre toutes les
chances de votre côté et voir vos modèles dans les infos
pratiques !

Les clés du succès


- Conserver une échelle et un emplacement précis.
- Mettre l’accent sur les aspects importants et
identifier les détails.
- Montrer les petits détails complexes dans les
textures de photos.
- Réduire le nombre de polygones.
- Créer un beau modèle.
Outils utiles

Google SketchUp Google Earth Banque d’images 3


www.sketchup.com earth.google.com sketchup.google.com/3dwarehouse
Outil de modélisation 3D Navigateur interactif 3D de la Terre Un monde en 3D interconnecté

Adobe Photoshop Picasa


www.adobe.com picasa.google.com
Édition avancée de photos Édition et organisation de photos
Ressources utiles

Google Search Emporis Archiplanet


www.google.com www.emporis.com www.archiplanet.org/
Nombreuses catégories interrogeables Construction de hauteurs et de détails Compilation d’une encyclopédie

Wikipédia Skyscraperpage
www.wikipedia.org www.skyscraperpage.com
L’encyclopédie libre Construction de hauteurs, diagrammes et
forums
Terminologie
Arête ou ligne
- La géométrie qui divise et borde les surfaces.

Face ou polygone (poly)


- Une surface plate, à deux côtés définie par au moins trois lignes.

Texture ou matière
- Les images ou les couleurs appliquées sur les faces.

Texture en mosaïque
- Une image qui se répète sur une face, créant une texture en
mosaïque.

Transparence alpha
- L’utilisation de la transparence dans une image.

Peu de polygones
- Utilisation d’un nombre minime d’arêtes et de faces pour limiter la
taille du fichier et augmenter la performance de l’ordinateur.

Taille du fichier
- La quantité d’espace que vos fichiers occupent sur votre
ordinateur. Seuls les modèles de moins de 10 Mo peuvent être
téléchargés vers la Banque d’images 3D.
Prise de photos
- Prenez de NOMBREUSES photos ! Vous aurez
besoin d’une photo de chaque façade, y
compris les allées et les cours.
- Si possible, prenez vos photos en évitant les
obstructions, telles que les arbres, les
personnes, les voitures, etc.
- Incluez le contexte. Montrez le bâtiment dans
son environnement.
- Prenez des photos des coins. Celles-ci
permettront d’adapter une photo.
Photogra-
phiez les
détails. Prenez des
photos des
environs pour
permettre de
situer le bâtiment.

Prenez plusieurs photos


des longues façades s’il
est trop difficile de les
photographier en une fois.
Prenez plusieurs Vous pourrez les
photos de chaque assembler ultérieurement
façade. à l’aide d’un éditeur de
photos.
Construction d’un modèle
Pour créer un modèle de qualité, il importe
que celui-ci représente exactement le
bâtiment et qu’il puisse être téléchargé
efficacement dans Google Earth. Les
modèles aux lignes simples et aux textures
pour interfaces web seront téléchargés
rapidement dans un environnement en ligne
comme celui de Google Earth.

- Démarrage
- Modélisation simple
- Composants
- Ancrage du modèle au sol
- Nettoyage
Construction d’un modèle Démarrage
Ouvrez Google Earth.
- Repérez votre bâtiment dans Google Earth. Appuyez sur la touche
« R » pour aligner le nord sur le haut de l’écran et pour obtenir une
vue aérienne directe (plan).
- Vérifiez que la valeur du Facteur d’élévation est de 1 dans le menu
Outils -> Options.
- Vérifiez que votre info pratique de relief est cochée.
- Enregistrez l’image pour pouvoir l’utiliser en tant que texture de toit
sans devoir changer de position. Fichier -> Enregistrer -> Enregistrer
l’image
Ouvrez Google SketchUp.
- Importer le terrain au moyen de l’outil Capturer la vue
actuelle de SketchUp.
- Aligner votre axe pour qu’il corresponde à votre bâtiment
au moyen de l’outil Axe.

Axe aligné incorrectement Axe aligné correctement


Modélisation
Construction d’un modèle simple
- Simplifiez les courbes. Moins il Dans SketchUp, les courbes sont
y a de faces, plus la taille du constituées de segments de ligne.
fichier sera réduite et Pour simplifier le traçage d’un arc
meilleure sera la ou d’un cercle, saisissez un chiffre,
performance. appuyez sur « S », puis sur la
touche Entrée.

- De nombreuses propriétés de Cette forme complexe est, en


bâtiments en 3D peuvent être réalité, constituée uniquement
rendues en 2D. de faces plates sans
profondeur. Cette technique
permet d’ajouter des détails
sans compliquer le modèle.

- Orientation correcte de Chaque face possède deux côtés.


la face. Vérifiez que le côté avant (clair) de
la face est tourné vers l’extérieur.
Pour afficher l’orientation de la
face, Afficher -> Style de face ->
Monochrome
Pour inverser une face, Cliquer
avec le bouton droit de la souris ->
Inverser les faces
Construction d’un modèle Composants

Utilisez les composants pour les N’oubliez pas de conserver


propriétés de bâtiments répétitives. aussi peu de polygones que
SketchUp considère les composants possible .
comme des entités uniques pour un Cette colonne possède
téléchargement plus rapide, sans seulement trois côtés. Les
augmenter la taille des fichiers. faces du haut et du bas ont
- Sélectionnez la géométrie. également été supprimées.
- Éditer -> Créer un N’oubliez pas que pour
composant ajouter une texture à un
composant ou à un groupe,
vous devez double cliquer
pour éditer l’objet avant de
pouvoir y appliquer votre
texture.
Ancrage de
Construction d’un modèle votre modèle
- Vérifiez que votre modèle est Activez et désactivez le
ancré dans le relief de Google relief avec l’icône
Earth. Activez et désactivez le « Activer/désactiver le
relief avec l’icône relief » et déplacez votre
« Activer/désactiver le relief » bâtiment verticalement afin
(voir Astuces pour utilisateurs que celui-ci repose sur le
avancés pour plus sol.
d’informations sur le relief).
La construction d’un modèle Nettoyage

- Au cours du processus de Essayez de créer des


modélisation, supprimer modèles à la carcasse
les faces non visibles et creuse, dénués de lignes
effacer les lignes inutiles. ou de faces internes.

- On parle de z-fighting Le z-fighting est le signe


lorsque les faces du d’une géométrie
modèle clignotent. excessive. Il convient
d’éliminer ce problème en
supprimant les faces en
trop.

- PURGEZ ! Purgez votre modèle


pour le nettoyer des textures
et des composants inutilisés.
Fenêtre -> Infos du modèle ->
Statistiques -> Purger les
éléments inutilisés.
Ajout de textures aux photos
Ajoutez de la texture à vos photos pour pouvoir les
appliquer sur votre modèle. Cela vous permettra
d’améliorer votre modèle en le rendant plus
réaliste tout en maintenant un faible niveau de
résolution. Certaines photos peuvent permettre de
produire des textures uniques, tandis que d’autres
peuvent uniquement être utilisées pour faciliter la
création de votre modèle.
- Application d’une texture
- Positionnement d’une texture
- Adaptation de la meilleure photo
- Adaptation d’une photo
- Localisation d’une photo
adaptée
Application
Ajout de textures aux photos d’une texture
- À l’aide de Picasa, rognez votre
image autant que possible sans
rien perdre du bâtiment.
- Dans SketchUp, sélectionnez
Fichier -> Importer, sélectionnez
votre image, choisissez « Utiliser
comme texture », puis ouvrez.
- Cliquez sur la face sur laquelle
vous souhaitez appliquer la
texture. Étirez ensuite la
texture sur la face et cliquez à
nouveau.
Ajout de textures aux photos Positionnement
d’une texture
- Éditez votre texture en cliquant avec le
bouton droit de votre souris sur la face et
choisissez Texture -> Position.
- L’image comporte quatre punaises. Cliquez
une fois sur une punaise pour la saisir,
puis déplacez-la dans le coin souhaité de
la texture. Répétez la procédure ci-dessus
pour les punaises et les coins restants.
- Cliquez sur l’image avec le bouton droit de
votre souris et désactivez l’option
« Punaises verrouillées ». Ensuite, cliquez
sur les punaises et déplacez-les vers les
coins du modèle.
- Appuyez sur Entrée pour finaliser le
positionnement de la texture.
- N’oubliez pas de faire de même avec la
texture de toit que vous avez enregistrée à
partir de Google Earth.
- Pour plus d’options d’ajout de textures aux
photos, voir Astuces pour utilisateurs
avancés.
Ajout de textures aux photos Adaptation de
la meilleure photo
L’adaptation d’une photo dans SketchUp
consiste à aligner la vue de votre modèle sur la
vue de la photo que vous avez prise.

Ligne d’horizon
Axe bleu
Serre-barre de l’axe rouge
Serre-barre de l’axe vert
Point de fuite
Point d’origine
Axe vert
Axe rouge

- Choisissez une photo de votre bâtiment qui


montre une perspective basée sur deux
points de mesure (photo d’un coin).
- Importez votre relief dans Google Earth et
tracez la superficie au sol de votre bâtiment.
- Examinez l’image que vous avez choisie, et
alignez votre axe dans SketchUp de façon à
ce que le point d’origine se trouve dans le
coin correspondant, comme indiqué sur
l’illustration.
Adaptation
Ajout de textures aux photos d’une photo
- Fichier -> Importer, sélectionnez Pas de panique.
votre image, choisissez « Utiliser
comme nouvelle photo
adaptée », puis cliquez sur ouvrir.
- Déplacez le point d’origine sur le
coin correspondant de votre
image.
- Alignez les barres rouge et verte Ne les alignez pas
sur les lignes horizontales du avec le sol, car celui-
bâtiment dans l’image. ci pourrait ne pas être
horizontal.
- Déplacez la souris sur l’axe bleu,
puis cliquez dessus et déplacez-
le pour faire un zoom. Faites
correspondre la superficie au sol
que vous avez tracée avec le
bâtiment de votre photographie.
- Cliquez sur Terminé.
Traçage d’une
Ajout de textures aux photos photo adaptée
- Vous pouvez maintenant tracer la silhouette du
bâtiment. N’oubliez pas de seulement faire un Filaire
panoramique et dessiner. Ne suivez pas d’orbite,
Ombré
car cela fermerait l’option d’adaptation de photo.
Vous pouvez retourner à la photo adaptée en
cliquant sur l’onglet situé en haut de la fenêtre de
votre modèle.
- Une fois le tracé de votre photo terminé, cliquez sur
« Projeter les textures de la photo » ou cliquez
avec le bouton droit de votre souris -> projeter la
photo sur une face spécifique afin d’ajouter de la
texture à votre nouveau modèle.
- Si vous choisissez d’adapter votre modèle à une
nouvelle photo, n’oubliez pas de redéfinir votre
axe et point d’origine.
Checklist de géo-modélisation
Supprimez toute géométrie inutile à l’intérieur et à l’extérieur de
votre bâtiment.
Activez votre géométrie cachée, Afficher -> Géométrie cachée,
et supprimez le surplus de lignes cachées.
Assurez-vous que votre bâtiment est aligné sur la base du
bâtiment de votre capture d’écran Google Earth.
Activez et désactivez le bouton du relief et confirmez que votre
bâtiment est ancré dans le sol.
Exportez votre modèle dans Google Earth, Fichier -> Exporter -
> Modèle 3D et choisissez Google Earth 4 (.kmz).
Ouvrez le fichier .kmz dans Google Earth afin de vérifier qu’il
représente précisément le bâtiment.
Vérifiez que la taille de votre fichier SketchUp est inférieure à
10 Mo afin de pouvoir le télécharger vers la Banque
d’images 3D.
Essayez d’obtenir un nombre minimal de faces (polygones),
Fenêtre -> Infos du modèle -> Statistiques. Moins de
500 faces convient pour la plupart des bâtiments.
Téléchargement de votre modèle
- Dans SketchUp, cachez vos lignes et vos profils
pour que votre capture d’écran soit moins
encombrée. Afficher -> Style d’arête ->
désactivez Afficher les arêtes et Profils.
- Positionnez votre vue à l’écran de façon à la
rendre attrayante. Elle représentera votre
capture d’écran dans la Banque d’images 3D.
- Cliquez sur le bouton « Partager le modèle ».
- Ouvrez un compte Google si cela n’est pas déjà
fait, puis choisissez un nom d’utilisateur.
- Remplissez autant de champs que possible
avec lesinformations concernant le bâtiment
que vous avez modélisé. Tout renseignement
utile, tel que nom de ville, architecte,
matériaux de construction, etc. facilite la
localisation de votre bâtiment dans la Banque
d’images 3D.
- Assurez-vous d’activer la case « Prêt pour
Google Earth ».
- Cliquez sur Télécharger.
Le meilleur de la Banque d’images 3D

Une fois que votre modèle géo-référencé a été


téléchargé, il est en route pour l’info pratique « Le
meilleur de la Banque d’images 3D » de Google
Earth. Voici comment vous pouvez vérifier si votre
modèle a été sélectionné.

- Voyez si votre modèle est orné d’un ruban bleu


Google Earth sur la Banque d’images 3D.

- Dans Google Earth, activez l’info pratique « Le


meilleur de la Banque d’images 3D » et rendez-
vous à l’emplacement de votre bâtiment.
- Votre bâtiment devrait apparaître accompagné d’une
maisonnette jaune contenant plus d’informations.

Les modèles n’apparaissent pas immédiatement dans les


infos pratiques. Ils doivent être examinés avant d’être
sélectionnés. Ce processus peut prendre jusqu’à 30 jours.
Astuces SketchUp
Astuces et conseils SketchUp
- Effets de sol
- Courbes et projections
- Cacher et révéler
Astuces SketchUp Effets de sol

- Ajout de couleurs à votre relief importé Google


Earth.
http://sketchupdate.blogspot.com/2007/06/adding-
color-to-your-earth-snapshots.html
- Assurez-vous d’enregistrer une image
provenant de Google Earth en même temps que
vous importez votre relief dans Google
SketchUp.
- Déverrouillez votre relief, cliquez avec le bouton
droit de la souris -> Déverrouiller.
- Double cliquez pour saisir le groupe.
- Insérez l’image que vous avez enregistrée lors
de l’importation de votre relief sur la face.
- Positionnez la texture en déplaçant les coins de
l’image afin qu’ils correspondent aux coins de la
face.
- Modélisation du relief.
- Il arrive que le relief dans Google Earth ne
corresponde pas au terrain réel. Le cas échéant,
vous pouvez modéliser le relief dans Google
SketchUp. N’oubliez pas de maintenir la
résolution la plus faible possible et de projeter la
texture du sol Google Earth sur votre nouveau
relief.
Astuces SketchUp Courbes et projections

- La projection de textures
- Cliquez avec le bouton droit de Rappelez-vous que lorsque
la souris sur une texture et vous projetez des textures, la
choisissez projeté. Cela peut être texture source doit être
utile pour appliquer des images perpendiculaire à la courbe.
sur des faces courbées ou
obliques.

- L’adoucissement des courbes


- Vous pouvez adoucir un dessin
en sélectionnant l’outil Effacer et
en maintenant enfoncée la touche
Ctrl tout en effaçant les bords.
Astuces SketchUp Cacher et Révéler

- Utilisez les fonctions Cacher et Révéler


pour accélérer la performance de
l’ordinateur.
- Si votre ordinateur fonctionne au
ralenti en raison de fichiers de grande
taille, cachez les parties de votre
modèle sur lesquelles vous n’êtes pas
en train de travailler afin d’optimiser la
performance de votre ordinateur. Vous
pouvez les révéler au moment où vous
en aurez besoin.
- Vous pouvez également cacher le relief
déverrouillé, cliquez avec le bouton
droit de votre souris –> Déverrouiller.
- Pour afficher la géométrie cachée,
Afficher -> Géométrie cachée.
Astuces Photoshop
Tout éditeur de photos, tel qu’Adobe
Photoshop, peut s’avérer pratique pour
supprimer les obstuctions des photos (arbres,
personnes, voitures, etc.).
- Perspective rognée
- Correction des couleurs
- Édition des obstructions
- Textures avancées
- Ajout aux textures
- Enregistrement en vue
d’une utilisation web
Astuces Photoshop Perspective rognée
- Cliquez sur l’outil Rogner. Une fois la procédure
lancée, cliquez sur la case « Perspective » située en
haut de l’écran. Cela vous permettra de déplacer les
coins de la boîte afin que ceux-ci correspondent à la
perspective de la face que vous souhaitez rogner.
- Appuyez sur entrée. L’outil Rogner laisse parfois un
renflement sur l’image en raison de l’objectif de
l’appareil photo. Utiliser l’outil Déformer.
Utilisation de l’outil Déformer.
- « Ctrl + A » pour tout sélectionner.
- « Ctrl + T » pour lancer la transformation.
- Cliquez avec le bouton droit de la souris et
sélectionnez Déformer.
- Utilisez les points d’ancrage ou cliquez simplement sur
l’image et déplacez-la pour déformer les courbes.
- Appuyez sur entrée pour terminer la transformation.
Utilisation du filtre Correction de l’objectif.
- Commencez avec une image non rognée.
- Sélectionnez Filtre -> Déformer -> Correction de
l’objectif.
- Utilisez le curseur « Supprimer la déformation » pour
corriger la déformation de l’objectif. Pour les
appareils photos compacts typiques, une valeur de
quatre convient très bien.
Correction des
Astuces Photoshop couleurs
Il peut être difficile de corriger les couleurs,
mais certains outils faciles à utiliser permettent
d’obtenir des résultats remarquables.
Masque Rapide, touche « Q »
Le Masque Rapide modifie toutes les actions
afin de créer des zones masquées (à partir
de la sélection). Celles-ci apparaissent en
rouge. Par exemple :
- Appuyez sur la touche « Q ».
- Appuyez sur l‘outil« Dégradé » pour créer un
dégradé.
- Appuyez à nouveau sur la touche « Q ».
- Votre sélection représente maintenant un
dégradé que vous pouvez utiliser pour
compenser un dégradé de votre image.
Image -> Ajustements -> Luminosité/Contraste
- Ajustez la luminosité et le contraste à
l’aide des curseurs.
Image -> Ajustements -> Nuance/Saturation
- Ajustez la nuance et la saturation à l’aide
des curseurs.
Densité et Assombrissement
- Utilisez l’outil Densité pour ajouter de la
luminosité avec un pinceau.

- Utilisez l’outil Assombrissement pour


retirer de la luminosité avec un pinceau.
Édition des
Astuces Photoshop obstructions
Utilisez la sélection et les outils de
clonage pour supprimer les obstructions.
- Utilisez l’outil Contour de sélection pour
sélectionner une zone.
- Passez à l’outil Déplacement.
- Maintenir la touche Alt enfoncée et
copier-déplacer votre sélection pour
couvrir les obstructions avec des
parties similaires de la photo.
- L’ajout d’une plume à votre sélection
peut permettre d’adoucir les lignes
que vous ne souhaitez pas voir
apparaître dans votre texture.
- Utilisation de l’outil Tampon de
duplication.
- Appuyez sur la touche Alt et
utilisez le curseur pour
sélectionner un point source.
- L’outil fonctionne ensuite
comme un pinceau qui peint à
partir de votre point source.
- Utilisation de l’outil Correcteur.
- Appuyez sur la touche Alt et
utilisez la cible pour sélectionner un
point source.
- L’outil atténue ensuite les
imperfections.
Astuces Photoshop Textures avancées

- Utilisation des outils de transparence alpha.


- Déverrouillez votre calque de fond (double
cliquez sur le calque) et effacer les zones non
désirées de votre image avec l’outil Effacer ou en
sélectionnant et supprimant les zones choisies.
- Enregistrez votre image pour le Web et
sélectionnez PNG-24.
- Assurez-vous d’appliquer un échantillon de
votre texture sur le côté arrière de la face sur
laquelle vous souhaitez l’appliquer.
- Création d’une image en mosaïque.
- Rognez une partie de l’image à utiliser pour la
mosaïque.
- Utilisez le filtre Déplacement, Filtre -> Autre ->
Déplacement, pour déplacer votre image rognée
horizontalement et verticalement. Le filtre
Déplacement vous permettra de déplacer votre
image selon la valeur spécifiée et placera le
surplus de l’autre côté de l’image.
- Rognez les bords afin que votre image s’étende
dans toutes les directions de façon homogène.
Astuces Photoshop Ajout aux textures

- Ajout d’un reflet


- Placez le reflet souhaité en
tant que nouveau calque dans
votre fichier.
- Réduisez la transparence
jusqu’à ce qu’il ait l’air réaliste.
- Utilisez l’outil Effacer ou
d’autres méthodes de
sélection pour retirer toute
propriété du bâtiment qui ne
se reflète pas.
- Ajout d’une ombre
- Utilisez l’outil Lasso ou
d’autres méthodes de
sélection pour dessiner
l’ombre désirée.
- Cliquez avec le bouton droit
de la souris et ajoutez une
plume à votre sélection.
- Utilisez la
luminosité/contraste pour
créer une ombre.
Enregistrement en vue
Astuces Photoshop d’une utilisation web
Il est utile d’enregistrer les fichiers en vue
d’une utilisation web, car ce format optimise
vos textures afin de ne pas en ralentir
l’utilisation dans des applications web.
- Fichier -> Enregistrer pour le Web
- Choisir JPEG (PNG 24 avec un outil
de transparence).
- Il existe deux façons d’optimiser la
taille de votre fichier.
- Abaissez le curseur de qualité.
- Cliquez sur l’onglet « Taille de
l’image ».
- Modifiez la taille ou votre image
(cela modifiera uniquement la taille
du fichier à enregistrer, et non le
fichier dans lequel vous avez
travaillé).
- Cela vous indique la taille de votre
fichier en fonction de la
configuration en cours.