Vous êtes sur la page 1sur 17

1

RAPPORT DU TP D’ARCHITECTURE DE SYSTEMES TELEINFORMATIQUES


I. INTRODUCTION
Il nous a été demandé de faire la configuration du protocole de Routage
EIGRP vu dans le cadre du cours d’Architecture des Systèmes
téléinformatiques.
1. Le Protocole de Routage EIGRP
EIGRP (Ehanced Interior Gateway Routing Information Protocol) : est un
protocole de routage de type IGRP (Interior Gateway Routing Information
Protocol) développé par Cisco, qui est un protocole de routage dynamique, qui
a la particularité d’utiliser, pour ses mises à jour, à la fois la connectivité à états
de liens et à vecteur de distance.
2. Un Protocole de Routage : est un ensemble de règles qui spécifient la
manière dont les routeurs identifient et transmettent les paquets le long
d’un chemin réseau. Le principal objectif du protocole de routage est de
maintenir à jour sa table de routage pour éviter les boucles réseau.

3. Le Routage : est un mécanisme par lequel des chemins sont sélectionnés


dans un réseau pour acheminer les données d’un expéditeur jusqu’à un ou
plusieurs destinataires.

II. REPRESENTATION DU PROTOCOLE EIGRP


2

 Configuration de base de R1
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 0/3/1


R1(config-if)#ip address 192.168.6.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 0/2/1


R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#

 Configuration d’EIGRP pour R1


R1(config)#router eigrp 1
R1(config-router)#eigrp router-id 1.1.1.1
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#network 192.168.5.0 0.0.0.255
R1(config-router)#network 192.168.6.0 0.0.0.255
R1(config-router)#exit
R1(config)#

 Configuration de base de R2
Router>en
Router#conf t
Router(config)#hostname R2
R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 0/3/0


R2(config-if)#ip address 192.168.6.2 255.255.255.0
R2(config-if)#no shutdown
3

R2(config-if)#exit

R2(config)#interface serial 0/2/0


R2(config-if)#ip address 192.168.4.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

 Configuration d’EIGRP pour R2


R2(config)#router eigrp 1
R2(config-router)#eigrp router-id 2.2.2.2
R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#network 192.168.4.0 0.0.0.255
R2(config-router)#network 192.168.6.0 0.0.0.255
R2(config-router)#exit
R2(config)#

 Configuration de base de R3
Router>en
Router#conf t
Router(config)#hostname R3
R3(config)#interface gigabitEthernet 0/0
R3(config-if)#ip address 192.168.3.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface serial 0/2/1


R3(config-if)#ip address 192.168.4.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface serial 0/2/0


R3(config-if)#ip address 192.168.5.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface serial 0/3/0


R3(config-if)#ip address 10.1.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
4

 Configuration d’EIGRP pour R3


R3(config)#router eigrp 1
R3(config-router)#eigrp router-id 3.3.3.3
R3(config-router)#network 192.168.3.0 0.0.0.255
R3(config-router)#network 192.168.4.0 0.0.0.255
R3(config-router)#network 192.168.5.0 0.0.0.255
R3(config-router)#network 10.1.1.0 0.0.0.255
R3(config-router)#exit
R3(config)#

 Configuration de la route par défaut


R3(config)#conf t
R3(config)#ip route 0.0.0.0 0.0.0.0 serial 0/3/0
R3(config)#router eigrp 1
R3(config-router)#redistribute static
R3(config-router)#exit
R3(config)#

 Configuration de base de R4
Router>en
Router#conf t
Router(config)#interface serial 0/3/1
Router(config-if)#ip address 10.1.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

Router>en
Router#conf t
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#ip address 192.168.7.1 255.255.255.0
Router(config-if)#no shutdown
Router#
5

II.1. AFFICHAGE DE LA CONFIGURATION DES ROUTEURS


La commande show running-config permet d’afficher la configuration des
routeurs
A. Routeur 1
R1>en
R1#show running-config
Building configuration...

Current configuration : 1070 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO2911/K9 sn FTX1524605I-
!
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
6

no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/2/1
ip address 192.168.5.1 255.255.255.0
!
interface Serial0/3/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3/1
ip address 192.168.6.1 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
eigrp router-id 1.1.1.1
network 192.168.1.0
network 192.168.5.0
network 192.168.6.0
!
ip classless
!
ip flow-export version 9
7

!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

B. Routeur 2
R2>en
R2#show running-config
Building configuration...

Current configuration : 1110 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
no ip cef
no ipv6 cef
!
!
!
license udi pid CISCO2911/K9 sn FTX1524JLS7-
!
!
!
spanning-tree mode pvst
8

!
!
!
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.4.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3/0
ip address 192.168.6.2 255.255.255.0
clock rate 2000000
!
interface Serial0/3/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
9

shutdown
!
router eigrp 1
eigrp router-id 2.2.2.2
network 192.168.2.0
network 192.168.4.0
network 192.168.6.0
!
ip classless
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
C. Routeur 3
R3>en
R3#show running-config
Building configuration...

Current configuration : 1188 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
10

!
!
no ip cef
no ipv6 cef
!
!
!
license udi pid CISCO2911/K9 sn FTX1524T706-
!
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
ip address 192.168.3.3 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.5.3 255.255.255.0
clock rate 2000000
!
interface Serial0/2/1
ip address 192.168.4.3 255.255.255.0
!
interface Serial0/3/0
11

ip address 10.1.1.1 255.255.255.0


clock rate 2000000
!
interface Serial0/3/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
eigrp router-id 3.3.3.3
redistribute static
network 192.168.3.0
network 192.168.4.0
network 192.168.5.0
network 10.1.1.0 0.0.0.255
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/3/0
!
ip flow-export version 9
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
12

D. Routeur 4
Router>en
Router#show running-config
Building configuration...

Current configuration : 973 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
no ip cef
no ipv6 cef
!
!
!
license udi pid CISCO2911/K9 sn FTX15241901-
!
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
ip address 192.168.7.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
13

interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3/1
ip address 10.1.1.2 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
14

!
!
end

II.2. EXECUTION AVEC LA COMMANDE « ping »


1. PC0

PC1
15

PC2

PC3
16

PC4

PC5
17

III. CONCLUSION
Ce TP avait pour but de mettre en œuvre l’EIGRP (Ehanced Interior Gateway
Routing Information Protocol), qui est un protocole de routage de type IGRP
(Interior Gateway Routing Information Protocol) développé par Cisco, qui a la
particularité d’utiliser, pour ses mises à jour, à la fois la connectivité à états de
liens et à vecteur de distance.
Il existe deux familles de protocole de routages :
 Ceux à vecteur de distance
 Et ceux à état de liens
 Vecteur de distance signifie que les routes échangées entre routeurs en
indiquant la direction et la distance.
 La distance correspond à ce que l’on appelle la métrique : par exemple pour
le protocole RIP, il s’agit du nombre de routeurs à traverser avant
d’atteindre la destination.
Pour faire la configuration de protocole de Routage EIGRP, nous avons
utilisés 4 routeurs, 3 commutateurs ou switch et 6 machines.
- Le routeur : est un équipement d’interconnexion de réseaux
informatiques permettant d’assurer le routage des paquets entre deux
réseaux ou plus afin de déterminer le chemin qu’un paquet de données
va emprunter.

- Le commutateur (switch) : est un dispositif multiport qui améliore


l’efficacité du réseau. Le commutateur gère des informations de routage
limitées sur les nœuds du réseau interne et permet de connexions à des
systèmes tels que les concentrateurs ou les routeurs.

Vous aimerez peut-être aussi