Vous êtes sur la page 1sur 10

République Algérienne Démocratique et Populaire

Université M'hamed Bougara


Boumerdès
Faculté de Technologie
Département de Génie des Procédés

Test de Méthode Numérique

Nom et Prénom : Boukerroua Ayoub


Groupe : 05
Niveau: 2ème année License

Année universitaire : 2019/2020


Exercice 01 :
1/ l’algorithme qui résoudre une équation du second degré :
Variables
a, b , c , d : réel
Début
Ecrire (‘Entrer les coefficients a, b et c : ‘)
Lire (a,b,c)
Si a = 0 alors
Si b=0 alors
Écrire (‘ il n’a pas de solution ‘)
Sinon
Écrire (‘ il y a une solution :’ -c /b)
FinSi
Sinon
D ← (b ^ 2) – (4 * a * c)
Si D < 0 Alors
Ecrire (‘Aucune solution dans R ' )
Sinon
Si D = 0 Alors
Ecrire (‘ une Solution : ‘ –b/ (2*a) )
Sinon
Ecrire (‘ Deux Solutions : ', (-b-Racine(D)) / (2*a), ' et ‘, (-b+ Racine (D)) / (2*a) )
FinSi
FinSi
FinSi
Fin

2/ l’algorithme qui résoudre une équation du second degré sous


matlab :
a = input ('entrer la valeur de a, a = ')
b = input ('entrer la valeur de b, b = ')
c = input ('entrer la valeur de c, c = ')

D=a^2-4*a*c
if (D > 0 )
X1 = (-b + sqrt(D) /2*a )
X2 = (-b - sqrt(D) /2*a )
elseif (D < 0 )
(‘Il n'a pas de solution')
else
x = -b/2*a
end.
2/ comment déclarer un polynôme sous matlab ?
On représente un polynôme P sous matlab par un vecteur :
P(x)= 2x² - x + 7
>> P= [2 -1 7]
P=
2 -1 7
- Le nombre d’éléments du vecteur est égal au degré de
polynôme +1.
Exercice 02 :
1/ Déclaration de Polynômes suivantes :
−x
P(x)= x 4 5
−1
P = [1 0 0 5 0]
−x5
W(x) = 3
−7 x

1
W = [- 3 0 0 0 -7 0]
Z(x) = x + x -1 3 2

Z = [1 1 0 -1]
2/
a- >> Z = [1 1 0 -1]

>> R =roots (z)

b- >> z = [ 1 1 0 -1]

z=

1 1 0 -1
>> polyval (z, -3)
ans =

5
>> polyval (z, 0)
ans =

-1
>> polyval (z, 3)

ans =

11

c-
>> r = [-2 , 2 ]

r=

-2 2

>> t = poly (r)

t=

1 0 -4
d-
>> L = [1 1 -1 -1]

L=
1 1 -1 -1

>> W = [-1/3 0 0 0 7 0]

W=

-0.3333 0 0 0 7.0000 0

>> [ Q , Rt ] = deconv(l,w)

Q=

Rt =

1 1 -1 1

Exercice 03:
- Les commandes pour trouver la primitive :
>> polyint (p)
Les commandes pour trouver la dérivée :
>> polyder (p)
Les Commandes pour calculer l’intégrale et la dérivée :
- Derive = polyder (p)
- intégrale = polyint (p)
Explication comment faire la représentation graphique :

On veut tracer le graphe d’une fonction z.


Y = Z(x) = x + x -1 3 2

b- >> z = [1 1 0 -1]

z=

1 1 0 -1

>> fplot('x^3 + x^2 -1 ', [ 1 4 ])


-la variable doit nécessairement s'appeler x.

>> grid off

>> xlabel('axe des abscisses')


>> ylabel('axe des ordonnées')

>> Title ('y=f(x)')

>> zoom on

click droit : zoom arrière

click gauche : zoom avant

click gauche et glissé : zoom d’une zone

>> zoom off


Exercice 04 :
- vérifier que f admet une racine séparée s e [1 ,2]
f(x) = x^3-x -5
f(1) = -5
f(2) = 1
f(2) * f(1) < 0
La fonction f change de Référence sur [1 ,2], donc
f(x) admet une racine séparée dans ce intervalle.
-méthode du point fixe :
Elle compte sur le changement de f(x)=0 a une
équation de fonction auxiliaire qui est équivalent à
g(x)=x . On choisit un point fixe de g, la fonction
auxiliaire doit être reliée à son point fixe.
L’agorithme :
1: k ←0
2: Tantque non convergence faire
3: x k+1 ← θ (x )
k

4: k ← k+1
5: Fin tantque
6: at ←x k