Vous êtes sur la page 1sur 30

Cours N°10:

Algorithmiques
Tableaux - Matrices
Département des Sciences Techniques.
Université Ammar Thelidji – Laghouat.
Sommaire

• Introduction.
• Notion de Matrice.
• Déclaration d’un tableau (Matrice).
• Lecture/Ecriture d’une Matrice.
• Parcours partiel.
• Exercices.
Introduction
Tableaux

Vecteurs Matrices
Notion de Matrice
Notion de Matrice

• Lorsque le tableau est composé de données de type simple,


on parle de tableau monodimensionnel (ou vecteur).

• Lorsque celui-ci contient d'autres tableaux on parle alors de


tableaux multidimensionnels (aussi matrice ou table).

• Les matrices sont donc des tableaux à deux dimensions.


Exemple: Soit la matrice M [3,4]

j
Indices
1 2 3 4

1 6 71 -8 12

14 5 56 6
i 2 Elément

3 32 17 9 21
Déclaration d’une matrice
Déclaration de Matrice

Une matrice (tableau) doit avoir :

• Un nom déclaré comme un identificateur.

• Deux dimensions connues à l’avance [ligne, colonne]:

1) La dimension correspond au nombre maximum de


cases composant la matrice (exemple [3,5] ).

2) Deux indices (i, j) peuvent être déclarés pour


permettre d’adresser les cases de la matrice. Les
indices sont obligatoirement de type entier.
Comment Déclarer une matrice?
• Le type d’une matrice précise l’intervalle de définition et le type
(commun) des éléments.
Nom_matrice : Tableau [nbre_ligne, nbre_colonne] type_éléments

• Exemple:
Soit la matrice M 3x5 de 15 éléments entiers, définit par:

M : Tableau [3,5] entier


Déclarer une matrice

Algorithme exemple;
1 2 3 4 5
Variables
T : Tableau [3,5] entier;
1
Début
2

3 Fin.
Accès direct
L’accès direct

• Signifie que nous pouvons obtenir le contenu d’une cellule


à l’aide de deux valeurs appelées des indices,
généralement i et j.
• Pour accéder à un élément d’une matrice on doit préciser
sa position (la ligne et la colonne).
• Exemple : soit la matrice M [2 x 3] :
1 2 3
M[1 , 3] = ?? = 8 1 6 71 8
M[2 , 1] = ?? 2 5 12 -4
Exemple: Soit la Matrice M (3 x 4)

• Affecter à la variable A, la valeur de l’élément


qui se trouve à la 2ème ligne et la 3ème colonne ?
1 2 3 4

1 6 71 -8 12

A ← M [2 , 3] 2 14 5 56 6

3 32 17 9 21
A = 56
Lecture / Ecriture
d’une matrice
Lecture / Ecriture d’une matrice

•Pour lire une matrice il faut parcourir tous ces éléments afin de donner à chaque
élément une valeur.

•Pour afficher une matrice il faut parcourir tous ces éléments et écrire chaque élément.

•Pour cela l’utilisation de deux (2) boucles imbriquées parait indispensable pour
parcourir la matrice.
Exemple de lecture et Ecriture d’une matrice
M de 3 x 4 entiers
Algorithme
Algorithme Lecture;
Variables
M: Tableau [3,4] entier;
j i, j :entier;

1 2 3 4 Début
1
Pour i ← 1 à 3 faire
Pour j ← 1 à 4 faire
i 2 Lire ( M [ i , j ] );
Ecrire ( M [ i , j ] );
3 FinPour;
FinPour;
Fin.
Exemple d’un Algorithme
Remplir une Matrice
M [3,3]
Exemple
j= j= j=
Algorithme Calcul;
Variable 1 2 3
M: Tableau [3,3] entier;
i , j: entier;
i=1 2 3 4
Début
i Pour i  1 à 3 Faire i=2 3 4 5
j Pour j 1 to 3 Faire
i=3 4 5 6
M [ i , j ]  i + j;
FinPour;
FinPour;
i Pour i  1 à 3 Faire
Pour j 1 to 3 Faire
j
Ecrire ( M [ i , j ] );
FinPour;
FinPour;
End.
Exemple :

Calculer la somme des


éléments de la colonne C
de la matrice M [3,5].

(par exemple C = 4)
Exemple: Algorithme Somme;
Variables
Somme de la M: Tableau [3,5]
colonne C = 4. entier;
i, j, C, S :entier;
j Début
C ← 4;
M 1 2 3 4 5 S ← 0;
1 6 71 -8 12 10
Pour i ← 1 à 3 faire
2 14 5 56 6 -2
S← S+M[i,C];
i
FinPour;
3 32 17 9 2 5
Ecrire (S);
Fin.
Exemple :

Calculer la somme des


éléments de la ligne L de
la matrice M [3,5].

(par exemple L = 2)
Exemple: Algorithme Somme;
Variables
Somme de la M: Tableau [3,5]
ligne L = 2. entier;
i, j, L, S :entier;
j Début
L ← 2;
M 1 2 3 4 5 S ← 0;
1 6 71 -8 12 10
Pour j ← 1 à 5 faire
2 14 5 56 6 -2
S← S+M[L,j];
i
FinPour;
3 32 17 9 2 5
Ecrire (S);
Fin.
Exemple :

Calculer la somme des


éléments d’une matrice M[2,5]
Algorithme Algorithme Somme;
Variables
Somme des M: Tableau [2,5] entier;
éléments de la i, j, S :entier;
matrice M[2,5] Début
S ← 0;
M 1 2 3 4 5 Pour i ← 1 à 2 faire
6 71 -8 12 10
Pour j ← 1 à 5 faire
1 S← S+M[i,j];
2 14 5 56 6 -2 FinPour;
FinPour;
Ecrire (S);
Fin.
Exercices …
Exercice N°1 :

Ecrire un algorithme qui calcule:


La trace T d’une matrice carrée K[3,3]
K 1 2 3

3
Exercice N°2 :
Ecrire un algorithme qui calcule:
l’addition de deux matrices A et B:

C=A+B
(par exemple la dimension est [3,4] )
Exercice N°3 :
Ecrire un algorithme qui calcule:
le produit de deux matrices A et B:

C=A*B
(par exemple la dimension est [3,3] )