Vous êtes sur la page 1sur 7

MS Excel

I. Introduction
- Excel est un tableur pour construire et stocker des tableaux de données et de calcul.
- Il regroupe 3 types d’outils :
o Tableau de calcule.
o Outil de création de graphiques.
o Programmation en Macros ou en Visual Basic.
- Un document Excel est appelé classeur, il contient une ou plusieurs feuilles de calcul, présentes
sous formes d'onglets en bas de page.
- Une feuille de calcul est un ensemble de cellules, organisé sous forme d’un tableau
- Une feuille de calcul est constituée de lignes (numérotées à l'aide de chiffres) et de colonnes
(numérotées à l'aide de lettres).
- Le croisement d'une ligne et d'une colonne est appelé cellule. Une cellule est donc repérée par
un nombre et une lettre
- Un tableau se divise en lignes et colonnes.
- Une cellule est l’intersection d’une ligne et d’une colonne. Caractérisée par Adresse (Référence)
- Chacune des cellules de la feuille de calcul peut contenir des valeurs.
- Une Plage est un regroupement de plusieurs cellules. Par exemple, la plage de A1 à A10.

II. Manipulation des cellules


- Une cellule est l’élément de base dans Excel.
- Elle est désignée par ses coordonnées (Ex : B12) : Lettre(colonne)/numéro(ligne)
- Elle peut être manipulée par valeur ou par référence.
o Par valeur : c’est la valeur contenue dans la cellule qui nous intéresse. (Ex : 10)
o Par référence : c’est le contenu, même si c’est une formule qui nous intéresse. (ex A1)
- Les cellules se manipulent par référence grâce au symbole $ :
o Référence relative : ni la ligne ni la colonne n’est fixée (A2)
o Référence absolue : on fixe à la fois la ligne et la colonne ($A$2)
o Référence mixte : la ligne ou la colonne est fixée ($A2 ou (A$2))
o Références nominales : C'est un autre type de référence qui est en fait une référence
absolue. Mais au lieu de désigner la cellule par son nom générique ($C$7 ou A1), on lui
donne un nom particulier (souvent en rapport avec son contenu). (exemple : A5*TVA
avec TVA est le nom d’une cellule)
- Dans le cas où on a besoins d’utiliser des Formules utilisant des données de feuilles différentes,
on écrit : « Nom_Feille!Adresse_cellule » (ex : =Feuil1!B4)
- On peut affecter un nom à la cellule : c’est un nom donné à une cellule ou une zone de cellules.
Ils permettent de manipuler les données de façon plus compréhensible.
Exemple :
- Sélectionner plusieurs cellules adjacentes: sélectionner la première cellule, maintenir la touche
SHIFT enfoncée, sélectionner la dernière cellule;
- Cellules disjointes: sélectionner chaque cellule en maintenant la touche CTRL enfoncée;
- Pour supprimer une ou plusieurs cellules, sélectionner la ou les cellules puis appuyer sur la
touche SUPPR;

III. Les Formules et les Fonctions


- Les formules et les fonctions commencent toujours par le signe =
- Exemple : la somme des cellules C1 à C10.
o Formule C12=C1+C2+…+C10
o Fonction C12 = SOMME(C1:C10)
- Les fonctions sont des formules préprogrammées qui évitent d’écrire de longues expressions de
calcul.
- Les adresses données en paramètre à une fonction donnée sont séparées par :

, Ex : A1 , A5 c-à-d A1 et A5

: Ex : A1 : A5 c-à-d de A1 jusqu’à A5

1) Quelques fonctions usuelles


1.1. Fonction « Somme »
Rôle : Définir la somme des cellules spécifiées.
Syntaxe : =SOMME(valeur1, valeur2, …)
Exemple : = SOMME(A1,B4,B8)

1.2. Fonction « PRODUIT »


Rôle : Définir le produit des cellules spécifiées.
Syntaxe : =PRODUIT(valeur1, valeur2, …)
Exemple : =PRODUIT(A1 : A5)

1.3. Fonction « MOYENNE »


Rôle : Définir la moyenne des cellules spécifiées.
Syntaxe : =MOYENNE(valeur1, valeur2, …)
Exemple : =MOYENNE(D3 : E5)

1.4. Fonction « MIN »


Rôle : Renvoie la valeur minimale.
Syntaxe : =MIN(valeur1, valeur2, …)
Exemple : =MIN(D3 : E5)

1.5. Fonction « MAX »


Rôle : Renvoie la valeur maximale.
Syntaxe : =MAX(valeur1, valeur2, …)
Exemple : =MAX(B2 : B4)

1.6. Fonction « AUJOURDHUI»


Rôle : Renvoie la date d’aujourd’hui.
Syntaxe : =AUJOURDHUI()

1.7. Fonction « SI »
Rôle : Définir la valeur d’une cellule en fonction d’une ou plusieurs conditions.
Syntaxe : =SI(condition, ‘’valeur_si_vrai’’, ‘’valeur_si_faux’’)
Exemple : Déterminer le résultat d’un étudiant en fonction de sa moyenne :
Moyenne < 10 : Afficher « Ajourné »
Moyenne >= 10 : Afficher « Admis »

=SI(A1<10,"Admis","Ajourné")

=SI(A1<10,

"Ajourné" "Admis"
❖ Fonction « SI » imbriquée :

Déterminer la mention d’un étudiant en fonction de sa moyenne :


Moyenne <10 : Afficher « Faible »
10<= moyenne < 12 : Afficher « Passable »
12<= moyenne < 14 : Afficher « A. Bien »
14<= moyenne < 16 Afficher « Bien »
16<= moyenne Afficher « T. Bien »

=SI(A1<10,"Faible",si(A1<12,"Passable",si(A1<14,"ABien",si(A1<16,"Bien", "T.Bien"))))
=Si(A1<10,

"Faible" SI(A1<12,

"Passable" Si(A1<14,

"Assez Bien" Si(A1<16,

"Bien" "T.Bien"

1.8. Fonction « NB »
Rôle : Renvoie le nombre de cellules contentent des valeurs.
Syntaxe : =NB(plage)
Exemple : =NB(A1 :A20)

1.9. Fonction « NBVAL »


Rôle : Renvoie le nombre de cellules non vide.
Syntaxe : =NBVAL(plage)
Exemple : =NBVAL(A1 :A20)
1.10. Fonction « NB.SI »
Rôle : Définir le nombre des cellules selon un critère.
Syntaxe : =NB.Si(plage, critère)
Exemple : =NB.SI(A1 :A20,"< 10")

1.11. Fonction « CONCAT »


Rôle : Définir le nombre des cellules selon un critère.
Syntaxe : = CONCAT(text1,text2…)
Exemple : =CONCAT(A1, ‘’Bonjour’’,A3)

1.12. Fonction « ALEA.ENTRE.BORNES »


Rôle : Renvoie un entier aléatoire choisie entre les deux bornes spécifiées.
Syntaxe : = ALEA.ENTRE.BORNES(valeur_min ,valeur_max)
Exemple : ALEA.ENTRE.BORNES(1,99)
1.13. Fonction « RECHERCHEH »
- La fonction RECHERCHEH recherche une valeur donnée dans la première ligne de la base de
données fournie et donne l'information présente dans la ligne demandée.

Syntaxe : =RECHERCHEH(valeur_cherchée ; matrice ; ligne ; [valeur_proche] )

- ''valeur_cherchée'' est la valeur que l'on utilise pour trouver la ligne contenant l'information
désirée.
- ''matrice'' est la base de données dans laquelle chercher.
- ''ligne'' est la ligne contenant l'information que l'on désire extraire de la base de données.
- [valeur_proche] est un argument logique (Vrai ou FAUX) optionnel indiquant si l'on recherche
une valeur proche ou une correspondance exacte de la valeur_cherchée. Dans la très grande
majorité des cas, il est préférable de rechercher une valeur exacte, et donc, de mettre FAUX. La
valeur par défaut est cependant VRAI.

Exemple :

1.1. Fonction « RECHERCHEV »


- La fonction RECHERCHEV recherche une valeur donnée dans la première colonne de la base de
données fournie et donne l'information présente dans la colonne demandée.

Syntaxe : =RECHERCHEV(valeur_cherchée ; matrice ; colonne ; [valeur_proche] )


- ''valeur_cherchée'' est la valeur que l'on utilise pour trouver la ligne contenant l'information
désirée.
- ''matrice'' est la base de données dans laquelle chercher.
- ''colonne'' est la colonne contenant l'information que l'on désire extraire de la base de données.
- [valeur_proche] est un argument logique (Vrai ou FAUX) optionnel indiquant si l'on recherche
une valeur proche ou une correspondance exacte de la valeur_cherchée. Dans la très grande
majorité des cas, il est préférable de rechercher une valeur exacte, et donc de mettre FAUX. La
valeur par défaut est cependant VRAI.
IV. Mise en forme conditionnelle

- C’est une mise en forme appliquée sous certaines conditions.


- Elle permet de formater une formule en fonction du contenu d'une cellule, qu'il s'agisse d'un
contenu numérique, chaîne de caractères ou logique (vrai/faux).
- Par exemple, vous voulez que dans le tableau de chiffre d'affaires les valeurs supérieures à 2 500
euros soient mises en rouge.
- Comment faire : Menu « Accueil » puis « Mise en forme conditionnelle »

V. Les graphiques
- Permettent de :
o Simplifier l'analyse d'une masse de données.
o Ressortir rapidement les tendances des séries de données.
o Comparer les données.
o Ressortir des proportions.
- Comment faire :
o Sélectionner la plage de données.
o Utiliser l’assistant de création de graphiques. (Menu Insertion)

VI. Validation des données

- Permet de limiter le type de données ou les valeurs que les utilisateurs peuvent entrer dans une
cellule. Une des utilisations les plus courantes de la validation des données consiste à créer une
liste déroulante.
- Comment faire : Menu « Données » puis « Outils de données »

VII. Voir aussi


❖ Tableau croisé dynamique

- Un tableau croisé dynamique est un outil qui permet d'analyser un tableau constitué de très
nombreuses données pour le présenter sous une autre forme en comparant par exemple une
donnée par rapport à une autre. Il est dit dynamique parce qu'il se recalcule quasi
immédiatement après l'ajout ou la suppression d'une ou plusieurs données.

❖ Les Macros Excel

- Une macro est une série de commandes et d’instructions regroupées au sein d’une même
commande afin d’exécuter automatiquement une tâche.
- Intérêt : enregistrer un ensemble de manipulations pour pouvoir les relancer ultérieurement.
- Comment faire : Affichage > Macros > Enregistrer une nouvelle macro.

❖ La Programmation en VBA

- EXCEL VBA (Visual Basic pour Application) est un langage de programmation permettant
d’utiliser du code Visual Basic pour exécuter les nombreuses fonctionnalités de l’Application
EXCEL.
- Un programme écrit en VBA est souvent appelé une macro.
- Une macro peut être créée en utilisant l'enregistreur de macros, qui ne nécessite aucune
connaissance du langage VBA.