Vous êtes sur la page 1sur 34

Ministre de lenseignement suprieur et de la recherche scientifique

Institut Suprieur des Etudes Technologiques de Rads

Etude et Mise en Place dun rseau dune


haute disponibilit LAN et WAN
Ralis par : Mlle Ben Targem Leila
Mr Mahfoudh Mohamed Bilel
Encadr par : Mr Elmahroug Sofiene
Mr Abdelmalek Anis

2010/2011

Plan
Prsentation de la socit
Prsentation
Etude du besoin
Partie LAN
Partie WAN
Conclusion
3

Prsentation de la
socit
Cest lUnion Bancaire pour le Commerce et
lindustrie .
Son Sige se situe Tunis et ses deux cent
agences sont rparties sur toute la rpublique.
Elle bnficie dun accs direct au rseau mondial
du group BNP PARIBAS

Prsentation
Le Projet consiste mettre en uvre une solution de
communication unifie pour lUBCI en respectant les
contraintes suivantes:
Garantir la qualit de service

Assurer une haute disponibilit de service

Mise en place de protocole garantissant le basculement


vers des liaisons redondants.

Etude du besoin

Visioconfrence

VLAN

Accs rapide Internet

VPN

Transfert des donnes

MPLS

Transfert du voix
(VoIP )

QOS

UBCI

Partie LAN
Solution LAN Propose

Configuration des VLANs

Configuration du service DHCP

Configuration de VTP

D
E

Amliorer le protocole STP

Configuration des IP phones

F
7

Architecture LAN
existante

Solution LAN Propose

tage1

tage 2

tage 3

tage 4

Ralisation LAN

Cre
Creles
lesVLANs
VLANs

Activation
Activationde
deprotocole
protocoleRSTP
RSTP

Configuration
Configurationde
deprotocole
protocole
VTP
VTP

-- Vlan
Vlan Data
Data
-- Vlan
Vlan voix
voix
-- Vlan
Vlan admin
admin

Sw1# spanning-tree mode rapid-pvst

etage1#vlan
SwI#vlan
database
database
SwI(vlan)#vtp server
etage1(vlan)#vtp
client
SwI(vlan)#vtp domain
etage1(vlan)#vtp
domain
UBCI.com.tn
UBCI.com.tn

10

Ralisation LAN

Configuration
Configurationde
deprotocole
protocole
DHCP
DHCP

Siege
data
Voice
Siege (config)
(config) ## ip
ip dhcp
dhcp pool
pool Admin
Admin
data
Voice
Siege
10.142.2.1
22.142.2.1
Siege (dhcp-config)
(dhcp-config) ## network
network 11.142.2.1
10.142.2.1
22.142.2.1
11.142.2.1
255.255.254.0
255.255.254.0
Siege
Siege (dhcp-config)
(dhcp-config) #default-router
#default-router
10.142.2.1
22.142.2.1
11.142.2.1
10.142.2.1
22.142.2.1
11.142.2.1
Siege
Siege (dhcp-config)
(dhcp-config) #exit
#exit
Siege
Siege (config)#
(config)# ip
ip dhcp
dhcp excluded-address
excluded-address
10.142.2.1
22.142.2.1
11.142.2.1
10.142.2.2
22.142.2.2
10.142.2.111.142.2.2
22.142.2.1
11.142.2.1
11.142.2.2
10.142.2.2
22.142.2.2

Configuration
Configurationdes
desIP
IPphones
phones

Siege
(config)
#telephony)
## ephone-dn
Siege (config(config) telephony)
(config# telephony-service
telephony-service
ephone-dn 11
Siege
telephony)
max-dn
Siege (config(config- telephony)#
telephony) ##125
telephony)#
125
max-dn 55
Siege
Siege (config(config- telephony)
telephony) ## max
max ephones
ephones 55
Siege
Siege (config(config- telephony)
telephony) ## ip
ip source
source address
address
22.142.2.1
22.142.2.1 port
port 2000
2000
Siege
Siege (config(config- telephony)
telephony) ## auto
auto assign
assign 44 to
to 66
Siege
Siege (config(config- telephony)
telephony) ## auto
auto assign
assign 11 to
to 55

11

Partie WAN
A
Solution WAN propose

B
Configuration des liaisons MPLS

C
Configuration des liaisons VPN

D
L implmentation du protocol HSRP

12

Architecture WAN
existante

13

Problmatique

Convergence de diffrent
flux tels que voix, data

Et

Augmentation du
nombre dutilisateurs

Augmentation de la taille des tables de routages

Augmentation des temps de traitement et de traverse

14

Problmatique
Besoin de trouver une mthode plus
efficace pour la transmission de
paquets en garantissant la qualit de
service

MPLS
15

Solution WAN propose

Sige_VP
N

HSRP

Sige_MPLS

16

Maquette MPLS
10.10.10.0/3
0

10.10.10.4/30

10.142.249.0
/30

10.142.2.0/2
3

10.142.249.24/3
0

10.142.20.0/23

17

Implmentation de MPLS
1

Activation du routage IP classique

o Assignation des adresse IP par interface


o Assignation des adresse IP des loopback des routeur CE et PE
o Activation du routage IGP (OSPF)
Activation MPLS

o Activation de la commutation CEF


o Activation de la distribution des labels sur les interfaces participants
o Configuration de l IGP (OSPF)
Activation MPLS/VPN

o Configuration de VRF
o Assignation de VRF une interfaces
o Configuration de MP-BGP entre les PE
oConfiguration de OSPF par VRF
o Redistribution de MP-BGP en OSPF et OSPF en MP-BGP
18

Implmentation de MPLS
Extrait de configuration :
ip cef
mpls label protocol ldp
mpls ip
ip vrf site
rd 1:1
route-target export 1:1
route-target import 1:1
exit
interface Loopback 0
ip address 4.4.4.4
255.255.255.255
interface s1/0
ip address 10.10.10.5
255.255.255.252

Activation de la
commutation CEF
Activation de la
distribution de
label

Configuration dun
VRF

Assignation des
adresse loopback
Activation de la
distribution des labels
sur touts les interface
P et PE
19

Implmentation de MPLS
Extrait de configuration :
int s1/1
ip vrf forwarding site
ip address 10.142.249.26
255.255.255.252
router ospf 10 vrf site
redistribute bgp 1 subnets
network 10.142.249.26 0.0.0.0
area 0
exit
router ospf 1
network 4.4.4.4 0.0.0.0 area 0
network 10.10.10.5 0.0.0.0 area 0

Assignation de VRF
a une interface

Configuration de
OSPF par VRF
Redistribuer BGP
en OSPF
Configuration de
routage IGP
(OSPF)

20

Implmentation de la
QOS
Diffserv

QOS

DSCP
EF : Trafic voix
Haute priorit
BP: 80Kbits/s

AF: Best effort

21

Implmentation de la
QOS
Extrait de configuration :
Megrine(config)# class-map
match all voix
Megrine(config-cmap)# match ip
rtp 16383 16000
Megrine(config-cmap)# exit
Megrine(config)# policy map out
policy
Megrine(config-pmap)# class
voix
Megrine(config-pmap-c)# set
dscp ef
Megrine(config-pmap-c)# priority
80
Megrine(config-pmap-c)#exit
Megrine(config-pmap)#class
class-default
Megrine(config-pmap-c)# set ip
dscp default

Dfinir une classe


pour notre stratgie
de QOS
Assur le transfert
de la voix (EF)
Lalgorithme traite
en priorit la voix et
lui garantie au
moins 80kbits/s de
la bande passante
Assur le transfert
des donnes (best
effort )

22

Configuration des liaisons


VPN
1

Mettre en place les Tunnels entre les deux sites


( dfinition des interfaces virtuelles).

Crypter les Tunnels.

Mettre en place le routage intersites

23

Dfinition de linterface
virtuelle
interface Tunnel1
ip address
172.16.254.2
255.255.255.252
tunnel source
Serial1/1
tunnel destination
10.142.245.1
24

Cryptage du tunnel

crypto isakmp policy 2


authentication pre-share
lifetime 3600
crypto isakmp key UBCI
address 10.142.245.2
crypto ipsec transform-set
transfdes esp-des
crypto map cryptvpn 2
ipsec-isakmp
set peer 10.142.245.2
set security-association
lifetime kilobytes 102400
set security-association
lifetime seconds 900
set transform-set transfdes
25
match address cryptolist

Routage intersites

router ospf 20
log-adjacencychanges
network 10.142.2.0
0.0.1.255 area 0
network
10.142.245.24
0.0.0.3 area 0
network
172.16.254.0 0.0.0.3
26
area 0

Les accs Listes


ip access-list extended cryptolist
permit gre host 10.142.245.1 host 10.142.245.2
ip access-list extended natlist
deny ip 10.142.2.0 0.0.1.255 10.142.20.0 0.0.1.255
permit ip 10.142.2.0 0.0.1.255 any
ip access-list extended netin
permit tcp any host 10.142.245.1 established
permit udp any eq domain host 10.142.245.1
permit tcp any eq www host 10.142.245.1
permit tcp any eq 443 host 10.142.245.1
permit udp host 10.142.245.2 eq isakmp host 10.142.245.1
eq isakmp
permit esp host 10.142.245.2 host 10.142.245.1
ip access-list extended netout
permit udp host 10.142.245.1 any eq domain
permit tcp host 10.142.245.1 any eq www
permit tcp host 10.142.245.1 any eq 443
permit tcp any eq 443 host 10.142.245.1
permit udp host 10.142.245.1 eq isakmp host 10.142.245.2
eq isakmp
permit esp host 10.142.245.1 host 10.142.245.2

27

Implmentation du protocole
HSRP

Sige
Sige VPN
MPLS
standby
standby 11 ip
ip
10.142.2.3
10.142.2.3
standby
standby 11 priority
priority
100
110
standby
standby 11 preemp
preemp

28

Implmentation du protocole
HSRP
Scnario 1

29

Implmentation du protocole
HSRP
Scnario 2

30

Implmentation du protocole
HSRP
Scnario 3

31

Implmentation du protocole
HSRP
implmentation du paramtre track

interface FastEthernet 2/0


standby 1 track
FastEthernet 2/1 3
standby 1 track serial 1/0
standby 1 1 track serial 1/
3

32

Conclusion
A travers ce projet nous avons mis en place une solution
dinterconnexion LAN qui supporte la tlphonie IP et
tolrante aux pannes.

Nous a avons Implment une nouvelle architecture WAN


hautement disponible en garantissant la qualit de service
et tolrante aux pannes en prvoyant un basculement
automatique entre quipements en cas de problme.

Un tel rseau dans son ampleur a besoin dun outil de


supervision ce qui lui fait dfaut, pour ce la il faut penser
mettre en place un outil qui assure la scurit daccs au
rseau LAN par exemples des firewalls.
33

34