Vous êtes sur la page 1sur 234

Architecture

ISEP 2007– A3

Partie 2
 SOMMAIRE

 1. Architecture Ethernet/ LAN (hors WiFi supposé traité par


ailleurs)

 2. VLAN
 3. SAN /NAS
 4. Architecture WAN
FORMAT DES ADRESSES MAC ETHERNET Couche MAC
(bits)
24 24
0000.0C xx.xxxx
IEEE Fabricant

COUCHE MAC ETHERNET


(octets)
8 6 6 2 variable 4
Préambule Adr dest Adr src Type Données FCS

COUCHE MAC 802.3


(octets)
8 6 6 2 variable 4
Préambule Adr dest Adr src Longueur 802.2 FCS
Ethernet

méthode d’accès CSMA/CD

Niveau liaison (couche 2 du modèle ISO)


Note : La couche physique = émission/réception en ligne sur
Codage Manchester – à détailler

La méthode d'accès sur Ethernet est appelée CSMA/CD


(Carrier Sense Multiple Access / Collision Detection ).

C'est une technique de gestion des conflits (contention)


Elle ne donne pas un accès exclusif au canal (comme le
polling ou le jeton) mais essaye d'éviter les conflits.
*CS : Carrier Sense, capacité à détecter tout trafic sur le canal
(Ecouter avant de parler), s'il y a trafic on ne tente pas
l'émission, …
mais à cause des temps de propagation du signal, deux stations
peuvent émettre en même temps c'est ce qu'on appelle une
collision.
* MA : Multiple Access, chaque station a potentiellement accès
au canal lorsqu'elle a besoin d'émettre… mais il faut que le
canal soit libre, il n'y a pas d'attente d'attribution comme dans le
cas du polling ou du jeton ( pour lesquels, il faut attendre
“ l'autorisation ” même si le canal est libre).
*CD : Collision Detect, c'est la capacité d'un noeud émetteur à
détecter le changement de niveau d'énergie et de l'interpréter
comme une collision : Ecouter pendant que l'on parle et arrêter
de parler si une autre station parle.
Note : il existe un protocole CSMA/CA (collision avoidance), utilisé notamment en 802.11 – cf chapitre wireless
qui suit
Protocoles couches physique et liaison

Couche ISO Protocole


2 IEEE 802.1 : services complémentaires

2 IEEE 802.2 LLC Logical Link Control :


interface avec les couches supérieures (unique pour les différents niveaux MAC)

2 IEEE 802.3 MAC Medium Access Control

1 Physique
Transmission d'une trame : La couche MAC reçoit de la
couche LLC des données à émettre; son rôle consiste à:

ajouter préambule et SFD aux données de la couche


LLC,
ajouter le padding si nécessaire,
ajouter les champs adresse source, adresse
destinataire, longueur/type des données,
calculer le CRC et l'ajouter à la trame,
si le signal "Carrier Sense" est faux depuis au moins
9.6µs (espace inter-trame à respecter), transmettre la
trame bit à bit à la couche physique,
sinon attendre que le signal "Carrier Sense" soit faux,
attendre 9.6 µs et transmettre bit à bit à la couche
physique.
Réception d'une trame : La couche MAC effectue:
écoute du signal "Carrier Sense",
réception des bits depuis la couche physique,
élimine le préambule, le délimiteur de début de trame
(SFD),
élimine éventuellement le padding,
examine l'adresse destination dans la trame et si celle-
ci inclut la station :
calcule la séquence de contrôle et indique une erreur:
si la séquence est erronée,
si la trame n'est pas un nombre entier d'octet
(alignment error),
si la trame > 1526 octets (préambule/SFD compris)
si la trame < 64 octets (trame victime de collision).
Si OK, transmet les champs à la couche LLC,
La sous-couche LLC
normalisée IEEE 802.2
commune aux normes IEEE 802.3, 802.4 (token
bus), 802.5 (token ring).
Interface LLC / MAC = service sans connexion
requête d'émission de données (LLC vers MAC),
primitive d'indication de données (MAC vers LLC),
primitive de confirmation d'émission de données
(MAC vers LLC).
Etude détaillée d’une communication

L'émission d'un paquet est déclenchée par une demande des


couches supérieures d'un noeud. Le noeud passe les données,
adresse destination, le format des données (type de protocole) à la
couche liaison.
La couche liaison place les informations dans les champs
correspondants et ajoute le FCS (Frame Check Sequence error).
Avant d'émettre, la couche liaison essaye d'éviter les conflits en
gérant le signal "détection de porteuse" fourni par la couche
physique.
Quand le canal est libre, la couche liaison passe le paquet à
émettre à la couche physique sous forme d'une série de bits (flot).
La trame est précédée d’un préambule codé qui permet aux
noeuds récepteurs de synchroniser leur horloge, ensuite la couche
physique commence à traduire les bits du paquet en code
Manchester et génère les signaux électriques sur le câble coaxial.
La couche physique d'un noeud en cours d'émission,
gère le canal pendant toute la durée de l'émission. En
d'autres termes, elle gère le niveau d'énergie (niveau du
signal électrique).
La couche physique connaît la valeur du niveau
d'énergie pendant une émission sans conflit. S'il y a
conflit (plusieurs émissions simultanées) il y a alors plus
d'énergie sur le canal et la couche physique fait monter
le signal "collision détectée".
Important : Ce signal ne peut être détecté que par un
noeud en cours d'émission.
Quand l'émission sans conflit est terminée, la couche
liaison prévient les couches supérieures et attend de
nouvelles demandes d'émissions
Réception sans conflit

Quand un noeud est en cours d'émission, les couches physiques


des autres noeuds détectent sa porteuse, et avertissent leur
couche liaison pour qu'il n'y ait pas de tentative d'émission. A cet
instant tous les autres noeuds du réseau sont récepteurs. Les
couches physiques des noeuds récepteurs se synchronisent sur
le préambule, reçoivent les signaux en code Manchester et les
traduisent en binaire en éliminant le préambule.
Le flot de bits est passé à la couche liaison (sur chaque noeud)
qui avait été avertie de l'arrivée par le signal "détection de
porteuse". La disparition du signal détection de porteuse indique
la fin du paquet. (Il est donc inutile de transmettre la longueur du
paquet).
Important : la couche liaison observe l'adresse
destination "au vol" pour savoir si le paquet est destiné
à ce noeud, si c'est le cas, elle teste la validité et passe
le paquet aux couches supérieures, si ce n'est pas le
cas, l'envoi du flot de bits à la couche liaison est arrêté
après le préambule et adresse destination et le paquet
n'est pas accepté.

Cela se passe au niveau du matériel (adaptateur Ethernet),


le logiciel correspondant aux couches supérieures n'est pas
"pollué" par des paquets qui ne sont pas destinés à ce
noeud, ou les paquets erronés...
Principe général d’une collision - Résolution des conflits

Il peut arriver que deux ou plusieurs noeuds s'aperçoivent que le


canal est libre et commencent à émettre à peu près en même
temps, leurs émissions se superposent et interfèrent, c'est que
l'on appelle une collision.
Un noeud peut détecter une collision pendant sa fenêtre de
collision (collision window) - intervalle de temps avant que le
signal puisse aller d'un bout à l'autre du réseau et revenir
[tranche canal (Slot Time)].
Temps maximum de détection : temps d’un aller-retour entre 2
nœuds les plus éloignés.Il y a donc un compromis entre la taille
maximale d’une trame et donc son temps d’émission et la
longueur maximale du réseau.. La durée d’émission d’une trame
de taille minimale doit être supérieure à la durée d’un aller retour
sur le réseau.
Une fois que la fenêtre de collision est passée, le noeud est
réputé avoir "acquis le canal" car à ce moment-là, tous les
noeuds fonctionnant correctement devraient avoir détecté la
porteuse et différé leur émission.
La taille minimale du paquet Ethernet de 64 octets pour une
raison bien définie : le slot time est plus grand que le temps
nécessaire à émettre 64 octets à 10 Mb/s sur un réseau
Ethernet de taille maximum (2,8 Km entre les deux noeuds
les plus éloignés).
Soit un noeud A et un noeud B aux extrémités d'une configuration
de taille maximale (2,8 km).
Le noeud A envoie un paquet. Juste avant que ce paquet n'arrive
au noeud B, le noeud B commence à émettre son propre paquet
puisqu'il n'a pas encore détecté le paquet du noeud A. La taille
mini de 64 octets est spécifiée pour que le signal de collision
détecté au noeud B ait le temps d'atteindre le noeud A pendant
que celui-ci est encore d'émettre le même paquet ; c'est la
seule façon que le noeud A a pour associer le signal de collision
au paquet qu'il a émis (niveau d’énergie spécial du à la
superposition). Si le noeud A avait reçu le signal de collision après
qu'il ait fini d'émettre, il n'aurait pas pu associer la collision avec
son émission car les noeuds ne reconnaissent la collision que
lorsqu'ils sont en cours d'émission (Energie). Par conséquent il
n'aurait pas réémis le paquet, celui-ci n'aurait pu être réémis qu'à
la suite d'une demande des couches supérieures (perte de
temps).
Ethernet est conçu pour délivrer les paquets avec le
moindre effort en éliminant les besoins de
complication des couches supérieures.

Quand une collision se produit pendant l'émission, la couche


physique du noeud émetteur envoie le signal de détection de
collision à la couche liaison qui initialise la procédure de gestion
des collisions:
- Le paquet en cours d'émission est prolongé pendant un bref
instant par l'émission d'un brouillage (JAM) de 32 bits pour
s'assurer que tous les autres noeuds émetteurs concernés par
cette collision la détectent bien.
-La couche liaison arrête l'émission et programme une tentative
de réémission : le noeud attend un multiple entier du slot time
avant de réémettre. Le multiple est tiré aléatoirement dans
chaque noeud concerné par la collision. Si une autre collision se
produit, le noeud augmente le temps d'attente ,par un facteur 2,
à partir du nombre aléatoire tiré à la 1ère collision, jusqu'à la
dixième tentative ensuite le temps n'est pas augmenté.
- On s'arrête en général à 16 tentatives, au delà on déclare le
canal hors service ou saturé. La trame est perdue, on n'avertit
pas les couches supérieures (ce sont elles qui doivent s'en
apercevoir ....)
Sur tous les noeuds récepteurs les bits d'une collision sont
décodés par la couche physique comme s'ils appartenaient à un
paquet valide (car le signal de détection de collision n'est pas
reconnu par les noeuds récepteurs).
La couche liaison fait la différence entre les paquets incomplets
résultants d'une collision et les paquets valides grâce à la taille
du paquet : un fragment est toujours plus petit que la taille mini
du paquet Ethernet (64 octets). Les paquets fragmentés ne sont
pas acceptés par la couche liaison.

Exercice (trivial) : vitesse de propagation du signal = 0,77c, taille


minimale de la trame = 64 octets.
Quelle est la longueur théorique maximale d’un cable Ethernet
10 Mb/s coaxiale ?
Pourquoi n’est-ce que théorique (dans la pratique 2,8 kms) ?
Limites
non déterministe (pas temps réel), non linéaire

Erreurs

runt (trames trop courtes) indicatifs d’une possible collision,


jabber (trames trop longues),
erreur de checksum, …
Collisions - Détails

Lors d'une émission la station envoie un niveau d'énergie sur le


canal, elle "écoute" en même temps, si le niveau d'énergie
"entendu" est supérieur à celui émis c'est qu'une autre station
émet en même temps.
Soient deux stations S1 et S2 voulant respectivement émettre
les messages M1 et M2.
S1 émet le message M1 qui met un temps T1 pour arriver en S2,
S2 émet M2 juste avant que le message M1 n'arrive (à un
instant T <T1), quand M1 arrive en S2, S2 détecte
immédiatement la collision et s'arrête d'émettre mais le début du
message M2 continue sa vie et arrive en S1, si S1 a fini
d'émettre son message elle ne s'aperçoit pas qu'il y a eu
collision (elle ne s'aperçoit pas que le message M2 qu'elle reçoit
est incomplet).
Pour éviter cela il faut que le message ait une longueur telle
que son émission dure au moins le temps que met le signal
pour faire un aller retour sur le câble (il faut que S1 n'ait pas fini
d'émettre quand M2, émis par S2 arrive en S1), c'est le temps
d'aller retour (Round Trip Delay). Lorsqu'une station a réussi à
émettre pendant une durée égale à la tranche canal (Slot Time)
définie comme un majorant du temps aller retour, elle est
réputée avoir acquis le canal (elle ne peut plus être interrompue
- toutes les stations ont entendu son émission et s'abstiennent
d'émettre).
Lorsqu'une station a détecté une collision elle prolonge son
émission par un signal de brouillage (JAM) pour avertir les
autres stations.
La vitesse de propagation du signal électrique est de l'ordre de
0,77 C (C = vitesse de la lumière dans le vide) 0,77 x 3 x 108
m/s 230 000 km/s
A 10Mbits/s un bit occupe le signal électrique pendant 1/(10 x
106)s soit 0,1 us c'est ce qu'on appelle la durée d'un bit (Bit
Time) ou BT.
Comme le signal se déplace à 230 000 km/s, un bit occupe
donc 2,3 x 108 x 10-7 = 23m sur le câble.
Sur un câble de 500m on peut "mettre" 500/23 = 22 bits, à un
instant donné, qui occuperont le câble pendant 22/(10 x 106) =
2,2 us.
La norme Ethernet fixe le temps d'aller retour (round trip
delay) entre deux émetteurs récepteurs les plus éloignés à
51,2us (512 BT soit 64 octets), ce qui permet au signal un aller
retour: 230x106x51,2x10-6 =11776 m, soit un réseau de 5888 m
maximum sur un seul câble coaxial.
Pour des raisons d'atténuation le signal doit être régénéré tous les
500 m, en effet la détection de collisions nécessite la
différenciation d'un signal de la superposition de 2 signaux (la
superposition de 2 signaux affaiblis pourrait avoir la même énergie
qu'un signal non affaibli). Pour régénérer le signal on utilise des
répéteurs qui induisent un retard, compte tenu de cela (et des
performances des circuits électronique en 1980) la taille maximale
d'un réseau Ethernet a donc été fixée à 2800m au lieu de 5888m
Ceci a conduit à des contraintes sur l’architecture des “anciens”
réseaux Ethernet: pas plus de 4 répéteurs ou hubs entre 2stations.
Aujourd’hui l’utilisation massive de commutateurs fait que ces
règles n’ont plus lieu d’être.La taille maximum d'un paquet est
fixée à 1500 caractères pour ne pas pénaliser les temps d'accès et
limiter les mémoires tampons des émetteurs-récepteurs.
Pour être sûr de détecter les collisions il faut que les messages
émis à 10 Mbits/s aient au moins une longueur de 512 bits soit 64
octets (préambule exclu).
Adressage MAC

Codage constructeur sur les 6 1ers caractères, ARP (notion)


Toutes les stations "entendent" tous les paquets passant sur le
câble, il est donc nécessaire d'inclure un champ adresse de
destination dans chaque paquet, et donc une adresse source
(pour adresser les réponses) pour éviter que le logiciel soit
interrompu par chaque paquet passant par le réseau, les
adaptateurs filtrent les paquets et ne transmettent (au logiciel) que
les paquets dont l'adresse de destination correspond à leur propre
adresse.
En fait, le constructeur reçoit une adresse (12 caractères hexa-
décimaux ou 6 octets) dont les trois premiers octets sont fixés, les
trois suivants étant laissés à sa libre utilisation.
La partie fixe de l'adresse est appelée code fabricant (Vendor
Code) ou OUI (Organizationally Unique Identifier). Cette
appellation est un peu abusive car un fabricant peut acheter
plusieurs blocs d'adresses et également "donner" ses
adresses à un autre constructeur.

Exemple : 00-00-0C CISCO


00-00-0E Fujitsu
00-00-1B Novell
Toute adresse Ethernet doit être unique dans le monde. Les
adresses étaient attribuées par le consortium (DEC, INTEL,
XEROX) aux fabricants de contrôleurs Ethernet. C'est
maintenant l'IEEE qui distribue ces adresses (1000 $ pour 224
adresses)
Un contrôleur a une adresse fixée à la fabrication (dans la
plage précédente), c'est l'adresse matérielle (Hardware
Address ou build-in address). Avec certaines cartes, on peut
leur affecter une adresse “ logicielle ”. Le client , utilisateur final,
doit alors garantir l’unicité des adresses MAC (à proscrire :
risque d’erreur, lourdeur de gestion lors des changements de
cartes, …- voir exemple du token-ring).

- Adresse universelle (Broadcast Address) : elle a pour valeur


FF-FF-FF-FF-FF-FF, elle représente toutes les machines du
réseau. Ce système d'adressage est très important car il
permet d'envoyer une information à toutes stations en une
seule émission.
Ses rôles …
Trame Ethernet
Description de la trame Ethernet

Préambule : nécessaire à la synchronisation des noeuds


récepteurs 7 octets contenant chacun 10101010 ce qui fournit
pendant 5,6 us une onde rectangulaire permettant d'acquérir la
synchronisation bit.
SFD :Un octet contenant 10101011 (SFD Starting Frame
Delimiter) permettant d'obtenir la synchronisation bit et la
synchronisation caractère. Cette synchronisation est nécessaire
car aucun trafic n'existe lorsque les stations n'ont rien à
transmettre et il n'y a aucune raison pour que les horloges des
différentes stations restent synchronisées.
Il faut ajouter 9,6us minimum de silence entre deux paquets pour
permettre la stabilisation électrique des circuits de réception et
l'émission éventuelle des autres stations.
Adresse destination : c'est l'adresse de la station réceptrice (12
caractères hexadécimaux soit 6 octets)
Adresse source : c'est l'adresse de la station qui a émis le
paquet.
Type : plusieurs protocoles sont véhiculés sur Ethernet, ce champ
permet d'identifier le protocole de niveau 3 et est utilisé par les
couches supérieures pour identifier le format des données.
Exemple :
00 01 02 f6 f0 71 00 06 d7 ee 34 2d suivi de 08 00 = type IP sur 2
octets
Remarque: La longueur des données n'est pas nécessaire
pour le récepteur car les débuts et fins de paquets se
déduisent respectivement de la fin du préambule (2 bits
consécutifs à 1) et de la chute de porteuse au dernier bit,
d'autre part les longueurs de autres champs sont fixées.

C’est une différence entre le standard de fait


Ethernet et la norme IEEE 802.3 où le protocole
est codé différemment. En 802.3, il s’agit ce
champ représente la taille de la zone de
données.
Données : Si les données fournies par la couche 3 sont
inférieures à 46 (soit 64 – 6 – 6 – 2 - 4) octets elles sont
complétées par une séquence de bourrage (PAD ou padding) :
la différenciation entre les données utiles et le PAD doit se faire
par les couches supérieures (non conforme au modèle en
couches: les données élaborées à un niveau sont traitées à un
autre niveau)

FCS : Frame Check Séquence, c'est un CRC (Cyclic


Redundancy Check) de degré 32 codé sur 4 octets
A décrire …
Historique : 10 Base 2, 10 Base 5, 10 Base T (AUI, BNC, DIX)
Ethernet 10 base 5 (Thick Ethernet)
Coaxial “ jaune ”
Noeud : entité adressable (transceiver + contrôleur).
- Max 1024 noeuds, sur tout le réseau.
- Un segment <500 m chaque extrémité est terminée par une résistance pour
éviter la réflexion du signal (50 ohms ).
- Un segment doit être connecté à la terre en un seul point.
- Moins de 100 noeuds sur un segment, les noeuds sont séparés par au
moins 2,5 m
Connectique carte : AUI ou DIX (Sub D15) – voir ancienne carte Ethernet 10
Base 5 ou carte Combo
Prises vampires, cable jaune (entretien avec colle spéciale…)
Drop cable (< 50 m)
Nombreux défauts : fragilité du réseau entier – single point failure, câblage
difficile : rayon de courbure à observer
Exploitation très difficile (isolation du défaut, réflectomètre, …)
Ethernet câble fin 10 BASE 2 (Thin Ethernet)

Le transceiver est intégré à la carte adaptateur.


Longueur limitée à 185 m (200 m en arrondissant)
La longueur dépend du délai de propagation, du facteur de bruit
sur le câble et des restrictions dues à la logique des contrôleurs
et transceivers.
- un segment < 185 m terminé à chaque extrémité par un
résistance d’adaptation (“ bouchon ”) .
- 30 stations sur un segment, 50 cm entre chaque station.
-pas de branche, pas de boucle, les connecteurs T doivent se
brancher directement sur les stations.

PB : insertion d'une station provoque une rupture de


communication sur le segment.
Non adapté aux grands réseaux
“ Amélioration ” : Autoshunt (prix élevé)
Notion de transceivers :

10 Base 2 – 10 Base 5
10 BASE 5 – 10 Base T
10 Base T – 10 Base F
ou adaptateur 10 Base 2 – 10 Base T

Différence de principe (et de prix) entre les transceivers


simples (conversion) et les transceivers +
amplificateurs.
Ethernet sur paire torsadée 10 BASE T

Réseau étoile (hub actif nécessaire au centre de l’étoile)


Un segment < 100m
une seule station par segment
câble 4 paires (2 paires utilisées, une paire émission + une
paire réception)
Caractéristiques 10 BASE T :Auto partitionnement
vitesse de propagation du signal différente : 0,59C.
Un segment 10 BASE T est défini comme un segment de
liaison (Link segment) lui même défini comme un segment
point à point potentiellement "full duplex" qui connecte
seulement 2 extrémités. Dans ce contexte "full duplex" signifie
simplement qu'il y a 2 supports physiques distincts pour
l'émission et la réception. (La méthode d'accès CSMA/CD est
par définition "half duplex".)
Fast Ethernet

100 Mb/s = Fast Ethernet


Même méthode d’accès CSMA/CD

Réseau étoile seulement

Initialement 2 standards:
100 Base TX sur 2 paires – câblage catégorie 5 (identique
au 10 Base T classique : utilise la norme ISO 8877)
100 Base T4 sur 4 paires : non déployé à grande échelle –
câblage < cat. 5

A ce jour, la quasi-totalité des cartes, switches sont 10/100


voire 1000 Mb/s.
Gigabit Ethernet

Gigabit Ethernet : la suite logique de l'évolution des normes


Ethernet 10 Mbps et Fast Ethernet 100 Mbps.

Le standard :
C'est sous le nom de IEEE802.3z qu'ont été ratifiées en Juin
1998, les règles qui régissent le standard gigaEthernet :
Operation en mode Half & Full-Duplex à 1000 Mbps
Utilisation des trames standard Ethernet (comme Ethernet et
Fast Ethernet)
Utilisation du mode CSMA/CD (Carrier Sense Multiple Access/
Collision Detection) avec support d'un répéteur par domaine de
collision.
Compatibilité avec les adressages Ethernet et Fast Ethernet
Lors de la ratification des normes en Juin 1998 ont été définies
plusieurs standards.

Un autre comité nommé IEEE802.3ab a ratifié un standard


1000Base-T pour paires torsadées. Enfin, un autre type de
transmission nommé 1000Base-LH répond à des spécifications
multi-constructeurs qui ont été précisées afin d'autoriser des
distances supérieures à celles spécifiées dans la norme
1000Base-LX.

1000BASE-SX : "S pour Short wavelength (onde courte)" spécifie les fibres et
transmetteurs à utiliser. La fibre doit être de type multimode et avoir une
longueur d'onde comprise entre 770 et 860 nm (habituellement appelée
850 nanomètres). Selon le diamètre de la fibre (50 ou 62.5 microns) et la
bande passante au kilomètre), les distances maximales peuvent atteindre 220
à 550 mètres. Le tableau suivant décrit ces variations :
Diamètre Bande Distance
Type fibre fibre Passante Maxi
(microns) (MHz * Km) (mètres)
Multimode 62.5 160 220
Multimode 62.5 200 275
Multimode 50 400 500
Multimode 50 500 550
1000Base-LX : "L pour Long wavelength (onde longue)". La
fibre peut-être de type monomode our multimode. La
longue d'onde doit être comprise entre 1270 et 1355
nanomètres. (habituellement 1350 nm).

Il est à noter que plus la bande passante est importante et


plus la distance de liaison peut être augmentée. Les
spécifications du comité IEEE 802.3z sont particulièrement
conservatrices face à des conditions d'environnement et
d'utilisation normales, il n'est pas rare que des distances trois
à quatre fois supérieures à celles définies sous dessous
fonctionnent parfaitement.
Diamètre Bande Distance
Type fibre fibre Passante Maxi
(microns) (MHz * Km) (mètres)
Multimode 62.5 500 550
Multimode 50 400 550
Multimode 50 500 550
Monomode 9 --- 5000
.1000Base-LH : "LH pour Long Haul (Longue distance). Mêmes si les
spécifications 1000Base-LH ne sont pas couvertes par un standard
IEEE, de nombreux constructeurs proposent des transmetteurs
autorisant des distances plus étendues, mais qui restent compatibles
avec le standard 1000Base-LX. Les architectes réseaux , s'ils doivent
se préoccuper des niveaux d'atténuation des fibres utilisent, peuvent se
servir de ces transmetteurs afin d'atteindre des distances de 10 à 40
Kilomètres .

.1000 Base ZX : distance jusqu’à 70 kms en fibre mono-mode ;


connectique SC pour le 1 Gb/s fibre.

.1000Base-T : Ces spécifications autorisent la transmission de


données à 1000 Mbps sur une distance maximale de 100 mètres et à
l'aide de câbles paires torsadées non blindés de catégorie 5, déjà
utilisé dans le câblage Fast Ethernet 100 Mbps.
Standard IEEE 802.3ab

Le standard IEEE 802.3ab ou 1000 Base T a été approuvé le


26 juin 1999, il permet des liaisons GIGABIT Ethernet jusqu' à
100 mètres en utilisant les 4 paires d'un câble cuivre de
Catégorie 5.

Le câblage Catégorie 5 est définit par les normes


ANSI/TIA/EIA568-A et ISO/IEC 11801:1995.
Architecture Ethernet

Caractéristiques des switches


Administrable (O/N)
Notion de pile (stackable)
Connexion des hub/switch au sein d’une même pile : propriétaire
Avantages : modularité, prix, ajout/remplacement en cas de
panne
Trunking, STP, gestion des VLAN, port mirroring, port
enable/disable, …

Exemple d’ architecture classique


Différentiateur des offres : empilable ou stackable, administrable
(sous SNMP) ou non

Distinguer:

équipements des réseaux capillaires (LT d’étage) : standalone,


empilable

équipements backbones : chassis modulaire avec des cartes


Giga optique vers les LT d’étage, Giga cuivre vers les serveurs
centraux.
Offre constructeur (cartes et switches)

Présentation des “ familles ” Catalyst Cisco et 3 Com Link switch


Chassis en switch backbone (famille Linkswitch 3COM ou
Catalyst 65xx Cisco, Accelar Nortel)
Boitier standalone (avec éventuellement modules
complémentaires) dans les locaux techniques secondaires.

Canaux de distribution très mouvants:


Acteurs: Constructeurs, Grossistes (absent des gros projets)
Gros revendeurs (“ VAR ”), Petits revendeurs (resellers)

Importance des certifications et du volume sur les niveaux de


remise
Phénomème semblable à la distribution des PC : Le rôle des
revendeurs disparaît. La vente en direct s’effectue de manière
cachée …
10 Gigabits

Alliance 10 Giga Ethernet pour de l’Ethernet étendu


Norme 802.3 ae à l’état de draft
Constructeurs impliqués : 3Com, Cisco Systems,
Extreme Networks, Intel, Nortel Networks, Sun
Microsystems, …
Nouvelle interface physique : XAUI (prononcer Zowie)
Applications très larges : LAN, SAN, WAN, MAN
Standard : 2002
Sortie des premiers produits dès 2003
Cisco example

Q1 2004: Cisco has announced support for 10GBASE-


CX4, 10 Gigabit Ethernet over Copper technology (15m ,
600 $) : norme IEEE 802.3ak

And availability of 10GBASE-LX4 and 10GBASE-SR


XENPAK Modules 10 Gigabit Ethernet over Multi-Mode-
Fiber (MMF) … about 4000 $

These new XENPAK interfaces are supported on


Catalyst 6500 and Catalyst 3750.
le 10 Gigabit Ethernet peut être obtenu sur fibre
optique avec une portée de plusieurs dizaines de
kilomètres, moyennant un coût élevé, et sur câble
twin-axial en cuivre (CX4), mais limité à 15 mètres.

802.3ak specification uses four transmitters and four


receivers operating differentially over a bundle of
very thin twin-axial cables to transmit 2.5G bit/sec
each at a baud rate of 3.125 GHz per channel with
8B10B coding. This requires four differential pairs in
each direction for a total of eight twin-axial channels
per assembly
Le groupe de travail IEEE 802.3an cherche à définir une
norme 10 Gigabit Ethernet (10GBase-T) sur paire
torsadée de cuivre, afin de couvrir une distance de 100
mètres à faible coût.

Il prévoit de finaliser ses travaux courant 2006, car les


problèmes à régler en termes de diaphonie (énergie
rayonnée par les câbles adjacents) sont nombreux.
10 Gigabit Ethernet LANs, MANs, and WANs
Historique d ’Ethernet
10 Gigabit Ethernet Performance

10 Gbps
10 Gbps
OC-192 Ethernet
Gigabit EtherChannel • LAN applications
• Metro applications
1 Gbps Gigabit Ethernet • WAN applications
10 Gb
Fast EtherChannel Ethernet IEEE
802.3ae
Standard
100 Mbps Fast Ethernet

1996 1997 1998 1999 2000 2001 2002


Fiber and Ethernet
IEEE 802.3ae Task Force Milestones

Cisco Delivers
10 GbE

1999 2000 2001 2002

HSSG PAR First Working LMSC


Formed Drafted Draft Group Ballot
Ballot
PAR 802.3ae Standard
Approved Formed

• HSSG (Higher Speed Study Group) • Working group ballot—task force submits
• PAR (Project Authorization Request) complete draft to larger 802.3 committee for
technical review and ballot
• 802.3ae—the name of the project
and the name of the sub-committee of • LMSC—LAN/MAN Standards Committee ballot;
IEEE 802.3 chartered with writing the 10 any member of the superset of 802 committees
Gb Ethernet standard may vote and comment on draft
Why 10 Gigabit Ethernet?

 Aggregates Gigabit Ethernet segments


 Scales enterprise and service provider
LAN backbones
 Strategic advantage (leverage) installed base of 250 million Ethernet
switch ports
 Supports all services (data, voice, and video) and IP
 Supports metropolitan and wide-area networks
 Faster and simpler than other alternatives
VLAN: réseaux locaux virtuels

Les besoins

Trafic en forte croissance (contrôle nécessaire des trames de


broadcast ARP ou autres)

Nécessité de sécurité (par isolation de groupes d’utilisateurs


accédant à une ressource)

Connectivité contrôlée entre les groupes d’utilisateurs

Simplification de l’exploitation réseau (diminution du nombre de


reconfigurations physiques – locaux et baies de brassage)

Faire la différence entre réalité et argument commercial


Cela impose d'augmenter:
Les performances, par une gestion plus rigoureuse
du trafic.
La sécurité, par la possibilité de définir des groupes
logiques et des règles de communication entre ces
groupes.
(Le débit en certains points du réseau)

Un moyen : les VLAN (segmentation d’un LAN


physique en plusieurs LAN logiques)

A partir de quelle taille de réseau, peut-on


avantageusement implémenter des VLAN :
Selon les constructeurs : 200 postes … voire moins.
Pas de règle (le nombre de postes d’un LAN n’est pas le
seul critère)… mais …
La sécurité peut s’implémenter par d’autre moyen que les
VLANs … et des réseaux de 2000 postes peuvent
fonctionner efficacement sans découpage en VLAN

Ne pas oublier le coût d’une mise en place de VLAN


(investissement puis fonctionnement)
Les réseaux virtuels (VLAN : Virtual Local Area Network)
permettent de réaliser des réseaux axés sur l’organisation de
l’entreprise en s’affranchissant de certaines contraintes
techniques comme la localisation géographique.

L'utilisation de VLAN permet:


.D'augmenter les performances globales du réseau
grâce à une meilleure gestion du traffic administratif.
.D'augmenter la sécurité par cloisonnement des
différents groupes de travail. Des équipements
appartenent à deux VLAN différents ne peuvent pas
communiquer ensemble.
Les VLAN introduisent la notion de segmentation
virtuelle, qui permet de constituer des sous-réseaux
logiques en fonction de critères prédéfinis comme les
adresses MAC ou les numéros de ports de façon
statique ou dynamique, les adresses IP.

Les échanges à l’intérieur d’un domaine sont


automatiquement sécurisés, et les communications
inter-domaines peuvent être contrôlées.
Il existe plusieurs niveaux de VLAN :
-Les VLAN de niveau 1 ou VLAN par port (Port-Based VLAN) qui
regroupent les stations connectés à un même port du
commutateur. Un VLAN par port. Administration lourde (gestion
des déplacements)

- Les VLAN de niveau 2 ou VLAN MAC (MAC Address-Based


VLAN) qui associent des stations par leur adresse MAC selon
des tables d’adresses introduites par l’administrateur. Plusieurs
VLAN par port possibles. Administration lourde (gestion par
adresse MAC …)

-Les VLAN de niveau 3 ou VLAN d’adresses réseaux (Network


Address-Based VLAN) qui associe des stations par leur
adresse réseau (sous-réseaux IP par exemple). On peut
également créer des VLAN selon un protocole (IP, IPX).
Notions :

VLAN géographiques et les VLAN étendus

VLAN géographiques : 1 seul VLAN par switch d’accès


Avantages : limitation des domaines de broadcast,

VLAN étendus
Avantages : mobilité physique
Les formats de trames adaptés aux VLAN

IEEE 802.10
Initialement, créé pour des besoins de sécurité (cryptage )
SDE : secure data exchange
SDE designator = LSAP indiquant une trame de type VLAN
802.10 (3 octets)
The Clear Header inclut un Security Association Identifier
(SAID) et un champ optionnel Management-Defined Field
(MDF), pour faciliter la prise en compte du PDU.
Le Protected Header contient la source address contenue dans
le MAC header pour permettre la validation de cette adresse.
Cela empêche qu’une autre station soit identifiée comme étant
la vraie source.

Le champ 802.10 SAID est utilisé comme VLAN ID (4 octets)


Au minimum les switches doivent supporter le Clear Header du
format 802.10.
Seules les trames inter-switches sont modifiées:

IEEE 802.3 Format à l’origine:


-------------------------------------------------------------
| | | | | |
| Destination | Source | Length | 802.2 LLC | Data |
| | | | | |
-------------------------------------------------------------

Format sur le 802.10 VLAN backbone :

--------------------------------------------------------------
| | |Length| | |Station|Frag|Original | |
|Dest|Source| |0A 0A 03|SAID| | | |Data|
| | | + 16 | | | ID |Flag|802.2 LLC| |
--------------------------------------------------------------

Note: LSAP = 0x0A 0x0A 0x03.


The SAID = 802.10 Security Association ID (4-bytes).
The Station ID comprend 8 bytes: Source Address de l’origine, 2 derniers octets =
NULL.
Fragmentation Flag = NULL (Cisco ne supporte pas la fragmentation 802.10)
Le Switch B transforme la trame dans le format 802.3/ 802.2 d’origine.
IEEE 802.1Q
Principe du “ tagging ”
Le tagging est indiqué par une valeur particulière du champ
EtherType (TPID), fixée à 0x8100. Quand le champ EtherType
est égal à 0x8100, cette trame contient un tag IEEE
802.1Q/802.1p.
Le tag est formé de 2 octets avec 3 bits de user priority, 1 bit de
Canonical Format Identifier (CFI) et 12 bits of VLAN ID (VID).
Les 3 bits de user priority sont utilisés par le standard 802.1p
CFI est utilisé pour une compatibilité entre Ethernet et Token
Ring .
VID est l’identification du VLAN (4094 VLANs au maximum)
Les 2 octets suivants contiennent soit la MAC Length (IEEE
802.3) ou le champ EtherType (Ethernet v.2).
Frame Tagging dans le cas d’ ISL (Inter- Switch Link ,
propriétaire Cisco)
Avec ISL, une trame Ethernet est également encapsulée
avec un header qui transporte un VLAN ID
Le header contient 26 octets dont 10 bits de VLAN ID.
VLAN Trunking
Exemples de configuration :
VLAN IEEE 802.1Q Bridging Example
interface FastEthernet4/0
no ip address
no ip route-cache
half-duplex
!
interface FastEthernet4/0.100
encapsulation dot1Q 100
no ip route-cache
bridge-group 1
!
interface FastEthernet4/0.200
encapsulation dot1Q 200 native
no ip route-cache
bridge-group 2
!
interface FastEthernet4/0.300
encapsulation dot1Q 1
no ip route-cache
bridge-group 3
!
interface FastEthernet10/0
no ip address
no ip route-cache
half-duplex
!
interface FastEthernet10/0.100
encapsulation dot1Q 100
no ip route-cache
bridge-group 1
!
interface Ethernet11/3
no ip address
no ip route-cache
bridge-group 2
!
interface Ethernet11/4
no ip address
no ip route-cache
bridge-group 3
!
bridge 1 protocol ieee
bridge 2 protocol ieee
bridge 3 protocol ieee
Routage inter-VLAN

3 protocoles sont utilisables :


ISL : protocole de type packet-tagging
802.1Q : non supporté en 10 Base T
802.10 :incorpore en plus des notions de sécurité et
d’authentification

Avec un routeur possédant plusieurs interfaces Ethernet :


Un routeur permet de plus la mise en place d'une politique de
filtrage.

ex.: Seuls certains PC d'un réseau (d'un VLAN) peuvent


communiquer avec certains PC d'un autre réseau (VLAN) et
ce pour une application.

Exemples : mise en œuvre d’access-list (travaux pratiques)

Inconvénients : performances des routeurs classiques (conçus


pour gérer des liens WAN bas ou moyen débit), coût lié au
nombre d’interfaces Ethernet nécessaires sur le routeur.

Solution : routeur supportant le 802.1Q:


. Un commutateur de niveau 3 est un équipement qui fait du
routage avec un temps de traitement beaucoup plus court qu'un
routeur.

Il s'appuie pour cela sur un composant électronique (ASIC) dédié


à ce travail.

Très schématiquement, on passe :

. d’une architecture avec un routeur classique Inter-VLAN dédié :

. à une architecture avec un switch backbone intégrant


efficacement la fonction de routage
3512xl#show running-config
hostname 3512xl
interface FastEthernet0/1
switchport mode trunk
!-- If 802.1Q is configured, you will instead see the following output under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
interface FastEthernet0/3
switchport access vlan 1
spanning-tree portfast
interface VLAN1
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
ip default-gateway 10.10.10.1
c2600#show running-confighostname c2600
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.10.11.1 255.255.255.0
!
C2600#show running-config
hostname c2600
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation isl 1
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation isl 2
ip address 10.10.11.1 255.255.255.0
!
Recommandations d’architecture:

Limiter le nombre de VLAN

Implémentation au niveau 3

Ne pas sous-estimer les tâches


d’exploitation inhérentes
Les requêtes DHCP étant envoyées en broadcast (à tout le
monde) sur le réseau, il est possible pour une personne
mal intentionnée d’utiliser son propre serveur DHCP afin
de diffuser des configurations malicieuses.
En effet, cela est possible en laissant le serveur DHCP
pirate répondre plus rapidement aux requêtes DHCP que
le serveur DHCP présent sur le réseau, offrant ainsi aux
utilisateurs des configurations prédéfinies et destinées à
des actions malicieuses
Réseau avec DHCP Snooping

Le principe de fonctionnement du DHCP Snooping est


simple. Etant donné que les requêtes DHCP Offer et
DHCP ACK peuvent provenir uniquement des serveurs
DHCP, il suffit donc de déterminer sur les
commutateurs (switchs) les ports autorisés à diffuser
ces requêtes.
De cette manière, seuls les ports configurés comme
étant des ports de confiance (trusted port), pourrons
renvoyer aux postes clients des configurations réseaux.
•If a physical LAN has more than one logical subnet,
how can different groups of clients be allocated
addresses on different subnets?
•One way to do this is to preconfigure each client
with information about what group it belongs to. A
DHCP feature designed for this is the user class
option. To do this, the client software must allow the
user class option to be preconfigured and the server
software must support its use to control which pool a
client's address is allocated from.
SAN (Storage Area Network) et NAS (Network Attached
Storage)

Lorsque l'on parle de stockage en réseau, c'est par opposition


à l'attachement direct (de type DAS, Direct Attached System)
où chaque disque ou ensemble de disques est physiquement
lié à une seule unité se commande, serveur de fichier ou
mainframe, par définition indépendante.

Le stockage en réseau fait généralement référence à deux


types de solution distinctes: le NAS (Network Attached Storage)
et le SAN (Storage Area Network).
Why Storage Networks?
“The total amount of data being stored doubles every
year. Also, more than 90% of companies today would
fail to survive a catastrophic data loss. Businesses
face a mission-critical need to protect, access, and
manage their ever-growing volume of storage
assets”

 Explosive growth of business data


 Internet and Multimedia
 High Availability
 Management complexity
Why Storage Networks? (Contd..)
High Availability

Host
Single Point Failure

Disk

Host
Multi Pathing Increased disk
availability
Load balancing
Disk
First layer of choice
IP/ETH

NAS Access to Information


Protocol:
• Channel (SCSI,FC)
• Network (TCP/IP)

SAN FC
Information Infrastructure, Topology Summary
Directly Server Data Storage
Attached
Storage Server
Device Data Storage

TCP/IP
Parallel Transmission

 Set of data signals are sent simultaneously through 8, 16 or


even more wires.
 Example - SCSI
» Bus length limitations
» Limited device count
SCSI
SCSI Bus Width Max No. of Bus Speed Max Max Bus
Interface (bits) devices (MHz) speed Length
standard (MB/s) (m)

Ultra 2 SCSI 8 8 40 40 12

WideUltra2 16 16 40 80 12
SCSI

Ultra 160 16 16 40 160 12


(DT)
Ultra 320 16 16 80 320 12
(DT)
Limitations of SCSI

 Not more than 16 devices per bus


 Maximum channel length 25 m (HVD) while
only 12 m with normal LVD/SE
 Data Transfer speed up to 320 MB/s
Typical Storage Area Network (SAN) Implementation

LAN

Switch
Fibre Channel
Host Bus Adapters (HBAs)
Tape B/R

Storage

Storage Consolidation.
SAN Pros and Cons

 High performance for large block transfers


 Excellent availability through multiple paths
 Integrated backup solutions

 Data sharing through proprietary filesystem solutions


 Expensive to deploy and manage
 Expensive HBAs (compared to NICs)
Information Infrastructure, Topology Summary
Directly Server Data Storage
Attached
Storage Server
Device Data Storage

Server
Storage Fibre
Data Storage
Area Server
Switch
Network Server Data Storage

TCP/IP
Typical Network Attached Storage(NAS) Implementation

Server Consolidation.
CIFS, for Common Internet File System, is
a network protocol for sharing files,
printers, serial ports, and other
communications between computers.

CIFS is based on the widely-used SMB,


Server Message Block, protocol.
NAS Pros

 File level access to storage


 Data sharing through proven standard network protocols (NFS,
CIFS, ...), heterogeneous system environment
 Availability through high bandwidth clustering and data replication
 Simple and inexpensive to deploy - inexpensive NICs
NAS: basé sur IP et Ethernet, permet de mutualiser les données
stockées sur les serveurs de fichiers reliés entre eux par un LAN
de l'entreprise (dédié ou non).
SAN, pas d'infrastructure IP. Mise en relation de serveurs avec
des baies de disques qui stockent les données via des
commutateurs particuliers (câbles/switches/cartes optiques de
type fibre channel)

Les 2 répondent aux besoins croissants des entreprises en


matière de consolidation et de mutualisation des données à
stocker et à sauvegarder. A mesure que le volume et les sources
des données à conserver se font plus importantes, il devient en
effet matériellement impossible de n'avoir qu'un point de
stockage, comme dans le cas du DAS.
iSAN :Enterprise Storage Future

 iSAN : SANs built on iSCSI protocol


iSCSI (internet small computer system
interface) is TCP/IP-based protocol for
establishing and managing connections
between IP-based storage devices, hosts and
clients
 iSCSI is a block access protocol, allows SCSI
access over TCP/IP networks
iSCSI Defined
 iSCSI = internet Small Computer System Interface
 An interconnect protocol that:
 Is designed for storage area networks
 Supports the block-based storage needs of database applications
 Is TCP/IP based
 Establishes and manages connections between IP-based storage
devices, hosts and clients
 Is based on familiar and ubiquitous open standards
 Provides advanced IP routing, management, and security tools
RAID Technology

“RAID is Redundant Array of Independent/


Inexpensive Disks “
RAID Technology

Advantages of RAID

 Improved Data Protection


 Enhanced Performance
RAID Technology
Various RAID Levels

 RAID 0 ( Striping)
 RAID 1 (Mirroring)
 RAID 10 / RAID 1+0 (Mirroring + Striping)

 RAID 3 (Independent Striping plus parity)


 RAID 5 (Independent Striping plus distributed parity)
RAID 0 (Striping)
Drive 1 Drive 2

Block 1 Block 2
Block 3 Block 4
Block 6
Block 5
Block 7 Block 8

Improved performance
 No redundancy : not suitable for critical data
 Min. no. of disks : 2
RAID 1 (Mirroring)
Drive 1 Drive 2

Block 1 Block 1
Block 2 Block 2
Block 3
Block 3
Block 4 Block 4

Increased redundancy
 Improved read performance
Min no. of disks : 2
RAID 10 (Mirroring + Striping)
Drive 1 Drive 2 Drive 3 Drive 4

Block 1 Block 2 Block 1 Block 2


Block 3 Block3 Block 4
Block 4
Block 5 Block6
Block 5 Block 6
Block 7 Block 7 Block 8
Block 8

Increased redundancy
 Improved read performance
Min no. of disks : 4
RAID 3 (Striping + Parity)
Drive 1 Drive 2 Parity Drive

Bit1 Bit 2 Parity 1-2


Bit 3 Bit4 Parity 3-4
Bit 6 Parity 5-6
Bit 5

Increased redundancy through parity data


 Improved read /write performance
 Single point of failure is parity drive
 Min no. of disks : 3
RAID 5 (Striping + Distributed
Parity)
Drive 1 Drive 2 Drive 3

Block 1 Block 2 Parity 1- 2


Block 3 Parity 3-4 Block 4
Parity 5-6 Block 5 Block 6
Block 7 Block 8 Parity 7-8

Increased redundancy through distributed parity data


 Improved read /write performance
 Min no. of disks : 3
Solutions de sauvegarde en architecture NAS

Serveur dédié de backup

sauvegarde en 2 temps: rapide sur disque (défini en


bandes virtuelles) puis sur bande (pour historisation et
externalisation)

Agents de sauvegarde sur chaque serveur


Architecture WAN
ATM – asynchronous transfert mode

Les principes

La technique de transfert ATM est basée sur les principes de


multiplexage et de commutation d'informations numériques
conditionnées en paquets de longueur fixe appelés "cellules"
(paquets de 53 octets répartis en 5 octets d'entête pour
l'identification de la cellule et en 48 octets pour la charge utile).
Petits paquets pour prendre en compte les contraintes liées au
flux voix.
Les cellules sont transmises au rythme du débit engendré par
l'application.
L'accommodation des différents services au format ATM est
réalisé par l'intermédiaire d'une fonction d'adaptation.
De base ATM est orienté connexion (contrairement au LAN
classique – mode sans connexion ou connectionless - où l’on
ne pré-établit pas de chemin physique ou virtuel entre 2
nœuds supposés pouvoir communiquer). Les connexions
sont établies pour toute la durée des échanges.
L'établissement d'une connexion se traduit non seulement par
l'allocation d'un chemin virtuel (voix virtuelle et/ou d'un
conduit virtuel) mais aussi par l'allocation de ressources
requises en terme, par exemple de débit. Le débit requis peut
être négocié entre l'utilisateur et le réseau. Le réseau doit
s'assurer que l'utilisateur respecte bien la valeur négociée et
doit être en mesure de garantir une certaine qualité de
service en terme de débit, de taux d'erreurs, de pertes de
cellules, de délais de transfert, de variations de ces délais...
ATM est défini selon un modèle structuré en 3 couches :

la couche physique (PHY) qui rassemble les


fonctions liées à la transmission;

la couche ATM qui assure l'acheminement des


informations par multiplexage et commutation des
cellules;

la couche d'adaptation AAL (ATM Adaptation Layer)


qui fait le lien avec les couches applicatives.
La couche physique définit plusieurs possibilités d'accès aux
média à des débits variables, sur des supports physiques
différents (paire torsadée, coaxial, fibre optique).
l'interface européenne à 34 Mbps (E3) selon les
recommandations G804/G832;
l'interface nord-américaine à 45 Mbps (T3);
les interfaces nord-américaines Sonet (Synchronous
Optical NETwork) à 51Mbps (Sonet-OC1), 155 Mbps
(Sonet-OC3) et 622 Mb/s (Sonet-OC12);
les interfaces européennes SDH (Synchronous Digital
Hierarchy) à 155 Mbps (SDH-STM1) et 622 Mbps (SDH-
STM4). Les interfaces SDH à 155 Mbps et 622 Mbps
correspondent en partie à celles de Sonet, mais ne sont
pas totalement compatibles

Interface européenne à 25,6 Mb/s …


 Le réseau ATM corsespond au niveau 2 (liaisons de données)
 Solution IP sur ATM de l'IETF
» IP over ATM
» Encapsulation au dessus de l'AAL5

IP
AAL5
ATM
Physique
SSCS
(Service SpecificConvergence Sublayer)
CS

CPCS
(Common Part Convergence Sublayer)
Adaptation Layer

(AAL)
SAR
(Segmentation & Re - assembly)

48 bytes

ATM Layer (Service Independent, cell formatting, Header Generation

53 bytes VPI/VCI Translation)


(Cell Switching)

TC (Transmission Convergence Sublayer)


Physical layer

PMD (Physical Medium Dependent Sublayer)


Le LAN est un mode de transfert sans connexion
Le LAN supporte des broadcasts, alors que ATM ne supporte que des
connexions point à point ou point à multipoint. (problème d'adressage,
de signalisation)

Les échanges des datagrammes sont faits en mode non fiable (Best
effort)

àl'opposé ATM est un protocole orienté connexion (QoS :


qualité de services)
Les Applications ATM
Encapsulation

 Le RFC 1483 spécifie deux méthodes d'encapsulation :

 Multiplexage (LLC/SNAP) de différents 3


protocoles sur une même connexion ATM
2

» les trames doivent être 1


soumises séquentiellement
sur le CV ATM
VCC

1 2
3
 Une connexion ATM pour
chaque protocole transporté
Analyse de la cellule : VPi, VCi, marquage de trames
CLP

La couche ATM est complètement indépendante du support


physique utilisé pour transporter les cellules.

La couche ATM assure quatre fonctions essentielles :


la commutation consistant en un traitement sur l'en-tête de la cellule (champs VPI
et VCI). Ces champs sont soit insérés soit extraits et traduits afin d'aiguiller
correctement la cellule;
le multiplexage-démultiplexage des cellules consistant principalement en une
gestion de files d'attente
l'extraction ou l'ajout de l'en-tête devant le champ d'information avant de la
transmettre à la couche d'adaptation AAL ou à la couche physique. La couche ATM
ne traite pas le champ HEC;
un mécanisme de contrôle de flux peut être implémenté par l'intermédiaire du
champ GFC, pour l'interface utilisateur-réseau.
La principale mission de la couche ATM est donc de véhiculer
correctement les cellules à travers le réseau. Elle se base sur
les informations fournies dans l'entête de la cellule. Les
informations nécessaires au bon cheminement des cellules
sont deux types :

l'identificateur de voies virtuelles (VCI : Virtual Channel


Identifier). La voie virtuelle individualise une
communication à l'intérieur d'un conduit virtuel;

l'identificateur de conduit virtuel (VPI : Virtual Path


Identifier). Le conduit virtuel permet d'acheminer en
bloc toutes les voies virtuelles qui lui appartiennent et
ainsi de constituer un réseau de "tuyaux" logiques.
Ces identificateurs n'ont qu'une signification locale.
VP, VC Switching
La cellule ATM a une taille fixe, ce qui permet de la commuter
avec un maximum d'efficacité.

Elle comporte 53 octets (5 d'en-tête et 48 de données).

Il s’agit d’un compromis entre US et Europe (32 et 64 octets).


Format trame ATM
Nombre
Nom Fonction
de bits
Generic Ces 4 bits sont destinés à faciliter le contrôle de la congestion, mais leur
4 (0) Flow signification n'a pas encore été précisée par le forum ATM. Un noeud du réseau
Control ATM incapable de gérer le flow control doit les mettre à 0.
8 (12) VPI VPI
16 VCI VCI
Ces bits donnent diverses informations : sur la nature des données de la cellule
(données utilisateur ou données de management ATM), sur l'état de congestion du
PTI réseau et l'état des ressources réseau. Ils peuvent prendre les valeurs suivantes :
(Payload 000 données utilisateur, pas de congestion
3
Type 010 données utilisateur, congestion
Indicator) 100 Cellule d'OAM (Operation And Maintenance) pour SVC
101 Cellule d'OAM pour PVC
111 Réservé à un usage futur
CLP (Cell Ce bit indique si la cellule doit être conservée de manière prioritaire au cas où le
1 Loss switch serait obligé d'en détruire. Il vaut 0 si la cellule doit être conservée, et 1 si
Priority) elle peut être détruite.
HEC
Ces 8 bits permettent de détecter une éventuelle erreur de transmission dans le
(Header
8 header. Ils permettent également de corriger une telle erreur si elle porte sur 1 ou 2
Error
bits dans 89% des cas.
Control)
Application au LAN : Lan emulation

La principale différence entre les réseaux locaux " traditionnels"


et un réseau ATM est que ceux-ci utilisent un média partagé
alors qu'ATM est orienté connexion. Ils envoient des messages
de " broadcast " à toutes les stations du réseau. Le LAN
Emulation doit donc suivre ce modèle de " broadcast ".

Puisque le but de l'ATM Forum est d'offrir au-dessus d'une


infrastructure ATM un support transparent pour tous les
protocoles de communication actuels, la voie évidente consiste
à créer une couche offrant les mêmes services que la couche
MAC traditionnelle - c'est-à-dire la création d'un espace d'adressage
uniformisé basé sur des adresses MAC de 48 bits permettant la communication
entre deux stations (unicast), l'envoi de données vers plusieurs utilisateurs
(multicast) ou vers tous les utilisateurs (broadcast). C'est cette couche que l'on
appelle LAN Emulation.
Dans le modèle LAN Emulation (LANE), les équipements réseaux (station
ou pont) directement attachés au réseau ATM sont appelés LEC (LAN
Emulation Client).
Puisque la couche émulée de ces LECs doit offrir les services classiques
d'une couche MAC et étant donné l'existence d'un adressage physique ATM
découplé de l'adressage MAC utilisé par les protocoles réseaux, le service
LANE doit prévoir :
la possibilité de trouver une adresse ATM correspondant à une
adresse MAC donnée,
le support des adresses multicast ou broadcast puisque le support
physique n'offre plus les caractéristiques de diffusion.
Deux serveurs sont utilisés pour cela :
un LES (LAN Emulation Server) pour le problème de résolution
d'adresse MAC vers ATM,
un BUS (Broadcast & Unknown Server) pour le problème de
diffusion.
L'AAL est une interface entre les couches logicielles élevées et le
protocole de bas niveau qu'est la transmission de cellules de 48
octets de données d'un point à l'autre du réseau. Différents types
d'AAL seront donc utilisés en fonction des besoins des couches
supérieures.
L'AAL se compose de deux sous-couches : CS (Convergence
Sublayer) et SAR (Segmentation And Reassembly sublayer). La
sous-couche la plus haute, CS, gère les temps de transmission, la
détection des cellules perdues et des erreurs de transmission.
Pour ce faire, elle encapsule les paquets de la couche applicative
(dits PDUs) dans des CS-PDUs (Protocol Data Unit) de taille
variable et supérieure à celle de la cellule ATM. La sous-couche
SAR, quant à elle, permet de découper ces CS-PDUs pour les
implanter dans les cellules ATM de 48 octets de données. AAL5
est la couche simplifiée adaptée au cas du LAN
La version actuelle du LAN Emulation ne laisse pas de place a la
specification de qualite de service associee aux echanges. Cela a
ete fait consciemment dans l'esprit des LAN actuels. Cela peut
etre vu comme un gaspillage de ressources important, puisque
l'interet majeur d'ATM reside dans sa capacite a fournir de la
qualite de service par flux d'echanges.

Voie explorée : MPOA (Multiple Protocol Over ATM)


utilisant notamment la couche ARP d’IP en remplacement
de LAN Emulation …

Lourd, couteux (investissement et fonctionnement) et


donc peu souvent retenu…
L’infrastructure banalisée en ATM supportant voix et
données reste encore un mythe (hormis les systèmes de
câblage au plus bas niveau) pour les LAN (mais pas pour
les architectures WAN)
Qualité de service : UBR, VBR1 et 3, CBR, ABR

CBR (constant bit rate) : “ solution riche et chère ”

PCR (peak cell rate)


Emulation de “ lien loué ”. Garantie dans tout le réseau traversé
d’une bande passante constante

Non-real time VBR (variable bit rate) : “ surbooking ”

PCR/CDVT (peak cell rate/cell delay variation tolerance)


SCR (sustainable cell rate = débit moyen garanti)
MBS (maximum burst size , nombre de cellules)
Notion de credit burst (exemple de l’accès@ en ADSL,
mode FTP et browsing, get/put de différentes tailles sur
serveur WEB ou DNS de référence …)
Distinguer VBR 1 (destruction) et VBR 3 (marquage CLP
au delà du MBS)
Real time VBR

UBR (unspecified bit rate)


PCR , “ best effort ”

ABR (available bit rate)


MCR (minimum cell rate) , PCR

Ordre de priorité entre classes de service : CBR, VBR, ABR,


UBR: Impact sur Netissimo (UBR)
Principes du trafic shaping (et spacing) et du policing

Si l’on ne “ shape ” pas correctement (exemple


d’un client) en amont d’une fonction de policing
(entrée du réseau d’un opérateur) : dégradation des
performances qui tombent en dessous des minima
promis par l’opérateur exprimés en cellules et non
en octets “ applicatifs).
Pire cas :3 % de cellules jetées = 100 % du trafic applicatif
perdu
Pas de procédure de récupération de la seule cellule
manquante dans une trame IP, tout doit être retransmis car
les mécanismes de reprise se font au niveau 3 et non au
niveau 2
When a subscriber makes a
telephone call, the dialed number is
used to set switches in the
exchanges along the route of the
Circuit Switching
call so that there is a continuous
circuit from the originating caller to
that of the called party.
Because of the switching operation
used to establish the circuit, the
telephone system is called a circuit-
switched network.
If the telephones are replaced with
modems, then the switched circuit
is able to carry computer data.
Packet Switching
An alternative to Circuit switches is to allocate the capacity to the traffic only when it
is needed, and share the available capacity between many users. With a circuit-
switched connection, the data bits put on the circuit are automatically delivered to the
far end because the circuit is already established.
If the circuit is to be shared, there
must be some mechanism to label the
bits so that the system knows where
to deliver them.
It is difficult to label individual bits,
therefore they are gathered into
groups called cells, frames, or
packets.
The packet passes from exchange to
exchange for delivery through the
provider network.
Networks that implement this system
are called packet-switched networks.
WAN Link Options
To connect to a packet-switched network, a subscriber needs a local loop to the nearest
location where the provider makes the service available.
This is called the point-of-presence (POP) of the service.
Normally this will be a dedicated leased line.
This line will be much shorter than
a leased line directly connected to
the subscriber locations, and often
carries several VCs.
Analog Dialup
When intermittent, low-volume data transfers are needed, modems and analog
dialed telephone lines provide low capacity and dedicated switched connections.

The advantages of modem and


analog lines are simplicity,
availability, and low
implementation cost.
The disadvantages are the low
data rates and a relatively long
connection time.
The dedicated circuit provided
by dialup will have little delay
or jitter for point-to-point
traffic, but voice or video
traffic will not operate
adequately at relatively low bit
rates.
ISDN
Integrated Services Digital Network (ISDN) turns the local loop into a TDM digital
connection.
The connection uses 64 kbps bearer channels (B) for carrying voice or data and a
signaling, delta channel (D) for call set-up and other purposes.
ISDN
A common application of ISDN is to provide additional capacity as needed on a
leased line connection.
The leased line is sized to carry average traffic loads while ISDN is added during
peak demand periods.
ISDN is also used as a backup in the case of a failure of the leased line. ISDN tariffs
are based on a per-B channel basis and are similar to those of analog voice
connections.
ISDN
In North America PRI corresponds to a T1 connection.
The rate of international PRI corresponds to an E1 connection.
For small WANs, the BRI
ISDN can provide an ideal
connection mechanism.
BRI has a call setup time that
is less than a second, and its
64 kbps B channel provide
greater capacity than an
analog modem link.
Leased Line
Leased lines are not only used to provide direct point-to-point
connections between Enterprise LANS, they can also be used to
connect individual branches to a packet switched network.

Point-to-point lines
are usually leased
from a carrier and are
called leased lines.
Leased lines are
available in different
capacities.
The cost of leased-
line solutions can
become significant
when they are used to
connect many sites.
WAN with X.25
X.25 provides a low bit rate, shared-variable capacity that may either be
switched or permanent.
X.25 can be very cost effective
because tariffs are based on the
amount of data delivered rather
than connection time or
distance.
Data can be delivered at any rate
up to the connection capacity.
X.25 networks are usually low
capacity, with a maximum of 48
kbps.
In addition, the data packets are
subject to the delays typical of
shared networks.
Frame Relay
Most Frame Relay connections are based on PVCs rather than
SVCs.
It implements no error or flow control.
Frame Relay provides permanent shared medium bandwidth
connectivity that carries both voice and data traffic.
ATM

Asynchronous Transfer Mode (ATM) is a technology capable of


transferring voice, video, and data through private and public networks.
It is built on a cell based architecture rather than on a frame-based
architecture.
DSL
Digital Subscriber Line (DSL) technology is a broadband technology that uses
existing twisted-pair telephone lines to transport high-bandwidth data to service
subscribers.
DSL technology allows the local loop line to be used for normal telephone voice
connection and an always-on connection for instant network connectivity.
Frame Relay Technology
Frame Relay History
 Frame Relay was designed as an evolution of X.25.
 X.25, a 1970s ITU-T standard, ensured reliable
transport at the data link layer with error detection and
error correction.
 With the introduction of DoD’s TCP/IP in the early
1980s, TCP took over error correction.
 Although Frame Relay detects errors at the data link
layer, it does not correct. That’s now TCP’s job.
Frame Relay History

 In 1990, Cisco Systems, StrataCom, Northern Telecom and Digital


Equipment (sometimes referred to as the Group of Four) worked to
standardize the Frame Relay protocol and add LMI extensions.
 In the 90’s Frame Relay became the most popular WAN protocol
because it is:
 Faster than X.25, it uses TCP for error correction
 Cost-effective - you no longer have to pay for a dedicated
point-to-point link
 Versatile - can operate over a variety of interfaces (ISDN,
Serial, Dial-up, etc.)
 Devices in the Frame Relay network are the DTE (customer
equipment) and DCE (provider’s frame relay switch)
 Often cheaper than other technologies because many times the
service provider also owns the DTE.
 The Frame Relay connection between the DTE and DCE operates at
the data link and physical layers of the OSI model.
Frame Relay

Data Link

Physical
Frame Relay Operation

 Frame Relay operates over a permanent virtual circuit


(PVC), which means that a permanent connection
exists between the source DCE and destination DCE
over the frame relay network.
 Therefore, there is no need for call setup and
termination like in ISDN. Frame Relay has two states:
 Data transfer--between the DCE and the provider’s DTE
 Idle--the line is active, but no data is being transferred.
Frame Relay Operation

 The connection between the local DTE and the DCE in


a Frame Relay network is logically identified with a
Data-link Connection Identifier (DLCI).
 A word about Switched Virtual Circuits (SVC)
 Frame Relay over ISDN must use a SVC with ISDN’s
call setup and termination procedures.
 However, currently few manufacturers of DCE
equipment support Frame Relay SVCs, so
implementation is minimal.
 Therefore, we will assume a PVC when discussing
Frame Relay.
Un réseau relais de trames est constitué d'un ensemble
de nœuds ou "relayeurs de trames" interconnectés de
façon maillée. Les interconnexions sont des voies à haut
débit et le maillage peut être quelconque. Le réseau
relais de trames travaille en mode connecté.

Un nœud achemine les données reçues sur l'une de ses


entrées vers l'une de ses sorties en fonction d'un
identifiant de connexion (DLCI). Pour cela, il utilise une
table de correspondance (table de commutation):

Numéro de port physique, n° DLCI entrant, n° DLCI


sortant
Caractéristiques, :
• attribution de la bande passante aux utilisateurs en
fonction de leurs besoins, ce qui implique qu'il n'y
aura pas de réservation statique de ressources
• un débit moyen est garanti ; cependant, le débit
d'accès réel peut être supérieur, la qualité de service
n'étant garantie que pour le débit moyen
• le bloc d'informations pouvant être transmis par
une trame FR est plus important que dans le cas des
paquets X.25, ce qui permet l'allègement des fonctions
de segmentation et de réassemblage
par rapport à X25, le travail des nœuds est
considérablement réduit, ce qui permet des temps de
traversée moins importants
• les trames ne sont identifiées que par l'identifiant DLCI,
modifiable par un nœud afin de véhiculer correctement les
informations dans le circuit virtuel (signification locale du
DLCI)
• le relais de trames opère dans une gamme de débit
comprise entre 64 kbit/s et 2Mbit/s pour l'Europe (aux USA,
débit typique de 1.5Mbit/s). Cependant, des débits d'accès de
45Mbit/s aux USA et de 34Mbit/s en Europe sont possibles.
Toute trame FR comprend les champs suivants :
• champ drapeau (flag). Ce champ permet d'identifier le début et la
fin d'une trame. Il prend la valeur 01111110
• champ adresse de taille variable de 2 à 4 octets. Il contient
l'identifiant de connexion ou DLCI, qui permet l'acheminement des
trames au niveau de chaque nœud du réseau. Le codage du DLCI se
fait sur 10, 16 ou 23 bits et dépend du nombre de circuits virtuels
différents sur les liaisons. Cependant, seule une partie de tous les
DLCI possibles va être utilisée pour les circuits utilisateurs ; certains
DLCI seront principalement réservés.
• les bits BECN, FECN et DE sont utilisés pour le contrôle de la
congestion dans le réseau
le champ de données de taille variable de 1 à 4096 octets. La
taille de ce champ peut être négociée lors de l'ouverture
d'une connexion. Toutefois, la taille minimale recommandée
est de 262 octets. Cette taille résulte d'un compromis entre les
coûteuses fonctions de fragmentation/défragmentation et les
problèmes de temps de transit dans les nœuds du réseau FR.
• le champ FCS sert à détecter d'éventuelles erreurs de
transmission même si le taux d'erreur est relativement faible.
Le FCS est calculé à chaque nœud de commutation ; la trame
est rejetée en cas d'erreur. Le FCS correspond à un polynôme
générateur de degré 15.
Committed Information Rate, CIR.
Il représente le débit moyen garanti par le réseau,
avec la QoS désirée par l'usager.
La valeur du CIR est déterminée en fonction des
caractéristiques du trafic généré par l'usager.

La somme des CIR des différents circuits


partageant un même lien doit être inférieure à la
capacité de celui-ci.

EIR: exceeded rate: valeur maximale possible


Signalisation
Les mécanismes de signalisation informent l'usager sur
le statut et la configuration du réseau, permettant ainsi
de contrôler les PVC.

Ces services, que l'on appelle LMI, sont optionnels et


utilisent le circuit virtuel de DLCI égal à 0
Le réseau relais de trames surveille si le flux de trafic
de l'utilisateur respecte son contrat. Le réseau est
autorisé à réduire le débit et même à rejeter des
informations si le débit d'accès est excessif. ( par le bit
DE Discard Eligibility).
Tant que la quantité d'informations mesurée pendant
l'intervalle de temps T au CIR, les trames sont
transmises avec le bit DE à 0
Si le débit dépasse le CIR, les trames sont marquées
avec un bit DE à 1. Dans un premier temps, ces trames
seront transmises ; elles seront détruites en priorité si
elles transitent dans un nœud proche de la saturation.
A l'origine, le bit FECN des trames FR est mis à
0. Lorsque la trame passe par un nœud
congestionné, le bit FECN est mis à 1, ce qui
permet de signaler au récepteur la présence d'au
moins un nœud congestionné dans le réseau
traversé par la trame. Le traitement de la
congestion ne pourra être assuré que par les
couches supérieures
La mise à 1 du bit BECN a pour but de faire remonter
la connaissance de l'état de congestion d'au moins un
des nœuds du circuit à l'émetteur (cela suppose la
présence d'une communication bidirectionnelle).
L'émetteur est donc invité à réduire son débit dès la
réception de trames comportant des bits BECN à 1.
Le relais de trames n'émet pas automatiquement une
trame, il doit alors attendre le passage d'une trame
dans le sens récepteur-émetteur afin de mettre le bit
BECN à 1
Frame Relay Lexicon
 DLCI - Identifies logical connections to the Frame Relay network and has
local significance only
 FECN - Forward explicit congestion notification; tell receiving DTE to
implement congestion avoidance procedures
 BECN - Backwards explicit congestion notification; tells the sending DTE
to slow down the transfer rate
 DE - Discard eligibility; bit set in the frame to say “frame is not business
critical” and can be discarded
 CIR - Committed information rate guaranteed by the service provider
(EIR/CIR).
 LMI - Local Management Interface; determines the operational status of
PVCs
FECN-tells receiving DTE device to
implement congestion avoidance
procedures

FRAMES

DLCI-identifies logical
connections on the
BECN-tells sending DTE device to Frame Relay switch to
reduce the rate of sending data. which the customer is
attached
Frame Relay Frame Format
 Flag - like most frame formats, the flag indicates the beginning and
end of the frame
 The DLCI makes up the first 10 bits of the address field, while the
FECN, BECN, and DE bits are the last 3 bits.
Local Management Interface
LMI Overview
 LMI, similar to LCP in PPP, is a set of extensions to the basic
Frame Relay protocol.
 LMI’s main functions are to:
 determine the operational status of the PVC between source
and destination.
 transmit keepalives to ensure PVC stays up
 inform router what PVCs are available
 LMI extensions were added by the Group of Four.
 A common extension that must be used by all who implement
Frame Relay is virtual circuit status messages.
 Optional extensions include...
» Multicasting
» Flow Control
Attention: il existe plusieurs LMI type !!
Frame Relay Map

 The term map means to “map” or bind a Layer 2


address to a Layer 3 address.
 An ARP table maps MACs to IPs in a LAN
 In ISDN, we use the dailer-map command to map
SPIDs to IP addresses
 In Frame Relay, we need to map the data link layer’s
DLCI to the IP address
 We use the frame-relay map command
Frame Relay Map

 The Frame Relay switch builds a table of


incoming/outgoing ports and DLCIs.
 The router builds a Frame Relay Map through Inverse
ARP requests of the switch during the LMI exchange
process.
 The Frame Relay Map is used by the router for next-
hop address resolution.
Use of Subinterfaces
Using a Subinterface
 In order to have an active Frame Relay link to all your routers in the
network, you need either
 All routers on the same network or subnet
 or use subinterfaces

A
DLCI 16 192.168.4.1

All Routers in
Same Network
Frame Relay
Network
192.168.4.2 192.168.4.0/24 192.168.4.3

DLCI 17 DLCI 18
B C
Using a Subinterface

 Rarely do you have all routers on the same network or


subnet, so we use subinterfaces.
 Each serial interface can logically be divided into as
many subinterfaces as you need to establish PVCs
with each destination.
 Each destination’s DLCI needs a separate point-to-
point subinterface.
 Each side of the PVC must belong to the same
network.
Subinterface Example #1

Each PVC as a point-


to-point link in its
B
own network or
subnet 192.168.1.2

192.168.2.2
A C

192.168.3.2
S0.1 192.168.1.1
S0.2 192.168.2.1
D
S0.3 192.168.3.1
Subinterface Example #2

S0.17 192.168.4.1 A S0.18 192.168.5.1

DLCI 16

AB-PVC AC-PVC

Frame Relay
Network
S0.16 192.168.4.2 S0.16 192.168.5.2

DLCI 17 DLCI 18
B C
S0.18 192.168.6.1 BC-PVC S0.17 192.168.6.2
Configuring Frame Relay
Frame Relay Encapsulation

 To enable Frame Relay, simply go to the serial interface and enter


the command
 However, if you are connecting to a non-Cisco remote router, you
must specify the option IETF

Router(config)#encap frame-relay [cisco|IETF]

Router(config)#int s0
Router(config-if)#encapsulation frame-relay
One Subnet/Network Configuration

 Use a subinterface and specify multipoint.


router(config-if)#int s1.1 multipoint
 However, subinterfaces are not necessary when configuring PVCs
on the same subnet.
 Also, we do not have to set the LMI type since our Cisco IOS is
11.2 or later. LMI type is autosensed.
 However, we enter a map command to link the remote rouer’s
DLCI to its IP address.
One Subnet/Network Configuration
 Configure frame relay
encapsulation and map the
destinations’ DLCIs to their IPs
A
 Repeat the commands on each
DLCI 16 192.168.4.1
router in the network

Frame Relay
Network
192.168.4.2 192.168.4.0/24 192.168.4.3

DLCI 17 DLCI 18
B C
RouterA(config)#int s0
RouterA(config-if)#encapsulation frame-relay
RouterA(config-if)#frame-relay map ip 192.168.4.2 17
RouterA(config-if)#frame-relay map ip 192.168.4.3 18
Multiple Subnet/Network Configuration
 When your routers are parts of different networks or subnets, then
you must either physically attach them on different interfaces or use
subinterfaces on a single interface.
 First step is to set the encapsulation type of the serial interface and
state no IP address.
RouterA(config)#int s0
RouterA(config-if)#encap frame-relay
RouterA(config-if)#no ip address
RouterA(config-if)#no shut
 Then enter subinterface configuration mode to assign each point-to-
point link its IP address and define the destination’s DLCI.
 Next slide shows the subinterface commands.
Multiple Subnet/Network Configuration

S0.17 192.168.4.1 A S0.18 192.168.5.1

DLCI 16
AB-PVC AC-PVC

Frame Relay
Network
S0.16 192.168.4.2 S0.16 192.168.5.2

DLCI 17 DLCI 18
B C
S0.18 192.168.6.1 BC-PVC S0.17 192.168.6.2

RouterA(config-if)#int s0.17 point-to-point


RouterA(config-subif)#ip address 192.168.4.1 255.255.255.0
RouterA(config-subif)#frame-relay interface-dlci 17
RouterA(config-subif)#int s0.18 (continue with configuration)
 show interface serial 0 Verifying Frame Relay
 is Frame Relay sending and receiving data?
 displays both LMI and DLCI information
 show frame-relay map
 displays the frame relay table on the router
 show frame-relay pvc
 used to verify a frame relay configuration
Technologies WAN

ISDN
Commutation de circuits
Offre commerciale nationale : Numéris
Accès de base : 2B + D (B : 64 kb/s)
Agrégation de canaux
Accès primaire : 30 B + D
Backup de LS
Exemple de configuration

hostname TEST1
username TEST2 password 7 1501121F072525
isdn switch-type vn3
interface Ethernet0
ip address 195.200.99.158 255.255.255.224
interface Serial0
backup delay 0 0
backup interface BRI0
ip address 192.1.14.202 255.255.255.0
encapsulation ppp
interface BRI0
ip address 197.5.10.1 255.255.255.0
encapsulation ppp
dialer map ip 197.5.10.2 name TEST2 0148154015
dialer load-threshold 1
dialer-group 1
ppp authentication chap (double intérêt …)
ip route 195.200.101.0 255.255.255.0 192.1.14.201
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

Paramètres optionnels
IDLE Time-out (voir cisco orientation)

Sh int dialer bri0 (occupation des 2 canaux, n° appelé, idle timeout


réarmé)
Debug ppp auth : pour vérifier le succès du challenge CHAP

Limites et problèmes
Risque de Facturation lié aux échanges non utiles
X25

Mode commutation de paquets


Notion de circuit virtuel commuté (CVC)
Niveau 2 ISO : HDLC (niveau trame)
Niveau 3 ISO : X25 (niveau paquet)
Principe d’adresse HDLC et X25
En passe de disparaître (protocole lourd, tarification à l’octet,
difficulté à “ budgetiser ”)
Exemple de configuration

hostname cisco3631
!
interface FastEthernet0
ip address 193.1.1.254 255.255.255.0
ipx network 2
duplex auto
speed auto
!
interface Serial0
ip address 192.1.2 255.255.255.0
encapsulation x25
x25 htc 8 (highest two-way channel, il existe aussi lowest,
incoming et outcoming …)
x25ips 256
x25 ops 256
x25 win 3
x25 nvc 2
x25 map ip 192.2.1.1 191334892 (sous-adresse possible)
x25 map ipx 5.0060.474f.9ae8 191334892
ipx network 5
X25 peu implanté aux US notamment en raison du bas coût des
LS .Donc Cisco a fait un effort minimal de développement
(exemple : n° du premier cvc), X25 est toutefois supporté en IOS
standard
Frame Relay
Amélioration naturelle de X25 (migrations
importantes depuis milieu des années 90)
Forfait, configuration plus simple (aux noeuds
d’extrémité)
Gestion des congestions (BECN, FECN,
mécanisme de burst (débit d’accès, CIR, EIR)
Exemple de configuration

interface serial0
no ip address
encapsulation frame-relay ietf
frame-relay lmi-type ansi

interface serial0.1 point-to-point


ip address 10.128.30.1 255.255.255.248
frame-relay interface-dlci 101

interface serial0.2 point-to-point


ip address 10.128.30.9 255.255.255.248
frame-relay interface-dlci 102
DLCI : n° identificateur de circuit fourni par l’opérateur

Il n’a qu’une signification locale (et non pas de bout en


bout)

Les switches de l’opérateur gèrent les n° de DLCI de


proche en proche.
ATM
Exemple de configuration d’un routeur “ abonné ” :

version 12.1
!
hostname R1
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip nat inside
!
interface ATM0
ip address 195.12.1.9 255.255.255.248
pvc 4/100
encapsulation aal5snap
ip nat outside
!
ip nat inside source list 1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 interface ATM0
access-list 1 permit 10.0.0.0 0.255.255.255
10 Gigabit Ethernet in the LAN

Building A 2 to 40 Km Building B

10 GbE
SM Fiber
10 GbE 100 to 300
m, MM Fiber
 Cost-effective bandwidth for the LAN, switch-to-switch
 Aggregate, multiple, Gigabit Ethernet segments
 10 Gigabit Ethernet channel will enable 20 to 80 Gbps (future)
10 Gigabit Ethernet in the Metro
 Enterprises
Enables dark fiber to become a 10 Gbps pipe for metro networks
Examples: serverless buildings, remote backup, and disaster recovery
 Service Providers
Enables Gigabit services at costs equal to T3 (44.7 Mbps) OC-3 (155 Mbps)

Customer A Ethernet Framing Customer A


Building A Building C
Clients Clients
Service Provider/LEC
10 Gb Ethernet
Backbone

1 or 10 Gb
1 or 10 Gb Ethernet
Ethernet
Customer A
Building B
Server Farm
 The 10 Gigabit Ethernet Task Force has identified an optional
interface that matches the data rate and protocol
requirements of SONET OC-192/SDH STM-64
 Therefore, 10 Gigabit Ethernet will be compatible with
SONET/SDH
 This enables direct attachment of packet-based IP/Ethernet
switches to the SONET/SDH and time division multiplexed
(TDM) infrastructure
 This feature is very important because it promises the ability
for Ethernet to use SONET/SDH for Layer 1 transport across
the WAN transport backbone
10 Gigabit Ethernet in the WAN
 Attachment to the optical cloud with WAN physical layer (WAN PHY)
 Compatibility with the installed base of SONET OC-192
 Interfaces and links between SP to IXC networks can be co-located
 No need for protocol conversion, traffic remains IP/Ethernet

10 GbE WAN DWD


10 GbE
PHY Mux (WAN PHY)
(< 300 m) DWD (< 300 m)
Mux IXC* WAN transport network DWD
Mux
OC-192 SONET and DWDM: 1000’s km

SONET Framing

Service Provider POP Service Provider POP


San Jose, CA *Short for interexchange carrier New York, NY
How the WAN PHY Work
SDH
Hiérarchie Synchrone
Hiérarchie synchrone

 Les supports physiques sont maintenant numériques et une


nouvelle hiérarchie a du être développée :
 SONET ( Synchronous Optical NETwork ) en Amérique du nord
 SDH en Europe

 Ces nouvelles hiérarchies prennent toujours en compte la


numérisation de la parole suivant un échantillonnage toutes les
125 µs, mais elles sont complètement synchrones :
 une trame est émise toutes les 125 µs,
 la longueur de la trame dépend de la vitesse de transmission.
SONET

 SONET est au départ une proposition de BELLCORE (BELL


COmmunication REsearch) puis un compromis a été trouvé
entre les intérêts américains, européens et japonais pour
l'interconnexion des différents réseaux des opérateurs et les
réseaux nationaux.

 SONET est devenu une recommandation de l'UIT-T.


C'est une technique de transport entre deux nœuds qui permet
l'interconnexion des réseaux.

 La hiérarchie des débits étant différente sur les trois


continents, il a fallu trouver un compromis pour le niveau de
base.
C'est le débit de 51,84 Mbps qui forme le premier niveau STS-1
( Synchronous Transport Signal, level 1 ).
Synchronous Digital Hierarchy

La recommandation SDH a été normalisée par L'UIT-T


(1988).
G.707 - Synchronous digital bit rate
G.708 - Network Node Interface for SDH
G.709 - Synchronous multiplexing structure

La hiérarchie SDH reprend celle de SONET.

Le niveau 1 de SDH est le niveau 3 de SONET


(en termes de débit).
Support de communication

 Hiérarchie SDH :
SDH (Europe - Japon) SONET (US)

STS - 1 51,840 Mbps

STM - 1 STS - 3 155,520 Mbps

STM - 3 STS - 9 466,560 Mbps

STM - 4 STS - 12 622,080 Mbps

STM - 6 STS - 18 933,120 Mbps

STM - 8 STS - 24 1244,160 Mbps

STM - 16 STS - 48 2488,370 Mbps

… … …
SDH
 La trame de base est appelée STM-1 ( Synchronous Transport
Module level 1 )

SDH Débit
STM - 1 155 Mbps
STM – 4 622 Mbps
STM – 16 2,5 Gbps
STM – 64 10 Gbps
STM – 128 20 Gbps
STM – 256 40 Gbps
Topologie des réseaux SDH

 Le raccordement des usagers sur le réseau d'opérateur se fait sur


des équipements de multiplexage spécifique : MIE (Multiplexeur à
Injection Extraction), ou ADM (Add Drop Multiplexer).

Réseau d'abonnés Affluents


2 Mbps, 34 Mbps, …

F.O. MIE F.O.

Réseau d'opérateur Agrégats


Topologie des réseaux SDH

 Il existe trois types de topologie pour les réseaux SDH :

Boucle ou anneau
MIE

MIE MIE

MIE
Topologie des réseaux SDH

 Il existe trois types de topologie pour les réseaux SDH :

Bus

MIE MIE
Topologie des réseaux SDH

 Il existe trois types de topologie pour les réseaux SDH :


Etoile/Maillage
MIE MIE

MIE

MIE MIE
Topologie des réseaux SDH

 Protection :

Normal
E R
/ /
M R E M
I I
E R
E / / E
R E
Secours
SDH
Synchronous Digital Hierarchy
Architecture
SDH

 La trame SDH de base (STM-1 155Mb/s)


 Le temps de base correspond toujours à 125 µs ( 8 000
trames par seconde ).
 Chaque trame comprend 9 rangées de 270 octets (taille
dépendant du débit).
 La zone de supervision comprend 9 octets en début de
rangée pour délimiter et gérer la trame.
 L'information transportée est indiquée par un pointeur
situé dans la zone de supervision.
 La zone d'information forme un conteneur virtuel,
l'information peut déborder d'une trame sur la suivante, la
fin est repérée par un "pointeur de fin" dans la zone de
supervision.
SDH
 La trame SDH de base ( STM-1 )
270 octets

framing 261 octets

9
r
pointeur a
n
g
é
e
s

9 octets
de contrôle
Trame de base SDH

Unité administrative (AU)

1
2
3 Pointeur
4
5
6
7
Surdébit de section (SOH)
8
9
Sur-débit de section SOH

RSOH Sur-débit de section


de régénération

1
2
3 Pointeur
4
5
6
7 MSOH Sur-débit de
8 section de multiplexage
9
SOH

 Le SOH est utilisé pour la gestion des sections de ligne de


transmission:
 Multiplexage et démultiplexage de trames
 Sécurisation automatique des liaisons
 Le RSOH est dédié à la gestion des sections de
régénération, il est donc traité au niveau des répéteur-
régénérateurs.
 Le MSOH est dédié à la gestion des sections de
multiplexage, il est donc traité au niveau des terminaux de
ligne.
Synchronous Digital Hierarchy

 Le concept de la hiérarchie SDH repose sur une


structure de trame où les signaux affluents destinés à
être transportés sont en-capsulés dans un conteneur.
 A chaque conteneur est associé un sur-débit de
conduit réservé à l'exploitation de celui-ci.
 Le conteneur et son sur-débit forment le conteneur
virtuel (VC : Virtual Conteneur).
Trame de base SDH avec conteneurs

Pointeur + POH

(UA)
1
2
3
4
5
6
7
Surdébit de section (SOH)
8
9

POH (Path OverHead)= Surdébit de conduit


SDH

 La trame SDH de base


 La trame offre une capacité totale de 2 430 (9 x 270) octets
toutes les 125 µs.
 Les 9 premières colonnes (81 octets) ne contribuent pas au
transport d'information et constituent un surdébit utilisé
pour délimiter et gérer la trame.
 Les 2 349 octets restants constituent un conteneur virtuel,
lui-même constitué d'une colonne (9 octets) transportant le
surdébit de conduit POH (Path OverHead) et du conteneur
proprement dit, offrant une capacité de transmission de
2340 toutes les 125 µs soit un débit de 149 760 kbps.
 Le surdébit de conduit est utilisé pour des fonctions de
gestion
( parité, type de charge utile, ...)
Byte Stuffing within the SONET/SDH Payload
10 Gigabit Ethernet in Metro DWDM (Future)
 Attach 10 GbE directly to clear channel 10 Gbps dark wavelength from DWDM
network
 Upgrade carrying capacity of each wavelength 4X over OC-48 (2.48 Gbps)
 10 GbE access directly or aggregate multiple
1 Gbps into 10 GbE

Service Provider/LEC
DWDM
Ethernet Framing

1 or 10 Gb 1 or 10 Gb
Ethernet Ethernet

Distance: 100 km
Summary: 10 GbE
in MAN/WAN

Rate
10 GbE over Adaptation
Service Provider/LEC
SONET/OC-192
SONET/TDM Yes
(SONET framing) OC-48, OC-192

10 GbE over 10 Gbps Service Provider/LEC

DWDM (Ethernet DWDM


No
framing)

Service Provider/LEC
10 GbE over dark fiber
No
(Ethernet framing)
Integrated Solutions

Gigabit and
10 Gigabit Ethernet on
Fiber and Copper in the
LAN Enterprise/SP

10 GbE in the MAN (Dark


Fiber)
ILEC/CLEC/SP

10 GbE L2 Interface
WAN (SONET
OC-192) IXC WAN
Transport
DWDM
Network
Réseaux IP – VPN
Distinguer VPN Internet et “ vrais offres ” VPN-IP des opérateurs
télécom
La qualité de service éventuellement présente au niveau 2 est
déplacée au niveau 3 (ce qui permet de faire des distinctions par
application – port (c.ad. par type de flux) et non par adresse
station seulement.
Couche 2 minimale ou inexistante (exemple de IP over SDH)

VPN : communication any to any (pas de définition de circuit


entre les différents nœuds d’un réseau)
Configuration en hub and spoke ou fully meshed
Les classes de service
Un (vrai) réseau VPN-IP:

- offre de la QoS (classes critiques pour la voix, classes medium


pour le transactionnel : offrir un temps de réponse, classe
« best effort »: FTP, browsing Internet)

- sécurité maximale (réseaux privés imperméables au sein du


réseau VPN de l’opérateur)

- indépendant des réseaux physiques d’extrémité


(collecte/transport ATM, Frame, LS, boucle locale optique, …)

- cœur de réseau IP: MPLS (e.g), commutation de labels


insérés dans les trames
- routeur P provider
- routeur frontière (ATM/IP) : PE (provider edge)
- routeur client CE (customer edge)
Virtual Private Network via Internet

 “Private network” basé un réseau public: Internet


 Objectif:

 Connecter des “private networks” en utilisant une


infrastructure publique

 Requirement: Securité via IPSEC

Pas de QOS (Quality of Service)