Vous êtes sur la page 1sur 27

TUTORIEL pour réaliser une simulation

avec Orcad Capture-Pspice

A). Présentation :

I ). Introduction :
La réalisation d’une simulation peut se décomposer en différentes étapes, pour lesquelles le respect
et la minutie de réalisation des étapes sont primordiaux pour obtenir une simulation correcte.
Les différentes étapes sont les suivantes :
 La saisie du schéma sous Orcad Capture,

 La recherche et la saisie des Modèles Pspice (Footprints),

 La simulation du schéma,

 L’analyse des résultats obtenus.

 La sortie des résultats.

II ). Organisation d’Orcad :

Orcad Orcad
Schéma Capture Netlist Pspice Simulations

Capture Pspice
Librairies Librairies

Dessins Modèles
des des
Composants Composants

On saisit le schéma sous Orcad Capture, à l’aide de symboles qui sont contenus, dans des librairies
que l’on chargera OBLIGATOIREMENT à partir du répertoire PSPICE, et suivant les besoins.
Une fois le schéma fini et vérifié, on crée le Profile de Simulation. C’est ce fichier qui va définir quel
type de simulation l’on désire réaliser. Il faut donc que le schéma soit correct !
En chargeant la netlist, Orcad Pspice va chercher les modèles de simulations dans les librairies.
Il faut alors ouvrir le logiciel Probe pour afficher les résultats.
Il restera alors à interpréter les résultats, et les sortir sur imprimante.

Orcad Pspice 1 JFA08


B). Première Simulation :

I ). Lancement de Capture :
Pour dessiner un schéma électronique, on va utiliser Orcad Capture. Pour lancer le programme, il
faut :

 Soit cliquer sur l’icône :

 Soit aller dans le menu :


Demarrer -> Tous les Programmes -> Orcad Release 9.1 -> Capture.
Une fenêtre Orcad Capture s’ouvre.

II ). Créer un Nouveau Projet :


On choisit alors :

 Soit cliquer sur l’icône Create document :

 Soit aller dans le menu :


File -> New -> Project.

Une nouvelle fenêtre s’ouvre pour vous demander le nom et type de projet que vous désirez, et le
chemin où vous voulez le sauvegarder :

Orcad Pspice 2 JFA08


Nom du
Projet

Type du
Projet

Chemin
du Projet

Il faudra donner un nom « réaliste » fonction du schéma que vous voulez faire. Ce nom devra
avoir 8 caractères maximum, et pas de caractères bizarres (accents, tirets, …).
Pour faire une simulation, il faudra choisir le type Analog or Mixed A/D.
Le chemin devra pointer vers votre répertoire de travail soit K:\CAO\Schema.
Capture vous propose un choix de création, choisissez : Create a blank Project, puis on clique sur
OK.

Capture crée alors deux nouvelles fenêtres :


 Une fenêtre Projet (à gauche),

 Une feuille de schéma vierge (à droite).

Orcad Pspice 3 JFA08


Dans la fenêtre projet, on remarque :
 Le nom du projet dans la barre de titre : essai.opj

 Le nom de la feuille de schéma essai.dsn.

 Nous n’avons pas de librairies de chargées, pas de fichiers de sortie,

 pas de composants dans le cache, et pas de projets référencés.


La première chose à faire est de sauvegarder le projet, et la feuille de schéma. Pour cela, il faut
sélectionner la fenêtre de projet (sa barre de titre doit être bleue), puis de cliquer sur l’icône :

Ou avec le menu File -> Save ou Ctrl S.


Cela permet de sauvegarder le projet mais pas la feuille de schéma, il faut maintenant cliquer sur la
feuille de schéma (sa barre de titre devient bleue) et recommencer l’opération de sauvegarde
précédente !!

Orcad Pspice 4 JFA08


III ). Ajout de bibliothèques :
En cliquant sur la feuille de schéma, on fait apparaître une barre d’outils sur la droite de la feuille.

On sélectionne le bouton « Place Part » pour aller chercher les composants :


Une nouvelle fenêtre s’ouvre, mais vide, car nous n’avons pas chargé de librairies.
Sinon, il vous faudra effacer toutes les librairies présentes.
Il faut donc presser le bouton « Add Library » ; et aller chercher les librairies dans le répertoire
PSPICE :

Et sélectionner alors le fichier analog.olb, puis tous les fichiers qui vous intéresse du répertoire, puis
ouvrir :

Nous avons donc maintenant quelques composants pour travailler !

IV ). Création du schéma :
Réalisez votre schéma comme d’habitude.
Orcad Pspice 5 JFA08
Quand vous choisissez un composant dans la librairie, les icones en bas permettent de dire avec quel type
de projet, on peut utiliser le composant choisit, ici, on peut utiliser R avec un projet de simulation Spice
, et avec un projet de Circuit imprimé Layout . Si c’est le composant qui nous intéresse, il suffit de
faire OK.

V ). Exigences de Pspice :

La première exigence Pspice est qu’il faut lui fournir une seule masse : .
Et Toutes les mesures seront faites à partir de ce point !
La deuxième exigence Pspice est qu’il faut que tous les composants aient au moins deux broches.
Donc les connecteurs sont interdis.
Créer alors le schéma suivant :

Sauvegardez et fermez le schéma.

VI ). Création du profile de simulation :


Choisir alors dans le menu Pspice, New Simulation Profile :

Une nouvelle fenêtre s’ouvre pour vous demander le nom du profil de simulation :

Orcad Pspice 6 JFA08


Entrez un nom, puis create, une nouvelle fenêtre s’ouvre pour vous demander les caractéristiques du
profil :

 Dans Analyse type :


Vous avez le choix entre
 Time Domain (Transient) : c’est l’analyse en fonction du temps, comme un oscilloscope.

 DC Sweep : c’est une analyse en continu, pour tracer des transferts en tension.

 AC Sweep : c’est une analyse en alternatif, pour tracer les diagrammes de bode.

 Bias Point : c’est le point de polarisation, l’étude en continu avant l’étude en petits signaux.
Choisissez Time Domain (Transient).
 Run to time :
C’est le temps de simulation que vous voulez observer. Plus ce temps est grand, plus le calcul est
long !
Choisissez 10ms.
 Start saving data after :

Orcad Pspice 7 JFA08


C’est le temps à partir duquel vous voulez sauver les résultats.
Ne pas toucher, pour l’instant.
 Maximum step size :
C’est le pas de calcul, si vos courbes ne sont pas belles, mettez Run to time/10000 mais le calcul va
être long, et le ficher de données énorme !
Ne pas toucher pour l’instant.
 Skip the initial transient bias point calculation :
Ne pas toucher pour l’instant.
Faire Ok.

VII ). Lancement de la simulation :


Choisir alors dans le menu Pspice, Run :

Une nouvelle fenêtre s’ouvre, les calculs s’effectuent, et si tout va bien, vous avez la fenêtre suivante :

Revenez à la fenêtre de ORCAD Capture, ouvrez votre feuille de schéma, puis sélectionnez une sonde de
tension :

Orcad Pspice 8 JFA08


Ou une sonde de courant :

Puis poser la sur votre schéma à l’endroit où vous voulez voir la tension simulée(ou sur la patte
du composant pour voir le courant). Faire End Mode pour lâcher les sondes.
Les sondes se colorent pour pouvoir les différencier sur les courbes. Vous devez obtenir :

Allez maintenant dans la fenêtre schematic dans la barre des taches, et vos courbes sont tracées :

Orcad Pspice 9 JFA08


Remarquez l’échelle des Y qui n’est pas très bien choisie, allez dans le menu Plot -> Axis Settings :

Une nouvelle fenêtre s’ouvre, pour vous proposer de modifier les axes. Allez sur Y Axis, User
Define et mettez 0 to 10V. Puis Ok.

Orcad Pspice 10 JFA08


La fenêtre se referme, et le tracé est redessiné avec les nouveaux axes :

Nous avons donc notre pont diviseur, et fait notre première simulation.

C). Deuxième Simulation :

I ). Présentation :
On va chercher maintenant à tracer la tension de charge d’un condensateur. Dessinez le schéma
suivant sous Capture :
R1

1k
V V
V1
10Vdc
C1
1u

Puis lancez la simulation en Time Domain (Transient) sur 10ms. Vous obtenez alors ceci :

Orcad Pspice 11 JFA08


Alors votre avis ? La courbe ne correspond pas à ce que l’on attendait.
Solution :
Quand on a des condensateurs, et des selfs dans un montage à simuler, et que l’on désire voir les
états transitoires, il faut donnez les conditions initiales de ces composants.
Cliquez alors sur le condensateur, et éditez ses propriétés :

Orcad Pspice 12 JFA08


Et modifiez la propriété IC (Initial Condition : Conditions initiales) et positionnez la à la tension
initiale du condensateur (ou au courant initial d’une self) ici à 0. Puis relancez la simulation :

C’est mieux, non !

 Exercice d’application :
Réaliser la simulation de décharge d’un condensateur de 1µF à travers une résistance de 1 kΩ,
sachant que Vc0=10V.
R1

1k

1u
C1

II ). Différents types de générateurs utilisables en mode Transient :


Vous pouvez utiliser les générateurs de tension (et de courant) suivants de la bibliothèque
SOURCE.OLB qui permettent d’obtenir différentes formes de tension (ou de courant) :

1°). Générateur sinusoïdale :


Le générateur de tension sinusoïdale (courant sinusoïdal) se nomme VSIN (ISIN) :

Orcad Pspice 13 JFA08


Il possède 3 caractéristiques principales :
VOFF : c’est la tension d’offset (tension continue) du générateur sinusoïdal.
VAMPL : c’est l’amplitude max du générateur sinusoïdal.
FREQ : c’est la fréquence du générateur sinusoïdal.

 Exercice d’application :
Réaliser la simulation du montage suivant :
D1

D1N4004
V V

V1
VOFF = 0 R1 C1
VAMPL = 10
FREQ = 50 1k 10u

Vous devez trouver les résultats suivants :

Orcad Pspice 14 JFA08


2°). Générateur de signal carré :
Le générateur de signal carré se nomme VPULSE :

Il possède 7 caractéristiques principales :


V1 : c’est la tension du niveau bas (V1=0V).
V2 : c’est la tension du niveau haut.
TD : c’est le temps de départ avant que le signal commence à osciller (TD=0s).
Orcad Pspice 15 JFA08
TR : c’est le temps de montée du signal carré, il ne doit pas être nul (TR=1us).
TF : c’est le temps de descente du signal carré, il ne doit pas être nul (TF=1us).
PW : c’est le temps du niveau haut du signal carré.
PER : c’est la période du signal.

 Exercice d’application :
Réaliser la simulation du montage suivant :
R2

V V
1k
V1 = 0 V2
V2 = 10 C2
TD = 0
TR = 1u 1u
TF = 1u
PW = 5m
PER = 10m

Vous devez trouver les résultats suivants :

Orcad Pspice 16 JFA08


3°). Générateur de signal par morceaux :
Le générateur de signal par morceaux se nomme VPWL :

Il possède 10 couples maximum de caractéristiques (Vn, Tn) :


Vn : c’est la tension au point n (l’ordonnée du point n).
Tn : c’est le temps au point n (l’abscisse du point n).
On trace donc la courbe désirée point par point.
Orcad Pspice 17 JFA08
 Exercice d’application :
Réaliser la simulation du montage suivant :
R3

V V
T1 = 0 V1 = 0 1k
T2 = 4.95ms V2 = 0 V3
T3 = 5ms V3 = 10 C3
T4 = 9.95m V4 = 10
T5 = 10ms V5 = 5 1u
T6 = 14.95m V6 = 5

Vous devez trouver les résultats suivants :

Orcad Pspice 18 JFA08


4°). Générateur autres :
Il existe bien d’autres types de générateurs, à vous de les tester si ça vous dit !

III ). Simulations logiques :


Pspice peut aussi simuler des circuits logiques, mais il faut savoir qu’en fait il les simule de façon
Analogique. Vous devez absolument aller chercher les composants logiques dans le répertoire
PSPICE. Par défaut, les circuits sont alimentés en 5V.

1°). Porte Inverseuse :


Simuler le schéma suivant :

U1A
DSTM1
S1 1 2
7404
Implementation = E1 V V

en allant chercher DStim dans la librairie SOURCESTM. Donner un nom à l’implémentation,


sélectionnez DStim, puis faire Edit Pspice Stimulus :

Orcad Pspice 19 JFA08


Une nouvelle fenêtre s’ouvre, pour vous demander la forme du signal que vous voulez générer :

Choisissez Clock par exemple, pour générer un signal carré de type Horloge. Une nouvelle
fenêtre s’ouvre, pour fixer les caractéristiques de l’horloge :

Orcad Pspice 20 JFA08


Faire Ok, puis Stimulus Editor vous dessine le signal pour vérifier qu’il correspond à ce que
vous lui avez rentré :

Puis faire File -> Exit, il vous demande si il doit mettre à jour le schéma, répondre OUI, puis il
ferme les fenêtres, vous pouvez alors lancer la simulation temporelle, et vérifier que l’inverseur
fonctionne !

Orcad Pspice 21 JFA08


Remarque, si vous utilisez des bascules ou des compteurs, il faudra penser à initialiser toutes
les bascules à 0. Pour cela, faire Pspice -> Edit Simulation Profile, puis l’onglet Options, puis
mettre initialize all flip-flops à 0 :

 Exercice d’application :
Réaliser la simulation du montage suivant :
HI
U2A
1
J 3
DSTM1 Q
S1 12
CLK 2
Q V
Implementation = E1 4
CLR

V K

74107
13

HI

On remarquera les niveaux 1 à appliquer sur J, K, CLR que l’on ira chercher dans Place
Power, (et il en sera de même pour un niveau logique 0) :

Vous devriez donc obtenir le résultat suivant :


Orcad Pspice 22 JFA08
IV ). Simulations mixtes :
Pspice peut donc simuler des circuits logiques et analogiques dans le même schéma.

1°). Astable :
Simuler le schéma suivant :
R1

PARAM ET ERS:
1k
CD4000_VDD = 12V
U1A
1
3
V HI
2
C1 V
CD4093B
1u

Allez chercher le composant PRARMETERS dans la librairie SPECIAL, puis éditez ses
propriétés, faire New Column :

Orcad Pspice 23 JFA08


Cela permet d’alimenter les circuits CMOS en 12V au lieu du 5V par défaut.
Vous obtenez alors le graphe suivant :

2°). Astable à NE555 :


Simuler le schéma suivant :
VCC=15V

P1
150k

R1
15k

R3
8
D1 U2 10k
V1
D1N4148 VCC
15Vdc D2 2
4 TRIGGER 3 VS
D1N4148 R2 5 RESET OUTPUT
6 CONTROL
27k 7 THRESHOLD
+ IC= 0 DISCHARGE
VC GND
555B
1
C1 C2
150n 10n

Vous obtenez alors le graphe suivant :

Orcad Pspice 24 JFA08


V ). Simulations de filtres :
Pspice peut aussi donner la réponse en fréquence de filtres : c’est l’analyse AC SWEEP.

1°). Filtre passe bas RC :


Dessinez le schéma suivant :
R1

1k
VDB
V1
VP
1Vac
0Vdc C1
1u

Pour cette analyse, il faudra absolument prendre un générateur VAC :

Orcad Pspice 25 JFA08


Puis, pour faire Pspice Edit Simulation Profile, et le remplir comme ci-dessous :

Vous remarquerez que l’on demande un type d’analyse en AC SWEEP, avec un parcours de
fréquence de type logarithmique, avec une fréquence de départ de 1 Hz et de fin de 1Mhz (1
MEG), avec une précision de 10 points par décade. Vous devez alors trouvez le diagramme
suivant en allant chercher les marqueurs suivants :

Orcad Pspice 26 JFA08


pour la tension, et phase of voltage pour le déphasage.

Orcad Pspice 27 JFA08