Vous êtes sur la page 1sur 103

MENU

MENU * Faire défiler la feuille si besoin, et


cliquer sur le bouton, face au libellé
* Toutes les feuilles sont protègées en écriture , seules les cellules de couleur verte sont modifiables .

1 BASE DE DONNEES - Extraire des données d'un champ

2 BASE DE DONNEES - Obtenir un classement sur un champ en conservant un ordre de tri

3 BASE DE DONNEES - Trier des données autrement que par ordre alphabétique

4 BASE DE DONNEES - Comparaison de données

5 CALCUL - Somme conditionnelle (1) Entre deux dates

6 CALCUL - Somme conditionnelle (2)

7 CALCUL - Somme conditionnelle (3) Totaux par catégorie

8 CALCUL - Somme avec messages d'erreur

9 CALCUL - Afficher un type d'information en fonction du résultat

10 CALCUL - Somme toutes les "n" colonnes

11 CALCUL - Somme toutes les "n" lignes

12 CALCUL - Somme des valeurs positives et des valeurs négatives

13 CALCUL - Moyenne ne tenant pas compte des valeurs " Zéro "

14 CALCUL - Somme entre 2 bornes

15 CALCUL - Additionner une cellule sur deux

16 COPIE - Transposer un tableau

Page 1
MENU

17 DATE - Nombre de jours dans le mois de la date

18 DATE - Fêtes mobiles

19 DATE - Calculer le n° de la semaine d'une date

20 DATE - Calculer le n° du trimestre

21 DATE - Nombre de jours ouvrés entre deux dates

22 DATE - Calculer un âge à partir de la date de naissance

23 DATE - Obtenir une date de paiement "60 jours fin de mois"

24 DATE - Obtenir la date du 1er jour du mois

25 DATE - Afficher automatiquement le mois en toutes lettres en fonction d'un nombre

26 DATE - Afficher les dates en majuscules ou en nom propre

27 DATE - Décaler une date de plusieurs mois

28 DATE - Combien de temps entre deux dates , en années , en mois ou en jours

29 DATE - Formatage de cellules

30 DATE - Calcul sur 12 mois glissants

31 DATE - Calcul de l'ancienneté en mois et années

32 DIVERS - Mise à jour automatique d'un n° de liste

33 DIVERS - Transformer des valeurs "textes" en valeurs "numériques"

34 DIVERS - Eviter que les données de type " FRACTIONS " soient interprétées comme des " DATES "

Page 2
MENU

35 DIVERS - Expliquer les valeurs d'erreur avec des messages

36 EXTRACTION - Extraire la partie entière et la partie décimale

37 EXTRACTION - Extraire la 1ère partie d'une saisie

38 EXTRACTION - Intervertir les deux parties d'une saisie

39 FINANCE - Calcul sur les prêts

40 FORMAT - Formatages spéciaux (1) Téléphone et KiloFrancs

41 FORMAT - Formatages spéciaux (2) Aligner les chiffres sur leurs virgules

42 FORMAT - Formatages spéciaux (3) Ecrire en Centièmes de Secondes

43 FORMAT - Formatages spéciaux (4) Valeurs négatives entre parenthèses

44 FORMAT - Formatages spéciaux (5) Ecrire des températures

45 FORMAT - Formatages spéciaux (6) Automatiser les adjectifs ordinaux

46 FORMAT - Formatages spéciaux (6) Combiner l'incrémentation des dates et des jours de la semaine

47 HEURE - Calculs en centièmes d'heure

48 HEURE - Cumul horaire au-delà de 24 heures

49 HEURE - Calcul horaire ventilé (h:m:s)

50 HEURE - Calcul d'heures entre le soir et le lendemain matin

51 RECHERCHE - Trouver le n° de la ligne d'une référence

52 RECHERCHE - Plus grande / plus petite valeur à la nième place

53 RECHERCHE - Contenu de la dernière cellule d'une colonne

Page 3
MENU

54 RECHERCHE - Afficher une information en fonction d'une valeur

55 RECHERCHE - Recherche dans une liste (contrôle de présence)

56 STATS - Compter les occurences

57 STATS - Afficher la valeur qui apparaît le plus souvent

58 STATS - Répartition par tranche d'âge

59 STATS - Recherches statistiques

60 STATS - Déterminer le nombre de références répondant à un critère défini

61 STATS - Rechercher des références répondant à un critère défini

62 STATS - Totaliser par catégorie

63 STATS - Cumul en fonction de critères multiples

64 STATS - Fréquence sur un intervalle

65 STATS - Elaborer un décompte des articles

66 TEXTE - Extraction sur des chaînes de caractères

67 TEXTE - Concatener le contenu d'un ensemble de cellules (1)

68 TEXTE - Concatener le contenu d'un ensemble de cellules (2)

69 TEXTE - Créer des points de suite

70 TEXTE - Supprimer les espaces inutiles dans une phrase

71 TEXTE - Des chiffres en toutes lettres

Page 4
MENU

72 TEXTE - Indiquer visuellement les valeurs limites de données des cellules

73 TEXTE - Différentes extractions de caractères

74 MACROS - L'Euro Version Excel 97

75 MACROS - L'Euro Version Excel 7

76 MACROS - Convertir en majuscules Version Excel 97

77 MACROS - Convertir en minuscules Version Excel 97

78 MACROS - Convertir en majuscule la première lettre d'une phrase Version Excel 97

79 MACROS - Comparer deux colonnes de données et éffacer les doublons Version Excel 97

Page 5
1

* Nbre de jours dans le mois de la date


5/12/1998

31

=JOUR(DATE(ANNEE(A3);MOIS(A3)+1;0))

Page 6
2

* Fêtes mobiles
Année: 1995
- PAQUES: #REF!

=SI(MOD(19*MOD(an;19)+24;30)+MOD(2*MOD(an;4)+4*MOD(an;7)+6*MOD(
19*MOD(an;19)+24;30)+5;7)-9<=0;DATE(an;3;22+MOD(19*MOD(an;19)+24;30)
+MOD(2*MOD(an;4)+4*MOD(an;7)+6*MOD(19*MOD(an;19)+24;30)+5;7));
DATE(an;4;MOD(19*MOD(an;19)+24;30)+MOD(2*MOD(an;4)+4*MOD(an;7)+6*
MOD(19*MOD(an;19)+24;30)+5;7)-9))

- ASCENSION: #REF! =C4+39


NOMS:
C3 an
- PENTECOTE: #REF! =C4+49

Page 7
3

* Calculer le numéro de la semaine d'une date


7/12/1956 28

=ENT((A3-DATE(ANNEE(A3);1;1)+SI(JOURSEM(DATE(ANNEE(A3);1;1))>1;
JOURSEM(DATE(ANNEE(A3);1;1))-2;JOURSEM(DATE(ANNEE(A3);1;1))+5))/7)

Page 8
4

* Extraction sur les chaînes de caractères


Patrick Vincenti 16

=NBCAR(B3)

CODE
1E458AA Erreur =SI(NBCAR(B8)>6;"erreur";"")
AZE342
RET4321 Erreur
5Z8JUG

Page 9
5

* Concatener le contenu d'un ensemble de cellules (1)

=SI(C5<>"";(TEXTE(C5;0)&" Kg de "&B5);"")
Produits Commande
Melon 120 120 Kg de Melon
Pêche
Poire 75 75 Kg de Poire
Pomme 100 100 Kg de Pomme
Prune
Raisin 210 210 Kg de Raisin

Vous avez commandé 120 Kg de Melon 75 Kg de Poire 100 Kg de Pomme 210 Kg de Raisin

="Vous avez commandé "&D5&" "&D6&" "&D7&" "&D8&" "&D9&" "&D10

Page 10
6

* Calculs sur les prêts


CAPITAL DUREE TAUX RBST/MOIS
50000 48 12% #REF!

Calcul du rbst mensuel #REF! =-VPM(tx1/12;dur1;cap1;0)

Calcul du taux #REF! =TAUX(dur1;-rbst1;cap1)*12

Calcul de durée #REF! =NPM(tx1/12;-rbst1;cap1)

Calcul du capital #REF! =VA(tx1/12;dur1;-rbst1)

NOMS:
D3 tx1 B3 cap1
C3 dur1 E3 rbst1

Page 11
7

* Calculs en centièmes d'heure


HH:MM:SS Heures et centièmes

17:45 17.75

=(B5-ENT(B5))*24

HH:MM:SS Heures et centièmes

14:15:00 14.25

=TEMPS(TRONQUE(D11);ARRONDI((D11-TRONQUE(D11))*60;);0)
(Formater la cellule en hh:mm:ss)

Page 12
8

* Cumul temps au-delà de 24 heures

Durées
9:00 HH:MM:SS
12:30 59:30:00
16:00
22:00 =SOMME(B4:B7)
(Format [h]:mm:ss)

HH et 100ème
59.50

=SOMME(B4:B7)*24
(Format 0,00)

Page 13
9

* Calcul horaire ventilé en hh; mm et ss


11:30:00 Heures Minutes Secondes
15:00:45 26 30 45

=ENT((A3+A4)*86400/3600)

=ENT((((A3+A4)*86400)-3600*C4)/60)

=(((A3+A4)*86400)-3600*C4)-60*D4

Page 14
10

* Compter les occurences

LISTE COMPTER
CC FF
BB
FF #REF! {=SOMME(SI(liste=D4;1;0))}
AA
CC (ou)
AA
FF #REF! {=SOMME((liste=D4)*1)}
AA
- Saisir les formules:
NE PAS VALIDER , mais confirmer
Noms: avec CTRL + MAJ + ENTREE
B4:B11 liste pour obtenir les accolades .

Page 15
11

* Trouver le n° de la ligne d'une référence


NOMS
Claude
Bernard Nom recherché Isabelle
Jean
Yves N° de la ligne #REF!
Rémi
Eric =SI(nr<>"";EQUIV(nr;liste1;0)+2;"")
Marcel
Paul
Christine
Isabelle
Philippe NOMS:
Henri D4 nr
Catherine A3:A15 liste1

Page 16
12

* Plus grande / plus petite valeur


dans une série, à la nième place

Données Contrôle
10 56 9
25 =GRANDE.VALEUR(A5:A11;3) 39 10
39 25 12
18 25 18 18
12 12 25
56 18 10 39
9 9 56
=PETITE.VALEUR(A5:A11;4)

TRI : Décroissant Croissant


3 ème place : 25
4 ème place : 18

Page 17
13

* Affiche la valeur qui apparaît le plus


souvent dans une plage de cellules
PLAGE
10 #REF!
9
15 =MODE(plage)
10
8
12
15 NOMS:
10 A4:A14 plage
3
18
12

Page 18
14

* Repartition par tranche d'âge


Noms:
4/1/2019 B5:B15 AGE
Date Naiss Age Tranche d'age E5:E8 TRANCHE
7/15/1932 87 jusqu'à 20 ###
4/25/1980 39 jusqu'à 40 ###
3/2/1946 73 jusqu'à 60 ###
12/3/1951 68 au-delà ###
11/15/1962 57 TOTAL ###
10/16/1960 59
8/14/1945 74 =ANNEE($C$3)-ANNEE(A8) - Sélectionner la zone F5:F8
4/15/1928 91 - Saisir la formule:
2/23/1984 35 =FREQUENCE(AGE;TRANCHE)
1/6/1987 32 NE PAS VALIDER, mais confirmer
3/31/1938 81 avec CTRL MAJ ENTREE
TOTAL 11 =NB(B5:B15)

Page 19
15

* Recherches statistiques

NOM MONTANT NOM NBRE MONTANT


Claude 125.10 F Claude #REF! #REF!
Bernard 115.85 F
Catherine 210.00 F
Odile 312.50 F =SI(nom3<>"";NB.SI(nom2;nom3);"")
Claude 872.00 F
Michel 654.25 F =SOMME.SI(nom2;nom3;MONTANT)
Isabelle 651.00 F
Claude 301.50 F
Catherine 420.00 F
Christine 110.00 F NOMS:
Catherine 58.00 F A4:A14 nom2
C4 nom3
B4:B14 montant

Page 20
15

;MONTANT)

Page 21
16

* Déterminer le nbre de références


répondant aux critères définis Caractère recherché T
Position du caractère 2
Références
AZE412 #REF! Réponse:
RTY515 #REF! =SI(STXT(A6;pos;1)=car;1;"") #REF!
TRE012 #REF!
GFR458 #REF!
DTR892 #REF! =SOMME(B5:B14)
FDZ958 #REF!
GBN124 #REF! NB: si le caractère recherché est un chiffre
QTF002 #REF! le faire précéder d'une apostrophe (4)
MPT586 #REF!
MTH874 #REF! Noms:
G2 car
G3 pos

Page 22
17

*Rechercher des références répondant


à un critère défini
Car recherché E Place 2

CODE
1E458AA 2 ok =SI(C7=$D$3;"ok";"")
AZE342 3
RET4321 2 ok
5Z8JUG #VALUE! #VALUE!

=TROUVE($B$3;B7)

Page 23
18

* Afficher une information en fonction d'une valeur


Tableau de correspondances
DONNEES Quantité Obs Valeurs
155 Acceptable Entre et Obs
310 Inacceptable 0 99 Ok
210 Attention 100 199 Acceptable
180 Acceptable 200 299 Attention
280 Attention 300 >300 Inacceptable

105 Acceptable
58 Ok

=SI(ESTVIDE(B5);"";RECHERCHEV(B5;$E$6:$G$9;3;VRAI))

Page 24
19

* Totaliser par catégorie


Catégorie Quantité Catégorie Total
1 10 1 70
3 15 2 65
1 30 3 40
2 25
1 15 TOTAL 175
3 25
2 40
1 15 {=SOMME($B$4:$B$11*($A$4:$A$11=D4))}

TOTAL 175

NB: Accolades: Pour obtenir les accolades, à la fin de la saisie , utiliser


les touches CTRL+MAJ+ENTREE , au lieu de la touche ENTREE .

Page 25
20

* Extraire des données d'un champ

NOM CP - VILLE CP VILLE


CLAUDE 70000 Vesoul 70000 Vesoul
BERNARD 70100 Gray 70100 Gray
MYRIAM 70200 Lure 70200 Lure
BEATRICE 70300 Luxeuil 70300 Luxeuil
GASTON 70000 Vesoul 70000 Vesoul

=CNUM(STXT(B5;1;5))

=STXT(B5;7;(NBCAR(B5)-6))

Page 26
21

* Transposer un tableau
Produit 1 Produit 2 Produit 3 TOTAL
Janvier 145 120 180 445
Février 130 142 163 435
Mars 118 138 154 410
TOTAL 393 400 497 1290
-1) Sélectionner la zone de destination
-2) Saisir la formule sous la forme matricielle {=TRANSPOSE($A$3:$E$7)}
NB: NB: Validation ---> CTRL+ MAJ+ ENTREE
Le tableau de destination est mis à jour en cas de changement au niveau de l'original
Aucune modification ne peut-être apportée dans le tableau de destination

Janvier Février Mars TOTAL


Produit 1 145 130 118 393
Produit 2 120 142 138 400
Produit 3 180 163 154 497
TOTAL 445 435 410 1290

Page 27
22

* Nbre de jours ouvrés entre 2 dates


8/15/1996
10/15/1996

#REF!

=ENT((fin-debut-(SI(JOURSEM(debut)=1;-1;7-JOURSEM(debut))
+SI(JOURSEM(fin)=7;0;JOURSEM(fin)-1)))/7*5)+SI(JOURSEM(debut)=1;
0;7-JOURSEM(debut))+SI(JOURSEM(fin)=7;0;JOURSEM(fin)-1)

NOMS:
A3 debut
A4 fin

Page 28
23

* Calculer un âge à partir de la date de naissance


10/16/1954 64

=SI(MOIS(AUJOURDHUI())>MOIS(A3);ANNEE(AUJOURDHUI())-ANNEE(A3);
SI(ET(MOIS(AUJOURDHUI())=MOIS(A3);JOUR(AUJOURDHUI())>JOUR(A3));
ANNEE(AUJOURDHUI())-ANNEE(A3);ANNEE(AUJOURDHUI())-ANNEE(A3)-1))

Date de naissance

7/12/1956 62

=ENT(JOURS360(B12;AUJOURDHUI())/360)

10/16/1954 64

=ANNEE(AUJOURDHUI()-B16)-1900

Page 29
24

* Obtenir un classement sur un champ


en conservant un ordre de tri initial
MARQUES UNITES CLT CLT
Citroën 50000 2 #REF!
Peugeot 40000 3 #REF!
Renault 80000 1 ( ou ) #REF!
Rover 38500 4 #REF!
Saab 1000 6 #REF!
Volskwagen 2000 5 #REF!

(Tri initial sur les MARQUES) =NB(unites)+1-RANG(B5;unites;1)

=SOMME(SI($B$5>B5;1);SI($B$6>B5;1);SI($B$7>B5;1);SI($B$8>B5;1);
SI($B$9>B5;1);SI($B$10>B5;1))+1

Page 30
25

* Trier des données autrement que


par ordre alphabétique
* Liste brute * Tri spécifique * Procédure:
VILLE VOLUME VILLE VOLUME Etape 1:
Vesoul 120 Vesoul 110 - Créer une liste personnalisée
Luxeuil 150 Vesoul 120 Données - Options - Liste personnalisées
Gray 110 Vesoul 180 (dans l'exemple:
Vesoul 180 Gray 110 Vesoul - Gray - Lure - Luxeuil)
Lure 150 Gray 165
Luxeuil 125 Lure 150 Etape 2:
Vesoul 110 Luxeuil 125 - Données - Trier
Gray 165 Luxeuil 150 - Cliquer sur le bouton "Options"
- Sélectionner la liste personnalisée

Page 31
26

* Formatages spéciaux (1)


TELEPHONE:
Valeur saisie Valeur affichée
16184848484 (16 1) 84 84 84 84
184848484 (1) 84 84 84 84
84848484 84 84 84 84 Format pour les cellules B5:B7:

[>=200000000](##\ #) ##\ ##\ ##\ ##;[>=100000000](##) ##\ ##\ ##\ ##:00\ 00\ 00\ 00

KILOFRANCS (KF):
Valeur saisie Valeur en KF
10,000.00 F 10 KF Format pour les cellules B13:B15:
1,250,000.00 F 1,250 KF
15,000.00 F 15 KF # ##0 " KF"

Page 32
27

* Obtenir une date de paiement "60 jrs fin de mois"

Date 60 jrs FM
5/21/1999 Err:520

=FIN.MOIS(B5;0)+60+1

(La cellule C5 doit être formatée au format Date)

NB: Avant de saisir la formule , contrôler que l'option


"Utilitaire d'Analyse" est cochée dans le menu
OUTILS - MACROS COMPLEMENTAIRES .

Page 33
28

* Obtenir la date du 1er jour du mois

Date 1er jr/mois


12/25/1996 Err:520

=FIN.MOIS(B5;-1)+1

NB: Avant de saisir la formule , contrôler que l'option


"Utilitaire d'Analyse" est cochée dans le menu
OUTILS - MACROS COMPLEMENTAIRES .

Page 34
29

* Réaliser une somme conditionnelle (1)

Date Valeur
11/29/1996 15 * Objectif: Réaliser la somme des valeurs
11/30/1996 12 entre 01/12/96 et le 03/12/96
12/1/1996 10
12/2/1996 12
12/3/1996 15
12/4/1996 13
NB: Validation : CTRL+ MAJ+ ENTREE pour obtenir les accolades .
0

{=SOMME((B5:B10)*(A5:A10>=DATEVAL("01/12/96"))*(A5:A10<=DATEVAL("03/12/96")))}

Page 35
30

* Somme avec plage comportant des


messages d'erreur
100 100
#N/A #N/A
-20 -20
#DIV/0! #DIV/0!

#DIV/0! 80

=SOMME(B4:B7) {=SOMME(SI(ESTERREUR(D4:D7);"";D4:D7))}

NB: Validation ---> CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 36
31

* Afficher "Négatif - Nul - Positif"


en fonction du résultat
Valeurs
100
200
-20
70
-200
10
-20

Positif Formater la cellule sous la forme:


[<0] "Négatif"; [=0] "Nul";"Positif"
=SOMME(B5:B11)

Page 37
32

* Créer des points de suite dans une cellule

Claude 150

Claude.................................................................. 150
Jean...................................................................... 100

- Créer un format @*. (arobasque+étoile+point)


( Les cellules A8:A12 sont ainsi formatées)

Page 38
33

* Mise à jour automatique d'un n° de liste


en cas de suppression d'une ligne

N° Action
1 Téléphoner à l'EDF - Mise en place:
2 Préparer le budget - Saisir 1 en A5
3 Téléphoner à Claude - Saisir la formule suivante en A6
4 Préparer le budget =NB($A$5:A5)+1
5 Etudier Excel - Recopier la formule avec la poignée

N° Action
1 Téléphoner à l'EDF
2 Téléphoner à l'EDF
3 Contrôler les factures
4 Etudier Excel

NB: Les lignes 13 - 14 et 15 peuvent être supprimées. En cas d'insertion, recopier la formule .

Page 39
34

* Comparaison de données
NB: - Les données doivent être triées

LISTE 1 LISTE 2 LISTE 3


Claude Claude Claude
Luc Luc Eric
Martine Martine Martine
Nicole Nicole Nicole
Pierre Pierre Pierre

1 0

{=ET(A5:A9=C5:C9)} {=ET(A5:A9=E5:E9)}

NB: Validation ---> CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 40
35

* Recherche dans une liste (contrôle de présence)

LISTE 1
Claude Pierre 1 {=OU(D5=B5:B9)}
Pierre
Martine Jean 0 {=OU(D7=B5:B9)}
Philippe
Nicole
NB : Validation : CTRL+MAJ+ENTREE pour obtenir les accolades .

Page 41
36

* Contenu de la dernière cellule d'une colonne

Dernier n°
96028

N° Facture =INDEX(B8:B14;NBVAL(B8:B14);1)
96024
96025
96026
96027
96028

Page 42
37

* Additionner les valeurs d'une ligne toutes les n colonnes

10 2 5 3 10 5

{=SOMME(SI(MOD(COLONNE(A4:E4)-2;2)=0;A4:E4;0))}

10 2 5 3 10 25

{=SOMME(SI(MOD(COLONNE(A10:E10)-1;2)=0;A10:E10;0))}
Synthaxe:

{=SOMME(SI(MOD(COLONNE(plage)-n° colonne début;nbre de colonnes séparant 2 valeurs)=0;plage;0))}

NB: Validation ---> CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 43
38

* Extraire la partie entière et la partie décimale


d'un nombre
Valeurs Entier Décimal
125.69 125 #VALUE!
15 15
0.375 0 #VALUE!
-10.25 -10 #VALUE!
12.378 12 #VALUE!
-0.9 0 #VALUE!
-15 -15

=TRONQUE(A11)

=SI(TRONQUE(A5)=A5;"";(A5-TRONQUE(A5))*10^(NBCAR(A5)-TROUVE(",";A5)))

Page 44
39

* Extraire la 1ère partie d'une saisie

Claude Béneux Claude


Excel 5 Excel
Neurey Les La Demie Neurey
70000 Vesoul 70000
03 84 75 26 03 03

=STXT(A4;1;(NBCAR(A4)-(NBCAR(A4)-CHERCHE(" ";A4;1))))

Page 45
40

* Transformer des valeurs " texte " avec signes


en valeurs " numériques "

TEXTE NUMER
12,02- Err:502
500+ 500.000
15,25- Err:502
125,036- -125036.000
0 Err:502

=SI(ESTNUM(A6);A6;CNUM(DROITE(A6;1)&SUBSTITUE(A6;DROITE(A6;1);"")))

Page 46
41

* Calculer le n° du trimestre
=ENT((MOIS(B5)+2)/3)

2/15/1996 1
5/25/1996 2
12/10/1996 4
4/12/1996 2
7/17/1996 3
3/31/1996 1

Page 47
42

* Réaliser une somme conditionnelle (2)

Dates Valeurs
11/29/1996 100.00 F entre le 11/30/1996 et le 12/2/1996
11/30/1996 120.00 F
12/1/1996 300.00 F 570.00 F
12/2/1996 150.00 F
12/3/1996 300.00 F {=SOMME(B5:B10*(A5:A10>=D5)*(A5:A10<=F5))}
12/4/1996 110.00 F

NB: Validation : CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 48
43

* Calcul de fréquence sur un intervalle

Date naiss. Age


10/16/1960 58 Age mini 20
4/25/1963 55 Age maxi 45
7/2/1955 63 Nombre 0
9/23/1972 46
4/15/1958 60
12/22/1950 68 {=SOMME(SI(B5:B13*(B5:B13>=E5)*(B5:B13<E6);1;0))}
9/6/1962 56
8/10/1950 68 =ENT(JOURS360(A5;AUJOURDHUI())/360)
7/31/1953 65

NB: Validation : CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 49
44

* Cumul en fonction de critères multiples


Date Client Montant Client Claude
10/1/1996 Bernard 200.00 F Date début 10/25/1996
10/3/1996 Claude 100.00 F Date fin 12/7/1996
10/15/1996 Maurice 180.00 F MONTANT 350.00 F
10/25/1996 Laurence 110.00 F
11/5/1996 Claude 220.00 F
11/20/1996 Bernard 150.00 F
11/30/1996 Maurice 170.00 F
12/7/1996 Claude 130.00 F
12/8/1996 Laurence 120.00 F
12/15/1996 Claude 100.00 F
12/20/1996 Laurence 140.00 F

{=SOMME(C4:C14*(B4:B14=F3)*(A4:A14>=CNUM(F4))*(A4:A14<=CNUM(F5)))}

NB: Validation ---> CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 50
45

* Cumul des valeurs positives et des valeurs négatives

Valeurs * Somme des valeurs positives


200 650
-120
-100 {=SOMME(B5:B12*(B5:B12>0))}
200
-250
110 * Somme des valeurs négatives
140 -620
-150
{=SOMME(B5:B12*(B5:B12<0))}
30 =SOMME(B5:B12)

NB: Validation ---> CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 51
46

* Concatener le contenu d'un ensemble de cellules (2)

NOMS PRENOMS ADRESSE CP VILLE


VINCENTI PATRICK 10, RUE CARNOT 20200 BASTIA
MATTEI ANGE 3,BD PAOLI 20600 SISCO

VINCENTI PATRICK 10, RUE CARNOT 20200 BASTIA -Tirer la cellule "A7" pour exemple
avec la poignée de recopie .

CELLULE A7 : =A4&" "&B4&" "&C4&" "&D4&" "&E4

Si plusieurs noms dans la liste , tirer les cellules et faire un Copier-Coller des valeurs
du menu EDITION - COLLAGE SPECIAL - VALEURS, vers une destination .

Page 52
47

* Macro de l' euro . (Version : Excel 97 )


Insérer dans un module
Option Explicit
Const Rate As Single = 6,55957

Euros en Francs Sub EuroEnFranc()


Dim cel As Range
For Each cel In Selection
If IsNumeric(cel) Then
cel.Value = Application.Round(cel.Value * Rate, 2)
cel.NumberFormat = "# ##0.00" & """ F"";-# ##0.00" & """ F"""
End If
Next
End Sub

Francs en Euros Sub FrancEnEuro()


Dim cel As Range
For Each cel In Selection
If IsNumeric(cel) Then
cel.Value = Application.Round(cel.Value / Rate, 2)
cel.NumberFormat = "# ##0.00" & """ E"";-# ##0.00" & """ E"""
End If
Next
End Sub

Page 53
48

* Additionner les valeurs d'une colonne toutes les n lignes


3
10 4
20 8
5 3
6 2
10 5
9
13 {=SOMME(SI(MOD(LIGNE(C3:C8)-3;2)=0;C3:C8;0))}

35 {=SOMME(SI(MOD(LIGNE(A4:A9)-5;2)=0;A4:A9;0))}

Synthaxe:

{=SOMME(SI(MOD(LIGNE(plage)-n° ligne début;nbre de lignes séparant 2 valeurs)=0;plage;0))}

NB: Validation ---> CTRL+ MAJ+ ENTREE pour obtenir les accolades .

Page 54
49

* Supprimer les espaces inutiles dans une phrase

Texte est le texte dont vous voulez supprimer les espaces inutiles .

Texte est le texte dont vous voulez supprimer les espaces inutiles .

=SUPPRESPACE(B4)

NB: Il faut ensuite copié le texte obtenu à l'endroit désiré .

Page 55
50

* Macro de l' euro . ( Version : Excel 7 )


Insérer dans un module
Option ForceDcl
Const Taux En Simple = 6,55957

Euros en Francs Proc EuroEnFranc()


Dcl cel En Plage
Pour Chaque cel Dans Sélection
Si EstNumérique (cel) Alors
cel.Valeur = Application.Arrondi (cel.Valeur * TAUX; 2)
cel.FormatNombre = "# ##0.00" & """ F"";-# ##0.00" & """ F"""
Fin Si
Suivant
Fin Proc

Francs en Euros Proc FrancEnEuro()


Dcl cel En Plage
Pour Chaque cel Dans Sélection
Si EstNumérique (cel) Alors
cel.Valeur = Application.Arrondi (cel.Valeur / TAUX; 2)
cel.FormatNombre = "# ##0.00" & """ E"";-# ##0.00" & """ E"""
Fin Si
Suivant
Fin Proc

Page 56
51

*Convertir en majuscules . ( Version Excel 97 )


a- Lancer Visual Basic Editor .
b- Ouvrir le menu Insertion / Module .
c- Saisir le listing ci-dessous :

Sub MinMaj ()
Dim ChaineCellule As String
ChaineCellule = Selection.Value
ChaineCellule = UCase (ChaineCellule)
Selection.Value = ChaineCellule
End Sub

d- Affecter la macro à un bouton

Page 57
52

*Convertir en minuscules . ( Version Excel 97 )


a- Lancer Visual Basic Editor .
b- Ouvrir le menu Insertion / Module .
c- Saisir le listing ci-dessous :

Sub MinMaj ()
Dim ChaineCellule As String
ChaineCellule = Selection.Value
ChaineCellule = LCase (ChaineCellule)
Selection.Value = ChaineCellule
End Sub

d- Affecter la macro à un bouton

Page 58
53

* Réaliser une somme conditionnelle (3)

Catégorie Montant Totaux par Catégorie


Course 100.00 F Course 125.00 F
Cinéma 250.00 F Cinéma 360.00 F
Loyer 300.00 F Loyer 300.00 F
Course 25.00 F Essence 300.00 F
Essence 300.00 F
Cinéma 110.00 F

=SOMME.SI($A$5:$A$10;D8;$B$5:$B$10)

Page 59
54

* Aligner les chiffres sur leurs virgules

Valeur saisie Valeur affichée Ne pas centrer horizontalement .


12.3 12.3
1.666666 1.66667
1589.33 1589.33 Format pour les cellules B5:B7:

0,?????

Valeur saisie Valeur affichée


12.3 12.3000 Format pour les cellules B13:B15:
1.666666 1.6667
1589.33 1589.3300
0,0000

Page 60
55

*Saisir en Minutes , Secondes et Centièmes de secondes .

AFFICHER LES DIXIEMES DE SECONDES .


Valeur saisie Valeur affichée
54:06.0 54:06.0
12:21.3 12:21.3 Format pour les cellules B6:B8:
23:12.6 23:12.6
mm:ss,0

AFFICHER LES CENTIEMES DE SECONDES .


Valeur saisie Valeur affichée
46:24.23 46:24.23 Format pour les cellules B13:B15:
56:23.12 56:23.12
23:12.63 23:12.63
mm:ss,00

Page 61
56

* Eviter que les données de type " FRACTIONS "


soient interprétées comme des " DATES " .

* Saisie normale :
Valeur saisie Valeur affichée
6/7 6-Jul
6/8 6-Aug
1/7 1-Jul

* Saisie Fraction: Taper 0 (zéro) et ESPACE avant de saisir la fraction .


Valeur saisie Valeur affichée
1/ 2 1/ 2
3/ 4 3/ 4
6/ 7 6/ 7

Page 62
56

ir la fraction .

Page 63
57

* Valeurs Négatives entre parenthèses

Valeur saisie Valeur affichée - Format pour les cellules B8:B10


233 233
-544 (544) 0;"("0")"
-2 (2)

Page 64
58

*Ecrire des températures

* Saisie Celsius
Valeur saisie Valeur affichée
12 12.00 °C Format pour les cellules B7:B9 :
12.5 12.50 °C
254.12 254.12 °C 0.00" °C"

* Saisie Fahrenheit
Valeur saisie Valeur affichée Format pour les cellules B14:B16 :
12 12.00 °F
12.5 12.50 °F
254.12 254.12 °F 0.00" °F"

Page 65
59

* Intervertir les deux parties d'une saisie

Claude Béneux Béneux Claude


Patrick Vincenti Vincenti Patrick
Isabelle Untel Untel Isabelle
70000 Vesoul Vesoul 70000

=DROITE(A4;NBCAR(A4)-CHERCHE(" ";A4;1))&" "&GAUCHE(A4;CHERCHE(" ";A4;1))

( Mettre un ESPACE entre les GUILLEMETS )

Page 66
60

* Automatiser les adjectifs ordinaux

1 1er magasin - Format pour les cellules B4:B8


2 2ème magasin
3 3ème magasin
14 14ème magasin
31 31ème magasin
[=1]0"er magasin";0"ème magasin"

Cette formule se résume ainsi :

Si le contenu de la cellule égal 1 , ajouter " er magasin "


sinon insérer " ème magasin " .

Page 67
61

* Afficher automatiquement le mois


en toutes lettres en fonction d'un nombre

1 January
2 February
3 March =DATE(1900;A5;1)
4 April
5 May
6 June - Format pour les cellules C5:C16
7 July mmmm
8 August
9 September
10 October
11 November
12 December

Page 68
62

* Des chiffres en toutes lettres

102,586 cent deux mille cinq cent quatre-vingt-six

- Maximun : 200 000


=SI(TRONQUE($A4/1000)>1;RECHERCHEV(TRONQUE($A4/1000);TABLEAU;2)&" mille";
SI(TRONQUE($A4/1000)=1;"mille";""))&SI(TRONQUE(MOD($A4;1000)/100)>1;
RECHERCHEV(TRONQUE(MOD($A4;1000)/100);TABLEAU;2)&" cent";
SI(TRONQUE(MOD($A4;1000)/100)=1;"cent";""))&SI(ET(ET(MOD(A4;1000)<>100;MOD($A4;100)=0);
TRONQUE(A4/1000)<>A4/1000);"s";" "&RECHERCHEV(MOD($A4;100);TABLEAU;2))

Tableau : N2:O202

Page 69
62

0
1 un
2 deux
3 trois
4 quatre
5 cinq
6 six
7 sept
8 huit
9 neuf
10 dix
11 onze
12 douze
13 treize
14 quatorze
15 quinze
16 seize
17 dix-sept
18 dix-huit
19 dix-neuf
20 vingt
21 vingt et un
22 vingt-deux
23 vingt-trois
24 vingt-quatre
25 vingt-cinq
26 vingt-six
27 vingt-sept
28 vingt-huit
29 vingt-neuf
30 trente
31 trente et un
32 trente-deux
33 trente-trois
34 trente-quatre
35 trente-cinq
36 trente-six
37 tente-sept
38 trente-huit
39 trente-neuf
Page 70
62

40 quarante
41 quarante et un
42 quarante-deux
43 quarante-trois
44 quarante-quatre
45 quarante-cinq
46 quarante-six
47 quarante-sept
48 quarante-huit
49 quarante-neuf
50 cinquante
51 cinquante et un
52 cinquante-deux
53 cinquante-trois
54 cinquante-quatre
55 cinquante-cinq
56 cinquante-six
57 cinquante-sept
58 cinquante-huit
59 cinquante-neuf
60 soixante
61 soixante et un
62 soixante-deux
63 soixante-trois
64 soixante-quatre
65 soixante-cinq
66 soixante-six
67 soixante-sept
68 soixante-huit
69 soixante-neuf
70 soixante-dix
71 soixante et onze
72 soixante-douze
73 soixante-treize
74 soixante-quatorze
75 soixante-quinze
76 soixante-seize
77 soixante-dix-sept
78 soixante-dix-huit
79 soixante-dix-neuf
80 quatre-vingt
Page 71
62

81 quatre-vingt-un
82 quatre-vingt-deux
83 quatre-vingt-trois
84 quatre-vingt-quatre
85 quatre-vingt-cinq
86 quatre-vingt-six
87 quatre-vingt-sept
88 quatre-vingt-huit
89 quatre-vingt-neuf
90 quatre-vingt-dix
91 quatre-vingt-onze
92 quatre-vingt-douze
93 quatre-vingt-treize
94 quatre-vingt-quatorze
95 quatre-vingt-quinze
96 quatre-vingt-seize
97 quatre-vingt-dix-sept
98 quatre-vingt-dix-huit
99 quatre-vingt-dix-neuf
100 cent
101 cent un
102 cent deux
103 cent trois
104 cent quatre
105 cent cinq
106 cent six
107 cent sept
108 cent huit
109 cent neuf
110 cent dix
111 cent onze
112 cent douze
113 cent treize
114 cent quatorze
115 cent quinze
116 cent seize
117 cent dix-sept
118 cent dix-huit
119 cent dix-neuf
120 cent vingt
121 cent vingt et un
Page 72
62

122 cent vingt-deux


123 cent vingt-trois
124 cent vingt-quatre
125 cent vingt-cinq
126 cent vingt-six
127 cent vingt-sept
128 cent vingt-huit
129 cent vingt-neuf
130 cent trente
131 cent trente et un
132 cent trente-deux
133 cent trente-trois
134 cent trente-quatre
135 cent trente-cinq
136 cent trente-six
137 cent tente-sept
138 cent trente-huit
139 cent trente-neuf
140 cent quarante
141 cent quarante et un
142 cent quarante-deux
143 cent quarante-trois
144 cent quarante-quatre
145 cent quarante-cinq
146 cent quarante-six
147 cent quarante-sept
148 cent quarante-huit
149 cent quarante-neuf
150 cent cinquante
151 cent cinquante et un
152 cent cinquante-deux
153 cent cinquante-trois
154 cent cinquante-quatre
155 cent cinquante-cinq
156 cent cinquante-six
157 cent cinquante-sept
158 cent cinquante-huit
159 cent cinquante-neuf
160 cent soixante
161 cent soixante et un
162 cent soixante-deux
Page 73
62

163 cent soixante-trois


164 cent soixante-quatre
165 cent soixante-cinq
166 cent soixante-six
167 cent soixante-sept
168 cent soixante-huit
169 cent soixante-neuf
170 cent soixante-dix
171 cent soixante et onze
172 cent soixante-douze
173 cent soixante-treize
174 cent soixante-quatorze
175 cent soixante-quinze
176 cent soixante-seize
177 cent soixante-dix-sept
178 cent soixante-dix-huit
179 cent soixante-dix-neuf
180 cent quatre-vingt
181 cent quatre-vingt-un
182 cent quatre-vingt-deux
183 cent quatre-vingt-trois
184 cent quatre-vingt-quatre
185 cent quatre-vingt-cinq
186 cent quatre-vingt-six
187 cent quatre-vingt-sept
188 cent quatre-vingt-huit
189 cent quatre-vingt-neuf
190 cent quatre-vingt-dix
191 cent quatre-vingt-onze
192 cent quatre-vingt-douze
193 cent quatre-vingt-treize
194 cent quatre-vingt-quatorze
195 cent quatre-vingt-quinze
196 cent quatre-vingt-seize
197 cent quatre-vingt-dix-sept
198 cent quatre-vingt-dix-huit
199 cent quatre-vingt-dix-neuf
200 deux cent

Page 74
63

* Afficher les dates en majuscules

Wednesday 25 - Format cellule verte : jjjj j


MERCREDI 25

=MAJUSCULE(CHOISIR(JOURSEM(B4);"Dimanche";"Lundi";"Mardi";"Mercredi";"Jeudi";"Vendredi";"Samedi"))&" "&JOUR(B4)

Friday 12 - Format cellule verte : jjjj j


Vendredi 12

=NOMPROPRE(CHOISIR(JOURSEM(b12);"Dimanche";"Lundi";"Mardi";"Mercredi";"Jeudi";"Vendredi";"Samedi"))&" "&JOUR(b12)

Page 75
63

)&" "&JOUR(B4)

"))&" "&JOUR(b12)

Page 76
64

* Décaler une date de plusieurs mois

Date décalée
Date de départ Mois de décalage Avec Fin.mois Sans Fin.mois

10/31/1998 4 Err:520 Err:520 - NB : Pour être juste avec


2/28/1998 6 Err:520 Err:520 les fins de mois , il faut employé
6/30/1985 2 Err:520 Err:520 la formule avec la fonction
6/7/1954 12 Err:520 Err:520 FIN.MOIS .
10/23/1996 18 Err:520 Err:520 ( Surtout pour Février . )
7/12/1998 5 Err:520 Err:520
2/28/1987 4 Err:520 Err:520
Err:520 Err:520
=SI(A12="";"";MOIS.DECALER(A12;C12))

=SI(A12="";"";SI(A12=FIN.MOIS(A12;0);FIN.MOIS(A12;C12);MOIS.DECALER(A12;C12)))

- NB : Avant de saisir la formule , contrôler que l'option


"Utilitaire d'Analyse" est cochée dans le menu
OUTILS - MACROS COMPLEMENTAIRES .

Page 77
64

tre juste avec


is , il faut employé
ec la fonction

ur Février . )

"";MOIS.DECALER(A12;C12))

ECALER(A12;C12)))

Page 78
65

* Combien de temps entre deux dates


en années , en mois et en jours
Date Départ

7/12/1956 7/12/1999

- En Années : 43

=SI(OU(MOIS($D$6)<>MOIS($B$6);MOIS($D$6)=MOIS($B$6));ANNEE($D$6)-ANNEE($B$6);ANNEE($D$6)-ANNEE($B$6)-1)

- En Mois : 516

=SI(OU(JOUR($D$6)<>JOUR($B$6);JOUR($D$6)=JOUR($B$6));((ANNEE($D$6)-ANNEE($B$6))*12)+(MOIS($D$6)-MOIS($B$

- En Jours : 15705
=$D$6 - $B$6

Il y a 43 ans ou 516 mois ou 15705 jours entre ces deux dates .


="Il y a "&C9&" ans ou "&C13&" mois ou "&C17&" jours entre ces deux dates ."

Page 79
65

E($D$6)-ANNEE($B$6)-1)

(MOIS($D$6)-MOIS($B$6)))

Page 80
66

*Convertir en majuscule ( Version Excel 97 )


la première lettre d'une phrase

a- Lancer Visual Basic Editor .


b- Ouvrir le menu Insertion / Module .
c- Saisir le listing ci-dessous :

Sub premiermot_majuscule()
phrase = Selection.Value
phrase = UCase(Left(phrase, 1)) + Right(phrase, Len(phrase) - 1)
Selection.Value = phrase
End Sub

d- Affecter la macro à un bouton

Page 81
67

*Comparer deux colonnes ( Version Excel 97 )


de données et éffacer les doublons

a- Lancer Visual Basic Editor .


b- Ouvrir le menu Insertion / Module .
c- Saisir le listing ci-dessous :

Sub Comparaison()
Range("B1").Select
Do While ActiveCell.Value <> ""
Adresse1 = ActiveCell.Address
Nom1 = ActiveCell.Value
Range("C1").Select
Do While ActiveCell <> ""
If ActiveCell.Value = Nom1 Then
ActiveCell.Delete
End If
ActiveCell.Offset(1, 0).Range("A1").Select
Loop
Range(Adresse1).Select
ActiveCell.Offset(1, 0).Range("A1").Select
Loop
End Sub

d- Affecter la macro à un bouton

Page 82
68

* Expliquer les valeurs d'erreurs avec des messages

12 / 0 #DIV/0! 0
12 + A #VALUE! 0
=SI(TYPE.ERREUR(E5)=3;"Attention , vous ajouter un texte !!!")

Numéros
* #NUL! est renvoyée lorsque vous spécifiez l'intersection de deux zones qui ne se coupent pas. 1

* #DIV/0! indique qu'une formule tente d'effectuer une division par 0 (zéro). 2

* #VALEUR! est renvoyée lorsque vous utilisez un type d'argument ou d'opérande incorrect. 3

* #REF! est renvoyée lorsque vous faites référence à une cellule non valide. 4

* #NOM? est renvoyée lorsque vous utilisez un nom que Microsoft Excel ne reconnaît pas. 5

* #NOMBRE! indique qu'un nombre est utilisé de manière incorrecte. 6

* #N/A indique qu'aucune valeur n'est disponible. (Ex : Référence à une cellule vide ) 7

Page 83
68

, vous ajouter un texte !!!")

Page 84
69

* Indiquer visuellement
les valeurs limites de données des cellules
Valeurs saisies Valeurs affichées
52 =SI(A5>=100;1;-1)
125 O
450 O * Format des cellules ( B5:B15 )
23
5 [Rouge]"O";""
621 O - Afficher un O (comme Ophélie)
5 si la cellule contient une valeur positive
7 et ne rien afficher pour une valeur négative .

965 O * Police des cellules ( B5:B15 )


352 O Wingdings

Page 85
70

* Calcul d'heures entre le soir


et le lendemain matin

Début 12:00:25 - Entrer les données comme ci-dessous :


( le lendemain ) Fin 6:00:10 Heures (deux-points) Minutes (deux-points) Secondes

6:21:54
=B7-B5 17:59

=(B7+1)-B5 17:59:45

Page 86
70

-points) Secondes

Page 87
71

* Elaborer un décompte des articles

PRODUITS CATEGORIE 1 CATEGORIE 2 FOURNISSEURS Nbres de Produits


Fromage 2 1 1 2
Pommes 5 2 2 2
Oranges 4 10 3 3
Citrons 7 5 4 2
Thé 3 11 5 3
Bananes 3 4 6 1
Vin 10 3 7 2
Eau 6 12 8 0
Jambon 9 12 9 2
Biscuits 7 9 10 2
Jus de Fruits 11 5 11 3
Tomates 1 11 12 2

Numéros de fournisseurs =NB.SI($B$5:$C$16;E16)

Page 88
72

* Combiner l'incrémentation des dates


et des jours de la semaine
Valeurs saisies Valeurs affichées
5/21/1965 Friday 21 May 1965
2/27/1956 Monday 27 February 1956 - Format pour les cellules B5:B10
10/23/1999 Saturday 23 October 1999
12/4/1952 ### jjjj jj mmmm aaaa
8/26/1995 Saturday 26 August 1995
1/5/1900 Friday 05 January 1900
( Mettre un ESPACE après chaque données . )

Page 89
73

* Différentes extraction de caractères


concaténe
r
André Legrand André Legrand
Paul Richaud Paul Richaud
Chantal Olivier Chantal Olivier

extraire les 4 premiers caractères


à partir de la gauche
1265-AZMPL-1451 1265
1278-F-7812 1278
6514-XRK-1453 6514

extraire le nom de la rue


puis le n° de la maison
75, rue des Trois Frères 75 rue des Trois Frères
98, avenue Général De Gaulle 98 avenue Général De Gaulle
2, place des Tilleuls 2 place des Tilleuls

extraire les lettres entre les deux tirets


15-AZMPL-1451 AZMPL
127568-F-7812 F
6514-XRK-1453 XRK

remplacer Mr par Monsieur


M Lindts Monsieur Lindts
M Robinson Monsieur Robinson
M Paterson Monsieur Paterson

remplacer Mr par Monsieur, Mme par Madame


et Melle par Mademoiselle
M Lindts Monsieur Lindts
Mme Robinson Madame Robinson
Melle Paterson Mademoiselle Paterson

Page 90
73

André Legrand
Paul Richaud
Chantal Olivier

rue des Trois Frères


avenue Général De Gaulle
place des Tilleuls
La fonction STXT utilisée dans cette
formule extrait des caractères situés
n'importe où à l'intérieur de la cellule.
Elle demande trois arguments : la
cellule contenant la donnée, la
position du caractère à partir duquel
l'extraction sera effectuée, le nombre
de caractères à extraire.
=STXT(B23;4;5) extrait 5 caractères à
partir du quatrième.

lle Paterson

Page 91
* Le Format des Dates

j le jour du mois en 1 ou 2 chiffres 9/04/2000

jj le jour du mois en 2 chiffres 09/04/2000

jjj le jour de la semaine en 3 lettres dim 9/4/2000

jjjj le jour de la semaine en toutes lettres dimanche 9/4/2000

M le numéro du mois en 1 ou 2 chiffres 9/4/2000

MM le numéro du mois en 2 chiffres 9/04/2000

MMM le nom du mois en trois lettres 9 avr 2000

MMMM le nom du mois en toutes lettres 9 avril 2000

aa l'année en 2 chiffres 9/4/00

aaaa l'année en 4 chiffres 9/4/2000


19/12/2000 j/mm/aaaa

19/12/2000 jj/mm/aaaa

mar 19/12/2000 jjj j/M/aaaa

mardi 19/12/2000 jjjj j/M/aaaa

19/12/2000 j/M/aaaa

19/12/2000 j/MM/aaaa

19 déc 2000 j MMM aaaa

19 décembre 2000 j MMMM aaaa

19/12/00 j/M/aa

19/12/2000 j/M/aaaa
* Calcul sur douze mois glissants
Mois Valeur

Apr-98 6 Avec Formule pour Glissement


May-98 6
Jun-98 6 9.00 =MOYENNE(DECALER(B5;NB(B:B)-1;;-12))
Jul-98 5
Aug-98 6
Sep-98 6 -* La formule prend en compte uniquement les 12 dernières valeurs
Oct-98 8
Nov-98 8 -* Si on rajoute une valeur en "B27", la formule prend toujours en compte les
Dec-98 12
Jan-99 10
Feb-99 11
Mar-99 12 =NB(B:B)
Apr-99 13
May-99 10
Jun-99 11 22
Jul-99 11
Aug-99 12
Sep-99 12
Oct-99 12
Nov-99 11
Dec-99 10
Jan-00 9
Feb-00
Mar-00 Pour essais
Apr-00
May-00
;NB(B:B)-1;;-12))

ernières valeurs.

nd toujours en compte les 12 dernières valeurs.


* Moyenne ne tenant pas compte
des valeurs zéro

20
20 18.89 =SOMME(Plage)/NB.SI(Plage;">0")
12 Ignore les lignes avec la valeur " 0 ".
20
20
0 17.00 =MOYENNE(Plage)
20 Prend en compte les lignes avec " 0 "
18
20
20 Plage = B6:B15
* Calcul de l'ancienneté en mois et années

Résultat en Résultat en
ans mois
Date d'entrée 10/1/1993
Date du jour 6/8/2001 7 92

=DATEDIF($C$4;$C$5;"y")

=DATEDIF($C$4;$C$5;"m

=DATEDIF(Date_début;Date_fin;Type)

L'argument " TYPE " peut prendre les valeurs suivantes :

"y" = Différence Absolue en Années

"m" = Différence Absolue en Mois

"d" = Différence Absolue en Jours

"ym" = Différence en Mois, si les 2 dates sont dans la même Année


"yd" = Différence en Jours, si les 2 dates sont dans la même Année

"md" = Différence en Jours, si les 2 dates sont dans le même Mois


Résultat en
jours

2807

;$C$5;"y")

ATEDIF($C$4;$C$5;"m")

=DATEDIF($C$4;$C$5;"d")
* Calculer une somme entre 2 bornes

5
30 Fourchette de Calcul
31
2 Supérieur à Inférieur à
54 50 500
125
210
26
34
9

Résultats

389 =SOMME.SI($B:$B;">="&$E$8)-SOMME.SI($B:$B;">"&$F$8)

389 {=SOMME((B4:B13>=$E$8)*(B4:B13<=$F$8)*B4:B13)}

Plage = B4:B13

NB: Validation : CTRL+ MAJ+ ENTREE pour obtenir les accolades .


.SI($B:$B;">"&$F$8)

$8)*B4:B13)}
* Addionner une cellule sur deux

Valeurs Saisie
35.00
5.00
4.00
35.00
21.00
87.00
35.00
32.00
32.54
65.03
2.00 * - Somme des Cellules Impaires

224.03 {=SOMME(SI(MOD(LIGNE(B6:B16);2)=1;B6:B16))}

* - Somme des Cellules Paires

129.54 {=SOMME(SI(MOD(LIGNE(B6:B16);2)=0;B6:B16))}

NB: Validation : CTRL+ MAJ+ ENTREE pour obtenir les accolades .


Boutons

BOUTONS FEUILLES BOUTONS FEUILLES BOUTONS FEUILLES


DU MENU ASSOCIEES DU MENU ASSOCIEES DU MENU ASSOCIEES
1 20 33 40 65 71
2 24 34 56 66 4
3 25 35 68 67 5
4 34 36 38 68 46
5 29 37 39 69 32
6 42 38 59 70 49
7 53 39 6 71 62
8 30 40 26 72 69
9 31 41 54 73 73
10 37 42 55 74 47
11 48 43 57 75 50
12 45 44 7 76 51
13 76 45 60 77 52
14 78 46 72 78 66
15 79 47 8 79 67
16 21 48 9 80
17 1 49 11 81
18 2 50 70 82
19 3 51 12 83
20 41 52 36 84
21 22 53 18 85
22 23 54 35 86
23 27 55 10 87
24 28 56 13 88
25 61 57 14 89
26 63 58 15 90
27 64 59 16 91
28 65 60 17 92
29 74 61 19 93
30 75 62 44 94
31 77 63 43 95
32 33 64 58 96

Page 103