Vous êtes sur la page 1sur 1

Accéder à Open-Campus

Contact @SUPINFO

ACCUEIL CURSUS COURS ADMISSIONS CAMPUS DOCUMENTATION ANCIENS ENTREPRISES LIBRAIRIES PUBLICATIONS Naviguer sur la page

ACCUEIL CURSUS COURS ADMISSIONS CAMPUS DOCUMENTATION ANCIENS ENTREPRISES LIBRAIRIES PUBLICATIONS

Cisco - Les commandes utilisable sur un switch


Par Pierre AMALOU • Publié le 30/10/2016 à 16:03:15 • Noter cet article: ★★★★★ (7 votes)
Avis favorable du comité de lecture

Pierre AMALOU

Administration d'un switch

Gestion de base des switch

Con guration de la sécurité

Con guration de VLAN

Bonus

Nous allons présenter les différentes commandes disponibles sur un switch et voir à quoi elles servent. Il s’agit là d’une liste non
exhaustive des commandes concernant les switch CISCO.

Administration d'un switch

Commandes basiques

nom_du_switch>enable : Changer de mode, de celui d’exécution utilisateur à celui d’exécution privilégié.


Password:password : Si un mot de passe a été défini en mode d’exécution privilégié, alors il faudra le saisir.
nom_du_switch#disable : Passer du mode d’exécution privilégié à celui d’exécution utilisateur.
nom_du_switch#configure terminal : Passer du mode d’exécution privilégié à celui de configuration globale.
nom_du_switch(config)#interface fastethernet 0/1 : Passer du mode de configuration globale au mode de configuration d’interface pour
l’interface citée.
nom_du_switch(config-if)#exit : Passer du mode de configuration d’interface en mode de configuration globale.

Con guration de la connectivité IP

Nom_du_switch1#configure terminal : Passer du mode d’exécution privilégié au mode de configuration globale.


Nom_du_switch1(config)#interface vlan 20 : Passer en mode de configuration d’interface pour l’interface du VLAN 20.
Nom_du_switch1(config-if)#ip address 172.1.1.10 255.255.255.0 : Configurer l’adresse IP de l’interface.
Nom_du_switch1(config-if)#no shutdown : Activer l’interface.
Nom_du_switch1(config-if)#end : Repasser en mode d’exécution privilégié.
Nom_du_switch1#configure terminal : Passer en mode de configuration globale.
Nom_du_switch1(config)#interface fastethernet 0/18 : Entrer dans l’interface pour affecter le réseau local virtuel.
Nom_du_switch1(config-if)#nom_du_switchport mode access : Définir le mode d’appartenance du port à un réseau local virtuel.
Nom_du_switch1 (config-if)#switchport access vlan 20 : Affecter le port à un réseau local virtuel.
Nom_du_switch1 (config-if)#end : Repasser en mode d’exécution privilégié.
Nom_du_switch1#copy running-config startup-config : Enregistrer la configuration en cours dans la configuration de démarrage du
switch.
Nom_du_switch1 (config)#ip default-gateway 172.1.1.1 : Configurer la passerelle par défaut sur le switch.
Nom_du_switch1 (config)#end : Repasser en mode d’exécution privilégié.
Nom_du_switch1#copy running-config startup-config : Enregistrer la configuration en cours dans la configuration de démarrage du
switch.
Nom_du_switch1# mdix auto : détecte le câblage ( croisé ou direct ) pour pas avoir à s'en occuper.

Con guration du mode bidirectionnel

Nom_du_switch1#configure terminal : Passer du mode d’exécution privilégié au mode de configuration globale.


Nom_du_switch1(config)#Interface fastethernet 0/1 : Passer en mode de configuration d’interface.
Nom_du_switch1(config-if)#duplex auto : Configurer le mode bidirectionnel d’interface pour activer la configuration bidirectionnelle
automatique.
Nom_du_switch1(config-if)#speed auto : Configurer la vitesse bidirectionnelle d’interface et activer la configuration de vitesse
automatique.
Nom_du_switch1(config-if)#end : Revenir au mode d’exécution privilégié.
Nom_du_switch1#copy running-config startup-config : Enregistrer la configuration en cours dans la configuration de démarrage du
switch.

Con guration d’une interface web

Nom_du_switch1#configure terminal : Passer du mode d’exécution privilégié au mode de configuration globale.


Nom_du_switch1(config)#ip http authentification enable : Configurer l’interface du serveur HTTP pour le type d’authentification enable.
Les autres options disponibles sont les suivantes : enable : utilisation du mot de passe actif, soit la méthode par défaut pour
l’authentification utilisateur du serveur HTTP local : utilisation de la base de données utilisateur telle que définie sur le routeur Cisco ou
le serveur d’accès. tacacs : utilisation du serveur TACACS.
Nom_du_switch1(config)#ip http server : Activer le serveur HTTP.
Nom_du_switch1(config)#end : Revenir au mode d’exécution privilégié.
Nom_du_switch1#copy running-config startup-config : Enregistrer la configuration en cours dans la configuration de démarrage du
switch.

Gestion de la table d’adresses mac

Nom_du_swicth# show mac-address-table : montre la table d’adresses mac.


Nom_du_swicth #mac-address-table static vlan {1-4096, ALL} interface id_interface. : créer un mappage statique donc permet de dire
quelle adresse mac pour quel port.
Nom_du_swicth #no mac-address-table static vlan {1-4096, ALL} interface id_interface. : annule le mappage statique.

Véri cation des con gurations

nom_du_switch# show interfaces [interface-id] : Affiche l’état et la configuration d’une ou de l’ensemble des interfaces disponibles sur le
switch.
nom_du_switch# show startup-config : Affiche le contenu de la configuration de démarrage.
nom_du_switch# show running-config : Affiche la configuration actuelle.
nom_du_switch# show flash : Affiche des informations sur le système de fichiers flash.
nom_du_switch# show version : Affiche l’état du logiciel et du matériel système.
nom_du_switch# show ip {interface | http | arp} : Affiche des informations IP. L’option d’interface dévoile l’état et la configuration de
l’interface IP. L’option http affiche les données HTTP relatives au gestionnaire de périphériques exécuté sur le switch. L’option arp affiche
la table ARP IP.nom_du_switch# show version : Affiche l’état du logiciel et du matériel système.
nom_du_switch# show mac-address-table : Affiche la table de transmission MAC.

Historique des commandes

nom_du_switch#show history : pour afficher les commandes d’exécution qui ont été récemment entrées.
nom_du_switch#terminal history : Configure la taille de l’historique du terminal. L’historique du terminal peut conserver entre 0 et 256
lignes de commande.
nom_du_switch#terminal history size 50 : Configure la taille de l’historique du terminal. L’historique du terminal peut conserver entre 0
et 256 lignes de commande.
nom_du_switch#terminal no history size : Rétablit la taille de l’historique du terminal d’après sa valeur par défaut, soit 10 lignes de
commande
nom_du_switch#terminal no history : Désactive l’historique du terminal.

Gestion de base des switch

Sauvegarde des con gurations

Nom_du_switch1#copy system:running-config flash:startup-config : Nom du fichier de destination [startup-config] ? : Version officielle de


la commande de copie de Cisco IOS. Confirmer le nom du fichier de destination. Appuyer sur la touche Entrée pour valider ou sur les
touches Crtl+C pour annuler.
Nom_du_switch1#copy running-config startup-config Nom du fichier de destination [startup-config] ? : Version non officielle de la
commande de copie. Il est supposé alors que la configuration en cours est exécutée sur le système et que le fichier de configuration de
démarrage sera stocké dans la mémoire vive non volatile flash. Appuyer sur la touche Entrée pour valider ou sur les touches Crtl+C pour
annuler.
Nom_du_switch1#copy startup-config flash:config.bak1 Nom du fichier de destination [config.bak1] ? : Sauvegarder la configuration de
démarrage dans un fichier stocké dans la mémoire vive non volatile flash. Confirmer le nom du fichier de destination. Appuyer sur la
touche Entrée pour valider ou sur les touches Crtl+C pour annuler.

Restaurer des con gurations

Nom_du_switch1#copy flash:config.bak1 startup-config : Nom du fichier de destination [startup-config] ? : Copier le fichier config.bak1
stocké dans la mémoire flash dans la configuration de démarrage qui doit être stockée dans la mémoire flash. Appuyer sur la touche
Entrée pour valider et sur les touches Crtl+C pour annuler.
Nom_du_switch1#reload System configuration has been modified. Save? [yes/no]: n Proceed with reload? [confirm]? : Demander à Cisco
IOS de redémarrer le switch. Si le fichier de configuration en cours a été modifié, le système demande de l’enregistrer. Confirmer par un
‘y’ (oui) ou un ‘n’ (non). Pour confirmer le rechargement, appuyer sur la touche Entrée pour valider ou sur les touches Crtl+C pour
annuler.

Supprimer une con guration

nom_du_switch#erase nvram: ou erase startup-config : supprimer la configuration

Con guration de la sécurité

Mot de passe console

Nom_du_switch1#configure terminal : Passer du mode d’exécution privilégié au mode de configuration globale.


Nom_du_switch1(config)#line con 0 : Passer du mode de configuration globale au mode de configuration de ligne pour la console 0.
Nom_du_switch1(config-line)#password cisco : Définir cisco en tant que mot de passe pour la ligne de console 0 sur le switch.
Nom_du_switch1(config-line)#login : Définir la ligne de console pour exiger la saisie du mot de passe avant l’octroi de l’accès.
Nom_du_switch1(config-line)#end : Quitter le mode de configuration de ligne et revenir en mode d’exécution privilégié.
Pour le mot de passe terminal il suffit de mettre à la place de Nom_du_switch1(config)#line con 0 mettre Nom_du_switch1(config)#line
vty 0 4

Mot de passe du mode d’exécution privilégié

Nom_du_switch1#configure terminal : Passer du mode d’exécution privilégié au mode de configuration globale.


Nom_du_switch1(config)#enable secret mot_de_passe : Configurer le mot de passe enable secret pour le passage en mode d’exécution
privilégié.
Nom_du_switch1(config)#end : Quitter le mode de configuration de ligne et revenir en mode d’exécution privilégié.

Chi rer tous les mots de passe d’un coup

nom_du_switch#conf t
nom_du_switch(config)#service password-encryption

Créer une bannière de connexion

Nom_du_switch1#configure terminal
Nom_du_switch1(config)#banner login « Personnel autorisé uniquement » : Configurer une bannière de connexion. Ou alors :
Nom_du_switch1(config)#banner login & ou « & » definit fin du texte

Con guration du motd

Nom_du_switch1#configure terminal
Nom_du_switch1(config)#banner motd « Personnel autorisé uniquement » : Configurer une bannière de connexion. Ou alors :
Nom_du_switch1(config)#banner motd & ou « & » definit fin du texte : La bannière MOTD affiche tous les terminaux connectés à la
connexion et permet de transmettre des messages destinés à tous les utilisateurs du réseau (pour les avertir, par exemple, d’un arrêt
imminent du système). La bannière MOTD apparaît avant la configuration de la bannière de connexion.

Con guration de la sécurité des ports

Nom_du_switch1#configure terminal
Nom_du_switch1(config)#interface fastEthernet 0/18 : Préciser le type et le numéro de l’interface physique à configurer (par exemple,
fastEthernet F0/18) et passer en mode de configuration d’interface. Utiliser la commande Cisco IOS
Nom_du_switch1(config-if)#switchport mode access : Définir le mode d’interface en accès. Il n’est pas possible de configurer une
interface en tant que port sécurisé selon le mode dynamique par défaut approprié. Utiliser la commande Cisco IOS
Nom_du_switch1(config-if)#switchport port-security : Activer la sécurité des ports sur l’interface. Utiliser la commande Cisco IOS.

Con guration avancée de la sécurité des ports

Nom_du_switch1#configure terminal
Nom_du_switch1(config)#interface fastEthernet 0/18 : Préciser le type et le numéro de l’interface physique à configurer (par exemple,
fastEthernet F0/18) et passer en mode de configuration d’interface. Utiliser la commande Cisco IOS
Nom_du_switch1(config-if)#switchport mode access : Définir le mode d’interface en accès. Il est impossible de configurer une interface
en tant que port sécurisé selon le mode dynamique par défaut approprié. Utiliser la commande Cisco IOS
Nom_du_switch1(config-if)#switchport port-security : Activer la sécurité des ports sur l’interface. Utiliser la commande Cisco IOS :
Nom_du_switch1(config-if)#switchport port-security maximum 50 : Définir le nombre maximal d’adresses sécurisées à 50. Utiliser la
commande Cisco IOS :
Nom_du_switch1(config-if)#switchport port-security mac-address sticky : Activer l’apprentissage rémanent. Utiliser la commande Cisco
IOS.

Véri cation de la sécurité des ports

nom_du_switch#show port-security [interface id_interface] : Pour afficher les paramètres de sécurité des ports du switch ou de l’interface
spécifiée
nom_du_switch#show port-security [interface id_interface] : Pour afficher toutes les adresses MAC sécurisées configurées dans toutes les
interfaces de commutation ou sur une interface définie avec informations d’obsolescence pour chacune

Désactiver des ports

Utiliser shutdown et interface range

Con guration de VLAN

Activation vlan voix

nom_du_switch3(config)#interface fa0/18
nom_du_switch3(config-if)#mls qos trust cos : garantit que le trafic vocal est identifié en tant que trafic prioritaire. N’oublier pas que le
réseau tout entier doit être configuré de manière à donner la priorité au trafic vocal. On ne peut pas simplement configurer le port avec
cette commande.
nom_du_switch3(config-if)#switchport voice vlan 150 : identifie le VLAN 150 en tant que VLAN voix. Il est possible de vérifier que c’est
bien le cas dans la capture d’écran du bas : Voice VLAN: 150 (VLAN0150).
nom_du_switch3(config-if)#switchport mode access
nom_du_switch3(config-if)#switchport access vlan 20 : configure le VLAN 20 en tant que VLAN (de données) en mode accès. Il est possible
de vérifier que c’est bien le cas dans la capture d’écran du bas : Access Mode VLAN: 20 (VLAN0020).
nom_du_switch3(config-if)#end
nom_du_switch3#show interface fa0/18 switchport

Ajout d’un réseau local virtuel

Nom_du_switch1#configure terminal : Passer en mode de configuration globale sur le switch Nom_du_switch1.


Nom_du_switch1(config)#vlan id_vlan : Créer un VLAN. « id_vlan » est le numéro de VLAN à créer. Passe en mode de configuration de
VLAN pour l’ID de VLAN du VLAN.
Nom_du_switch1(config-vlan)#name nom_vlan : (Facultatif) Spécifier un nom de VLAN unique pour identifier le VLAN. Si aucun nom n’est
entré, le numéro de VLAN, complété par des zéros, est ajouté au mot « VLAN », comme par exemple VLAN0020.
Nom_du_switch1(config-if)#end

A ectation d’un port de switch

Nom_du_switch1#configure terminal : Passer en mode de configuration globale sur le switch Nom_du_switch1.


Nom_du_switch1(config)#interface F0/1 : Passer en mode de configuration d’interface.
Nom_du_switch1(config-if)#switchport mode trunk : Définir l’interface F0/1 comme agrégation IEEE 802.1Q
Nom_du_switch1(config-if)#switchport trunk native vlan 99 : Configurer le VLAN 99 en tant que VLAN natif.
Nom_du_switch1(config-if)#end

Véri cation des réseaux locaux virtuels et des appartenances des ports

Nom_du_switch1(config)#show vlan [brief | id id_vlan | name nom_vlan | summary].


brief : Afficher une ligne pour chaque VLAN comportant le nom du VLAN, son état et ses ports.
id id_vlan : Afficher des informations sur un VLAN unique identifié par un numéro d’ID de VLAN. La valeur id_vlan peut être comprise
entre 1 et 4094.
name nom_vlan : Afficher des informations sur un VLAN unique identifié par un nom de VLAN. Le nom de VLAN est une chaîne ASCII de 1
à 32 caractères de long.
summary : Afficher un résumé sur les VLAN. La commande show interfaces
Nom_du_switch1(config)#show interfaces [id_interface | vlan id_vlan] | switchport
id_interface : Les interfaces autorisées comprennent les ports physiques (y compris le type, le module et le numéro de port) et les canaux
de port. La plage des canaux de port est comprise entre 1 et 6.
vlan id_vlan : Identification du VLAN. La plage est comprise entre 1 et 4094. >
switchport : Afficher l’état administratif et opérationnel d’un port de commutation, y compris les paramètres de blocage et de protection
du port.

Gérer les appartenances des ports

Nom_du_switch1#configure terminal : Passer en mode de configuration globale.


Nom_du_switch1(config)#interface id_interface : Passer en mode de configuration d’interface pour configurer l’interface.
Nom_du_switch1(config-if)#no switchport access vlan : Supprimer l’affectation de VLAN sur cette interface de port de switch et revenir à
l’appartenance par défaut au VLAN 1.
Nom_du_switch1(config-if)#end : Repasser en mode d’exécution privilégié.

Con guration d’une agrégation 802.1Q

Nom_du_switch1#configure terminal : Passer en mode de configuration globale.


Nom_du_switch1(config)#interface id_interface : Passer en mode de configuration d’interface pour configurer l’interface.
Nom_du_switch1(config-if)#switchport mode trunk : Forcer la liaison reliant les switchs à devenir une liaison agrégée.
Nom_du_switch1(config-if)#switchport trunk native vlan id_vlan : Spécifier un autre VLAN en tant que VLAN natif pour le trafic non
étiqueté pour les agrégations IEEE 802.1Q.
Nom_du_switch1(config-if)#end : Repasser en mode d’exécution privilégié. Pour vérifier la configuration d’une agrégation : show
interfaces id_interface switchport.

Gestion de la con guration d’une agrégation

Nom_du_switch1#configure terminal : Passer en mode de configuration globale.


Nom_du_switch1(config-if)#no switchport trunk allowed vlan : Utiliser cette commande en mode de configuration d’interface pour
réinitialiser tous les VLAN configurés sur l’interface d’agrégation.
Nom_du_switch1(config-if)#no switchport trunk native vlan : Utiliser cette commande en mode de configuration d’interface pour
réinitialiser le VLAN natif et le réaffecter au VLAN 1.
Nom_du_switch1(config-if)#switchport mode access : Utiliser cette commande en mode de configuration d’interface pour réinitialiser
l’interface du port d’agrégation en port de mode d’accès statique.

Con guration du routage entre VLAN

Sur le switch :

Nom_du_switch1#configure terminal
Nom_du_switch1(config)#vlan50
Nom_du_switch1(config-vlan)#vlan100
Nom_du_switch1(config-vlan)#exit
Nom_du_switch1(config)#interface f0/10
Nom_du_switch1(config-if)#switchport access vlan 50
Nom_du_switch1(config-if)#interface f0/1
Nom_du_switch1(config-if)#switchport access vlan 100
Nom_du_switch1(config-if)#end

Sur le routeur :

Nom_du_router1#configure terminal
Nom_du_router1 (config)#interface f0/0
Nom_du_router1 (config-if)#ip address 192.168.1.2 255.255.255.0
Nom_du_router1 (config-if)#no shutdown
Nom_du_router1 (config-if)#interface f0/1
Nom_du_router1 (config-if)#ip address 192.168.3.2 255.255.255.0
Nom_du_router1 (config-if)#no shutdown

Con guration du routage entre VLAN « Router-on-a-Stick »

Sur le switch :

Nom_du_switch1#configure terminal
Nom_du_switch1(config)#vlan50
Nom_du_switch1(config-vlan)#vlan100
Nom_du_switch1(config-vlan)#exit
Nom_du_switch1(config)#interface f0/10
Nom_du_switch1(config-if)#switchport mode trunk
Nom_du_switch1 (config-if)#end

Sur le routeur :

Nom_du_router1#configure terminal
Nom_du_router1 (config)#interface f0/0.50
Nom_du_router1 (config-if)#encapsulation dot1q 50
Nom_du_router1(config-if)#ip address 192.168.1.2 255.255.255.0
Nom_du_router1 (config)#interface f0/0.100
Nom_du_router1 (config-if)#encapsulation dot1q 100
Nom_du_router1(config-if)#interface f0/1
Nom_du_router1 (config-if)#ip address 192.168.3.2 255.255.255.0
Nom_du_router1 (config-if)#no shutdown

Bonus
Pour récupérer le mot de passe sur un switch Cisco 2960, procéder comme suit :
Étape 1. Au moyen d’un logiciel d’émulation de terminal, connecter un terminal ou un PC au port de la console du switch.
Étape 2. Définir le débit de la ligne dans le logiciel d’émulation à 9 600 bauds.
Étape 3. Mettre le switch hors tension. Reconnecter le cordon d’alimentation au switch, puis appuyer sur le bouton Mode pendant les 15
secondes qui suivent tandis que le LED système continue de clignoter en vert. Maintenir le bouton Mode enfoncé jusqu’à ce que le LED
système devienne brièvement orange, puis prenne une couleur verte définitive. Relâcher ensuite le bouton Mode.
Étape 4. Initialiser le système de fichiers flash à l’aide de la commande flash_init.
Étape 5. Charger tous les fichiers d’aide au moyen de la commande load_helper.
Étape 6. Afficher le contenu de la mémoire flash à l’aide de la commande dir flash : Le système de fichiers du switch apparaît alors.
Étape 7. À l’aide de la commande rename flash:config.text flash:config.text.old, modifier le fichier de configuration en le renommant «
config.text.old », soit le fichier contenant la définition du mot de passe.
Étape 8. Démarrer le système avec la commande boot.
Étape 9. Le système demande de démarrer le programme de configuration. À l’invite, entrer N et lorsque le système demande si l’on
souhaite poursuivre dans la boîte de dialogue de configuration, entrer N.
Étape 10. À l’invite du switch, entrer le mode d’exécution privilégié en se servant de la commande enable.
Étape 11. Utiliser la commande rename flash:config.text.old flash:config.text pour renommer le fichier de configuration d’après son nom
d’origine.
Étape 12. Copier le fichier de configuration dans la mémoire à l’aide de la commande copy flash:config.text system:running-config. Une
fois cette commande entrée, le texte suivant s’affiche dans la console : Source filename [config.text]? Destination filename [running-
config]? Appuyer sur la touche Entrée en réponse à l’invite de confirmation. Le fichier de configuration est désormais rechargé et il est
possible de modifier le mot de passe.
Étape 13. Passer en mode de configuration globale au moyen de la commande configure terminal.
Étape 14. Modifier le mot de passe en utilisant la commande enable secret mot de passe.
Étape 15. Repasser en mode d’exécution privilégié avec la commande exit.
Étape 16. Inscrire la configuration en cours dans le fichier de configuration de démarrage au moyen de la commande copy running-config
startup-config.
Étape 17. Recharger le switch à l’aide de la commande reload.
Remarque : la procédure de récupération de mots de passe peut varier selon la gamme de switch Cisco. Il faut donc se reporter à la
documentation du produit avant toute tentative de récupération.

A propos de SUPINFO | Contacts & adresses | Enseigner à SUPINFO | Presse | Conditions d'utilisation & Copyright | Respect de la vie privée | Investir

SUPINFO International University


Ecole d'Informatique - IT School
École Supérieure d'Informatique de Paris, leader en France
La Grande Ecole de l'informatique, du numérique et du management
Fondée en 1965, reconnue par l'État. Titre Bac+5 certifié au niveau I.
SUPINFO International University is globally operated by EDUCINVEST Belgium - Avenue Louise, 534 - 1050 Brussels