Vous êtes sur la page 1sur 27

Les VLANs

Virtual Local Area Network

Guillaume Le Grand IR3 Ingnieurs 2000


Sommaire
Intrt
Historique
Principe
La norme 802.1Q
Interconnexion inter-VLAN
GVRP
VTP
VLAN et STP
Exemple dapplication
Conclusion
Intrt
Historique

Originellement ISL (Cisco):


Introduit les notions de Base des VLAN
tiquettage
Routage inter-VLAN
etc
Par la suite IEEE 802.1Q (1998)
Reprend principalement les notions de lISL
IEEE 802.1Q (2003)
Possibilit denregistrement dynamique des
VLANs (GVRP)
Support la transmission de trames sur plusieurs
instances de spanning-tree
Principe
Niveau 2 du modle OSI.
Segmentation dun support physique en
segments logiques.
Avantages:
Limite la diffusion des broadcasts.
Plus grande flexibilit de la segmentation du
rseau. (indpendance gographique)
Amlioration de la scurit.
Priorisation des flux.
Trame ethernet 802.1Q

TPID: type du tag, 0x8100 pour 802.1Q


Priorit: niveaux de priorit dfinis par lIEEE
802.1P
CFI: Ethernet ou token-ring
VID: VLAN identifier, jusqu 4096 vlans
Types de VLAN

Par port
Par adresse MAC
Par adresse IP
Par Protocole de niveau 3
Terminologie
VID : Vlan ID
PVID : Port Vlan ID
Mode daccs
Port Access ou untagged(non tiquet)
Port trunk ou tagged(tiquett)
Matriel Aware (Vlan-inform)
VLANs de base
VLAN par dfaut gnralement VLAN 1
VLAN utilisateur
VLAN de management
VLAN natif
Exemple
Trame Ethernet

PVID=20

Commutateur

PVID = 20 VLAN 20 autoris, Port trunk


Port access

Trame Ethernet VID =20 Trame Ethernet

Tag: champs 802.1q


Tag: champs 802.1q

VID =20 Trame Ethernet


VLAN 20 autoris, port trunk

Commutateur

PVID= 20 Port untagged VLAN 20 autoris, Port trunk

Trame Ethernet VID =20 Trame Ethernet

Tag: champs 802.1q


Interconnexion inter-VLAN
Se fait au niveau 3 du modle OSI,
Donc routage, entre interfaces virtuelles
Seul un routeur peut raliser linterconnexion
entre deux VLANs et modifier ainsi le VID
associ une trame.
Switch#vlan database
Switch(vlan)# vlan 2 name VLAN2
Switch(vlan)# vlan 3 name VLAN3
Switch(vlan)# exit
Switch#conf t

Switch(config)# interface FastEthernet2/1


Switch(config-if)# description vers PC
Switch(config-if)# no ip address
Switch(config-if)# duplex auto
Switch(config-if)# speed auto
Switch(config-if)# switchport access vlan 2
Switch(config-if)# interface FastEthernet2/1
Switch(config-if)# description vers switch
Switch(config-if)# no ip address
Switch(config-if)# duplex auto
Switch(config-if)# speed auto
Switch(config-if)# switchport trunk allowed vlan 2,3
Switch(config-if)# encapsulation dot1q
Routeur(config)# interface Vlan 2
Routeur(config-if)# description vers secrtariat
Routeur(config-if)# ip address 192.168.0.1
255.255.254.0
Routeur(config-if)# ip mroute-cache
Routeur(config-if)#interface Vlan 3
Routeur(config-if)# description vers Direction
Routeur(config-if)# ip address 192.168.100.1
255.255.255.0
Routeur(config-if)# ip mroute-cache
GVRP ou GARP VLAN
Diffusion dynamique des VLAN dfinis
statiquement
Dfinit dans le 802.1P
BPDU GVRP envoyes de proche en proche
(GID) GARP Information Declaration
(GIP) GARP Information Propagation

GVRP pruning
VTP (VLAN Trunking Protocol)
Propritaire Cisco
Permet dadministrer les VLANs
Plusieurs mode:
Server
Client
Transparent
Paramtres:
VTP domain
VTP password
VTP pruning
Routeur1# vlan database
Routeur1(vlan)# vtp domain monDomain
Routeur1(vlan)# vtp passwd monMotDePasse
Routeur1(vlan)# vtp server
Routeur1(vlan)#vtp prunning
Routeur1(vlan)# exit

Routeur2# vlan database


Routeur2(vlan)# vtp domain monDomain
Routeur2(vlan)# vtp passwd monMotDePasse
Routeur2(vlan)# vtp client
Routeur2(vlan)# vtp prunning
Routeur2(vlan)# exit
Vlan et Spanning-tree (STP)

IEEE 802.1D
STP classique
Trame STP sur le Vlan de management.
Ncessairement un seul arbre recouvrant.
En bref, non adapt, pas prvu pour.
Multiple STP et Rapid STP

MSTP: IEEE 802.1s


Un arbre de recouvrement par VLAN.
Un port peut tre forwarding pour un VLAN et
disabled pour un autre.
RSTP: IEEE 802.1w
Possibilit davoir un arbre de recouvrement par
VLAN (mode PVST)
Ou pour rduire le nombre dinstances reduire
deux arbres de recouvrement.
RSPAN
Permet de monitorer un port distance

Routeur(Config)#set vlan 200 rspan

Sur le switch distant

Routeur(Config)# set rspan source 3/1 both


OU
Routeur(Config)# set rspan source 100 both
Routeur(Config)#set rspan destination 4/5
Exemple dapplication ToIP
Conclusion
Flexibilit
Scurit
Facilit dadministration (selon larchitecture)
Dynamique (ou pas)
Bibliographie
IEEE: La source, en anglais.
http://standards.ieee.org/getieee802/download/802.1Q-199 8.pdf

http://standards.ieee.org/getieee802/download/802.1Q-2003.pdf

http://standards.ieee.org/getieee802/download/802.1X-2004.pdf

CISCO: Matriels, exemples, VTP, ISL.


http://www.cisco.com/univercd

http://www.cisco.com/warp/public/473/21.html

CERTA: assez complet, GVRP


http://www.reseaucerta.org/docs/didactique/VLAN.pdf
Question ?