Vous êtes sur la page 1sur 8

Exemple de configuration d'ingnierie du trafic

MPLS de base l'aide de la configuration OSPF

Contenu
Introduction
Conditions pralables
Conditions requises
Composants utiliss
Conventions
Composants fonctionnels
Configurez
Diagramme du rseau
Guide de configuration rapide
Fichiers de configuration
Vrifiez
Exemple de sortie de la commande show
Dpannez
Informations connexes

Introduction
Ce document fournit un exemple de configuration pour mettre en oeuvre l'ingnierie de trafic (TE)
sur un rseau existant de commutation multiprotocole par tiquette (MPLS) utilisant le Frame
Relay et l'Open Shortest Path First (OSPF). Notre exemple met en oeuvre deux tunnels
dynamiques (configurs automatiquement par des commutateurs-routeurs d'tiquettes d'afflux
[LSR]) et deux tunnels utilisant des trajectoires explicites.

TE est un nom gnrique correspondant l'utilisation de diffrentes Technologies d'optimiser


l'utilisation d'une capacit et d'une topologie donnes de circuit principal.

MPLS TE fournit une manire d'intgrer des capacits TE (comme ceux utiliss sur des protocoles
de couche 2 comme l'atmosphre) dans les protocoles de la couche 3 (IP). MPLS TE emploie une
extension aux protocoles existants (Protocole IS-IS (Intermediate System-to-Intermediate
System), Protocole RSVP (Resource Reservation Protocol), OSPF) pour calculer et tablir les
tunnels unidirectionnels qui sont placs selon la contrainte de rseau. La circulation est trace sur
les diffrents tunnels selon leur destination.

Conditions pralables
Conditions requises
Aucune spcification dtermine n'est requise pour ce document.

Composants utiliss

Les informations de ce document sont bases sur les versions de logiciel et matriel suivantes:

Versions de logiciel 12.0(11)S et 12.1(3a)T de Cisco IOS


Routeurs de Cisco 3600
Les informations contenues dans ce document ont t cres partir des priphriques d'un
environnement de laboratoire spcifique. Tous les priphriques utiliss dans ce document ont
dmarr avec une configuration efface (par dfaut). Si votre rseau est oprationnel, assurez-
vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilises dans ce document, reportez-vous
Conventions relatives aux conseils techniques Cisco.

Composants fonctionnels
Le tableau suivant dcrit les composants fonctionnels de cet exemple de configuration :

Composant Description
Couche 2 : une interface de tunnel MPLS
est la tte d'un chemin commut par
tiquette (LSP). Il est configur avec un
Interfaces
ensemble des besoins en matire de
de tunnel
ressources, tels que la bande passante et la
IP
priorit. Couche 3 : l'interface de tunnel LSP
est la tte de rseau d'une liaison virtuelle
unidirectionnelle la destination de tunnel.
Le RSVP est utilis pour tablir et mettre
jour des tunnels LSP bass sur le chemin
calcul des messages utilisant de CHEMIN
RSVP avec
et de RSVP rservation (RESV). La
l'extension
spcification de protocole de RSVP a t
TE
tendue de sorte que les messages RESV
distribuent galement les informations
d'tiquette.
Protocole
IGP
(Interior
Utilis pour inonder la topologie et les
Gateway
informations de ressource du module de
Protocol)
gestion de lien. L'IS-IS utilise de nouvelles
d'tat de
Type-Longueur-valeurs (TLVs) ; L'OSPF
lien [IS-IS
utilise des annonces d'tat de lien du type
ou OSPF
10 (galement appeles Opaque LSAs).
avec
l'extension
TE]
Module de Fonctionne la tte LSP seulement et
calcul de dtermine un chemin utilisant les
chemin informations de la base de donnes d'tat
MPLS TE de lien.
chaque saut LSP, ce module excute
Module de
l'admission d'appel de lien sur les messages
gestion de
de signalisation de RSVP, et la comptabilit
lien MPLS
de la topologie et des informations de
TE
ressource inonder par OSPF ou IS-IS.
Expdition
de
Mcanisme de transfert de base MPLS bas
commutatio
sur des tiquettes.
n par
tiquette

Configurez
Cette section vous fournit des informations pour configurer les fonctionnalits dcrites dans ce
document.

Remarque:Utilisez l'outil Command Lookup Tool (clients enregistrs seulement) pour trouver plus
d'informations sur les commandes utilises dans ce document.

Diagramme du rseau

Ce document utilise la configuration rseau suivante:

Guide de configuration rapide

Vous pouvez employer les tapes suivantes pour excuter une configuration rapide. Rfrez-vous
l'Ingnierie de trafic MPLS et aux amliorations pour plus d'informations dtailles.

1. Installez votre rseau avec la configuration habituelle. (Dans ce cas, nous avons utilis le
Relais de trames.)Remarque:Il est obligatoire d'installer une interface de bouclage avec un
masque IP de 32 bits. Cette adresse sera utilise pour l'installation du rseau MPLS et du
TE par le protocole de routage. Cette adresse de bouclage doit tre accessible par
l'intermdiaire de la table de routage globale.
2. Installez un protocole de routage pour le rseau MPLS. Ce doit tre un protocole de routage
tat de liens (IS-IS ou OSPF). Dans le mode de configuration de protocole de routage,
slectionnez les commandes suivantes :Pour l'IS-IS :
metric-style [wide | both] mpls traffic-eng router-id LoopbackN mpls traffic-eng [level-1 |
level-2 |] Pour l'OSPF :
mpls traffic-eng area X mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255
mask)
3. Enable MPLS TE. Entrez dans l'ip cef (ou l'ip cef distribu si disponible afin d'amliorer la
reprsentation) en mode de configuration gnrale. Activez MPLS (IP de balise-
commutation) sur chaque interface intresse. Entrez dans le tunnel d'Ingnierie de trafic
MPLS pour activer MPLS TE, aussi bien que le RSVP pour des tunnels de la zro-bande
passante TE.
4. Activez le RSVP en entrant dans l'ip rsvp bandwidth XXX sur chaque interface intresse
pour les tunnels diffrents de zro de bande passante.
5. Tunnels d'installation utiliser pour TE. Il y a beaucoup d'options qui peuvent tre
configures pour le tunnel MPLS TE, mais la commande de tunnel mode mpls traffic-eng est
obligatoire. La commande de tunnel mpls traffic-eng autoroute announce annonce la
prsence du tunnel par le protocole de routage.Remarque:N'oubliez pas d'utiliser le
loopbackN d'ip unnumbered pour l'adresse IP des interfaces de tunnel.Cette configuration
affiche deux tunnels dynamiques (Pescara_t1 et Pescara_t3) avec la bande passante
diffrente (et les priorits) allant du routeur de Pescara au routeur de Pesaro, et deux tunnels
(Pesaro_t158 et Pesaro_t159) utilisant un chemin explicite allant de Pesaro Pescara.

Fichiers de configuration

Ce document utilise les configurations prsentes ci-dessous. Seulement les lments pertinents
des fichiers de configuration sont inclus. Les commandes utilises pour activer le MPLS sont en
texte bleu ; les commandes spcifiques TE (RSVP y compris) sont en texte en gras.

Pesaro
Current configuration:

version 12.1

hostname Pesaro

ip cef ! mpls traffic-eng tunnels ! interface Loopback0


ip address 10.10.10.6 255.255.255.255 ! interface
Tunnel158 ip unnumbered Loopback0 tunnel destination
10.10.10.4 tunnel mode mpls traffic-eng tunnel mpls
traffic-eng autoroute announce tunnel mpls traffic-eng
priority 2 2 tunnel mpls traffic-eng bandwidth 158
tunnel mpls traffic-eng path-option 1 explicit name low
! interface Tunnel159 ip unnumbered Loopback0 tunnel
destination 10.10.10.4 tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce tunnel mpls
traffic-eng priority 4 4 tunnel mpls traffic-eng
bandwidth 159 tunnel mpls traffic-eng path-option 1
explicit name straight ! interface Serial0/0 no ip
address encapsulation frame-relay ! interface
Serial0/0.1 point-to-point bandwidth 512 ip address
10.1.1.22 255.255.255.252 tag-switching ip mpls traffic-
eng tunnels frame-relay interface-dlci 603 ip rsvp
bandwidth 512 512 ! router ospf 9 network 10.1.1.0
0.0.0.255 area 9 network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9 mpls traffic-eng router-id
Loopback0 ! ip classless ! ip explicit-path name low
enable next-address 10.1.1.21 next-address 10.1.1.10
next-address 10.1.1.1 next-address 10.1.1.14 ! ip
explicit-path name straight enable next-address
10.1.1.21 next-address 10.1.1.5 next-address 10.1.1.14 !
end

Pescara
Current configuration:

version 12.0

hostname Pescara

ip cef ! mpls traffic-eng tunnels ! interface Loopback0


ip address 10.10.10.4 255.255.255.255 ! interface
Tunnel1 ip unnumbered Loopback0 no ip directed-broadcast
tunnel destination 10.10.10.6 tunnel mode mpls traffic-
eng tunnel mpls traffic-eng autoroute announce tunnel
mpls traffic-eng priority 5 5 tunnel mpls traffic-eng
bandwidth 25 tunnel mpls traffic-eng path-option 2
dynamic ! interface Tunnel3 ip unnumbered Loopback0 no
ip directed-broadcast tunnel destination 10.10.10.6
tunnel mode mpls traffic-eng tunnel mpls traffic-eng
autoroute announce tunnel mpls traffic-eng priority 6 6
tunnel mpls traffic-eng bandwidth 69 tunnel mpls
traffic-eng path-option 1 dynamic ! interface Serial0/1
no ip address encapsulation frame-relay ! interface
Serial0/1.1 point-to-point bandwidth 512 ip address
10.1.1.14 255.255.255.252 mpls traffic-eng tunnels tag-
switching ip frame-relay interface-dlci 401 ip rsvp
bandwidth 512 512 ! router ospf 9 network 10.1.1.0
0.0.0.255 area 9 network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9 mpls traffic-eng router-id
Loopback0 ! end

Pomerol
Current configuration:

version 12.0

hostname Pomerol

ip cef ! mpls traffic-eng tunnels ! interface Loopback0


ip address 10.10.10.3 255.255.255.255 ! interface
Serial0/1 no ip address encapsulation frame-relay !
interface Serial0/1.1 point-to-point bandwidth 512 ip
address 10.1.1.6 255.255.255.252 mpls traffic-eng
tunnels tag-switching ip frame-relay interface-dlci 301
ip rsvp bandwidth 512 512 ! interface Serial0/1.2 point-
to-point bandwidth 512 ip address 10.1.1.9
255.255.255.252 mpls traffic-eng tunnels tag-switching
ip frame-relay interface-dlci 302 ip rsvp bandwidth 512
512 ! interface Serial0/1.3 point-to-point bandwidth 512
ip address 10.1.1.21 255.255.255.252 mpls traffic-eng
tunnels tag-switching ip frame-relay interface-dlci 306
ip rsvp bandwidth 512 512 ! router ospf 9 network
10.1.1.0 0.0.0.255 area 9 network 10.10.10.0 0.0.0.255
area 9 mpls traffic-eng area 9 mpls traffic-eng router-
id Loopback0 ! ip classless ! end
Pulligny
Current configuration:

version 12.1

hostname Pulligny

ip cef ! mpls traffic-eng tunnels ! interface Loopback0


ip address 10.10.10.2 255.255.255.255 ! interface
Serial0/1 no ip address encapsulation frame-relay !
interface Serial0/1.1 point-to-point bandwidth 512 ip
address 10.1.1.2 255.255.255.252 mpls traffic-eng
tunnels tag-switching ip frame-relay interface-dlci 201
ip rsvp bandwidth 512 512 ! interface Serial0/1.2 point-
to-point bandwidth 512 ip address 10.1.1.10
255.255.255.252 mpls traffic-eng tunnels tag-switching
ip frame-relay interface-dlci 203 ip rsvp bandwidth 512
512 ! router ospf 9 network 10.1.1.0 0.0.0.255 area 9
network 10.10.10.0 0.0.0.255 area 9 mpls traffic-eng
area 9 mpls traffic-eng router-id Loopback0 ! ip
classless ! end

Pauillac
!

version 12.1

hostname pauillac

ip cef ! mpls traffic-eng tunnels ! interface Loopback0


ip address 10.10.10.1 255.255.255.255 ! interface
Serial0/0 no ip address encapsulation frame-relay !
interface Serial0/0.1 point-to-point bandwidth 512 ip
address 10.1.1.1 255.255.255.252 mpls traffic-eng
tunnels tag-switching ip frame-relay interface-dlci 102
ip rsvp bandwidth 512 512 ! interface Serial0/0.2 point-
to-point bandwidth 512 ip address 10.1.1.5
255.255.255.252 mpls traffic-eng tunnels tag-switching
ip frame-relay interface-dlci 103 ip rsvp bandwidth 512
512 ! interface Serial0/0.3 point-to-point bandwidth 512
ip address 10.1.1.13 255.255.255.252 mpls traffic-eng
tunnels tag-switching ip frame-relay interface-dlci 104
ip rsvp bandwidth 512 512 ! router ospf 9 network
10.1.1.0 0.0.0.255 area 9 network 10.10.10.0 0.0.0.255
area 9 mpls traffic-eng area 9 mpls traffic-eng router-
id Loopback0 ! ip classless ! end

Vrifiez
Cette section prsente des informations que vous pouvez utiliser pour vous assurer que votre
configuration fonctionne correctement.
Des commandes show gnrales sont illustres en configurant l'ingnierie du trafic de base MPLS
utilisant l'IS-IS. Les commandes suivantes sont spcifiques MPLS TE avec l'OSPF et sont
illustres ci-dessous :

lien de show ip ospf mpls traffic-eng


show ip ospf database opaque-area
L'Outil Interprteur de sortie (clients enregistrs uniquement) (OIT) prend en charge certaines
commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Exemple de sortie de la commande show

Vous pouvez utiliser la commande de lien de show ip ospf mpls traffic-eng de voir ce qui sera
annonc par OSPF un routeur donn. Les caractristiques de RSVP sont affiches dans ci-
dessous gras, indiquant la bande passante qui peut tre rserve, qui est annonc et utilis. Vous
pouvez voir la bande passante utilise par Pescara_t1 ( priorit 5) et Pescara_t3 ( priorit 6).

Pesaro# show ip ospf mpls traffic-eng link OSPF Router with ID (10.10.10.61) (Process ID 9) Area
9 has 1 MPLS TE links. Area instance is 3. Links in hash bucket 48. Link is associated with
fragment 0. Link instance is 3 Link connected to Point-to-Point network Link ID : 10.10.10.3
Pomerol Interface Address : 10.1.1.22 Neighbor Address : 10.1.1.21 Admin Metric : 195 Maximum
bandwidth : 64000 Maximum reservable bandwidth : 64000 Number of Priority : 8 Priority 0 : 64000
Priority 1 : 64000 Priority 2 : 64000 Priority 3 : 64000 Priority 4 : 64000 Priority 5 : 32000
Priority 6 : 24000 Priority 7 : 24000 Affinity Bit : 0x0
La commande de show ip ospf database peut tre retenue au type 10 LSAs et affiche la base de
donnes qui est utilise par le processus MPLS TE pour calculer la meilleure route (pour TE) pour
les tunnels dynamiques (Pescara_t1 et Pescara_t3 dans cet exemple). Ceci peut tre vu dans la
sortie partielle suivante :

Pesaro# show ip ospf database opaque-area OSPF Router with ID (10.10.10.61) (Process ID 9) Type-
10 Opaque Link Area Link States (Area 9) LS age: 397 Options: (No TOS-capability, DC) LS Type:
Opaque Area Link Link State ID: 1.0.0.0 Opaque Type: 1 Opaque ID: 0 Advertising Router:
10.10.10.1 LS Seq Number: 80000003 Checksum: 0x12C9 Length: 132 Fragment number : 0 MPLS TE
router ID : 10.10.10.1 Pauillac Link connected to Point-to-Point network Link ID : 10.10.10.3
Interface Address : 10.1.1.5 Neighbor Address : 10.1.1.6 Admin Metric : 195 Maximum bandwidth :
64000 Maximum reservable bandwidth : 48125 Number of Priority : 8 Priority 0 : 48125 Priority 1
: 48125 Priority 2 : 48125 Priority 3 : 48125 Priority 4 : 48125 Priority 5 : 16125 Priority 6 :
8125 Priority 7 : 8125 Affinity Bit : 0x0 Number of Links : 1 LS age: 339 Options: (No TOS-
capability, DC) LS Type: Opaque Area Link Link State ID: 1.0.0.0 Opaque Type: 1 Opaque ID: 0
Advertising Router: 10.10.10.2 LS Seq Number: 80000001 Checksum: 0x80A7 Length: 132 Fragment
number : 0 MPLS TE router ID : 10.10.10.2 Pulligny Link connected to Point-to-Point network Link
ID : 10.10.10.1 Interface Address : 10.1.1.2 Neighbor Address : 10.1.1.1 Admin Metric : 195
Maximum bandwidth : 64000 Maximum reservable bandwidth : 64000 Number of Priority : 8 Priority 0
: 64000 Priority 1 : 64000 Priority 2 : 64000 Priority 3 : 64000 Priority 4 : 64000 Priority 5 :
64000 Priority 6 : 64000 Priority 7 : 64000 Affinity Bit : 0x0 Number of Links : 1 LS age: 249
Options: (No TOS-capability, DC) LS Type: Opaque Area Link Link State ID: 1.0.0.0 Opaque Type: 1
Opaque ID: 0 Advertising Router: 10.10.10.3 LS Seq Number: 80000004 Checksum: 0x3DDC Length: 132
Fragment number : 0

Dpannez
Il n'existe actuellement aucune information de dpannage spcifique pour cette configuration.

Informations connexes
Page d'assistance MPLS
Page de support pour le routage IP
Support et documentation techniques - Cisco Systems