Vous êtes sur la page 1sur 4

UNIVERSITE SAAD DAHLAB DE BLIDA 1

FACULTE DE TECHNOLOGIE
DEPARTEMENT DE MECANIQUE

Mini Projet
Module TP informatique
Licence 2ème année

TP Informatique

Nom: SAID ABD ESSAMEUD


Prenom : RIADH
Groupe :09

Année universitaire 2020/2021


Paramètres de position : Les paramètres de position sont la moyenne (moy), la médiane (med) et le mode (freq).

1\Algorithme_position ;
Var T : Tableau [100] de entiers ;
N, i, j, S, med, tmp, freq, compteur : entiers ;
moy : réel ;
Début
Si (N == 0) alors
Ecrire (" Le tableau est vide ") ;
Sinon
S=0;
Pour i <-- 1 à N faire
S <-- S + T [i] ;
finPour ;
moy <-- S/N ;
finSi ;
Pour i <-- 1 à N faire
Si (T [i] > T [i+1]) alors
tmp <-- T [i];
T [i] <-- T[i+1];
T [i+1] <-- tmp;
finSi ;
finPour ;
Si (n%2 == 0) alors
i = N/2 ;
med <-- (T [i] + T [i+1])/2 ;
Sinon
med <-- T [N/2] ;
finSi ;
freq = 0;
Pour i <-- 1 à N faire
compteur = 0 ;
Pour j <-- 1 à N faire
Si (T [i] == T [j]) alors
compteur <-- compteur + 1 ;
finSin ;
finPour ;
Si (compteur > freq) alors
freq = compteur ;
val = T [i] ;
finSi ;
finPour ;
// Affichage des résultats
Ecrire (" La somme des éléments du tableau est : ", S) ;
Ecrire (" La moyenne des éléments du tableau est : ", moy) ;
Ecrire (" La valeur de la médiane est : ", med) ;
Ecrire ("L’élément le plus fréquent est : " val " il apparait " freq " fois ") ;
Fin ;

Paramètres de dispersion : Les paramètres de dispersion sont l’étendue (E), la variance (var) et l’écart type (ecart).
Algorithme_dispersion ;
Var T : Tableau [100] de entiers ;
N, i, j, min, max, E : entiers ;
moy, var, ecart, S : réel ;
Début
min = T [1] ; max = T [1] ;
Pour i <-- 2 à N faire
Si (T [i] < min) alors
min <-- T [i] ;
finSi ;
S1eri T [i] > max) alor
max <-- T [i] ;
finSi ;
finPour ;
E <-- max – min ;
S=0;
Pour i <-- 1 à N faire
S <-- S + pow (T [i] - moy, 2) ;
finPour ;
var <-- S/N ;
ecart <-- sqrt (var) ;
//Affichage des résultats
Ecrire (" La valeur de l’étendue est : ", E) ;
Ecrire (" La valeur de la variance est : ", var) ;
Ecrire (" La valeur de l’écart type est : ", ecart) ;
Fin ;

2\Programme MATLAB
Paramètres de position : Les paramètres de position sont la moyenne (moy), la médiane (med) et le mode (freqFi

%%la partie des positions:

n=input('value of n?');

a=sym('a',[1 n])

%maintenant je vais saisir les valeurs de a1,a2,...,an

for i=1:n

a(i)=input('donner les valeurs');

end

%%maintenant la serie a

x=mean(a)%pour claculer la moyenne

c=median(a)%%pour calculer la médiane

v=mode(a)%%pour calculer le mode

Paramètres de dispersion : Les paramètres de dispersion sont l’étendue (E), la variance (var) et l’écart type (ecart).
%la partie de la dispersion

%l'etendue

etendue=max(a)-min(a)

%pour la variance

b=var(a)

%pour l'ecart type

ecart=std(a)