Vous êtes sur la page 1sur 12

17

Chapitre 16
Le tableur et ses fonctions avancées

Application 1 • Création d’une macro-commande


Dans le classeur « Analyse du CA N.xls », créer un bouton « Retour au
modèle » exécutant une macro-commande automatisant l’ouverture du
modèle ainsi créé.
Pour le corrigé de cette application, reportez-vous au fichier intitulé
« Chap_16_ex_1_base_clients_corr.xls » disponible sur le site
www.nathan.fr/expertise-comptable/

Application 2 • Création d’une macro-commande


1. Dans le classeur nommé « Suivi des ventes », créer les feuilles de calcul
« Saisie ventes mensuelles » et « Cumul annuel » avec implantation des
formules de calcul. (Ne pas saisir le montant des ventes.)
2. Créer une macro-commande nommée « Cumul_ventes » correspondant
aux opérations de copie de la plage de cellules B3 : E6 de la feuille de calcul
« Saisie ventes mensuelles » et de collage spécial en B3 de la feuille « Cumul
annuel ».
3. Créer un bouton « Cumuler les ventes » dans la feuille de calcul « Saisie
ventes mensuelles » associé à la macro-commande créée.
4. Créer une macro-commande dans la feuille de calcul « Cumul annuel »
permettant d’ouvrir, à partir d’un bouton nommé « Graphique CA cumulé par
vendeur », le graphique d’analyse du CA mensuel par vendeur. Pour la
réalisation du graphique, les plages de cellules B2 : E2 et B7 :E7 doivent être
sélectionnées simultanément.

158
16. Le tableur et ses fonctions avancées © Nathan
17
5. Tester la solution en générant le cumul des ventes en février. Repartir des
ventes cumulées en janvier données dans le tableau ci-dessous et mettre à
jour la feuille de calcul « Cumul annuel » en cliquant sur le bouton « Cumuler
les ventes ».
Pour le corrigé de cette application, reportez-vous au fichier intitulé
« Chap_16_ex_2_base_clients_corr.xls » disponible sur le site
www.nathan.fr/expertise-comptable/

Application 3 • Analyse et implantation d’une solution


1. Après avoir rédigé les formules de calcul, implanter ces dernières dans le
tableau de détermination des dépréciations des titres pour N-1 (fichier :
Chap_16_ex_3_base_clients.xls).

2. Créer la feuille de calcul « N » et saisir les valeurs relatives à chacun des


exercices pour tester la solution.
3. Créer la macro-commande « Fond_vert » permettant d’obtenir, par
Ctrl+Maj+V, les cellules sélectionnées avec un fond vert ainsi que les
boutons « Exercice N-1 » et « Exercices N » permettant l’exécution de macro-
commandes faisant passer d’une feuille à une autre dans le classeur « Suivi
dépréciations titres.xls ».
Pour créer la macro-commande d’ouverture de la feuille N dans la feuille de
calcul N-1 :
– cliquer sur « Macro/Nouvelle macro » dans le menu « Outils » (Excel 2003) ou
« Macro/Enregistrer une nouvelle macro » dans l’onglet « Affichage » (Excel 2007)
et nommer la macro « Exercice N » ;
– enregistrer la macro dans ce classeur ;
– cliquer sur l’onglet N ;

159
16. Le tableur et ses fonctions avancées © Nathan
17
– cliquer sur le bouton pour arrêter l’enregistrement de la macro ;
– créer dans la feuille « N-1 » un bouton associé à la macro « Exercice N » ;
Pour créer la macro-commande d’ouverture de la feuille N-1 dans la feuille de
calcul N :
– cliquer sur Outils/Macros/Nouvelle macro et nommer la macro « Exercice N-1 » ;
– enregistrer la macro dans ce classeur ;
– cliquer sur l’onglet N-1 ;
– cliquer sur le bouton pour arrêter l’enregistrement de la macro ;
– créer dans la feuille « N » un bouton associé à la macro « Exercice N ».
4. Réaliser pour les titres A une simulation du montant des dépréciations,
des dotations et des reprises au 31/12/N avec un cours variant de 25 à 30 €en
utilisant le gestionnaire de scénarios.
Pour le corrigé, reportez-vous au fichier intitulé :
« Chap_16_ex_3_base_clients_corr.xls » disponible sur le site
www.nathan.fr/expertise-comptable/, ainsi que ci-après.
Synthèse de scénarios
Valeurs Titres A : Titres Titres Titres Titres Titres
actuelles : 25 € A : 26 € A : 27 € A : 28 € A : 29 € A : 30 €
Cellules
variables :
Cours 28,00 € 25,00 € 26,00 € 27,00 € 28,00 € 29,00 € 30,00 €
Cellules
résultantes :
Dépréciation 0,00 € 1 197,50 € 697,50 € 197,50 € 0,00 € 0,00 € 0,00 €
Dotation 1 000,00 € 500,00 €
Reprise 197,50 € 197,50 € 197,50 € 197,50 €

5. Déterminer, à l’aide de la commande valeur cible, le cours au 31/12/N que


les titres B auraient dû atteindre afin que la dépréciation soit nulle.

La commande valeur cible revoit le cours de 101,36 €.

160
16. Le tableur et ses fonctions avancées © Nathan
17
Application 4 • Analyse et implantation d’une solution
1. Rédiger les formules de calcul à implanter dans la feuille de calcul
« Modèle ».
Adresse(s) Formule de calcul
F7:F19 =D7*E7
Recopier vers le bas jusqu’en F19
G7:G19 =SI(E7/C7=1;0;SI(E7/C7>=0,9;1;SI(E7/C7>=0;2;"Niveau inconnu")))
Recopier vers le bas jusqu’en G19
F20 =SOMME(F7:F19)
B23 =ARRONDI(F5*F20;0)
B24 =SOMME(B22:B23)
G27:G29 =SOMME.SI(G$7:G$19;0;F$7:F$19)/F$20
Recopier vers le bas jusqu’en G29
G30 =SOMME(G27:G29)
D31 =F20*G27*0,02-F20*G29*0,01

2. Implanter les formules de calcul.


3. Copier la feuille « Modèle » dans le même dossier, dans une feuille
nommée « Primard Franck ». Saisir les valeurs correspondant à ce délégué
afin de vérifier la solution proposée.
Pour le corrigé des questions 1, 2, et 3 de cette application, reportez-vous au
fichier intitulé « Chap_16_ex_4_base_clients_corr.xls » disponible sur le site
www.nathan.fr/expertise-comptable/
4. Créer un bouton « Retour au modèle » affecté à une macro-commande
permettant de revenir au modèle à partir des différentes feuilles contenues
dans le dossier de suivi des rémunérations des délégués.

Application 5 • Analyse et implantation d’une solution


1. Présenter les formules de calcul des cellules suivantes : G4, D23, C27,
D27, D31, D33, D35. (Remarque : les cellules G4 et D27 doivent pouvoir être
recopiées vers le bas.)
Adresse(s) Signification Formule de calcul
G4 Test sur Age artisan =SI((B$1-E4)<=35;1;"")
D23 Nombre d’artisans connectés =SOMME(D20:D22)
C27 Nombre d’inscription Internet aux formations =NB.SI(C4:C15;"oui")
D27 % d’inscription aux formations par Internet =C27/C$29
D31 Temps moyen de connexion par page =SOMME(D4:D15)/SOMME(F4:F15)

161
16. Le tableur et ses fonctions avancées © Nathan
17
Adresse(s) Signification Formule de calcul
D33 Nombre d’artisans ayant consulté plus de 6 =NB.SI(F4:F15;">6")
pages
D35 Nombre total de pages consultées par les =SOMME.SI(I4:I15;"1";F4:F15)
artisans de plus de 45 ans

2. Implanter les formules de calcul dans la feuille « Modèle » du fichier :


« Chap_16_ex_5_base_clients.xls ».
Pour le corrigé des questions 1 et 2 de cette application, reportez-vous au fichier
intitulé « Chap_16_ex_5_base_clients_corr.xls » disponible sur le site
www.nathan.fr/expertise-comptable/
3. Copier la feuille « Modèle » dans le même dossier, dans une feuille
nommée « Analyse 09-N ». Saisir les valeurs correspondant au mois de
septembre N afin de vérifier la solution proposée.

4. Créer une macro permettant d’affecter, une ligne sur deux, un fond jaune
aux cellules des lignes 4 à 15.
Sub Fond_jaune()
’ Fond_jaune Macro
’ Touche de raccourci du clavier: Ctrl+Maj+J
’ positionnement sur la première cellule de la première ligne du tableau
Range("debut_tableau").Select
’ boucle effectuée tant que la cellule active n’est pas vide
Do While ActiveCell.Value <> ""
’ colorie la plage comprise entre
’ la cellule active (activecell.address) et
’ la cellule située sur la même ligne,
’ 8 cellules plus loin à droite par rapport à la cellule active
’ activecell.(offset(0, 8).address
Range(ActiveCell.Address & ":" & ActiveCell.Offset(0,
8).Address).Interior.ColorIndex = 36
’ déplacement de deux lignes vers le bas
’ (puisqu’on ne doit colorier qu’une ligne sur deux)
ActiveCell.Offset(2, 0).Select
Loop
’ on est sorti de la boucle puisque la cellule active est vide (colonne A)
’ fin
End Sub

162
16. Le tableur et ses fonctions avancées © Nathan
17
5. Présenter l’algorithme permettant de définir la valeur en cellule H4 sachant
que l’année en cours est fournie par la fonction ANENCOURS(), que l’année
de naissance sera saisie dans une variable de type Entier nommée ANNAIS
et qu’une variable ÂGE de type Entier pourra être utilisée pour mémoriser le
résultat du calcul de l’âge.
Algorithme : affectation d’une valeur en H4
LEXIQUE
ANNAIS Entier {Année de naissance de l’artisan}
ÂGE Entier {Âge de l’artisan}
DEBUT
SAISIR ANNAIS
ÂGE  ANENCOURS() – ANNAIS
SI ÂGE > 35
ALORS SI ÂGE <= 45
ALORS H4  1
SINON ""
FINSI
SINON ""
FINSI
FIN

Application 6 • Analyse et implantation d’une solution


1. Écrire l’algorithme permettant le calcul de la commission « objectif » pour
un vendeur.
Algorithme : calcul de la commission « objectif » pour un vendeur
LEXIQUE
QtéObjectif Entier {Quantité objectif du vendeur}
NbreVéhVendu Entier {Nombre de véhicules vendus par vendeur}
ComObjectif Réel {Commission objectif du vendeur}
DEBUT
ComObjectif  0,00
SAISIR QtéObjectif, NbreVéhVendu
SI NbreVéhVendu > (QtéObjectif + 5)
ALORS ComObjectif  (NbreVéhVendu – QtéObjectif) * 200,00 + (5 *
100,00)
SINON SI NbreVéhVendu >= QtéObjectif
ALORS ComObjectif  (NbreVéhVendu – QtéObjectif ) * 100
SINON ComObjectif  0,00
FINSI
FINSI
FIN

163
16. Le tableur et ses fonctions avancées © Nathan
17
2. Présenter les formules de calcul des cellules suivantes : F15:F26,
G15:G26, C7, C9, C11. (Remarque : les cellules F15 et G15 doivent pouvoir
être recopiées vers le bas et doivent éviter les messages d’erreur.)
Adresse(s) Signification Formule de calcul
e
F15 2 =SI(ESTVIDE(A15);"";SI(C15>6;$G$11*E15;SI(C15>3;$G$10*E15;$G$9*
commission E15)))
G15 3e =SI(ESTVIDE(A15);"";SI(E15>D15*1,1;(E15-D15)*0,05;0))
commission
C7 Nombre de =NBVAL(B15:B26)
véhicules
vendus
C9 Total 2e =SOMME(F15:F26)
commission
C11 Salaire brut =SOMME(C8:C10)+G3

3. Implanter les formules de calcul dans la feuille « Modèle » du fichier


« Chap_16_ex_6_base_clients.xls ». Copier la feuille « Modèle » dans le
même dossier, dans une feuille nommée « Payet JP 01-N ». Saisir les valeurs
correspondant au mois de janvier N afin de contrôler la solution proposée.
Pour le corrigé de la question 3 de cette application, reportez-vous au fichier
intitulé « Chap_16_ex_6_base_clients_corr.xls » disponible sur le site
www.nathan.fr/expertise-comptable/

Application 7 • Implantation d’une solution d’optimisation


sous contrainte
1. Déterminer la production optimale permettant de maximiser la marge sur
coût variable totale.
A B C D E F
Produit Produit Produit
1 Temps/quantité produite Temps maximal
X Y Z
2 Atelier Découpe 1,00 2,50 4,00 500,00 500,00
3 Atelier Assemblage 2,00 3,00 1,00 800,00 800,00
4 Quantité produite 250,00 100,00 -
5 Marché potentiel 250,00 150,00 100,00
6 MSCV unitaire 10,00 20,00 30,00
7 MSCV totale 4 500,00
Les résultats seront obtenus en utilisant le solveur en saisissant les
caractéristiques suivantes :
Objectif à définir : $B$7

164
16. Le tableur et ses fonctions avancées © Nathan
17
Cellules variables : $B$4 : $D$4
Contraintes :
$B$4<=$B$5
$C$4<=$C$5
$D$4<=$D$5
$E$2<=$F$2
$E$3<=$F$3
B4>=0
C4>=0
D4>=0
2. Déterminer la production optimale permettant de maximiser la marge sur
coût variable totale après remplacement des machines. Conclure.
Après avoir copié la feuille de calcul ayant permis de répondre à la question 1,
modifier les valeurs saisies dans les plages de cellules B2 à D3 et F2 à F3, les
résultats obtenus sont les suivants :

A B C D E F
1 Produit Produit Produit
Temps/quantité produite Temps maximal
X Y Z
2 Atelier Découpe 1,00 2,00 3,00 750,00 750,00
3 Atelier Assemblage 1,50 2,50 1,00 816,67 1 000,00
4 Quantité produite 250,00 150,00 66,67
5 Marché potentiel 250,00 150,00 100,00
6 MSCV unitaire 12,50 25,00 35,00
7 MSCV totale 9 208,33

Les quantités optimales doivent être arrondies aux valeurs suivantes :


– 250 produits X ;
– 150 produits Y ;
– 66 produits Z.
La marge sur coût variable totale est alors de 9 185 €. Elle est supérieure à celle
obtenue avec les capacités de production des anciennes machines, ce qui plaide
en faveur de l'investissement.

165
16. Le tableur et ses fonctions avancées © Nathan
17

Entraînement à l’examen
Dossier 1 – Étude des données
1. Placer la propriété DuréeBudgétée sur l’annexe 4.
La propriété DuréeBudgétée est une propriété portée de BUDGETER étant donné
que c’est une propriété en dépendance fonctionnelle du couple de valeur
(#CodeClient, #CodeTâche).
2. Compléter les cardinalités manquantes sur l’annexe 4.
Voir réponse en question 3.
3. Compléter le schéma conceptuel des données afin de prendre en compte
le fait qu’une personne du cabinet est responsable d’un dossier client
(annexe 4).

4. Un dossier technique peut-il comporter plusieurs missions-types ?


Oui, un dossier technique correspond à un dossier-type (cardinalité 1, 1 entre
DOSSIER TECHNIQUE et CORRESPONDRE), qui peut être composé de
plusieurs missions-types (cardinalité maximale n entre DOSSIER-TYPE et
COMPOSER).
5. Un dossier client peut-il être concerné par plusieurs dossiers-types ?
Oui, un dossier client peut être concerné par plusieurs dossiers techniques
(cardinalité maximale n entre DOSSIER CLIENT et CONCERNER) correspondant
chacun à un dossier-type (cardinalité 1, 1 entre DOSSIER TECHNIQUE et
CORRESPONDRE).

166
16. Le tableur et ses fonctions avancées © Nathan
17
6. Les données présentes dans le schéma conceptuel des données
(annexe 4) permettront-elles de réaliser la facturation au client ?
Non, les montants n’étant pas mémorisés, on ne pourra pas réaliser la facturation
au client.
7. Dans le schéma relationnel correspondant au schéma conceptuel des
données, retrouvera-t-on la clé étrangère #CodeClient dans la relation
DOSSIER TECHNIQUE ?
Oui, la clé étrangère #CodeClient sera dans la relation DOSSIER TECHNIQUE
afin de faire le lien avec la clé primaire CodeClient de la relation DOSSIER
CLIENT.
En effet, l’association hiérarchique CONCERNER disparait lors de la rédaction du
schéma relationnel. L’identifiant de l’entité ayant les cardinalités 1,n, c’est-à-dire
CodeClient de l’entité DOSSIER CLIENT, est incorporé dans la relation née de
l’entité ayant les cardinalités 1,1, c’est-à-dire l’entité DOSSIER TECHNIQUE.

Dossier 2 – Algorithme et simulation par tableur


1. Rédiger l’algorithme permettant de calculer le montant HT des honoraires
pour un client donné et d’afficher le montant HT des honoraires des tâches
principales et complémentaires ainsi que le montant HT total des honoraires.
Algorithme Détermination du montant des honoraires
LEXIQUE
CodeTâcheP Chaîne {Code de la tâche principale ou FIN}
Effectif Entier {Effectif de l’entreprise}
DuréeBudgétée Réel {Durée de la tâche principale}
CtUnitBaseTâcheP Réel {Coût unitaire de base de la tâche principale}
CtUnitFactTâcheP Réel {Coût unitaire facturé de la tâche principale}
CoefTech Réel {Coefficient de technicité de la tâche principale}
MontantTâcheP Réel {Montant total des honoraires des tâches
principales}
LibelléTâcheC Chaîne {Libellé de la tâche complémentaire ou FIN}
ForfTâcheC Réel {Montant forfaitaire de la tâche
complémentaire}
MontantTâcheC Réel {Montant total des honoraires des tâches
complémentaires}
MontantTotal Réel {Montant total des honoraires}

167
16. Le tableur et ses fonctions avancées © Nathan
17

DEBUT
AFFICHER "Entrer le code de la tâche principale"
SAISIR CodeTâcheP
AFFICHER "Entrer l’effectif de l’entreprise"
SAISIR Effectif
CoefTech  0,00
SI Effectif < 10
ALORS CoefTech  1,00
SINON SI Effectif < 50
ALORS CoefTech  1,40
SINON SI Effectif < 100
ALORS CoefTech  1,80
SINON CoefTech  2,50
FINSI
FINSI
FINSI
MontantTâcheP  0,00
MontantTâcheC  0,00
MontantTotal  0,00
TANT QUE CodeTâcheP <> « FIN »
AFFICHER "Entrer la durée de la tâche principale"
SAISIR DuréeBudgétée
AFFICHER "Entrer le coût unitaire de base de la tâche principale"
SAISIR CtUnitBaseTâcheP
SI DuréeBudgétée > 20,00
ALORS CtUnitFactTâcheP  CtUnitBaseTâcheP X 0,9
SINON CtUnitFactTâcheP  CtUnitBaseTâcheP
FINSI
MontantTâcheP  MontantTâcheP + (DuréeBudgétée X CtUnitFactTâcheP X
CoefTech)
AFFICHER "Entrer le code de la tâche principale"
SAISIR CodeTâcheP
FIN TANT QUE
AFFICHER "Entrer le libellé de la tâche complémentaire"
SAISIR LibelléTâcheC
TANT QUE LibelléTâcheC <> « FIN »
AFFICHER "Entrer le montant forfaitaire de la tâche complémentaire"
SAISIR ForfTâcheC
MontantTâcheC  MontantTâcheC + ForfTâcheC
AFFICHER "Entrer le libellé de la tâche complémentaire"

168
16. Le tableur et ses fonctions avancées © Nathan
17
SAISIR LibelléTâcheC
FIN TANT QUE
MontantTotal  MontantTâcheP + MontantTâcheC
AFFICHER "Le montant des honoraires des tâches principales sont de : "
MontantTâcheP " €, celui des tâches complémentaires de : " MontantTâcheC " €,
soit un total des honoraires de : " MontantTotal " € "
FIN
2. Donner les formules de calcul des cellules C5, D9 à D14, E9 à E14, E15.
Adresse(s) Signification Formule de calcul
C5 Coefficient de =SI(ESTVIDE(C4);"";RECHERCHEV(C4;A28:B31;2))
technicité
D9 à D14 Coût unitaire facturé =SI(ESTVIDE(A9);"";SI(B9>20;C9*0,9;C9))
Recopier vers le bas jusqu’en D14
E9 à E14 Montant HT =SI(OU(ESTVIDE(A9);ESTVIDE(C$4));"";C$5*B9*D9)
Recopier vers le bas jusqu’en E14
E15 Montant des honoraires =SOMME(E9:E14)
– sous-total 1

3. Si le taux de TVA change, quelles cellules devront être modifiées ?


Il faudra modifier la cellule E24.
Que faudrait-il changer dans la maquette pour ne pas avoir à modifier la
formule de calcul du montant de la TVA lors d’un changement de taux ?
Il faudrait insérer un nom TxTVA auquel la valeur du taux normal de TVA serait
rattachée dans la zone « Faire référence à ».

169
16. Le tableur et ses fonctions avancées © Nathan